Installazione e Amministrazione di SOLIDWORKS

Questa guida descrive l'installazione, la gestione delle licenze, l'aggiornamento e l'amministrazione dei prodotti SOLIDWORKS per installazioni singole e multiple.

Installazioni individuali | Funzionamento delle installazioni multiple
Installazione Installazione su uno o alcuni computer. | Installazione Creazione di un'immagine amministrativa distribuita su un numero di computer client.
Licenza Attivazione della macchina o licenze in rete. | Licenza Attivazione della macchina o licenze in rete.
Aggiornamenti Migrazione di singoli computer a una nuova release. | Aggiornamenti Spostamento di più computer a una nuova release aggiornando l'immagine amministrativa utilizzata per l'installazione su tali computer.
Amministrazione Modifica, riparazione e rimozione delle installazioni tramite l'aggiornamento a nuove release. | Amministrazione Aggiornamento immagini amministrative e clienti, amministrazione licenze di rete.

Gestione installazioni di SOLIDWORKS consente di configurare le impostazioni dei componenti dei prodotti SOLIDWORKS, inclusi SOLIDWORKS, SOLIDWORKS Toolbox, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS Visualize e SOLIDWORKS SolidNetWork License Manager.

SolidNetWork License Manager supporta più client di licenza mediante la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.

Indice

  • Installazione individuale o Immagine amministrativa

    I prodotti SOLIDWORKS devono essere installati singolarmente in ogni computer o è necessario creare un'immagine amministrativa e distribuire l'installazione a tutti i client con un singolo comando?

  • Controllo dei requisiti di sistema e software

    Prima dell'installazione, verificare che il sistema soddisfi i requisiti hardware, del sistema operativo e dei prodotti Microsoft. Le aggiunte, come SOLIDWORKS Electrical, SOLIDWORKS Visualize ed eDrawings, hanno requisiti aggiuntivi specifici.

  • Download del supporto di installazione

    Tutti i supporti di installazione sono disponibili nella pagina dei download del sito SOLIDWORKS.

  • Installazione delle app 3DEXPERIENCE

    Se si gestiscono i dati utilizzando 3DEXPERIENCE Platform, è possibile acquistare il ruolo di Collaborative Designer for SOLIDWORKS per connettere l'ambiente desktop alla piattaforma.


Installazione individuale o Immagine amministrativa

I prodotti SOLIDWORKS devono essere installati singolarmente in ogni computer o è necessario creare un'immagine amministrativa e distribuire l'installazione a tutti i client con un singolo comando?

Se si effettua l'installazione solo su un computer o si gestiscono dozzine o centinaia di computer, la scelta è ovvia. Per le altre situazioni, considerare quanto segue.

Installazione individuale | Immagine amministrativa
Gli utenti possono amministrare SOLIDWORKS autonomamente. | L'amministratore di sistema può personalizzare installazioni multiple usando l'Editor opzioni, specificando le opzioni di installazione come la creazione di una nuova installazione o aggiornandone una esistente, eseguendo l'installazione come utente amministrativo, eseguendo comandi esterni prima o dopo l'installazione, raggruppamenti di prodotti diversi e così via.
I computer devono essere fisicamente accessibili alla persona che effettua l'installazione. | I computer client possono essere distanti ma devono essere accessibili dalla stessa rete.
Si possono installare versioni diverse, Service Pack o prodotti su computer diversi con impostazioni indipendenti. | Usando l'Editor opzioni, le immagini amministrative possono mantenere la coerenza nelle versioni, service pack, prodotti ed impostazioni per installazioni multiple.
I computer devono disporre dell'accesso alla rete o all'email. È necessaria una connessione di rete o email per attivare SOLIDWORKS ed eseguire il download dei file. L'accesso alla rete è anche richiesto per la raccolta delle licenze da un server di licenza di rete.

La connessione di rete locale è necessaria per distribuire l'applicazione; le unità dei supporti non sono necessarie sui computer client.

I client possono essere aggiornati automaticamente. Tutti i client implementati dalla stessa immagine amministrativa si trovano nello stesso service pack. Per mantenere versioni multiple, è possibile creare immagini amministrative multiple.

L'attivazione delle licenze può essere automatizzata.

Un'immagine amministrativa necessita di spazio addizionale su disco sul server; i client hanno bisogno dello stesso spazio per le installazioni individuali.

Argomento principale Installazione e Amministrazione di SOLIDWORKS
Controllo dei requisiti di sistema e software
Download del supporto di installazione
Installazione delle app 3DEXPERIENCE


Controllo dei requisiti di sistema e software

Prima dell'installazione, verificare che il sistema soddisfi i requisiti hardware, del sistema operativo e dei prodotti Microsoft. Le aggiunte, come SOLIDWORKS Electrical, SOLIDWORKS Visualize ed eDrawings, hanno requisiti aggiuntivi specifici.

Per garantire un'installazione ideale e una prestazione ottimale, vedere Requisiti del sistema.

Argomento principale Installazione e Amministrazione di SOLIDWORKS
Installazione individuale o Immagine amministrativa
Download del supporto di installazione
Installazione delle app 3DEXPERIENCE


Download del supporto di installazione

Tutti i supporti di installazione sono disponibili nella pagina dei download del sito SOLIDWORKS.

Se non è possibile accedere alla pagina dei download del sito SOLIDWORKS, contattare il proprio rivenditore VAR per ricevere i DVD.

Per scaricare i supporti di installazione:

  1. Accedere alla pagina dei download del sito SOLIDWORKS come cliente dei servizi in abbonamento, utilizzando il proprio indirizzo e-mail e password o il proprio numero di serie di SOLIDWORKS.
  2. Nella pagina Downloads (Download), selezionare l'anno per Select Version (Seleziona versione).
  3. Selezionare la scheda SOLIDWORKS per SOLIDWORKS products (Prodotti SOLIDWORKS).
  4. Nell'area Prodotto, selezionare un service pack.
    Per la release principale più recente, selezionare Prodotti SOLIDWORKS versione 0.0.
  5. Fare clic su Accetta accordo e continua per accettare i termini del contratto di licenza.
  6. Fare clic su Download (Scarica).
    Il browser web scarica SolidworksSetup.exe nella posizione predefinita C:\Users\Username\Downloads.
  7. Decomprimere SolidworksSetup.exe nella cartella Downloads.
    È anche possibile decomprimere il file SolidworksSetup.exe nella posizione desiderata.
  8. Eseguire setup.exe con autorizzazioni amministrative.
  9. In Gestione installazioni, fare clic su Scarica e condividi tutti i file.
    Creare singole installazioni o immagini amministrative su più computer con un singolo download, quindi seguire le istruzioni per completare il processo.

    Installation Manager scarica il supporto di installazione.

    Questa opzione è utile per:
    • Installare il software su un numero ridotto di computer
    • Eseguire il download tramite un'unità portatile o un'unità di rete
    • Installare Service Pack
    Per scaricare i file di installazione in maniera selettiva, seguire le istruzioni per selezionare il metodo di download manuale.
Argomento principale Installazione e Amministrazione di SOLIDWORKS
Installazione individuale o Immagine amministrativa
Controllo dei requisiti di sistema e software
Installazione delle app 3DEXPERIENCE


Installazione delle app 3DEXPERIENCE

Se si gestiscono i dati utilizzando 3DEXPERIENCE Platform, è possibile acquistare il ruolo di Collaborative Designer for SOLIDWORKS per connettere l'ambiente desktop alla piattaforma.

Questo ruolo fornisce l'accesso alle app 3DEXPERIENCE che consentono ai prodotti SOLIDWORKS Desktop di salvare, cercare e gestire i dati memorizzati sulla piattaforma. È inoltre possibile utilizzare l'app SOLIDWORKS Connected basata sul Web. Per i dettagli di installazione, vedere Installazione.

È possibile installare e ottenere la licenza delle app da 3DEXPERIENCE Platform, ma non da Gestione installazioni SOLIDWORKS. Per istruzioni sull'installazione, nella Guida in linea di SOLIDWORKS, vedere Utilizzo di 3DEXPERIENCE Platform e delle app 3DEXPERIENCE > Installazione delle app 3DEXPERIENCE.

Argomento principale Installazione e Amministrazione di SOLIDWORKS
Installazione individuale o Immagine amministrativa
Controllo dei requisiti di sistema e software
Download del supporto di installazione
https://help.solidworks.com


Installazioni individuali

Indice

  • Installazione su singoli computer

    Per installare SOLIDWORKS in un singolo computer, sono disponibili vari metodi.

  • Amministrazione delle installazioni individuali

    Solitamente, l'amministrazione di singole installazioni implica la modifica, la riparazione, la rimozione e l'aggiornamento delle installazioni.


Installazione su singoli computer

Per installare SOLIDWORKS in un singolo computer, sono disponibili vari metodi.

Gestione installazioni SOLIDWORKS esegue l'installazione adattandola ai prodotti acquistati. Prima di iniziare l'installazione:

  • Se si sta installando una licenza standalone di SOLIDWORKS, avere a disposizione i numeri di serie di SOLIDWORKS.
  • Verificare che la connessione internet sia operativa. La connessione è richiesta per la verifica dei diritti.
  • Creare un ID 3DEXPERIENCE. Per ulteriori informazioni sulla creazione di ID 3DEXPERIENCE vedere https://www.3ds.com/support.
  • L'utente deve verificare di essere l'amministratore designato per l'account o che l'amministratore lo abbia indicato come contatto.

Gestione installazioni SOLIDWORKS installa vari componenti Microsoft, tra cui Microsoft Visual Studio Tools for Applications, Visual Basic e .NET Framework. Se non sono installate le versioni corrette di tutti componenti Microsoft richiesti, Gestione installazioni SOLIDWORKS li installa automaticamente prima di procedere con l'installazione dei prodotti SOLIDWORKS.

SOLIDWORKS Chromium Embedded Framework (CEF) è un altro componente installato da Gestione installazioni SOLIDWORKS. Il suo scopo è mostrare i contenuti per le app SOLIDWORKS e 3DEXPERIENCE Platform.

SOLIDWORKS Login Manager viene installato anche dalla Gestione installazioni di SOLIDWORKS. Consente di accedere a 3DEXPERIENCE Marketplace e alle app 3DEXPERIENCE.

Metodo d'installazione Sintesi della procedura
Download dalla pagina dei download di SOLIDWORKS

Tutti i supporti di installazione sono disponibili nella pagina dei download del sito SOLIDWORKS.

  1. Accedere alla pagina dei download del sito SOLIDWORKS.
  2. Accedere con l'ID 3DEXPERIENCE.
  3. Nella pagina Downloads (Download), selezionare l'anno per Select Version (Seleziona versione).
  4. Selezionare la scheda SOLIDWORKS per Prodotti SOLIDWORKS e selezionare un Service Pack sotto Prodotto.
  5. Fare clic su Accetta accordo e continua per accettare i termini del contratto di licenza.
  6. Fare clic su Download (Scarica).
È necessario disporre di una connessione Internet funzionante con accesso alla pagina dei download.

Se non si riesce ad accedere alla pagina dei download, contattare il proprio rivenditore VAR per ricevere i supporti di installazione.
Uso di una directory di download su un server Nella directory di download, fare doppio clic su setup.exe.

Tale directory deve essere accessibile dal computer in cui si installano i prodotti SOLIDWORKS e deve contenere tutti i file di installazione di SOLIDWORKS prima di avviare la procedura. Gestione installazioni SOLIDWORKS riesce anche a individuare i file mancanti se il computer dispone di accesso Internet e diritti di scrittura per la directory di download.
Aggiornamento di un'installazione di SOLIDWORKS esistente tramite Verifica aggiornamenti Scegliere una delle seguenti opzioni:
  • In SOLIDWORKS, fare clic su [image] > Verifica aggiornamenti.
  • In Windows, fare clic su Start > Gestione installazioni di SOLIDWORKS > Verifica aggiornamenti.
È anche possibile fare clic su Start > Gestione installazioni SOLIDWORKS > SOLIDWORKS Background Downloader. Nell'area delle notifiche di Windows, fare clic con il pulsante destro del mouse su SOLIDWORKS Background Downloader e fare clic su Verifica aggiornamenti.
È necessaria una connessione a Internet e privilegi di amministratore sul computer.

Nella Gestione installazioni SOLIDWORKS, è anche possibile selezionare l'opzione Scarica e condividi tutti i file, incluso il software necessario come prerequisito. Questa opzione è utile se si installa il software su alcuni computer e si desidera copiare il download utilizzando un'unità portatile o un'unità di rete. Inoltre, è utile per installare i Service Pack poiché la versione completa e il Service Pack sono contenuti in un'unica installazione.

Al termine dell'installazione, avviare l'applicazione SOLIDWORKS e attivare la licenza.

Per visualizzare un elenco dei prodotti disponibili con licenza sul computer, dal menu principale di SOLIDWORKS -
  • Fare clic su [image] > I miei prodotti
  • Fare clic su Home nel Task Pane Risorse SOLIDWORKS > I miei prodotti
  • Fare clic Start > Strumenti SOLIDWORKS Versione > I miei prodotti.

I segni di spunta nella finestra di dialogo indicano i prodotti che l'utente o l'azienda possiede in base alla propria attivazione e alle licenze di rete. Inoltre è possibile approfondire la conoscenza dei prodotti SOLIDWORKS facendo clic sul collegamento nella parte superiore di ogni categoria di prodotti.

Se si dispone di una licenza SOLIDWORKS, per vedere quali licenze sono in uso, in Windows, fare clic su Start > Strumenti SOLIDWORKS <versione> > SolidNetWork License Manager Client > Uso della licenza.

Argomento principale Installazioni individuali
Amministrazione delle installazioni individuali


Amministrazione delle installazioni individuali

Solitamente, l'amministrazione di singole installazioni implica la modifica, la riparazione, la rimozione e l'aggiornamento delle installazioni.

Indice

  • Modifica di un'installazione

    È possibile modificare un'installazione per installare prodotti che non sono stati installati in precedenza o per rimuovere prodotti, purché l'installazione precedente sia stata eseguita con un gruppo completo di file di installazione. Questa opzione non è disponibile se l'installazione precedente è stata aggiornata con un Service Pack.

  • Riparazione di un'installazione

    In caso di problemi con un prodotto SOLIDWORKS installato, usare Gestione installazioni SOLIDWORKS per ripristinare l'installazione.

  • Ripristino di un'installazione individuale ad un Service Pack precedente

  • Rimozione di un'installazione

    Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.

  • Aggiornamento a una nuova release

    Esistono sono vari metodi per aggiornare una singola installazione a una nuova release di SOLIDWORKS.

  • Regole di coesistenza del prodotto

    Le seguenti regole di coesistenza del prodotto determinano il modo in cui i nuovi prodotti vengono installati e quelli esistenti aggiornati.

Argomento principale Installazioni individuali
Installazione su singoli computer


Modifica di un'installazione

È possibile modificare un'installazione per installare prodotti che non sono stati installati in precedenza o per rimuovere prodotti, purché l'installazione precedente sia stata eseguita con un gruppo completo di file di installazione. Questa opzione non è disponibile se l'installazione precedente è stata aggiornata con un Service Pack.

Se si installa SOLIDWORKS e in seguito si acquista un'aggiunta, è possibile modificare l'installazione per includere la nuova aggiunta. È necessario installare l'aggiunta in ogni singolo computer.

  1. Verificare che non siano presenti sessioni di SOLIDWORKS attive.
  2. In Windows, selezionare Impostazioni > Applicazioni > Applicazioni installate.
  3. Selezionare l'installazione di SOLIDWORKS da modificare e fare clic su Cambia.
  4. Nella schermata Benvenuti in Gestione installazioni SOLIDWORKS, fare clic su Modificare l'installazione.
  5. Nella schermata Numero seriale, verificare che siano indicati i numeri di seriali appropriati.
  6. Nella schermata Selezione del prodotto, selezionare i prodotti da installare o rimuovere.
    Quando si modifica un'installazione:
    • Nessun prodotto viene installato o rimosso di default, anche Se si specifica un nuovo numero seriale. Cambiare l'azione dell'installazione di ogni componente di prodotto o funzione.
    • Per visualizzare l'azione prevista di un componente specifico, fare clic sul nome del componente (ma non sulla sua casella di controllo). L'azione prevista appare nel campo delle informazioni sotto l'elenco dei prodotti.
    • Per cambiare l'azione di installazione per un componente del prodotto, fare clic sulla casella di controllo relativa al componente stesso. (Ad esempio, se si sta installando o rimuovendo componenti, selezionando la casella di controllo si specifica che il componente deve essere installato o rimosso e deselezionandola si specifica che il componente non deve essere installato o rimosso).
    • Quando si modifica l'azione di installazione specificata inizialmente per un componente, accanto a quest'ultimo viene visualizzato un asterisco (*).
    • Se un componente dispone di sottocomponenti da installare in modo opzionale, accanto al componente viene visualizzata l'icona [image] . Per visualizzare i sottocomponenti disponibili per un componente, fare clic sull'icona [image].
    • Quando si espande un componente per visualizzare i sottocomponenti opzionali, accanto al componente viene visualizzata l'icona [image]. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona [image] .
  7. Nella schermata Sintesi, fare clic su Modifica ora.
  8. Nella schermata Installazione completata, fare clic su Fine.
Argomento principale Amministrazione delle installazioni individuali
Riparazione di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Rimozione di un'installazione
Aggiornamento a una nuova release
Regole di coesistenza del prodotto


Riparazione di un'installazione

In caso di problemi con un prodotto SOLIDWORKS installato, usare Gestione installazioni SOLIDWORKS per ripristinare l'installazione.

Per correggere un'installazione, il computer deve contenere tutti i file di origine dell'installazione precedente e tutti i service pack applicati. Questi devono trovarsi nella posizione in cui sono stati originariamente installati.

Un'installazione individuale può essere riparata. Non è possibile riparare un'immagine amministrativa; disinstallare e quindi installare nuovamente l'immagine amministrativa.
  1. Aprire il Pannello di controllo di Windows e fare clic su Programmi > Programmi e funzionalità.
  2. Fare clic con il pulsante destro del mouse sulla versione di SOLIDWORKS da correggere e fare clic su Cambia.
  3. Nella schermata Benvenuti in Gestione installazioni SOLIDWORKS, fare clic su Correggere l'installazione e fare clic su Avanti.
  4. In Prodotti da riparare selezionare il prodotto desiderato.
  5. Deselezionare il resto dei prodotti.
  6. Fare clic su Ripara.
Argomento principale Amministrazione delle installazioni individuali
Argomento principale Errori di installazione / Installazione annullata
Modifica di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Rimozione di un'installazione
Aggiornamento a una nuova release
Regole di coesistenza del prodotto
Ripristino da un'installazione non riuscita o annullata
Come contattare il rivenditore SOLIDWORKS


Ripristino di un'installazione individuale ad un Service Pack precedente

Per ripristinare una singola installazione a un Service Pack precedente all'interno della release principale corrente, disinstallare il Service Pack attualmente installato sul computer e reinstallarne la versione precedente.
Argomento principale Amministrazione delle installazioni individuali
Modifica di un'installazione
Riparazione di un'installazione
Rimozione di un'installazione
Aggiornamento a una nuova release
Regole di coesistenza del prodotto


Rimozione di un'installazione

Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.

  1. Verificare che non siano presenti sessioni di SOLIDWORKS attive.
  2. Se si desidera trasferire la licenza di SOLIDWORKS su un altro computer, disattivare la licenza prima di rimuovere l'installazione di SOLIDWORKS dal computer in uso.
    Per ulteriori informazioni, vedere Trasferimento di una licenza.
  3. Aprire il Pannello di controllo di Windows e fare clic su Programmi e funzionalità.
  4. Selezionare il componente del prodotto da rimuovere e fare clic su Disinstalla.
    In alcuni casi, potrebbero essere disponibili più Service Pack di SOLIDWORKS per una stessa release principale. Per rimuovere una release principale di SOLIDWORKS, rimuovere tutti gli elementi dei Service Pack per tale release.
  5. Nello schermo Disinstallare:
    1. Selezionare i prodotti da rimuovere.
      Di default, sono selezionati tutti i componenti di prodotto.
    2. Deselezionare i prodotti che non devono essere rimossi.
    3. Fare clic su Cambia in Opzioni avanzate.
      Si apre la schermata Opzioni avanzate e l'opzione File e cartelle del programma è selezionata.
    4. Selezionare una o più opzioni per effettuare una disinstallazione personalizzata o selezionare tutte le opzioni per effettuare una disinstallazione completa.
      Per impostazione predefinita, Gestione installazioni SOLIDWORKS esegue una disinstallazione completa e rimuove tutti i file e le cartelle aggiunti al momento dell'installazione.
    5. Fare clic su Torna alla Sintesi.
    6. Nella schermata Sintesi, espandere Opzioni avanzate per visualizzare il metodo di disinstallazione e le relative voci.
    7. Fare clic su Rimuovi elementi.
Argomento principale Amministrazione delle installazioni individuali
Argomento principale Amministrazione delle installazioni multiple
Modifica di un'installazione
Riparazione di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Aggiornamento a una nuova release
Regole di coesistenza del prodotto
Aggiornamento di immagini amministrative a una nuova release
Amministrazione aggiornamento del prodotto con Service Pack
Trasferimento di una licenza


Aggiornamento a una nuova release

Esistono sono vari metodi per aggiornare una singola installazione a una nuova release di SOLIDWORKS.

Si può aggiornare ad una nuova release:
  • Mediante la ricezione di nuovi supporti di installazione
  • Alla notifica della disponibilità di aggiornamenti all'avvio di SOLIDWORKS
  • Controllando manualmente la disponibilità di aggiornamenti
  • Avviando una nuova variante di Gestione installazioni SOLIDWORKS

Quando si installa una nuova release maggiore, è possibile aggiornare una release maggiore già installata oppure installare parallelamente la nuova release. Se si installa una release Service Pack da una release precedente installata, tale release viene aggiornata automaticamente.

Argomento principale Amministrazione delle installazioni individuali
Modifica di un'installazione
Riparazione di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Rimozione di un'installazione
Regole di coesistenza del prodotto

Verifica manuale degli aggiornamenti

Se si dispone dei privilegi dell'amministratore sul computer, è possibile utilizzare uno dei metodi seguenti per verificare la disponibilità di aggiornamenti per una release di SOLIDWORKS attualmente installata.

  • In SOLIDWORKS, fare clic su [image] > Verifica aggiornamenti.
  • In Windows, fare clic suStart > Gestione installazioni di SOLIDWORKS > Verifica aggiornamenti.
È anche possibile fare clic su Start > Gestione installazioni SOLIDWORKS > SOLIDWORKS Background Downloader. Nell'area delle notifiche di Windows, fare clic con il pulsante destro del mouse su SOLIDWORKS Background Downloader e fare clic su Verifica aggiornamenti.

Accorgimenti per l'aggiornamento

I prodotti che possono avere installazioni multiple con versioni diverse non supportano sempre gli aggiornamenti maggiori, o la capacità di aggiornare tra le versioni maggiori in una sola operazione.

In questo caso Gestione installazioni SOLIDWORKS simula l'aggiornamento installando prima la versione nuova, quindi rimuovendo quella precedente. Al momento, gli aggiornamenti principali sono supportati dal prodotto SOLIDWORKS di base, ma non dagli altri prodotti.

Le conseguenze di questa modalità sono:
  • Quando si aggiorna il prodotto SOLIDWORKS di base a una versione principale:
    • le ubicazioni esistenti installate non cambiano.
    • L'aggiornamento può essere riportato indietro se avviene un errore o un annullamento durante l'aggiornamento.
  • Quando gli altri prodotti vengono aggiornati tra le versioni maggiori:
    • ogni prodotto viene prima installato come prodotto nuovo in un punto nuovo, quindi l'installazione originale sarà rimossa.
    • Una volta iniziato, l'aggiornamento non può essere riportato indietro se avviene un errore o un annullamento durante l'aggiornamento.


Regole di coesistenza del prodotto

Le seguenti regole di coesistenza del prodotto determinano il modo in cui i nuovi prodotti vengono installati e quelli esistenti aggiornati.

Regola | Esempi
Sono consentite più versioni di release maggiori del prodotto principale SOLIDWORKS, ad eccezione dei prodotti indicati di seguito. | SOLIDWORKS 2024 SP3.0 e SOLIDWORKS 2025 SP0.0 possono coesistere sullo stesso computer.
Le Service Pack multiple dalla stessa versione principale non sono consentite. | SOLIDWORKS 2025 SP0.0 e 2025 SP1.0 non possono coesistere sullo stesso computer. Se si installa SOLIDWORKS 2025 SP1.0 su un computer su cui è già installato SOLIDWORKS 2025 SP0.0, la Gestione installazioni SOLIDWORKS sostituirà SP0.0 con SP1.0.
Solo una versione dei seguenti prodotti è consentita sul computer:
  • SolidNetWork License Manager
 Se SolidNetWork License Manager 2024 SP3.0 è installato, SolidNetWork License Manager viene aggiornato a 2025 SP0.0, anche se una release principale precedente di SOLIDWORKS rimane sul computer.
Solo una versione del seguente prodotto è consentita sul computer:
  • SOLIDWORKS Electrical
 Se si crea una nuova installazione di SOLIDWORKS Electrical 2025 SP1.0, la Gestione installazioni SOLIDWORKS rimuove automaticamente le versioni precedenti di SOLIDWORKS Electrical dal computer. Eseguire il backup dell'ambiente SOLIDWORKS Electrical prima di effettuare l'aggiornamento.
Solo una versione dei seguenti prodotti è consentita sul computer:
  • Client PDM di SOLIDWORKS
  • SOLIDWORKS PDM Server

Se si installa SOLIDWORKS 2025 SP0.0 o SP1.0, è necessario eseguire anche l'aggiornamento a SOLIDWORKS 2025 PDM Server e PDM Client.

Se si installa SOLIDWORKS 2025 PDM Server, si consiglia di utilizzare il processo di installazione di PDM Server per installare SOLIDWORKS PDM Client. Non installare SOLIDWORKS PDM Client separatamente con il processo di installazione client.

SOLIDWORKS PDM client deve essere la stessa versione e service pack di SOLIDWORKS PDM server sullo stesso computer.

Per ulteriori informazioni, vedere SOLIDWORKS PDM e SOLIDWORKS Manage.

Solo una versione di un prodotto compreso potrà essere installata per qualsiasi versione maggiore di SOLIDWORKS. Tuttavia, le versioni di prodotti da diverse versioni di SOLIDWORKS possono coesistere. | Se SOLIDWORKS 2025 SP0.0 viene aggiornato a 2025 SP1.0, SOLIDWORKS Composer 2025 SP0.0 viene aggiornato automaticamente a 2025 SP1.0. Tuttavia, SOLIDWORKS Composer 2024 SP4.0 può coesistere con SOLIDWORKS Composer 2025 SP0.0 o con SOLIDWORKS Composer 2025 SP1.0.
Argomento principale Amministrazione delle installazioni individuali
Modifica di un'installazione
Riparazione di un'installazione
Ripristino di un'installazione individuale ad un Service Pack precedente
Rimozione di un'installazione
Aggiornamento a una nuova release


Installazioni multiple

Indice

  • Distribuzione su più client

    Il prodotto SOLIDWORKS può essere installato su più client creando un'immagine amministrativa e distribuendo l'installazione sui client.

  • Uso di immagini amministrative

    Un'immagine amministrativa consente di creare installazioni configurabili dei prodotti SOLIDWORKS da un singolo percorso di rete.

  • Distribuzione dalla riga di comando

    È possibile distribuire automaticamente un'immagine amministrativa usando un prompt dei comandi o file batch (installazione invisibile).

  • Amministrazione delle installazioni multiple

    Per installazioni multiple, le operazioni amministrative comprendono l'aggiornamento delle immagini amministrative alle nuove release, l'aggiornamento dei prodotti tramite Service Pack e la rimozione delle installazioni.


Distribuzione su più client

Il prodotto SOLIDWORKS può essere installato su più client creando un'immagine amministrativa e distribuendo l'installazione sui client.

Segue la procedura per la distribuzione su più client:
  1. Creare un'immagine amministrativa.
    • Creazione di un'immagine amministrativa dalla Gestione installazioni SOLIDWORKS
  2. Distribuire l'immagine amministrativa ai clienti.
    • Distribuire un'immagine amministrativa ai client tramite il metodo manuale/pull (e-mail)
    • Distribuire un'immagine amministratore ai client tramite il metodo automatico/push
    • Installazione da un'immagine amministrativa mediante la riga di comando
  3. Implementare le licenze.
    • Amministrazione di licenze individuali
    • Amministrazione delle licenze mediante SolidNetWork License Manager
Argomento principale Installazioni multiple
Uso di immagini amministrative
Distribuzione dalla riga di comando
Amministrazione delle installazioni multiple


Uso di immagini amministrative

Un'immagine amministrativa consente di creare installazioni configurabili dei prodotti SOLIDWORKS da un singolo percorso di rete.

L'immagine amministrativa potrà essere installata da qualsiasi computer in rete, compreso il computer client.
  • L'immagine amministrativa deve essere in una cartella condivisa.
  • Se si includono tutti i prodotti, i requisiti di spazio disco dell'immagine amministrativa potrà essere 17GB o maggiore.
  • Se il nome di condivisione viene aggiornato con l'aggiornamento dell'immagine amministrativa, il client aggiornerà automaticamente all'avvio successivo dell'applicazione. Per i dettagli, vedere Aggiornamento di un'immagine amministrativa.
  • Quando si implementa un'immagine amministrativa, il suo percorso deve comportare meno di 58 caratteri.
  • Richiede ai client di possedere i privilegi amministrativi sui loro computer. Se non dispone di privilegi sufficienti, un client può eseguire un'installazione come un utente diverso. Questa opzione si rivela utile quando un singolo utente non dispone di permessi amministrativi locali sulla macchina (necessari per installare i prodotti SOLIDWORKS).

    Vedere Disposizione installazioni dall'editor delle opzioni. Illustra inoltre un metodo alternativo per installare le immagini quando un client non dispone di privilegi sufficienti.

  • Se è abilitata la funzionalità di registrazione di Windows o si utilizza la funzionalità di stato nell'Editor opzione immagine amministrativa, è necessario disporre delle autorizzazioni di lettura/scrittura per questa cartella: {Administrative image directory}\x64\Logs.

Una volta creata l'immagine amministrativa, è possibile utilizzare l'editor delle opzioni dell'immagine amministrativa per gestire le opzioni di installazione per gli utenti e i gruppi che eseguono l'installazione da tale immagine. Per i dettagli, vedere Editor opzioni immagine amministrativa.

Indice

  • Tipi di immagini amministrative

    È possibile utilizzare l'Editor opzione immagine amministrativa per creare diversi tipi di immagini per gli utenti remoti e per quelli sulla rete.

  • Creazione di un'immagine amministrativa dalla Gestione installazioni SOLIDWORKS

    Se si installa SOLIDWORKS su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.

  • Editor opzioni immagine amministrativa

    L'Editor opzioni immagine amministrativa consente di personalizzare le impostazioni di parametro d'installazione in un'immagine amministrativa per singoli computer e per gruppi di computer.

  • Strumento Amministratore impostazioni

Argomento principale Installazioni multiple
Distribuzione su più client
Distribuzione dalla riga di comando
Amministrazione delle installazioni multiple
Aggiornamento dei client dalle immagini amministrative


Tipi di immagini amministrative

È possibile utilizzare l'Editor opzione immagine amministrativa per creare diversi tipi di immagini per gli utenti remoti e per quelli sulla rete.

Tipo di immagine amministrativa Descrizione
Standard

Questa è l'immagine predefinita per tutte le nuove immagini amministrative.

Si tratta di un'immagine amministrativa standard di Windows Installer ideale per gli utenti che dispongono di un accesso affidabile alla rete aziendale. Memorizza tutti i file necessari per installare i prodotti SOLIDWORKS selezionati in una cartella di immagini condivise.

Quando gli utenti effettuano l'aggiornamento a un nuovo Service Pack, possono scaricare e applicare i file patch senza dover scaricare l'intera immagine.
Client remoto

Questa immagine è destinata agli utenti remoti che non dispongono di un accesso affidabile alla rete aziendale.

Quando si installa questo tipo di immagine, gli utenti remoti ereditano tutte le opzioni di installazione specificate, come il numero di serie e i prodotti da installare.

Gli utenti possono scaricare i file richiesti da Internet dalla Pagina dei download SOLIDWORKS. L'accesso e l'installazione di questi file da Internet sono più affidabili rispetto alle reti aziendali e possono ridurre il carico sulle reti stesse.

Gli utenti remoti installano questa immagine utilizzando le stesse tecniche supportate dall'immagine amministrativa standard. È comunque possibile eseguire lo script delle installazioni utilizzando i file sldim.exe e startwinstall.exe.

I file di installazione vengono scaricati in un percorso specificato nell'Editor opzione immagine amministrativa prima dell'installazione. Gli utenti devono accedere alla cartella dell'immagine amministrativa per avviare l'installazione ed eseguire eventuali batch o file delle impostazioni lì presenti.

Gli utenti remoti devono disporre di spazio su disco sufficiente per memorizzare tutti i file nell'immagine, sebbene gli utenti possano eliminare l'immagine al termine dell'installazione.
Compressa

L'immagine amministrativa compressa è destinata alle organizzazioni che devono copiare immagini amministrative su più siti o computer client e che desiderano ridurre al minimo l'impatto sulla rete.

Questa immagine è più piccola del 60% rispetto a un'immagine amministrativa standard, ma viene installata nella stessa quantità di tempo. Supporta tutte le operazioni di installazione, come la modifica e la riparazione.

Anche le immagini amministrative compresse hanno percorsi file brevi. In questo modo si evitano problemi quando le immagini vengono memorizzate in strutture di cartelle profonde.

Quando gli utenti effettuano l'aggiornamento a un nuovo Service Pack, devono scaricare l'intera immagine, non solo le patch.
Argomento principale Uso di immagini amministrative


Creazione di un'immagine amministrativa dalla Gestione installazioni SOLIDWORKS

Se si installa SOLIDWORKS su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.

  1. Avviare Gestione installazioni SOLIDWORKS.

    Vedere Download del supporto di installazione.

  2. Nella schermata di Benvenuto, selezionare Creare un'immagine amministrativa da distribuire in più computer e selezionare una delle seguenti opzioni:
    Opzione | Descrizione
    Creare una nuova immagine usando le impostazioni di default. | Creare l'immagine usando le impostazioni di configurazione di default (cioè non basate sulle impostazioni stabilite per un'immagine amministrativa esistente presso il sito).
    Creare una nuova immagine usando le impostazioni e i file da un'immagine esistente. | Creare l'immagine usando le impostazioni di configurazione specificate da un'immagine amministrativa esistente presso il sito. Fare clic su Sfoglia per specificare la directory di installazione dell'immagine amministrativa esistente.
  3. Immettere i Numeri di serie SOLIDWORKS.
  4. Fare clic su Cambia per modificare i prodotti o le opzioni predefinite, tra cui:
    • Ubicazione immagine amministrativa
    • Tipo di immagine amministrativa
  5. Accettare il contratto di licenza e fare clic su Crea ora.
  6. Fare clic su Personalizza immagine per aprire e visualizzare le impostazioni nell'Editor delle opzioni dell'immagine amministrativa.
  7. Opzionale: Fare clic su Crea collegamento sul desktop per accedere all'immagine sul desktop.
Argomento principale Uso di immagini amministrative


Editor opzioni immagine amministrativa

L'Editor opzioni immagine amministrativa consente di personalizzare le impostazioni di parametro d'installazione in un'immagine amministrativa per singoli computer e per gruppi di computer.

Dopo avere creato un'immagine amministrativa, Gestione installazioni chiede di avviare l'editor opzioni. L'editor opzioni può essere avviato anche facendo doppio clic su sldAdmintOptionEditor.exe nella cartella delle immagini amministrative.

Per specificare diverse configurazioni di installazione per gruppi di macchine o singole macchine, nell'Editor opzioni, selezionare le macchine. Quindi, specificare le opzioni di installazione per queste macchine.

Tutte le finestre di dialogo, che chiedono un percorso file o cartella, includono un'opzione che consente di mappare una cartella selezionata a una variabile di ambiente. Ad esempio, se si seleziona C:\Program Files\SOLIDWORKS Corp, il percorso del file è mappato in %ProgramFiles%\SOLIDWORKS Corp. Le variabili più comuni sono %ProgramFiles% e %SystemDrive%.

Non è possibile mappare tutti i percorsi in variabili di ambiente. Ad esempio, non è possibile mappare Z:\SOLIDWORKS Data a una variabile di ambiente.

Indice

  • Aggiunta ed eliminazione di gruppi e macchine

    L'Editor opzioni dell'immagine amministrativa consente di specificare configurazioni di installazione diverse per gruppi di macchine e per macchine individuali.

  • Visualizzazione e modifica delle impostazioni

    L'editor delle opzioni immagini amministrative di SOLIDWORKS consente di visualizzare e modificare le impostazioni delle opzioni per i gruppi e la macchine specificate per l'immagine.

  • Disposizione installazioni dall'editor delle opzioni

    È possibile distribuire le installazioni direttamente dall'Editor delle opzioni usando sia un metodo manuale sia push.

  • Uscita dall'Editor opzioni

    È possibile fare clic su OK o Chiudi per applicare le modifiche e uscire dall'Editor delle opzioni.

  • Creazione di un collegamento sul desktop per l'Editor opzioni

    È possibile create un collegamento sul desktop per l'Editor opzioni di una particolare immagine amministrativa all'interno dell'applicazione.

  • Distribuzione di un'immagine amministrativa ai client via email

    Una volta creata una directory condivisa per l'immagine amministrativa, è possibile notificare i client via email.

Argomento principale Uso di immagini amministrative


Aggiunta ed eliminazione di gruppi e macchine

L'Editor opzioni dell'immagine amministrativa consente di specificare configurazioni di installazione diverse per gruppi di macchine e per macchine individuali.

Ad esempio, è possibile configurare diversi sistemi per l'uso di un sottoinsieme dei componenti di prodotto disponibili nell'immagine mentre un altro gruppo di sistema potrebbe utilizzare un sottoinsieme diverso dei componenti. Anche utilizzando la stessa immagine amministrativa, le impostazioni del gruppo Editor opzioni consentono di installare diversi sottoinsiemi di prodotto su diversi gruppi di computer. È possibile spostare le impostazioni tra i gruppi e modificare i gruppi di computer.

È inoltre possibile dividere gruppi di macchine in sottogruppi. I sottogruppi ereditano le impostazioni dal gruppo padre, ma è possibile modificare le impostazioni individuali per ciascun sottogruppo.

Per aggiungere un gruppo:
  1. Fare clic con il pulsante destro del mouse su Impostazioni globali e scegliere Aggiungi gruppo.
  2. Immettere il nome del gruppo.

Per aggiungere i sistemi:
  1. Fare clic con il pulsante destro del mouse su un gruppo esistente o su Impostazioni globali e scegliere Aggiungi macchina.
    Facendo clic con il pulsante destro del mouse su un gruppo esistente, i computer verranno aggiunti al gruppo. Altrimenti, saranno aggiunte al primo livello.
  2. Scegliere una delle seguenti opzioni:
    • Selezionare Per nome macchina e immettere un nome di macchina.
      Un nome di macchina non può includere un qualificatore di dominio. Per esempio, pluto.solidworks.com non è valido.
    • Selezionare Per indirizzo IP e immettere l'indirizzo IP di una macchina.
    • Selezionare Per intervallo indirizzi IP e immettere l'indirizzo IP iniziale e l'indirizzo IP finale del range.
    • Fare clic su Aggiungi altre macchine per immettere i nomi delle macchine. È possibile separare nomi di macchina con un'interruzione di riga, uno spazio, una tabulazione, una virgola, un punto, due punti o un punto e virgola. È anche possibile copiare e incollare un elenco dei nomi macchina da un file delimitato, ad esempio un file *.xls o *.cvs nella finestra di dialogo.

    Se si aggiungono macchine in base a Nome, Indirizzo IP e Intervallo indirizzi IP, la macchina di installazione cerca una corrispondenza seguendo questo ordine: Nome macchina, Indirizzo IP, quindi Intervallo indirizzi IP. Le opzioni di installazione verranno applicate alla macchina di installazione in base alla prima corrispondenza trovata.

Per spostare un computer esistente in un gruppo o sottogruppo:

Trascinare la macchina in un gruppo o sottogruppo.

Per spostare un computer da un gruppo o sottogruppo:

Trascinare la macchina su Impostazioni globali o su un gruppo o sottogruppo diverso.

Per eliminare un gruppo, sottogruppo o computer:

Fare clic con il pulsante destro del mouse sul gruppo, sottogruppo o computer e scegliere Elimina gruppo o Elimina computer.

Eliminando un gruppo, tutte le macchine all'interno di quel gruppo saranno eliminate.

Per eliminare tutti i gruppi e computer:

Fare clic con il pulsante destro del mouse su Impostazioni globali e scegliere Elimina tutto.

Argomento principale Editor opzioni immagine amministrativa
Visualizzazione e modifica delle impostazioni
Disposizione installazioni dall'editor delle opzioni
Uscita dall'Editor opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni
Distribuzione di un'immagine amministrativa ai client via email


Visualizzazione e modifica delle impostazioni

L'editor delle opzioni immagini amministrative di SOLIDWORKS consente di visualizzare e modificare le impostazioni delle opzioni per i gruppi e la macchine specificate per l'immagine.

  • Quando si avvia l'Editor delle opzioni per la prima volta, le impostazioni delle opzioni sono visualizzate in modalità sola lettura. L'icona Modifica [image] non è ombreggiata.

    Se si fa clic su Impostazioni globali, su un gruppo o un computer è possibile visualizzare un riepilogo delle impostazioni delle opzioni per l'elemento specifico:

    Ambito | Impostazioni delle opzioni visualizzate
    Impostazioni globali | Tutte le impostazioni delle opzioni specificate per l'immagine amministrativa
    Raggruppare | Modifiche delle impostazioni di gruppo rispetto alle Impostazioni globali
    Macchina | Modifiche delle impostazioni della macchina rispetto al gruppo
  • Per apportare modifiche alle impostazioni delle opzioni, fare clic su Modifica [image]. L'icona diventa ombreggiata e viene visualizzato un elenco più dettagliato relativo alle impostazioni delle opzioni.

    Se si fa clic su Impostazioni globali, su un gruppo o un computer è possibile modificare le impostazioni delle opzioni per l'elemento specifico. Quando si sceglie un'impostazione delle opzioni diversa dalle impostazioni globali o di gruppo ereditate, l'opzione viene evidenziata.

    Se si fa di nuovo clic sull'icona Modifica [image], la visualizzazione torna in modalità sola lettura.

    Quando si apportano modifiche, l'Editor delle opzioni chiede all'utente se desidera salvare o eliminare i dati all'uscita.

Indice

  • Specificazione delle impostazioni per gruppi e sistemi

    Le impostazioni possono essere specificate per tutti i sistemi (Impostazioni globali), per gruppi di sistemi e per singoli computer.

  • Impostazioni opzione immagine amministrativa

    L'Editor delle opzioni consente di specificare le impostazioni delle opzioni per i singoli clienti o gruppi, compresi i numeri seriali, le opzioni di installazione client, i componenti software da installare e la posizione di Toolbox.

  • Eredità di impostazioni globali e di gruppo

    Le impostazioni delle opzioni per le Impostazioni globali o i gruppi vengono ereditate dagli elementi sottostanti.

  • Personalizzazione delle impostazioni per ciascun computer

    È inoltre possibile modificare le impostazioni applicate a computer specifici facendo clic con il pulsante destro del mouse sul nome del computer.

Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Disposizione installazioni dall'editor delle opzioni
Uscita dall'Editor opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni
Distribuzione di un'immagine amministrativa ai client via email


Specificazione delle impostazioni per gruppi e sistemi

Le impostazioni possono essere specificate per tutti i sistemi (Impostazioni globali), per gruppi di sistemi e per singoli computer.

  1. Nell'Editor delle opzioni fare clic sull'oggetto da modificare (Impostazioni Globali, gruppo o macchina).
  2. A destra, fare clic su Modifica [image].
    L'icona diventa ombreggiata e viene visualizzato un elenco più dettagliato relativo alle impostazioni delle opzioni.
  3. Per apportare le modifiche, fare clic sulle impostazioni a destra corrispondenti all'elemento selezionato a sinistra.
    Vengono evidenziate le modifiche delle impostazioni delle opzioni che sovrascrivono le Impostazioni globali o di gruppo.
  4. Fare clic su OK o su Chiudi per salvare le modifiche.
    Opzione | Descrizione
    OK | L'Editor delle opzioni salva le modifiche e viene chiuso.
    Chiudi | L'Editor delle opzioni chiede se si desidera salvare le modifiche e viene chiuso.
Argomento principale Visualizzazione e modifica delle impostazioni
Impostazioni opzione immagine amministrativa
Eredità di impostazioni globali e di gruppo
Personalizzazione delle impostazioni per ciascun computer


Impostazioni opzione immagine amministrativa

L'Editor delle opzioni consente di specificare le impostazioni delle opzioni per i singoli clienti o gruppi, compresi i numeri seriali, le opzioni di installazione client, i componenti software da installare e la posizione di Toolbox.

Numeri di serie

Immettere i numeri seriali per installare i prodotti sulle macchine client.
Visto che esistono diverse modalità per l'acquisto dei prodotti SOLIDWORKS, alcuni numeri seriali potranno coprire due o più prodotti. Per esempio, un numero seriale per SOLIDWORKS può permettere di installare SOLIDWORKS Simulation senza immettere un numero seriale separato per SOLIDWORKS Simulation. Inoltre, alcuni prodotti non necessitano di un numero seriale. In caso di domande relative ai numeri seriali, contattare il proprio rivenditore autorizzato (VAR).
Se si gestiscono le licenze usando le licenze SolidNetWork:
  • nel primo campo del numero seriale, immettere il numero di serie SolidNetWork.
  • Nel campo SNL Server port@server, immettere il nome e la porta di SolidNetWork License Manager nel formato nnnnn@servername. Separare voci multiple usando i punti e virgole.

Per i dettagli sulle licenze SolidNetWork, vedere Panoramica dell'installazione delle licenze SolidNetWork.

Opzioni di installazione client

Come effettuare le installazioni client delle versioni maggiori? È possibile specificare il modo in cui le installazioni client gestiranno un'installazione della versione principale precedente esistente:
  • Aggiornare la versione principale esistente (se esistente).

    Specificare questa opzione per sostituire l'installazione di versione principale precedente con l'installazione della nuova versione.

  • Creare una nuova versione principale.

    Specificare questa opzione per conservare la versione principale precedente e creare una nuova installazione della nuova versione principale. Per specificare il percorso di installazione della nuova versione, fare clic su Sfoglia.
Disinstallare la versione precedente più recente prima di installare una versione nuova? Specificare se disinstallare l'installazione della versione maggiore esistente:
  • Non disinstallare.

    Specificare questa opzione per conservare l'installazione della versione precedente.

  • Disinstalla l'ultima versione.
  • Disinstallare tutte le versioni.
Come applicare le impostazioni di SOLIDWORKS? È possibile specificare un file delle impostazioni all'avvio del software. Le installazioni client fanno riferimento a un file delle impostazioni. Memorizzare il file delle impostazioni (*.sldsettings) in un percorso UNC condiviso visibile a tutte le installazioni. Specificare il percorso del file *.sldsettings prima di installare SOLIDWORKS. Le installazioni client rilevano il percorso del file *.sldsettings durante l'installazione.
Proteggere il file *.sldsettings specificando le autorizzazioni per i file di Windows e consentire l'accesso in scrittura solo agli utenti designati.

Per creare o modificare un file *.sldsettings, fare clic su Avvia Amministratore impostazioni. Lo strumento Amministratore impostazioni di SOLIDWORKS consente di definire quali opzioni di sistema di SOLIDWORKS applicare ed eventualmente bloccare per gli utenti finali. È inoltre possibile definire come e quando applicare le impostazioni alle singole installazioni e modificare il file *.sldsettings in qualsiasi momento eseguendo lo strumento Amministratore impostazioni e sovrascrivendo il file esistente.

È possibile utilizzare un file *.sldsettings diverso per macchine o gruppi diversi.

Il percorso del file *.sldsettings viene definito al momento dell'installazione. Dopo l'installazione, non rinominare né spostare il file *.sldsettings.

È necessaria un'installazione di SOLIDWORKS [versione principale corrente] per eseguire lo strumento Amministratore impostazioni.
Come attivare le installazioni client? L'utente può specificare se completare automaticamente l'attivazione del prodotto dopo l'esecuzione dell'installazione o richiedere che l'utente effettui l'attivazione del prodotto manualmente dopo l'installazione.
  • Attivare automaticamente al completamento di ogni installazione client.

    La selezione di questa opzione specifica che l'attivazione del prodotto verrà eseguita automaticamente. Immettere l'indirizzo e-mail che dovrà essere fornito quando l'attivazione viene eseguita sul computer client.

  • Non attivare automaticamente.

    Selezionare l'impostazione di questa opzione specifica che non ci sarà nessuna attivazione automatizzata del prodotto. L'utente client effettua l'attivazione del prodotto dopo l'installazione.

Opzioni amministrative

Creare un log diagnostico durante ogni installazione. | Un'installazione client può creare un log diagnostico per la risoluzione dei problemi di installazione. Generando questo log l'esecuzione dell'installazione client rallenterà. Il file di registro è memorizzato in {Administrative image directory}\x64\Logs\<machine_name>.
Eseguire l'installazione come altro utente.

In luogo dell'utente connesso, è possibile specificare un altro utente con permessi amministrativi per eseguire l'installazione. Questa opzione può essere utile quando singoli utenti non dispongono di permessi amministrativi locali sulle proprie macchine (necessari per installare i prodotti SOLIDWORKS).

Se i client non sono dotati di privilegi amministrativi, si può ricorrere a un metodo alternativo per le operazioni di implementazione e installazione. Vedere Disposizione installazioni dall'editor delle opzioni.
Eseguire un programma prima o dopo l'installazione | È possibile specificare l'esecuzione di un programma personalizzato prima o dopo l'installazione client.
Specificare se il client deve partecipare al Programma SOLIDWORKS Customer Experience. | Si può specificare che le macchine client partecipano nel programma SOLIDWORKS Customer Experience. Le informazioni di prestazione vengono inviate alla SOLIDWORKS Corporation per migliorare il prodotto. Il processo è trasparente e confidenziale. Per i dettagli, vedere il sito Web del Programma di miglioramento dell'esperienza clienti.

Limiti delle opzioni di Esegui un programma prima dell'installazione ed Esegui un programma dopo l'installazione

Queste opzioni consentono di eseguire altri programmi o script di installazione sui computer client prima o dopo la distribuzione di SOLIDWORKS, ad esempio uno script di installazione di Microsoft Office.

L'uso di queste opzioni è limitato. Si verifica un errore se si utilizza una delle opzioni per distribuire un programma di installazione o uno script che visualizza un'interfaccia utente, ad esempio uno script che visualizza finestre di dialogo. Quando la distribuzione automatica di SOLIDWORKS è in esecuzione, non è in grado di installare SOLIDWORKS sulla macchina di destinazione.

Per utilizzare le opzioni Esegui un programma prima dell'installazione e Esegui un programma dopo l'installazione, selezionare solo programmi che possono essere installati in modalità invisibile.

Software da installare

Si può specificare quali componenti di prodotto SOLIDWORKS installare.
  • La selezione della casella di controllo accanto al componente del prodotto specifica che il componente verrà installato durante l'installazione sul client.
  • Deselezionando la casella, il componente non verrà installato.
  • Se un componente dispone di sottocomponenti da installare in modo opzionale, accanto al componente viene visualizzata l'icona +. Per visualizzare i sottocomponenti disponibili per un componente, fare clic sull'icona +.
  • Quando si espande un componente per visualizzare i sottocomponenti opzionali, accanto al componente viene visualizzata l'icona -. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona -.
La specifica Lingue limita le lingue installate solo per il prodotto SOLIDWORKS. Le installazioni di altri prodotti non saranno condizionate da questa specifica. Ad esempio, eDrawings® installa tutte le lingue.

Opzioni Toolbox

Specificare quali standard supportare e l'ubicazione di default di Toolbox per le installazioni client.

E' frequente avere utenti multipli che accedono ad un Toolbox condiviso, tipicamente attraverso un punto in rete (per esempio, un percorso UNC, una cartella condivisa o una specificazione di unità in rete comune).

Se la posizione contiene una versione principale precedente di Toolbox, l'installazione client aggiornerà Toolbox alla nuova versione principale. I file non saranno più compatibili con le versioni principali precedenti di SOLIDWORKS.
Se alcuni client continuano a utilizzare una versione precedente di SOLIDWORKS, è necessario specificare un percorso di rete Toolbox differente per i client che vengono aggiornati alla versione più recente.

Per i dettagli relativi all'amministrazione di Toolbox, vedere le informazioni su Toolboxnella Guida di SOLIDWORKS.

Installazione del software Toolbox senza installare i dati Toolbox

Se l'ambiente dispone di PDM o posizione di Creazione guidata fori/Toolbox condivisa, è possibile specificare le installazioni client in modo che non installino o aggiornino i dati Toolbox in quella posizione.

Eseguire questa operazione se:
  • Prima di installare il software SOLIDWORKS non è stata ancora specificata la vista locale di SOLIDWORKS PDM.
  • I file nella posizione sono in uso e potrebbero impedire il completamento delle installazioni SOLIDWORKS.
  • La posizione non è disponibile e potrebbe impedire il completamento delle installazioni SOLIDWORKS.

Quando si specificano le installazioni client in modo che non installino i dati Toolbox, il software SOLIDWORKS e le impostazioni fanno riferimento alla posizione di Creazione guidata fori/Toolbox, ma è necessario installare i dati in una posizione centrale in un secondo momento.

Per installare il software SOLIDWORKS senza includere i dati di Creazione guidata fori/Toolbox:
  • Quando viene richiesto se si desidera che questo client installi/aggiorni i file Toolbox, selezionare No, installare il software Toolbox senza includere i file di dati.

Almeno una persona, in genere l'amministratore CAD, deve installare o aggiornare i dati di Creazione guidata fori/Toolbox nella posizione centrale, altrimenti il software non funzionerà correttamente. Chiunque all'interno dell'organizzazione può gestire questa attività con un'unica installazione manuale del software SOLIDWORKS. Se si gestisce Toolbox all'interno di SOLIDWORKS PDM, seguire i passaggi descritti nella sezione Toolbox della Guida dell'amministratore di SOLIDWORKS PDM per installare o aggiornare i dati Toolbox.

Opzioni del client SOLIDWORKS PDM

È possibile selezionare le seguenti opzioni per la distribuzione di client e aggiunte di SOLIDWORKS PDM:

  • Tipo di prodotto PDM
  • Tipo di client PDM
  • Funzioni
  • Vista del vault

    Per aprire Impostazione guidata vista è necessario eseguire l'Editor opzione immagine amministrativa su un computer su cui è installato il client SOLIDWORKS PDM.

    Per creare la vista del vault sul computer client, è necessario un file Conisio View Setup (.cvs) che definisca i parametri per la configurazione della vista del vault sul computer client. È possibile fare riferimento a un file .cvs esistente o creare questo file dall'Editor opzione immagine amministrativa.

Vedere la sezione su SOLIDWORKS PDM nella Guida di SOLIDWORKS per ulteriori informazioni su questi client e queste aggiunte.

Opzioni Electrical

È possibile specificare i parametri seguenti per i componenti amministrativi di SOLIDWORKS Electrical:
  • Percorso dati
  • Nome del computer Collaborative Server e numero di porta
  • Nome del computer server SQL Server e password

Vedere SOLIDWORKS Electrical per ulteriori informazioni su questi componenti.

Argomento principale Visualizzazione e modifica delle impostazioni
Specificazione delle impostazioni per gruppi e sistemi
Eredità di impostazioni globali e di gruppo
Personalizzazione delle impostazioni per ciascun computer
Panoramica dell'installazione delle licenze SolidNetWork
Disposizione installazioni dall'editor delle opzioni
SOLIDWORKS Electrical


Eredità di impostazioni globali e di gruppo

Le impostazioni delle opzioni per le Impostazioni globali o i gruppi vengono ereditate dagli elementi sottostanti.

Ad esempio:
  • Le impostazioni definite per Impostazioni globali derivano da tutti i gruppi e computer.
  • Le impostazioni definite per un gruppo derivano da tutti i sottogruppi e computer all'interno di quel gruppo.

Le impostazioni delle opzioni possono cambiare per gruppo, sottogruppo o computer per sovrascrivere le impostazioni di default o quelle derivate. Quando si cambiano le impostazioni delle opzioni di default o il loro valore derivato, tale opzione viene evidenziata.

Per ripristinare le impostazioni delle opzioni sui valori ereditati originali, fare clic con il pulsante destro del mouse sul gruppo, sul sottogruppo o sul computer, quindi fare clic su uno dei seguenti elementi:
  • Torna alle impostazioni globali (per un gruppo, sottogruppo o computer che non sia membro del gruppo)
  • Torna alle impostazioni di gruppo (per un computer che sia un membro di gruppo)
  • Ripristina le impostazioni di gruppo dei membri (per tutti i membri di quel gruppo contemporaneamente)
Argomento principale Visualizzazione e modifica delle impostazioni
Specificazione delle impostazioni per gruppi e sistemi
Impostazioni opzione immagine amministrativa
Personalizzazione delle impostazioni per ciascun computer


Personalizzazione delle impostazioni per ciascun computer

È inoltre possibile modificare le impostazioni applicate a computer specifici facendo clic con il pulsante destro del mouse sul nome del computer.

Dal menu di scelta rapida, è possibile effettuare le seguenti attività per ogni computer:
  • Rinomina
  • Elimina macchina
  • Torna alle impostazioni globali
  • Modifica note
  • Modifica opzioni

Modifica opzioni consente di modificare tutte le opzioni per il computer, come le opzioni di installazione client e le opzioni amministrative.

Argomento principale Visualizzazione e modifica delle impostazioni
Specificazione delle impostazioni per gruppi e sistemi
Impostazioni opzione immagine amministrativa
Eredità di impostazioni globali e di gruppo


Disposizione installazioni dall'editor delle opzioni

È possibile distribuire le installazioni direttamente dall'Editor delle opzioni usando sia un metodo manuale sia push.

  • Usare la pagina Distribuzione manuale dell'Editor opzioni per inviare via email le istruzioni agli utenti su come avviare l'installazione. Usare questo metodo se gli utenti non sono dotati dei privilegi amministrativi necessari per i rispettivi client.
    In Opzioni amministrative, è possibile assegnare agli utenti le autorizzazioni amministrative selezionando Esegui l'installazione come altro utente.
  • Usare la pagina Distribuzione automatica dell'Editor opzioni per effettuare automaticamente il push delle installazioni ai computer di destinazione. Usare questo metodo se gli utenti non hanno i privilegi amministrativi richiesti per installare software sui propri sistemi. Con questo metodo è anche possibile eseguire installazioni personalizzate.

Per la distribuzione manuale o automatica, è necessario archiviare la directory di installazione dell'immagine amministrativa in una directory condivisa di Windows, in modo che sia disponibile attraverso un percorso di rete, ad esempio \\machine\shared_directory. Inoltre, è possibile rendere disponibile l'immagine copiandola nella directory locale su ciascun computer, ad esempio C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0.

Indice

  • Uso di un percorso UNC per distribuire un'immagine amministrativa

    Invece di mappare le posizioni dell'unità di rete, utilizzare un percorso UNC (\\machine_name\share_name) quando si specifica un percorso di rete per la directory di installazione dell'immagine amministrativa.

  • Utilizzo di StartSWInstall.exe per distribuire un'immagine amministrativa

  • Distribuzione manuale

    È possibile usare questo metodo se gli utenti hanno i privilegi amministrativi richiesti per installare software sui propri sistemi.

  • Prerequisiti per la distribuzione automatica

    La distribuzione automatica è efficace per gli utenti senza privilegi amministrativi, poiché garantisce che l'installazione del software possa procedere senza problemi.

  • Distribuzione automatica

  • Test di una configurazione per una distribuzione push

    La scheda Distribuisci automaticamente nell'Editor opzione immagine amministrativa contiene una funzione di test.

Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Visualizzazione e modifica delle impostazioni
Uscita dall'Editor opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni
Distribuzione di un'immagine amministrativa ai client via email


Uso di un percorso UNC per distribuire un'immagine amministrativa

Invece di mappare le posizioni dell'unità di rete, utilizzare un percorso UNC (\\machine_name\share_name) quando si specifica un percorso di rete per la directory di installazione dell'immagine amministrativa.

Le unità di rete mappate non sono compatibili con il metodo push e di installazione automatica, nonché con l'opzione Esegui come altro utente nel metodo pull e manuale.

Argomento principale Disposizione installazioni dall'editor delle opzioni


Utilizzo di StartSWInstall.exe per distribuire un'immagine amministrativa

È possibile installare o disinstallare un'immagine amministrativa nei client eseguendo il comando admin_image_install_dir\ StartSWInstall.exe. Questo metodo consente di installare SOLIDWORKS utilizzando le opzioni, i computer e i gruppi definiti nell'editor delle opzioni dell'immagine amministrativa.

È possibile aggiungere le seguenti opzioni al comando StartSWInstall.exe:
Opzione di comando | Descrizione
/install | Installa l'immagine amministrativa sui computer client.
/uninstall Disinstalla il software dai computer client, con due opzioni facoltative:

/removedata

Disponibile solo per la disinstallazione. Rimuove i file di dati e le cartelle di SOLIDWORKS durante la disinstallazione.

/removeregistry

Disponibile solo per la disinstallazione. Rimuove le voci di registro di SOLIDWORKS durante la disinstallazione.
/showui | Visualizza una finestra di avanzamento per Gestione installazioni SOLIDWORKS. In caso contrario, l'applicazione Gestione installazioni SOLIDWORKS non è visibile all'utente.
/now | Avvia immediatamente l'installazione o la disinstallazione. La finestra di dialogo di avviso 5 minuti non viene visualizzata.

È preferibile utilizzare StartSWInstall.exe anziché StartSWInstall.hta nei casi in cui si desidera che l'installazione proceda senza alcuna interazione da parte dell'utente, ma non si desidera utilizzare la distribuzione automatica dall'Editor opzione immagine amministrativa.

Argomento principale Disposizione installazioni dall'editor delle opzioni


Distribuzione manuale

È possibile usare questo metodo se gli utenti hanno i privilegi amministrativi richiesti per installare software sui propri sistemi.

Per distribuire le installazioni manualmente via email:

  1. Nell’Editor opzioni fare clic su Distribuzione.
    Verrà visualizzata la disponibilità di installazione e lo stato per ogni macchina.
  2. Fare clic su Invia email.
  3. Specificare il percorso di rete alla directory d'installazione dell'immagine amministrativa.
    In genere, il percorso della directory di installazione dell'immagine amministrativa viene inizialmente visualizzato come percorso di un file di Windows (ad esempio, C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0). La finestra di dialogo indica Questo percorso non è un percorso di rete.
    1. Fare clic su Fare clic su Sfoglia per specificare il percorso di rete di questa directory d'installazione dell'immagine amministrativa.
    2. Navigare al computer dove è installata l'immagine amministrativa e selezionare la directory Windows condivisa specificata per la directory d'installazione dell'immagine amministrativa.
      Non accedere nella directory condivisa dell'immagine amministrativa (ad esempio, nelle sottodirectory 64 bit)).
    3. Fare clic su OK.
      La finestra di dialogo indica Questo percorso è un percorso di rete.
    Viene generata un'email per fornire al proprietario del computer le istruzioni su come eseguire l'installazione dall'immagine amministrativa usando il percorso di rete per il file StartSWInstall.hta nell'immagine amministrativa.
  4. Inviare l'email agli utenti responsabili dell'installazione di SOLIDWORKS.

Gli utenti possono fare doppio clic sul collegamento al percorso di rete per StartSWInstall.hta nell'email per installare SOLIDWORKS dall'immagine amministrativa.

Nell'Editor delle opzioni, viene visualizzato lo Stato di installazione:
In attesa | L'utente non ha ancora eseguito l'installazione su questo computer.
Riuscita | L'utente ha completato con successo l'installazione su questo computer.
Non riuscita | L'utente ha eseguito l'installazione su questo computer, ma non è riuscita.
Altri messaggi di stato che potrebbero essere visualizzati sono: Installato con successo, Disinstallato con successo, Installazione, Disinstallazione, Riavvio necessario, Installazione non riuscita, e Disinstallazione non riuscita.
Nella parte superiore della colonna Stato, fare clic sulla freccia verde per aggiornare e mostrare le informazioni aggiornate.
Argomento principale Disposizione installazioni dall'editor delle opzioni


Prerequisiti per la distribuzione automatica

La distribuzione automatica è efficace per gli utenti senza privilegi amministrativi, poiché garantisce che l'installazione del software possa procedere senza problemi.

Per utilizzare la distribuzione automatica, sia il client sia il server devono appartenere allo stesso dominio Active Directory. Questa configurazione permette di spostare le attività di installazione nelle macchine di destinazione, dove saranno gestite dall'Utilità di pianificazione Microsoft senza necessità di interventi manuali da parte degli utenti.

Con un'installazione push, Task Scheduler esegue l'operazione di avvio di Gestione installazioni SOLIDWORKS su un computer client utilizzando le credenziali specificate da un amministratore nell'Editor delle opzioni. L'utilità di pianificazione viene eseguita con l'account LocalSystem del computer. Questo account è rappresentato in rete come entità di protezione del computer. Il principio di sicurezza del computer deve avere il seguente accesso:
  • Accesso in lettura alla cartella Admin Images.
  • Accesso in lettura e scrittura alla cartella Admin Images folder\x64\logs.

In Active Directory, quando si aggiunge un computer a un gruppo di una Cartella condivisa, selezionare Tipi di oggetto e Computer.

Inoltre, il computer che fornisce l'immagine amministrativa e i computer client di destinazione devono appartenere allo stesso dominio di Active Directory.

Argomento principale Disposizione installazioni dall'editor delle opzioni


Distribuzione automatica

Per distribuire automaticamente effettuando il push delle installazioni ai sistemi dell'utente:

  1. Nell'Editor delle opzioni, fare clic sulla scheda Distribuzione automatica.
    Verrà visualizzata la disponibilità di installazione e lo stato per ogni macchina.
  2. Nella colonna Distribuzione, selezionare i computer client di destinazione e i gruppi nella colonna Distribuzione.
    Selezionare uno o più computer o gruppi nella colonna Distribuzione prima di iniziare il processo di distribuzione.
  3. In Orario installazione, selezionare Ora per distribuire subito o Dopo per pianificare data e orario specifici per la distribuzione.
  4. In Opzioni client, selezionare le opzioni seguenti:
    • Installa o aggiorna SOLIDWORKS 2025
    • Disinstalla SOLIDWORKS 2025
      Se si sceglie di disinstallare, è possibile specificare se disinstallare le voci di registro, i file di dati e le cartelle insieme ai programmi e alle cartelle.
  5. Selezionare Riavvia automaticamente il computer se si desidera che una o più macchine di destinazione si riavvii, in caso di necessità, durante o dopo la distribuzione.
  6. Inserire le Credenziali client di una o più macchine di destinazione.
  7. Fare clic su Distribuzione per iniziare il processo di distribuzione.
Nell'Editor delle opzioni viene visualizzato lo Stato di installazione:
In attesa | L'installazione non è ancora stata eseguita su questo computer.
Riuscita | L'installazione è stata completata con successo su questo computer.
Non riuscita | L'installazione su questo computer non è riuscita.

Altri messaggi di stato che potrebbero essere visualizzati sono: Installato con successo, Disinstallato con successo, Pianificazione, Connessione, Installazione, Disinstallazione, Riavvio necessario, Installazione pianificata, Disinstallazione pianificata, Installazione non riuscita, Disinstallazione non riuscita, Connessione non riuscita e Pianificazione non riuscita.

Argomento principale Disposizione installazioni dall'editor delle opzioni


Test di una configurazione per una distribuzione push

La scheda Distribuisci automaticamente nell'Editor opzione immagine amministrativa contiene una funzione di test.

È possibile eseguire un'installazione simulata che esercita i sistemi utilizzati per la distribuzione, ad esempio:
  • Connessione al computer di destinazione.
  • Creazione di un'attività di installazione su quel computer.
  • Completamento dell'attività di installazione su quel computer.
  • Aggiornamento di stato e log sull'immagine amministrativa.
  • Rilevamento di un programma da eseguire prima o dopo l'installazione.

Il test verifica i percorsi dei file, convalida le autorizzazioni e segnala che l'installazione è stata completata correttamente. Non installa alcun software né modifica il registro nel sistema di destinazione. Se un sistema non funziona su uno dei computer di destinazione, il test indica quale sistema non ha funzionato.

Le descrizioni dei comandi forniscono ulteriori informazioni sugli errori. È possibile esportare i risultati in un foglio di calcolo .xml o .csv, utile per esaminare più errori o condividere i risultati con altro personale di supporto.

Per testare una configurazione per una distribuzione push:

  1. Utilizzando la Gestione installazioni, creare un'Immagine amministrativa.
  2. Avviare l'Editor delle opzioni immagine amministrativa.

    È possibile avviare l'opzione dopo che la Gestione installazioni ha completato la creazione dell'immagine amministrativa oppure fare doppio clic su sldAdminOptionEditor.exe nella cartella dell'immagine amministrativa.

  3. Nella scheda Configurazione, aggiungere uno o più computer.
  4. Fare clic su Distribuisci automaticamente:
    1. Fornire il nome utente e la password di un amministratore del dominio.
    2. Selezionare uno o più computer da testare.
    3. Fare clic su Test.
  5. Quando compare il test di configurazione, fare clic su Esegui test.
  6. Attendere alcuni minuti per il completamento del test o fare clic su Annulla test in qualsiasi momento.
  7. Esaminare e correggere eventuali problemi di configurazione.
Argomento principale Disposizione installazioni dall'editor delle opzioni


Uscita dall'Editor opzioni

È possibile fare clic su OK o Chiudi per applicare le modifiche e uscire dall'Editor delle opzioni.

  • Fare clic su OK per applicare le modifiche alle impostazioni delle opzioni e uscire dall'Editor delle opzioni.
  • Fare clic sul pulsante Chiudi dell'applicazione Windows per uscire dall'Editor delle opzioni. Se il software rileva che sono presenti modifiche non salvate, viene chiesto all'utente di salvare.
Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Visualizzazione e modifica delle impostazioni
Disposizione installazioni dall'editor delle opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni
Distribuzione di un'immagine amministrativa ai client via email


Creazione di un collegamento sul desktop per l'Editor opzioni

È possibile create un collegamento sul desktop per l'Editor opzioni di una particolare immagine amministrativa all'interno dell'applicazione.

  1. Avviare l'Editor opzioni.
    In File Explorer, ad esempio, accedere alla directory di installazione dell'immagine amministrativa e fare doppio clic su sldAdminOptionEditor.exe.
  2. Fare clic su Crea collegamento a questo Editor delle opzioni sul desktop.
    Sul desktop di Windows appare un collegamento all'Editor opzioni dell'immagine amministrativa.
Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Visualizzazione e modifica delle impostazioni
Disposizione installazioni dall'editor delle opzioni
Uscita dall'Editor opzioni
Distribuzione di un'immagine amministrativa ai client via email


Distribuzione di un'immagine amministrativa ai client via email

Una volta creata una directory condivisa per l'immagine amministrativa, è possibile notificare i client via email.

Configurare la directory dell'immagine amministrativa da condividere su una macchina accessibile agli altri computer (es. con un percorso UNC).

È possibile inviare una mail con il collegamento al percorso_installazione_immagine_amministrativa\StartSWInstall.hta a tutti i client. I client potranno quindi selezionare questo collegamento e fare clic su Installa ora i prodotti SOLIDWORKS per avviare l'installazione dall'immagine amministrativa.

Se si aggiorna un'immagine amministrativa ad una nuova versione di SOLIDWORKS, si potrà configurare la posizione dell'immagine amministrativa e condividere le proprietà in modo che i client installati precedentemente usando quella immagine si aggiorneranno automaticamente. Per i dettagli, vedere Aggiornamento dei client dalle immagini amministrative.
Argomento principale Editor opzioni immagine amministrativa
Aggiunta ed eliminazione di gruppi e macchine
Visualizzazione e modifica delle impostazioni
Disposizione installazioni dall'editor delle opzioni
Uscita dall'Editor opzioni
Creazione di un collegamento sul desktop per l'Editor opzioni


Strumento Amministratore impostazioni

È possibile utilizzare lo strumento Amministratore impostazioni per specificare le opzioni sistema applicate durante la distribuzione o l'aggiornamento del software SOLIDWORKS, oltre a impedire agli utenti di modificare tali opzioni. Questo strumento sostituisce la Procedura guidata impostazioni di SOLIDWORKS per la distribuzione delle impostazioni, sebbene la procedura guidata sia sempre disponibile per copiare le impostazioni.

Per utilizzare lo strumento Amministratore impostazioni con l'Editor opzioni immagine amministratore, procedere come segue:
  1. Creare un'immagine amministrativa per accedere allo strumento.
  2. Utilizzare lo strumento Amministratore impostazioni per generare un file *.sldsettings contenente le opzioni SOLIDWORKS selezionate.
  3. Includere il file *.sldsettings nelle installazioni SOLIDWORKS.
Se si utilizza l'aggiunta 3DEXPERIENCE, è anche possibile distribuire un file *.sldsettings all'esterno di un'immagine amministrativa. Un vantaggio di questo metodo è che le impostazioni vengono distribuite automaticamente al momento dell'accesso.
  1. Per accedere allo strumento Amministratore impostazioni, attenersi alla procedura descritta in Accesso allo strumento Amministratore impostazioni.
  2. Seguire le istruzioni per applicare e bloccare le impostazioni.
  3. Da Compass di 3DEXPERIENCE, espandere I miei ruoli e fare clic sull'app Platform Manager. Accedere a Contenuto > Collaboration Spaces Configuration Center > Collaborazione CAD > SOLIDWORKS > Impostazioni > Risorse > CAD.
  4. In Impostazioni CAD, cercare, caricare e scaricare il file *.sldsettings.

Indice

  • Accesso allo strumento Amministratore impostazioni

    Per accedere allo Strumento Amministratore impostazioni, occorre innanzitutto creare un'immagine amministrativa.

  • Utilizzo dello strumento Amministratore impostazioni

  • Applicazione e blocco delle opzioni

  • Opzioni di impostazione di finitura

  • Includere il file sldsettings nelle installazioni di SOLIDWORKS

Argomento principale Uso di immagini amministrative


Accesso allo strumento Amministratore impostazioni

Per accedere allo Strumento Amministratore impostazioni, occorre innanzitutto creare un'immagine amministrativa.

È possibile avviare lo strumento Amministratore impostazioni da un'immagine amministrativa.

Per accedere allo strumento Amministratore impostazioni:

  1. Lanciare sldAdminOptionEditor.exe nella cartella dell'immagine amministrativa.
  2. Nell'Editor opzione immagine amministrativa, fare clic su Modifica [image].
  3. Nella sezione Opzioni di installazione client, effettuare le seguenti operazioni:
    1. Fare clic su Usare un file di impostazione esportato dallo strumento Amministratore impostazioni SOLIDWORKS.
    2. Fare clic su Avvia Amministratore impostazioni.
      Per accedere ad Avvia Amministratore impostazioni, è necessario installare SOLIDWORKS <versione> sul computer che esegue sldAdminOptionEditor.exe.
Argomento principale Strumento Amministratore impostazioni


Utilizzo dello strumento Amministratore impostazioni

Per utilizzare lo Strumento Amministratore impostazioni:

  1. Nella scheda Benvenuto, selezionare una delle seguenti opzioni:
    • Serie di opzioni di default per iniziare da questa release di SOLIDWORKS.
    • Importa opzioni di SOLIDWORKS 2025 da questo computer.
    • Accedi a un file sldreg esistente.
    • Accedi a un file sldsettings esistente.
    Il file *.sldreg è generato dalla Procedura guidata impostazioni di SOLIDWORKS e il file *.sldsettings è generato dallo strumento Amministratore impostazioni.
  2. Fare clic su Avanti.
Argomento principale Strumento Amministratore impostazioni


Applicazione e blocco delle opzioni

Nella scheda Opzioni di sistema, due colonne di caselle di spunta consentono di selezionare quali di queste opzioni applicare e quali invece bloccare tra quelle applicate, in modo da impedire agli utenti di modificarle.

Quando gli utenti accedono alla finestra di dialogo Opzioni di sistema nel software SOLIDWORKS, le opzioni bloccate sono visualizzate come non disponibili, con un'icona a forma di lucchetto [image]. Tuttavia, è possibile creare una password che consenta agli utenti di sbloccare le opzioni. Quando gli utenti passano con il mouse su un'opzione bloccata, viene visualizzata una descrizione del comando contenente il nome e l'indirizzo e-mail da contattare per richiedere la password.

Per applicare e bloccare le opzioni:

  1. Nella scheda Opzioni di sistema, effettuare le seguenti operazioni:
    1. Per applicare un'opzione di sistema, selezionare l'opzione e selezionare la casella corrispondente nella colonna Applica.
    2. Per bloccare un'opzione di sistema, selezionare l'opzione e selezionare la casella corrispondente in entrambe le colonne Applica e Blocco.
      Quando gli utenti accedono alla scheda Opzioni di sistema, queste opzioni sono visualizzate con un lucchetto [image].
  2. A seconda dell'opzione, può essere necessario specificare parametri aggiuntivi.
  3. È inoltre possibile impedire agli utenti di sopprimere i messaggi, applicando controlli per Messaggi/Errori/Avvertenze.
    1. Fare clic su Messaggi/Errori/Avvertenze.
    2. Selezionare Applica e, facoltativamente, selezionare Blocca per i messaggi che si desidera gestire.
    3. Impostare Mostra o Non mostrare per il messaggio.

      Se si seleziona Mostra, il messaggio viene rimosso dall'elenco dei messaggi soppressi dell'utente e viene mostrato all'utente al momento opportuno. Se si seleziona Non mostrare, il messaggio viene aggiunto automaticamente all'elenco dei messaggi soppressi dell'utente e non viene visualizzato quando l'utente sta lavorando su un modello.

      La tabella seguente descrive il comportamento nel software:
      Applica | Blocca | Mostra | Non mostrare | Comportamento
      X | X | Forza la visualizzazione del messaggio.
      X | X | Elimina il messaggio e lo aggiunge all'elenco dei messaggi soppressi.
      X | X | X | Forza la visualizzazione del messaggio e disattiva l'opzione Non visualizzare nuovamente nella finestra del messaggio.
      X | X | X | Elimina il messaggio e impedisce all'utente di attivarlo in Strumenti > Opzioni > Messaggi/Errori/Avvertenze.
  4. Nella scheda Opzioni di sistema, fare clic su Avanti.
Argomento principale Strumento Amministratore impostazioni


Opzioni di impostazione di finitura

Procedere nel seguente modo:

  1. Nella scheda Fine, selezionare quando applicare le opzioni di sistema:
    • la prima volta che un utente avvia il software.
    • ogni volta che un utente avvia il software.
    • e se applicare contemporaneamente le personalizzazioni.
  2. Si può scegliere di applicare le opzioni bloccate quando gli utenti sono fuori rete e consentire all'API di scavalcare il blocco delle opzioni.
  3. Per le opzioni di sistema bloccate, è necessario fornire il proprio nome e indirizzo e-mail. Il software SOLIDWORKS mostra queste informazioni in una descrizione dei comandi quando gli utenti passano con il mouse su un'opzione bloccata.
  4. Inoltre, è possibile consentire agli utenti di bypassare il blocco delle opzioni. A tale scopo, è necessario specificare una Password che può essere fornita agli utenti.
  5. Fare clic su Salva per generare un file *.sldsettings per la distribuzione.
Argomento principale Strumento Amministratore impostazioni


Includere il file sldsettings nelle installazioni di SOLIDWORKS

Per includere un file *.sldsettings nell'installazione:

  1. Fare doppio clic su sldAdminOptionEditor.exe nella cartella dell'immagine amministrativa.
  2. Nell'Editor opzione immagine amministrativa, fare clic su Modifica.
  3. Nella sezione Opzioni di installazione client, effettuare le seguenti operazioni:
    1. Fare clic su Usare un file di impostazione esportato dallo strumento Amministratore impostazioni SOLIDWORKS.
    2. Fare clic su Modifica percorso e individuare il file *.sldsettings.
    È possibile creare e applicare file *.sldsettings differenti per gruppi o macchine differenti.
  4. Distribuire e installare il software SOLIDWORKS.

Dopo la distribuzione, è possibile ripetere il punto 2 in qualsiasi momento per modificare un file *.sldsettings esistente. All'avvio successivo, il software SOLIDWORKS legge il file *.sldsettings modificato.

Argomento principale Strumento Amministratore impostazioni


Distribuzione dalla riga di comando

È possibile distribuire automaticamente un'immagine amministrativa usando un prompt dei comandi o file batch (installazione invisibile).

Per distribuire un'immagine amministrativa mediante la riga di comando per i client SOLIDWORKS PDM, vedere la Guida di installazione di SOLIDWORKS PDM.

Indice

  • Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa

    Dopo aver creato l'immagine amministrativa e prima di aver notificato i client, è necessario installare i componenti Microsoft Windows che non possono essere installati da immagini amministrative, utilizzando la riga di comando o Microsoft Active Directory.

  • Installazione da un'immagine amministrativa mediante la riga di comando

    È possibile distribuire le installazioni da un'immagine amministrativa utilizzando la riga di comando.

  • Proprietà della riga di comando

    Le proprietà della riga di comando descritte di seguito comprendono proprietà di funzione, proprietà globali, proprietà specifiche di prodotto e convenzioni internazionali di Windows.

  • Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory

    La distribuzione tramite Microsoft Active Directory è supportata per la distribuzione del prodotto principale SOLIDWORKS ai client.

Argomento principale Installazioni multiple
Distribuzione su più client
Uso di immagini amministrative
Amministrazione delle installazioni multiple


Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa

Dopo aver creato l'immagine amministrativa e prima di aver notificato i client, è necessario installare i componenti Microsoft Windows che non possono essere installati da immagini amministrative, utilizzando la riga di comando o Microsoft Active Directory.

L'installazione manuale di questi componenti Windows è necessaria solo se si installa da un'immagine amministrativa mediante la riga di comando o con Microsoft Active Directory. Se si usa la Gestione installazioni SOLIDWORKS per creare e installare un'immagine amministrativa, questi componenti Windows saranno installati automaticamente.
Di seguito è fornito il riepilogo dei file necessari a SOLIDWORKS nei componenti Windows:
Windows Performance Toolkit | Abilita l'accesso esteso in SOLIDWORKS Rx.
Visual C++ 2022 Redistributable Package | Contiene i componenti runtime per Microsoft Visual C++. È necessario installare la versione 2022.
Visual Basic for Applications 7.1 | Fornisce il supporto per le macro di Visual Basic.
Strumenti Visual Studio per Applicazioni 2022 | Opzionale. Contiene un gruppo di strumenti che supportano le applicazioni Visual Studio 2022 (VSTA17).
.NET Framework 4,8 | Contiene il runtime di lingua comune e i componenti .NET Framework necessari per eseguire le applicazioni .NET Framework 4.8.
SWCEF | Chromium Embedded Framework (CEF) viene utilizzato per mostrare i contenuti di 3DEXPERIENCE platform.
Microsoft Edge Web View2 | Necessario per mostrare i contenuti Web.
SOLIDWORKS Login Manager | Consente l'accesso a 3DEXPERIENCE Marketplace e ad altre app 3DEXPERIENCE.
Visual C++ Redistributable Package e .NET Framework 4.8 sono necessari per tutti i prodotti SOLIDWORKS, non solo per il prodotto principale SOLIDWORKS.

Questi componenti devono essere compresi nelle sottodirectory della directory con l'immagine amministrativa.

La tabella seguente indica i file necessari per ogni sistema operativo supportato.
Sistema operativo: Windows Server 2019 a 64 bit e Windows Server 2022 a 64 bit
L'installazione su Windows Server 2019 e 2022 è supportata per SOLIDWORKS PDM Server e SOLIDWORKS SolidNetWork License Manager.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package: | vc_redist.x86.exe vc_redist.x64.exe Entrambi devono essere installati.
Visual Basic 7.1: | vba71.msi e vba71_1033.msi Più un pacchetto lingua opzionale.
.NET Framework 4,8: | ndp48-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
Sistema operativo: Windows 10 o Windows 11 a 64 bit
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package: | vc_redist.x86.exe vc_redist.x64.exe Entrambi devono essere installati.
Visual Basic 7.1: | vba71.msi e vba71_1033.msi Più un pacchetto lingua opzionale.
.NET Framework 4,8: | .NET 4.8 fa parte del sistema operativo, che soddisfa questo requisito.
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

Indice

  • Installazione dei prerequisiti di Windows dalla riga di comando su sistemi operativi a 64 bit

    Attenersi alla procedura seguente per installare i prerequisiti di Windows per l'installazione dell'immagine amministrativa utilizzando la riga di comando su versioni a 64 bit di Windows.

Argomento principale Distribuzione dalla riga di comando
Installazione da un'immagine amministrativa mediante la riga di comando
Proprietà della riga di comando
Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory


Installazione dei prerequisiti di Windows dalla riga di comando su sistemi operativi a 64 bit

Attenersi alla procedura seguente per installare i prerequisiti di Windows per l'installazione dell'immagine amministrativa utilizzando la riga di comando su versioni a 64 bit di Windows.

Per installare più componenti in una sola operazione, creare un file batch con i comandi forniti nelle seguenti procedure e usarlo per installare i componenti sui computer client.

  1. assicurarsi che il computer di destinazione abbia almeno 620 MB di spazio su disco e una directory TEMP valida.
  2. Installare i pacchetti ridistribuibili RELEASE di Visual C++. È necessario installare sia la versione a 32 bit sia quella a 64 bit di ogni pacchetto.
    Installare il pacchetto per la RELEASE = 2022.

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. Installare Microsoft .NET Framework 4,8:
    administrative_image_directory\.Net_Framework_4.8\ndp48-x86-x64-allos-enu.exe
  4. Installare gli strumenti Visual Studio per applicazioni 2022:
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. Installare Visual Basic 7.1:
    administrative_image_directory\Microsoft_VBA\vba71.msi e administrative_image_directory\Microsoft_VBA\vba71_1033.msi sono richiesti per tutte le lingue.
    Solo la versione a 64 bit di questo pacchetto deve essere installata.

    Inoltre, installare il language pack seguente per la lingua desiderata:

    vba71_1028.msi | Cinese
    vba71_1031.msi | Tedesco
    vba71_1036.msi | Francese
    vba71_1040.msi | Italiano
    vba71_1041.msi | Giapponese
    vba71_1042.msi | Coreano
    vba71_1046.msi | Portoghese brasiliano
    vba71_2052.msi | Cinese semplificato
    vba71_3082.msi | Spagnolo
    Le lingue inglese, ceca, polacca, russa e turca non necessitano di language pack aggiuntivi.
  6. Installare SOLIDWORKS Chromium Embedded Framework (SWCEF):
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. Installare SOLIDWORKS Login Manager:
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
Argomento principale Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa


Installazione da un'immagine amministrativa mediante la riga di comando

È possibile distribuire le installazioni da un'immagine amministrativa utilizzando la riga di comando.

Per un'installazione invisibile:

  1. Aprire una finestra Prompt dei comandi (in Windows, fare clic su Start > Esegui).
  2. Digitare il comando msiexec.exe con /i e /qb e specificare le proprietà per qualsiasi opzione non compresa nei valori predefiniti indicati di seguito.

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

Le proprietà della riga di comando del singolo componente di installazione includono:
  • Proprietà di funzione della riga di comando
  • Proprietà globali della riga di comando
  • eDrawings Proprietà della riga di comando
  • Proprietà della riga di comando per SOLIDWORKS Flow Simulation

Usare gli esempi seguenti come modelli per un'installazione invisibile.

Client SOLIDWORKS

  • Ambiente SOLIDWORKS (inglese)
  • Aggiunta Toolbox
  • Partecipazione nel programma feedback
  • Lingua francese

SOLIDWORKS:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

Il componente di installazione di lingua francese SOLIDWORKS deve essere installato separatamente:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

Quando si specificano i comandi di installazione del componente di lingua di SOLIDWORKS, non specificare argomenti di riga dei comandi.

Client di eDrawings

  • Tutte le funzioni

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

A causa della complessità tecnica insita nell'installare SOLIDWORKS Electrical con Microsoft SQL Server, gli esempi della riga di comando per SOLIDWORKS Electrical sono esclusi dalla documentazione.

SOLIDWORKS Visualize e Visualize Boost

Per SOLIDWORKS Visualize:

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

Per SOLIDWORKS Visualize Boost:

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

Argomento principale Distribuzione dalla riga di comando
Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa
Proprietà della riga di comando
Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory


Proprietà della riga di comando

Le proprietà della riga di comando descritte di seguito comprendono proprietà di funzione, proprietà globali, proprietà specifiche di prodotto e convenzioni internazionali di Windows.

Indice

  • Proprietà di funzione della riga di comando

    L?installazione di SOLIDWORKS supporta queste proprietà ADDLOCAL per la distribuzione dalla riga di comando.

  • Proprietà globali della riga di comando

    Ogni proprietà viene definita per le installazioni amministrative o individuali, salvo indicazione diversa. I numeri di seriali possono essere comunicati sia a un'installazione tramite immagine amministrativa sia a un'installazione individuale che utilizza le proprietà globali.

  • eDrawings Proprietà della riga di comando

    Queste proprietà della riga di comando sono specifiche a eDrawings ®.

  • Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player

    Queste proprietà della riga di comando sono specifiche di SOLIDWORKS Composer e SOLIDWORKS Composer Player.

  • Proprietà della riga di comando per SOLIDWORKS Flow Simulation

    Queste proprietà della riga di comando sono specifiche a SOLIDWORKS Flow Simulation.

  • Proprietà riga di comando di SOLIDWORKS Inspection

    Queste proprietà della riga di comando sono specifiche a SOLIDWORKS Inspection.

  • Proprietà della riga di comando di SOLIDWORKS Visualize

    Queste proprietà della riga di comando sono specifiche per SOLIDWORKS Visualize.

  • Posizioni dei file MSI per immagini amministrative

    Per creare immagini amministrative dalla riga di comando, i file .msi dei componenti del prodotto vengono memorizzati nelle seguenti posizioni sui supporti SOLIDWORKS.

Argomento principale Distribuzione dalla riga di comando
Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa
Installazione da un'immagine amministrativa mediante la riga di comando
Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory


Proprietà di funzione della riga di comando

L?installazione di SOLIDWORKS supporta queste proprietà ADDLOCAL per la distribuzione dalla riga di comando.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
Quando si specificano le proprietà per l'installazione da riga di comando:
  • SOLIDWORKS non supporta l'installazione del prodotto usando l'opzione ADDSOURCE.
  • le proprietà sono sensibili al contesto, non possono contenere spazi o trattini e devono essere separate da virgole.
Argomento principale Proprietà della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà globali della riga di comando

Ogni proprietà viene definita per le installazioni amministrative o individuali, salvo indicazione diversa. I numeri di seriali possono essere comunicati sia a un'installazione tramite immagine amministrativa sia a un'installazione individuale che utilizza le proprietà globali.

Proprietà | Descrizione
ENABLEPERFORMANCE Specifica se l'applicazione deve inviare automaticamente i dati relativi alla prestazione a SOLIDWORKS Corporation.

1

Inviare i dati relativi alle prestazioni.

0

Non inviare i dati relativi alle prestazioni.
INSTALLDIR | Cartella di installazione per SOLIDWORKS.
MBDSERIALNUMBER | Numero di serie del prodotto SOLIDWORKS Model Based Definition.
MOTIONSERIALNUMBER | Numero di serie del prodotto SOLIDWORKS Motion.
OFFICEOPTION Specificare il pacchetto del prodotto da installare:
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL Specificare ALL per aggiornare tutte le caratteristiche attualmente installate.
Specificare questa proprietà solo se si esegue l'aggiornamento a una versione del Service Pack che rientra in una release principale esistente (ad esempio, se si esegue l'aggiornamento da un'installazione SOLIDWORKS 2025 SP01 esistente a SOLIDWORKS 2025 SP02).
REINSTALLMODE Opzioni di reinstallazione di Microsoft Installer.

Ad esempio, se si esegue l'aggiornamento di un'installazione da una versione del Service Pack a un'altra che rientra nella stessa versione maggiore, specificare REINSTALLMODE=vomus.

Per ulteriori informazioni sulle impostazioni di REINSTALLMODE, vedere la documentazione di Windows Installer all'indirizzo www.microsoft.com.

Specificare questa proprietà solo se si esegue l'aggiornamento a una versione del Service Pack che rientra in una release principale esistente (ad esempio, se si esegue l'aggiornamento da un'installazione SOLIDWORKS 2025 SP01 esistente a SOLIDWORKS 2025 SP02). Non specificare questa proprietà la prima volta che si installa una nuova versione maggiore di SOLIDWORKS.
SERVERLIST Elenco server di SolidNetWork.
L'elenco server di SolidNetWork è un elenco delimitato di stringhe, ognuna delle quali fa riferimento a un numero di porta su un server con il seguente formato:
  • Terna (delimitata da virgole) =xxxxx@nome_server1,yyyyy@nome_server2,zzzzz@nome_server3
  • Non terna (delimitata da punto e virgola) = xxxxx@nome_server1;yyyyy@nome_server2;zzzzz@nome_server3
X e Y sono singole cifre. Non inserire un delimitatore dopo l'ultimo server nell'elenco.
SIMULATIONSERIALNUMBER | Numero di serie del prodotto SOLIDWORKS Simulation.
SOLIDWORKSSERIALNUMBER | Numero di serie del prodotto SOLIDWORKS, aggiunte comprese.
SWMIGRATE Versione di SOLIDWORKS da aggiornare così come apparirebbe nell'elenco nella finestra di dialogo Scelta di installazione SOLIDWORKS. Ad esempio:

SWMIGRATE="SOLIDWORKS 2025 x64 Edition SP01"

Specificare questa proprietà solo se si installa una nuova versione maggiore e ne è già installata una maggiore precedente. Non specificare questa proprietà se si esegue l'aggiornamento da una versione del Service Pack a un'altra che rientra nella stessa versione maggiore.
TOOLBOXFOLDER Cartella di installazione per i file di SOLIDWORKS Toolbox.

Ad esempio: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Se l'ambiente dispone di una posizione PDM o di Creazione guidata fori/Toolbox condivisa, è possibile specificare un'installazione client in modo tale da non installare o aggiornare i dati Toolbox in quella posizione tramite la proprietà NOTTOOLBOXSETUP. Specificare:

0 | Installa i file Toolbox.
1 | Non installare i file Toolbox.
TRANSFORMS Contiene elementi specifici per la lingua nel formato:
TRANSFORMS numero.mst
  • Cinese (1028)
  • Cinese semplificato (2052)
  • Ceco (1029)
  • Inglese (1033)
  • Francese (1036)
  • Tedesco (1031)
  • Italiano (1040)
  • Giapponese (1041)
  • Coreano (1042)
  • Polacco (1045)
  • Portoghese brasiliano (1046)
  • Russo (1049)
  • Spagnolo (1034)
  • Turco (1055)
UPGRADESWINSTALL
Specificare se aggiornare una versione esistente di SOLIDWORKS alla versione corrente.
0 | Nuova installazione, non aggiornare.
1 | Aggiorna
Specificare questa proprietà solo se si installa una nuova versione maggiore e ne è già installata una maggiore precedente. Non specificare questa proprietà se si esegue l'aggiornamento da una versione del Service Pack a un'altra che rientra nella stessa versione maggiore.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


eDrawings Proprietà della riga di comando

Queste proprietà della riga di comando sono specifiche a eDrawings ®.

Proprietà | Descrizione
ADDLOCAL Specifica quale porzione dell'applicazione eDrawings installare.
All è l'opzione raccomandata.
Sintassi linea comandi | Funzione
All | Installa tutte le funzioni. L'applicazione eDrawings ricerca applicazioni publisher di SOLIDWORKS e AutoCAD per validare l'installazione.
CALS | Visualizza i file CAL nell'eDrawings Viewer
Inventor | Creazione dei file eDrawings dall'applicazione Autodesk Inventor.
eDrawingsViewer | Visualizza eDrawings e altri file.
ProE | Visualizza i file ProE nell'eDrawings Viewer
DXFDWGTranslator | Visualizza i file DXF/DWG in eDrawings Viewer.
Shortcuts | Installa i collegamenti sul desktop.
XML3D | Visualizza i file 3DXML nell'eDrawings Viewer.
INSTALLDIR | Permette di specificare la cartella di installazione per eDrawings
SNLSERVER Immettere porta@nome_server del server SolidNetWork License. Utilizzare il punto e virgola per separare più combinazioni porta@nome_server .

Il nome server della porta per SNLSERVER e SERVERLIST è necessario solo per la configurazione del server SNL di SOLIDWORKS.

L'elenco server di SolidNetWork è un elenco delimitato di stringhe, ognuna delle quali fa riferimento a un numero di porta su un server con il seguente formato:
  • Terna (delimitata da virgole)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

  • Non terna (delimitata da punto e virgola)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

X e Y sono singole cifre. Dopo l’ultimo server nell’elenco, non aggiungere un punto e virgola.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player

Queste proprietà della riga di comando sono specifiche di SOLIDWORKS Composer e SOLIDWORKS Composer Player.

Per SOLIDWORKS Composer:

Proprietà | Descrizione
ACTIVSERIALNUMBER | Numero di serie di SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | Optional. Numero di serie di SOLIDWORKS Composer Player Pro.
ADDLOCAL Facoltativo. Se si installa l'applicazione completa, non è necessario specificare la proprietà ADDLOCAL.
Per un'installazione personalizzata, utilizzare ADDLOCAL con i seguenti elementi richiesti:
  • Licensing
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
È inoltre possibile utilizzare ADDLOCAL con Sync3Dvia, ma non è necessario.
INSTALLDIR | Specifica la cartella di installazione per il software SOLIDWORKS Composer.

Per SOLIDWORKS Composer Player:

Proprietà | Descrizione
ACTIVSERIALNUMBERPLAYERPRO | Optional. Numero di serie di SOLIDWORKS Composer Player Pro.
INSTALLDIR | Specifica la cartella di installazione per il software SOLIDWORKS Composer Player.
Su macchine che non hanno SOLIDWORKS installato, è necessario utilizzare SOLIDWORKS Translator per importare i file in SOLIDWORKS Composer. Per distribuire SOLIDWORKS Translator, è necessario utilizzare il SOLIDWORKS Installation Manager; non è possibile utilizzare la riga di comando.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà della riga di comando per SOLIDWORKS Flow Simulation

Queste proprietà della riga di comando sono specifiche a SOLIDWORKS Flow Simulation.

Proprietà | Descrizione
ACTIVSERIALNUMBER Numero di serie di SOLIDWORKS Flow Simulation standalone.

(Installazioni individuali e installazioni client da un'immagine amministrativa)
CWUPGRADEINSTALL Aggiorna una versione esistente di un particolare software SOLIDWORKS Flow Simulation.
1 | Aggiorna
2 | Nuova installazione; installazione in una nuova directory

(Installazioni individuali e installazioni client da un'immagine amministrativa)
INSTALLDIR Specifica l'installazione per una particolare applicazione SOLIDWORKS Flow Simulation.

(Solo installazioni individuali)
SERVERLIST | Elenco di stringhe delimitate da punti e virgole, ognuno dei quali fa riferimento ad un numero di porta su un server con il formato: xxxxx@nome_server1; yyyyy@nome_server2;& dove x e y sono cifre singole. Dopo l’ultimo server nell’elenco, non aggiungere un punto e virgola.
SOLIDWORKSPATH Specifica la cartella dove è installato il software SOLIDWORKS.

(Installazioni individuali e installazioni client da un'immagine amministrativa)
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà riga di comando di SOLIDWORKS Inspection

Queste proprietà della riga di comando sono specifiche a SOLIDWORKS Inspection.

Propriet | Descrizione
ACTIVSERIALNUMBER | Numero seriale di SOLIDWORKS Inspection. (Installazioni individuali e installazioni client da un'immagine amministrativa)
INSTALLDIR | Specifica l'installazione del software di applicazione di SOLIDWORKS Inspection. (Solo installazioni individuali)
SERVERLIST | Elenco di stringhe delimitate da punti e virgole, ognuno dei quali fa riferimento ad un numero di porta su un server con il formato: xxxxx@nome_server1; yyyyy@nome_server2;& dove x e y sono cifre singole. Dopo l’ultimo server nell’elenco, non aggiungere un punto e virgola.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà della riga di comando di SOLIDWORKS Visualize
Posizioni dei file MSI per immagini amministrative


Proprietà della riga di comando di SOLIDWORKS Visualize

Queste proprietà della riga di comando sono specifiche per SOLIDWORKS Visualize.

Proprietà | Descrizione
ACTIVSERIALNUMBER | Numero di serie di SOLIDWORKS Visualize. (Installazioni individuali e installazioni client da un'immagine amministrativa)
INSTALLDIR | Specifica l'installazione del software di applicazione SOLIDWORKS Visualize. (Solo installazioni individuali)
SERVERLIST | Elenco di stringhe delimitate da punti e virgole, ognuno dei quali fa riferimento ad un numero di porta su un server con il formato: xxxxx@nome_server1; yyyyy@nome_server2;& dove x e y sono cifre singole. Dopo l’ultimo server nell’elenco, non aggiungere un punto e virgola.
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Posizioni dei file MSI per immagini amministrative


Posizioni dei file MSI per immagini amministrative

Per creare immagini amministrative dalla riga di comando, i file .msi dei componenti del prodotto vengono memorizzati nelle seguenti posizioni sui supporti SOLIDWORKS.

SOLIDWORKS (prodotto principale, in inglese)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (componenti non in lingua inglese)

Cinese tradizionale | swwi\lang\chinese\chinese.msi
Cinese semplificato | swwi\lang\chinese-simplified\chinese-simplified.msi
NewFeature1 | swwi\lang\czech\czech.msi
NewFeature1 | swwi\lang\french\french.msi
NewFeature1 | swwi\lang\german\german.msi
NewFeature1 | swwi\lang\italian\italian.msi
NewFeature1 | swwi\lang\japanese\japanese.msi
NewFeature1 | swwi\lang\korean\korean.msi
NewFeature1 | swwi\lang\polish\polish.msi
Portoghese brasiliano | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
NewFeature1 | swwi\lang\russian\russian.msi
NewFeature1 | swwi\lang\spanish\spanish.msi
NewFeature1 | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace per SOLIDWORKS

marketplace\3dexperience marketplace.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage Client

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional fornisce un'API, ma è disponibile solo per il Client e non è disponibile in un file .msi. Per ulteriori informazioni, vedere la Guida API nella directory install\API del client di SOLIDWORKS PDM.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
Argomento principale Proprietà della riga di comando
Proprietà di funzione della riga di comando
Proprietà globali della riga di comando
eDrawings Proprietà della riga di comando
Proprietà della riga di comando di SOLIDWORKS Composer/Composer Player
Proprietà della riga di comando per SOLIDWORKS Flow Simulation
Proprietà riga di comando di SOLIDWORKS Inspection
Proprietà della riga di comando di SOLIDWORKS Visualize


Distribuzione di un'immagine amministrativa mediante Microsoft Active Directory

La distribuzione tramite Microsoft Active Directory è supportata per la distribuzione del prodotto principale SOLIDWORKS ai client.

Microsoft Active Directory è un servizio di directory per la gestione dei client e dei server negli ambienti in rete. Semplifica la gestione, la migrazione e l'utilizzo.

Per informazioni su come installare SOLIDWORKS mediante Microsoft Active Directory, contattare il proprio rivenditore.

Argomento principale Distribuzione dalla riga di comando
Preparazione dei client per l'installazione da riga di comando di un'immagine amministrativa
Installazione da un'immagine amministrativa mediante la riga di comando
Proprietà della riga di comando


Amministrazione delle installazioni multiple

Per installazioni multiple, le operazioni amministrative comprendono l'aggiornamento delle immagini amministrative alle nuove release, l'aggiornamento dei prodotti tramite Service Pack e la rimozione delle installazioni.

Indice

  • Aggiornamento di immagini amministrative a una nuova release

    Per aggiornare i client che hanno installato da un'immagine amministrativa, aggiornare prima l'immagine amministrativa e quindi configurare i client perché facciano riferimento alla nuova copia dell'immagine.

  • Amministrazione aggiornamento del prodotto con Service Pack

    Gli aggiornamenti di prodotto con Service Pack possono contenere correzioni per la maggiore affidabilità del sistema, per la compatibilità del programma, per un livello di protezione migliore ecc.

  • Rimozione di un'installazione

    Un'installazione può essere rimossa in un ambiente server/client o su un computer individuale.

Argomento principale Installazioni multiple
Distribuzione su più client
Uso di immagini amministrative
Distribuzione dalla riga di comando


Aggiornamento di immagini amministrative a una nuova release

Per aggiornare i client che hanno installato da un'immagine amministrativa, aggiornare prima l'immagine amministrativa e quindi configurare i client perché facciano riferimento alla nuova copia dell'immagine.

Eseguire la Gestione installazioni di SOLIDWORKS dalla Pagina dei download SOLIDWORKS in modo che i file corretti siano referenziati.

Una volta aggiornata l'immagine amministrativa creando una nuova copia dell'immagine, i client possono essere aggiornati in modo da creare riferimenti alla nuova copia dell'immagine amministrativa.

Se i client fanno riferimento alla versione precedente dell'immagine amministrativa usando una directory condivisa, è possibile ridefinire quella directory condivisa usando la posizione dell'immagine amministrativa aggiornata.

Indice

  • Download dei file di installazione aggiornati per le immagini amministrative

    La Gestione installazioni di SOLIDWORKS è in grado di rilevare quando sono necessari file di installazione aggiornati per un'immagine amministrativa.

  • Aggiornamento di un'immagine amministrativa

    Per aggiornare un'immagine amministrativa, la Gestione installazioni SOLIDWORKS crea una nuova directory immagine. Si indica quindi ai client di utilizzare la nuova directory dell'immagine amministrativa per aggiornare alla nuova versione del prodotto.

  • Aggiornamento dei client dalle immagini amministrative

    La Gestione installazioni SOLIDWORKS può aggiornare automaticamente i computer client installati da un'immagine amministrativa.

Argomento principale Amministrazione delle installazioni multiple
Amministrazione aggiornamento del prodotto con Service Pack
Rimozione di un'installazione


Download dei file di installazione aggiornati per le immagini amministrative

La Gestione installazioni di SOLIDWORKS è in grado di rilevare quando sono necessari file di installazione aggiornati per un'immagine amministrativa.

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella schermata introduttiva, selezionare Immagine amministrativa.
  3. Nella schermata Numero seriale, immettere il numero seriale di SOLIDWORKS.
    La Gestione installazioni verifica il sito Web di SOLIDWORKS per i prodotti con licenza e i Service Pack disponibili.
  4. Nella schermata Versione più recente disponibile, selezionare Sì, fare il download ed installare una nuova versione: versione.
    Gestione installazioni di SOLIDWORKS avvia una nuova sessione per installare la versione più recente.
  5. In caso di problemi con la cartella di download, potrebbero apparire le Opzioni di download, nel qual caso accettare la directory di default per i nuovi file di installazione o immettere un nuovo nome di directory.
    Se appare un messaggio che la directory non esiste, fare clic su Sì per crearla.
  6. Nella schermata Download completato, fare clic su Chiudi per chiudere l'installatore corrente e avviarlo per la nuova versione.
Argomento principale Aggiornamento di immagini amministrative a una nuova release
Aggiornamento di un'immagine amministrativa
Aggiornamento dei client dalle immagini amministrative


Aggiornamento di un'immagine amministrativa

Per aggiornare un'immagine amministrativa, la Gestione installazioni SOLIDWORKS crea una nuova directory immagine. Si indica quindi ai client di utilizzare la nuova directory dell'immagine amministrativa per aggiornare alla nuova versione del prodotto.

Questa procedura presume che si siano scaricati i file di installazione aggiornati per l'immagine amministrativa. Per i dettagli, vedere Download dei file di installazione aggiornati per le immagini amministrative.

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella schermata introduttiva, selezionare Immagine amministrativa.
    Verranno visualizzate le opzioni di creazione dell'immagine amministrativa:
    Opzione | Descrizione
    Creare una nuova immagine usando le impostazioni di default. | Creare l'immagine usando le impostazioni di configurazione di default (cioè non basate sulle impostazioni stabilite per un'immagine amministrativa esistente presso il sito).
    Creare una nuova immagine usando le impostazioni e i file da un'immagine esistente. | Creare l'immagine usando le impostazioni di configurazione specificate da un'immagine amministrativa esistente presso il sito. Fare clic su Sfoglia per specificare la directory di installazione dell'immagine amministrativa esistente.
  3. Nella schermata Numero seriale, controllare il numero seriale.
  4. Nella schermata Sintesi (Pronto a creare immagine), verificare che le opzioni dell'immagine amministrativa siano corrette.
    Per i dettagli sulle varie opzioni di un'immagine amministrativa e per l'installazione, fare clic su CAMBIA per aprire la pagina delle opzioni, quindi fare clic su ?.
  5. Per creare una nuova versione dell'immagine amministrativa, fare clic su Crea ora.

È ora possibile aggiornare i client a questa nuova versione dell'immagine amministrativa. Per i dettagli, vedere Aggiornamento dei client dalle immagini amministrative.

Argomento principale Aggiornamento di immagini amministrative a una nuova release
Download dei file di installazione aggiornati per le immagini amministrative
Aggiornamento dei client dalle immagini amministrative


Aggiornamento dei client dalle immagini amministrative

La Gestione installazioni SOLIDWORKS può aggiornare automaticamente i computer client installati da un'immagine amministrativa.

Tipicamente, le immagini amministrative sono organizzate in cartelle su un server. Per supportare l'aggiornamento automatico dei clienti, l'immagine amministrativa di SolidWorks dovrà trovarsi in una cartella condivisa.

Dopo l'aggiornamento dell'immagine amministrativa, l'installazione originale sarà in una cartella e l'installazione aggiornata sarà in un'altra. Per usare l'installazione aggiornata, rimuovere prima di tutto l'opzione di condivisione dalla cartella dell'immagine amministrativa originale ed aggiungere l'opzione di condivisione alla cartella dell'immagine amministrativa aggiornata.

Quando SOLIDWORKS inizia su una macchina client installata da un'immagine amministrativa originale, visualizza la nuova versione e aggiorna il client.
Inoltre, quando SOLIDWORKS lancia un aggiornamento, gli altri prodotti installati da un'immagine amministrativa vengono automaticamente aggiornati.
Argomento principale Aggiornamento di immagini amministrative a una nuova release
Download dei file di installazione aggiornati per le immagini amministrative
Aggiornamento di un'immagine amministrativa

Rimozione dell'opzione Condivisione dalla cartella dell'immagine amministrativa originale

Quando si aggiorna un'immagine amministrativa con accesso da una cartella condivisa, è necessario rimuovere la condivisione dalla cartella originale.

  1. navigare alla cartella dove i file dell'immagine amministrativa originale sono ubicati.
  2. Fare clic con il pulsante destro del mouse sulla cartella e selezionare Proprietà.
  3. Nella scheda Condivisione, selezionare Non condividere questa cartella e fare clic su OK.

Aggiungere l'opzione di condivisione alla cartella dell'immagine amministrativa aggiornata, come descritto in Aggiunta dell'opzione Condivisione a una cartella dell'immagine amministrativa aggiornata.

Aggiunta dell'opzione Condivisione a una cartella dell'immagine amministrativa aggiornata

Una volta creata la cartella aggiornata dell'immagine amministrativa e dopo aver disattivato la condivisione per la cartella originale, è necessario aggiungere l'opzione Condivisione alla nuova cartella per riattivare l'immagine amministrativa.

  1. navigare alla cartella dove i file dell'immagine amministrativa aggiornata sono ubicati.
  2. Fare clic con il pulsante destro del mouse sulla cartella e selezionare Proprietà.
  3. Nella scheda Condivisione, specificare le proprietà di condivisione appropriate per la propria azienda o gruppo e modificare il nome di condivisione con il nome usato per la cartella delle immagini amministrative.
I computer con installazione dalla posizione condivisa dell'immagine amministrativa originale si aggiorneranno automaticamente alla nuova versione all'avvio di SOLIDWORKS.


Amministrazione aggiornamento del prodotto con Service Pack

Gli aggiornamenti di prodotto con Service Pack possono contenere correzioni per la maggiore affidabilità del sistema, per la compatibilità del programma, per un livello di protezione migliore ecc.

L'utente può acquisire gli aggiornamenti del prodotto in due modi:
  • Utilizzando Gestione installazioni SOLIDWORKS per verificare la disponibilità, scaricare e installare gli aggiornamenti.

    Gestione installazioni SOLIDWORKS può essere avviata manualmente o pianificata per controllare periodicamente gli aggiornamenti.

  • Scaricando i Service Pack manualmente dal sito Web del supporto SOLIDWORKS.

    I service pack vengono applicati come patch ad una versione esistente del software. Ad esempio, SOLIDWORKS 2025 SP1.0 è un Service Pack per SOLIDWORKS 2025 SP0.0. Questi Service Pack possono essere installati tramite la Gestione installazioni di SOLIDWORKS 2025; non è possibile installarli utilizzando la Gestione installazioni SOLIDWORKS in SOLIDWORKS 2024.

    Per informazioni su come scaricare e installare i Service Pack, consultare la documentazione di installazione per la versione di SOLIDWORKS da aggiornare.

Indice

  • Annullamento dei Service Pack in un'immagine amministrativa

    Si può riportare un'immagine amministrativa ad un Service Pack precedente. Se il software SOLIDWORKS viene installato dai CD, sarà necessario il CD originale per ripristinare un Service Pack. Sarà necessario avere una copia dell'immagine amministrativa precedente.

Argomento principale Amministrazione delle installazioni multiple
Aggiornamento di immagini amministrative a una nuova release
Rimozione di un'installazione


Annullamento dei Service Pack in un'immagine amministrativa

Si può riportare un'immagine amministrativa ad un Service Pack precedente. Se il software SOLIDWORKS viene installato dai CD, sarà necessario il CD originale per ripristinare un Service Pack. Sarà necessario avere una copia dell'immagine amministrativa precedente.

Le immagini amministrative che sono state aggiornate non possono essere riportate ad un Service Pack precedente. Le immagini amministrative create con qualsiasi metodo diverso dalla Gestione installazioni SOLIDWORKS non potranno essere riportate ad una versione precedente. I client installati da queste immagini amministrative devono essere disinstallati e quindi reinstallati con un'immagine amministrativa creata dalla versione precedente.
  1. Cancellare la cartella che contiene l'immagine amministrativa corrente. A tale fine, aprire la finestra Prompt dei comandi e digitare:
    rmdir /s/q percorso_immagine_amministrativa_corrente
  2. Spostare la copia di backup dell'immagine amministrativa nella posizione in cui è stata eliminata l'immagine amministrativa corrente. A tale fine, aprire la finestra Prompt dei comandi e digitare:
    move percorso_backup_immagine_amministrativa percorso_immagine_amministrativa_corrente
    Dopo avere ripristinato la versione precedente di un'immagine amministrativa, i computer client saranno riportati la versione precedente all'esecuzione successiva del software SOLIDWORKS.
Argomento principale Amministrazione aggiornamento del prodotto con Service Pack


SOLIDWORKS PDM e SOLIDWORKS Manage

SOLIDWORKS PDM è un prodotto per la gestione dei documenti basato sull'architettura client/server precedentemente conosciuta come SOLIDWORKS Enterprise PDM. SOLIDWORKS PDM è disponibile in due tipi:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM utilizza un database Microsoft SQL Server per gestire i vault.

Questa tabella elenca i sistemi database, componenti server e le opzioni client disponibili per ogni tipo di prodotto.
 | PDM Standard | PDM Professional
Progettato per | Reti aziendali di piccole e medie dimensioni, generalmente con meno di 20 utenti simultanei. | Reti aziendali di grandi dimensioni, numerosi utenti simultanei
Limiti | Dimensioni inferiori a 1 socket o 4 core, 1 GB di RAM e 10 GB di database | Limiti SQL Standard: Dimensioni inferiori a 4 socket o 16 core, 128 GB di RAM e 524 PB di database
Sistema di gestione database | Microsoft SQL Server Express 2019 o versioni successive fino alla 2022. | Microsoft SQL Server 2019 o versioni successive fino alla 2022.
Richiede SolidNetWork License Manager? | Sì | Sì
Include il server archivio e il server database? | Sì | Sì
Include SOLIDWORKS PDM Web2 Server e WebAPI Server? | No | Sì
Tipi di client | Nativo | Nativo, basato su browser
Aggiunte del client per CAD Editors | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Integrazione Microsoft Office
Aggiunte del client per Contributors | DraftSight | DraftSight, Microsoft Office Integration
Aggiunte del client per Viewers |  | Integrazione con Microsoft Office

SOLIDWORKS Manage Professional offre strumenti avanzati di gestione dati per SOLIDWORKS PDM Professional. Offre funzionalità per un controllo della versione avanzato e per la gestione dei progetti, dei processi e degli elementi. Dashboard e rapporti interattivi aiutano a tenere traccia degli elementi, delle attività e dei progressi ottenuti durante il completamento dei progetti.

SOLIDWORKS Manage Professional ha un'architettura simile a quella di SOLIDWORKS PDM Professional. Utilizza un'architettura client-server, con un database Microsoft SQL Server, per gestire gli elementi e i dati del progetto. Vi sono tre servizi per database, server file e funzioni server Web, che supportano sia thick client che client browser Web. I tre servizi possono essere ospitati sullo stesso server o su server separati. Gli utenti che dispongono di licenze SOLIDWORKS Manage Professional Editor possono utilizzare il componente aggiuntivo SOLIDWORKS Manage, per accedere ai dati di gestione direttamente da SOLIDWORKS.

È possibile utilizzare Gestione installazioni SOLIDWORKS per installare il server e il client di SOLIDWORKS Manage Professional.

Per istruzioni sull'installazione di SOLIDWORKS Manage Professional, consultare la Guida di installazione di SOLIDWORKS PDM/SOLIDWORKS Manage.

Indice

  • Elenco di componenti server PDM

  • Differenze tra i client PDM

    Prima di installare il software client, è necessario determinare i client necessari a seconda dell'ambiente PDM in uso.

  • Prima di installare il server PDM

    Tenere a mente questi requisiti prima di installare i componenti server PDM:

  • Installazione del server PDM mediante la Gestione installazioni SOLIDWORKS

    Quando si installa il server PDM per PDM standard, è possibile installare il server di archivio, il server del database e il client PDM CAD Editor sulla stessa macchina. Non è necessario eseguire l'installazione del client separatamente.

  • Installazione di un client PDM mediante la Gestione installazioni SOLIDWORKS


Elenco di componenti server PDM

In questa tabella vengono riepilogati i componenti di SOLIDWORKS PDM Server.

Server | Funzione | Installazione
Microsoft SQL Server Express per PDM Standard | Gestisce i dati nei vault di dati SOLIDWORKS PDM. | Può essere installato con PDM Standard o utilizzare una versione precedentemente concessa in licenza e installata.
Microsoft SQL Server per PDM Professional | Gestisce i dati nei vault di dati SOLIDWORKS PDM. | Necessario. Si può anche usare una versione precedentemente concessa in licenza e installata.
Client SolidNetWork License Manager | Gestisce licenze SOLIDWORKS PDM. | Deve essere installato prima che possano essere creati nuovi vault. Può essere installato con i componenti server di SOLIDWORKS PDM quando si utilizza la Gestione installazioni SOLIDWORKS.
Server di archivio | Gestisce trasferimenti di file tra i client e l'archivio dei vault e gestisce gli utenti e le relative credenziali. | Necessario. Deve essere installato con PDM Standard o Professional.
Server database | Esamina i database PDM per verificare la presenza di aggiornamenti, gestisce le regole di importazione ed esportazione dati, gestisce il sistema di messaggi e le pianificazioni replica e cold storage. | Necessario. Deve essere installato con PDM Standard o Professional.
Server Web2 | Fornisce l'accesso ai vault su Internet da client basati su browser. | Optional. Può essere installato solo con PDM Professional.
Server API Web | Gli utenti EXALEAD OnePart possono utilizzare un server API Web per indicizzare e recuperare i dati SOLIDWORKS PDM. | Optional. Può essere installato solo con PDM Professional.

I server di archiviazione vengono eseguiti come servizi nell'account di sistema dei computer in cui sono installati. Un server archivio può ospitare più vault sullo stesso computer.

In un'installazione standalone, il server archivio, il server database, il server di licenza e il server API WEB, nonché il database SQL Express o SQL Server, possono essere installati sullo stesso computer.

In un ambiente distribuito, i componenti del server possono trovarsi su computer diversi. SOLIDWORKS PDM Professional supporta inoltre la replica degli archivi del vault e del database SQL Server per migliorare le prestazioni nelle posizioni remote. Per ulteriori informazioni, consultare la Guida di replicazione per SOLIDWORKS PDM Professional.

Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


Differenze tra i client PDM

Prima di installare il software client, è necessario determinare i client necessari a seconda dell'ambiente PDM in uso.

In questa tabella vengono riepilogati i client per SOLIDWORKS PDM Standard:
Tipo di client standard | Descrizione
CAD Editor | Supporta l'uso di file SOLIDWORKS, DWG/DXF, Microsoft Word e Microsoft Excel. Tutti i formati di file gestiti dal plug-in di Office si comportano nello stesso modo in SOLIDWORKS PDM Standard, ad eccezione di Preview.
Contribuente | Supporta l'uso di file SOLIDWORKS, DWG/DXF, Microsoft Word e Microsoft Excel.
Visualizzatore | Consente l'accesso di sola lettura ai vault del file. L'utente può transitare i file attraverso un flusso di lavoro, ma l'utente non può aggiungere o modificare (check-in, check-out, aggiornamento valori) i file.
In questa tabella vengono riepilogati i client per SOLIDWORKS PDM Professional:
Tipo di client Professional | Descrizione
CAD Editor e Web | Supporta tutti i tipi di file, permettendo la gestione avanzata e la visualizzazione dei formati CAD, come SOLIDWORKS. Attraverso aggiunte CAD gli utenti possono accedere a SOLIDWORKS PDM Professional dall’interno dell’applicazione CAD. Gli utenti remoti possono eseguire ricerche nei vault ed eseguire funzioni di base su Internet utilizzando i client Web2.
Contributor e Web | Supporta l’uso di tutti i tipi di file, inclusi i formati CAD. Su questo tipo di client non sono supportate le aggiunte CAD. Gli utenti remoti possono eseguire ricerche nei vault ed eseguire funzioni di base su Internet utilizzando i client Web2.
Visualizzatore | Consente l'accesso di sola lettura ai vault del file. L'utente può transitare i file attraverso un flusso di lavoro, ma l'utente non può aggiungere o modificare (check-in, check-out, aggiornamento valori) i file o utilizzare le aggiunte CAD.
Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


Prima di installare il server PDM

Tenere a mente questi requisiti prima di installare i componenti server PDM:

  • Ottenere diritti amministrativi completi per i computer in cui si intende installare server e client.
  • Verificare che il server database abbia accesso al server archivio tramite la porta TCP 3030 e a SQL Server tramite la porta TCP 1433.
  • Se si intende utilizzare un database SQL Server Express o SQL Server esistente, ottenere il nome del database SQL Server e l'ID e la password dell'account di un amministratore o un proprietario di database SQL Server con accesso in lettura/scrittura al database. Non è possibile utilizzare l'utente tew.
  • Se un client PDM è già installato sul sistema, disinstallarlo. Se si desidera che il server PDM e il client PDM siano sullo stesso sistema, è possibile installarli entrambi dalla pagina Prodotti del server in Gestione installazioni di SOLIDWORKS.
Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


Installazione del server PDM mediante la Gestione installazioni SOLIDWORKS

Quando si installa il server PDM per PDM standard, è possibile installare il server di archivio, il server del database e il client PDM CAD Editor sulla stessa macchina. Non è necessario eseguire l'installazione del client separatamente.

Quando si installa il server PDM per PDM Professional, è possibile includere questi componenti e anche il server Web2 e server API Web.

Per installare un server PDM e i suoi componenti:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina Benvenuto, selezionare Installa componenti server e fare clic su quanto segue:
    • Installare i componenti di SOLIDWORKS PDM Server su questo computer.
    • Installare SolidNetWork License Manager su questo computer.

      Se SolidNetWork License Manager viene installato su questo computer o un altro, questa opzione non viene visualizzata.

  3. Se viene visualizzata la pagina Opzioni SolidNetWork License Manager, immettere un numero seriale e specificare una posizione per la directory, quindi fare clic su Avanti.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi, per SOLIDWORKS PDM Server, fare clic su Cambia.
  6. Nella pagina Opzioni del server SOLIDWORKS PDM:
    1. Per selezionare prodotto server, fare clic su SOLIDWORKS PDM Standard o Professional.
    2. Per Ubicazione installazione, fare clic su Sfoglia per specificare un percorso del file.
    3. In Selezionare funzioni:
      1. Fare clic su Server di archivio, Server database e Client per installare Questi componenti sulla stessa macchina. Se si è in un ambiente distribuito, è possibile installare il server di archivio e il server database eseguendo il gestore installazioni su un'altra macchina.
        • Se un client PDM è già installato sulla macchina, è necessario annullare l'installazione e disinstallare il client. È quindi possibile eseguire la Gestione installazioni SOLIDWORKS per installare il server PDM insieme al client.
        • Il componente client SOLIDWORKS PDM incluso nell'installazione del server SOLIDWORKS PDM include Item Explorer, che non può essere escluso.
      2. Se si sta installando PDM Professional, è anche possibile fare clic su server Web2 e Server API Web.
        Se si sta installando il server API Web, è possibile specificare un valore per il Numero di porta HTTP compreso tra 0 e 65535. Il valore di default è 65453.
    4. In SQL Server, è possibile installare una nuova istanza degli strumenti del database forniti con PDM Server (SQL Server Express per PDM Standard), oppure è possibile specificare nome del database, nome utente e password di un'istanza esistente.
      È necessario installare una versione completa di SQL Server per SOLIDWORKS PDM Professional.
    5. Fare clic su Torna alla Sintesi.
  7. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.

    Quando Gestione installazioni di SOLIDWORKS completa l'installazione, lo strumento Configurazione del server archivio viene avviato. Seguire le indicazioni nella procedura guidata per configurare il server archivio.

Per installare, configurare e risolvere i problemi relativi al server di archivio, al server del database, al server Web2 e ai database SQL Server, consultare gli argomenti pertinenti nella Guida di installazione di SOLIDWORKS PDM.

Indice

  • Modifica di un'installazione di SOLIDWORKS PDM Server

Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


Modifica di un'installazione di SOLIDWORKS PDM Server

Per modificare un'installazione di SOLIDWORKS PDM Server e dei relativi componenti, utilizzare Programmi e funzionalità dal Pannello di controllo di Windows. Non è possibile modificare l'installazione tramite Gestione installazioni di SOLIDWORKS (SLDIM), anche se è stato utilizzato per installare SOLIDWORKS PDM Server.

Argomento principale Installazione del server PDM mediante la Gestione installazioni SOLIDWORKS


Installazione di un client PDM mediante la Gestione installazioni SOLIDWORKS

La versione principale del client SOLIDWORKS PDM deve corrispondere alla versione principale del server SOLIDWORKS PDM. Quando si installa o si aggiorna il SOLIDWORKS PDM Client, accertarsi che le versioni corrispondano.

Per installare un PDM Client:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina Benvenuto, selezionare Installa su questo computer.
  3. Nella pagina Numero seriale fare clic su Avanti.
    I client SOLIDWORKS PDM non richiedono un numero di serie separato.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi, in Prodotti, fare clic su Cambia.
  6. Nella pagina Selezione prodotto fare clic su Selezionare pacchetti o prodotti diversi.
  7. Nella finestra di dialogo Selezionare il pacchetto da visualizzare selezionare un'edizione di SOLIDWORKS. Quindi fare clic su OK.
  8. Nella pagina Selezione prodotto selezionare SOLIDWORKS PDM Client. Quindi selezionare eDrawings per attivare la funzionalità di anteprima PDM. Se si utilizza una versione di SOLIDWORKS PDM Professional, è inoltre possibile selezionare Item Explorer.
  9. Nella pagina Sintesi espandere Opzioni SOLIDWORKS PDM e fare clic su Cambia.
  10. Nella pagina Opzioni del client SOLIDWORKS PDM selezionare quanto segue e fare clic su Torna alla sintesi:
    • Tipo di prodotto PDM
    • Tipo di client PDM
    • Aggiunte
  11. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.
Gli amministratori possono inoltre utilizzare l'Editor opzione immagine amministrativa per creare e distribuire immagini di client PDM. Per i dettagli, vedere Uso di immagini amministrative.
Argomento principale SOLIDWORKS PDM e SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS Installation Manager consente di installare tutti i componenti di SOLIDWORKS Electrical in modalità standalone o client/server.

SOLIDWORKS Electrical utilizza diversi componenti. Durante l'installazione, è necessario selezionare questi componenti in base al tipo di installazione desiderato.
  • SOLIDWORKS Electrical Schematic: Applicazione 2D per la creazione e la gestione di schemi elettrici.
  • SOLIDWORKS Electrical 3D: componente aggiuntivo di SOLIDWORKS per l'integrazione di schemi 2D con modelli 3D. SOLIDWORKS Electrical 3D consente di gestire il layout di dispositivi elettrici e instradare fili, cavi e cablaggi.
  • Dati: Dati raggruppa tutti i dati richiesti dal software. Questi dati sono grafici (file che rappresentano simboli e blocchi di titoli) o tecnici (cataloghi di produttori e dati associati ai simboli). È possibile condividere i dati in modo che siano accessibili a tutti gli utenti.
  • Collaborative Server: utility per la gestione dell'apertura e dell'aggiornamento dei disegni elettrici.
  • SQL Server: SOLIDWORKS Electrical richiede un database Microsoft SQL Server. Scegliere di creare un nuovo database o utilizzare un database esistente durante l'installazione.

Tipo di installazione

È possibile installare tutti i componenti di SOLIDWORKS Electrical nello stesso computer. Questa è un'installazione standalone. Tutti i dati del programma, ad esempio disegni e rapporti di progetto, vengono memorizzati in un'unica workstation.

È possibile installare i componenti di SOLIDWORKS Electrical anche come applicazione client/server. Utilizzare questo tipo di installazione per memorizzare i dati su un server di rete. L'installazione client/server consente a diversi utenti di lavorare allo stesso progetto. I sistemi client, inoltre, devono disporre dell'accesso di rete al server e dei privilegi di lettura/scrittura per la creazione di progetti, librerie e simboli.

Informazioni

Indipendentemente dal tipo di installazione (standalone o client/server), è necessario avviare la sessione di Windows in modalità con diritti completi per installare SOLIDWORKS Electrical.

Su un computer è possibile installare una sola versione di SOLIDWORKS Electrical. Se si sta installando SOLIDWORKS e si seleziona SOLIDWORKS Electrical come uno dei prodotti da installare, il programma di installazione rimuove la vecchia versione di SOLIDWORKS Electrical.

Quando si avvia SOLIDWORKS Installation Manager, vengono rilevate automaticamente le versioni esistenti di SOLIDWORKS Electrical installate sulla workstation o sul server.

Eseguire sempre il backup dell'ambiente esistente di SOLIDWORKS Electrical prima di installare la nuova versione. Da SOLIDWORKS Electrical Schematic, selezionare File > Archivia ambiente oppure, da SOLIDWORKS Electrical 3D, selezionare SOLIDWORKS Electrical > Strumenti > Archivia ambiente.

Indice

  • Requisiti per l'installazione di SOLIDWORKS Electrical

  • Installazione Standalone o Client/Server

    È possibile installare SOLIDWORKS Electrical in due modalità. In modalità standalone, il software viene installato sulla workstation. In modalità client/server, gli utenti condividono i dati.

  • Configurazione di Collaborative Server

  • Configurazione di Microsoft SQL Server

  • Impostazione dell'ubicazione dei dati


Requisiti per l'installazione di SOLIDWORKS Electrical

Per accedere ai requisiti di sistema correnti, vedere Requisiti di sistema.

Argomento principale SOLIDWORKS Electrical
Installazione Standalone o Client/Server
Configurazione di Collaborative Server
Configurazione di Microsoft SQL Server
Impostazione dell'ubicazione dei dati


Installazione Standalone o Client/Server

È possibile installare SOLIDWORKS Electrical in due modalità. In modalità standalone, il software viene installato sulla workstation. In modalità client/server, gli utenti condividono i dati.

SOLIDWORKS Electrical deve sempre connettersi a un'istanza di SQL Server.

Argomento principale SOLIDWORKS Electrical
Requisiti per l'installazione di SOLIDWORKS Electrical
Configurazione di Collaborative Server
Configurazione di Microsoft SQL Server
Impostazione dell'ubicazione dei dati

Installazione standalone

Per una prima installazione, è NECESSARIO installare tutti i componenti sulla workstation.

  • Schemi di SOLIDWORKS Electrical
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • Dati di applicazione
  1. Nella scheda Riepilogo, fare clic su Modifica della sezione Selezione prodotto e selezionare tutti i componenti di SOLIDWORKS Electrical.
  2. Per modificare le opzioni di installazione, nella scheda Riepilogo fare clic su Modifica della sezione Opzioni Electrical. È possibile creare una nuova istanza di SQL Server o utilizzarne una esistente. Per ulteriori dettagli, consultare i capitoli specifici sui dati e su Microsoft SQL Server in questa documentazione. In alternativa, mantenere le opzioni predefinite.
  3. Fare clic su Installa ora per continuare.
Se SOLIDWORKS Electrical è già installato sulla workstation, SOLIDWORKS Installation Manager lo trova automaticamente e chiede di aggiornarlo. Installare tutti i componenti senza modificare Opzioni Electrical.

Installazione client/server

Un'installazione client/server consente di condividere i dati tra più utenti.

In modalità server è necessario installare i seguenti componenti:
  • Collaborative Server
  • Dati di applicazione
  • Server SQL
Sui client è necessario installare i seguenti componenti:
  • Schemi di SOLIDWORKS Electrical
  • SOLIDWORKS Electrical 3D
  1. Sul server installare i componenti del server.
  2. Nella scheda Benvenuti in SOLIDWORKS Installation Manager, fare clic su Installa componente server.
  3. Selezionare l'opzione SOLIDWORKS Electrical.
  4. Nella scheda Riepilogo, è possibile modificare le opzioni di installazione. Per ulteriori dettagli, consultare i capitoli specifici sui dati e su Microsoft SQL Server in questa documentazione. In alternativa, mantenere le opzioni predefinite.
  5. Fare clic su Installa ora per continuare.
  6. Sui client installare le applicazioni.
  7. Nella scheda Benvenuti in SOLIDWORKS Installation Manager, fare clic su Installa su questo computer.
  8. Nella scheda Riepilogo, fare clic su Modifica della sezione Selezione prodotto e deselezionare l'opzione Electrical Server.
  9. Nella scheda Riepilogo, fare clic su Modifica della sezione Opzioni Electrical e modificare le impostazioni per collegarsi al server.
  10. Fare clic su Installa ora per continuare.
Se SOLIDWORKS Electrical è già installato sulla workstation o sul server, SOLIDWORKS Installation Manager lo trova automaticamente e chiede di aggiornarlo. Per aggiornare il software, utilizzare la stessa procedura della prima installazione.


Configurazione di Collaborative Server

Collaborative Server è un servizio di Windows che deve essere sempre in esecuzione e deve disporre di una comunicazione bidirezionale costante e ininterrotta con i client tramite firewall e programmi antivirus.

Per installare Collaborative Server in modalità individuale o server, è necessario specificare i seguenti parametri:
  • Il nome del della macchina (ad es. LOCALHOST o MiaMacchina), oppure il relativo indirizzo IP (ad es. 127.0.0.1 o 192.168.999.999).
  • Il numero di porta (per impostazione predefinita 26666).

È possibile configurare Collaborative Server durante l'installazione o in un secondo momento nel comando Strumenti > Impostazioni dell'applicazione.

Per consentire una comunicazione bidirezionale ininterrotta, assicurarsi che i numeri di porta da 26666 a 26676 (quando 10 utenti sono connessi contemporaneamente) siano disponibili sul sistema in cui Collaborative Server è installato. In alternativa, chiedere all'amministratore di sistema di trovare un'altra porta per SOLIDWORKS Electrical.

Argomento principale SOLIDWORKS Electrical
Requisiti per l'installazione di SOLIDWORKS Electrical
Installazione Standalone o Client/Server
Configurazione di Microsoft SQL Server
Impostazione dell'ubicazione dei dati


Configurazione di Microsoft SQL Server

Verificare che per qualsiasi tipo di installazione di SOLIDWORKS Electrical sia disponibile una variante del database SQL Server. È possibile utilizzare un database SQL Server esistente se è già installato nel sistema o installare una nuova variante come parte dell'installazione di SOLIDWORKS Electrical.

Quando si installa una nuova istanza di SQL Server, l'installazione di SOLIDWORKS fornisce una versione gratuita di Microsoft SQL Express 2022. Questa versione è limitata a 1 CPU, 1 GB di memoria e 10 GB di dati. I limiti di memoria e CPU sono sufficienti per supportare 10 utenti simultanei.

Se si installa SQL Express 2022, assicurarsi che il software e l'hardware del server soddisfino i requisiti elencati in Requisiti del sistema.

Come pratica consigliata, se sullo stesso server sono presenti più di 10 utenti simultanei, è necessario acquistare e installare una versione completa di SQL Server. Attenersi al flusso di lavoro descritto per installare SOLIDWORKS Electrical con un'istanza esistente di SQL Server.

Per informazioni su SQL Express 2022, consultare la documentazione di Microsoft SQL Server.

Argomento principale SOLIDWORKS Electrical
Requisiti per l'installazione di SOLIDWORKS Electrical
Installazione Standalone o Client/Server
Configurazione di Collaborative Server
Impostazione dell'ubicazione dei dati

Gestione dei dati in SOLIDWORKS Electrical

Molti programmi utilizzano un solo database che contiene tutti i dati del programma. Questo non avviene con SOLIDWORKS Electrical. A ogni progetto in SOLIDWORKS Electrical è assegnato un numero di ID univoco e a ogni progetto è correlato un database che può essere identificato in base a tale ID univoco. Ad esempio, se nel Project Manager di SOLIDWORKS Electrical si trova un progetto con ID 112, il database associato è denominato "tew_project_data_112".

La disponibilità di un database univoco per ogni progetto consente di ridurre in modo significativo i tempi di elaborazione. Inoltre, in caso di errore critico del database, viene interessato dall'errore un solo progetto, garantendo l'integrità della maggior parte delle informazioni del programma.

Tuttavia, alcune aziende prevedono policy che limitano la creazione di nuovi database. Per eseguire SOLIDWORKS Electrical, non deve essere presente nessuna restrizione alla creazione di nuovi database da parte degli utenti. Per assicurarsi che le impostazioni di configurazione non impediscano agli utenti di creare nuovi database, rivolgersi all'amministratore del database o di sistema.

Nuove istanze di SQL Server

Se si installa una nuova istanza di SQL Server, è necessario disporre di diritti amministrativi completi per il server e qualsiasi sistema client. È inoltre necessario assicurarsi che i client dispongano di privilegi di lettura/scrittura per il database in modo che sia possibile creare e modificare progetti, librerie, simboli e altri dati di progetto.

Quando si installa una nuova istanza di SQL Server, selezionare un nome diverso dal nome di default.

Istanze esistenti di SQL Server

Per installare nuovi database di SOLIDWORKS Electrical o connettersi a un'installazione di SOLIDWORKS Electrical su una variante già esistente di SQL Server, è necessario disporre di un account dell'utente con diritti amministrativi completi per il database di SQL Server.

Per garantire il corretto funzionamento di SOLIDWORKS Electrical, è necessario abilitare SQL Server per l'autenticazione in modalità mista. L'autenticazione in modalità mista consente l'uso delle credenziali Windows o SQL Server.

Per connettersi a un database SQL Server esistente, è possibile utilizzare l'autenticazione di Windows o SQL Server. Inserire un nome utente e una password per un account di accesso Windows o SQL Server con diritti amministrativi completi per SQL Server.

Per connettersi a SQL Server, non è possibile utilizzare l'utente 'TEW'. Per informazioni su come ottenere un account di accesso con le credenziali corrette per SQL Server, contattare l'amministratore di SQL Server o l'amministratore di sistema.

Database di SOLIDWORKS Electrical

Dopo l'installazione di SOLIDWORKS Electrical, il programma di installazione crea i database indicati di seguito nell'istanza di SQL Server.

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


Impostazione dell'ubicazione dei dati

Per l'ubicazione dei dati, selezionare una directory in cui memorizzare i dati del programma, come parti, modelli e simboli 2D e 3D. Questa posizione deve essere una directory dedicata. Non può essere una directory principale o la stessa directory utilizzata per memorizzare i dati di SOLIDWORKS.

La directory predefinita è C:\ProgramData\SOLIDWORKS Electrical.

Nel caso di un'installazione client/server, è necessario condividere la directory dei dati.

Il programma di installazione crea una nuova cartella denominata Update nella directory predefinita per memorizzare tutti i nuovi dati.

Quando si avvia SOLIDWORKS Electrical per la prima volta, il programma unisce automaticamente i dati memorizzati nella cartella Update con i dati esistenti. Nella procedura guidata Aggiorna dati, è possibile selezionare i dati da aggiungere all'applicazione e al database SQL Server.

Argomento principale SOLIDWORKS Electrical
Requisiti per l'installazione di SOLIDWORKS Electrical
Installazione Standalone o Client/Server
Configurazione di Collaborative Server
Configurazione di Microsoft SQL Server


SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize fornisce una suite di strumenti standalone che abbinano capacità di rendering avanzate a funzioni e flussi di lavoro visivi orientati alla progettazione, in modo da poter creare immagini estremamente realistiche dei modelli CAD 3D.

I prodotti SOLIDWORKS Visualize sono disponibili in due pacchetti:
  • Standard
  • Professional

Una licenza gratuita di SOLIDWORKS Visualize Standard è inclusa con tutte le licenze SOLIDWORKS Professional e Premium con abbonamento attivo. Per i clienti SOLIDWORKS con attivazione di licenze standalone è necessario anche un numero di serie. Rivolgersi all'amministratore di SOLIDWORKS o al rivenditore se non si conosce il numero di serie di SOLIDWORKS Visualize.

SOLIDWORKS Visualize supporta inoltre i tipi di licenza SolidNetWork (SNL), ad esempio la licenza flessibile, e l'attivazione non in linea.

Tramite la Gestione installazioni di SOLIDWORKS (SLDIM), installare SOLIDWORKS Visualize come parte dell'installazione Individuale (Installa su questo computer). Può essere installato come app standalone, il che rappresenta un vantaggio se si desidera usare computer separati per la modellazione e il rendering. Non consuma una licenza SOLIDWORKS.

SOLIDWORKS Visualize Boost è un servizio che consente di distribuire il rendering da un computer che esegue SOLIDWORKS Visualize Professional a uno o più computer in una rete. Durante la generazione dell'immagine del rendering, è possibile eseguire altre attività sul computer e le immagini di rendering finali sono disponibili più rapidamente. È inoltre possibile installare Visualize Boost come parte dell'installazione Individuale (Installa su questo computer) nella Gestione installazioni SOLIDWORKS.

Una licenza gratuita di SOLIDWORKS Visualize Boost è inclusa con tutte le licenze SOLIDWORKS Visualize Professional con abbonamento attivo.
Visualize Boost è un prodotto aggiuntivo esclusivo per Visualize Professional. Visualize Boost non funziona con Visualize Standard.

Indice

  • Requisiti di sistema per SOLIDWORKS Visualize

  • Installazione di SOLIDWORKS Visualize mediante la Gestione installazioni SOLIDWORKS

  • Installazione di Visualize Boost utilizzando la Gestione installazioni di SOLIDWORKS


Requisiti di sistema per SOLIDWORKS Visualize

Per prestazioni e configurazione ottimali di SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost, seguire queste linee guida prima dell'installazione:
  • Assicurarsi di disporre di un numero di serie separato per ciascun prodotto prima di installare SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost.
  • Assicurarsi che ogni computer su cui è in esecuzione SOLIDWORKS Visualize o SOLIDWORKS Visualize Boost soddisfi i requisiti elencati in Requisiti di sistema.
  • Installare l'applicazione di SOLIDWORKS Visualize Boost sul computer di rendering dedicati all'interno della stessa rete. Questi computer devono essere diversi da quelli che eseguono SOLIDWORKS Visualize Professional per eseguire l'analisi delle attività di rendering.
  • Se non viene trovata una GPU applicabile, SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost vengono invece utilizzati come predefiniti per l'unità di elaborazione centrale (CPU). Consultare la Certificazione hardware SOLIDWORKS per ulteriori informazioni su driver e schede grafiche specifiche.

Per il supporto GPU con 3DS Stellar Physically Correct

Modalità rendering preciso di Stellar:
  • Scheda grafica NVIDIA basata almeno sulla microarchitettura Maxwell
  • Versione driver consigliata 538.78 con supporto per CUDA 12.2.
  • Minimo 4 GB di memoria video
Modalità rendering rapido di Stellar:
  • Scheda grafica NVIDIA basata almeno sulla microarchitettura Turing (con RT Core)
  • Utilizza la stessa versione del driver e gli stessi requisiti di memoria della modalità Precisa

Per il supporto GPU con AMD ProRender

Modalità di rendering rapido e Preciso di AMD ProRender:
  • Una GPU e un driver che supportino lo standard Vulkan
Argomento principale SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost


Installazione di SOLIDWORKS Visualize mediante la Gestione installazioni SOLIDWORKS

Per installare SOLIDWORKS Visualize:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina Benvenuto, selezionare Installa su questo computer.
  3. Procedere nel modo seguente:
    1. Nella pagina Numero seriale, espandere Visualizzazione.
    2. Selezionare SOLIDWORKS Visualize e immettere il numero seriale.
    3. Fare clic su Avanti.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.
Seguire le istruzioni della procedura guidata di attivazione del prodotto per attivarlo.

Dopo l'attivazione, fare doppio clic sull'icona del collegamento SOLIDWORKS Visualize sul desktop oppure, dal menu Start di Windows, fare clic su SOLIDWORKS versione > SOLIDWORKS Visualize versione.

Indice

  • Operazioni di postinstallazione

Argomento principale SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost


Operazioni di postinstallazione

Dopo l'installazione vengono eseguite alcune operazioni per configurare SOLIDWORKS Visualize.

Per ulteriori informazioni, vedere Guida introduttiva a SOLIDWORKS Visualize nella Guida in linea di SOLIDWORKS Visualize.

Indice

  • Creazione della cartella Content

  • Accesso alla guida, ai tutorial, alle informazioni di sistema e alle licenze

Argomento principale Installazione di SOLIDWORKS Visualize mediante la Gestione installazioni SOLIDWORKS


Creazione della cartella Content

Alla prima esecuzione del software, SOLIDWORKS Visualize richiede di specificare una posizione in cui creare una cartella Content.

La cartella Content contiene le seguenti sottocartelle in cui è possibile memorizzare le risorse per i progetti:
Sottocartelle | Elementi memorizzati
Videocamere | Videocamere predefinite e salvate
Ambienti | Immagini con elevato range dinamico (HDR)
Tavolozze | Immagini di fondale
Immagini | Rendering e scatti
Aspetti | Materiali nella libreria di aspetti I contenuti si aggiornano all'aggiunta di un aspetto alla libreria.
Modelli | File modello Per impostazione predefinita, SOLIDWORKS Visualize effettua la ricerca prima in questa cartella quando si usa File > Importazione per un modello.
Piastre | Immagini 2D standard per l'uso in piastre posteriori
Progetti | File di progetto nativi in formato .SVPJ
Trame | Trame 2D per l'uso negli aspetti
Argomento principale Operazioni di postinstallazione


Accesso alla guida, ai tutorial, alle informazioni di sistema e alle licenze

Il menu Guida fornisce la documentazione e le opzioni per aggiornare il software e risolvere i problemi relativi al sistema.

Guida di Visualize | Apre la Guida in linea SOLIDWORKS Visualize.
Tutorial su Visualize | Apre MySolidWorks e consente di accedere ai tutorial di SOLIDWORKS Visualize.
Note di distribuzione | Visualizza le note di rilascio online per la versione corrente.
Novità | Visualizza le nuove funzionalità dei prodotti SOLIDWORKS.
Informazioni sul sistema | Effettua un controllo di sistema del software SOLIDWORKS Visualize con l'hardware del PC e consiglia aggiornamenti, laddove necessario.
Verifica aggiornamenti | Controlla se sul server è disponibile l'aggiornamento più recente a SOLIDWORKS Visualize.
Attiva licenza | (licenze bloccate con nodo) Utilizza la procedura guidata Attivazione prodotto SOLIDWORKS per attivare il prodotto.
Disattiva licenza | (licenze bloccate con nodo) Utilizza la procedura guidata Attivazione prodotto SOLIDWORKS per disattivare il prodotto.
SolidNetWork License Manager | Utilizza la procedura guidata Attivazione prodotto SOLIDWORKS per disattivare il prodotto.
Informazioni su Visualize | Visualizza il numero di versione e informazioni sulla licenza della copia di SOLIDWORKS Visualize.
Argomento principale Operazioni di postinstallazione


Installazione di Visualize Boost utilizzando la Gestione installazioni di SOLIDWORKS

Installare Visualize Boost utilizzando la Gestione installazioni di SOLIDWORKS. Richiede un numero seriale separato.

Si consiglia di installare Visualize Boost su computer separati da quelli che eseguono SOLIDWORKS Visualize Professional. È possibile massimizzare le prestazioni di rendering installando Visualize Boost su computer con più unità di elaborazione grafica (GPU).

Per installare SOLIDWORKS Visualize Boost:

  1. Avviare Gestione installazioni SOLIDWORKS.
  2. Nella pagina Benvenuto, selezionare Installa su questo computer.
  3. Procedere nel modo seguente:
    1. Nella pagina Numero seriale, espandere Visualizzazione.
    2. Selezionare SOLIDWORKS Visualize Boost e immettere il numero seriale.
    3. Fare clic su Avanti.
  4. Seguire le istruzioni per gli avvisi di sistema e fare clic su Avanti.
  5. Nella pagina Sintesi accettare i termini del contratto di licenza SOLIDWORKS e fare clic su Installa ora.
Seguire le istruzioni della procedura guidata di attivazione del prodotto per attivarlo.

Dopo l'attivazione, aprire l'app facendo doppio clic sul collegamento sul desktop di SOLIDWORKS Visualize Boost [image].

Indice

  • Configurazione di Visualize Boost

    È possibile configurare la macchina principale Visualize Boost come Coordinatore e le macchine aggiuntive nel cluster di rendering come Nodi.

Argomento principale SOLIDWORKS Visualize e SOLIDWORKS Visualize Boost


Configurazione di Visualize Boost

È possibile configurare la macchina principale Visualize Boost come Coordinatore e le macchine aggiuntive nel cluster di rendering come Nodi.

Visualize Boost consente di eseguire il rendering delle immagini su una singola macchina o su un gruppo di macchine. La configurazione è semplice e intuitiva. Un computer principale, il Coordinatore, gestisce il cluster e distribuisce i processi di rendering da SOLIDWORKS Visualize. Altre macchine, definite Nodi, si connettono al Coordinatore per fornire assistenza con queste attività su una rete. In un'attività di rendering, ogni macchina nel cluster esegue continuamente un'istanza di Visualize Boost.

Per configurare Visualize Boost:

  1. Aprire Visualize Boost:
    • Fare doppio clic sul collegamento sul desktop di Visualize Boost [image].
    • Dal menu Start di Windows, fare clic su SOLIDWORKS < version> > SOLIDWORKS Visualize Boost <version>.
    Dopo l'attivazione, la finestra di Visualize Boost identifica e mostra il nome e l'indirizzo IP della macchina con licenza.
  2. In Visualize Boost, fare clic su File > Impostazioni.
  3. Nella finestra di dialogo Impostazioni:
    1. Selezionare una macchina come Coordinatore. Lasciare l'area del Coordinatore libera durante la configurazione di tutti gli altri Nodi.
    2. Accettare i valori predefiniti di 8001 per la Porta Boost e 8002 per la Porta DStellar.
      È possibile aggiornare queste porte per soddisfare i requisiti di rete. Assicurarsi di aggiungere le eccezioni del firewall per le comunicazioni dei nodi. In caso di domande, rivolgersi all'amministratore di rete.
  4. Opzionale: I parametri aggiuntivi includono:
    Opzione | Descrizione
    Lingua | La macchina utilizza automaticamente la lingua del sistema operativo.
    Tema | Scegliere tra uno sfondo Chiaro o Scuro per il Tema. Questa impostazione interessa SOLIDWORKS Visualize se è installato sulla stessa macchina su cui è installato Visualize Boost.
    Notifiche attivate | Mostra i messaggi da DStellar.Boost nell'area di notifica di Windows.
    Esporta | Salva le impostazioni di configurazione di Visualize Boost in un file .json.
    Importa | Carica le impostazioni esistenti in un'istanza di Visualize Boost in un file .json.
  5. Fare clic su Applica.
Per finalizzare la configurazione, vedere le istruzioni per Lavorare con Visualize Boost.
Argomento principale Installazione di Visualize Boost utilizzando la Gestione installazioni di SOLIDWORKS


Amministrazione delle licenze

Dopo l'installazione, è possibile attivare le licenze SOLIDWORKS singolarmente su ogni computer (attivazione della macchina) oppure installare e attivando licenze di rete mobili su un server (licenze SolidNetWork).

Di solito, le installazioni su computer individuali usano l'attivazione della licenza; tuttavia, è possibile installare il software individualmente e poi controllare le licenze con SolidNetWork License Manager. Inoltre, sebbene i siti di grandi dimensioni di solito usano licenze in rete mobili, è possibile implementare le installazioni da un'immagine amministrativa e successivamente attivare i numeri seriali dai computer individuali.

Indice

  • Amministrazione di licenze individuali

    È possibile specificare una licenza individuale per utilizzare l'attivazione della macchina.

  • Amministrazione delle licenze mediante SolidNetWork License Manager

    SolidNetWork License Manager supporta più client di licenza mediante la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.


Amministrazione di licenze individuali

È possibile specificare una licenza individuale per utilizzare l'attivazione della macchina.

Solitamente, l'amministrazione di licenze individuali implica l'attivazione e la disattivazione delle licenze direttamente dal software SOLIDWORKS.

L'attivazione è un processo di registrazione e immatricolazione per le licenze standalone di SOLIDWORKS (licenze non SolidNetWork). Se la licenza del prodotto non è stata attivata, SOLIDWORKS tenta di attivarla al primo avvio.

A partire da SOLIDWORKS 2022, e in tutte le versioni successive, se è stata acquistata una licenza permanente di SOLIDWORKS, è necessario riattivare la licenza una volta all'anno. Una licenza permanente non scade mai, ma deve essere riattivata. SOLIDWORKS richiede di riattivare la licenza permanente prima della data di riattivazione richiesta.

È possibile disattivare licenze singole facendo clic su [image] > Licenze > Disattiva in SOLIDWORKS.

Argomento principale Amministrazione delle licenze
Amministrazione delle licenze mediante SolidNetWork License Manager

Attivazione di una licenza

Per eseguire i prodotti SOLIDWORKS in un determinato computer, è prima necessario attivare la licenza per tale computer.

L'attivazione richiede l'accesso ad Internet o all'e-mail. Dopo l'attivazione, non sarà più necessario essere online per usare i prodotti. Senza accesso email sul computer dove viene utilizzato questo prodotto, sarà possibile salvare il file di attivazione ed inviarlo da un altro computer.

Questo procedimento svolge le seguenti operazioni:
  • Attiva tutte le licenze del sofware per qualsiasi prodotto SOLIDWORKS.
  • Consente di trasferire i diritti di licenza da un computer all'altro.
  • Può essere effettuata immediatamente (consigliato) o entro trenta giorni dall'installazione.
  • Elimina il bisogno dei dispositivi di sicurezza. Tuttavia, se si eseguono le versioni precedenti dei prodotti SOLIDWORKS che non utilizzano l'attivazione, è necessario mantenere il dispositivo di sicurezza.

Gli amministratori di sistema che devono gestire più numeri di serie possono utilizzare l'editor delle opzioni dell'immagine amministrativa. Per i dettagli, vedere Editor opzioni immagine amministrativa.

Per attivare una licenza:

  1. Avviare SOLIDWORKS.
  2. Avviare l'attivazione del prodotto SOLIDWORKS tramite uno dei metodi seguenti:
    • Se la licenza non è ancora stata attivata nel computer in uso, all'avvio del software SOLIDWORKS si apre automaticamente la finestra Attivazione del prodotto SOLIDWORKS.
    • Se la finestra Attivazione del prodotto SOLIDWORKS non si apre automaticamente, avviare l'attivazione selezionando [image] > Licenze > Attiva.
  3. Selezionare l'elenco Prodotto per specificare la licenza da attivare.
  4. Selezionare l'attivazione automatica via Internet o l'attivazione manuale via email.
  5. Fornire le informazioni di contatto email.
  6. Fare clic su Avanti.
    • Internet: L'attivazione è automatica.
    • Email: Fare clic su Salva per creare un file di richiesta, quindi inviarlo via e-mail all'indirizzo activation@solidworks.com. Quando si riceve l'e-mail contenente il file di risposta, estrarre il file e fare clic su Apri per caricarlo.
      Se richiesto, è possibile uscire e ripetere la procedura di attivazione per aprire il file della risposta.
  7. Fare clic su Fine.
Editor opzioni immagine amministrativa

Riattivazione di una licenza

Se si dispone di licenze permanenti o commerciali dei prodotti SOLIDWORKS 2022 e successivi, è necessario riattivarle una volta all'anno. L'attivazione del prodotto SOLIDWORKS richiede di eseguire questa operazione prima della data di riattivazione richiesta.

Per riattivare una licenza:

  1. Avviare SOLIDWORKS.
    L'attivazione del prodotto SOLIDWORKS chiede di riattivarlo. Per ogni licenza di prodotto SOLIDWORKS, viene visualizzato quanto segue:
    • La data di scadenza dell'attivazione corrente
    • L'azione richiesta per continuare a utilizzare il prodotto, come la riattivazione di una licenza permanente o il rinnovo e la riattivazione di una licenza a termine o di prova.
  2. Fare clic su Riattiva ora per avviare l'attivazione guidata del prodotto.

    Se non si desidera riattivare immediatamente la licenza, fare clic su Chiedi nuovamente in futuro. Ad esempio, in SOLIDWORKS, fare clic su [image] > Licenze > Attiva per avviare l'attivazione guidata del prodotto. Vedere Attivazione di una licenza.

Trasferimento di una licenza

Per trasferire una licenza SolidNetWork a un computer nuovo o aggiornato, disattivarla prima sul server chiavi di licenza di Dassault Systèmes SOLIDWORKS Corporation. Quindi, riattivarla sull'altro computer.

Nel caso in cui non sia possibile disattivare la licenza da Dassault Systèmes SOLIDWORKS Corporation (ad esempio, a causa di un errore del disco rigido), la riattivazione avverrà comunque nella maggior parte dei casi. Se non sono presenti, contattare il proprio rivenditore VAR per ricevere assistenza.

Per spostare una licenza:

  1. In SOLIDWORKS, fare clic su [image] > Licenze > Disattiva e seguire le istruzioni.
  2. Per riattivare la licenza, passare al computer nuovo o aggiornato e attivare la licenza procedendo come per l'attivazione iniziale. Per i dettagli, vedere Attivazione di una licenza.


Amministrazione delle licenze mediante SolidNetWork License Manager

SolidNetWork License Manager supporta più client di licenza mediante la distribuzione delle licenze ai client in rete. Ciò consente al numero di utenti di eccedere il numero di licenze grazie all'uso di licenze mobili.

Questa immagine raffigura una tipica installazione di licenze SolidNetWork:

Questa immagine illustra:
  • Il software SolidNetWork License Manager viene installato e attivato solo sul computer del gestore di licenze.
  • I computer client di licenza non possiedono altro software specifico SolidNetWork.

    Se al momento dell'installazione si specifica il numero di serie di una licenza SolidNetWork, la Gestione installazioni SOLIDWORKS identifica tale computer come un client di licenza SolidNetWork. La Gestione installazioni SOLIDWORKS richiede di specificare il nome del computer di SolidNetWork License Manager e il numero di porta per connettere il client al gestore di licenze.

  • Il gestore di licenze e tutti i client di licenza devono avere connettività TCP/IP.

Indice

  • Panoramica dell'installazione delle licenze SolidNetWork

    Utilizzare SOLIDWORKS Installation Manager per installare SolidNetWork License Manager Server su almeno uno dei computer prima di installare il software client SOLIDWORKS sui computer. Successivamente, è possibile utilizzare l'Attivazione guidata del prodotto per aggiungere e attivare numeri di serie per licenze a tempo indeterminato e a termine.

  • Avvio di SolidNetWork License Manager

    È possibile avviare SolidNetWork License Manager dal menu Start di Windows.

  • Aggiornamento di SolidNetWork License Manager

    Per le release principali di SOLIDWORKS, l'upgrade del gestore di licenze implica la disinstallazione del gestore precedente, l'installazione di un nuovo gestore e la riattivazione della licenza SolidNetWork.

  • Trasferimento di una licenza SolidNetWork

    Per trasferire una licenza SolidNetWork a un computer nuovo o aggiornato, disattivare prima la licenza sul server chiavi di licenza di Dassault Systèmes SOLIDWORKS Corporation, quindi riattivarla sull'altro computer.

  • Eliminazione dei file di licenza SolidNetWork

    È possibile eliminare i file di licenza SolidNetWork scaduti prima di installare nuove licenze.

  • Presa in prestito e restituzione di licenze SolidNetWork

    Una licenza SolidNetWork può essere presa in prestito per usare il software da una postazione remota. Dato che una licenza presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

  • Gestione dell'accesso alle versioni di SOLIDWORKS

    Gli amministratori possono impedire agli utenti di utilizzare versioni specifiche di SOLIDWORKS in un ambiente SolidNetWork. Questa funzionalità consente di gestire le versioni di SOLIDWORKS utilizzate da persone, progetti e business unit diversi.

  • Monitoraggio del tempo di inattività di una licenza

    SOLIDWORKS può registrare il tempo di inattività con il SolidNetWork License Manager, in modo tale che le licenze non utilizzate per un certo periodo di tempo vengano restituite al gruppo delle licenze disponibili.

  • Utilizzo di una licenza temporanea

    Una licenza temporanea "any" può essere utilizzata provvisoriamente quando non è una licenza SolidNetWork.

  • Uso delle licenze SolidNetWork con prodotti aggiuntivi

    È anche possibile usare SolidNetWork License Manager per distribuire le licenze per i prodotti aggiuntivi principali di SOLIDWORKS.

  • Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License

    Gli utenti SolidNetWork License possono controllare quali licenze di SOLIDWORKS® Simulation utilizzare nel proprio gruppo di licenze quando aggiungono SOLIDWORKS Simulation. Inoltre, possono aggiornare la licenza di SOLIDWORKS Simulation senza scaricare l'aggiunta nel caso in cui sia necessario un tipo di licenza superiore per studi più avanzati.

  • Caricamento dei moduli Flow Simulation

    In qualità di cliente con SolidNetWork License, è possibile controllare il caricamento dei moduli aggiuntivi HVAC ed Electronics Cooling per Flow Simulation tramite due metodi.

  • Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics

    Quando si eseguono gli studi SOLIDWORKS Simulation, Plastics o Flow Simulation, le licenze di rete rimangono attive e non scadono. SOLIDWORKS conserva le licenze durante il processo di calcolo, che è considerato un'attività.

  • Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa

    È possibile configurare un computer su una rete in modo che funga da gestore di licenze per distribuire le licenze SolidNetWork e da posizione per l'immagine amministrativa, dalla quale gli utenti possano installare il software SOLIDWORKS.

  • Disinstallazione di SolidNetWork License Manager

    Quando si aggiorna SolidNetWork License Manager, è necessario disinstallare il gestore di licenze vecchio prima di installare quello nuovo.

  • Gestione delle licenze di FlexNet Publisher

    Le licenze SolidNetWork si basano sulla gestione delle licenze di FlexNet Publisher®.

Argomento principale Amministrazione delle licenze
Amministrazione di licenze individuali


Panoramica dell'installazione delle licenze SolidNetWork

Utilizzare SOLIDWORKS Installation Manager per installare SolidNetWork License Manager Server su almeno uno dei computer prima di installare il software client SOLIDWORKS sui computer. Successivamente, è possibile utilizzare l'Attivazione guidata del prodotto per aggiungere e attivare numeri di serie per licenze a tempo indeterminato e a termine.

Quando si installa il software client SOLIDWORKS su un computer, specificare il numero di serie di una licenza SolidNetWork. SOLIDWORKS Installation Manager identifica il computer come client di licenza SolidNetWork e richiede il nome del computer e il numero di porta di SolidNetWork License Manager Server. Viene visualizzato un errore se SolidNetWork License Manager Server non è installato o se il nome o il numero di porta non sono corretti.

Procedura di attivazione

Prima che gli utenti possano eseguire prodotti SOLIDWORKS sui loro computer, è necessario attivare una licenza SolidNetWork sul computer su cui è installato SolidNetWork License Manager Server.

L'attivazione richiede l'accesso e-mail o una connessione Internet attiva. Dopo l'attivazione, non sarà più necessario essere online per usare i prodotti. Senza accesso email sul computer dove viene utilizzato questo prodotto, sarà possibile salvare il file di attivazione ed inviarlo da un altro computer.

Questo procedimento svolge le seguenti operazioni:
  • Attivare SOLIDWORKS SolidNetWork License Manager con le licenze valide per più prodotti SOLIDWORKS.
  • Consente di trasferire i diritti di licenza SolidNetWork da un computer di SolidNetWork License Manager a un altro.
  • Consente di installare e attivare i diritti di licenza SolidNetWork su un computer di SolidNetWork License Manager.
  • Da eseguire prima di utilizzare le licenze SolidNetWork.
  • Elimina il bisogno dei dispositivi di sicurezza. Se si attiva una licenza SolidNetWork per questa versione di SOLIDWORKS, le vengono attivate le licenze SolidNetWork per le versioni precedenti di SOLIDWORKS. Non è più necessario conservare il dispositivo di sicurezza.

Indice

  • Installazione di SolidNetWork License Manager Server

    SolidNetWork License Manager Server supporta più client di licenza. Distribuisce le licenze ai client in rete.

  • Attivazione di SolidNetWork License

    Prima che gli utenti possano eseguire prodotti SOLIDWORKS sui loro computer, è necessario attivare una licenza SolidNetWork sul computer di SolidNetWork License Manager.

  • Attivazione manuale con SolidNetWork License Manager Server

    Quando si installa o si effettua l'upgrade di SolidNetWork License Manager Server, è necessario attivare o riattivare la licenza. È possibile attivare o riattivare la licenza tramite Internet o manualmente.

  • Installazione di client di licenza SolidNetWork

  • Uso di licenze SolidNetWork con i firewall

    Se il computer utilizza un firewall, è necessario configurare le porte per il supporto delle licenze SolidNetWork.

  • Riattivazione di una SolidNetWork License

    La riattivazione deve essere eseguita per i prodotti con licenza SolidNetWork dopo che un'organizzazione ha effettuato l'upgrade di SolidNetWork License Manager alla versione 2022 o una versione successiva. Anche se i prodotti installati sono di una versione precedente, a partire dalla versione 2022 il server richiede la riattivazione una volta l'anno.

  • Installazione del Gestore di licenze a terna

    La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Se il computer che gestisce il file della licenza non è disponibile, uno degli altri due potrà farlo.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Installazione di SolidNetWork License Manager Server

SolidNetWork License Manager Server supporta più client di licenza. Distribuisce le licenze ai client in rete.

Se si intende effettuare l'upgrade da una versione precedente di SolidNetWork License Manager Server che usava dongle hardware per l'attivazione delle licenze, rimuovere il dongle prima di installare la nuova versione di SolidNetWork License Manager Server.

  1. Avviare Gestione installazioni SOLIDWORKS come descritto in Download del supporto di installazione.
  2. Per il tipo di installazione, selezionare Installa componenti server e fare clic su Installare SolidNetWork License Manager (licenze distribuite) su questo computer.
  3. Nella pagina Riepilogo, rivedere il percorso di installazione e lo strumento di download in background, accettare i termini di licenza e fare clic su Installa ora.
  4. Nella procedura guidata Attivazione del prodotto SOLIDWORKS da SolidNetWork License Manager Server, aggiungere un numero di serie e attivare almeno una licenza. Vedere Aggiunta di numeri di serie e attivazione delle licenze SolidNetWork.
Argomento principale Panoramica dell'installazione delle licenze SolidNetWork
Attivazione di SolidNetWork License
Attivazione manuale con SolidNetWork License Manager Server
Installazione di client di licenza SolidNetWork
Uso di licenze SolidNetWork con i firewall
Riattivazione di una SolidNetWork License
Installazione del Gestore di licenze a terna


Attivazione di SolidNetWork License

Prima che gli utenti possano eseguire prodotti SOLIDWORKS sui loro computer, è necessario attivare una licenza SolidNetWork sul computer di SolidNetWork License Manager.

Per attivare una licenza SolidNetWork:

  1. Avviare SolidNetWork License Manager facendo clic su Start > Strumenti di SOLIDWORKS versione > Server SolidNetWork License Managerversione.
  2. Opzionale: Se non si è ancora attivata la licenza SolidNetWork, un messaggio chiede di attivarla. Fare clic su Sì.
    Ciò avvia la procedura guidata Attivazione del prodotto SOLIDWORKS.
  3. Opzionale: Se è attivo un firewall, selezionare Un firewall è in uso su questo server.
  4. Immettere i numeri della porta nella pagina Informazioni sul server di licenza SolidNetWork, quindi fare clic su Avanti.
  5. In N. di serie: selezionare i numeri di serie specifici o fare clic su Seleziona tutto per evidenziare e attivare tutti i numeri di serie SOLIDWORKS.
    1. Selezionare l'opzione di attivazione Automaticamente su Internet (consigliato).
    2. In Informazioni contatto, immettere un indirizzo e-mail.
    La finestra di dialogo Attivazione/Riattivazione riuscita mostra i prodotti attivati con successo.
  6. Fare clic su Fine.
Argomento principale Panoramica dell'installazione delle licenze SolidNetWork
Installazione di SolidNetWork License Manager Server
Attivazione manuale con SolidNetWork License Manager Server
Installazione di client di licenza SolidNetWork
Uso di licenze SolidNetWork con i firewall
Riattivazione di una SolidNetWork License
Installazione del Gestore di licenze a terna


Attivazione manuale con SolidNetWork License Manager Server

Quando si installa o si effettua l'upgrade di SolidNetWork License Manager Server, è necessario attivare o riattivare la licenza. È possibile attivare o riattivare la licenza tramite Internet o manualmente.

Attivazione manuale:
  • Per un nuovo SolidNetWork License Manager Server, l'attivazione deve essere eseguita due volte per configurare correttamente il server. Con la prima attivazione viene inizializzato il sistema di licenze sul server. Con la seconda attivazione viene attivata la licenza.
  • Per un SolidNetWork License Manager Server aggiornato, è necessario riattivare la licenza esistente. Se il server non ha licenze attive, l'attivazione viene eseguita utilizzando Modifica nella scheda Amministrazione del server.
Argomento principale Panoramica dell'installazione delle licenze SolidNetWork
Installazione di SolidNetWork License Manager Server
Attivazione di SolidNetWork License
Installazione di client di licenza SolidNetWork
Uso di licenze SolidNetWork con i firewall
Riattivazione di una SolidNetWork License
Installazione del Gestore di licenze a terna


Installazione di client di licenza SolidNetWork

Quando si installa il software CAD SOLIDWORKS su un computer, deve essere specificato il numero di serie di una licenza SolidNetWork. SOLIDWORKS Installation Manager identifica il computer come client di licenza SolidNetWork e richiede il nome e il numero del computer di SolidNetWork License Manager. Viene visualizzato un errore se SolidNetWork License Manager Server non è installato o se il nome o il numero di porta non sono corretti.

Per installare SOLIDWORKS con una licenza SolidNetWork:

  1. Avviare Gestione installazioni SOLIDWORKS come descritto in Download del supporto di installazione.
  2. Nella pagina di benvenuto, fare clic su Installare su questo computer se questa è la prima installazione di SOLIDWORKS su questo computer per questa release principale.
    Se si aggiorna da una release esistente e si cambia da una licenza individuale alla licenza SolidNetWork, fare clic su Modificare l'installazione individuale (su questo computer). Per i dettagli, vedere Aggiornamento da licenze individuali a licenze SolidNetWork .
  3. Nella finestra di dialogo Aggiungi server, digitare l'indirizzo del SolidNetWork License Manager nel formato:

    porta@Nome computer

    Il numero della porta deve essere identico a quello utilizzato per il computer del gestore di licenze. Il valore predefinito è 25734.

    La Gestione installazioni SOLIDWORKS tenta di confermare che questo SolidNetWork License Manager è accessibile. Se non si è ancora installato un gestore di licenze, questa autenticazione non andrà a buon fine ma si potrà comunque procedere con l'installazione del client di licenza.
  4. Completare l'installazione di SOLIDWORKS attenendosi alle istruzioni della Gestione installazioni.
Argomento principale Panoramica dell'installazione delle licenze SolidNetWork
Installazione di SolidNetWork License Manager Server
Attivazione di SolidNetWork License
Attivazione manuale con SolidNetWork License Manager Server
Uso di licenze SolidNetWork con i firewall
Riattivazione di una SolidNetWork License
Installazione del Gestore di licenze a terna


Uso di licenze SolidNetWork con i firewall

Se il computer utilizza un firewall, è necessario configurare le porte per il supporto delle licenze SolidNetWork.

Nel software del firewall, è necessario aggiungere due porte di licenza SolidNetWork (ad esempio, SNL-in-port e SNL-out-port) all'elenco delle eccezioni del firewall. Per i dettagli sulla configurazione di queste porte, consultare l'amministratore del sistema.

Se si utilizza Windows Firewall su un sistema operativo Windows supportato, è necessario modificare le porte sul computer di SolidNetWork License Manager e modificare il file di licenza SolidNetWork per distribuire le licenze ai computer client.

Modifica delle porte computer del gestore di licenze per Windows Firewall

  1. Fare clic su Start e aprire protezione di Windows.
  2. Selezionare Firewall e Protezione di rete > Impostazioni avanzate e fare clic su Sì per confermare le modifiche.
  3. Nella finestra di dialogo Windows Defender Firewall con sicurezza avanzata, selezionare Regole in entrata > Nuova regola.
  4. In Nuova regola guidata in entrata, selezionare il tipo di regola Porta, quindi fare clic su Avanti.
  5. Digitare il numero di porta in Porte locali specifiche: (ad esempio, 80, 25734, 443), quindi fare clic su Avanti.
  6. Selezionare Nome. Digitare un Nome (ad esempio, SNL-in-port).
  7. Fare clic su Fine.

Modifica delle impostazioni di SolidNetWork License Manager per Windows Firewall

  1. Avviare SolidNetWork License Manager facendo clic su Start > Strumenti di SOLIDWORKS versione > SolidNetWork License Manager Server versione.
  2. Nella scheda Amministrazione del server, in Server di licenza, fare clic su Ferma. Fare clic su Sì per confermare e su OK per arrestare il server di licenza.
  3. In Informazioni sulla licenza, fare clic su Modifica.
  4. In Tipo di server, selezionare la disposizione dei server in rete (Singolo o Terna) e fare clic su Avanti.
  5. In Informazioni server:
    1. Selezionare Un firewall è in uso su questo server.
    2. Numero porta e Numero porta Daemon venditore dovrebbero contenere i numeri di porta specificati per Windows Firewall (per i dettagli, consultare la procedura di cui sopra).
    3. Selezionare File opzioni e fare clic su Sfoglia per individuare il file. Fare clic su Modifica per modificare uno qualsiasi dei suoi parametri.
    Il file di opzioni consente all'amministratore delle licenze di controllare vari parametri di funzionamento di FlexNet Licensing.

    Consigli: Il file di opzioni è collocato nella directory di installazione di SolidNetWork License Manager (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt). Questo file deve trovarsi nella stessa directory del file sw_d.lic.

    Per ulteriori informazioni sul file di opzioni, consultare la Guida amministrativa delle licenze di FlexNet Publisher nella cartella di installazione di SolidNetWork License Manager:

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Argomento principale Panoramica dell'installazione delle licenze SolidNetWork
Installazione di SolidNetWork License Manager Server
Attivazione di SolidNetWork License
Attivazione manuale con SolidNetWork License Manager Server
Installazione di client di licenza SolidNetWork
Riattivazione di una SolidNetWork License
Installazione del Gestore di licenze a terna


Riattivazione di una SolidNetWork License

La riattivazione deve essere eseguita per i prodotti con licenza SolidNetWork dopo che un'organizzazione ha effettuato l'upgrade di SolidNetWork License Manager alla versione 2022 o una versione successiva. Anche se i prodotti installati sono di una versione precedente, a partire dalla versione 2022 il server richiede la riattivazione una volta l'anno.

Entro 30 giorni dalla data di riattivazione, i prodotti SOLIDWORKS in rete avvisano gli utenti della scadenza delle licenze. Gli amministratori devono essere a conoscenza della scadenza per riattivare le licenze in tempo.

Per riattivare una licenza SolidNetWork:

  1. Avviare SolidNetWork License Manager Server facendo clic su Start > Strumenti di SOLIDWORKS versione > SolidNetWork License Manager Server versione.
  2. Nella scheda Amministrazione del server, in Informazioni sulla licenza, fare clic su Riattiva.

  3. In Seriale, selezionare Tutti per tutte le licenze o immettere un numero di licenza per cercare una licenza specifica.

    La finestra di dialogo Riattiva licenze evidenzia in rosso tutte le date di scadenza e riattivazione della licenza entro 30 giorni. Gli asterischi contrassegnano le licenze che richiedono il rinnovo.

  4. Fare clic su Riattiva.
Argomento principale Panoramica dell'installazione delle licenze SolidNetWork
Installazione di SolidNetWork License Manager Server
Attivazione di SolidNetWork License
Attivazione manuale con SolidNetWork License Manager Server
Installazione di client di licenza SolidNetWork
Uso di licenze SolidNetWork con i firewall
Installazione del Gestore di licenze a terna


Installazione del Gestore di licenze a terna

La terna dei gestori di licenze usano tre computer per una maggiore stabilità. Se il computer che gestisce il file della licenza non è disponibile, uno degli altri due potrà farlo.

Requisiti per l'uso di gestori di licenze a terna:
  • Installare i gestori di licenze a terna su computer stabili non programmati per spegnimenti frequenti.
  • I tre computer dei gestori di licenze devono essere sulla stessa sottorete. Non configurare mai i gestori di licenze a terna con comunicazioni lente o con connessione remota.
  • L'amministratore di sistema deve intervenire immediatamente qualora un computer del gestore di licenze si porti fuori linea per riavviarlo non appena possibile.
    Se sono in esecuzione solo due computer del gestore di licenze, la situazione è peggiore rispetto al caso in cui è in esecuzione un solo computer del gestore di licenza perché le probabilità di guasto raddoppiano.

Indice

  • Installazione del gestore di licenze a terna iniziale

    Questa procedura dimostra come installare SolidNetWork License Manager sul primo computer della terna.

  • Installazione del gestore di licenze a terna su altri computer

    Seguire queste istruzioni per installare il software SolidNetWork License Manager sul secondo e terzo computer della terna. La procedura è pressoché identica a quella per installare il software sul computer iniziale, ad eccezione dei passi 2(f) e 2(i).

Argomento principale Panoramica dell'installazione delle licenze SolidNetWork
Installazione di SolidNetWork License Manager Server
Attivazione di SolidNetWork License
Attivazione manuale con SolidNetWork License Manager Server
Installazione di client di licenza SolidNetWork
Uso di licenze SolidNetWork con i firewall
Riattivazione di una SolidNetWork License


Installazione del gestore di licenze a terna iniziale

Questa procedura dimostra come installare SolidNetWork License Manager sul primo computer della terna.

  1. Sul primo computer del gestore di licenze a terna, installare SolidNetWork License Manager mediante la Gestione installazioni SOLIDWORKS:
    1. Avviare Gestione installazioni SOLIDWORKS come descritto in Download del supporto di installazione.
    2. Per il tipo di installazione, selezionare Installa componenti server e fare clic su Installare SolidNetWork License Manager (licenze distribuite) su questo computer.
    3. Nella pagina Riepilogo, rivedere il Percorso di installazione di SolidNetWork License Manager e le Opzioni di download, quindi fare clic su Installa ora per completare il processo di Gestione installazioni SOLIDWORKS.
  2. Utilizzando SolidNetWork License Manager, configurare il computer iniziale del gestore di licenze a terna:
    1. Avviare SolidNetWork License Manager. Fare clic su Start > Strumenti SOLIDWORKS versione > SolidNetWork License Manager Server versione.

      Dato che si tratta della prima volta che SolidNetWork License Manager viene eseguito su questo computer, un messaggio chiede se si desidera attivare ora.

    2. Fare clic su No.

      Si apre la scheda Amministrazione del server di SOLIDWORKS SolidNetWork License Manager.

    3. Nella scheda Amministrazione del server, fare clic in Opzioni avanzate, fare clic su Opzioni.
    4. In Modalità di licenza del server SolidNetWork, fare clic su Usa un file di licenza e fare clic su OK.
    5. In Informazioni sulla licenza, fare clic su Modifica.
      Compare la Creazione guidata del file di licenza SolidNetWork.
    6. In Tipo di server, selezionare Terna e fare clic su Avanti.
    7. Nel riquadro Informazioni sul server, verificare che il nome del computer e il numero di porta del computer iniziale del gestore di licenze a terna siano corretti e fare clic su Avanti.

      Verificare che l'indirizzo NIC (Network Interface Card) corrisponda alle informazioni contenute nel file di licenza ricevuto da SOLIDWORKS e che il numero di porta del computer del gestore di licenze a terna sia corretto. L'indirizzo NIC è denominato anche indirizzo MAC (Media Access Control). Fare quindi clic su Avanti.

      Per individuare l'indirizzo NIC, aprire una finestra del Prompt dei comandi e digitare:

      ipconfig /all

      Inoltre, se sul computer è attivo un firewall, potrebbe essere necessario selezionare altre opzioni in questa schermata. Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.

    8. Nella schermata Informazioni sul server del Partner a terna, immettere il nome del computer e l'ID host degli altri due computer di gestione licenza della terna e fare clic su Avanti.
      Ciò assicura che, qualora un gestore di licenze a terna non sia accessibile, i computer client potranno ottenere una licenza da uno degli altri due server.
    9. Nella schermata Licenze, fare clic su Leggi per identificare e aprire il file di licenza SolidNetWork.
      Le licenze appariranno nella Creazione guidata del File di licenza SolidNetWork. Per questo computer, utilizzare il file di licenza ricevuto dal VAR o dall'Assistenza clienti di Dassault Systèmes SOLIDWORKS.
    10. Fare clic su Fine.
    11. Fare clic su OK per uscire, quindi su Fine per chiudere SolidNetWork License Manager.
Argomento principale Installazione del Gestore di licenze a terna
Installazione del gestore di licenze a terna su altri computer
Uso di licenze SolidNetWork con i firewall


Installazione del gestore di licenze a terna su altri computer

Seguire queste istruzioni per installare il software SolidNetWork License Manager sul secondo e terzo computer della terna. La procedura è pressoché identica a quella per installare il software sul computer iniziale, ad eccezione dei passi 2(f) e 2(i).

Il presupposto di partenza è che si sia già installato almeno un gestore di licenze a terna su un altro computer.

  1. Sul computer del gestore di licenze a terna, installare SolidNetWork License Manager mediante la Gestione installazioni SOLIDWORKS:
    1. Avviare Gestione installazioni SOLIDWORKS come descritto in Download del supporto di installazione.
    2. Per il tipo di installazione, selezionare Installa componenti server e fare clic su Installare SolidNetWork License Manager (licenze distribuite) su questo computer.
    3. Nella pagina Riepilogo, verificare il Percorso di installazione di SolidNetWork License Manager e le Opzioni di download, quindi fare clic su Installa ora per completare il processo di Gestione installazioni SOLIDWORKS.
  2. Utilizzando SolidNetWork License Manager, configurare il computer del gestore di licenze a terna:
    1. Avviare SolidNetWork License Manager. Fare clic su Start > Strumenti SOLIDWORKS versione > SolidNetWork License Manager Server versione.
      Dato che si tratta della prima volta che SolidNetWork License Manager viene eseguito su questo computer, un messaggio chiede se si desidera attivare ora.
    2. Fare clic su No.
      Si apre la scheda Amministrazione del server del SOLIDWORKS SolidNetWork License Manager.
    3. In Opzioni avanzate, fare clic su Opzioni.
      Viene visualizzata la finestra di dialogo Opzioni avanzate.
    4. In Modalità di licenza del server SolidNetWork, fare clic su Usa un file di licenza e fare clic su OK.
      La finestra di dialogo Opzioni avanzate si chiude.
    5. In Informazioni sulla licenza, fare clic su Modifica.
      Compare la Creazione guidata del file di licenza SolidNetWork.
    6. In Tipo di server, selezionare Terna e Sincronizzazione delle informazioni su server/licenza, quindi fare clic su Avanti.
    7. Nella schermata Informazioni sul server triade, specificare il nome del computer e l'ID host. Fare quindi clic su Avanti.
      Ciò assicura che qualora un gestore di licenze non sia accessibile, i computer client potranno ottenere una licenza da uno degli altri due server.
    8. Nella schermata Licenze, fare clic su Leggi per identificare e aprire il file di licenza SolidNetWork.
      Le licenze appariranno in Creazione guidata del file di licenza SolidNetWork.
    Il file di licenza viene generato dal primo computer del gestore di licenze a terna configurato. Generalmente, il file delle licenze si trova in \licenses\sw_d.lic. Ad esempio: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. Fare clic su Fine.
      Compare un'avvertenza della Creazione guidata del file di licenza SolidNetWork.
    2. Fare clic su OK per chiudere la procedura guidata File di licenza SolidNetWork e quindi su Fine per uscire dal SolidNetWork License Manager.

Ripetere la procedura per il terzo computer del gestore di licenze a terna.

Argomento principale Installazione del Gestore di licenze a terna
Installazione del gestore di licenze a terna iniziale


Avvio di SolidNetWork License Manager

È possibile avviare SolidNetWork License Manager dal menu Start di Windows.

In Windows, fare clic su Start > Strumenti di SOLIDWORKS versione > SolidNetWork License Manager Server versione.

È possibile utilizzare lo stesso percorso dal menu Start di Windows per aprire SolidNetWork License Manager Client versione.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Aggiornamento di SolidNetWork License Manager

Per le release principali di SOLIDWORKS, l'upgrade del gestore di licenze implica la disinstallazione del gestore precedente, l'installazione di un nuovo gestore e la riattivazione della licenza SolidNetWork.

Il gestore di licenze di una release più recente può distribuire licenze ai computer client che non aggiornano ma restano alla release precedente.

  1. Avviare SolidNetWork License Manager facendo clic su Start > Strumenti di SOLIDWORKS versione > SolidNetWork License Manager Server versione.
  2. Nella scheda Uso della licenza, verificare che nessun client in rete abbia in esecuzione SOLIDWORKS.
  3. Disinstallare la vecchia gestione licenze. Per i dettagli, vedere Disinstallazione di SolidNetWork License Manager.
  4. Installare il nuovo gestore di licenze e riattivare la licenza SolidNetWork sul computer del gestore di licenze. Per i dettagli, vedere Installazione di SolidNetWork License Manager Server.

Se si aggiorna SolidNetWork License Manager su un computer che esegue anche l'applicazione SOLIDWORKS, aggiornare prima i SolidNetWork License Manager e i client e solo successivamente installare su tale computer i nuovi Service Pack di SOLIDWORKS.

Se si aggiorna il gestore di licenze su un computer che ospita immagini amministrative, aggiornare il gestore di licenze prima delle immagini amministrative. Per i dettagli, vedere Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Trasferimento di una licenza SolidNetWork

Per trasferire una licenza SolidNetWork a un computer nuovo o aggiornato, disattivare prima la licenza sul server chiavi di licenza di Dassault Systèmes SOLIDWORKS Corporation, quindi riattivarla sull'altro computer.

Nel caso in cui non sia stato possibile disattivare la licenza a Dassault Systèmes SOLIDWORKS Corporation (ad esempio, a causa di un guasto del disco rigido), la riattivazione avverrà comunque nella maggior parte dei casi. Se non sono presenti, contattare il proprio rivenditore VAR per ricevere assistenza.

Per spostare una licenza SolidNetWork:

  1. Avviare SolidNetWork License Manager Server facendo clic su Start > Strumenti di SOLIDWORKS versione > SolidNetWork License Manager Server versione.
  2. Nella scheda Amministrazione del server, in Informazioni sulla licenza, fare clic su Modifica. Si avvia la procedura guidata Attivazione del prodotto SOLIDWORKS.
  3. In Come procedere? selezionare Trasferire le licenze del prodotto a un computer nuovo/aggiornato, quindi fare clic su Avanti.
  4. Nell'elenco N. di serie: selezionare i numeri di serie o fare clic su Seleziona tutto per attivare tutti i numeri di serie SOLIDWORKS.
    1. Selezionare l'opzione Automaticamente su Internet (consigliato).
    2. In Informazioni di contatto (obbligatorie): specificare un indirizzo e-mail.
  5. Viene visualizzata la finestra di messaggio Disattivazione riuscita.
    La disattivazione della licenza del prodotto viene completata.
  6. Fare clic su Fine.
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Eliminazione dei file di licenza SolidNetWork

È possibile eliminare i file di licenza SolidNetWork scaduti prima di installare nuove licenze.

  1. Avviare SolidNetWork License Manager facendo clic su Start > Strumenti di SOLIDWORKS versione > SolidNetWork License Manager Server.
  2. Nella scheda Amministrazione server, in Informazioni sulla licenza, fare clic su Modifica, quindi fare clic su Avanti.
  3. Nella pagina Attiva/Disattiva prodotto SOLIDWORKS, selezionare i file di licenza SolidNetWork scaduti e fare clic su Rimuovi.
  4. Fare clic su Fine e su OK per uscire.
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Presa in prestito e restituzione di licenze SolidNetWork

Una licenza SolidNetWork può essere presa in prestito per usare il software da una postazione remota. Dato che una licenza presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

Le licenze in prestito sono valide solo per l'utente e la macchina su cui sono state prese in prestito e non possono essere trasferite.

La licenza viene prestata per un periodo di tempo specificato, fino a 30 giorni, (o come definito dall'amministratore del sistema) e la licenza viene rimossa dal gruppo di licenze disponibili.

Le operazioni di presa in prestito e restituzione di una licenza non funzionano se la licenza SOLIDWORKS è in uso.

L'amministratore del sistema può personalizzare il prestito per:
  • definire gli utenti o i gruppi che possono prendere in prestito le licenze:
  • Impostare il numero di licenze che non possono essere prese in prestito

Per ulteriori informazioni, vedere directory_installazione_Gestione_licenza_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

Indice

  • Presa in prestito di licenze SolidNetWork

  • Restituzione di una licenza SolidNetWork presa in prestito

    Dato che una licenza SolidNetWork presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Presa in prestito di licenze SolidNetWork

Avviare sempre SolidNetWork License Manager dal menu Start di Windows. È necessario connettersi a SolidNetWork License Manager per ottenere in prestito la licenza.

Questi passaggi possono variare a seconda della configurazione del sistema. Per ulteriori istruzioni e opzioni, consultare la documentazione di Microsoft Windows.
  1. Avviare SolidNetWork License Manager sulla macchina client facendo clic su Start > Strumenti SOLIDWORKS versione > SolidNetWork License Manager Client versione.
  2. Nella scheda Prestito della licenza:
    1. In Prestito fino al selezionare una data.
    2. In Licenze prodotto disponibili, selezionare i prodotti da prendere in prestito e fare clic su Prestito.
    3. Nella finestra di dialogo Seleziona prodotto, selezionare il prodotto dall'elenco e fare clic su OK per confermare.
    4. Nella parte inferiore della finestra di dialogo, fare clic su Aggiorna.
      La colonna Prestito fino a indica quando le licenze devono essere restituite.
  3. Fare clic su OK.

Nella scheda Utilizzo licenza, è inoltre possibile visualizzare le Licenze totali, le Licenze gratuite, l'utente delle Licenze utilizzate da e le date del Prestito fino a.

Selezionare Usa solo licenze in prestito (avvio più veloce) se si lavora da remoto e l'apertura delle app SOLIDWORKS è lenta.

Questa opzione blocca le query ai server di licenza, che possono essere lente in alcuni ambienti. Le app possono avviarsi più velocemente omettendo le query, ma utilizzano solo le licenze prese in prestito.

Riavviare le app affinché questa opzione sia effettiva.

Argomento principale Presa in prestito e restituzione di licenze SolidNetWork
Restituzione di una licenza SolidNetWork presa in prestito


Restituzione di una licenza SolidNetWork presa in prestito

Dato che una licenza SolidNetWork presa in prestito viene rimossa dal gruppo di licenze disponibili, la licenza prelevata deve essere restituita perché torni ad essere disponibile.

  1. Avviare SolidNetWork License Manager sulla macchina client facendo clic su Start > Strumenti di SOLIDWORKS versione > SolidNetWork License Manager Client versione.
  2. Nella scheda Prestito della licenza:
    1. In licenze prodotto In prestito, selezionare i prodotti da restituire e fare clic su Restituisci.
    2. Fare clic su Aggiorna. La colonna Prestito fino al diventa vuota, a indicare che le licenze sono state restituite.
  3. Fare clic su OK.

Nella scheda Utilizzo licenza, è anche possibile visualizzare il numero di Licenze totali.

Non è necessario restituire le licenze dopo la data di scadenza. La licenza viene restituita al gruppo sul SolidNetWork License Manager a mezzanotte della data di scadenza e le applicazioni sul sistema remoto non funzioneranno più.
Argomento principale Presa in prestito e restituzione di licenze SolidNetWork
Presa in prestito di licenze SolidNetWork


Gestione dell'accesso alle versioni di SOLIDWORKS

Gli amministratori possono impedire agli utenti di utilizzare versioni specifiche di SOLIDWORKS in un ambiente SolidNetWork. Questa funzionalità consente di gestire le versioni di SOLIDWORKS utilizzate da persone, progetti e business unit diversi.

Per gestire l'accesso alle versioni di SOLIDWORKS utilizzando un file di opzioni FlexNet:

  1. Nella directory di installazione di SolidNetWork License Manager, creare un file di testo:
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. Per gestire l'accesso a una specifica versione di SOLIDWORKS nel file di licenza, aggiungere la seguente sintassi accanto a SOLIDWORKS:
    :SWVERSION=xx dove xx è la versione del prodotto SOLIDWORKS che si desidera gestire
  3. Per gestire più versioni di SOLIDWORKS, aggiungere una riga per ogni versione che si desidera gestire.

    Non sono supportate tutte le opzioni FlexNet. Le opzioni supportate per i filtri di versione sono:

    INCLUDE | Per consentire all'utente o al gruppo solo la capacità di avviare la versione specifica. A tutti gli altri utenti non è consentito di avviare la versione.
    INCLUDE_BORROW | Per consentire all'utente o al gruppo solo la capacità di prendere in prestito la versione specifica. A tutti gli altri utenti non è consentito di prendere in prestito la versione.
    EXCLUDE | Per impedire all'utente o al gruppo elencato di avviare la versione specifica di SOLIDWORKS. EXCLUDE ha priorità su INCLUDE.
    EXCLUDE_BORROW | Per impedire all'utente o al gruppo elencato di prendere in prestito la versione specifica di SOLIDWORKS. EXCLUDE ha priorità su INCLUDE.
    Esempi:
    1 | SWVERSION=32.0 fa riferimento a SOLIDWORKS 2025
    SWVERSION=31.0 fa riferimento a SOLIDWORKS 2024
    2 | INCLUDE solidworks:SWVERSION=32.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=32.0 USER jane
    Queste righe nel file delle opzioni consentono solo a jane di eseguire SOLIDWORKS 2025. Tutti gli altri utenti non possono eseguire o prendere in prestito SOLIDWORKS 2025, ma possono eseguire e prendere in prestito altre versioni di SOLIDWORKS. Inoltre, jane può eseguire e prendere in prestito anche altre versioni di SOLIDWORKS.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=32.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=31.0 GROUP chicago
    EXCLUDE solidworks USER don
    Queste righe definiscono un GROUP di utenti denominato chicago, che non possono accedere a SOLIDWORKS 2025 e SOLIDWORKS 2024, ma possono eseguire qualsiasi altra versione di SOLIDWORKS. L'utente don non può eseguire alcuna versione di SOLIDWORKS.
    4 | EXCLUDE swinspection_std:SWVERSION=32.0 HOST machine1
    Questa riga vieta a chiunque si trovi sulla machine1 di lanciare SOLIDWORKS Inspection 2025.

    Per informazioni su FlexNet, consultare la Guida amministrativa delle licenze di FlexNet Publisher nella directory di installazione di SolidNetWork License Manager (\Docs\flexuser\fnp_LicAdmin.pdf).

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Monitoraggio del tempo di inattività di una licenza

SOLIDWORKS può registrare il tempo di inattività con il SolidNetWork License Manager, in modo tale che le licenze non utilizzate per un certo periodo di tempo vengano restituite al gruppo delle licenze disponibili.

  1. Nella directory di installazione di SolidNetwork License Manager, creare un file di testo:
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. Aggiungere la seguente linea al file:
    TIMEOUTALL secondi

    dove secondi è un numero maggiore o uguale a 900 (15 minuti), il tempo minimo consentito.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Utilizzo di una licenza temporanea

Una licenza temporanea "any" può essere utilizzata provvisoriamente quando non è una licenza SolidNetWork.

Per impostazione predefinita, SolidNetWork License Manager può attivare un solo server alla volta. Per lavorare in un ambiente di prova, è possibile richiedere un file di licenza temporaneo al supporto tecnico e caricare una licenza "any" in SolidNetWork License Manager o un altro server. Se si lavora con un server offline, è possibile utilizzare le stesse istruzioni per caricare una licenza che non richiede attivazione.

Utilizzando un file di licenza "any", si accetta di implementare una licenza quando si ottiene una licenza SolidNetWork da Dassault Systèmes SOLIDWORKS Corporation. La conformità con le limitazioni della licenza è necessaria.

Per utilizzare una licenza temporanea ("any"):

  1. Avviare SolidNetWork License Manager facendo clic su Start > Strumenti di SOLIDWORKS versione > Server SolidNetWork License Manager versione.
  2. Quando nel software compare un messaggio che invita ad attivare, fare clic su No.
  3. Nella scheda Amministrazione del server, fare clic su Opzioni avanzate > Opzioni.
  4. In Modalità di licenza del server SolidNetWork, fare clic su Usa un file di licenza, quindi su OK.
  5. Nella scheda Amministrazione del server, in Informazioni sulla licenza, fare clic su Modifica.
    Compare la Creazione guidata del file di licenza SolidNetWork.
  6. In Tipo di server, selezionare Singolo e fare clic su Avanti.
  7. Selezionare l'ID dongle e immettere Any o l'indirizzo della scheda di rete per le informazioni sul server. Fare quindi clic su Avanti.

    Fare clic su Annulla quando viene visualizzato questo messaggio: Impossibile leggere il numero di ID del dispositivo di sicurezza.

    Se sul computer è attivo un firewall, potrebbe essere necessario selezionare altre opzioni in questa schermata. Per ulteriori informazioni, vedere Uso di licenze SolidNetWork con i firewall.
  8. In Licenze, fare clic su Leggi per leggere il file di licenza.
  9. Nella finestra di dialogo Leggi, selezionare il file SNL_ANY.txt o SNL_(NIC Card Number).txt ricevuto dal supporto tecnico e fare clic su Apri. Quindi fare clic su OK.
    La Creazione guidata del file di licenza SolidNetWork visualizza l'elenco delle licenze contenuto nel file di testo.
    Fare clic su Rimuovi per eliminare dall'elenco le voci delle licenze temporanee scadute.
  10. Fare clic su Fine per chiudere la Creazione guidata del file di licenza SolidNetWork.
  11. Per attivare una licenza temporanea ("any"):
    1. Nella scheda Amministrazione del server, fare clic su Opzioni avanzate > Opzioni.
    2. In Modalità di licenza del server SolidNetWork, selezionare Usa un file di licenza e fare clic su OK.
    3. Nella scheda Amministrazione del server, fare clic su Modifica > Attivare/Disattivare le licenze del prodotto.
    4. Selezionare il numero di serie, immettere le informazioni di contatto, quindi selezionare il metodo di attivazione. Seguire le istruzioni se si sceglie l'attivazione manuale.
    5. Fare clic su Fine per confermare l'attivazione.
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Uso delle licenze SolidNetWork con prodotti aggiuntivi

È anche possibile usare SolidNetWork License Manager per distribuire le licenze per i prodotti aggiuntivi principali di SOLIDWORKS.

  • Non è necessario un numero equo di licenze del software SOLIDWORKS e di licenze aggiuntive SOLIDWORKS.
  • Per prelevare una licenza di un prodotto aggiuntivo, l'utente deve prima prelevare una licenza del software SOLIDWORKS.
  • Per prendere in prestito la licenza di un prodotto aggiuntivo, è necessario prendere in prestito sia la licenza del software SOLIDWORKS che la licenza del prodotto SOLIDWORKS che comprende l'aggiunta. Per impostazione predefinita, viene presa in prestito una licenza SOLIDWORKS Standard, ma per attivare un'aggiunta è necessario prendere in prestito una licenza SOLIDWORKS Professional, SOLIDWORKS Premium o SOLIDWORKS Ultimate.
  • Per rilasciare la licenza di un prodotto aggiuntivo:
    • In SOLIDWORKS, fare clic su Strumenti > Aggiunte e deselezionare l'aggiunta.
    • Uscire da SOLIDWORKS.
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License

Gli utenti SolidNetWork License possono controllare quali licenze di SOLIDWORKS® Simulation utilizzare nel proprio gruppo di licenze quando aggiungono SOLIDWORKS Simulation. Inoltre, possono aggiornare la licenza di SOLIDWORKS Simulation senza scaricare l'aggiunta nel caso in cui sia necessario un tipo di licenza superiore per studi più avanzati.

  1. Per utilizzare una licenza specifica di SOLIDWORKS Simulation:
    1. In SOLIDWORKS, fare clic su Strumenti > Aggiunte e nella finestra di dialogo Aggiunta, selezionare SOLIDWORKS Simulation.
    2. In SOLIDWORKS Simulation (CommandManager), fare clic sulla freccia Giù [image] per visualizzare un elenco di licenze sul server che possano supportare Simulation.

    3. Selezionare la licenza SOLIDWORKS Simulation appropriata.
  2. Per controllare o modificare la licenza corrente di SOLIDWORKS Simulation, fare clic sulla freccia Giù [image] in SOLIDWORKS Simulation (CommandManager).

    La licenza in uso visualizza un segno di spunta. Se sono disponibili tipi di licenza più avanzati è possibile eseguire l'aggiornamento.
    Non è possibile eseguire il downgrade di una licenza SOLIDWORKS Simulation. Disattivare l'aggiunta SOLIDWORKS Simulation e aggiungere nuovamente la licenza a un livello inferiore.
  3. Opzionale: Per disattivare l'aggiunta, fare clic su SOLIDWORKS Simulation (CommandManager) o deselezionarla da Strumenti > Aggiunte.
I seguenti casi utilizzano ancora l'ordine di licenza:
  • Quando viene avviata l'esecuzione di SOLIDWORKS Simulation.
  • Se SOLIDWORKS Simulation viene aggiunto in Strumenti > Aggiunte.
  • Se si fa clic su SOLIDWORKS Simulation senza specificare una licenza dall'elenco a discesa.
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Caricamento dei moduli Flow Simulation

In qualità di cliente con SolidNetWork License, è possibile controllare il caricamento dei moduli aggiuntivi HVAC ed Electronics Cooling per Flow Simulation tramite due metodi.

Il primo metodo consente di specificare il comportamento predefinito per le aggiunte quando si carica Flow Simulation. L'opzione Carica automaticamente i moduli dell'aggiunta Flow Simulation se disponibili è nella scheda Client SolidNetWork License Manager > Ordine licenza. Deselezionare questa opzione se non è necessario utilizzare le aggiunte di Flow Simulation. I moduli aggiuntivi HVAC ed Electronics Cooling non si caricano quando Flow Simulation viene aggiunto con i metodi esistenti.

Il secondo metodo consente di ignorare il comportamento predefinito e includere i moduli aggiuntivi HVAC ed Electronics Cooling quando si carica Flow Simulation. Fare clic sulla freccia Giù [image] in SOLIDWORKS Flow Simulation (barra degli strumenti aggiunte SOLIDWORKS®) o SOLIDWORKS Flow Simulation con uno o entrambi i moduli aggiuntivi da caricare.

Senza questi metodi, le licenze per i moduli aggiuntivi vengono utilizzate indipendentemente dal fatto che siano necessarie o meno e potrebbero essere rifiutate ad altri utenti della rete.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics

Quando si eseguono gli studi SOLIDWORKS Simulation, Plastics o Flow Simulation, le licenze di rete rimangono attive e non scadono. SOLIDWORKS conserva le licenze durante il processo di calcolo, che è considerato un'attività.

I periodi di inattività, definiti da un'opzione TIMEOUT, hanno effetto solo dopo che gli studi hanno terminato il calcolo.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa

È possibile configurare un computer su una rete in modo che funga da gestore di licenze per distribuire le licenze SolidNetWork e da posizione per l'immagine amministrativa, dalla quale gli utenti possano installare il software SOLIDWORKS.

I computer client possono ottenere le licenze dal gestore di licenze e quindi installare SOLIDWORKS dallo stesso computer.

Per realizzare questa configurazione, il gestore di licenze e l'immagine amministrativa devono essere installati sullo stesso computer. Installare il gestore di licenze per primo e successivamente creare e distribuire l'immagine amministrativa.
Per i dettagli, vedere:
  • Installazione di SolidNetWork License Manager Server
  • Distribuzione su più client
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Disinstallazione di SolidNetWork License Manager
Gestione delle licenze di FlexNet Publisher


Disinstallazione di SolidNetWork License Manager

Quando si aggiorna SolidNetWork License Manager, è necessario disinstallare il gestore di licenze vecchio prima di installare quello nuovo.

  1. Avviare SolidNetwork License Manager facendo clic su Start > Strumenti di SOLIDWORKS versione > SolidNetWork License Manager Server versione.
  2. Verificare che nessun client in rete abbia in esecuzione SOLIDWORKS.
    La scheda Uso della licenza mostra i client con SOLIDWORKS in esecuzione.
  3. Se si intende trasferire la licenza SolidNetWork su un altro computer, disattivarla da questo computer prima di rimuovere SolidNetWork License Manager.
    Per informazioni sul trasferimento di licenze SolidNetWork, vedere Trasferimento di una licenza SolidNetWork.
  4. Nella scheda Amministrazione del server, in Server di licenza, fare clic su Ferma.
  5. Fare clic su OK per uscire dal gestore di licenze.
  6. In Windows, aprire Pannello di controllo > Programmi e funzionalità.
  7. Selezionare SOLIDWORKS SolidNetWork License Manager, fare clic su Disinstalla e confermare la disinstallazione.
  8. In File Explorer, eliminare la cartella SOLIDWORKS SolidNetWork License Manager.
    (Di norma, questa cartella si trova in Program Files (x86) nella directory di installazione di SOLIDWORKS).

È ora possibile procedere ad installare una nuova versione del gestore di licenze. Per maggiori dettagli, vedere Installazione di SolidNetWork License Manager Server.

Se il computer di SolidNetwork License Manager ha un dongle hardware allegato, rimuovere il dongle prima di installare la nuova versione di SolidNetWork License Manager.
Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Gestione delle licenze di FlexNet Publisher
Installazione di SolidNetWork License Manager Server


Gestione delle licenze di FlexNet Publisher

Le licenze SolidNetWork si basano sulla gestione delle licenze di FlexNet Publisher®.

Per ulteriori informazioni sulla gestione delle licenze di FlexNet Publisher, consultare la Guida amministrativa delle licenze di FlexNet Publisher nella directory di installazione di SolidNetWork License Manager: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Per le informazioni più recenti sulla gestione delle licenze di FlexNet Publisher, contattare Flexera® Software.

È possibile controllare la versione FlexNet rivedendo il registro sul server delle licenze. Aprire il server SolidNetWork License Manager e fare clic su Amministrazione del server > Visualizza log. Il registro elenca la versione della licenza FlexNet all'inizio tra parentesi.

Argomento principale Amministrazione delle licenze mediante SolidNetWork License Manager
Panoramica dell'installazione delle licenze SolidNetWork
Avvio di SolidNetWork License Manager
Aggiornamento di SolidNetWork License Manager
Trasferimento di una licenza SolidNetWork
Eliminazione dei file di licenza SolidNetWork
Presa in prestito e restituzione di licenze SolidNetWork
Gestione dell'accesso alle versioni di SOLIDWORKS
Monitoraggio del tempo di inattività di una licenza
Utilizzo di una licenza temporanea
Uso delle licenze SolidNetWork con prodotti aggiuntivi
Selezione di una licenza SOLIDWORKS Simulation con una SolidNetWork License
Caricamento dei moduli Flow Simulation
Timeout di inattività per SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation e SOLIDWORKS Plastics
Uso dello stesso computer per l'installazione del gestore di licenze e dell'immagine amministrativa
Disinstallazione di SolidNetWork License Manager


Diagnostica

Consultare questi argomenti per risolvere i problemi di installazione.

Indice

  • Uso della licenza di rete

  • File di registro della Gestione installazioni SOLIDWORKS

    I file di registro della Gestione installazioni SOLIDWORKS sono disponibili per assistere nella risoluzione dei problemi di installazione.

  • Cartella di download di Gestione installazioni SOLIDWORKS

    Gestione installazioni SOLIDWORKS consente di scaricare i file di installazione necessari in una cartella specificata dall'utente. Questo argomento fornisce le risposte alle domande più frequentemente poste circa la cartella del download.

  • Diagnostica delle licenze SolidNetWork

    Se l'installazione del Gestore di licenze SolidNetWork non va a buon fine, controllare se esiste una soluzione tra queste spiegazioni.

  • Diagnostica aggiornamenti

    Se si riscontrano problemi durante l'aggiornamento a una nuova release di SOLIDWORKS, verificare se esiste una soluzione tra queste spiegazioni.

  • Convalida della scheda grafica durante l'installazione o l'aggiornamento

    Una volta terminata l'installazione o l'aggiornamento di SOLIDWORKS sul computer, eseguire SOLIDWORKS Rx per assicurarsi che sul computer siano presenti una scheda grafica e un driver della scheda grafica supportati.


Uso della licenza di rete

Questa finestra si apre quando il server non ha più licenze per un prodotto.

Fare clic sulla freccia nella casella Prodotto per visualizzare tutte le opzioni di prodotto. Le opzioni includono SOLIDWORKS e tutte le aggiunte disponibili per l'acquisto.

Licenze totali è il numero totale di licenze acquistate.

Licenze gratuite è il numero di licenze non in uso.

La casella Licenze usate da fornisce informazioni su ogni persona che usa una licenza.

Argomento principale Diagnostica
File di registro della Gestione installazioni SOLIDWORKS
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Diagnostica aggiornamenti
Convalida della scheda grafica durante l'installazione o l'aggiornamento


File di registro della Gestione installazioni SOLIDWORKS

I file di registro della Gestione installazioni SOLIDWORKS sono disponibili per assistere nella risoluzione dei problemi di installazione.

Questi file log si trovano nella stessa posizione degli altri file log dell'applicazione di SOLIDWORKS.

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

Se si esegue Gestione installazioni da un account di sistema, i log si trovano in questa cartella:
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
Per visualizzare la directory dei file di registro, potrebbe essere necessario configurare le opzioni della cartella Windows attivando Mostra file e cartelle nascosti.

Se i dati dell'applicazione sono su un'unità diversa da C:, regolare il percorso della directory in maniera corrispondente.

Questa directory contiene il file SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.TXT, un registro generale delle operazioni svolte dalla Gestione installazioni SOLIDWORKS.

La sottodirectory Other Logs contiene registri di installazione con informazioni più dettagliate.

Argomento principale Diagnostica
Uso della licenza di rete
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Diagnostica aggiornamenti
Convalida della scheda grafica durante l'installazione o l'aggiornamento


Cartella di download di Gestione installazioni SOLIDWORKS

Gestione installazioni SOLIDWORKS consente di scaricare i file di installazione necessari in una cartella specificata dall'utente. Questo argomento fornisce le risposte alle domande più frequentemente poste circa la cartella del download.

Domanda Risposta
Come installare i file in questa cartella?

Eseguire setup.exe. Potrebbe essere necessario scaricare alcuni file se viene selezionata l'installazione di elementi non ancora scaricati.

Non eseguire l'installazione con msiexec (vedere di seguito).
Posso installare i file MSI manualmente da questa cartella usando msiexec o altra applicazione?

No. Gestione installazioni non scarica alcuni dei file richiesti per l'esecuzione di msiexec.
Posso selezionare la stessa cartella del download per ogni versione che installo?

Le cartelle di download riportano il nome della versione. Gestione installazioni SOLIDWORKS crea automaticamente nella cartella specificata una sottocartella specifica per la versione.

Ho scaricato alcuni prodotti manualmente dal sito web di Dassault Systèmes SOLIDWORKS Corporation. La Gestione installazioni può installare questi file?
Gestione installazioni SOLIDWORKS è in grado di utilizzare i file scaricati manualmente. Tuttavia, è preferibile eseguire Gestione installazioni SOLIDWORKS scegliendo l'opzione per il download dei file. Gestione installazioni SOLIDWORKS mostra i file necessari in base al componente da installare, fornendo i collegamenti per scaricare i singoli file. Questa opzione può essere usata quando la pagina di download non funziona (a causa di limitazioni sul download gestite da un server proxy).
Se una finestra di dialogo invita a salvare o eseguire i file durante il download o l'installazione, scegliere sempre Salva.
Posso condividere i file che ho scaricato con altri utenti?

Sì. A tale fine, scaricare in una cartella condivisa in rete. Ogni client potrà quindi eseguire Gestione installazioni SOLIDWORKS dalla cartella condivisa.

Non è necessario scaricare altro, a meno che non si scelgano alcuni elementi non selezionati durante il download iniziale o se il computer che utilizza questo download per l'installazione ha requisiti diversi da quello utilizzato per il download.

Nel caso si effettui il download per conto di un altro utente ma non l'installazione, selezionare l'opzione Solo download durante l'installazione. Questa opzione consente di selezionare i prodotti a prescindere da ciò che è installato sul proprio sistema. Tuttavia, questa opzione non può essere usata per scaricare le patch o per creare le immagini amministrative.
Come posso scoprire quando è disponibile una nuova versione di SOLIDWORKS?
L'utente sarà informato della nuova versione disponibile nei seguenti casi:
  • Se si esegue Verifica aggiornamenti (Start > Gestione installazioni SOLIDWORKS > Verifica aggiornamenti)
  • Se si è attivato SOLIDWORKS Background Downloader
  • Se viene selezionata una versione installata di SOLIDWORKS in Installazione applicazioni di Windows e viene scelto Cambia
  • Se viene eseguita una versione precedente di Gestione installazioni (sldIM.exe) da una cartella di download
In questi casi, è possibile selezionare di scaricare la versione più recente. Gestione installazioni SOLIDWORKS scarica ed esegue la propria versione più recente, ignorando qualsiasi altro file di installazione. Dopo l'esecuzione della versione più recente di Gestione installazioni SOLIDWORKS, selezionare un gruppo di azioni di installazione. Gestione installazioni SOLIDWORKS determina i file di installazione necessari (ma non scaricati in precedenza) e propone di scaricare tali file.
Gestione installazioni SOLIDWORKS non permette di selezionare un Service Pack diverso da installare.

Ogni versione di Gestione installazioni SOLIDWORKS è progettata per installare solo una versione specifica dei prodotti SOLIDWORKS. Per installare un Service Pack diverso, è necessario eseguire la versione corrispondente di Gestione installazioni SOLIDWORKS. Per trovare la versione più recente disponibile, vedere l'argomento precedente.
Perché Gestione installazioni SOLIDWORKS impedisce di scaricare file?

Se i limiti del server proxy impediscono il download dei file, Gestione installazioni SOLIDWORKS non può scaricare i file automaticamente.

Scaricare i file manualmente e installarli tramite Gestione installazioni SOLIDWORKS. In Gestione installazioni di SOLIDWORKS selezionare l'opzione per scaricare i singoli file (ad esempio, Metodo di download manuale nella pagina Opzioni di download). In base alle selezioni del proprio prodotto e requisiti di sistema, apparirà una pagina web in una finestra separata che contiene i link per scaricare tutti i file necessari manualmente.
Non tutti i prodotti SOLIDWORKS installati sono aggiornati al Service Pack più recente. Perché Verifica aggiornamenti afferma che è installata la versione più recente?

Verifica aggiornamenti evidenzia se è stata installata (o è in esecuzione) la versione più recente di Gestione installazioni SOLIDWORKS.

Per aggiornare tutti i prodotti alla versione più recente installata, in Pannello di controllo > Programmi > Programmi e funzionalità, selezionare la versione di SOLIDWORKS installata più recente, quindi fare clic su Cambia.
Posso copiare un dvd su una cartella del download?

Sì, ma le installazioni possono non riuscire, a meno che non venga copiato l'intero contenuto di ogni DVD rilasciato per la piattaforma in uso. Gestione installazioni SOLIDWORKS cerca i file swdata*.id per determinare la versione. Se questi file non sono presenti, non verrà riconosciuto alcun file di installazione copiato e sarà necessario riscaricarlo.
Argomento principale Diagnostica
Uso della licenza di rete
File di registro della Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Diagnostica aggiornamenti
Convalida della scheda grafica durante l'installazione o l'aggiornamento


Diagnostica delle licenze SolidNetWork

Se l'installazione del Gestore di licenze SolidNetWork non va a buon fine, controllare se esiste una soluzione tra queste spiegazioni.

Argomento principale Diagnostica
Uso della licenza di rete
File di registro della Gestione installazioni SOLIDWORKS
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica aggiornamenti
Convalida della scheda grafica durante l'installazione o l'aggiornamento

Accesso ai file di registro della licenza SolidNetWork

Nel caso di errore relativo alla licenza, la soluzione spesso è indicata nel file directory_installazione_Gestore_SNL\lmgrd.log.

Impossibile ottenere una licenza per SOLIDWORKS. Impossibile connettere al server di licenza.

Solitamente, il problema è causato da impostazioni errate della porta.

  • Le impostazioni della porta tra il gestore di licenza SolidNetWork e il client di licenza potrebbero non corrispondere.
  • Altre impostazioni della porta per versioni multiple dei Gestori di licenze SolidNetWork potrebbero non essere state specificate.
  • Dato il nome del server, verificare che il computer client possa risolvere in modo corretto l'indirizzo e il percorso al server.
Per i dettagli sulle impostazioni della porta per i gestori di licenze SolidNetWork e i client, vedere Uso di licenze SolidNetWork con i firewall.
Uso di licenze SolidNetWork con i firewall


Diagnostica aggiornamenti

Se si riscontrano problemi durante l'aggiornamento a una nuova release di SOLIDWORKS, verificare se esiste una soluzione tra queste spiegazioni.

Argomento principale Diagnostica
Uso della licenza di rete
File di registro della Gestione installazioni SOLIDWORKS
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Convalida della scheda grafica durante l'installazione o l'aggiornamento

Modifica o riparazione di una sorgente spostata

Quando viene installato SOLIDWORKS, Gestione installazioni di SOLIDWORKS ricorda l'ubicazione delle sorgenti d'installazione (supporto su disco, immagine disco su una rete, ecc). Si prevede che le sorgenti siano disponibili nella stessa posizione durante la modifica o la riparazione.

Se la fonte si sposta o viene cancellata, o se cambia il mezzo della fonte, la Gestione installazioni di SOLIDWORKS genererà un messaggio di errore. Tuttavia, è possibile modificare o riparare le sorgenti d'installazione passando a un'altra ubicazione, purché contenga tutti gli stessi file e strutture di cartella.


Convalida della scheda grafica durante l'installazione o l'aggiornamento

Una volta terminata l'installazione o l'aggiornamento di SOLIDWORKS sul computer, eseguire SOLIDWORKS Rx per assicurarsi che sul computer siano presenti una scheda grafica e un driver della scheda grafica supportati.

Per convalidare le schede grafiche durante l'installazione o l'aggiornamento:

  1. Al termine dell'installazione tramite Gestione installazioni, verrà visualizza la pagina Fine. Sotto Verifica il sistema fare clic su Esegui diagnostica di sistema.

    SOLIDWORKS Rx avvia ed esegue la diagnostica.

  2. SOLIDWORKS Rx conferma se la scheda grafica e il driver sono supportati.
    Se la scheda grafica è supportata, ma il driver non lo è, un messaggio di stato può richiedere l'aggiornamento del driver.

Ogni decimo avvio di SOLIDWORKS, appare un messaggio Verifica il sistema e consiglia nuovamente di eseguire la diagnostica di sistema. Per sospendere queste notifiche, fare clic con il pulsante destro del mouse su SOLIDWORKS Resource Monitor [image] nell'area di notifica di Windows e fare clic su Elimina notifiche grafiche.

È possibile convalidare una scheda grafica e il driver in qualsiasi momento facendo clic con il pulsante destro del mouse su SOLIDWORKS Resource Monitor nell'area di notifica di Windows. Il menu offre inoltre le seguenti opzioni:
  • Accesso alla Guida di SOLIDWORKS Resource Monitor
  • Esegui diagnostica di sistema
  • Elimina notifiche grafiche
  • Elimina notifiche abbonamento
  • Visualizza driver scheda grafica certificati
Argomento principale Diagnostica
Uso della licenza di rete
File di registro della Gestione installazioni SOLIDWORKS
Cartella di download di Gestione installazioni SOLIDWORKS
Diagnostica delle licenze SolidNetWork
Diagnostica aggiornamenti


Guida dell'applicazione Gestione installazioni di SOLIDWORKS

La Gestione installazioni SOLIDWORKS è un'applicazione standalone che installa e aggiorna i prodotti SOLIDWORKS.

La Gestione installazioni SOLIDWORKS è lo strumento principale per scaricare, installare, modificare, aggiornare, riparare e rimuovere il software SOLIDWORKS.

La Gestione installazioni di SOLIDWORKS può essere eseguita:
  • Da un DVD di SOLIDWORKS o una cartella di origine condivisa o una di download (per l'installazione di una nuova versione)
  • Dal Pannello di controllo Installazione applicazioni (per modificare o rimuovere una versione esistente)
  • Mediante un controllo degli aggiornamenti automatico o manuale (per rilevare, scaricare, installare le nuove versioni)

Ogni versione di SOLIDWORKS ha una versione di Gestione installazioni di SOLIDWORKS specifica per quella versione di SOLIDWORKS.

Indice

  • SOLIDWORKS Background Downloader

    SOLIDWORKS Background Downloader esegue il download dei file automatizzato (ad esempio, quando si trova una nuova versione del Service Pack) usando processi in background, permettendo di proseguire con il lavoro durante il download. Al termine del download, l'utente può decidere se eseguire subito l'installazione, posticipare il download o eliminarlo.

  • Specifica delle opzioni per Installation Manager

    Queste opzioni includono le impostazioni per la registrazione, l'accesso a Internet e la lingua utilizzata in Installation Manager.

  • Risultati di Verifica aggiornamenti

    Verifica aggiornamenti cerca le versioni successive di SOLIDWORKS.

  • Ubicazione immagine amministrativa

    Specificare la posizione di installazione dell'immagine amministrativa.

  • Opzioni di download

    Specificare i dettagli per completare il download, ad esempio la posizione dei file scaricati, come scaricare i file e se installare i file dopo il download.

  • Opzioni di download per i file di Gestione installazioni SOLIDWORKS

    Si è scelto di scaricare una versione successiva della Gestione installazioni di SOLIDWORKS. Usare questo schermo per specificare dove e come scaricare.

  • Download dei file di installazione del prodotto

    Specificare dove e come scaricare i file mancanti per il prodotto specificato.

  • Avanzamento del download

    La Gestione installazioni di SOLIDWORKS scarica, verifica ed estrae tutti i file in parallelo durante questo processo.

  • Risultati del download

    Indica se il download si è completato correttamente, se non è riuscito o se è stato annullato.

  • Errori di installazione / Installazione annullata

    L'installazione ha riscontrato un errore o è stata annullata.

  • Installazione completata

    La Gestione installazioni di SOLIDWORKS ha completato la procedura.

  • Ubicazione installazione

  • Opzioni di aggiornamento

    Una o più precedenti versioni maggiori di SOLIDWORKS sono installate su questo computer. È possibile creare una nuova installazione, che coesisterà con la versione precedente; in alternativa, è possibile eseguire un aggiornamento che rimuoverà la versione precedente.

  • Avanzamento dell'installazione

    Questo schermo mostra l'avanzamento dell'installazione.

  • Tipo di installazione

    È possibile specificare l'operazione di installazione che si desidera eseguire. Ad esempio, creazione di una nuova installazione, modifica o riparazione di un'installazione esistente, creazione di un'immagine amministrativa, installazione di prodotti del server amministrativo o download di file da condividere e installare su altri computer.

  • Installazione e gestione di computer multipli

    La Gestione installazioni di SOLIDWORKS fornisce i seguenti strumenti per installare e gestire multipli computer SOLIDWORKS.

  • Download manuale

    Si è scelto di scaricare i file manualmente (oppure si sono scaricati manualmente i file all'ultima esecuzione della Gestione installazioni di SOLIDWORKS).

  • Versione più recente disponibile

    La Gestione installazioni ha identificato una versione più recente dei prodotti SOLIDWORKS. Si può scegliere di installare la versione contenuta nel dvd d'installazione originale o nel download oppure scaricare ed installare la versione più recente.

  • Nessuna nuova versione disponibile

    Non ci sono versioni più recenti disponibili per il download. Procedere con l'installazione della versione specifica.

  • Processi rilevati

    La Gestione installazioni di SOLIDWORKS ha rilevato alcuni processi in corso su questo computer che possono impedire la riuscita dell'installazione.

  • Selezione prodotti

    È possibile specificare i componenti del prodotto da installare, modificare, scaricare o rimuovere.

  • Prodotti da scaricare

    Selezionare i prodotti SOLIDWORKS da scaricare in un punto specifico.

  • Prodotti da riparare

    Quando si seleziona Ripara questa installazione, questo schermo visualizzerà i prodotti SOLIDWORKS con i numeri di versione che potranno essere riparati da questa Gestione installazione di SOLIDWORKS.

  • Numeri di seriali

    I numeri di serie associano il computer ai prodotti SOLIDWORKS acquistati.

  • Installazione del server

    I prodotti server che l'utente tenta di installare sono elencati, con i risultati delle installazioni.

  • Sintesi

    La Gestione installazioni di SOLIDWORKS ha tutte le informazioni necessarie per completare l'installazione.

  • Avvertimenti di controllo sistema

    La Verifica del sistema ha riportato problemi che possono avere conseguenze se si decide di continuare con l'installazione. Nella maggioranza dei casi, si potrà procedere senza problemi con la Gestione installazioni di SOLIDWORKS.

  • Creazione guidata fori/Opzioni Toolbox

    Se è installato SOLIDWORKS Toolbox, SOLIDWORKS include una libreria standard di tipi di foro e hardware.

  • Disinstalla prodotti

    Quando si seleziona Rimuovi o Disinstalla programmi dal Pannello di controllo, questa schermata visualizzerà i prodotti SOLIDWORKS (con numeri di versione), che saranno disinstallati da questa versione di Gestione installazioni di SOLIDWORKS. Scegliere se effettuare una disinstallazione standard, personalizzata o completa.


SOLIDWORKS Background Downloader

SOLIDWORKS Background Downloader esegue il download dei file automatizzato (ad esempio, quando si trova una nuova versione del Service Pack) usando processi in background, permettendo di proseguire con il lavoro durante il download. Al termine del download, l'utente può decidere se eseguire subito l'installazione, posticipare il download o eliminarlo.

Background Downloader è attivato per impostazione predefinita quando si installa SOLIDWORKS.

Quando è in esecuzione la Gestione installazioni, per un'operazione di installazione o di download, Background Downloader viene messo in pausa. Per esempio, i download in corso verranno messi in pausa, non viene consentito l'avvio di alcun nuovo download e non verrà consentito di modificare le specifiche della cartella di download.

È possibile disattivare Background Downloader durante l'installazione. Nella pagina Riepilogo, in Opzioni di download, deselezionare l'opzione Usare il background downloader per i futuri Service Pack.

Quando l'opzione è attivata, questa icona viene visualizzata nell'area di notifica di Windows, nella barra degli strumenti:

Facendo clic su questa icona, è possibile eseguire le seguenti operazioni:
  • Assistenza con il Background Downloader
  • Download in pausa
  • Riprendi il download
  • Annulla download
  • Opzioni di installazione
  • Modifica impostazioni download
  • Verifica aggiornamenti
  • Verifica automaticamente aggiornamenti
  • Download automatico aggiornamenti
  • Disattiva Background Downloader

Guida di Background Downloader

Aprire questo argomento relativo al Background Downloader nella Guida di installazione di SOLIDWORKS.

Pausa/Riprendi download

Se un download è in esecuzione in background, fare clic su Download in pausa per mettere in pausa il download. È possibile riprenderlo in seguito facendo clic su Riprendi il download.

Annulla download

Se il download è in esecuzione, arrestarlo ed eliminare tutti i file che Background Downloader ha già scaricato.
Non è possibile riprendere un download annullato.

Opzioni di installazione

Al termine del download, è possibile scegliere tra le opzioni seguenti:
  • Installa ora: installa i file scaricati.
  • Ricordami dopo: non installa i file scaricati, ma imposta un messaggio di promemoria per l'utente.
  • Elimina questo download: non installa i file scaricati e li elimina. (Questa funzione è utile se l'utente decide di non voler più installare i file scaricati).

Modifica impostazioni download

Modificare la posizione della cartella in cui Background Downloader scarica i file.

Questa opzione non è disponibile mentre il download è in esecuzione o in pausa.
È anche possibile specificare il Numero di giorni tra le verifiche degli aggiornamenti.

Verifica aggiornamenti

Eseguire la funzione Verifica aggiornamenti della Gestione installazioni di SOLIDWORKS.

Verifica automatica degli aggiornamenti

Eseguire periodicamente la Verifica aggiornamenti, informando l'utente quando sono disponibili aggiornamenti da scaricare.

Download automatico degli aggiornamenti

Eseguire periodicamente la Verifica aggiornamenti, scaricando gli aggiornamenti appena sono disponibili.

Disattivazione e riattivazione del Background Downloader di SOLIDWORKS

È possibile disattivare Background Downloader facendo clic sull'icona nella barra delle applicazioni di Windows e selezionando Disattiva Background Downloader.

Per riattivare il Background Downloader, fare clic su Start > Gestione installazioni SOLIDWORKS > SOLIDWORKS Background Downloader.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Specifica delle opzioni per Installation Manager

Queste opzioni includono le impostazioni per la registrazione, l'accesso a Internet e la lingua utilizzata in Installation Manager.

Per specificare le opzioni di Installation Manager prima di installare il software:

  1. Nella Gestione installazioni, fare clic con il pulsante destro del mouse sull'icona SOLIDWORKS sulla barra del titolo e selezionare:
    Opzione | Descrizione
    Livelli di accesso installazione Specificare il livello di registrazione su Alto, Medio o Basso. Livelli più elevati raccolgono più dati per la risoluzione dei problemi, ma possono rallentare l'installazione. Per impostazione predefinita, è selezionato il livello Basso (più veloce), che ottimizza le prestazioni e la stabilità.

    Crea registri di Windows Installer (lento) salva i registri nella stessa cartella degli altri registri di installazione.
    Opzioni immagine amministrativa | Selezionare Usa nomi file brevi (formato 8.3) o Usa nomi cartelle e nomi file completi.
    Raccogli registri di installazione | Specifica a posizione in cui sono memorizzati i registri di installazione. La Gestione installazioni salva questi file in IM_Logs.zip.
    Disattiva l'accesso ad internet
    Lingua | Specifica la lingua utilizzata in Installation Manager. L'impostazione predefinita è Inglese.
  2. Fare clic su Chiudi.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Risultati di Verifica aggiornamenti

Verifica aggiornamenti cerca le versioni successive di SOLIDWORKS.

Se si hanno privilegi di amministratore sul computer, è possibile eseguire il comando Verifica aggiornamenti manualmente:
  • In Windows, fare clic su Start > Gestione installazioni di SOLIDWORKS > Verifica aggiornamenti
  • In SOLIDWORKS, fare clic su [image] > Verifica aggiornamenti
Verifica aggiornamenti non è disponibile su client installati da immagini amministrative.

Nuove versioni disponibili

La Gestione installazioni di SOLIDWORKS ha identificato una versione più recente dei prodotti SOLIDWORKS. Si potrà aggiornare ad una versione più recente selezionando la Gestione installazioni di SOLIDWORKS per quella versione.

Questa versione più recente può scaricare i file di installazione in base ai prodotti specificati nell'installazione. Inoltre, sarà possibile condividere i file scaricati con altri utenti che installano usando la Gestione installazioni di SOLIDWORKS.

Questi download sono solo per uso con la Gestione installazioni di SOLIDWORKS.
Queste opzioni sono disponibili:
  • nel caso di multiple versioni disponibili, è possibile selezionare una versione dall'elenco.
  • Per informazioni dettagliate su questa versione, fare clic su Controlla cosa è compreso in questo aggiornamento.
Fare clic su Avanti per ottenere ed eseguire la versione selezionata della Gestione installazioni di SOLIDWORKS.

Nessun nuovo download disponibile/Impossibile verificare nuove versioni

La Gestione installazioni di SOLIDWORKS non ha trovato una versione più recente dei prodotti SOLIDWORKS, probabilmente perché si sta installando la versione più recente disponibile o perché non è collegata al sito SOLIDWORKS da verificare.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Ubicazione immagine amministrativa

Specificare la posizione di installazione dell'immagine amministrativa.

Quando si crea un'immagine amministrativa, valgono queste opzioni:
Nuova ubicazione immagine | La directory nella quale la Gestione installazioni SOLIDWORKS creerà la nuova immagine. | Questa posizione non può contenere un'immagine amministrativa esistente. L'immagine amministrativa deve trovarsi in una cartella condivisa perché sia possibile applicarla ai client.
Spazio stimato necessario per la creazione dell'immagine | Spazio aggiuntivo necessario per l'immagine amministrativa. | Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti dell'immagine.
Crea immagine da | La directory dalla quale si installano i prodotti SOLIDWORKS. Questa opzione è disponibile solo se si è selezionata l'opzione Solo installazione. Per i dettagli, vedere Opzioni di download.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Opzioni di download

Specificare i dettagli per completare il download, ad esempio la posizione dei file scaricati, come scaricare i file e se installare i file dopo il download.

La Gestione installazioni di SOLIDWORKS supporta la distribuzione del software elettronico (ESD). Se non s'intende installare da un dvd SOLIDWORKS, si dovrà specificare la fonte dei prodotti SOLIDWORKS in via di installazione.

Per le risposte alle domande relative alla cartella del download, vedere Cartella di download di Gestione installazioni SOLIDWORKS.

Che cosa si intende fare?

Scegliere una delle seguenti opzioni:

Download e installa/Download e crea immagini

Al termine del download, Gestione installazioni SOLIDWORKS esegue un'installazione dei file scaricati.

Solo download. È possibile scaricare i file una sola volta e poi condividerli su più computer.

Gestione installazioni SOLIDWORKS non esegue un'installazione al termine del download.

Di solito, si specifica questa opzione se si scaricano i file per configurare una serie di file da condividere su più computer.

Se si sceglie questa opzione, un messaggio invita a selezionare uno tra due gruppi di file per il download:
  • File per QUESTO computer: il download conterrà solo i file mancanti nel gruppo dei file di installazione attualmente presente su questo computer.
    Il download dovrebbe avere dimensioni minori perché contiene:
    • Solo i file dei prodotti selezionati nella pagina Selezione prodotti
    • Solo i file di prerequisito necessari al computer e non ancora installati

    Tuttavia se per l'installazione si tenta di utilizzare questo gruppo di file scaricati su un altro computer, alcuni file potrebbero mancare perché i file di installazione per un computer non sono sempre identici a quelli per un altro computer. Si possono utilizzare i file scaricati per l'installazione su un altro computer ma mentre la procedura è in corso potrebbe essere necessario scaricare altri file per completare la serie di file di installazione su tale computer.

  • File da condividere con QUALSIASI computer: il download conterrà il gruppo completo dei file di installazione, da utilizzare per installare questa versione su qualsiasi computer.

    Questo download avrà grandi dimensioni perché contiene tutti i file da usare per installare questa versione di un prodotto su un computer qualsiasi.

    Se si specifica un gruppo limitato di prodotti da installare, questa opzione ignora tale specifica e scarica tutti i prodotti contenuti nella release.

    Il download conterrà tutti i file necessari per creare un'immagine amministrativa, non solo quelli per eseguire un'installazione individuale.

Installa solo/Crea solo immagine. Possiedo già tutti i file di installazione necessari.

Gestione installazioni SOLIDWORKS non scarica i file ma utilizza quelli presenti nella directory selezionata.

Fare clic su Sfoglia per selezionare una posizione diversa. Ad esempio, è possibile navigare al DVD di installazione o ad una cartella di download, a patto che tale posizione contenga tutti i file necessari.

Nel caso di messaggio di errore circa la cartella non completa mentre si presumevano tutti i file di installazione presenti in quel punto, i potenziali motivi sono:
  • è stato selezionato un componente per l'installazione non scaricato precedentemente o è stato selezionato di default.
  • I file sono stati scaricati su un altro computer con un gruppo diverso di requisiti di sistema.
  • L'utente ha effettuato un'installazione client e ora sta creando un'immagine amministrativa che richiede un gruppo di file più ampio.

È possibile navigare a una cartella contenente tutti i file (ad es. il DVD) oppure selezionare una delle opzioni di download.

Dove si desidera scaricare i file necessari?

La posizione della cartella di download.

In alcuni casi, questa opzione potrebbe essere visibile ma ombreggiata e quindi non selezionabile. Ad esempio, se è selezionato Solo installazione, Gestione installazioni SOLIDWORKS installerà tutti i file scaricati dalla directory specificata nell'opzione, e non utilizzerà una directory di download distinta.

Tutti i file devono essere scaricati nella stessa cartella del download, sia che siano stati scaricati o prelevati da una propria ubicazione.

Dimensione stimata del download

I tempi stimati del download e i requisiti di spazio su disco si basano sull'elenco completo dei componenti scelti, a prescindere che si tratti di un download nuovo o di uno esistente ripreso da una sessione precedente.

Ad esempio, se si riprende un download precedente la Gestione installazioni di SOLIDWORKS elaborerà solo quei file che non sono stati ancora scaricati. I tempi del download potranno essere minori di quelli calcolati.

Se un file è stato scaricato nel download precedente, la sua dimensione non è inclusa nella stima. La stima potrebbe dunque essere superiore alla dimensione effettiva del download.

Come si desidera effettuare il download?

Eseguire il download manuale

In alcuni casi, un server proxy potrebbe impedire i download automatici dalla Gestione installazioni di SOLIDWORKS.

Selezionando questa opzione, è possibile scaricare manualmente i file attraverso una pagina Web, quindi completare l'installazione con la Gestione installazioni di SOLIDWORKS. Questa pagina Web è personalizzata dalla Gestione installazioni di SOLIDWORKS al fine di scaricare solamente i file necessari per completare l'installazione.

Uso di SOLIDWORKS Background Downloader

SOLIDWORKS Background Downloader può essere usato per completare questa operazione di download o per scaricare le future release dei Service Pack di SOLIDWORKS appena diventano disponibili.

Solidworks Background Downloader può identificare automaticamente e scaricare nuovi aggiornamenti service pack nel background, notificando quando il download è completato e i file sono pronti per l'installazione. Per i dettagli, vedere SOLIDWORKS Background Downloader.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Opzioni di download per i file di Gestione installazioni SOLIDWORKS

Si è scelto di scaricare una versione successiva della Gestione installazioni di SOLIDWORKS. Usare questo schermo per specificare dove e come scaricare.

Per le risposte alle domande relative alla cartella del download, vedere Cartella di download di Gestione installazioni SOLIDWORKS.

Questa schermata compare solo se si è verificato un problema con la cartella di download di default (es. se manca il diritto di scrittura o l'accesso di rete). Di solito, è sufficiente specificare una directory di download alternativa per continuare.

Directory del download

Navigare alla destinazione per i file della Gestione installazioni di SOLIDWORKS.

Sono visualizzate la dimensione del download e la quantità di spazio necessaria. La quantità di spazio necessario comprende lo spazio extra per estrarre certi download e sarà maggiore della dimensione del download attuale.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Download dei file di installazione del prodotto

Specificare dove e come scaricare i file mancanti per il prodotto specificato.

La Gestione installazioni di SOLIDWORKS scarica, verifica ed estrae tutti i file in parallelo durante il processo di download.

Uscendo da questa schermata verrà annullato il resto della sequenza di installazione.

Per le conseguenze dell'annullamento e le istruzioni su come completare le installazioni interrotte, vedere Errori di installazione / Installazione annullata.

Directory del download

Navigare alla destinazione per i file scaricati.

Sono mostrati la dimensione del download e lo spazio necessario. La quantità di spazio necessario comprende lo spazio necessario per estrarre determinati download e sarà maggiore della dimensione del download attuale.

Per le risposte alle domande relative alla cartella del download, vedere Cartella di download di Gestione installazioni SOLIDWORKS.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Errori di installazione / Installazione annullata
Cartella di download di Gestione installazioni SOLIDWORKS


Avanzamento del download

La Gestione installazioni di SOLIDWORKS scarica, verifica ed estrae tutti i file in parallelo durante questo processo.

Per annullare il download dopo l'avvio, fare clic su Annulla.

Se si annulla il download o se questo non riesce, uno schermo Download annullato o Problema di download indicherà quali download non sono stati completati e consentirà di riprendere la procedura o di chiudere l'applicazione.

Per le risposte alle domande relative alla cartella del download, vedere Cartella di download di Gestione installazioni SOLIDWORKS.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Risultati del download

Indica se il download si è completato correttamente, se non è riuscito o se è stato annullato.

Problema di download/Download annullato

Se appare il messaggio Problema di download, la Gestione installazioni di SOLIDWORKS ha riscontrato problemi che hanno impedito il buon esito del download.

Se appare il messaggio Download annullato, l'utente ha annullato il download prima che fosse completato.

Per continuare:

Riprova/Riprendi download automatici | Per riprendere un download automatico dal punto in cui è stato annullato, selezionare questa opzione e fare clic su Riprova download o Riprendi download.
Scarica i file singolarmente in un browser web | In alcuni casi, un server proxy potrebbe impedire i download automatici dalla Gestione installazioni di SOLIDWORKS. | Selezionando questa opzione, è possibile scaricare manualmente i file attraverso una pagina Web, quindi completare l'installazione con la Gestione installazioni di SOLIDWORKS. Questa pagina Web è personalizzata dalla Gestione installazioni di SOLIDWORKS al fine di scaricare solamente i file necessari per completare l'installazione.

Download completo

La schermata Download completato appare quando termina il download se si è specificata l'opzione Solo download.

Fare clic su Fine per chiudere la Gestione installazioni di SOLIDWORKS.

Non tentare di installare uno di questi prodotti manualmente. Utilizzare sempre la Gestione installazioni di SOLIDWORKS per installare i file scaricati.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Errori di installazione / Installazione annullata

L'installazione ha riscontrato un errore o è stata annullata.

Se si verifica un errore o un annullamento:
  • i prodotti installati prima dell'errore o annullamento rimarranno nel computer.
  • Il prodotto in via di installazione al momento dell'annullamento viene riportato allo stato precedente, in modo che non ci siano installazioni parziali.
  • I prodotti restanti non sono installati o sono stati disinstallati. L'elenco è fornito in Non ancora tentato.

    Per riprendere l'installazione o la disinstallazione di questi prodotti, fare clic sui link forniti.

La Gestione installazioni di SOLIDWORKS prima installa qualsiasi prerequisito non installato nel computer, come ad esempio .NET Framework.

Indice

  • Ripristino da un'installazione non riuscita o annullata

    Se si verifica un errore o un'interruzione durante l'installazione, è possibile recuperarla da quel punto rieseguendo l'installazione.

  • Riparazione di un'installazione

    In caso di problemi con un prodotto SOLIDWORKS installato, usare Gestione installazioni SOLIDWORKS per ripristinare l'installazione.

  • Come contattare il rivenditore SOLIDWORKS

    Se la modifica o riparazione dell'installazione non riesce, contattare il proprio rivenditore SOLIDWORKS con le informazioni raccolte da questo schermo. Potrebbe essere necessario fornire un file zip dei file log della Gestione installazioni di SOLIDWORKS.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Ripristino da un'installazione non riuscita o annullata

Se si verifica un errore o un'interruzione durante l'installazione, è possibile recuperarla da quel punto rieseguendo l'installazione.

  1. Registrare il messaggio di errore e il codice del prodotto per l'installazione non riuscita, come mostrato nella schermata Errori di installazione o Installazione annullata.
    Se il software richiede un file di origine e non si sta modificando un'installazione SOLIDWORKS esistente, l'installazione o il computer potrebbero essere danneggiati. Rivolgersi al proprio rivenditore SOLIDWORKS.
  2. Riavviare il proprio computer.
  3. Per verificare che nessun prodotto SOLIDWORKS sia in esecuzione, in Windows, premere i tasti Ctr+Alt+Del per aprire Gestione attività.
  4. Nella scheda Processi, se uno qualsiasi dei seguenti processi appare in Nome immagine, selezionarlo e fare clic su Fine processo.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Se l'applicazione è già installata e si tenta di modificare o rimuoverla, provare a riparare l'installazione. Per i dettagli, vedere Riparazione di un'installazione.
  6. In Windows, fare clic su Start > Pannello di controllo > Programmi e funzionalità.
  7. Selezionare la versione di SOLIDWORKS che non è riuscita.
    Se non esiste una voce corrispondente alla versione di SOLIDWORKS in via di installazione, ripetere la procedura di installazione.
  8. Procedere in uno dei modi seguenti:
    • Per riprovare, fare clic su Cambia e selezionare tutti i prodotti la cui installazione non è riuscita o è stata ignorata.

    • Per ignorare le installazioni non riuscite, fare clic su Cambia e selezionare tutti i prodotti la cui installazione è stata ignorata. Deselezionare il prodotto con installazione non riuscita.

    • Per abbandonare l'installazione, fare clic su Rimuovi e selezionare qualsiasi prodotto già installato.
    Ciò non ripristinerà la versione precedente di qualsiasi prodotto in via di aggiornamento.
Argomento principale Errori di installazione / Installazione annullata
Riparazione di un'installazione
Come contattare il rivenditore SOLIDWORKS


Come contattare il rivenditore SOLIDWORKS

Se la modifica o riparazione dell'installazione non riesce, contattare il proprio rivenditore SOLIDWORKS con le informazioni raccolte da questo schermo. Potrebbe essere necessario fornire un file zip dei file log della Gestione installazioni di SOLIDWORKS.

  1. Identificare i file di log. Per Windows:
    C:\Users\nome utente\AppData\Roaming\SOLIDWORKS\Installation Logs\versione installata\.
    Se non si trova la cartella, potrebbe essere nascosta. In Esplora file, fare clic su Strumenti > Opzioni cartella. Nella scheda Visualizza, in Impostazioni avanzate, selezionare Visualizza cartelle, file e unità nascosti per File e cartelle nascosti.
  2. comprimere l'intero contenuto di questa cartella, comprese le sottocartelle.
Argomento principale Errori di installazione / Installazione annullata
Ripristino da un'installazione non riuscita o annullata
Riparazione di un'installazione


Installazione completata

La Gestione installazioni di SOLIDWORKS ha completato la procedura.

Potrebbero visualizzarsi una o più di queste opzioni.

Novità

Per le installazioni individuali, alla fine del processo di installazione, apparirà un documento che descriverà la nuova funzionalità in SOLIDWORKS e i relativi prodotti aggiuntivi.

Per le installazioni dall'immagine amministrativa, il documento apparirà sui computer client al completamento dell'installazione.

Partecipa al programma di miglioramento dell'esperienza clienti di SOLIDWORKS

Le informazioni di prestazione vengono inviate alla SOLIDWORKS Corporation per migliorare il prodotto. Il processo è trasparente e confidenziale. Selezionare una delle seguenti opzioni:
  • Sì, voglio unirmi
  • No, grazie
  • Ricorda in seguito
Per ulteriori informazioni, vedere il sito Web del Programma di miglioramento dell'esperienza clienti.

La creazione dell'immagine amministrativa è completata

Ultimata la creazione dell'immagine amministrativa, è possibile fare clic su Personalizza immagine per eseguire l'Editor opzioni dell'immagine amministrativa.

Fare clic su Dimostra come installare questa immagine su un client per visualizzare le istruzioni sull'uso dell'Editor opzioni.

Per i dettagli sulla configurazione di un'immagine amministrativa con l'Editor opzioni, vedere Editor opzioni immagine amministrativa.

Fare clic su Personalizza immagine per avviare l'Editor opzioni immagine amministrativa e personalizzare le impostazioni delle opzioni per questa immagine amministrativa.
È possibile avviare l'Editor opzioni successivamente facendo doppio clic su sldAdminOptionEditor.exe nella cartella SOLIDWORKS Admin.

Indice

  • Verifica degli aggiornamenti per SOLIDWORKS

    Se si dispone dei privilegi di amministratore, è possibile utilizzare Gestione installazioni di SOLIDWORKS per verificare manualmente la disponibilità di aggiornamenti o per configurare automaticamente il controllo degli aggiornamenti.

  • Programma di miglioramento dell'esperienza clienti SOLIDWORKS

    Quando si installa SOLIDWORKS, si può specificare che le informazioni sulle prestazioni vengano inviate a SOLIDWORKS Corporation per migliorare il prodotto.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Editor opzioni immagine amministrativa


Verifica degli aggiornamenti per SOLIDWORKS

Se si dispone dei privilegi di amministratore, è possibile utilizzare Gestione installazioni di SOLIDWORKS per verificare manualmente la disponibilità di aggiornamenti o per configurare automaticamente il controllo degli aggiornamenti.

  1. Avviare la Gestione installazioni di SOLIDWORKS effettuando una delle seguenti operazioni:

    • Nell'applicazione SOLIDWORKS, fare clic su ? > Verifica aggiornamenti.

    • In Windows, fare clic su Start > Tutti i programmi > SOLIDWORKS Installation Manager > Verifica aggiornamenti.

    È anche possibile fare clic su Start > Gestione installazioni SOLIDWORKS > SOLIDWORKS Background Downloader. Nell'area delle notifiche di Windows, fare clic con il pulsante destro del mouse su SOLIDWORKS Background Downloader e fare clic su Verifica aggiornamenti.
    La Gestione installazioni di SOLIDWORKS indica se sono disponibili nuovi aggiornamenti.
  2. Se sono disponibili, scegliere se scaricarli ed installarli.
  3. Per abilitare il controllo periodico e automatico degli aggiornamenti, al termine della Gestione installazioni di SOLIDWORKS selezionare Verifica aggiornamenti ogni __ giorni e specificare la frequenza dei controlli.
Argomento principale Installazione completata
Programma di miglioramento dell'esperienza clienti SOLIDWORKS


Programma di miglioramento dell'esperienza clienti SOLIDWORKS

Quando si installa SOLIDWORKS, si può specificare che le informazioni sulle prestazioni vengano inviate a SOLIDWORKS Corporation per migliorare il prodotto.

SOLIDWORKS utilizza questi dati per determinare le abitudini relative all'uso del prodotto e alla qualità. Il nostro obiettivo è quello di fornire la massima qualità nel prodotto e i log della prestazione vengono appunto utilizzati in questo processo.

Il processo è trasparente. Tutte le informazioni contenute nei file di registro sono riservate. Non vengono utilizzate per altri scopi e l'utente non sarà contattato.

Per ulteriori informazioni, vedere il sito Web del Programma di miglioramento dell'esperienza clienti.

Argomento principale Installazione completata
Verifica degli aggiornamenti per SOLIDWORKS


Ubicazione installazione

Per tutte installazioni tranne la creazione di un'immagine amministrativa, valgono queste opzioni:
Installa i prodotti selezionati in | La directory nella quale si installa SOLIDWORKS. Quando si aggiorna o di modifica un'installazione, tutti i file devono essere installati nella posizione esistente di tale installazione. In questo caso, non è possibile cambiare al posizione dell'installazione esistente di SOLIDWORKS.
Spazio stimato necessario per l'installazione | Si tratta di spazio aggiuntivo necessario per i prodotti selezionati per l'installazione o la modifica. | Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti di installazione.
Installa da | La directory dalla quale si installa SOLIDWORKS. Questa opzione è disponibile solo se si è selezionata l'opzione Solo installazione. Per i dettagli, vedere le Opzioni di download.
Rivolgersi all'amministratore del sistema prima di cambiare la posizione di installazione di SOLIDWORKS.

Ubicazioni immagine amministrativa

Quando si crea un'immagine amministrativa, valgono queste opzioni:
Nuova ubicazione immagine | La directory nella quale la Gestione installazioni SOLIDWORKS creerà la nuova immagine. | Questa posizione non può contenere un'immagine amministrativa esistente.
Spazio stimato necessario per la creazione dell'immagine | Spazio aggiuntivo necessario per l'immagine amministrativa. | Verificare che il disco di installazione abbia una quantità di spazio disponibile sufficiente in base ai requisiti dell'immagine.
Crea immagine da | La directory dalla quale si installano i prodotti SOLIDWORKS. Questa opzione è disponibile solo se si è selezionata l'opzione Solo installazione. Per i dettagli, vedere le Opzioni di download.
Ubicazione immagine esistente | Quando si aggiorna un'immagine amministrativa esistente, Gestione installazioni SOLIDWORKS crea una nuova immagine in base alle impostazioni dell'immagine esistente. Questa immagine esistente non viene modificata. Indica la posizione dell'immagine originale specificata nella schermata Benvenuti.

Evitare l'uso di percorsi di directory specifici per la versione

Se si specifica un numero di versione in una posizione della directory di installazione (ad esempio C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2023\) e poi si effettua l'upgrade a SOLIDWORKS 2024, la directory di installazione di SOLIDWORKS 2024 verrà etichettata con SOLIDWORKS 2023.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Opzioni di download


Opzioni di aggiornamento

Una o più precedenti versioni maggiori di SOLIDWORKS sono installate su questo computer. È possibile creare una nuova installazione, che coesisterà con la versione precedente; in alternativa, è possibile eseguire un aggiornamento che rimuoverà la versione precedente.

Creazione di una nuova installazione di SOLIDWORKS versione.

Se si sceglie di creare una nuova installazione, è possibile selezionare il prodotto SOLIDWORKS da installare.

Per ciascuno dei prodotti selezionati, viene creata una nuova installazione di questa versione principale. Le precedenti versioni principali restano sul computer, a eccezione di SOLIDWORKS Electrical e SOLIDWORKS PDM Client.

Se si deseleziona un prodotto, la nuova versione non viene installata.

La creazione di una nuova versione può essere utile per accedere alla versione precedente di SOLIDWORKS dopo aver installato una versione più recente. Ad esempio, se si condividono i file con altri utenti che ancora utilizzano la versione precedente, utilizzare la versione più recente per evitare incompatibilità di file tra le versioni.

Aggiornare SOLIDWORKS previous_major_version a SOLIDWORKS current_major_version.

Se si sceglie di eseguire l'aggiornamento, è possibile selezionare il prodotto SOLIDWORKS da aggiornare. Per ciascuno dei prodotti selezionati viene creata una nuova installazione e vengono rimosse le versioni precedenti.

Se si deseleziona un prodotto, la nuova versione non viene installata e la versione precedente rimane sul computer.

Note relative a SOLIDWORKS Electrical e SOLIDWORKS PDM Client

È possibile installare una sola versione di SOLIDWORKS Electrical su un computer. Se si sta creando una nuova installazione di SOLIDWORKS e si seleziona SOLIDWORKS Electrical tra i prodotti da installare, la versione precedente di SOLIDWORKS Electrical viene rimossa.

Eseguire il backup dell'ambiente SOLIDWORKS Electrical esistente prima di installare la nuova versione. In Schemi di SOLIDWORKS Electrical selezionare File Archivia ambiente, oppure in SOLIDWORKS Electrical 3D selezionare SOLIDWORKS Electrical > Strumenti > Archivia ambiente.

La versione principale del client SOLIDWORKS PDM deve corrispondere alla versione principale del server SOLIDWORKS PDM. Se non si intende aggiornare SOLIDWORKS PDM Server, deselezionare l'aggiornamento di SOLIDWORKS PDM.

Per rimuovere un componente di prodotto, in Windows, utilizzare Installazione applicazioni. Per i dettagli, vedere Rimozione di un'installazione.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Rimozione di un'installazione


Avanzamento dell'installazione

Questo schermo mostra l'avanzamento dell'installazione.

Per annullare l'installazione dopo l'avvio, fare clic su Annulla.

Per le conseguenze dell'annullamento e le istruzioni su come completare le installazioni interrotte, vedere Errori di installazione.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Tipo di installazione

È possibile specificare l'operazione di installazione che si desidera eseguire. Ad esempio, creazione di una nuova installazione, modifica o riparazione di un'installazione esistente, creazione di un'immagine amministrativa, installazione di prodotti del server amministrativo o download di file da condividere e installare su altri computer.

Se la versione più recente del software SOLIDWORKS è già installata sul computer, sono disponibili le opzioni per modificarla o ripararla.

Individuale

Installare i prodotti SOLIDWORKS su questo computer.

Questa opzione compare solo se la versione non è installata sul computer.

Modifica l'installazione individuale

Modificare l'installazione esistente di SOLIDWORKS su questo computer.

Questa opzione compare solo se la versione è installata sul computer.
Le modifiche comprendono:
  • Aggiunta o rimozione dei componenti di prodotto SOLIDWORKS
  • Selezione di un pacchetto SOLIDWORKS diverso (es. SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate, ecc.)
  • Modifica del numero seriale di SOLIDWORKS
    Se si è già specificato un numero seriale di SOLIDWORKS durante un'installazione precedente, la Gestione installazioni di SOLIDWORKS potrebbe non visualizzare di nuovo la richiesta. Per modificare il numero di serie, è necessario selezionare questa opzione.

Correggi l'installazione individuale

Ripristinare l'installazione esistente di SOLIDWORKS su questo computer.

Questa opzione compare solo se la versione è installata sul computer.
La riparazione verifica che tutti i file siano presenti e registrati e le risoluzioni siano definitive. I dati creati non sono impattati.
  • Per rimuovere un prodotto, assicurarsi che sia selezionato.
  • Deselezionare le caselle per i prodotti che non devono essere riparati.
Un'installazione individuale può essere riparata. Non è possibile riparare un'installazione con immagine amministrativa, ma è necessario reinstallarla.

Immagine amministrativa

Creare o aggiornare un'immagine amministrativa da distribuire su più computer.

Per i dettagli sull'installazione di SOLIDWORKS su più client con l'uso delle immagini amministrative, vedere Uso di immagini amministrative.

Quando si crea o aggiorna un'immagine amministrativa:
  • È possibile utilizzare le impostazioni di installazione di un'immagine esistente per configurare l'immagine nuova o aggiornata oppure utilizzare le impostazioni di installazione di default di SOLIDWORKS.
  • Se si aggiorna un'immagine esistente:
    • Gestione installazioni SOLIDWORKS crea una nuova copia dell'immagine, anche se si effettua un aggiornamento. L'immagine originale non viene modificata.
    • È possibile creare l'immagine aggiornata utilizzando i file dell'immagine esistente in fase di aggiornamento. Il download risultante è pertanto minore.
    Se non si specifica un'immagine per cui sia disponibile una release Service Pack per l'aggiornamento dell'immagine precedente, non è possibile utilizzare il download di dimensione più piccola.

Prodotti del server

I prodotti del server SOLIDWORKS comprendono SOLIDWORKS Electrical, SOLIDWORKS PDM e SolidNetWork License Manager.

Per SOLIDWORKS Electrical e SOLIDWORKS PDM, è possibile scegliere di installare gli strumenti client e server sullo stesso PC o su PC diversi.

Per i dettagli sull'installazione di questi server, vedere gli argomenti corrispondenti nella Guida in linea.

Scarica e condividi tutti i file

Scaricare i file di installazione per i prodotti SOLIDWORKS selezionati senza installare i prodotti.

Questa opzione non è disponibile se si utilizza un DVD per l'installazione.
Il contenuto dei file scaricati è identico ai file disponibili sui DVD di installazione di SOLIDWORKS. Selezionare questa opzione per scaricare il gruppo completo dei file d'installazione, a prescindere da quali file possano già essere installati sul computer. È quindi possibile copiare i file su un dispositivo portatile o in una directory di rete e utilizzarli per installare il software SOLIDWORKS su altri computer. È anche possibile utilizzare questo metodo per impostare un server dal quale gli utenti potranno eseguire le installazioni.
Questo metodo è diverso dalla creazione di un'immagine amministrativa.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Uso di immagini amministrative
Amministrazione delle licenze mediante SolidNetWork License Manager
SOLIDWORKS Electrical


Installazione e gestione di computer multipli

La Gestione installazioni di SOLIDWORKS fornisce i seguenti strumenti per installare e gestire multipli computer SOLIDWORKS.

Immagini amministrative di SOLIDWORKS

Se si installa SOLIDWORKS su multipli computer, sarà possibile creare un'immagine amministrativa e quindi implementare l'applicazione su altri computer.

SOLIDWORKS PDM

SOLIDWORKS PDM è un prodotto per la gestione dei documenti basato sulla stessa architettura client/server di SOLIDWORKS Enterprise PDM. È disponibile in due versioni: Standard e Professional. SOLIDWORKS PDM utilizza un database Microsoft SQL Server per gestire i vault.

SolidNetWork License Manager

SolidNetWork License Manager consente al numero di utenti di eccedere il numero di licenze rendendo mobile l'uso delle licenze. Quando la licenza di un client non è in uso, è disponibile per un altro utente SOLIDWORKS.

È anche possibile usare SolidNetWork License Manager per distribuire le licenze per i prodotti aggiuntivi principali di SOLIDWORKS come ad esempio FeatureWorks.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Download manuale

Si è scelto di scaricare i file manualmente (oppure si sono scaricati manualmente i file all'ultima esecuzione della Gestione installazioni di SOLIDWORKS).

Fare clic sul link per aprire una pagina web generata automaticamente con un elenco completo dei file necessari per il download.

È necessario scaricarli nella cartella indicata nella pagina di riepilogo. L'installazione non può iniziare se non sono stati scaricati tutti i file nella cartella.

Una volta completati i download manuali, fare clic su Avanti per continuare.

Per scaricarli manualmente, è possibile modificare l'opzione tornano alla pagina di riepilogo e modificando le opzioni di download.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Versione più recente disponibile

La Gestione installazioni ha identificato una versione più recente dei prodotti SOLIDWORKS. Si può scegliere di installare la versione contenuta nel dvd d'installazione originale o nel download oppure scaricare ed installare la versione più recente.

Se si installa da un download

Scegliere una delle seguenti opzioni:
  • Continuare a installare versione.

    Selezionare questa opzione per continuare ad installare la versione contenuta nel download iniziale.

  • Scaricare e installare una nuova versione: versione.

    Selezionare questa opzione per scaricare e installare la nuova versione. Nel caso di versioni multiple disponibili, selezionare la versione da scaricare ed installare.

Se si installa da un DVD

In Utilizzare la versione più recente?, selezionare una delle risposte seguenti:
  • No, continuare a installare versione da questo DVD. L'aggiornamento può avvenire successivamente.

    Selezionare questa opzione per continuare l'installazione utilizzando la Gestione installazioni corrente.

    Al completamento dell'installazione, sarà possibile selezionare ed installare gli aggiornamenti usando la Gestione installazioni. Per controllare gli aggiornamenti, selezionare Start > Gestione installazioni di SOLIDWORKS > Verifica aggiornamenti.
    Il comando Verifica aggiornamenti è disponibile solo se si dispone di privilegi di amministratore per il computer.

    Il vantaggio è che questo genera un download più piccolo. Gli svantaggi sono rappresentati dal fatto che questa è una procedura a due fasi e i file scaricati sono specifici della versione (e non possono essere condivisi usando versioni diverse).

  • Sì, esegui l'installazione da questo DVD, quindi scarica e aggiorna a versione.

    Selezionare questa opzione per scaricare ed eseguire una versione più recente della Gestione installazioni per installare i prodotti SOLIDWORKS per quella versione.

    Se è disponibile un piccolo Service Pack per aggiornare la versione su DVD, la Gestione installazioni installa la versione originale dal DVD e poi applica l'aggiornamento del Service Pack. Il download risultante è pertanto minore.

    È possibile ottenere lo stesso risultato selezionando l'opzione per continuare l'installazione da DVD e applicare l'aggiornamento in un momento successivo.

    Il vantaggio è che questa opzione è una procedura unica.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Nessuna nuova versione disponibile

Non ci sono versioni più recenti disponibili per il download. Procedere con l'installazione della versione specifica.

Per procedere con l'installazione, fare clic su Avanti.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Processi rilevati

La Gestione installazioni di SOLIDWORKS ha rilevato alcuni processi in corso su questo computer che possono impedire la riuscita dell'installazione.

  • Per continuare l'installazione, adottare una delle seguenti metodologie:
    • Chiudere questi processi (es. l'uso del Task Manager in Microsoft Windows) e premere Riprova.
    • Fare clic su Ignora per procedere senza chiudere i processi.
  • Per interrompere l'installazione, premere Annulla.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Selezione prodotti

È possibile specificare i componenti del prodotto da installare, modificare, scaricare o rimuovere.

Nell'elenco prodotti:
  • L'elenco prodotti contiene tutti i prodotti disponibili nel pacchetto specificata sopra l'elenco stesso.
  • Per visualizzare l'azione prevista di un componente specifico, fare clic sul nome del componente (ma non sulla sua casella di controllo). L'azione prevista appare nel campo delle informazioni sotto l'elenco dei prodotti.
  • Per cambiare l'azione di installazione per un componente del prodotto, fare clic sulla casella di controllo relativa al componente stesso. (Ad esempio, se si sta installando o rimuovendo componenti, selezionando la casella di controllo si specifica che il componente deve essere installato o rimosso e deselezionandola si specifica che il componente non deve essere installato o rimosso).
  • Se si esegue Modifica installazione, appare un asterisco (*) a sinistra dei componenti dopo aver apportato modifiche alla selezione.
  • Se un componente dispone di sottocomponenti da installare in modo opzionale, accanto al componente viene visualizzata l'icona +. Per visualizzare i sottocomponenti disponibili per un componente, fare clic sull'icona +.
  • Quando si espande un componente per visualizzare i sottocomponenti opzionali, accanto al componente viene visualizzata l'icona -. Per comprimere l'elenco dei sottocomponenti, fare clic sull'icona -.

Se si applica un Service Pack, non è possibile selezionare le funzioni di SOLIDWORKS visualizzate sotto SOLIDWORKS (ad es. FeatureWorks). Ciò accade perché non è possibile aggiungere o rimuovere una funzione quando si effettua questo tipo di aggiornamento.

Le azioni effettuate da SOLIDWORKS Installation Manager sono controllate da un gruppo di regole di coesistenza del prodotto. Per i dettagli, vedere Regole di coesistenza del prodotto.

SOLIDWORKS Installation Manager seleziona per impostazione predefinita questi componenti di prodotto:
  • Se si esegue un aggiornamento o si installa un Service Pack, Gestione installazioni di SOLIDWORKS deseleziona i prodotti attualmente installati.
  • Diversamente, Gestione installazioni di SOLIDWORKS selezionerà tutti i prodotti cui ha diritto l'utente.
Per ridurre i tempi di installazione o download e i requisiti di spazio su disco, espandere i componenti del prodotto e deselezionare la casella di controllo dei componenti non desiderati.

Se Gestione installazioni SOLIDWORKS non ha potuto verificare i prodotti cui ha diritto l'utente, è possibile fare clic su Seleziona pacchetti o prodotti diversi per cambiare il pacchetto di prodotti (es. SOLIDWORKS Professional, SOLIDWORKS Premium o SOLIDWORKS Ultimate) da installare o modificare. Gestione installazioni di SOLIDWORKS elenca tutti i prodotti SOLIDWORKS presenti sui supporti di installazione che sono compatibili con il pacchetto selezionato. È possibile selezionare un prodotto qualsiasi tra quelli acquistati o in valutazione.

Ricerca SOLIDWORKS

La Ricerca SOLIDWORKS fornisce un mezzo di ricerca efficace dei documenti SOLIDWORKS. La ricerca visualizza un'anteprima e l'ubicazione del file e il nome.

Dopo l'installazione, Ricerca SOLIDWORKS indicizza i documenti SOLIDWORKS per rendere più rapide le ricerche. Di default, vengono indicizzati solo i file SOLIDWORKS.

Supporto internazionale

Espandere il prodotto SOLIDWORKS e il componente Lingue per visualizzare le lingue che è possibile installare.

La specifica Lingue limita le lingue installate solo per il prodotto SOLIDWORKS. Le installazioni di altri prodotti non saranno condizionate da questa specifica. Ad esempio, eDrawings® e SOLIDWORKS PDM installano tutte le lingue.

Spazio necessario

Gestione installazioni SOLIDWORKS indica la dimensione totale dell'installazione o quella totale del download nella parte inferiore della pagina.

  • Se si seleziona l'opzione Solo download, viene visualizzata la dimensione del download. La dimensione del download è l'ammontare totale di spazio su disco richiesto per tutti i file scaricati (non incluso lo spazio extra per estrarre i file dopo il completamento del download). Quest valore è un'approssimazione.
    Tutti i file necessari per l'installazione sono compresi nella dimensione del download totale. Se alcuni file sono già stati scaricati nella cartella di download corrente, non vengono scaricati di nuovo. Quindi, la dimensione effettiva del download potrà essere minore della dimensione del download totale o potrà non essere necessario scaricare alcun file.
  • Altrimenti, apparirà la dimensione dell'installazione. La dimensione dell'installazione è la modifica nell'uso di spazio su disco necessaria al completamento di questa installazione. A causa della compressione del file, queste cifre sono approssimative.

    Nel caso di aggiornamento o rimozione di un'installazione esistente, la dimensione dell'installazione potrà essere zero.

    Il valore indicato non comprende lo spazio necessario per scaricare o estrarre i file se necessari per l'installazione.

    Se i download sono necessari e l'utente sta scaricando nella stessa unità, i requisiti di spazio su disco effettivi potranno essere significativamente maggiori rispetto alla dimensione dell'installazione che appare.

    Per ridurre i tempi del download o di installazione per le modifiche future, non cancellare i file scaricati dopo l'installazione. Gli aggiornamenti e le patch successive richiedono generalmente l'accesso all'ultimo gruppo completo dei file d'installazione.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Regole di coesistenza del prodotto


Prodotti da scaricare

Selezionare i prodotti SOLIDWORKS da scaricare in un punto specifico.

I prodotti disponibili per il download sono determinati dal numero seriale fornito:

  • l'azione da effettuare per ciascun componente appare alla destra di ogni elemento.
  • Se accanto al componente viene visualizzata l'icona +, vuol dire che dispone di sottocomponenti da installare a scelta. Per visualizzare tali sottocomponenti, fare clic sull'icona +.
  • Quando si espande un componente per visualizzarne i sottocomponenti facoltativi, accanto al componente viene visualizzata l'icona -. Per comprimere l'elenco di sottocomponenti, fare clic sull'icona -.
  • Fare clic sulla casella a sinistra di ogni componente per scegliere come gestire la Gestione installazioni di SOLIDWORKS.
Gestione installazioni SOLIDWORKS scarica tutti i componenti del prodotto cui l'utente ha diritto, tranne se diversamente specificato. Per ridurre i tempi del download e i requisiti di spazio su disco, espandere i componenti del prodotto e deselezionare i componenti non necessari.

Se Gestione installazioni di SOLIDWORKS non ha potuto verificare i prodotti cui l'utente ha diritto, selezionare un pacchetto SOLIDWORKS da scaricare. Gestione installazioni di SOLIDWORKS elenca tutti i prodotti SOLIDWORKS compatibili con il pacchetto selezionato.

Se Gestione installazioni SOLIDWORKS non ha potuto verificare i prodotti cui ha diritto l'utente, è possibile fare clic su Seleziona pacchetti o prodotti diversi per cambiare il pacchetto di prodotti (es. SOLIDWORKS Professional, SOLIDWORKS Premium o SOLIDWORKS Ultimate) da installare o modificare. Gestione installazioni di SOLIDWORKS elenca tutti i prodotti SOLIDWORKS presenti sui supporti di installazione che sono compatibili con il pacchetto selezionato. È possibile selezionare un prodotto qualsiasi tra quelli acquistati o in valutazione.

Supporto internazionale

La specifica Lingue limita le lingue installate per il solo prodotto SOLIDWORKS. Le installazioni di altri prodotti non saranno condizionate da questa specifica. Ad esempio, eDrawings® installa tutte le lingue.

Spazio necessario

In base ai prodotti selezionati, lo spazio necessario per effettuare il download verrà visualizzato. La dimensione del download è l'ammontare totale di spazio su disco richiesto per tutti i file scaricati (non incluso lo spazio extra per estrarre i file dopo il completamento del download). Quest valore è un'approssimazione.

Per ridurre i tempi del download o di installazione per gli aggiornamenti futuri e le patch, non cancellare i file scaricati dopo l'installazione. Gli aggiornamenti e le patch successive richiedono generalmente l'accesso all'ultimo gruppo completo dei file d'installazione.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Prodotti da riparare

Quando si seleziona Ripara questa installazione, questo schermo visualizzerà i prodotti SOLIDWORKS con i numeri di versione che potranno essere riparati da questa Gestione installazione di SOLIDWORKS.

La riparazione verifica che tutti i file siano presenti e registrati e le risoluzioni siano definitive. I dati creati non sono impattati.
  • Per rimuovere un prodotto, assicurarsi che sia selezionato.
  • Deselezionare le caselle per i prodotti che non devono essere riparati.

Fare clic su Ripara per iniziare a riparare i prodotti selezionati.

Un'installazione individuale può essere riparata. Non è possibile riparare un'installazione con immagine amministrativa, ma è necessario reinstallarla.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Numeri di seriali

I numeri di serie associano il computer ai prodotti SOLIDWORKS acquistati.

Se sul computer sono già installati dei prodotti SOLIDWORKS, i relativi numeri di serie vengono visualizzati per impostazione predefinita:
  • immettere il numero di serie del prodotto SOLIDWORKS se non viene visualizzato.
  • Se si dispone di numeri seriali per prodotti non inclusi nella licenza SOLIDWORKS, immetterli nei campi appropriati.

Con una connessione Internet, i numeri di serie forniti determinano i prodotti ai quali ha diritto l'utente mentre si prosegue con l'installazione.

Visto che esistono diverse modalità per l'acquisto dei prodotti SOLIDWORKS, alcuni numeri seriali potranno coprire due o più prodotti. Per esempio, un numero seriale per SOLIDWORKS può permettere di installare SOLIDWORKS Simulation senza immettere un numero seriale separato per SOLIDWORKS Simulation. Inoltre, alcuni prodotti non necessitano di un numero seriale. In caso di domande relative ai numeri seriali, contattare il proprio VAR.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Installazione del server

I prodotti server che l'utente tenta di installare sono elencati, con i risultati delle installazioni.

Stato di installazione del server

Le installazioni di prodotti server sono eseguite da un'applicazione esterna. Se tale applicazione non è in uso, è necessario attivarla per completare l'installazione.

Fare clic su Annulla per interrompere le installazioni di prodotti server.

Installazione server completata

L'applicazione esterna si è conclusa.

Fare clic su Fine o su Avanti.
  • Se si installano altri prodotti amministrativi (es. un'immagine amministrativa SOLIDWORKS), l'installazione continua.
  • Se l'installazione di prodotti server è l'unica procedura di installazione che si desidera eseguire, a questo punto la Gestione installazioni di SOLIDWORKS si chiude.

Installazione server annullata o non riuscita

Se l'installazione di un prodotto server è stata annullata o non è riuscita dopo l'avvio, i server non installati saranno elencati.

Fare clic su Chiudi o su Avanti.
  • Se si sono specificate altre installazioni di prodotti amministrativi, la Gestione installazioni di SOLIDWORKS riprende.
  • Se l'installazione di prodotti server è l'unica procedura di installazione che si desidera eseguire, a questo punto la Gestione installazioni di SOLIDWORKS si chiude.

Per saperne di più

Per ulteriori informazioni su installazione, configurazione e utilizzo di SolidNetWork License Manager, vedere Amministrazione delle licenze mediante SolidNetWork License Manager.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Sintesi

La Gestione installazioni di SOLIDWORKS ha tutte le informazioni necessarie per completare l'installazione.

Per continuare: | Fare clic sul pulsante azione ora per avviare l'installazione (ad esempio Installa ora, Crea ora, Scarica ora, Modifica ora).
Per modificare le impostazioni di installazione: | Fare clic su CAMBIA [image] nella sezione che si desidera modificare (ad esempio Prodotti, Ubicazione installazione, Opzioni Toolbox).
Per annullare: | Fare clic su Annulla per uscire da Gestione installazioni di SOLIDWORKS senza modificare i componenti dell'installazione.
Per tornare a una pagina precedente: | Fare clic su Indietro per tornare a una pagina precedente in Gestione installazioni di SOLIDWORKS.
Per informazioni su uno specifico set di opzioni di installazione (ad esempio, Prodotti, Ubicazione installazione, Opzioni Toolbox e così via):
  1. Fare clic su CAMBIA [image] in corrispondenza della sezione per la quale si desidera ottenere maggiori informazioni.
  2. Nella pagina dei dettagli che viene visualizzata fare clic su ? per ottenere informazioni relative alle opzioni di installazione corrispondenti.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Avvertimenti di controllo sistema

La Verifica del sistema ha riportato problemi che possono avere conseguenze se si decide di continuare con l'installazione. Nella maggioranza dei casi, si potrà procedere senza problemi con la Gestione installazioni di SOLIDWORKS.

Gli avvertimenti possono verificarsi in qualsiasi fase tra quelle sotto elencate e forniscono suggerimenti per continuare.

Problemi di convalida del numero seriale

La Gestione installazioni non è stata in grado di verificare la disponibilità di nuove versioni perchè non è riuscita a convalidare il numero di serie. Se si è connessi ed è stato inserito un numero di serie valido, ciò potrebbe indicare un problema temporaneo sul server di SOLIDWORKS. Riprovare in un altro momento.

Convalida numero seriale: La Gestione installazioni di SolidWorks non ha potuto convalidare il numero seriale per stabilire quali prodotti possono essere installati. Si potrà comunque scegliere i prodotti da installare, ma non sarà possibile scaricare i file di installazione. È necessario procurarsi un gruppo completo dei file sorgente oppure il DVD di installazione.

Risoluzione:
  • Controllare la connessione Internet. Il controllo del numero seriale richiede una connessione Internet operativa.
  • Verificare che il numero seriale specificato sia valido per i prodotti che si desidera installare.
  • Per alcune installazioni è necessario essere in possesso di un abbonamento valido al momento del rilascio della versione. Per ulteriori dettagli, consultare il proprio rivenditore SOLIDWORKS.
  • Nella maggioranza dei casi, si potrà procedere all'installazione a patto che si utilizzi un DVD o un gruppo di file scaricati in precedenza.

Versione più recente disponibile

Versione più recente disponibile

Nuove versioni disponibili

È disponibile per il download una versione più recente di questo prodotto.

Risoluzione: Quando si esegue un'operazione Verifica aggiornamenti, l'installazione potrebbe richiedere di installare una versione successiva, disponibile tramite download da SOLIDWORKS. È possibile continuare questa operazione utilizzando la versione inizialmente specificata oppure si può effettuare il download di questa versione più recente e continuare l'operazione usando questa versione.

Versione più recente disponibile

Questa è la versione più recente disponibile. Fare clic su Avanti per continuare.

Nessun nuovo download disponibile

Risoluzione: Questo messaggio può comparire quando si verifica la disponibilità di aggiornamenti durante un'installazione o una modifica. Indica che si sta installando (o si è installata) la versione più recente disponibile.

Problemi di connessione Internet

Connessione internet: Il Manager installazioni non è stato in grado di connettersi al server di SOLIDWORKS per determinare i prodotti disponibili per l'installazione. Sarà comunque possibile scegliere i prodotti da installare, ma non è possibile effettuare il download di qualsiasi file di installazione. È necessario fornire i file di origine su DVD o un gruppo di file scaricati in precedenza.

Impossibile verificare nuove versioni

La Gestione installazioni di SolidWorks non ha potuto verificare la disponibilità di nuove versioni perché non è riuscita a connettersi al server.

Risoluzione:
  • Controllare la connessione Internet.
  • Si può procedere all'installazione a patto che si utilizzi un DVD o un gruppo di file scaricati in precedenza.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Creazione guidata fori/Opzioni Toolbox

Se è installato SOLIDWORKS Toolbox, SOLIDWORKS include una libreria standard di tipi di foro e hardware.

Per i dettagli su configurazione, estensione e uso di SOLIDWORKS Toolbox, in SOLIDWORKS, fare clic su Guida in SOLIDWORKS e fare riferimento alla sezione Toolbox.

Prima di utilizzare SOLIDWORKS Toolbox, assicurarsi che sia opportunamente configurato secondo le direttive aziendali o del proprio gruppo. In molti casi, un gruppo configura e mantenere una installazione centrale di Toolbox. Consultare l'amministratore di SOLIDWORKS per informazioni su come specificare l'installazione di Toolbox durante l'installazione di SOLIDWORKS.

È possibile modificare il SOLIDWORKS Toolbox selezionato dopo l'installazione. In SOLIDWORKS, fare clic su Strumenti > Opzioni. Nella scheda Opzioni del sistema, fare clic su Creazione guidata fori/Toolbox.

Le sezioni seguenti descrivono tutte le opzioni che possono presentarsi in questa schermata per tutte le configurazioni. Le opzioni effettive di Toolbox dipendono da configurazioni preesistenti di SOLIDWORKS e Toolbox su questo computer e sulle scelte della Gestione installazioni specificata fino a questo punto.

Creare una nuova versione di Toolbox

Creare una nuova versione di SOLIDWORKS Toolbox su questo computer.

Quando si crea una nuova versione, nella schermata Selezione prodotto espandere SOLIDWORKS > SOLIDWORKS Toolbox e selezionare gli standard da supportare per Toolbox. Tutti gli standard sono selezionati per impostazione predefinita.

Qualsiasi Toolbox esistente su questo computer non viene modificata.

Fare riferimento o aggiornare un Toolbox esistente

Usare un Toolbox esistente. Fare clic su Sfoglia per specificare la posizione del Toolbox da utilizzare per questa installazione.

  • Se Toolbox è configurato per una precedente release maggiore di SOLIDWORKS, viene aggiornato a questa versione. Qualsiasi elemento personalizzato di Toolbox viene mantenuto nella versione aggiornata.
    L'aggiornamento di Toolbox a una nuova versione di release maggiore di SOLIDWORKS rende Toolbox incompatibile con i computer che eseguono versioni di SOLIDWORKS di release maggiore precedenti.
  • Se Toolbox è configurato per questa versione di SOLIDWORKS (come se si specifica un Toolbox condiviso in rete già aggiornato), non viene aggiornato.
  • Se si aggiorna un Toolbox in un ambiente SOLIDWORKS PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere Note sulla configurazione di SOLIDWORKS Toolbox.

Questa opzione appare in tutte le situazioni di installazione, tranne durante la creazione di un'immagine amministrativa.

Aggiornare una versione precedente Toolbox

Copiare un Toolbox configurato per una release maggiore precedente in una nuova posizione e aggiornare tale copia a questa versione.

Questa opzione appare se su questo computer è installata una precedente versione di release maggiore di SOLIDWORKS, ma si è scelto di non aggiornare tale installazione a questa release.
Lo scopo di questa opzione è aggiornare un Toolbox di una precedente release maggiore di SOLIDWORKS installato senza conseguenze per gli utenti che usano ancora la versione precedente di Toolbox.

Se si aggiorna un Toolbox in un ambiente SOLIDWORKS PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere Note sulla configurazione di SOLIDWORKS Toolbox.

Aggiornare questa versione precedente di Toolbox installata

Aggiornare questo Toolbox alla versione più recente.
L'aggiornamento di Toolbox a una nuova versione di release maggiore di SOLIDWORKS rende Toolbox incompatibile con i computer che eseguono versioni di SOLIDWORKS di release maggiore precedenti.

Questa opzione appare se si aggiorna una precedente release maggiore di SOLIDWORKS a questa versione e un Toolbox configurato per tale release è già installato su questo computer.

Se si aggiorna un Toolbox in un ambiente SOLIDWORKS PDM, è necessario eseguire alcune procedure aggiuntive. Per i dettagli, vedere Note sulla configurazione di SOLIDWORKS Toolbox.

Utilizzare la versione corrente di Toolbox installata

La Gestione installazioni SOLIDWORKS ha rilevato su questo computer un Toolbox configurato per questa versione di release maggiore di SOLIDWORKS.

Se si seleziona questa opzione, SOLIDWORKS userà questo Toolbox. Nessun aggiornamento.

Questa opzione appare se su questo computer è installata una precedente versione di release maggiore di SOLIDWORKS, ma è configurato un Toolbox per questa versione. Potrebbe accadere se viene creato un Toolbox condiviso su un computer che ancora segue una versione precedente di SOLIDWORKS.

Specificare la posizione di Toolbox per il computer client

Specificare una posizione di rete o una cartella come posizione predefinita di Toolbox quando i client installano da un'immagine amministrativa.
Se la posizione contiene un'istanza di Toolbox configurata per una precedente release principale di SOLIDWORKS al momento dell'installazione del client, Gestione installazioni SOLIDWORKS effettua l'aggiornamento di tale Toolbox.

Questa opzione appare quando si crea una nuova immagine amministrativa.

Aggiornare o utilizzare il Toolbox referenziato nell'immagine esistente per il computer client

Usare la posizione di Toolbox specificata in un'immagine amministrativa esistente in aggiornamento.
Se la posizione contiene un'istanza di Toolbox configurata per una precedente release principale di SOLIDWORKS al momento dell'installazione del client, Gestione installazioni SOLIDWORKS effettua l'aggiornamento di tale Toolbox.

Selezionare una posizione diversa di Toolbox per il computer client

Specificare una posizione di Toolbox diversa da quella indicata nell'immagine amministrativa esistente in corso di aggiornamento.
Se la posizione contiene un'istanza di Toolbox configurata per una precedente release principale di SOLIDWORKS al momento dell'installazione del client, Gestione installazioni SOLIDWORKS effettua l'aggiornamento di tale Toolbox.

Indice

  • Note sulla configurazione di SOLIDWORKS Toolbox

    SOLIDWORKS Toolbox è uno strumento potente e complesso. Questo argomento riassume alcuni concetti fondamentali prima di configurare un Toolbox con la Gestione installazioni SOLIDWORKS.

  • Formato UNC

    Il formato UNC (convenzione di nomina universale) rappresenta un formato specifico per la sintassi dei nomi di file ed è utilizzato per descrivere una posizione condivisa.

Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS
Note sulla configurazione di SOLIDWORKS Toolbox


Note sulla configurazione di SOLIDWORKS Toolbox

SOLIDWORKS Toolbox è uno strumento potente e complesso. Questo argomento riassume alcuni concetti fondamentali prima di configurare un Toolbox con la Gestione installazioni SOLIDWORKS.

Ulteriori informazioni su SOLIDWORKS Toolbox

Per i dettagli su configurazione, estensione e uso di SOLIDWORKS Toolbox, in SOLIDWORKS, fare clic su [image] Guida in SOLIDWORKS e fare riferimento alla sezione Toolbox.

Uso di un Toolbox condiviso

Quando si installa Toolbox, è possibile salvare i dati di Toolbox sul proprio sistema o in una posizione in rete condivisa. Si consiglia di memorizzare i dati di Toolbox in una posizione di rete. Utilizzando una posizione condivisa, tutti gli utenti di SOLIDWORKS potranno accedere agli stessi fissaggi.

Se questa è la prima installazione, navigare alla nuova ubicazione condivisa dove installare Toolbox.

Aggiornamento di Toolbox esistente.

L'aggiornamento di Toolbox a una nuova versione di release maggiore di SOLIDWORKS rende Toolbox incompatibile con i computer che eseguono versioni di SOLIDWORKS di release maggiore precedenti.

Se altri computer vengono mantenuti a una release principale precedente e continuano a necessitare di un Toolbox configurato per tale release, creare una copia di tale Toolbox e di aggiornarla. La nuova installazione SOLIDWORKS aggiorna la copia di Toolbox; le installazioni meno recenti di SOLIDWORKS continuano a usare il precedente Toolbox.

Configurazione accesso a Toolbox

Dopo l'installazione, quando si accede ai componenti Toolbox, SOLIDWORKS verifica la configurazione di Toolbox e suggerisce come migliorare l'accesso e le prestazioni.

Per accedere a Toolbox condiviso in rete (opzione consigliata), usare un percorso UNC al server sul quale è installato Toolbox condiviso. Per i dettagli, vedere Formato UNC.

Un amministratore può creare una password per l'accesso a Toolbox e definire i permessi e le preferenze per l'intero gruppo di lavoro. Limitare l'accesso alla configurazione e impostare preferenze comuni garantisce la coerenza dei dati Toolbox utilizzati dall'intero gruppo di lavoro.

Aggiornamento di Toolbox in un ambiente SOLIDWORKS PDM

Quando si aggiorna il software SOLIDWORKS, Toolbox viene aggiornato se vi sono state aggiunte parti. Se la cartella di origine Toolbox è contenuta in un vault di SOLIDWORKS PDM, prima di iniziare l'aggiornamento di SOLIDWORKS, è necessario prepararla.

Sul primo sistema da aggiornare, eseguire il check out del database Toolbox e utilizzare Leggi l'ultima versione per scaricare i file Toolbox nella cache locale ed eseguire il check out del file di database di Toolbox. Sugli altri sistemi da aggiornare, l’unica operazione consiste nello scaricare i file Toolbox.

Prima di eseguire l'aggiornamento:
  • Accertarsi che esista un backup completo recente del database vault e archivio.
  • Assicurarsi che le parti Toolbox non siano sottoposte a check-out o non siano in uso in uno degli assiemi su cui è stato effettuato il check-out.

Per aggiornare Toolbox:

  1. In File Explorer, accedere al vault come utente con permessi completi (check-out-, check-in, aggiunta, eliminazione).
  2. Fare clic con il pulsante destro del mouse sulla cartella Toolbox e selezionare Prendi la versione più recente per copiare tutti i file Toolbox e il database Toolbox nella cache locale.
    Se il proprio server di archivio è remoto, l'operazione impiegherà alcuni minuti.
  3. Eseguire il check-out del file del database Toolbox (SWBrowser.mdb) o (swbrowser.sldedb) da \Toolbox_folder_name\lang\your_lang.
  4. Eseguire la Gestione installazioni SOLIDWORKS per aggiornare.
  5. Nello schermo Sintesi, assicurarsi che l'ubicazione dell'installazione Opzioni Toolbox sia l'ubicazione nel vault.

    In caso contrario, fare clic su Cambia, selezionare Riferimento o aggiornamento di un Toolbox esistente e accedere alla posizione di Toolbox nel vault.

  6. Al termine dell'aggiornamento, in File Explorer effettuare il check-in della cartella Toolbox per aggiungere i file nuovi o aggiornati al vault in modo che altri utenti possano lavorare con Toolbox.
  7. Per gli aggiornamenti, accedere alla cartella Toolbox nel vault e verificare che siano presenti:
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      Se non sono presenti, contattare il proprio rivenditore VAR.

  8. Eseguire l'aggiornamento del resto dei computer che usano l'integrazione di SOLIDWORKS PDM con Toolbox:
    1. In File Explorer, accedere al vault come utente con almeno il permesso di lettura per la cartella Toolbox.
    2. Fare clic con il pulsante destro del mouse sulla cartella Toolbox e selezionare Prendi la versione più recente per copiare i file Toolbox nella cache locale.
    3. Eseguire la Gestione installazioni SOLIDWORKS per aggiornare.

      Il programma di installazione rileva che Toolbox è già aggiornato.

Per i dettagli sulla configurazione Toolbox in SOLIDWORKS PDM, vedere la guida Configurazione Toolbox nello SOLIDWORKS PDM Strumento di amministrazione.

Argomento principale Creazione guidata fori/Opzioni Toolbox
Formato UNC


Formato UNC

Il formato UNC (convenzione di nomina universale) rappresenta un formato specifico per la sintassi dei nomi di file ed è utilizzato per descrivere una posizione condivisa.

\\server\volume\percorso

Ad esempio:

\\Disk_Server\SOLIDWORKS\AdminImage

Argomento principale Creazione guidata fori/Opzioni Toolbox
Note sulla configurazione di SOLIDWORKS Toolbox


Disinstalla prodotti

Quando si seleziona Rimuovi o Disinstalla programmi dal Pannello di controllo, questa schermata visualizzerà i prodotti SOLIDWORKS (con numeri di versione), che saranno disinstallati da questa versione di Gestione installazioni di SOLIDWORKS. Scegliere se effettuare una disinstallazione standard, personalizzata o completa.

La disinstallazione standard rimuove i file di programma e le cartelle di un prodotto SOLIDWORKS. Per impostazione predefinita, tutti i prodotti SOLIDWORKS per la release selezionata sono specificati per una disinstallazione standard.

Una disinstallazione personalizzata rimuove uno o più elementi: file e cartelle del programma, chiavi di registro e cartelle dati, come ad esempio SOLIDWORKS Toolbox e i file e cartelle dall'ubicazione di download originale.

Una completa disinstallazione rimuove le directory di installazione, le chiavi di registro e le cartelle dati.

Per disinstallare un prodotto:
  1. nello schermo Disinstalla, assicurarsi che il prodotto sia selezionato.

    Se si disinstallano tutti i prodotti, la Gestione installazioni sarà anch'essa disinstallata.

  2. Deselezionare i prodotti che non devono essere rimossi.

    Se si mantengono dei prodotti, la Gestione installazioni di SOLIDWORKS non sarà rimossa.

  3. Scegliere se effettuare una disinstallazione personalizzata o completa.
    1. Fare clic su Cambia in Opzioni avanzate.

      Si visualizza la finestra di dialogo Opzioni avanzate. L'opzione File e cartelle del programma è selezionata.

    2. Selezionare una o più opzioni per effettuare una disinstallazione personalizzata o selezionare tutte le opzioni per effettuare una disinstallazione completa.
    3. Fare clic su Torna alla Sintesi.
    4. Nello schermo Sintesi, espandere Opzioni avanzate per visualizzare il metodo di disinstallazione e le voci.
  4. Fare clic su Rimuovi elementi.
Quando si fa clic su Rimuovi elementi, la Gestione installazioni di SOLIDWORKS inizia subito a rimuovere i prodotti.
Argomento principale Guida dell'applicazione Gestione installazioni di SOLIDWORKS


Installazione

SOLIDWORKS Connected fornisce l'accesso a tutti i servizi e le app 3DEXPERIENCE che l'utente ha diritto a utilizzare in base al proprio ruolo.

Licensing

3DEXPERIENCE Platform utilizza licenze utente denominate. Una licenza viene assegnata quando un amministratore assegna un ruolo all'utente. Un ruolo determina quali servizi e app 3DEXPERIENCE l'utente è autorizzato a utilizzare. È possibile utilizzare la licenza su qualsiasi dispositivo. La licenza non è legata a un computer specifico.

Per i dettagli, vedere Elementi fondamentali licenze DS.

3DEXPERIENCE Launcher

Quando si installa SOLIDWORKS Connected per la prima volta, 3DEXPERIENCE Platform chiede di scaricare e installare 3DEXPERIENCE Launcher. Launcher è un servizio in background che aiuta le app native, come SOLIDWORKS Connected, ad accedere alla piattaforma. L'icona di Launcher [image] viene visualizzata nella barra delle applicazioni di Windows dopo l'installazione.

Per ulteriori informazioni, vedere 3DEXPERIENCE Launcher. L'accesso al servizio di assistenza agli utenti di Dassault Systèmes richiede le credenziali 3DEXPERIENCE.


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost è un'app che consente di distribuire il rendering da un computer che esegue SOLIDWORKS Visualize Professional a uno o più computer in una rete.

Durante l'esecuzione del rendering in background, è possibile eseguire altre operazioni sulla macchina; le immagini finali sottoposte a rendering saranno pronte più rapidamente. È possibile eseguire il rendering delle immagini su una sola macchina o su un cluster di più macchine che eseguono Visualize Boost.

Ogni abbonamento attivo a SOLIDWORKS Visualize Professional include una licenza gratuita di SOLIDWORKS Visualize Boost.

L'aumento delle prestazioni, ad esempio un tempo di rendering più rapido, dipende dalla potenza dei computer Visualize Boost. Le macchine con GPU migliori forniranno ottimizzazioni migliori.


Aggiornamento da licenze individuali a licenze SolidNetWork

È possibile aggiornare un computer dalla modalità di licenza SOLIDWORKS individuale alle licenze SolidNetWork specificando il numero seriale della licenza SolidNetWork nella Gestione installazioni SOLIDWORKS.

Se un computer non ha SOLIDWORKS installato, è possibile specificare le licenze SolidNetWork inserendo il numero seriale SolidNetWork quando si esegue l'installazione con la Gestione installazioni SOLIDWORKS.

Se un computer ha già installato SOLIDWORKS e si passa da un tipo di licenza individuale alle licenze SolidNetWork, è possibile modificare l'installazione del computer client e specificare il numero di serie della licenza SolidNetWork al posto di quello della licenza individuale quando si esegue Gestione installazioni SOLIDWORKS. Per i dettagli, vedere Modifica di un'installazione.
Se si è installato SOLIDWORKS da un'immagine amministrativa, l'opzione di modifica non è disponibile. È necessario apportare delle modifiche all'immagine amministrativa mediante l'Editor opzione immagine amministrativa, disinstallare il client ed eseguire nuovamente l'installazione.


Lavorare con Visualize Boost

Per abilitare il rendering distribuito, è necessario collegare SOLIDWORKS Visualize a Visualize Boost dopo la configurazione.

La connessione Boost richiede l'Indirizzo IP Coordinatore e i valori della Porta Boost in SOLIDWORKS Visualize.

Tenere aperti Visualize Boost e SOLIDWORKS Visualize durante i seguenti passaggi.

Per connettere SOLIDWORKS Visualize a Visualize Boost:

  1. Aprire Visualize Boost facendo doppio clic sul collegamento sul desktop [image].
  2. Fare doppio clic sull'Indirizzo IP Coordinatore in Visualize Boost per copiarlo negli Appunti.
  3. In SOLIDWORKS Visualize, fare clic su Strumenti > Opzioni > Boost e premere CTRL+V per incollare Indirizzo IP coordinatore.
  4. Ripetere i passaggi 2 e 3 per copiare la Porta Boost da Visualize Boost a SOLIDWORKS Visualize.
    La Porta Boost specificata in Visualize Boost e in SOLIDWORKS Visualize Boost deve essere la stessa.
    Il comando Stato Boost viene visualizzato in SOLIDWORKS Visualize.
  5. Fare clic su OK per chiudere la finestra di dialogo Opzioni.
  6. Per connettersi a Boost, fare clic sul comando Stato Boost [image] o disconnettere [image] nelle seguenti interfacce:
    • Visore a sovraimpressione
    • Pagina Qualità della procedura guidata di rendering
    • Strumenti Opzioni scheda Boost

Per i dettagli sulla configurazione Boost, vedere SOLIDWORKS Visualize Boost.


Inizializzazione di un nuovo server di licenza SolidNetWork

Per inizializzare un nuovo server di licenza SolidNetWork:

  1. Dopo aver installato e aperto SolidNetWork License Manager Server, fare clic su Sì quando viene richiesto di eseguire l'attivazione.
  2. Nella finestra di dialogo Informazioni sul server di licenza SolidNetWork, verificare i dati in Firewall e Porte e fare clic su Avanti.
  3. Nella procedura guidata di attivazione del prodotto, selezionare i numeri di serie da attivare, selezionare Manualmente via e-mail come metodo di attivazione e immettere le Informazioni di contatto e-mail.

    Il metodo manuale richiede di creare la richiesta del file e inviarla tramite e-mail a activation@solidworks.com. Quando si riceve la risposta contenente il file della licenza, estrarre il file e fare clic su Apri per caricarlo sul server.

    È possibile chiudere ed eseguire nuovamente la procedura guidata Attivazione del prodotto per aprire e caricare il file ricevuto.

  4. Quando compare un messaggio che informa che l'inizializzazione è riuscita, fare clic su OK e, nella procedura guidata Attivazione del prodotto, fare clic su Fine.


Attivazione manuale di un nuovo SolidNetWork License Manager Server

Dopo aver inizializzato SolidNetWork License Manager Server, aprire SolidNetWork License Manager Server e creare una seconda richiesta per completare l'attivazione.

Per attivare manualmente un nuovo SolidNetWork License Manager Server:

  1. Scegliere una delle seguenti opzioni:
    • Se un messaggio chiede di eseguire l'attivazione, fare clic su Sì.
    • Se questa richiesta non viene visualizzata, fare clic su Modifica nella scheda Amministrazione del server.
    Per impostazione predefinita, le Opzioni avanzate sono impostate sulla modalità Usa attivazione.
  2. Verificare i dati in Firewall e Porte nella finestra di dialogo Informazioni su SolidNetWork License Server e fare clic su Avanti.
  3. Nell'Attivazione guidata del prodotto, selezionare i numeri di serie da attivare, immettere le informazioni di contatto e-mail, quindi selezionare Manualmente via e-mail come metodo di attivazione.
  4. Seguire le istruzioni della procedura per creare una richiesta e inviarla a activation@solidworks.com. Quando si riceve la risposta con il file della licenza, fare clic su Apri per caricare il file.
  5. Al termine dell'attivazione, fare clic su Fine.


Attivazione manuale di un'installazione aggiornata di SolidNetWork License Manager Server

Dopo aver aggiornato SolidNetWork License Manager Server con SOLIDWORKS Installation Manager, aprire SolidNetWork License Manager Server.

Per attivare manualmente un'installazione aggiornata di SolidNetWork License Manager Server:

  1. Nella scheda Amministrazione del server, in Informazioni sulla licenza, fare clic su Riattiva.
    Se invece le licenze sono state disattivate prima di disinstallare e aggiornare SolidNetWork License Manager Server, fare clic su Modifica nella scheda Amministrazione del server. L'opzione Riattiva è disponibile solo se sul server sono presenti licenze attivate.

    Continuare con il passaggio 3.

  2. Nella finestra di dialogo Riattiva, selezionare i numeri di serie installati per visualizzare le licenze associate, quindi fare clic su Riattiva.
  3. Verificare i dati in Firewall e Porte nella finestra di dialogo Informazioni su SolidNetWork License Server e fare clic su Avanti.
  4. Nell'Attivazione guidata del prodotto, selezionare i numeri di serie da attivare, immettere le informazioni di contatto e-mail, quindi selezionare Manualmente via e-mail come metodo di attivazione.
    L'attivazione manuale è un processo semplice. Le istruzioni per la procedura guidata di attivazione del prodotto guideranno l'utente nei vari passaggi.
  5. Al termine dell'attivazione, fare clic su Fine.