SOLIDWORKS Installation und Administration

Diese Anleitung beschreibt die Installation, Lizenzierung, Aktualisierung und Administration von SOLIDWORKS Produkten für Einzelinstallationen und Mehrfachinstallationen.

Einzelinstallationen | Aktivierung mehrerer Installationen
Installation Installation auf einem oder mehreren Computern. | Installation Erstellung eines Administrator-Installationsabbildes, das auf einer bestimmte Anzahl von Client-Computern angewendet wird.
Lizenzierung Computeraktivierung oder Netzwerklizenzierung. | Lizenzierung Computeraktivierung oder Netzwerklizenzierung.
Upgrades (Aktualisierungen) Einzel-Computer auf eine neue Version aktualisieren. | Upgrades (Aktualisierungen) Aktualisieren von mehreren Computern auf eine neue Version durch Aktualisierung des Administrator-Installationsabbildes, das auf allen diesen Computern zur Installation benutzt wird.
Verwaltung Modifizieren, Reparieren oder Entfernen von Installationen, Aktualisieren auf neue Versionen. | Verwaltung Aktualisieren von Administrator-Installationsabbildern und Clients und Verwalten von Netzwerklizenzen.

Der SOLIDWORKS Installations-Manager ermöglicht das Konfigurieren von Einstellungen für SOLIDWORKS Produktkomponenten einschließlich SOLIDWORKS, SOLIDWORKS Toolbox, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS Visualize und SOLIDWORKS SolidNetWork License Manager.

Der SolidNetWork License Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.

Inhaltsverzeichnis

  • Einzelinstallation oder Administrator-Installationsabbild

    Sollten Sie SOLIDWORKS Produkte auf jedem Computer separat installieren oder sollten Sie ein Administrator-Installationsabbild erstellen und die Installation allen Clients mit einem Befehl bereitstellen?

  • System- und Softwareanforderungen überprüfen

    Stellen Sie vor der Installation sicher, dass Ihr System die Anforderungen an Hardware, Betriebssystem und Microsoft-Produkte erfüllt. Für Zusatzanwendungen, wie z. B. SOLIDWORKS Electrical und SOLIDWORKS Visualize und eDrawings, gelten zusätzliche Anforderungen.

  • Installationsmedien herunterladen

    Alle Installationsmedien sind auf der Seite SOLIDWORKS Downloads verfügbar.

  • Installieren von 3DEXPERIENCE Apps

    Wenn Sie Daten mit der 3DEXPERIENCE Platform verwalten, können Sie die Rolle Collaborative Designer for SOLIDWORKS erwerben, um Ihre Desktop-Umgebung mit der Plattform zu verbinden.


Einzelinstallation oder Administrator-Installationsabbild

Sollten Sie SOLIDWORKS Produkte auf jedem Computer separat installieren oder sollten Sie ein Administrator-Installationsabbild erstellen und die Installation allen Clients mit einem Befehl bereitstellen?

Wenn Sie nur auf einem Computer installieren, oder wenn Sie für Dutzende oder Hunderte Computer zuständig sind, ist es offensichtlich, welche Option zu wählen ist. In Fällen, die dazwischen liegen, sollten Sie die folgenden Vergleiche beachten.

Einzelinstallation | Administrator-Installationsabbild
Anwender können Ihre eigene SOLIDWORKS Administration führen. | Der Systemadministrator kann mehrere Installationen mit dem Options-Editor anpassen, indem er Optionen wie die Erstellung einer neuen Installation oder die Aktualisierung einer bestehenden festlegt sowie die Ausführung der Installation als Administrator, die Ausführung externer Befehle vor oder nach der Installation, verschiedene Produktgruppierungen etc. festlegt.
Die Computer müssen für die Person, die die Installation ausführt, physisch zugreifbar sein. | Client-Computer können sich auch entfernt befinden, solange auf sie vom selben Netz zugegriffen werden kann.
Siee können verschiedene Versionen. Service Packs oder Produkte auf verschiedenen Computern mit separaten Einstellungen installieren. | Mit dem Options-Editor können Administrator-Installationsabbilder Konsistenz in Versionen, Service Packs, Produkten und Einstellungen gewährleisten.
Die Computer müssen Netzwerk- oder E-Mail-Zugang haben. Eine Netzwerk- oder E-Mail-Verbindung ist erforderlich, um SOLIDWORKS zu aktivieren und Dateien herunterzuladen. Netzwerkzugriff ist auch für den Bezug von Lizenzen von einem Netzwerk-Lizenzserver erforderlich.

Eine lokale Netzwerk-Verbindung ist für die Bereitstellung der Anwendung erforderlich. Medien-Laufwerke auf Client-Computern sind nicht erforderlich.

Clients können automatisch aktualisiert werden. Alle Clients, auf denen vom selben Administrator-Installationsabbild installiert wurde, haben dasselbe Service Pack. Um mehrere Versionen zu verwalten, können Sie mehrere Administrator-Installationsabbilder erstellen.

Die Lizenzaktivierung kann automatisiert werden.

Für ein Administrator-Installationsabbild ist Speicherplatz auf dem Server erforderlich; Clients benötigen denselben Platz wie Einzelinstallationen.

Übergeordnetes Thema SOLIDWORKS Installation und Administration
System- und Softwareanforderungen überprüfen
Installationsmedien herunterladen
Installieren von 3DEXPERIENCE Apps


System- und Softwareanforderungen überprüfen

Stellen Sie vor der Installation sicher, dass Ihr System die Anforderungen an Hardware, Betriebssystem und Microsoft-Produkte erfüllt. Für Zusatzanwendungen, wie z. B. SOLIDWORKS Electrical und SOLIDWORKS Visualize und eDrawings, gelten zusätzliche Anforderungen.

Um eine erfolgreiche Installation und optimale Leistung sicher zu stellen, siehe Systemanforderungen.

Übergeordnetes Thema SOLIDWORKS Installation und Administration
Einzelinstallation oder Administrator-Installationsabbild
Installationsmedien herunterladen
Installieren von 3DEXPERIENCE Apps


Installationsmedien herunterladen

Alle Installationsmedien sind auf der Seite SOLIDWORKS Downloads verfügbar.

Wenn Sie nicht auf die Seite SOLIDWORKS Downloads zugreifen können, wenden Sie sich an Ihren Fachhändler, um die entsprechenden DVDs zu erhalten.

So laden Sie die Installationsmedien herunter:

  1. Melden Sie sich als Subskriptionsdienst-Kunde mit Ihrer E-Mail-Adresse und Ihrem Passwort oder Ihrer SOLIDWORKS Seriennummer auf der Seite SOLIDWORKS Downloads an.
  2. Wählen Sie auf der Seite „Downloads“ unter Version auswählen das Jahr aus.
  3. Wählen Sie die Registerkarte SOLIDWORKS für SOLIDWORKS Produkte aus.
  4. Wählen Sie im Bereich „Produkt“ ein Service Pack aus.
    Wählen Sie SOLIDWORKS Produkte Version 0.0 aus, um die neueste Hauptversion zu erhalten.
  5. Klicken Sie auf Accept Agreement & Continue (Vereinbarung akzeptieren und fortfahren), um die Bedingungen der Lizenzvereinbarung zu akzeptieren.
  6. Klicken Sie auf Herunterladen.
    Ihr Webbrowser lädt SolidworksSetup.exe an den Standardspeicherort C:\Users\Username\Downloads herunter.
  7. Entpacken Sie die Datei SolidworksSetup.exe in den Ordner Downloads.
    Sie können die Datei SolidworksSetup.exe auch an Ihrem bevorzugten Speicherort entpacken.
  8. Führen Sie setup.exe mit Administratorrechten aus.
  9. Klicken Sie im Installations-Manager auf Alle Dateien herunterladen und teilen.
    Erstellen Sie einzelne Installationen oder Administrator-Installationsabbilder auf mehreren Computern mit einem einzigen Download und befolgen Sie dann die Anweisungen, um den Vorgang abzuschließen.

    Der Installations-Manager lädt die Installationsmedien für Sie herunter.

    Diese Option ist hilfreich für:
    • Installieren der Software auf einer kleinen Anzahl von Computern
    • Herunterladen über ein tragbares Laufwerk oder ein Netzlaufwerk
    • Installieren von Service Packs
    Um die Installationsdateien selektiv herunterzuladen, befolgen Sie die Anweisungen, um die manuelle Downloadmethode auszuwählen.
Übergeordnetes Thema SOLIDWORKS Installation und Administration
Einzelinstallation oder Administrator-Installationsabbild
System- und Softwareanforderungen überprüfen
Installieren von 3DEXPERIENCE Apps


Installieren von 3DEXPERIENCE Apps

Wenn Sie Daten mit der 3DEXPERIENCE Platform verwalten, können Sie die Rolle Collaborative Designer for SOLIDWORKS erwerben, um Ihre Desktop-Umgebung mit der Plattform zu verbinden.

Diese Rolle gewährt Zugriff auf 3DEXPERIENCE Apps, die es SOLIDWORKS Desktop Produkten ermöglichen, auf der Plattform gespeicherte Daten zu speichern, zu durchsuchen und zu verwalten. Sie können auch die webbasierte App SOLIDWORKS Connected verwenden. Informationen zur Installation finden Sie unter Installation.

Sie installieren und lizenzieren diese Anwendungen von der 3DEXPERIENCE Platform, nicht über den SOLIDWORKS Installations-Manager. Installationsanweisungen finden Sie in der SOLIDWORKS Hilfe unter Arbeiten mit der 3DEXPERIENCE Platform und den 3DEXPERIENCE Apps > Installieren von 3DEXPERIENCE Apps.

Übergeordnetes Thema SOLIDWORKS Installation und Administration
Einzelinstallation oder Administrator-Installationsabbild
System- und Softwareanforderungen überprüfen
Installationsmedien herunterladen
https://help.solidworks.com


Einzelinstallationen

Inhaltsverzeichnis

  • Installation auf Einzel-Computern

    Sie können SOLIDWORKS mit mehreren Installationsmethoden auf einem Einzelcomputer installieren.

  • Verwaltung von Einzelplatzinstallationen

    Normalerweise besteht die Verwaltung von Einzelinstallationen aus der Modifizierung, Reparatur, dem Entfernen und Aktualisieren von Installationen.


Installation auf Einzel-Computern

Sie können SOLIDWORKS mit mehreren Installationsmethoden auf einem Einzelcomputer installieren.

Die Installation erfolgt über den SOLIDWORKS Installations-Manager, der die Installation auf die von Ihnen erworbenen Produkte anpasst. Bevor Sie mit der Installation beginnen:

  • Wenn Sie eine eigenständige Version von SOLIDWORKS installieren, halten Sie Ihre SOLIDWORKS Seriennummern bereit.
  • Stellen Sie sicher, dass Sie über einen funktionierenden Internet-Anschluss verfügen. Die Verbindung ist zum Prüfen der Berechtigung erforderlich.
  • Erstellen Sie eine 3DEXPERIENCE ID. Weitere Informationen zur Erstellung von 3DEXPERIENCE IDs finden Sie unter https://www.3ds.com/support.
  • Stellen Sie sicher, dass Sie der designierte Administrator für Ihr Konto sind oder dass Ihr Administrator Sie als Kontakt angegeben hat.

Der SOLIDWORKS Installations-Manager installiert verschiedene Microsoft-Komponenten wie zum Beispiel Microsoft Visual Studio Tools for Applications, Visual Basic und .NET Framework. Wenn die korrekten Versionen aller von Windows vorausgesetzten Komponenten nicht auf dem Computer installiert sind, installiert der SOLIDWORKS Installations-Manager diese automatisch vor der Installation der SOLIDWORKS Produkte.

Das SOLIDWORKS Chromium Embedded Framework (CEF) ist eine weitere Komponente, die vom SOLIDWORKS Installations-Manager installiert wird. Der Zweck besteht darin, Inhalte für SOLIDWORKS Apps und die 3DEXPERIENCE Platform anzuzeigen.

Der SOLIDWORKS Login Manager wird auch vom SOLIDWORKS Installations-Manager installiert. Er ermöglicht die Anmeldung bei 3DEXPERIENCE Marketplace und 3DEXPERIENCE Apps.

Installationsmethode Übersicht über den Vorgang
Herunterladen von der Seite SOLIDWORKS Downloads

Alle Installationsmedien sind auf der Seite SOLIDWORKS Downloads verfügbar.

  1. Navigieren Sie zur Seite SOLIDWORKS Downloads.
  2. Melden Sie sich mit Ihrer 3DEXPERIENCE ID an.
  3. Wählen Sie auf der Seite „Downloads“ unter Version auswählen das Jahr aus.
  4. Klicken Sie auf die Registerkarte SOLIDWORKS für SOLIDWORKS Produkte und wählen Sie unter Produkt ein Service Pack aus.
  5. Klicken Sie auf Accept Agreement & Continue (Vereinbarung akzeptieren und fortfahren), um die Bedingungen der Lizenzvereinbarung zu akzeptieren.
  6. Klicken Sie auf Download (Herunterladen).
Sie müssen über eine funktionierende Internetverbindung und Anmeldezugriff auf die Download-Seite verfügen.

Wenn Sie nicht auf die Seite „Downloads“ zugreifen können, wenden Sie sich an Ihren Fachhändler, um die entsprechenden Installationsmedien zu erhalten.
Ein Download-Verzeichnis auf einem Server verwenden Doppelklicken Sie im Download-Verzeichnis auf setup.exe.

Man muss von dem Computer, auf dem Sie SOLIDWORKS Produkte installieren, auf das Download-Verzeichnis zugreifen können. Er muss des Weiteren alle SOLIDWORKS Installationsdateien enthalten, bevor Sie mit der Installation beginnen können. Mit dem SOLIDWORKS Installations-Manager können Sie fehlende Dateien finden, wenn Sie Zugriff auf das Internet und Schreibrechte auf das Download-Verzeichnis haben.
Aktualisierung einer bestehenden SOLIDWORKS Installation mittels Nach Aktualisierungen suchen Wählen Sie eine der folgenden Optionen aus:
  • Klicken Sie in SOLIDWORKS auf [image] > Auf Aktualisierungen prüfen.
  • Klicken Sie in Windows auf Start > SOLIDWORKS Installations-Manager > Auf Aktualisierungen prüfen.
Sie können auch auf Start > SOLIDWORKS Installations-Manager > SOLIDWORKS Hintergrund-Downloader klicken. Klicken Sie im Windows-Benachrichtigungsbereich mit der rechten Maustaste auf SOLIDWORKS Hintergrund-Downloader und wählen Sie Nach Aktualisierungen suchen aus.
Sie müssen über eine funktionierende Internetverbindung und Administratorrechte auf dem Computer verfügen.

Im SOLIDWORKS Installations-Manager können Sie auch die Option Alle Dateien herunterladen und teilen sowie die erforderliche Software auswählen. Diese Option ist nützlich, wenn Sie die Software auf mehreren Computern installieren und den Download über einen Wechseldatenträger oder ein Netzwerklaufwerk kopieren möchten. Sie ist auch hilfreich für die Installation von Service Packs, da die Vollversion und das Service Pack in einer Installation enthalten sind.

Wenn die Installation abgeschlossen ist, starten Sie die SOLIDWORKS Anwendung, und aktivieren Sie die Lizenz.

Um eine Liste der auf Ihrem Computer installierten Produkte anzuzeigen, gehen Sie zum SOLIDWORKS Hauptmenü.
  • Klicken Sie auf [image] > Meine Produkte
  • Klicken Sie in der Taskansicht auf SOLIDWORKS Ressourcen > Meine Produkte
  • Klicken Sie auf Start > SOLIDWORKS Werkzeuge Version > Meine Produkte.

Die mit einem Häkchen gekennzeichneten Produkte gehören Ihnen oder Ihrem Unternehmen basierend auf Ihren Aktivierungen und Netzwerklizenzen. Sie können auch mehr über SOLIDWORKS Produkte erfahren, indem Sie auf den Link oben in jeder Produktkategorie klicken.

Wenn Sie eine SOLIDWORKS Lizenz haben und sehen möchten, welche Lizenzen in Verwendung sind, klicken Sie in Windows auf die Registerkarte Start > SOLIDWORKS Werkzeuge <Version> > SolidNetWork License Manager Client > Lizenzverwendung.

Übergeordnetes Thema Einzelinstallationen
Verwaltung von Einzelplatzinstallationen


Verwaltung von Einzelplatzinstallationen

Normalerweise besteht die Verwaltung von Einzelinstallationen aus der Modifizierung, Reparatur, dem Entfernen und Aktualisieren von Installationen.

Inhaltsverzeichnis

  • Modifizieren einer Installation

    Sie können eine Installation modifizieren, um Produkte zu installieren, die noch nicht installiert wurden, oder um Produkte zu entfernen. Dafür muss die vorherige Installation mit einem vollständigen Satz von Installationsdateien abgeschlossen worden sein. Diese Option ist nicht verfügbar, wenn Sie die vorherige Installation mit einem Service Pack aktualisiert haben.

  • Reparieren einer Installation

    Wenn Sie Probleme mit einem installierten SOLIDWORKS Produkt haben, können Sie den SOLIDWORKS Installations-Manager für die Reparatur der Installation verwenden.

  • Einzelinstallation auf ein früheres Service Pack zurücksetzen

  • Entfernen einer Installation

    Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.

  • Auf neue Version aktualisieren

    Es gibt mehrere Methoden, wie Sie eine Einzelinstallation auf eine neue SOLIDWORKS Version aktualisieren können.

  • Produkt-Koexistenzregeln

    Die folgenden Produkt-Koexistenzregeln bestimmen, wie neue Produkte installiert und bestehende Produkte aktualisiert werden.

Übergeordnetes Thema Einzelinstallationen
Installation auf Einzel-Computern


Modifizieren einer Installation

Sie können eine Installation modifizieren, um Produkte zu installieren, die noch nicht installiert wurden, oder um Produkte zu entfernen. Dafür muss die vorherige Installation mit einem vollständigen Satz von Installationsdateien abgeschlossen worden sein. Diese Option ist nicht verfügbar, wenn Sie die vorherige Installation mit einem Service Pack aktualisiert haben.

Wenn Sie die SOLIDWORKS Anwendung installiert und eine Zusatzanwendung zu einem späteren Zeitpunkt erworben haben, können Sie die Installation ändern, um die neue Zusatzanwendung hinzuzufügen. Sie müssen die Zusatzanwendung auf jedem einzelnen Rechner installieren.

  1. Stellen Sie sicher, dass keine SOLIDWORKS Sitzungen aktiv sind.
  2. Wählen Sie in Windows Einstellungen > Apps > Installierte Apps aus.
  3. Wählen Sie die installierte SOLIDWORKS Software aus, die Sie ändern möchten, und klicken Sie auf Ändern.
  4. Klicken Sie auf dem Bildschirm Willkommen beim SOLIDWORKS Installations-Manager auf Installation ändern.
  5. Verifizieren Sie auf dem Bildschirm Seriennummer, dass die für Ihre Installation passenden Seriennummern angegeben sind.
  6. Wählen Sie auf dem Bildschirm Produktauswahl die zu installierenden oder entfernenden Produkte aus.
    Falls Sie eine Installation modifizieren:
    • Es werden standardmäßig keine Produkte installiert oder entfernt, auch wenn Sie eine neue Seriennummer festlegen. Sie müssen die Installationsaktion für jedes Produkt oder jede Feature-Komponente ändern.
    • Klicken Sie, um die projizierte Aktion für eine bestimmte Komponente zu sehen, auf den Namen der Komponente (aber nicht auf das Kontrollkästchen). Die gewünschte Installationsaktion erscheint im Informationsfeld unter der Produktauflistung.
    • Sie können auf das Kontrollkästchen neben der Produktkomponente klicken, um die Installationsaktion für diese Komponente zu ändern. (Beispiel: Wenn Sie Komponenten installieren oder entfernen, legt die Aktivierung des Kontrollkästchens fest, dass die Komponente zu installieren oder zu entfernen ist, und die Deaktivierung des Kontrollkästchens legt fest, dass die Komponente nicht zu installieren oder zu entfernen ist.)
    • Wenn Sie eine Komponenteninstallationsaktion aus der ursprünglichen Wahl ändern, erscheint in der Auflistung ein Sternchen (*) neben der Komponente.
    • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol [image] angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol [image].
    • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird neben der Komponente das Symbol [image] angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol [image] .
  7. Klicken Sie auf dem Bildschirm Zusammenfassung auf Jetzt modifizieren.
  8. Klicken Sie auf dem Bildschirm Installation vollständig auf Fertig stellen.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Reparieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Entfernen einer Installation
Auf neue Version aktualisieren
Produkt-Koexistenzregeln


Reparieren einer Installation

Wenn Sie Probleme mit einem installierten SOLIDWORKS Produkt haben, können Sie den SOLIDWORKS Installations-Manager für die Reparatur der Installation verwenden.

Zum Reparieren einer Installation muss Ihr Computer über alle Quelldateien aus der vorherigen Installation und über alle angewendeten Service Packs verfügen. Diese müssen sich an dem Ort befinden, an dem Sie sie ursprünglich installiert haben.

Eine Einzelinstallation kann repariert werden. Ein Administrator-Installationsabbild kann nicht repariert werden; Sie müssen das Administrator-Installationsabbild deinstallieren und erneut installieren.
  1. Öffnen Sie die Windows Systemsteuerung und klicken Sie auf Programme > Programme und Funktionen.
  2. Klicken Sie mit der rechten Maustaste auf die SOLIDWORKS Version, die Sie reparieren möchten, und klicken Sie auf Ändern.
  3. Klicken Sie auf dem Bildschirm Willkommen beim SOLIDWORKS Installations-Manager auf Installation reparieren und klicken Sie auf Weiter.
  4. Wählen Sie auf dem Bildschirm Zu reparierende Produkte das zu reparierende Produkt.
  5. Deaktivieren Sie den Rest der Produkte auf dem Bildschirm.
  6. Klicken Sie auf Reparieren.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Übergeordnetes Thema Installationsfehler / Installation abgebrochen
Modifizieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Entfernen einer Installation
Auf neue Version aktualisieren
Produkt-Koexistenzregeln
Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation
Kontaktaufnahme mit dem SOLIDWORKS Fachhändler


Einzelinstallation auf ein früheres Service Pack zurücksetzen

Um eine Einzelinstallation auf ein früheres Service Packversion in der aktuellen Hauptversionsfamilie zurückzusetzen, die aktuell auf dem Computer installierte Service Pack-Version deinstallieren und die frühere Version installieren.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Modifizieren einer Installation
Reparieren einer Installation
Entfernen einer Installation
Auf neue Version aktualisieren
Produkt-Koexistenzregeln


Entfernen einer Installation

Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.

  1. Stellen Sie sicher, dass keine SOLIDWORKS Sitzungen aktiv sind.
  2. Wenn Sie die SOLIDWORKS Lizenz auf einen anderen Computer übertragen möchten, deaktivieren Sie die Lizenz, bevor Sie die SOLIDWORKS Installation auf diesem Computer entfernen.
    Weitere Informationen hierzu finden Sie unter Übertragen einer Lizenz.
  3. Öffnen Sie die Windows-Systemsteuerung und klicken Sie auf Programme und Funktionen.
  4. Wählen Sie die zu entfernende Produktkomponente aus und klicken Sie auf Deinstallieren.
    In einigen Fällen könnten Sie mehrere SOLIDWORKS Service Pack-Komponenten für eine bestimmte Hauptversion vorfinden. Entfernen Sie, um eine Hauptversion von SOLIDWORKS zu entfernen, alle Service Pack-Elemente dieser Hauptversion.
  5. Auf dem Deinstallieren-Bildschirm:
    1. Wählen Sie die Produkte aus, die entfernt werden sollen.
      Standardmäßig werden alle Produktkomponente selektiert.
    2. Deaktivieren Sie die Produkte, die nicht entfernt werden sollen.
    3. Klicken Sie auf Ändern in Erweiterte Optionen.
      Der Bildschirm Erweiterte Optionen wird eingeblendet und die Programmdateien und die Ordner-Option sind ausgewählt.
    4. Wählen Sie eine oder mehrere Optionen aus, um eine benutzerdefinierte Deinstallation auszuführen, oder wählen Sie alle Optionen aus, um eine vollständige Deinstallation durchzuführen.
      Standardmäßig führt der SOLIDWORKS Installations-Manager eine vollständige Deinstallation durch und entfernt alle Dateien und Ordner, die bei der Installation hinzugefügt wurden.
    5. Klicken Sie auf Zurück zu Übersicht.
    6. Klappen Sie auf dem Bildschirm Zusammenfassung Erweiterte Optionen auf, um die Deinstallationsmethode und die Einträge anzuzeigen.
    7. Klicken Sie auf Elemente entfernen.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Übergeordnetes Thema Verwaltung von mehreren Installationen
Modifizieren einer Installation
Reparieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Auf neue Version aktualisieren
Produkt-Koexistenzregeln
Administrator-Installationsabbilder auf neue Version aktualisieren
Administration von Service Pack-Produktaktualisierungen
Übertragen einer Lizenz


Auf neue Version aktualisieren

Es gibt mehrere Methoden, wie Sie eine Einzelinstallation auf eine neue SOLIDWORKS Version aktualisieren können.

Sie können auf eine neue Version aktualisieren, wenn Sie:
  • Neue Installationsmedien erhalten
  • Nach dem Start von SOLIDWORKS über Upgrades benachrichtigt werden
  • Manuell nach Aktualisierungsergebnissen suchen
  • Eine neue Kopie des SOLIDWORKS Installations-Managers starten

Wenn Sie eine neue Version installieren, können Sie die aktuelle Installation aktualisieren oder die neue Version parallel installieren. Wenn Sie eine Service Pack-Version für eine aktuelle Hauptversion installieren, dann wird die Version automatisch aktualisiert.

Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Modifizieren einer Installation
Reparieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Entfernen einer Installation
Produkt-Koexistenzregeln

Manuell nach Aktualisierungen suchen

Wenn Sie über Administratorrechte auf dem Computer verfügen, können Sie mit einer der folgenden Methoden nach Aktualisierungen für eine installierte SOLIDWORKS Version suchen.

  • Klicken Sie in SOLIDWORKS auf [image] > Auf Aktualisierungen prüfen.
  • Klicken Sie in Windows auf Start > SOLIDWORKS Installations-Manager > Auf Aktualisierungen prüfen.
Sie können auch auf Start > SOLIDWORKS Installations-Manager > SOLIDWORKS Hintergrund-Downloader klicken. Klicken Sie im Windows-Benachrichtigungsbereich mit der rechten Maustaste auf SOLIDWORKS Hintergrund-Downloader und wählen Sie Nach Aktualisierungen suchen aus.

Vorbehalte betreffend Aktualisierungen

Produkte, die mehrere Installationen mit verschiedenen Hauptversionen haben können, unterstützen nicht in jedem Fall Hauptaktualisierungen oder die Möglichkeit, von einer Hauptversionen auf die nächste in einer Einzeloperation zu aktualisieren.

In diesem Fall simuliert der SOLIDWORKS Installations-Manager die Aktualisierung, indem zunächst die neue Version installiert und dann die alte entfernt wird. Zurzeit unterstützen das SOLIDWORKS Kernprodukt und Hauptaktualisierungen, während dies auf andere Produkte nicht zutrifft.

Daraus ergeben sich folgende Konsequenzen:
  • Wenn Sie das SOLIDWORKS Kernprodukt von einer Hauptversion auf die nächste aktualisieren:
    • Die bestehenden installierten Speicherplätze ändern sich nicht.
    • Die Aktualisierung kann zurückgesetzt werden, wenn ein Fehler auftritt oder während der Aktualisierung abgebrochen wird.
  • Wenn andere Produkte von einer Hauptversion auf die nächste aktualisiert werden:
    • Jedes Produkt wird zunächst als neues Produkt an einem neuen Speicherplatz installiert. Danach wird die ursprüngliche Installation entfernt.
    • Sobald die Aktualisierung gestartet wurde, kann sie nicht mehr zurückgesetzt werden, wenn ein Fehler auftritt oder wenn der Aktualisierungsvorgang abgebrochen wird.


Produkt-Koexistenzregeln

Die folgenden Produkt-Koexistenzregeln bestimmen, wie neue Produkte installiert und bestehende Produkte aktualisiert werden.

Regel | Beispiele
Mehrere Hauptversionen des SOLIDWORKS Kernprodukts sind erlaubt, mit Ausnahme der unten aufgeführten Produkte. | SOLIDWORKS 2024 SP3.0 und SOLIDWORKS 2025 SP0.0 können auf demselben Computer installiert sein.
Mehrere Service Packs der gleichen Hauptversion sind nicht erlaubt. | SOLIDWORKS 2025 SP0.0 und 2025 SP1.0 können nicht gemeinsam auf demselben Computer installiert sein. Wenn Sie SOLIDWORKS 2025 SP1.0 auf einem Computer installieren, auf dem SOLIDWORKS 2025 SP0.0 bereits installiert ist, ersetzt der SOLIDWORKS Installations-Manager SP0.0 durch SP1.0,
Von den folgenden Produkten ist nur jeweils eine Version auf einem Computer erlaubt:
  • SolidNetWork License Manager
 Wenn SolidNetWork License Manager 2024 SP3.0 installiert ist, wird SolidNetWork License Manager auf 2025 SP0.0 aktualisiert, auch wenn eine frühere Hauptversion von SOLIDWORKS auf dem Computer installiert bleibt.
Von den folgenden Produkten ist nur jeweils eine Version auf einem Computer erlaubt:
  • SOLIDWORKS Electrical
 Wenn Sie eine neue Installation von SOLIDWORKS Electrical 2025 SP1.0 erstellen, entfernt der SOLIDWORKS Installations-Manager automatisch frühere Versionen von SOLIDWORKS Electrical vom Computer. Sichern Sie Ihre SOLIDWORKS Electrical Umgebung vor dem Upgrade.
Von den folgenden Produkten ist nur jeweils eine Version auf einem Computer erlaubt:
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

Wenn Sie SOLIDWORKS 2025 SP0.0 oder SP1.0 installieren, sollten Sie auch auf SOLIDWORKS 2025 PDM Server und PDM Client aktualisieren.

Wenn Sie SOLIDWORKS 2025 PDM Server installieren, sollten Sie den PDM Server Installationsprozess für die Installation von SOLIDWORKS PDM Client verwenden. Installieren Sie den SOLIDWORKS PDM Client nicht separat mit dem Client-Installationsprozess.

Release-Version und Service Packs von SOLIDWORKS PDM Client müssen die gleichen wie SOLIDWORKS PDM Server auf dem gleichen Computer sein.

Weitere Informationen finden Sie unter SOLIDWORKS PDM und SOLIDWORKS Manage.

Nur eine Version eines integrierten Produkts kann für eine SOLIDWORKS Hauptversion installiert werden. Versionen eingeschlossener Produkte aus verschiedenen Hauptversionen von SOLIDWORKS können jedoch koexistieren. | Wenn SOLIDWORKS 2025 SP0.0 auf 2025 SP1.0 aktualisiert wird, wird SOLIDWORKS Composer 2025 SP0.0, automatisch auf 2025 SP1.0 aktualisiert. SOLIDWORKS Composer 2024 SP4.0 kann jedoch gemeinsam mit SOLIDWORKS Composer 2025 SP0.0, oder mit SOLIDWORKS Composer 2025 SP1.0 installiert sein.
Übergeordnetes Thema Verwaltung von Einzelplatzinstallationen
Modifizieren einer Installation
Reparieren einer Installation
Einzelinstallation auf ein früheres Service Pack zurücksetzen
Entfernen einer Installation
Auf neue Version aktualisieren


Mehrere Installationen

Inhaltsverzeichnis

  • Bereitstellung für mehrere Clients

    Sie können das SOLIDWORKS Produkt auf mehreren Clients installieren, indem Sie ein Administrator-Installationsabbild erstellen und die Installation auf Clients anwenden.

  • Administrator-Installationsabbilder verwenden

    Ein Administrator-Installationsabbild gestattet die konfigurierbare Installation von SOLIDWORKS Produkten von einem einzigen Netzwerkbereich.

  • Befehlszeilenbereitstellung

    Sie können mittels einer Eingabeaufforderung oder Stapeldatei (stille Installation) ein Administrator-Installationsabbild automatisch aktivieren.

  • Verwaltung von mehreren Installationen

    Für mehrere Installationen umfassen die Verwaltungsaufgaben die Aktualisierung der Administrator-Installationsabbilder auf die neuen Versionen, Anwendung der Service Pack Aktualisierungen und das Entfernen von Installationen.


Bereitstellung für mehrere Clients

Sie können das SOLIDWORKS Produkt auf mehreren Clients installieren, indem Sie ein Administrator-Installationsabbild erstellen und die Installation auf Clients anwenden.

Der Vorgang zur Anwendung auf mehreren Clients ist wie folgt:
  1. Administrator-Installationsabbild erstellen.
    • Administrator-Installationsabbild vom SOLIDWORKS Installations-Manager aus erstellen
  2. Administrator-Installationsabbild auf Clients anwenden.
    • Bereitstellen eines Administrator-Installationsabbilds für Clients über die manuelle/Pull-Methode (E-Mail)
    • Bereitstellen eines Administrator-Installationsabbilds für Clients über die automatische/Push-Methode
    • Mit der Befehlszeile aus dem Administrator-Abbild installieren
  3. Lizenzierung implementieren.
    • Verwalten von Einzellizenzen
    • Lizenzen mit einem SolidNetWork License Manager verwalten
Übergeordnetes Thema Mehrere Installationen
Administrator-Installationsabbilder verwenden
Befehlszeilenbereitstellung
Verwaltung von mehreren Installationen


Administrator-Installationsabbilder verwenden

Ein Administrator-Installationsabbild gestattet die konfigurierbare Installation von SOLIDWORKS Produkten von einem einzigen Netzwerkbereich.

Administrator-Installationsabbilder lassen sich von jedem Netzwerkcomputer, einschließlich einem Client-Computer, aus installieren.
  • Das Administrator-Installationsabbild muss sich in einem freigegebenen Ordner befinden.
  • Wenn Sie alle Produkte einbeziehen, können 17 GB oder mehr auf der Festplatte für das Administrator-Installationsabbild erforderlich sein.
  • Wenn Sie den Freigabenamen bei der Aktualisierung des Administrator-Installationsabbilds aktualisieren, wird der Client automatisch beim nächsten Starten der Anwendung aktualisiert. Einzelheiten finden Sie unter Aktualisieren eines Administrator-Installationsabbildes.
  • Bei der Bereitstellung eines Administrator-Installationsabbilds muss der Pfad zum Abbild weniger als 58 Zeichen lang sein.
  • Clients benötigen Administratorrechte auf den jeweiligen Rechnern. Wenn ein Client nicht über ausreichende Berechtigungen verfügt, kann ein Client eine Installation unter einem anderen Benutzer durchführen. Diese Option ist nützlich, wenn ein einzelner Benutzer keine lokalen Administratorrechte auf dem Computer besitzt, die zur Installation der SOLIDWORKS Produkte erforderlich sind.

    Siehe Bereitstellung von Installationen über den Options-Editor. Dieser Abschnitt beschreibt auch eine alternative Methode zum Installieren von Installationsabbildern, wenn ein Client nicht über ausreichende Berechtigungen verfügt.

  • Wenn die Windows-Protokollierung aktiviert ist oder Sie die Statusfunktionen im Administrator-Installationsabbild-Options-Editor verwenden, müssen Sie über Lese-/Schreibberechtigungen für diesen Ordner verfügen: {Administrative image directory}\x64\Logs.

Nachdem Sie ein Administrator-Installationsabbild erstellt haben, können Sie im Administrator-Installationsabbild Options-Editor Installationsoptionseinstellungen für Benutzer und Gruppen, die Installationen mithilfe des Abbilds durchführen, vornehmen. Einzelheiten finden Sie unter Administrator-Installationsabbild Options-Editor.

Inhaltsverzeichnis

  • Typen von Administrator-Installationsabbildern

    Sie können den Options-Editor für Administrator-Installationsabbilder verwenden, um für Remote-Benutzer und für Benutzer in Ihrem Netzwerk verschiedene Arten von Abbildern zu erstellen.

  • Administrator-Installationsabbild vom SOLIDWORKS Installations-Manager aus erstellen

    Wenn Sie SOLIDWORKS auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.

  • Administrator-Installationsabbild Options-Editor

    Mit dem Administrator-Installationsabbild Options-Editor können Sie Installationsparameter-Einstellungen in einem Administrator-Installationsabbild für Einzel-Computer und für Gruppen von Computern anpassen.

  • Einstellungsadministrator-Werkzeug

Übergeordnetes Thema Mehrere Installationen
Bereitstellung für mehrere Clients
Befehlszeilenbereitstellung
Verwaltung von mehreren Installationen
Aktualisierung von Clients von Administrator-Installationsabbildern


Typen von Administrator-Installationsabbildern

Sie können den Options-Editor für Administrator-Installationsabbilder verwenden, um für Remote-Benutzer und für Benutzer in Ihrem Netzwerk verschiedene Arten von Abbildern zu erstellen.

Typ des Administrator-Installationsabbilds Beschreibung
Norm

Dieses Abbild ist die Standardeinstellung für alle neuen Administrator-Installationsabbilder.

Es handelt sich um ein standardmäßiges Administrator-Installationsabbild für Windows Installer, das für Benutzer mit zuverlässigem Zugriff auf das Unternehmensnetzwerk ideal geeignet ist. Dabei werden alle zur Installation der ausgewählten SOLIDWORKS Produkte erforderlichen Dateien in einem gemeinsam genutzten Abbild-Ordner gespeichert.

Wenn Benutzer eine Aktualisierung auf ein neues Service Pack durchführen, können sie die Patch-Dateien herunterladen/anwenden und müssen nicht das gesamte Abbild herunterladen.
Remote-Client

Dieses Abbild ist für Remote-Benutzer gedacht, die keinen zuverlässigen Zugriff auf das Unternehmensnetzwerk haben.

Bei der Installation dieses Abbild-Typs übernehmen Remote-Benutzer alle von Ihnen angegebenen Installationsoptionen, z. B. die Seriennummer und die zu installierenden Produkte.

Benutzer laden die erforderlichen Dateien über das Internet von der Seite SOLIDWORKS Downloads herunter. Der Zugriff auf diese Dateien aus dem Internet und ihre Installation ist zuverlässiger, als diese vom Unternehmensnetzwerk herunterzuladen, und reduziert möglicherweise die Belastung des Unternehmensnetzwerks.

Remote-Benutzer installieren dieses Abbild unter Verwendung derselben Techniken wie beim Standard-Administrator-Installationsabbild. Sie können weiterhin Skriptinstallationen mit den Dateien sldim.exe und startwinstall.exe durchführen.

Installationsdateien werden vor der Installation an einen im Options-Editor für Administrator-Installationsabbilder festgelegten Speicherort heruntergeladen. Benutzer müssen auf den Ordner für Administrator-Installationsabbilder zugreifen, um die Installation zu starten und alle dort gehosteten Stapel- oder Einstellungsdateien auszuführen zu können.

Remote-Benutzer müssen über ausreichend freien Speicherplatz verfügen, um alle Dateien im Abbild zu speichern, können das Abbild jedoch nach Abschluss der Installation löschen.
Compressed

Das komprimierte Administrator-Installationsabbild ist für Organisationen bestimmt, die Installationsabbilder in mehreren Standorten oder auf mehrere Client-Computer kopieren müssen, und soll die Auswirkungen auf das interne Netzwerk minimieren.

Dieses Abbild ist um 60 % kleiner als ein Standard-Administrator-Installationsabbild, die Installation dauert jedoch genauso lange. Es unterstützt alle Installationsvorgänge, z. B. auch Modifizieren und Reparieren.

Komprimierte Administrator-Installationsabbilder haben außerdem kurze Dateipfade. Dadurch werden Probleme beim Speichern der Installationsabbilder in tiefen Ordnerstrukturen vermieden.

Wenn Benutzer eine Aktualisierung auf ein neues Service Pack durchführen, müssen sie nicht nur die Patches, sondern das gesamte Abbild herunterladen.
Übergeordnetes Thema Administrator-Installationsabbilder verwenden


Administrator-Installationsabbild vom SOLIDWORKS Installations-Manager aus erstellen

Wenn Sie SOLIDWORKS auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.

  1. Starten Sie den SOLIDWORKS Installations-Manager.

    Siehe Installationsmedien herunterladen.

  2. Wählen Sie auf dem Begrüßungsbildschirm die Option Administrator-Installationsabbild erstellen, das auf mehreren Computern bereitgestellt wird sowie eine der folgenden Optionen aus:
    Option | Bezeichnung
    Neues Abbild mit Standardeinstellungen erstellen. | Erstellen Sie das Abbild unter Verwendung der Standardkonfigurationseinstellungen (d. h. nicht auf der Basis der Einstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort erstellt wurden).
    Neues Abbild mit Einstellungen und Dateien von einem bestehenden Abbild erstellen. | Erstellen Sie das Abbild unter Verwendung der Konfigurationseinstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort festgelegt wurden. Klicken Sie auf Durchsuchen, um das Installationsverzeichnis für das vorhandene Administrator-Installationsabbild anzugeben.
  3. Geben Sie Ihre SOLIDWORKS Seriennummer ein.
  4. Klicken Sie auf Ändern, um Produkte oder Standardoptionen zu ändern, die Folgendes enthalten:
    • Administrator-Installationsabbild-Position
    • Typ des Administrator-Installationsabbilds
  5. Akzeptieren Sie den Lizenzvertrag und klicken Sie auf Jetzt erstellen.
  6. Klicken Sie auf Abbild anpassen, um die Einstellungen im Editor für die Optionen für Administrator-Installationsabbilder zu öffnen und anzuzeigen.
  7. Optional: Klicken Sie auf Desktopverknüpfung erstellen, um auf das Installationsabbild auf Ihrem Desktop zuzugreifen.
Übergeordnetes Thema Administrator-Installationsabbilder verwenden


Administrator-Installationsabbild Options-Editor

Mit dem Administrator-Installationsabbild Options-Editor können Sie Installationsparameter-Einstellungen in einem Administrator-Installationsabbild für Einzel-Computer und für Gruppen von Computern anpassen.

Nach der Erstellung eines Administrator-Installationsabbilds werden Sie vom SOLIDWORKS Installations-Manager zum Starten des Options-Editors aufgefordert. Sie können den Options-Editor auch starten, indem Sie auf sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner doppelklicken.

Um verschiedene Installationskonfigurationen für Computergruppen oder einzelne Computer festzulegen, wählen Sie im Options-Editor die Computer aus. Geben Sie dann die Installationsoptionen für diese Maschinen an.

Alle Dialogfelder, in denen Sie nach einer Datei oder einem Ordnerpfad gefragt werden, enthalten eine Option zum Zuordnen eines ausgewählten Ordners zu einer Umgebungsvariable. Wenn Sie z. B. C:\Program Files\SOLIDWORKS Corp auswählen, ist der Dateipfad %ProgramFiles%\SOLIDWORKS Corp zugeordnet. Die häufigsten Variablen sind %ProgramFiles% und %SystemDrive%.

Sie können nicht alle Pfade Umgebungsvariablen zuordnen. Sie können beispielsweise Z:\SOLIDWORKS Data keiner Umgebungsvariable zuordnen.

Inhaltsverzeichnis

  • Gruppen und Computer hinzufügen und löschen

    Mit dem Administrator-Installationsabbild Options-Editor können Sie verschiedene Installationskonfigurationen für Gruppen und Computer sowie für Einzelplatz-Computer festlegen.

  • Anzeigen und Bearbeiten von Optionseinstellungen

    Der SOLIDWORKS Options-Editor für das Administrator-Installationsabbild ermöglicht Ihnen, Optionseinstellungen für Gruppen und Computer, die für das Abbild festgelegt wurden, anzuzeigen und zu ändern.

  • Bereitstellung von Installationen über den Options-Editor

    Sie können Installationen direkt vom Options-Editor aus bereitstellen, indem Sie entweder die manuelle oder die Push-Methode verwenden.

  • Beenden des Options-Editors

    Sie können auf „OK“ oder „Schließen“ klicken, um die Änderungen zu übernehmen und den Options-Editor zu beenden.

  • Erstellen einer Desktop-Verknüpfung zum Options-Editor

    Sie können eine Windows-Desktop-Verknüpfung zum Options-Editor für ein bestimmtes Administrator-Installationsabbild erstellen, und von der Anwendung aus.

  • Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen

    Sobald Sie ein freigegebenes Administrator-Installationsabbild-Verzeichnis erstellt haben, können Sie Clients über E-Mail benachrichtigen.

Übergeordnetes Thema Administrator-Installationsabbilder verwenden


Gruppen und Computer hinzufügen und löschen

Mit dem Administrator-Installationsabbild Options-Editor können Sie verschiedene Installationskonfigurationen für Gruppen und Computer sowie für Einzelplatz-Computer festlegen.

Sie können z. B. etliche Computer so konfigurieren, dass sie einen Teilsatz der Produktkomponenten verwenden, die im Abbild zur Verfügung stehen, während eine andere Gruppe u. U. einen anderen Teilsatz der Komponenten verwendet. Obwohl Sie ein Administrator-Installationsabbild verwenden, ermöglichen es die Gruppeneinstellungen des Options-Editors, dass verschiedene Produkt-Teilsätze auf verschiedene Gruppen von Maschinen installiert werden können. Sie können Einstellungen zwischen Gruppen verschieben und Gruppen von Computern bearbeiten.

Sie können auch Gruppen von Computern in Untergruppen unterteilen. Die Untergruppen erben die Einstellungen von der übergeordneten Gruppe. Sie können jedoch für jede Untergruppe die Einstellungen individuell ändern.

Hinzufügen einer Gruppe:
  1. Klicken Sie mit der rechten Maustaste auf Globale Einstellungen und dann auf Gruppe hinzufügen.
  2. Geben Sie den Gruppennamen ein.

Computer hinzufügen:
  1. Klicken Sie mit der rechten Maustaste auf eine bestehende Gruppe oder auf Globale Einstellungen und dann auf Computer hinzufügen.
    Wenn Sie auf eine bestehende Gruppe rechtsklicken, werden dieser Gruppe Computer hinzugefügt. Ansonsten werden sie auf der übergeordneten Ebene hinzugefügt.
  2. Wählen Sie eine der folgenden Optionen aus:
    • Wählen Sie Nach Computer-Name aus und geben Sie einen Computer-Namen ein.
      Ein Computer-Name darf keinen Domain-Kennzeichner enthalten. pluto.solidworks.com ist z. B. ungültig.
    • Wählen Sie Nach IP-Adresse aus und geben Sie die IP-Adresse eines Computers ein.
    • Wählen Sie Nach IP-Adressbereich aus und geben Sie die erste und die letzte IP-Adresse des Bereichs ein.
    • Klicken Sie auf Mehrere Maschinen hinzufügen, um die Maschinennamen einzugeben. Sie können Computer-Namen durch Zeilenumbruch, Leerzeichen, Tabulator, Komma, Punkt, Doppelpunkt oder Semikolon trennen. Sie können auch eine Liste von Maschinennamen aus einer Datei mit Trennzeichen, z. B. aus einer *.xls- oder *.cvs-Datei, kopieren und in das Dialogfeld einfügen.

    Wenn Sie Computer nach Name, IP-Adresse und IP-Adressbereich hinzufügen, sucht der installierende Computer in der folgenden Reihenfolge nach einer Übereinstimmung: Computer-Name, IP-Adresse und dann IP-Adressbereich. Die Installationsoptionen werden auf Basis der ersten gefundenen Übereinstimmung auf den installierenden Computer angewendet.

So verschieben Sie einen bestehenden Computer in eine Gruppe oder Untergruppe:

Ziehen Sie den Computer in die Gruppe oder Untergruppe.

So verschieben Sie einen Computer aus einer Gruppe oder Untergruppe:

Ziehen Sie den Computer auf Globale Einstellungen oder in eine andere Gruppe oder Untergruppe.

So löschen Sie eine Gruppe, eine Untergruppe oder einen Computer:

Klicken Sie mit der rechten Maustaste auf die Gruppe, die Untergruppe oder den Computer und dann auf Gruppe löschen oder Computer löschen.

Wenn Sie eine Gruppe löschen, werden alle Computer in dieser Gruppe gelöscht.

All Gruppen und Computer löschen:

Klicken Sie mit der rechten Maustaste auf Globale Einstellungen und dann auf Alles löschen.

Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Anzeigen und Bearbeiten von Optionseinstellungen
Bereitstellung von Installationen über den Options-Editor
Beenden des Options-Editors
Erstellen einer Desktop-Verknüpfung zum Options-Editor
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen


Anzeigen und Bearbeiten von Optionseinstellungen

Der SOLIDWORKS Options-Editor für das Administrator-Installationsabbild ermöglicht Ihnen, Optionseinstellungen für Gruppen und Computer, die für das Abbild festgelegt wurden, anzuzeigen und zu ändern.

  • Beim ersten Starten des Options-Editor werden die Optionseinstellungen schreibgeschützt angezeigt. Das Symbol „Bearbeiten“ [image] ist nicht schattiert.

    Durch Klicken auf Globale Einstellungen wird eine Zusammenfassung der Optionseinstellungen für eine Gruppe oder einen Computer angezeigt:

    Bereich | Angezeigte Optionseinstellungen
    Globale Einstellungen | Alle Optionseinstellungen, die für das Administrator-Installationsabbild festgelegt wurden
    Gruppe | Änderungen bei den Gruppeneinstellungen bezüglich der globalen Einstellungen.
    Computer | Änderungen bei den Computereinstellungen bezüglich der Gruppe.
  • Um Änderungen an den Optionseinstellungen vorzunehmen, klicken Sie auf Ändern [image]. Das Symbol wird schattiert dargestellt und eine ausführlichere Optionseinstellungsliste wird angezeigt.

    Durch Klicken auf Globale Einstellungen können Sie Optionseinstellungen für eine Gruppe oder einen Computer ändern. Wenn Sie eine Optionseinstellung ändern, die sich von den übernommenen globalen oder Gruppeneinstellungen unterscheidet, wird diese Optionseinstellung hervorgehoben.

    Wenn Sie erneut auf Ändern [image] klicken, kehrt die Anzeige in den schreibgeschützten Modus zurück.

    Beim Beenden des Options-Editors werden Sie aufgefordert, die Änderungen zu speichern oder zu verwerfen.

Inhaltsverzeichnis

  • Optionseinstellungen für Gruppen und Computer festlegen

    Sie können Optionseinstellungen für alle Computer (globale Einstellungen), Gruppen von Computern und Einzel-Computer festlegen.

  • Administrator-Installationsabbild-Optionseinstellungen

    Der Options-Editor ermöglicht die Definition der Einstellungen für einzelne Clients oder Gruppen, einschließlich Seriennummern, Client-Installationsoptionen, welche Software-Komponenten installiert werden sollen und die Toolbox Position.

  • Übernahme von globalen und Gruppenoptionseinstellungen

    Optionseinstellungen für Globale Einstellungen oder Gruppen werden von untergeordneten Elementen übernommen.

  • Anpassen der Einstellungen für einzelne Computer

    Sie können auch Einstellungen ändern, die Sie für bestimmte Computer festgelegt haben. Klicken Sie dazu mit der rechten Maustaste auf den Computernamen.

Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Bereitstellung von Installationen über den Options-Editor
Beenden des Options-Editors
Erstellen einer Desktop-Verknüpfung zum Options-Editor
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen


Optionseinstellungen für Gruppen und Computer festlegen

Sie können Optionseinstellungen für alle Computer (globale Einstellungen), Gruppen von Computern und Einzel-Computer festlegen.

  1. Klicken Sie im Options-Editor auf das zu ändernde Objekt (z. B. Globale Einstellungen, eine Gruppe oder einen Computer).
  2. Klicken Sie rechts auf Ändern [image].
    Das Symbol wird schattiert dargestellt und eine ausführlichere Optionseinstellungsliste wird angezeigt.
  3. Ändern Sie Optionseinstellungen, indem Sie rechts auf die Optionseinstellungen für das auf der linken Seite ausgewählte Element klicken.
    Änderungen an den Optionseinstellungen, die Globale Einstellungen oder Gruppeneinstellungen überschreiben, werden hervorgehoben.
  4. Klicken Sie auf OK oder Schließen, um die Änderungen zu speichern.
    Option | Bezeichnung
    OK | Die Änderungen werden gespeichert, und der Options-Editor wird geschlossen.
    Schließen | Der Options-Editor fragt, ob Sie die Änderungen speichern möchten, und wird dann geschlossen.
Übergeordnetes Thema Anzeigen und Bearbeiten von Optionseinstellungen
Administrator-Installationsabbild-Optionseinstellungen
Übernahme von globalen und Gruppenoptionseinstellungen
Anpassen der Einstellungen für einzelne Computer


Administrator-Installationsabbild-Optionseinstellungen

Der Options-Editor ermöglicht die Definition der Einstellungen für einzelne Clients oder Gruppen, einschließlich Seriennummern, Client-Installationsoptionen, welche Software-Komponenten installiert werden sollen und die Toolbox Position.

Seriennummern

Geben Sie die Seriennummern für die Installation der Produkte auf Client-Computern ein.
Da es viele Möglichkeiten gibt, SOLIDWORKS Produkte zu erwerben, können einige Seriennummern zwei oder mehr Produkte abdecken. So kann eine SOLIDWORKS Seriennummer Ihnen beispielsweise gestatten, SOLIDWORKS Simulation zu installieren, ohne eine separate SOLIDWORKS Simulation Seriennummer eingeben zu müssen. Zudem benötigen einige Produkte keine Seriennummer. Wenn Sie Fragen zu Ihren Seriennummern haben, wenden Sie sich an Ihren Fachhändler.
Wenn Sie Lizenzen mit der SolidNetWork Lizenzierung verwalten:
  • Geben Sie die SolidNetWork Seriennummer in das erste Seriennummerfeld ein.
  • Geben Sie den Servernamen und Port des SolidNetWork License Manager in das Feld SNL Server Port@Server im Format nnnnn@Servername ein. Geben Sie mehrere Einträge durch Semikolon getrennt ein.

Nähere Informationen über die SolidNetWork Lizenzierung finden Sie unter Installation von SolidNetWork Lizenzen – Übersicht.

Client-Installationsoptionen

Wie sollen Client-Installationen von Hauptversionen ausgeführt werden? Sie können festlegen, wie bei Clientinstallationen eine vorhandene Hauptversionsinstallation behandelt wird:
  • Auf bestehende Hauptversion (sofern vorhanden) aktualisieren.

    Aktivieren Sie diese Option, wenn die vorherige Hauptversionsinstallation durch die neue Installation ersetzt werden soll.

  • Neue Hauptversion erstellen.

    Aktivieren Sie diese Option, wenn die vorherige Hauptversioninstallation erhalten bleiben soll und eine neue Installation für die neue Hauptversion erstellt werden soll. Um einen Speicherort für die Installation der neuen Version anzugeben, klicken Sie auf Durchsuchen.
Soll die letzte vorige Version deinstalliert werden, bevor eine neue Hauptversion installiert wird? Sie können festlegen, ob die bestehende Version vor der Hauptversion deinstalliert werden soll:
  • Nicht deinstallieren.

    Aktivieren Sie diese Option, um die frühere Hauptversionsinstallation beizubehalten.

  • Die neueste Version deinstallieren.
  • Alle Versionen deinstallieren.
Wie sollen SOLIDWORKS Einstellungen angewendet werden? Sie können beim Starten der Software eine Einstellungsdatei angeben. Client-Installationen verweisen auf eine Einstellungsdatei. Speichern Sie die Einstellungsdatei (*.sldsettings) unter einem freigegebenen UNC-Pfad, der für alle Installationen sichtbar ist. Geben Sie vor der Installation von SOLIDWORKS einen *.sldsettings-Pfad an. Client-Installationen erkennen den Pfad der *.sldsettings-Datei während der Installation.
Schützen Sie die *.sldsettings-Datei, indem Sie in den Windows-Dateiberechtigungen den Schreibzugriff auf bestimmte Benutzer einschränken.

Klicken Sie zum Erstellen oder Bearbeiten einer *.sldsettings-Datei auf Einstellungsadministrator starten. Mit dem SOLIDWORKS Einstellungsadministrator können Sie festlegen, welche SOLIDWORKS Systemoptionen für Endbenutzer angewendet oder optional gesperrt werden sollen. Sie können auch definieren, wie und wann die Einstellungen auf Einzelinstallationen angewendet werden, und Sie können die *.sldsettings-Datei jederzeit ändern, indem Sie das Einstellungsadministrator-Werkzeug ausführen und die bestehende Datei überschreiben.

Sie können verschiedene *.sldsettings-Dateien für andere Computer oder Gruppen verwenden.

Der Pfad zu *.sldsettings wird bei der Installation festgelegt. Nach der Bereitstellung dürfen Sie die *.sldsettings-Datei weder umbenennen noch verschieben.

Um das Einstellungsadministrator-Werkzeug auszuführen, benötigen Sie eine bestehende Installation von SOLIDWORKS [aktuelle Hauptversion].
Wie sollen Client-Installationen aktiviert werden? Sie können festlegen, ob Sie Produktaktivierung automatisch nach dem Ausführen der Installation ausführen möchten oder fordern, dass der Anwender die Produktaktivierung manuell nach der Installation ausführt.
  • Automatisch aktivieren, wenn jede Client-Installation abgeschlossen wird.

    Durch Auswahl dieser Optionseinstellung wird festgelegt, dass die Produktaktivierung automatisch ausgeführt wird. Geben Sie die E-Mail-Adresse ein, die bei der Aktivierung auf dem Client-Computer angegeben wird.

  • Nicht automatisch aktivieren.

    Die Auswahl dieser Optionseinstellung definiert, dass keine automatisierte Produktaktivierung erfolgt. Der Client-Anwender führt eine Produktaktivierung nach der Installation durch.

Verwaltungsoptionen

Während jeder Installation ein Diagnoseprotokoll erstellen. | Bei der Client-Installation kann ein Diagnoseprotokoll erstellt werden, das bei der Behebung von Installationsproblemen nützlich sein kann. Die Erstellung dieses Protokolls kann jedoch die Clientinstallation verlangsamen. Die Protokolldatei wird im Verzeichnis {Administrator-Installationsabbild-Verzeichnis}\x64\Logs\<machine_name> gespeichert.
Installation als anderer Anwender ausführen.

Sie können einen anderen Benutzer mit Administratorrechten anstelle des angemeldeten Benutzers angeben, um die Installation auszuführen. Diese Option ist nützlich, wenn einzelne Benutzer auf ihren Computern keine lokalen Administratorrechte besitzen, die zur Installation der SOLIDWORKS Produkte erforderlich sind.

Es steht eine alternative Vorgehensweise zur Bereitstellung und Installation zur Verfügung, wenn Clients nicht über Administratorrechte verfügen. Siehe Bereitstellung von Installationen über den Options-Editor.
Programm vor oder nach der Installation ausführen. | Sie können festlegen, dass ein benutzerdefiniertes Programm vor oder nach der Clientinstallation ausgeführt wird.
Sollen Clients am SOLIDWORKS Kunden-Feedback-Programm teilnehmen? | Außerdem können Sie festlegen, dass Clients am SOLIDWORKS Kunden-Feedback-Programm teilnehmen. Leistungsdaten werden zur Produktverbesserung an die SOLIDWORKS Corporation gesendet. Das Verfahren ist transparent und die gewonnenen Daten werden geschützt. Weitere Informationen dazu finden Sie unter Anwendererfahrungs-Optimierungsprogramm – Website.

Einschränkungen der Installationsoptionen "Programm vor/nach der Installation ausführen"

Mithilfe dieser Optionen können Sie auf den Client-Computern vor oder nach dem Bereitstellen von SOLIDWORKS andere Installationsprogramme oder Skripts ausführen, z. B. ein Skript zum Installieren von Microsoft Office.

Die Verwendung dieser Optionen ist eingeschränkt. Es tritt ein Fehler auf, wenn Sie eine der Optionen zum Bereitstellen eines Installationsprogramms oder Skripts verwenden, das eine Benutzeroberfläche anzeigt, z. B. ein Skript zum Anzeigen von Dialogfeldern. Wenn die automatische Bereitstellung von SOLIDWORKS ausgeführt wird, wird SOLIDWORKS nicht auf den Zielcomputern installiert.

Um die Optionen Programm vor der Installation ausführen und Programm nach der Installation ausführen zu verwenden, wählen Sie nur Programme aus, die im stillen Modus installiert werden können.

Zu installierende Software

Sie können festlegen, welche SOLIDWORKS Produktkomponenten installiert werden.
  • Durch Markieren des Kontrollkästchens neben der Produktkomponente wird die Komponente während der Clientinstallation installiert.
  • Wird die Markierung entfernt, wird die entsprechende Komponente nicht installiert.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird neben der Komponente das Symbol - angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.
Die Spezifikation Sprachen begrenzt nur die Sprachen, die für das SOLIDWORKS Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. Für eDrawings® werden beispielsweise alle Sprachen installiert.

Toolbox Optionen

Sie können festlegen, welche Normen unterstützt werden sollen und das Toolbox Standardverzeichnis bei Client-Installationen festlegen.

In der Regel greifen mehrere Benutzer auf eine freigegebene Toolbox zu, die sich meistens in einem Netzwerkspeicherort befindet (z. B. UNC-Pfad, freigegebener Ordner oder ein gemeinsam verwendetes Netzwerklaufwerk).

Wenn am Speicherort bereits eine ältere Hauptversion der Toolbox vorhanden ist, wird bei der Client-Installation ein Upgrade der Toolbox auf die neue Hauptversion ausgeführt. Die Dateien sind anschließend nicht mehr mit vorherigen Hauptversionen von SOLIDWORKS kompatibel.
Wenn einige Clients weiterhin eine ältere Version von SOLIDWORKS verwenden, müssen Sie einen anderen Toolbox-Netzwerkspeicherort für die Clients angeben, für die ein Upgrade auf die neue Version ausgeführt wird.

Weitere Informationen zur Verwaltung der SOLIDWORKS Toolbox finden Sie unter Toolbox in der SOLIDWORKS Hilfe.

Installation der Toolbox-Software ohne Installation der Toolbox-Daten

Wenn Ihre Umgebung über einen PDM oder freigegebenen Toolbox/Bohrungsassistent-Speicherort verfügt, können Sie Client-Installationen so einrichten, dass Toolbox-Daten an diesem Speicherort nicht installiert oder aktualisiert werden.

Dies ist sinnvoll, wenn:
  • Sie haben die lokale Ansicht von SOLIDWORKS PDM vor der Installation von SOLIDWORKS noch nicht festgelegt.
  • Die Dateien am Speicherort verwendet werden und verhindern könnten, dass SOLIDWORKS Installationen abgeschlossen werden.
  • Der Speicherort nicht verfügbar ist und verhindern könnte, dass SOLIDWORKS Installationen abgeschlossen werden.

Wenn Sie Client-Installationen so einstellen, dass Toolbox-Daten nicht installiert werden, verweisen die SOLIDWORKS Software und Einstellungen auf den Speicherort der Toolbox/des Bohrungsassistenten, aber Sie müssen die Daten später an einem zentralen Ort installieren.

So installieren Sie die SOLIDWORKS Software ohne Toolbox/Bohrungsassistent-Daten:
  • Wenn Sie gefragt werden, ob dieser Client die Toolbox-Dateien installieren/aktualisieren soll, wählen Sie Nein, Toolbox-Software ohne Datendateien installieren aus.

Mindestens eine Person, in der Regel der CAD Administrator, muss die Toolbox/Bohrungsassistent-Daten am zentralen Ort installieren oder aktualisieren, da die Software sonst nicht ordnungsgemäß funktioniert. Jeder Mitarbeiter im Unternehmen kann diese Aufgabe mit einer einzigen manuellen Installation der SOLIDWORKS Software durchführen. Wenn Sie Toolbox in SOLIDWORKS PDM verwalten, befolgen Sie die Schritte im Abschnitt „Toolbox“ der SOLIDWORKS PDM Administrationsanleitung, um die Toolbox Daten zu installieren oder zu aktualisieren.

SOLIDWORKS PDM Client Optionen

Sie können die folgenden Optionen für die Bereitstellung von SOLIDWORKS PDM Clients und Zusatzanwendungen auswählen:

  • PDM-Produkttyp
  • PDM Clienttyp
  • Features
  • Tresoransicht

    Um den Assistenten zur Ansichtseinrichtung zu starten, müssen Sie den Administrator-Installationsabbild Options-Editor auf einem Computer ausführen, auf dem der SOLIDWORKS PDM Client installiert ist.

    Um die Tresoransicht auf dem Client-Computer zu erstellen, benötigen Sie eine Datei im Format „Conisio View Setup“ (.cvs), in der die Parameter für die Konfiguration der Tresoransicht auf dem Client-Computer definiert werden. Sie können eine vorhandene .cvs-Datei referenzieren oder diese Datei im Administrator-Installationsabbild Options-Editor erstellen.

Weitere Informationen zu diesen Clients und Zusatzanwendungen finden Sie im Abschnitt zu SOLIDWORKS PDM in der SOLIDWORKS Hilfe.

Optionen für Electrical

Sie können die folgenden Parameter für die administrativen Komponenten von SOLIDWORKS Electrical festlegen:
  • Datenpfad
  • Computername und Portnummer des Collaborative Server
  • SQL Server-Computername und -Passwort

Weitere Informationen zu diesen Optionen finden Sie unter SOLIDWORKS Electrical .

Übergeordnetes Thema Anzeigen und Bearbeiten von Optionseinstellungen
Optionseinstellungen für Gruppen und Computer festlegen
Übernahme von globalen und Gruppenoptionseinstellungen
Anpassen der Einstellungen für einzelne Computer
Installation von SolidNetWork Lizenzen – Übersicht
Bereitstellung von Installationen über den Options-Editor
SOLIDWORKS Electrical


Übernahme von globalen und Gruppenoptionseinstellungen

Optionseinstellungen für Globale Einstellungen oder Gruppen werden von untergeordneten Elementen übernommen.

Beispiel:
  • Einstellungen, die für Globale Einstellungen definiert sind, gelten für alle Gruppen und Computer.
  • Einstellungen, die für eine Gruppe definiert sind, gelten für alle Untergruppen und Computer in dieser Gruppe.

Sie können Optionseinstellungen für eine Gruppe, eine Untergruppe oder einen Computer ändern, um Standardeinstellungen oder übertragene Einstellungen außer Kraft zu setzen. Wenn Sie eine Optionseinstellung vom Standardwert oder übernommenen Wert ändern, wird diese Option hervorgehoben.

Um die Optionseinstellungen auf die ursprünglichen übernommenen Werte zurückzusetzen, klicken Sie mit der rechten Maustaste auf die Gruppe, Untergruppe oder den Computer und klicken Sie dann auf eine der folgenden Optionen:
  • Auf globale Einstellungen zurücksetzen (für eine Gruppe, Untergruppe oder einen Computer, der nicht Gruppenmitglied ist)
  • Auf Gruppeneinstellungen zurücksetzen (für einen Computer, der Gruppenmitglied ist)
  • Teile auf Gruppeneinstellungen zurücksetzen (für alle Mitglieder dieser Gruppe auf einmal)
Übergeordnetes Thema Anzeigen und Bearbeiten von Optionseinstellungen
Optionseinstellungen für Gruppen und Computer festlegen
Administrator-Installationsabbild-Optionseinstellungen
Anpassen der Einstellungen für einzelne Computer


Anpassen der Einstellungen für einzelne Computer

Sie können auch Einstellungen ändern, die Sie für bestimmte Computer festgelegt haben. Klicken Sie dazu mit der rechten Maustaste auf den Computernamen.

Im Kontextmenü können Sie die folgenden Tasks für die einzelnen Computer ausführen:
  • Umbenennen
  • Computer löschen
  • Auf globale Einstellungen zurücksetzen
  • Hinweise bearbeiten
  • Optionen bearbeiten

Das Bearbeiten von Optionen ermöglicht Ihnen, alle Optionen für den Computer zu ändern, z. B. die Client-Installationsoptionen und die Verwaltungsoptionen.

Übergeordnetes Thema Anzeigen und Bearbeiten von Optionseinstellungen
Optionseinstellungen für Gruppen und Computer festlegen
Administrator-Installationsabbild-Optionseinstellungen
Übernahme von globalen und Gruppenoptionseinstellungen


Bereitstellung von Installationen über den Options-Editor

Sie können Installationen direkt vom Options-Editor aus bereitstellen, indem Sie entweder die manuelle oder die Push-Methode verwenden.

  • Verwenden Sie im Options-Editor die Seite zur manuellen Bereitstellung, um Benutzern per E-Mail Anweisungen zum Starten der Installation zu senden. Verwenden Sie diese Methode, wenn Benutzer über Administratorrechte für ihre Client-Computer verfügen.
    Unter Administrative Optionen können Sie Benutzern administrative Berechtigungen zuweisen, indem Sie Installation als anderer Benutzer ausführen auswählen.
  • Verwenden Sie im Options-Editor die Seite zur automatischen Bereitstellung, um Installationen mittels Push automatisch auf Zielcomputer zu übertragen. Verwenden Sie diese Methode, wenn Benutzer keine Administratorrechte haben, um Software auf ihren Systemen zu installieren. Mit dieser Methode können Sie auch benutzerdefinierte Installationen durchführen.

Um eine manuelle oder automatische Bereitstellung durchzuführen, müssen Sie das Verzeichnis mit dem Administrator-Installationsabbild in einem freigegebenen Windows-Verzeichnis speichern, damit es über einen Netzwerkspeicherort verfügbar ist, z. B. \\machine\shared_directory. Sie können das Abbild auch verfügbar machen, indem Sie es auf jedem Computer in ein lokales Verzeichnis kopieren, z. B. C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0.

Inhaltsverzeichnis

  • Verwenden eines UNC-Pfads, um ein Administrator-Installationsabbild bereitzustellen

    Verwenden Sie anstelle der Zuordnung von Netzlaufwerken einen UNC-Pfad (\\machine_name\share_name), wenn Sie einen Netzwerkspeicherort für das Installationsverzeichnis des Administrator-Installationsabbilds angeben.

  • Verwenden von StartSWInstall.exe zum Bereitstellen eines Administrator-Installationsabbilds

  • Manuelles Bereitstellen

    Sie können diese Methode verwenden, wenn Benutzer die Berechtigungen haben, die erforderlich sind, um auf ihren Systemen Installationen durchzuführen.

  • Voraussetzungen für die automatische Bereitstellung

    Die automatische Bereitstellung gilt für Benutzer ohne Administratorrechte, da sie sicherstellt, dass die Softwareinstallation nahtlos durchgeführt werden kann.

  • Automatisches Bereitstellen

  • Testen einer Einrichtung für eine Push-Bereitstellung

    Die Registerkarte Automatisch bereitstellen im Administrator-Installationsabbild Options-Editor enthält eine Testfunktion.

Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Anzeigen und Bearbeiten von Optionseinstellungen
Beenden des Options-Editors
Erstellen einer Desktop-Verknüpfung zum Options-Editor
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen


Verwenden eines UNC-Pfads, um ein Administrator-Installationsabbild bereitzustellen

Verwenden Sie anstelle der Zuordnung von Netzlaufwerken einen UNC-Pfad (\\machine_name\share_name), wenn Sie einen Netzwerkspeicherort für das Installationsverzeichnis des Administrator-Installationsabbilds angeben.

Zugeordnete Netzlaufwerke sind nicht kompatibel mit der Push- und der automatischen Installationsmethode und auch nicht mit „Als anderer Benutzer ausführen“ in der Pull- und der manuellen Methode.

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Verwenden von StartSWInstall.exe zum Bereitstellen eines Administrator-Installationsabbilds

Sie können ein Administrator-Installationsabbild auf Clients installieren bzw. deinstallieren. Führen Sie dazu den Befehl admin_image_install_dir\ StartSWInstall.exe aus. Diese Methode installiert SOLIDWORKS mit den im Options-Editor des Administrator-Installationsabbilds definierten Optionen, Computern und Gruppen.

Sie können die folgenden Schalter an den Befehl StartSWInstall.exe anfügen:
Wechseln | Beschreibung
/install | Installiert das Administrator-Installationsabbild auf Client-Computern.
/uninstall Deinstalliert die Software von Client-Computern, mit zwei optionalen Schaltern:

/removedata

Nur für Deinstallation verfügbar. Entfernt SOLIDWORKS Datendateien und Ordner während der Deinstallation.

/removeregistry

Nur für Deinstallation verfügbar. Entfernt SOLIDWORKS Registrierungseinträge während der Deinstallation.
/showui | Zeigt ein Verlaufsfenster für den SOLIDWORKS Installations-Manager an. Andernfalls ist der SOLIDWORKS Installations-Manager für den Benutzer ausgeblendet.
/now | Startet die Installation oder Deinstallation sofort. Das 5-Minuten-Warndialogfeld wird nicht angezeigt.

StartSWInstall.exe sollte statt StartSWInstall.hta bevorzugt verwendet werden, wenn die Installation ohne Benutzereingriff durchgeführt werden soll, aber keine automatische Bereitstellung über den Options-Editor des Administrator-Installationsabbilds erwünscht ist.

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Manuelles Bereitstellen

Sie können diese Methode verwenden, wenn Benutzer die Berechtigungen haben, die erforderlich sind, um auf ihren Systemen Installationen durchzuführen.

Manuelles Bereitstellen von Installationen per E-Mail:

  1. Klicken Sie im Options-Editor auf Bereitstellen.
    Für jeden Computer werden die Verfügbarkeit und der Status bezüglich der Installation angezeigt.
  2. Klicken Sie auf E-Mail senden.
  3. Geben Sie den Netzwerkpfad zum Administrator-Installationsabbildverzeichnis an.
    In der Regel wird der Verzeichnispfad zum Administrator-Installationsabbildverzeichnis anfänglich als Windows-Dateipfad angezeigt (z. B. C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0). Im Dialogfeld wird der Hinweis Dieser Pfad ist kein Netzwerkpfad angezeigt.
    1. Klicken Sie auf Durchsuchen, um den Netzwerkspeicherort für dieses Administrator-Installationsabbildverzeichnis anzugeben.
    2. Navigieren Sie zu dem Computer, auf dem das Administrator-Installationsabbild installiert ist, und wählen Sie das freigegebene Windows-Verzeichnis aus, das für das Administrator-Installationsabbild-Verzeichnis festgelegt ist.
      Navigieren Sie nicht in Unterverzeichnisse des Administrator-Installationsabbild-Verzeichnisses (z. B. in die Unterverzeichnisse 64bit).
    3. Klicken Sie auf OK.
      Im Dialogfeld wird nun der Hinweis Dieser Pfad ist ein Netzwerkpfad angezeigt.
    Es wird eine E-Mail erstellt, die den Eigentümer des Computers anleitet, wie aus dem Administrator-Installationsabbild installiert wird, und zwar unter Verwendung des Netzwerkspeicherorts für die Datei StartSWInstall.hta im Administrator-Installationsabbild.
  4. Senden Sie die E-Mail an die Benutzer, die für die SOLIDWORKS-Installation verantwortlich sind.

Benutzer können in der E-Mail auf den Link zum Netzwerkspeicherort für StartSWInstall.hta klicken, um SOLIDWORKS aus dem Administrator-Installationsabbild zu installieren.

Im Options-Editor zeigt Installationsstatus Folgendes an:
Noch nicht erledigt | Der Benutzer hat die Installation noch nicht auf dem betreffenden Computer durchgeführt.
Erfolgreich | Der Benutzer hat die Installation erfolgreich auf dem betreffenden Computer ausgeführt.
Fehlgeschlagen | Der Benutzer hat versucht, die Installation auf dem betreffenden Computer auszuführen, sie ist jedoch fehlgeschlagen.
Andere Statusmeldungen, die erscheinen könnten, sind: "Erfolgreich installiert", "Erfolgreich deinstalliert", "Installieren", "Deinstallieren", "Neustart erforderlich", "Installation fehlgeschlagen" und "Deinstallation fehlgeschlagen".
Klicken Sie oben in der Spalte Status auf den grünen Pfeil, um die Aktualisierung durchzuführen und aktualisierte Informationen anzuzeigen.
Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Voraussetzungen für die automatische Bereitstellung

Die automatische Bereitstellung gilt für Benutzer ohne Administratorrechte, da sie sicherstellt, dass die Softwareinstallation nahtlos durchgeführt werden kann.

Für die automatische Bereitstellung müssen sowohl der Client als auch der Server zur selben Active Directory-Domäne gehören. Mit dieser Konfiguration können Installationsaufgaben auf Zielcomputer übertragen werden, wo sie vom Microsoft Taskplaner ohne Benutzeraktionen ausgeführt werden.

Bei einer Push-Installation startet der Taskplaner den SOLIDWORKS Installations-Manager auf einem Client-Computer mit den Anmeldeinformationen, die von einem Administrator im Options-Editor festgelegt wurden. Der Taskplaner wird auf dem LocalSystem-Konto des Computers ausführt. Dieses Konto wird auf dem Netzwerk als Sicherheitsprinzip des Computers ausgeführt. Das Sicherheitsprinzip des Computers muss folgenden Zugriff haben:
  • Lesezugriff auf den Ordner Admin Images.
  • Lese- und Schreibzugriff auf den Ordner Admin Images\x64\logs.

Wählen Sie beim Hinzufügen eines Computers zu einer Gruppe eines freigegebenen Ordners in Active Directory die Optionen Objekttypen und Computer aus.

Der Computer mit dem Administrator-Installationsabbild und die Client-Zielcomputer müssen darüber hinaus Mitglieder derselben Microsoft Active Directory-Domäne sein.

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Automatisches Bereitstellen

Automatisches Bereitstellen durch Übertragung von Installationen mittels Push auf Benutzersysteme:

  1. Klicken Sie im Options-Editor auf die Registerkarte Automatisch bereitstellen.
    Für jeden Computer werden die Verfügbarkeit und der Status bezüglich der Installation angezeigt.
  2. Wählen Sie unter der Spalte Bereitstellen die Client-Zielcomputer und die Gruppen in der Spalte Bereitstellen aus.
    Wählen Sie eine(n) oder mehrere Computer oder Gruppen unter der Spalte Bereitstellen aus, bevor Sie den Bereitstellungsprozess starten.
  3. Wählen Sie unter Install Time (Installationszeitpunkt) die Option Jetzt aus, um sofort bereitzustellen, oder Später, um ein bestimmtes Datum und eine Uhrzeit für die Bereitstellung festzulegen.
  4. Wählen Sie unter Client-Optionen Folgendes aus:
    • SOLIDWORKS 2025 installieren oder aktualisieren
    • SOLIDWORKS 2025 deinstallieren
      Wenn Sie sich für eine Deinstallation entscheiden, können Sie angeben, ob Registrierungseinträge sowie Datendateien und -ordner zusammen mit den Programmdateien und -ordnern deinstalliert werden sollen.
  5. Wählen Sie Computer automatisch neu starten aus, wenn mindestens ein Zielrechner während oder nach der Bereitstellung bei Bedarf neu gestartet werden soll.
  6. Geben Sie die Clientanmeldeinformationen von mindestens einem Zielrechner ein.
  7. Klicken Sie auf Bereitstellen, um den Bereitstellungsprozess zu starten.
Im Options-Editor lautet der Installationsstatus wie folgt:
Noch nicht erledigt | Die Installation wurde noch nicht auf dem betreffenden Computer ausgeführt.
Erfolgreich | Die Installation wurde erfolgreich auf dem betreffenden Computer ausgeführt.
Fehlgeschlagen | Die Installation auf dem betreffenden Computer ist fehlgeschlagen.

Andere Statusmeldungen, die erscheinen könnten, sind: "Erfolgreich installiert", "Erfolgreich deinstalliert", "Planung", "Verbindung", "Installieren", "Deinstallieren", "Neustart erforderlich", "Installation geplant", "Deinstallation geplant", "Installation fehlgeschlagen", "Deinstallation fehlgeschlagen", "Verbindung fehlgeschlagen" und "Planung fehlgeschlagen".

Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Testen einer Einrichtung für eine Push-Bereitstellung

Die Registerkarte Automatisch bereitstellen im Administrator-Installationsabbild Options-Editor enthält eine Testfunktion.

Sie können eine Pseudo-Installation ausführen, die die für die Bereitstellung verwendeten Systeme testet, z. B.:
  • Verbindung zum Zielcomputer
  • Erstellen eines Installations-Tasks auf diesem Computer
  • Abschließen des Installations-Tasks auf diesem Computer
  • Aktualisieren des Status und der Protokolle für das Administrator-Installationsabbild
  • Erkennen eines Programms, das vor oder nach der Installation ausgeführt werden soll

Der Test prüft auf Dateipfade, validiert Berechtigungen und meldet, dass die Installation erfolgreich beendet wurde. Auf dem Zielsystem wird keine Software installiert und die Registrierung wird nicht geändert. Wenn ein System auf einem der Zielcomputer ausfällt, zeigt der Test an, welches System fehlgeschlagen ist.

Tooltips bieten weitere Informationen zu Fehlern. Sie können die Ergebnisse in eine .xml-Tabellenkalkulation (oder .csv-Datei) exportieren, die hilfreich ist, um mehrere Ausfälle zu überprüfen oder Ergebnisse mit anderen Supportmitarbeitern zu teilen.

So testen Sie eine Einrichtung für eine Push-Bereitstellung:

  1. Erstellen Sie mit dem Installations-Manager ein Administrator-Installationsabbild.
  2. Starten Sie den Administrator-Installationsabbild-Options-Editor:

    Sie können die Option starten, nachdem der Installations-Manager die Erstellung des Administrator-Installationsabbilds abgeschlossen hat, oder im Administrator-Installationsabbildordner auf sldadminoptioneditor.exe doppelklicken.

  3. Fügen Sie auf der Registerkarte Einrichten einen oder mehrere Computer hinzu.
  4. Klicken Sie auf Automatisch bereitstellen:
    1. Geben Sie den Benutzernamen und das Kennwort eines Domänenadministrators an.
    2. Wählen Sie einen oder mehrere zu testende Computer aus.
    3. Klicken Sie auf Testen.
  5. Wenn der Einrichtungstest angezeigt wird, klicken Sie auf Test ausführen.
  6. Warten Sie einige Minuten, bis der Test abgeschlossen ist, oder klicken Sie auf Test abbrechen.
  7. Überprüfen und beheben Sie alle Einrichtungsprobleme.
Übergeordnetes Thema Bereitstellung von Installationen über den Options-Editor


Beenden des Options-Editors

Sie können auf „OK“ oder „Schließen“ klicken, um die Änderungen zu übernehmen und den Options-Editor zu beenden.

  • Klicken Sie auf OK, um die Optionseinstellungsänderungen zu übernehmen, und beenden Sie den Options-Editor.
  • Klicken Sie auf die Windows-Schaltfläche Schließen, um den Options-Editor zu beenden. Wenn die Software erkennt, dass ungespeicherte Änderungen vorhanden sind, werden Sie zum Speichern aufgefordert.
Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Anzeigen und Bearbeiten von Optionseinstellungen
Bereitstellung von Installationen über den Options-Editor
Erstellen einer Desktop-Verknüpfung zum Options-Editor
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen


Erstellen einer Desktop-Verknüpfung zum Options-Editor

Sie können eine Windows-Desktop-Verknüpfung zum Options-Editor für ein bestimmtes Administrator-Installationsabbild erstellen, und von der Anwendung aus.

  1. Starten Sie den Options-Editor.
    Beispiel: Navigieren Sie im Datei-Explorer zum Administrator-Installationsbildverzeichnis und doppelklicken Sie auf sldAdminOptionEditor.exe.
  2. Klicken Sie auf Desktop-Verknüpfung zu diesem Options-Editor erstellen.
    Es wird dann eine Verknüpfung zum Options-Editor für das Administrator-Installationsabbild auf dem Windows-Desktop angezeigt.
Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Anzeigen und Bearbeiten von Optionseinstellungen
Bereitstellung von Installationen über den Options-Editor
Beenden des Options-Editors
Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen


Ein Administrator-Installationsabbild für Clients mittels E-Mail erstellen

Sobald Sie ein freigegebenes Administrator-Installationsabbild-Verzeichnis erstellt haben, können Sie Clients über E-Mail benachrichtigen.

Konfigurieren Sie das auf einem Computer freigegebene Administrator-Installationsabbild-Verzeichnis und auf den andere Computer zugreifen können auf einem Computer (z.B., über einen UNC-Pfad).

Sie können eine E-Mail mit einem Link auf admin_image_install_dir\StartSWInstall.hta an alle Clients schicken. Die Clients können dann auf diesen Link klicken und dann auf SOLIDWORKS Produkte jetzt installieren klicken, um die Installation vom Administrator-Installationsabbild aus zu starten.

Wenn Sie ein Administrator-Installationsabbild auf eine neue SOLIDWORKS Version aktualisieren, können Sie den Administrator-Installationsabbildbereich konfigurieren und Eigenschaften freigeben, sodass Clients, die früher mit diesem Abbild installiert haben, automatisch aktualisiert werden. Einzelheiten dazu finden Sie unter Aktualisierung von Clients von Administrator-Installationsabbildern.
Übergeordnetes Thema Administrator-Installationsabbild Options-Editor
Gruppen und Computer hinzufügen und löschen
Anzeigen und Bearbeiten von Optionseinstellungen
Bereitstellung von Installationen über den Options-Editor
Beenden des Options-Editors
Erstellen einer Desktop-Verknüpfung zum Options-Editor


Einstellungsadministrator-Werkzeug

Mit dem Einstellungsadministrator-Werkzeug können Sie Systemoptionen festlegen, die bei der Bereitstellung oder Aktualisierung der SOLIDWORKS Software angewendet werden, und verhindern, dass Benutzer diese Optionen ändern. Dieses Werkzeug ersetzt den SOLIDWORKS Einstellungsassistenten für die Bereitstellung von Einstellungen, obwohl der Assistent weiterhin für das Kopieren von Einstellungen verfügbar ist.

Die Verwendung des Einstellungsadministrator-Werkzeug mit dem Options-Editor für Administrator-Installationsabbilder erfolgt in drei Schritten:
  1. Erstellen Sie ein Administrator-Installationsabbild, um auf das Werkzeug zuzugreifen.
  2. Verwenden Sie das Einstellungsadministrator-Werkzeug, um eine *.sldsettings Datei zu erzeugen, die Ihre ausgewählten SOLIDWORKS Optionen enthält.
  3. Schließen Sie die *.sldsettings-Datei in SOLIDWORKS Installationen ein.
Wenn Sie die Zusatzanwendung von 3DEXPERIENCE verwenden, können Sie eine *.sldsettings-Datei auch außerhalb eines Administrator-Installationsabbilds bereitstellen. Ein Vorteil dieser Methode ist, dass die Einstellungen bei der Anmeldung automatisch bereitgestellt werden.
  1. Um auf das Einstellungsadministrator-Werkzeug zuzugreifen, führen Sie die unter Zugriff auf das Einstellungsadministrator-Werkzeug beschriebenen Schritte aus.
  2. Folgen Sie den Anweisungen, um die Einstellungen zu übernehmen und zu sperren.
  3. Erweitern Sie im 3DEXPERIENCE Compass den Bereich Meine Rollen und klicken Sie auf die App Platform Manager. Gehen Sie zu Inhalt > Konfigurationszentrum für Teamarbeitsbereiche > CAD Collaboration > SOLIDWORKS > Einstellungen > Ressourcen > CAD-Einstellungen.
  4. Unter CAD-Einstellungen können Sie nach der *.sldsettings-Datei suchen und sie hoch- bzw. herunterladen.

Inhaltsverzeichnis

  • Zugriff auf das Einstellungsadministrator-Werkzeug

    Erstellen Sie zunächst ein Administrator-Installationsabbild, um auf das Einstellungsadministrator-Werkzeug zuzugreifen.

  • Verwendung des Einstellungsadministrator-Werkzeugs

  • Anwenden und Speeren von Optionen

  • Fertigstellen der Optionseinstellungen

  • Einbindung der sldsettings-Datei in SOLIDWORKS Installationen

Übergeordnetes Thema Administrator-Installationsabbilder verwenden


Zugriff auf das Einstellungsadministrator-Werkzeug

Erstellen Sie zunächst ein Administrator-Installationsabbild, um auf das Einstellungsadministrator-Werkzeug zuzugreifen.

Sie können das Einstellungsadministrator-Werkzeug von einem Administrator-Installationsabbild aus starten.

So greifen Sie auf das Einstellungsadministrator-Werkzeug zu:

  1. Führen Sie sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner aus.
  2. Klicken Sie im Options-Editor des Administrator-Installationsabbilds auf Ändern [image].
  3. Führen Sie im Abschnitt Client Installationsoptionen folgende Schritte aus:
    1. Klicken Sie auf Exportierte Einstellungsdatei aus SOLIDWORKS Settings Administrator verwenden.
    2. Klicken Sie auf Einstellungsadministrator starten.
      Um auf Einstellungsadministrator starten zuzugreifen, muss SOLIDWORKS <Version> auf dem Computer installiert sein, auf dem sldAdminOptionEditor.exe ausgeführt wird.
Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Verwendung des Einstellungsadministrator-Werkzeugs

So verwenden Sie das Einstellungsadministrator-Werkzeug:

  1. Wählen Sie auf der Registerkarte Willkommen die folgenden Optionen aus:
    • Standardoptionen, um diese Version von SOLIDWORKS zu starten.
    • Optionen für SOLIDWORKS 2025 von diesem Computer importieren.
    • Gehen Sie zu einer bestehenden sldreg-Datei.
    • Gehen Sie zu einer bestehenden .sldsettings-Datei.
    Die *.sldreg-Datei wird durch den SOLIDWORKS Einstellungsassistenten und die *.sldsettings-Datei durch das Einstellungsadministrator-Werkzeug generiert.
  2. Klicken Sie auf Weiter.
Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Anwenden und Speeren von Optionen

Auf der Registerkarte Systemoptionen können Sie über zwei Spalten mit Kontrollkästchen auswählen, welche dieser Optionen angewendet und welche der angewendeten Optionen gesperrt werden sollen, sodass sie von Benutzern nicht geändert werden können.

Wenn Benutzer auf das Dialogfeld Systemoptionen in der SOLIDWORKS Software zugreifen, werden die gesperrten Optionen mit einem Schlosssymbol [image] angezeigt. Sie können jedoch ein Passwort festlegen, das Benutzern das Entsperren von Optionen ermöglicht. Wenn Benutzer mit dem Cursor über eine gesperrte Option fahren, werden in einem Tooltip Ihr Name und Ihre E-Mail-Adresse angezeigt, damit die Benutzer Sie kontaktieren und um das Passwort bitten können.

So wenden Sie Optionen an und sperren sie:

  1. Gehen Sie auf der Registerkarte Systemoptionen wie folgt vor:
    1. Um eine Systemoption anzuwenden, wählen Sie die Option aus und aktivieren Sie das entsprechende Kontrollkästchen in der Spalte Anwenden.
    2. Um eine Systemoption zu sperren, wählen Sie die Option aus und aktivieren Sie die entsprechenden Kontrollkästchen in den Spalten Anwenden und Sperren.
      Wenn Benutzer auf die Registerkarte Systemoptionen zugreifen, werden diese Optionen mit einem Schloss [image] angezeigt.
  2. Je nach Option müssen Sie möglicherweise zusätzliche Parameter für die Option festlegen.
  3. Sie können Benutzer auch daran hindern, Meldungen zu verwerfen, indem Sie die Handhabung von Meldungen/Fehlern/Warnungen steuern.
    1. Klicken Sie auf Meldungen/Fehler/Warnungen.
    2. Wählen Sie Anwenden und aktivieren Sie optional Sperren für die zu verwaltenden Meldungen.
    3. Richten Sie die Meldung auf Einblenden oder Nicht mehr einblenden ein.

      Wenn Sie die Option Einblenden auswählen, wird die Meldung aus der Liste der verworfenen Meldungen eines Benutzers entfernt und dem Benutzer zu gegebener Zeit angezeigt. Wenn Sie Nicht mehr einblenden auswählen, wird die Meldung automatisch zur Liste der verworfenen Meldungen eines Benutzers hinzugefügt und nicht angezeigt, wenn der Benutzer an einem Modell arbeitet.

      In der nachfolgenden Tabelle wird das Verhalten in der Software beschrieben:
      Anwenden | Sperren | Anzeigen | Nicht mehr einblenden | Verhalten
      X | X | Erzwingt das Anzeigen der Meldung.
      X | X | Verwirft die Meldung und fügt die Meldung der Liste verworfener Meldungen hinzu.
      X | X | X | Erzwingt das Anzeigen der Meldung und deaktiviert die Option Nicht mehr einblenden im Meldungsfeld.
      X | X | X | Verwirft die Meldung und hindert Benutzer daran, sie unter Extras > Optionen > Meldungen/Fehler/Warnungen zu aktivieren.
  4. Klicken Sie auf der Registerkarte Systemoptionen auf Weiter.
Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Fertigstellen der Optionseinstellungen

So stellen Sie die Einstellung von Optionen fertig:

  1. Legen Sie auf der Registerkarte Fertigstellen fest, wann Systemoptionen angewendet werden sollen:
    • Beim ersten Starten der Software
    • Bei jedem Starten der Software
    • und ob zur selben Zeit Anpassungen angewendet werden.
  2. Sie können entscheiden, ob Optionen angewendet werden, wenn der Benutzer vom Netzwerk getrennt wurde und das Außerkraftsetzen gesperrter Optionen durch API erlaubt ist.
  3. Für gesperrte Systemoptionen müssen Sie Ihren Namen und Ihre E-Mail-Adresse eingeben. Die SOLIDWORKS Software zeigt diese Informationen in einem Tooltip an, wenn Benutzer mit dem Cursor über eine gesperrte Option fahren.
  4. Sie können auch zulassen, dass Benutzer gesperrte Optionen außer Kraft setzen. Sie müssen dann ein Passwort angeben, dass Sie den Benutzern zur Verfügung stellen können.
  5. Klicken Sie auf Speichern, um eine *.sldsettings-Datei für die Bereitstellung zu erstellen.
Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Einbindung der sldsettings-Datei in SOLIDWORKS Installationen

So schließen Sie eine *.sldsettings-Datei in Ihre Installation ein:

  1. Doppelklicken Sie auf sldAdminOptionEditor.exe im Administrator-Installationsabbild-Ordner.
  2. Klicken Sie im Options-Editor des Administrator-Installationsabbilds auf Ändern.
  3. Führen Sie im Abschnitt Client Installationsoptionen folgende Schritte aus:
    1. Klicken Sie auf Exportierte Einstellungsdatei aus SOLIDWORKS Settings Administrator verwenden.
    2. Klicken Sie auf Pfad bearbeiten und navigieren Sie zur *.sldsettings-Datei.
    Sie können verschiedene *.sldsettings-Dateien für unterschiedliche Gruppen und Computer erstellen und verwenden.
  4. Aktivieren und installieren Sie die SOLIDWORKS Software.

Nach der Bereitstellung können Sie Schritt 2 jederzeit zum Ändern einer bestehenden *.sldsettings-Datei wiederholen. Die SOLIDWORKS Software liest die geänderte *.sldsettings-Datei, wenn sie das nächste Mal gestartet wird.

Übergeordnetes Thema Einstellungsadministrator-Werkzeug


Befehlszeilenbereitstellung

Sie können mittels einer Eingabeaufforderung oder Stapeldatei (stille Installation) ein Administrator-Installationsabbild automatisch aktivieren.

Zum Bereitstellen eines Administrator-Installationsabbilds mit der Befehlszeile für SOLIDWORKS PDM Clients, siehe die SOLIDWORKS PDM Installationsanleitung.

Inhaltsverzeichnis

  • Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus

    Nach der Erstellung des Administrator-Installationsabbildes und vor der Benachrichtung der Clients müssen Sie Microsoft Windows Komponenten installieren, die nicht mit dem Administrator-Installationsabbild über die Befehlzeile oder das Microsoft Active Directory installiert werden können.

  • Mit der Befehlszeile aus dem Administrator-Abbild installieren

    Sie können über die Befehlszeile Installationen von einem Administrator-Installationsabbild verwenden.

  • Befehlszeileneigenschaften

    Befehlszeileneigenschaften beschreiben hier die Feature-Eigenschaften, globalen Eigenschaften, produktspezifischen Eigenschaften und die Windows Konventionen in Bezug auf Standorte.

  • Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren

    Die Bereitstellung über Microsoft Active Directory wird für die Bereitstellung der SOLIDWORKS Kernprodukte an Clients unterstützt.

Übergeordnetes Thema Mehrere Installationen
Bereitstellung für mehrere Clients
Administrator-Installationsabbilder verwenden
Verwaltung von mehreren Installationen


Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus

Nach der Erstellung des Administrator-Installationsabbildes und vor der Benachrichtung der Clients müssen Sie Microsoft Windows Komponenten installieren, die nicht mit dem Administrator-Installationsabbild über die Befehlzeile oder das Microsoft Active Directory installiert werden können.

Die Installation dieser Windows-Komponenten ist nur dann erforderlich, wenn Sie von einem Administrator-Installationsabbild installieren, das manuell mit der Befehlszeile oder über das Microsoft Active Directory erstellt wurde. Wenn Sie den SOLIDWORKS Installations-Manager für die Erstellung und Installation eines Administrator-Installationsabbilds verwenden, werden diese Windows-Komponenten automatisch installiert.
Hier ist eine Zusammenfassung der Dateien, die von SOLIDWORKS für die Windows-Komponenten erforderlich sind:
Windows Performance Toolkit | Aktiviert die erweiterte Protokollierung in SOLIDWORKS Rx.
Visual C++ 2022 Redistributable Package | Enthält die Laufzeit-Komponenten für Microsoft Visual C++. Die Version 2022 muss installiert sein.
Visual Basic for Applications 7.1 | Bietet Unterstützung für Visual Basic Makros.
Visual Studio Tools for Application 2022 | Optional. Umfasst ein Toolset zur Unterstützung von Visual Studio 2022-Anwendungen (VSTA17).
.NET Framework 4.8 | Enthält die gemeinsamen Sprach-Laufzeit- und .NET Framework-Komponenten, die für die Ausführung von .NET Framework 4.8-Anwendungen erforderlich sind.
SWCEF | Chromium Embedded Framework (CEF) wird verwendet, um Inhalte der 3DEXPERIENCE Platform anzuzeigen.
Microsoft Edge Web View2 | Erforderlich, um Webinhalte anzuzeigen.
SOLIDWORKS Login Manager | Ermöglicht die Anmeldung beim 3DEXPERIENCE Marketplace und anderen 3DEXPERIENCE Apps.
Visual C++ Redistributable Package und .NET Framework 4.8 sind nicht nur für die SOLIDWORKS Kernprodukte, sondern für alle SOLIDWORKS Produkte erforderlich.

Diese Komponenten müssen in die Unterverzeichnisse des Administrator-Installationsabbild-Verzeichnisses mit einbezogen sein.

Die folgenden Tabellen listen die spezifischen Dateien auf, die für die unterstützten Betriebssysteme erforderlich sind.
Betriebssystem: Windows Server 2019 64-Bit und Windows Server 2022 64-Bit
Die Installation unter Windows Server 2019 und 2022 wird für SOLIDWORKS PDM Server und SOLIDWORKS SolidNetWork License Manager unterstützt.
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package: | vc_redist.x86.exe vc_redist.x64.exe Beide müssen installiert sein.
Visual Basic 7.1: | vba71.msi und vba71_1033.msi Mit optionalem Sprachpaket.
.NET Framework 4.8: | ndp48-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
Betriebssystem: Windows 10 oder Windows 11 (64 Bit)
Windows Performance Toolkit: | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package: | vc_redist.x86.exe vc_redist.x64.exe Beide müssen installiert sein.
Visual Basic 7.1: | vba71.msi und vba71_1033.msi Mit optionalem Sprachpaket.
.NET Framework 4.8: | .NET 4.8 ist Teil des Betriebssystems, das diese Anforderung erfüllt.
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

Inhaltsverzeichnis

  • Windows-Voraussetzungen von der Befehlszeile auf 64-Bit-Betriebssystemen installieren

    Sie können diese Anleitungen befolgen, um die Windows-Voraussetzungen für Administrator-Installationsabbilder mit der Befehlszeile unter 64-Bit-Versionen von Windows zu installieren.

Übergeordnetes Thema Befehlszeilenbereitstellung
Mit der Befehlszeile aus dem Administrator-Abbild installieren
Befehlszeileneigenschaften
Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren


Windows-Voraussetzungen von der Befehlszeile auf 64-Bit-Betriebssystemen installieren

Sie können diese Anleitungen befolgen, um die Windows-Voraussetzungen für Administrator-Installationsabbilder mit der Befehlszeile unter 64-Bit-Versionen von Windows zu installieren.

Um mehrere Komponenten in einer Installationsoperation zu installieren, erstellen Sie eine Stapeldatei mit den Befehlen, die in den folgenden Vorgehensweisen genannt werden und verwenden Sie sie, um die Komponenten den Client-Computern zuzuweisen.

  1. Stellen Sie sicher, dass der Ziel-Computer über mindestens 620 MB freien Speicherplatz und ein gültiges TEMP-Verzeichnis verfügt.
  2. Installieren Sie Visual C++ VERSION Redistributable Package. Sie müssen sowohl die 32-Bit- als auch die 64-Bit-Version der jeweiligen Pakete installieren.
    Installieren Sie das Paket für VERSION = 2022.

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. Installieren Sie Microsoft .NET Framework 4.8:
    Administrator-Installationsabbild-Verzeichnis\.Net_Framework_4.8\ndp48-x86-x64-allos-enu.exe
  4. Installieren Sie Visual Studio Tools for Applications 2022:
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. Installieren Sie Visual Basic 7.1:
    administrative_image_directory\Microsoft_VBA\vba71.msi und administrative_image_directory\Microsoft_VBA\vba71_1033.msi sind für alle Sprachen erforderlich.
    Nur die 64-Bit-Version dieses Pakets muss installiert werden.

    Installieren Sie außerdem das folgende Paket für die gewünschte Sprache:

    vba71_1028.msi | Chinesisch
    vba71_1031.msi | NewFeature1
    vba71_1036.msi | Französisch
    vba71_1040.msi | Italienisch
    vba71_1041.msi | NewFeature1
    vba71_1042.msi | Koreanisch
    vba71_1046.msi | Portugiesisch (Brasilianisch)
    vba71_2052.msi | Chinesisch - vereinfacht
    vba71_3082.msi | Spanisch
    Englisch, Tschechisch, Polnisch, Russisch und Türkisch erfordern keine zusätzlichen Sprachpakete.
  6. Installation von SOLIDWORKS Chromium Embedded Framework (SWCEF):
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. SOLIDWORKS Login Manager installieren:
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
Übergeordnetes Thema Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus


Mit der Befehlszeile aus dem Administrator-Abbild installieren

Sie können über die Befehlszeile Installationen von einem Administrator-Installationsabbild verwenden.

Still installieren:

  1. Öffnen Sie ein Eingabeaufforderungsfenster (klicken Sie in Windows auf Start > Ausführen).
  2. Geben Sie in das Fenster den Befehl msiexec.exe mit den Schaltern /i und /qb ein und geben Sie die Eigenschaften für alle Optionen, die keine Standardwerte sind, wie unten gezeigt an.

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

Die einzelnen Installations-Komponenten-Befehlszeilen-Eigenschaften sind:
  • Befehlszeilen-Feature-Eigenschaften
  • Befehlszeile - Globale Eigenschaften
  • eDrawings Befehlszeileneigenschaften
  • SOLIDWORKS Flow Simulation Befehlszeileneigenschaften

Verwenden Sie die folgenden Beispiele als Vorlagen für eine stille Installation.

SOLIDWORKS Client

  • SOLIDWORKS-Kernprodukt (Englisch)
  • Zusatzanwendung Toolbox
  • Teilnahme am Feedback-Programm
  • Sprache Französisch

SOLIDWORKS:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

Die SOLIDWORKS-Installationskomponente für Französisch muss separat installiert werden:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

Bei der Festlegung von SOLIDWORKS-Sprach-Komponenten-Installationsbefehlen dürfen keine Befehlszeilenargumente verwendet werden.

eDrawings Client

  • Alle Features

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

Aufgrund der technischen Komplexität der Installation von SOLIDWORKS Electrical mit Microsoft SQL Server sind in der Dokumentation keine Beispiel-Befehlszeilen für SOLIDWORKS Electrical enthalten.

SOLIDWORKS Visualize und Visualize Boost

Für SOLIDWORKS Visualize:

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

Für SOLIDWORKS Visualize:

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

Übergeordnetes Thema Befehlszeilenbereitstellung
Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus
Befehlszeileneigenschaften
Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren


Befehlszeileneigenschaften

Befehlszeileneigenschaften beschreiben hier die Feature-Eigenschaften, globalen Eigenschaften, produktspezifischen Eigenschaften und die Windows Konventionen in Bezug auf Standorte.

Inhaltsverzeichnis

  • Befehlszeilen-Feature-Eigenschaften

    Die SOLIDWORKS-Installation unterstützt diese ADDLOCAL-Eigenschaften für die Befehlszeilenanwendung.

  • Befehlszeile - Globale Eigenschaften

    Jede Eigenschaft gilt sowohl für eine Administrator- als auch eine Einzelinstallation, wenn nicht anders angegeben. Seriennummern können an Administrator-Installationen und an Einzelinstallationen unter Verwendung der globalen Eigenschaften übergeben werden.

  • eDrawings Befehlszeileneigenschaften

    Diese Befehlszeileneigenschaften sind spezifisch für eDrawings ®.

  • Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player

    Diese Befehlszeileneigenschaften gelten speziell für SOLIDWORKS Composer und SOLIDWORKS Composer Player.

  • SOLIDWORKS Flow Simulation Befehlszeileneigenschaften

    Diese Befehlszeileneigenschaften sind spezifisch für SOLIDWORKS Explorer Flow Simulation.

  • SOLIDWORKS Inspection Befehlszeileneigenschaften

    Diese Befehlszeileneigenschaften sind spezifisch für SOLIDWORKS Inspection.

  • SOLIDWORKS Visualize Befehlszeileneigenschaften

    Diese Befehlszeileneigenschaften sind für SOLIDWORKS Visualize spezifisch.

  • MSI Dateipositionen für Administrator-Installationsabbilder

    Um Administrator-Installationsabbilder von der Befehlszeile aus erstellen zu können, sind die .msi Dateien der Produktkomponente an folgenden Positionen auf dem SOLIDWORKS Medium abgelegt.

Übergeordnetes Thema Befehlszeilenbereitstellung
Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus
Mit der Befehlszeile aus dem Administrator-Abbild installieren
Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren


Befehlszeilen-Feature-Eigenschaften

Die SOLIDWORKS-Installation unterstützt diese ADDLOCAL-Eigenschaften für die Befehlszeilenanwendung.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorks Costing
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
Wenn Eigenschaften für die Befehlszeilen-Installation angegeben werden:
  • SOLIDWORKS unterstützt nicht die Produktinstallation unter Verwendung der Option ADDSOURCE.
  • Bei den Eigenschaften muss die Groß- und Kleinschreibung beachtet werden. Die Befehle dürfen keine Leerzeichen oder Bindestriche enthalten und müssen durch Kommas getrennt sein.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


Befehlszeile - Globale Eigenschaften

Jede Eigenschaft gilt sowohl für eine Administrator- als auch eine Einzelinstallation, wenn nicht anders angegeben. Seriennummern können an Administrator-Installationen und an Einzelinstallationen unter Verwendung der globalen Eigenschaften übergeben werden.

Eigenschaft | Beschreibung
ENABLEPERFORMANCE Legt fest, ob die Anwendung Leistungsdaten automatisch an die SOLIDWORKS Corporation senden soll.

1

Leistungsdaten senden.

0

Keine Leistungsdaten senden.
INSTALLDIR | Installationsordner für SOLIDWORKS.
MBDSERIALNUMBER | Seriennummer für das modellbasierte SOLIDWORKS Definitionsprodukt.
MOTIONSERIALNUMBER | Seriennummer für das SOLIDWORKS Motion Produkt.
OFFICEOPTION Festlegen des zu installierenden Produktpakets.
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL Geben Sie ALL an, um alle derzeit installierten Funktionen zu aktualisieren.
Geben Sie diese Eigenschaft nur an, wenn auf eine Service Pack-Version innerhalb einer vorhandenen Hauptversion aktualisiert wird (z. B. Aktualisierung einer vorhandenen SOLIDWORKS 2025 SP01 Installation auf SOLIDWORKS 2025 SP02).
REINSTALLMODE Microsoft Installationsprogramm-Neuinstallationsoptionen.

Beispiel: Wenn eine Installation von einer Service Pack-Version auf eine andere innerhalb derselben Hauptversion aktualisiert wird, müssen Sie REINSTALLMODE=vomus angeben.

Details zu den REINSTALLMODE-Einstellungen finden Sie in der Windows-Installationsprogramm-Dokumentation unter www.microsoft.com.

Geben Sie diese Eigenschaft nur an, wenn auf eine Service Pack-Version innerhalb einer vorhandenen Hauptversion aktualisiert wird (z. B. Aktualisierung einer vorhandenen SOLIDWORKS 2025 SP01 Installation auf SOLIDWORKS 2025 SP02). Geben Sie diese Eigenschaft nicht an, wenn Sie zum ersten Mal eine neue Hauptversion von SOLIDWORKS installieren.
SERVERLIST SolidNetWork Server-Liste.
Die SolidNetWork Serverliste ist eine kommagetrennte Liste von Zeichenketten. Jeder String bezieht sich auf eine Portnummer auf einem Server im Format:
  • Triade (kommagetrennt) =xxxxx@Servername1,yyyyy@Servername2,zzzzz@Servername3
  • Nichttriade (durch Semikolons getrennt) = xxxxx@Servername1;yyyyy@Servername2;zzzzz@Servername3
S und Y sind Einzelziffern. Setzen Sie kein Trennzeichen nach dem letzten in der Liste aufgeführten Server.
SIMULATIONSERIALNUMBER | Seriennummer für das SOLIDWORKS Simulation Produkt
SOLIDWORKSSERIALNUMBER | Seriennummer für das SOLIDWORKS Produkt, das alle Zusatzanwendungen enthält.
SWMIGRATE Zu aktualisierende SOLIDWORKS Version, wie diese in der Liste im Dialogfeld SOLIDWORKS Installationsauswahl angezeigt wird. Beispiel:

SWMIGRATE="SOLIDWORKS 2025 x64 Edition SP01"

Geben Sie diese Eigenschaft nur an, wenn Sie eine neue Hauptversion installieren und schon eine ältere Hauptversion installiert ist. Geben Sie diese Eigenschaft nicht an, wenn Sie von einer Service Pack-Version auf eine andere Version innerhalb derselben Hauptversion aktualisieren.
TOOLBOXFOLDER Installationsordner für SOLIDWORKS Toolbox Dateien.

Beispiel: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Wenn Ihre Umgebung über einen PDM oder freigegebenen Toolbox/Bohrungsassistent-Speicherort verfügt, können Sie eine Client-Installation so festlegen, dass Toolbox-Daten an diesem Speicherort nicht installiert oder aktualisiert werden. Verwenden Sie dazu die Eigenschaft NOTTOOLBOXSETUP. Geben Sie Folgendes an:

0 | Toolbox-Dateien werden installiert.
1 | Toolbox-Dateien werden nicht installiert.
TRANSFORMS Enthält sprachspezifische Elemente in der Form:
TRANSFORMS Zahl.mst
  • Chinese (1028)
  • Chinese-Simplified (2052)
  • Czech (1029)
  • English (1033)
  • French (1036)
  • German (1031)
  • Italian (1040)
  • Japanese (1041)
  • Korean (1042)
  • Polish (1045)
  • Portuguese-Brazilian (1046)
  • Russian (1049)
  • Spanish (1034)
  • Turkish (1055)
UPGRADESWINSTALL
Legt fest, ob eine bestehende SOLIDWORKS Version auf die aktuelle Version aufgerüstet werden soll.
0 | Neue Installation, nicht aktualisieren.
1 | Aktualisieren
Geben Sie diese Eigenschaft nur an, wenn Sie eine neue Hauptversion installieren und schon eine ältere Hauptversion installiert ist. Geben Sie diese Eigenschaft nicht an, wenn Sie innerhalb derselben Hauptversion von einer Service Pack-Version auf eine andere Version aktualisieren.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


eDrawings Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind spezifisch für eDrawings ®.

Eigenschaft | Beschreibung
ADDLOCAL Definiert die zu installierenden Komponenten der eDrawings Anwendung.
All ist die empfohlene Option.
Befehlszeilensyntax | Feature
All | Installiert alle Komponenten. Die eDrawings Anwendung sucht nach installierten SOLIDWORKS und AutoCAD Publisher Anwendungen, um die Installation zu bestätigen.
CALS | Öffnen von CAL-Dateien im eDrawings Viewer.
Inventor | Erstellen von eDrawings Dateien aus der Autodesk Inventor Anwendung.
eDrawingsViewer | Öffnen von eDrawings und anderer Dateien.
ProE | Öffnen von ProE-Dateien im eDrawings Viewer.
DXFDWGTranslator | Anzeige von DXF/DWG-Dateien im eDrawings Viewer.
Shortcuts | Installation von Desktop-Verknüpfungen.
XML3D | Öffnen von 3DXML-Dateien im eDrawings-Viewer.
INSTALLDIR | Legt den Installationsordner fest für eDrawings
SNLSERVER Geben Sie Anschluss@Servernamen für Ihren SolidNetWork License Server ein. Verwenden Sie Semikolons zum Trennen mehrerer Anschluss@Servernamen .

Ein Port-Servername für SNLSERVER und eine SERVERLIST sind nur für die SOLIDWORKS SNL-Serverkonfiguration erforderlich.

Die SolidNetWork Serverliste ist eine kommagetrennte Liste von Zeichenketten. Jeder String bezieht sich auf eine Portnummer auf einem Server im Format:
  • Triade (durch Komma getrennt)

    = xxxx@Servername1,yyyy@Servername2,zzzz@Servername3

  • Nicht Triade (durch Semikolon getrennt)

    = xxxx@Servername1,yyyy@Servername2,zzzz@Servername3

S und Y sind Einzelziffern. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player

Diese Befehlszeileneigenschaften gelten speziell für SOLIDWORKS Composer und SOLIDWORKS Composer Player.

Für SOLIDWORKS Composer:

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER | SOLIDWORKS Composer Seriennummer.
ACTIVSERIALNUMBERPLAYERPRO | Optional. SOLIDWORKS Composer Player Pro Seriennummer.
ADDLOCAL Optional. Wenn Sie die vollständige Anwendung installieren, brauchen Sie die Eigenschaft „ADDLOCAL“ nicht anzugeben.
Verwenden Sie „ADDLOCAL“ für eine benutzerdefinierte Installation mit den folgenden erforderlichen Elementen:
  • Lizenzierung
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • Plugins
  • SWComposerCommon
  • SWPlayer
Sie können „ADDLOCAL“ auch mit „Sync3Dvia“ verwenden, was jedoch nicht erforderlich ist.
INSTALLDIR | Legt den Installationsordner für die SOLIDWORKS Composer Software fest.

Für SOLIDWORKS Composer Player:

Eigenschaft | Beschreibung
ACTIVSERIALNUMBERPLAYERPRO | Optional. SOLIDWORKS Composer Player Pro Seriennummer.
INSTALLDIR | Legt den Installationsordner für die SOLIDWORKS Composer Player Software fest.
Bei Rechnern, auf denen SOLIDWORKS nicht installiert ist, müssen Sie SOLIDWORKS Translator zum Importieren von SOLIDWORKS Dateien in SOLIDWORKS Composer verwenden. Für die Bereitstellung von SOLIDWORKS Translator müssen Sie den SOLIDWORKS Installations-Manager verwenden. Die Befehlszeile kann nicht verwendet werden.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


SOLIDWORKS Flow Simulation Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind spezifisch für SOLIDWORKS Explorer Flow Simulation.

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER Separate SOLIDWORKS Flow Simulation Seriennummer

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
CWUPGRADEINSTALL Aktualisiert eine bestehende Version einer bestimmten SOLIDWORKS Flow Simulation Anwendungs-Software.
1 | Aktualisieren
2 | Neue Installation; Installation in ein neues Verzeichnis

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
INSTALLDIR Legt die Installation für eine bestimmte SOLIDWORKS Flow Simulation Anwendungs-Software fest.

(Nur Einzelinstallationen)
SERVERLISTE | Liste von Strings (Zeichenketten), die durch Semikolons getrennt sind. Jeder String bezieht sich auf eine Anschlussnummer auf dem Server im Format: xxxxx@Server_Name1; yyyyy@Server_Name2;& wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
SOLIDWORKSPATH Gibt den Installationsordner der SOLIDWORKS Software an.

(Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


SOLIDWORKS Inspection Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind spezifisch für SOLIDWORKS Inspection.

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER | SOLIDWORKS Inspection Seriennummer. (Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
INSTALLDIR | Bestimmt die Installation der SOLIDWORKS Inspection Anwendungssoftware. (Nur Einzelinstallationen)
SERVERLISTE | Liste von Strings (Zeichenketten), die durch Semikolons getrennt sind. Jeder String bezieht sich auf eine Anschlussnummer auf dem Server im Format: xxxxx@Server_Name1; yyyyy@Server_Name2;& wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


SOLIDWORKS Visualize Befehlszeileneigenschaften

Diese Befehlszeileneigenschaften sind für SOLIDWORKS Visualize spezifisch.

Eigenschaft | Beschreibung
ACTIVSERIALNUMBER | SOLIDWORKS Visualize Seriennummer (Einzelinstallationen und Client-Installationen von einem Administrator-Installationsabbild)
INSTALLDIR | Bestimmt die Installation der SOLIDWORKS Visualize Anwendungssoftware. (Nur Einzelinstallationen)
SERVERLISTE | Liste von Strings (Zeichenketten), die durch Semikolons getrennt sind. Jeder String bezieht sich auf eine Anschlussnummer auf dem Server im Format: xxxxx@Server_Name1; yyyyy@Server_Name2;& wobei x und y Einzelziffern sind. Setzen Sie kein Semikolon nach dem letzten aufgeführten Server in der Liste.
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
MSI Dateipositionen für Administrator-Installationsabbilder


MSI Dateipositionen für Administrator-Installationsabbilder

Um Administrator-Installationsabbilder von der Befehlszeile aus erstellen zu können, sind die .msi Dateien der Produktkomponente an folgenden Positionen auf dem SOLIDWORKS Medium abgelegt.

SOLIDWORKS (Kernprodukt, Englisch)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (Komponenten nicht auf Englisch)

Traditionelles Chinesisch | swwi\lang\chinese\chinese.msi
Vereinfachtes Chinesisch | swwi\lang\chinese-simplified\chinese-simplified.msi
Tschechisch | swwi\lang\czech\czech.msi
Französisch | swwi\lang\french\french.msi
Deutsch | swwi\lang\german\german.msi
Italienisch | swwi\lang\italian\italian.msi
Japanisch | swwi\lang\japanese\japanese.msi
Koreanisch | swwi\lang\korean\korean.msi
Polnisch | swwi\lang\polish\polish.msi
Portugiesisch (Brasilianisch) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
Russisch | swwi\lang\russian\russian.msi
Spanisch | swwi\lang\spanish\spanish.msi
Türkisch | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace für SOLIDWORKS

marketplace\3dexperience marketplace.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage Client

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM-Professional bietet eine API, aber sie ist nur für den Client und nicht in einer .msi- Datei verfügbar. Weitere Informationen finden Sie im API-Handbuch im SOLIDWORKS PDM-Client-Verzeichnis install\API.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
Übergeordnetes Thema Befehlszeileneigenschaften
Befehlszeilen-Feature-Eigenschaften
Befehlszeile - Globale Eigenschaften
eDrawings Befehlszeileneigenschaften
Befehlszeileneigenschaften in SOLIDWORKS Composer/Composer Player
SOLIDWORKS Flow Simulation Befehlszeileneigenschaften
SOLIDWORKS Inspection Befehlszeileneigenschaften
SOLIDWORKS Visualize Befehlszeileneigenschaften


Ein Administrator-Installationsabbild mit Microsoft Active Directory aktivieren

Die Bereitstellung über Microsoft Active Directory wird für die Bereitstellung der SOLIDWORKS Kernprodukte an Clients unterstützt.

Microsoft Active Directory ist ein Verzeichnisdienst zur Verwaltung von Clients und Servers in Netzwerkumgebungen. Es vereinfacht die Verwaltung, Migration und Aktivierung.

Informationen zum Installieren von SOLIDWORKS über Microsoft Active Directory erhalten Sie von Ihrem Fachhändler.

Übergeordnetes Thema Befehlszeilenbereitstellung
Vorbereitung von Clients für Befehlszeilen-Installation von einem Administrator-Installationsabbild aus
Mit der Befehlszeile aus dem Administrator-Abbild installieren
Befehlszeileneigenschaften


Verwaltung von mehreren Installationen

Für mehrere Installationen umfassen die Verwaltungsaufgaben die Aktualisierung der Administrator-Installationsabbilder auf die neuen Versionen, Anwendung der Service Pack Aktualisierungen und das Entfernen von Installationen.

Inhaltsverzeichnis

  • Administrator-Installationsabbilder auf neue Version aktualisieren

    Um Clients zu aktualisieren, die von einem Administrator-Installationsabbild aus installiert haben, muss zuerst das Administrator-Installationsabbild aktualisiert und dann müssen die Clients konfiguriert werden, damit sie sich auf die neue Kopie des Abbildes beziehen.

  • Administration von Service Pack-Produktaktualisierungen

    Service Pack-Produktaktualisierungen können Aktualisierungen für die Systemstabilität, Programmkompatibilität, Sicherheit etc. beinhalten.

  • Entfernen einer Installation

    Sie können eine Installation auf einem Einzel-Computer oder in einer Server/Client-Umgebung entfernen.

Übergeordnetes Thema Mehrere Installationen
Bereitstellung für mehrere Clients
Administrator-Installationsabbilder verwenden
Befehlszeilenbereitstellung


Administrator-Installationsabbilder auf neue Version aktualisieren

Um Clients zu aktualisieren, die von einem Administrator-Installationsabbild aus installiert haben, muss zuerst das Administrator-Installationsabbild aktualisiert und dann müssen die Clients konfiguriert werden, damit sie sich auf die neue Kopie des Abbildes beziehen.

Führen Sie den SOLIDWORKS Installations-Manager von der SOLIDWORKS Downoadseite aus, damit die korrekten Dateien referenziert werden.

Sobald Sie das Administrator-Installationsabbild aktualisiert haben (das eine neue Kopie des Abbilds erstellt), können Sie Clients aktualisieren, indem Sie eine Referenz auf die neue Kopie des Administrator-Installationsabbilds herstellen.

Wenn Clients über ein gemeinsames Verzeichnis auf die vorherige Version des Administrator-Installationsabbild verwiesen, konnten Sie dieses gemeinsame Verzeichnis mithilfe des Speicherorts des aktualisierten Administrator-Installationsabbilds neu festlegen.

Inhaltsverzeichnis

  • Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen

    Der SOLIDWORKS Installations-Manager kann erkennen, wenn Sie aktualisierte Dateien für die Aktualisierung eines Administrator-Installationsabbilds benötigen.

  • Aktualisieren eines Administrator-Installationsabbildes

    Um ein Administrator-Installationsabbild zu aktualisieren erstellt der SOLIDWORKS Installations-Manager ein neues Abbildverzeichnis. Sie weisen dann direkte Clients an, das neue Administrator-Installationsabbild-Verzeichnis für die Aktualisierung zu dieser Produktversion zu verwenden.

  • Aktualisierung von Clients von Administrator-Installationsabbildern

    Der SOLIDWORKS Installations-Manager kann Client-Computer, die von einem Administrator-Installationsabbild installiert wurden, automatisch aktualisieren.

Übergeordnetes Thema Verwaltung von mehreren Installationen
Administration von Service Pack-Produktaktualisierungen
Entfernen einer Installation


Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen

Der SOLIDWORKS Installations-Manager kann erkennen, wenn Sie aktualisierte Dateien für die Aktualisierung eines Administrator-Installationsabbilds benötigen.

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Wählen Sie im Bildschirm Willkommen die Option Administrator-Installationsabbild.
  3. Verifizieren Sie auf dem Bildschirm Seriennummer die SOLIDWORKS Seriennummer.
    Der SOLIDWORKS Installations-Manager prüft die SOLIDWORKS Website auf Ihre lizenzierten Produkte und die verfügbaren Service Packs.
  4. Wenn der Bildschirm Neuere Version verfügbar angezeigt wird, wählen Sie Ja, die neuere Version herunterladen und installieren: Version.
    Der SOLIDWORKS Installations-Manager startet eine neue Sitzung, um die neuere Version zu installieren.
  5. Sollte es ein Problem mit dem Download-Ordner geben, könnte Download-Optionen erscheinen. Nehmen Sie in diesem Fall das Standardverzeichnis für die neuen Installationsdateien an oder geben Sie einen neuen Verzeichnisnamen ein.
    Wenn eine Meldung eingeblendet wird, dass das Verzeichnis nicht existiert, klicken Sie auf Ja, um das Verzeichnis zu erstellen.
  6. Klicken Sie auf dem Bildschirm Download abgeschlossen auf Schließen, um das aktuelle Installationsprogramm zu schließen und das Installationsprogramm für die neue Version zu starten.
Übergeordnetes Thema Administrator-Installationsabbilder auf neue Version aktualisieren
Aktualisieren eines Administrator-Installationsabbildes
Aktualisierung von Clients von Administrator-Installationsabbildern


Aktualisieren eines Administrator-Installationsabbildes

Um ein Administrator-Installationsabbild zu aktualisieren erstellt der SOLIDWORKS Installations-Manager ein neues Abbildverzeichnis. Sie weisen dann direkte Clients an, das neue Administrator-Installationsabbild-Verzeichnis für die Aktualisierung zu dieser Produktversion zu verwenden.

Dieser Vorgang setzt voraus, dass Sie alle aktualisierten Installationsdateien für das Administrator-Installationsabbild heruntergeladen haben. Weitere Informationen finden Sie unter Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen.

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Wählen Sie im Bildschirm Willkommen die Option Administrator-Installationsabbild.
    Die Administrator-Installationsabbild-Optionen werden angezeigt.
    Option | Bezeichnung
    Neues Abbild mit Standardeinstellungen erstellen. | Erstellen Sie das Abbild unter Verwendung der Standardkonfigurationseinstellungen (d. h. nicht auf der Basis der Einstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort erstellt wurden).
    Neues Abbild mit Einstellungen und Dateien von einem bestehenden Abbild erstellen. | Erstellen Sie das Abbild unter Verwendung der Konfigurationseinstellungen, die für ein vorhandenes Administrator-Installationsabbild an Ihrem Standort festgelegt wurden. Klicken Sie auf Durchsuchen, um das Installationsverzeichnis für das vorhandene Administrator-Installationsabbild anzugeben.
  3. Verifizieren Sie auf dem Seriennummer-Bildschirm die Seriennummer.
  4. Stellen Sie auf dem Bildschirm Zusammenfassung (Bereit zur Erstellung des Abbilds) sicher, dass die Administrator-Installationsabbildoptionen korrekt sind.
    Details über individuelle Administrator-Installationsabbild- und Installationsoptionen erhalten Sie, wenn Sie auf ÄNDERN klicken, um zur Optionsseite zu gelangen, und dort auf Hilfe klicken.
  5. Um die neue Version des Administrator-Installationsabbilds zu erstellen, klicken Sie auf Jetzt erstellen.

Jetzt können Sie Clients auf diese neue Version des Administrator-Installationsabbilds aktualisieren. Einzelheiten dazu finden Sie unter Aktualisierung von Clients von Administrator-Installationsabbildern.

Übergeordnetes Thema Administrator-Installationsabbilder auf neue Version aktualisieren
Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen
Aktualisierung von Clients von Administrator-Installationsabbildern


Aktualisierung von Clients von Administrator-Installationsabbildern

Der SOLIDWORKS Installations-Manager kann Client-Computer, die von einem Administrator-Installationsabbild installiert wurden, automatisch aktualisieren.

Normalerweise sind Administrator-Installationsabbilder in Ordnern auf einem Server organisiert. Um die automatische Aktualisierung von Clients zu unterstützen, muss sich das Administrator-Installationsabbild in einem freigegebenen Ordner befinden.

Nach der Aktualisierung des Administrator-Installationsabbilds wird sich die Original-Installation in einem Ordner befinden und die aktualisierte Installation in einem anderen Ordner. Um die aktualisierte Installation zu verwenden, entfernen Sie die Freigabeoption vom Originalordner des Administrator-Installationsabbilds und fügen Sie dann die Freigabeoption zum aktualisierten Administrator-Installationsabbild hinzu.

Wenn SOLIDWORKS auf einem Client-Computer, der vom Original-Administrator-Installationsabbild installiert ist, gestartet wird, „sieht“ die Anwendung die neue Version und aktualisiert den Client.
Zudem werden andere von einem Administrator-Installationsabbild installierte Produkte automatisch aktualisiert, wenn SOLIDWORKS eine Aktualisierung auslöst.
Übergeordnetes Thema Administrator-Installationsabbilder auf neue Version aktualisieren
Aktualisierte Installationsdateien für Administrator-Installationsabbilder herunterladen
Aktualisieren eines Administrator-Installationsabbildes

Freigabeoption vom Original-Administrator-Installationsabbildordner entfernen

Bei der Aktualisierung eines Administrator-Installationsabbildes, auf den von einem freigegebenen Ordner aus zugegriffen wird, müssen Sie zunächst die Freigabeoption vom Originalordner des Administrator-Installationsabbilds entfernen.

  1. Wählen Sie den Ordner aus, in dem sich die Dateien des Administrator-Installationsabbilds befinden.
  2. Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Eigenschaften aus.
  3. Wählen Sie auf dem Register Freigeben und wählen Sie dann Diesen Ordner nicht freigeben, klicken Sie dann auf OK.

Fügen Sie jetzt die Freigabeoption dem aktualisierten Ordner des Administrator-Installationsabbilds wie in Freigabeoption zu einem Original-Administrator-Installationsabbildordner hinzufügen beschrieben hinzu.

Freigabeoption zu einem Original-Administrator-Installationsabbildordner hinzufügen

Sobald Sie einen aktualisierten Administrator-Installationsabbildordner erstellt und die Freigabe für den Original-Administrator-Installationsabbildordner deaktiviert haben, müssen Sie dem neuen Ordner die Freigabeoption hinzufügen, um das Administrator-Installationsabbild wieder zu aktivieren.

  1. Wählen Sie den Ordner aus, in dem sich die Dateien des aktualisierten Administrator-Installationsabbilds befinden.
  2. Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Eigenschaften aus.
  3. Definieren Sie auf der Registerkarte Freigabe die Freigabeeigenschaften für Ihr Unternehmen oder Ihre Gruppe, und ändern Sie den Freigabenamen in den Namen, der für die Original-Administrator-Installationsabbild-Ordner verwendet wird.
Computer, die vom ursprünglichen Administrator-Installationsimage-Freigabepfad aus installiert wurden, werden automatisch beim nächsten Start von SOLIDWORKS auf die neue Version aktualisiert.


Administration von Service Pack-Produktaktualisierungen

Service Pack-Produktaktualisierungen können Aktualisierungen für die Systemstabilität, Programmkompatibilität, Sicherheit etc. beinhalten.

Sie können Produktaktualisierungen auf zwei verschiedene Arten erhalten:
  • Über die Verwendung des SOLIDWORKS Installations-Managers für die Suche nach, den Download und die Installation von Aktualisierungen.

    Sie können den SOLIDWORKS Installations-Manager manuell initiieren oder einen Zeitplan für eine periodische Überprüfung nach Aktualisierungen festlegen.

  • Durch manuelles Downloaden der Service Packs von der SOLIDWORKS Support-Website.

    Service Packs werden als Patches auf die bestehende Software-Version angewendet. Zum Beispiel ist SOLIDWORKS 2025 SP1.0 ein Service Pack für SOLIDWORKS 2025 SP0.0, Sie können diese Service Packs mit dem SOLIDWORKS 2025 Installations-Manager installieren, nicht jedoch mit dem SOLIDWORKS Installations-Manager in SOLIDWORKS 2024,

    Hilfe zum Download und der Installation von Service Packs finden Sie in der Installationsdokumentation für die SOLIDWORKS Version, die Sie aktualisieren.

Inhaltsverzeichnis

  • Zurücksetzen von Service Packs in einem Administrator-Installationsabbild

    Sie können ein Administrator-Installationsabbild auf ein früher installiertes Service Pack zurücksetzen. Wenn Sie die SOLIDWORKS Software mit Datenträger installiert haben, benötigen Sie die Originaldatenträger, um auf ein Service Pack zurücksetzen zu können. Das frühere Administrator-Installationsabbild muss abgespeichert worden sein.

Übergeordnetes Thema Verwaltung von mehreren Installationen
Administrator-Installationsabbilder auf neue Version aktualisieren
Entfernen einer Installation


Zurücksetzen von Service Packs in einem Administrator-Installationsabbild

Sie können ein Administrator-Installationsabbild auf ein früher installiertes Service Pack zurücksetzen. Wenn Sie die SOLIDWORKS Software mit Datenträger installiert haben, benötigen Sie die Originaldatenträger, um auf ein Service Pack zurücksetzen zu können. Das frühere Administrator-Installationsabbild muss abgespeichert worden sein.

Administrator-Installationsabbilder, die aktualisiert wurden, können nicht auf ein früheres Service Pack zurückgesetzt werden. Administrator-Installationsabbilder, die mit einer anderen Methode als dem SOLIDWORKS Installations-Manager erstellt wurden, können nicht auf eine frühere Version zurückgesetzt werden. Clients, die von einem Administrator-Installationsabbild installiert wurden, müssen von einem Administrator-Installationsabbild einer früheren Version aus deinstalliert und wieder installiert werden.
  1. Löschen Sie den Ordner, der das aktuelle Administrator-Installationsabbild enthält. Öffnen Sie dazu das Fenster Eingabeaufforderung und geben Sie folgendes ein:
    rmdir /s/q Pfad_zu_aktuellem_Administrator_Installationsabbild
  2. Verschieben Sie die Sicherungskopie des Administrator-Installationsabbildes an den Ort, an dem Sie das aktuelle Administrator-Installationsabbild gelöscht haben. Öffnen Sie dazu das Fenster Eingabeaufforderung und geben Sie folgendes ein:
    move Pfad_zu_gesichertem_Administrator_Installationsabbild Pfad_zu_aktuellem_Administrator_Installationsabbild
    Nach der Zurücksetzung eines Administrator-Installationsabbildes werden Client-Computer automatisch beim nächsten Ausführen der SOLIDWORKS Software zurückgesetzt.
Übergeordnetes Thema Administration von Service Pack-Produktaktualisierungen


SOLIDWORKS PDM und SOLIDWORKS Manage

SOLIDWORKS PDM ist ein Produkt zur Dokumentenverwaltung, das auf der Client-/Server-Architektur basiert, die früher SOLIDWORKS Enterprise PDM genannt wurde. Es sind zwei Typen von SOLIDWORKS PDM verfügbar:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM verwendet eine Microsoft SQL Server-Datenbank für die Verwaltung von Dateitresoren.

In dieser Tabelle sind die Datenbanksysteme, die Serverkomponenten und die für jeden Produkttyp verfügbaren Client-Optionen aufgeführt.
 | PDM Standard | PDM Professional
Vorgesehen für | Kleine und mittlere Büronetzwerke, im Allgemeinen mit weniger als 20 gleichzeitigen Benutzern. | Große Büronetzwerke, große Anzahl gleichzeitiger Benutzer
Grenzwerte | Weniger als 1 Socket oder 4 Kerne, 1 GB RAM und Datenbankgröße von 10 GB | Beschränkungen bei SQL Standard: Weniger als 4 Sockets oder 16 Kerne, 128 GB RAM und Datenbankgröße von 524 PB
Datenbankverwaltungssystem | Microsoft SQL Server Express 2019 oder neuere Versionen bis 2022. | Microsoft SQL Server 2019 oder neuere Versionen bis 2022.
Erfordert SOLIDWORKS SolidNetWork License Manager? | Ja | Ja
Beinhaltet Archiv- und Datenbankserver? | Ja | Ja
Sind SOLIDWORKS PDM Web2-Server und WebAPI-Server einbezogen? | Nein | Ja
Client-Typen | Nativ | Nativ, browser-basiert
Client-Zusatzanwendungen für CAD-Editoren | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration
Client-Zusatzanwendungen für Beitragsleister | DraftSight | DraftSight, Microsoft Office-Integration
Client-Zusatzanwendungen für Viewer |  | Microsoft Office Integration

SOLIDWORKS Manage Professional bietet erweiterte Tools zur Datenverwaltung in SOLIDWORKS PDM Professional. Die Software umfasst Funktionen für die erweiterte Versionskontrolle und für die Verwaltung von Projekten, Prozessen und Elementen. Interaktive Dashboards und Berichte helfen Ihnen dabei, Elemente und Aktivitäten zu verfolgen und diese zum Abschluss von Projekten voranzubringen.

SOLIDWORKS Manage Professional hat eine ähnliche Architektur wie SOLIDWORKS PDM Professional. In der Software wird eine Client-Server-Architektur mit einer Microsoft SQL Server-Datenbank für die Verwaltung von Elementen und Projektdaten verwendet. Es gibt drei Services für Datenbank-, Dateiserver- und Webserver-Funktionen, die sowohl Thick Clients, als auch Browser-Clients unterstützen. Die drei Services können auf demselben oder auf unterschiedlichen Servern gehostet werden. Benutzer mit Lizenzen für SOLIDWORKS Manage Professional Editor können für den direkten Zugriff auf Daten in Manage von SOLIDWORKS aus eine SOLIDWORKS Zusatzanwendung verwenden.

Sie können den SOLIDWORKS Installation Manager verwenden, um den SOLIDWORKS Manage Professional Server und Client zu installieren.

Anweisungen zur Installation von SOLIDWORKS Manage Professional finden Sie in der SOLIDWORKS PDM/SOLIDWORKS Manage Installationsanleitung.

Inhaltsverzeichnis

  • Auflisten von PDM Serverkomponenten

  • Unterschiede zwischen PDM Clients

    Vor der Installation der Client-Software müssen Sie bestimmen, welche Clients je nach PDM-Umgebung erforderlich sind.

  • Vor der Installation von PDM Server

    Berücksichtigen Sie die folgenden Anforderungen vor der Installation von PDM Server Komponenten:

  • Installieren eines PDM Servers mit dem SOLIDWORKS Installations-Manager

    Bei der Installation des PDM Servers für PDM Standard können Sie den Archivserver, den Datenbankserver und den PDM CAD Editor Client auf demselben Computer installieren. Sie brauchen die Client-Installation nicht separat auszuführen.

  • Installieren des PDM Client mit SOLIDWORKS Installations-Manager


Auflisten von PDM Serverkomponenten

Diese Tabelle enthält eine Zusammenfassung der Serverkomponenten des SOLIDWORKS PDM Servers.

Server | Function | Installation
Microsoft SQL Server Express für PDM Standard | Verwaltet Daten in SOLIDWORKS PDM Datentresoren. | Kann mit PDM Standard installiert werden oder verwendet eine zuvor installierte und lizenzierte Version.
Microsoft SQL Server für PDM Professional | Verwaltet Daten in SOLIDWORKS PDM Datentresoren. | Erforderlich. Sie können auch eine zuvor installierte und lizenzierte Version verwenden.
SolidNetWork License Manager Client | Verwaltet SOLIDWORKS PDM Lizenzen. | Muss installiert sein, damit neue Tresore erstellt werden können. Kann bei Verwendung des SOLIDWORKS Installations-Managers mit SOLIDWORKS PDM Serverkomponenten installiert werden.
Archiv-Server | Verwaltet Übertragungen von Dateien zwischen Clients und dem Dateitresor-Archiv und verwaltet Benutzer und deren Anmeldeinformationen. | Erforderlich. Wird mit PDM Standard oder Professional installiert.
Datenbankserver | Fragt PDM Datenbanken nach Aktualisierungen ab, verwaltet Import- und Exportregeln für Daten, verwaltet das Nachrichtensystem und plant Replikation und Cold Storage. | Erforderlich. Wird mit PDM Standard oder Professional installiert.
Web2-Server | Bietet Zugriff auf Dateitresore über das Internet von browserbasierten Clients. | Optional. Wird nur mit PDM Professional installiert.
Web-API-Server | EXALEAD OnePart-Benutzer können mit einem Web-API-Server SOLIDWORKS PDM Daten indizieren und abrufen. | Optional. Wird nur mit PDM Professional installiert.

Archivserver werden als Dienste auf dem Systemkonto der Computer ausgeführt, auf denen sie installiert sind. Ein Archivserver kann mehrere Dateitresore auf demselben Computer hosten.

In einer eigenständigen Installation können der Archivserver, Datenbankserver und Lizenzserver sowie die SQL Express- oder SQL Server-Datenbank alle auf demselben Computer installiert werden.

In einer verteilten Umgebung können sich die Serverkomponenten auf unterschiedlichen Computern befinden. SOLIDWORKS PDM Professional unterstützt auch die Replikation von Dateitresorarchiven und der SQL-Serverdatenbank, um die Leistung an entfernten Standorten zu verbessern. Weitere Informationen finden Sie im SOLIDWORKS PDM Professional Replication Guide.

Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


Unterschiede zwischen PDM Clients

Vor der Installation der Client-Software müssen Sie bestimmen, welche Clients je nach PDM-Umgebung erforderlich sind.

Diese Tabelle enthält eine Zusammenfassung der Clients für SOLIDWORKS PDM Standard:
Standard Client-Typ | Beschreibung
CAD Editor | Unterstützt die Arbeit mit SOLIDWORKS-, DWG/DXF-Format-, Microsoft Word- und Microsoft Excel-Dateien. Alle Dateiformate, die von Microsoft Office Zusatzanwendungen unterstützt werden, verhalten sich auf die gleiche Weise in SOLIDWORKS PDM Standard, ausgenommen die Vorschau.
Beitragsleister | Unterstützt die Arbeit mit SOLIDWORKS-, DWG/DXF-Format-, Microsoft Word- und Microsoft Excel-Dateien.
Viewer | Ermöglicht den schreibgeschützten Zugriff auf Dateitresore. Benutzer können einen Übergang für Dateien durch einen Workflow durchführen. Die Benutzer können keine Dateien hinzufügen oder ändern (auschecken, einchecken, Werte aktualisieren).
Diese Tabelle enthält eine Zusammenfassung der Clients für SOLIDWORKS PDM Professional:
Professional Client-Typ | Beschreibung
CAD Editor & Web | Unterstützt die Arbeit mit allen Dateitypen, einschließlich der erweiterten Verwaltung und Vorschau von CAD-Formaten wie SOLIDWORKS. Mit CAD-Zusatzanwendungen können Benutzer über die CAD-Anwendung auf SOLIDWORKS PDM Professional zugreifen. Remote-Anwender können mithilfe von Web2-Clients Tresore durchsuchen und grundlegende Funktionen über das Internet ausführen.
Contributor & Web | Unterstützt die Arbeit mit allen Dateitypen, einschließlich CAD-Dateien. Die CAD-Zusatzanwendungen werden auf diesem Client-Typ jedoch nicht unterstützt. Remote-Anwender können mithilfe von Web2-Clients Tresore durchsuchen und grundlegende Funktionen über das Internet ausführen.
Viewer | Ermöglicht den schreibgeschützten Zugriff auf Dateitresore. Benutzer können einen Übergang für Dateien durch einen Workflow durchführen. Die Benutzer können keine Dateien hinzufügen oder ändern (auschecken, einchecken, Werte aktualisieren) und keine CAD-Zusatzanwendungen verwenden.
Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


Vor der Installation von PDM Server

Berücksichtigen Sie die folgenden Anforderungen vor der Installation von PDM Server Komponenten:

  • Besorgen Sie sich volle Administratorrechte für die Maschinen, auf denen Sie Server und Clients installieren wollen.
  • Stellen Sie sicher, dass der Datenbankserver über TCP-Port 3030 Zugriff auf den Archivserver und über TCP-Port 1433 Zugriff auf den SQL Server hat.
  • Wenn Sie eine bestehende SQL Server Express oder SQL Server Datenbank verwenden werden, besorgen Sie sich den Namen der SQL Server Datenbank und die Konto-ID und das Passwort eines SQL Server Administrators oder Datenbankbesitzers mit Lese-/Schreibzugriff auf die Datenbank. Der Benutzer TEW kann nicht verwendet werden.
  • Wenn auf dem System bereits ein PDM Client installiert ist, deinstallieren Sie ihn. Wenn Sie möchten, dass der PDM Server und der PDM Client auf demselben System installiert werden, können Sie beide von der Seite Server-Produkte im SOLIDWORKS Installations-Manager installieren.
Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


Installieren eines PDM Servers mit dem SOLIDWORKS Installations-Manager

Bei der Installation des PDM Servers für PDM Standard können Sie den Archivserver, den Datenbankserver und den PDM CAD Editor Client auf demselben Computer installieren. Sie brauchen die Client-Installation nicht separat auszuführen.

Bei der Installation des PDM-Servers für PDM Professional können Sie diese Komponenten sowie den Web2-Server und Web-API-Server einschließen.

So installieren Sie einen PDM Server und seine Komponenten:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Wählen Sie auf der Seite Willkommen die Option Serverkomponenten installieren aus und klicken Sie auf Folgendes:
    • SOLIDWORKS PDM Server Komponenten auf diesem Computer installieren.
    • SolidNetWork License Manager auf diesem Computer installieren.

      Wenn der SolidNetWork License Manager auf diesem oder einem anderen Computer installiert ist, wird diese Option nicht angezeigt.

  3. Wenn die Seite SolidNetwork License Manager-Optionen angezeigt wird, geben Sie eine Seriennummer ein, legen Sie einen Speicherort für das Verzeichnis fest und klicken Sie auf Weiter.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Klicken Sie auf der Seite Zusammenfassung für SOLIDWORKS PDM Server auf Ändern.
  6. Auf der Seite SOLIDWORKS PDM Server Optionen:
    1. Klicken Sie unter Serverprodukt auswählen auf SOLIDWORKS PDM Standard oder auf SOLIDWORKS PDM Professional.
    2. Klicken Sie bei Installationsort auf Durchsuchen, um einen Dateipfad anzugeben.
    3. In Features auswählen:
      1. Klicken Sie auf Archivserver, Datenbank-Server und Client, um diese Komponenten auf demselben Computer zu installieren. Wenn Sie sich in einer verteilten Umgebung befinden, können Sie den Archivserver und den Datenbankserver installieren, indem Sie den Installation Manager auf einem anderen Computer ausführen.
        • Wenn auf dem Computer bereits ein PDM Client installiert ist, müssen Sie die Installation abbrechen und den Client deinstallieren. Anschließend können Sie den SOLIDWORKS Installations-Manager ausführen, um den PDM Server zusammen mit dem Client zu installieren.
        • Die SOLIDWORKS PDM Client-Komponente, die in der SOLIDWORKS PDM Server-Installation enthalten ist, enthält den Artikel-Explorer, der nicht ausgeschlossen werden kann.
      2. Wenn Sie PDM Professional installieren, können Sie auch auf Web2-Server und Web-API-Server klicken.
        Wenn Sie den Web-API-Server installieren, können Sie für HTTP-Portnummer einen Wert zwischen 0 und 65535 angeben. Der Standardwert ist 65453.
    4. In SQL Server können Sie eine neue Instanz der Datenbankwerkzeuge installieren, die mit PDM Server geliefert werden (SQL Server Express für PDM Standard). Sie können auch den Datenbanknamen, den Benutzernamen und das Passwort einer vorhandenen Instanz angeben.
      Für SOLIDWORKS PDM Professional muss eine vollständige Version von SQL Server installiert werden.
    5. Klicken Sie auf Zurück zu Übersicht.
  7. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.

    Wenn die Installation im SOLIDWORKS Installation Manager abgeschlossen wurde, wird das Archivserver-Konfigurationswerkzeug gestartet. Folgen Sie den Anweisungen des Assistenten, um den Archivserver zu konfigurieren.

Informationen zum Einrichten und Konfigurieren des Archivservers, des Datenbankservers, des Web2-Servers und der SQL Server-Datenbanken sowie zur Problembehebung finden Sie in den entsprechenden Themen in der SOLIDWORKS PDM Installationsanleitung.

Inhaltsverzeichnis

  • Ändern einer SOLIDWORKS PDM Server-Installation

Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


Ändern einer SOLIDWORKS PDM Server-Installation

Das Ändern der Installation von SOLIDWORKS PDM Server und seiner Komponenten ist nur über Programme und Funktionen in der Windows Systemsteuerung möglich. Sie können die Installation nicht mithilfe des SOLIDWORKS Installations-Managers (SLDIM) ändern, auch wenn Sie diesen zur Installation von SOLIDWORKS PDM Server verwendet haben.

Übergeordnetes Thema Installieren eines PDM Servers mit dem SOLIDWORKS Installations-Manager


Installieren des PDM Client mit SOLIDWORKS Installations-Manager

Die Hauptversion von SOLIDWORKS PDM Client muss mit der Hauptversion von SOLIDWORKS PDM Server übereinstimmen. Wenn Sie SOLIDWORKS PDM Client installieren oder aktualisieren, stellen Sie sicher, dass die Versionen übereinstimmen.

So installieren Sie einen Lizenz-Client:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Wählen Sie auf der Seite Willkommen die Option Auf diesem Computer installieren aus.
  3. Auf der Seite Seriennummer klicken Sie auf Weiter.
    SOLIDWORKS PDM Clients erfordern keine separate Seriennummer.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Auf der Seite Zusammenfassung unter „Produkte“ klicken Sie auf Ändern.
  6. Auf der Seite Produktauswahl klicken Sie auf Andere Pakete oder Produkte auswählen.
  7. Im Dialogfeld Das anzuzeigende Paket auswählen wählen Sie eine Edition von SOLIDWORKS aus. Klicken Sie auf OK.
  8. Auf der Seite Produktauswahl wählen Sie SOLIDWORKS PDM Client. Wählen Sie dann eDrawings aus, um die PDM Vorschaufunktion zu aktivieren. Wenn Sie SOLIDWORKS PDM Professional verwenden, können Sie auch den Artikel-Explorer auswählen.
  9. Erweitern Sie auf der Seite ZusammenfassungSOLIDWORKS PDM Optionen und klicken Sie auf Ändern.
  10. Wählen Sie auf der Seite SOLIDWORKS PDM Client Optionen Folgendes aus und klicken Sie auf Zurück zur Übersicht:
    • PDM-Produkttyp
    • PDM Clienttyp
    • Zusatzanwendungen
  11. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.
Administratoren können auch den Options-Editor des Administrations-Abbilds verwenden, um Abbilder von PDM Clients zu erstellen und bereitzustellen. Einzelheiten finden Sie unter Administrator-Installationsabbilder verwenden.
Übergeordnetes Thema SOLIDWORKS PDM und SOLIDWORKS Manage


SOLIDWORKS Electrical

Mit dem SOLIDWORKS Installations-Manager können Sie alle Komponenten von SOLIDWORKS Electrical in einem eigenständigen oder Client/Server-Modus installieren.

SOLIDWORKS Electrical verwendet mehrere Komponenten. Während der Installation müssen Sie diese Komponenten entsprechend dem gewünschten Installationstyp auswählen.
  • SOLIDWORKS Electrical Schematic - 2D-Anwendung zum Erstellen und Verwalten elektrischer Stromlaufpläne.
  • SOLIDWORKS Electrical 3D - SOLIDWORKS Zusatzanwendung zur Integration von 2D-Stromlaufplänen in 3D-Modelle. Mit SOLIDWORKS Electrical 3D können Sie das Layout elektrischer Geräte verwalten und die Drähte, Kabel und Kabelbäume routen.
  • Data - Unter „Data“ werden alle Daten zusammengefasst, die von der Software benötigt werden. Diese Daten sind grafischer (z. B. Dateien, die die Symbole und Titelblöcke darstellen) oder technischer Natur (z. B. Herstellerkataloge und mit den Symbolen verbundene Daten). Sie können die Daten freigeben, um sie für alle Benutzer zugänglich zu machen.
  • Collaborative Server - Ein Dienstprogramm zum Öffnen und Aktualisieren von elektrischen Zeichnungen.
  • SQL Server - SOLIDWORKS Electrical erfordert eine Microsoft SQL Server-Datenbank. Sie können während der Installation eine neue Datenbank erstellen oder eine vorhandene Datenbank verwenden.

Installationstyp

Sie können alle SOLIDWORKS Electrical Komponenten auf demselben Computer installieren. Dies ist eine eigenständige Installation. Alle Programmdaten, wie z. B. Projektzeichnungen und Berichte, sind auf der Workstation gespeichert.

Die SOLIDWORKS Electrical Komponenten können auch als Client-/Serveranwendung installiert werden. Verwenden Sie diesen Installationstyp, wenn Sie die Daten auf einem Netzwerkserver speichern möchten. Bei der Client/Serverinstallation können mehrere Benutzer an demselben Projekt arbeiten. Client-Systeme müssen Netzwerkzugriff auf den Server und Schreib-/Leseberechtigungen zum Erstellen von Projekten, Bibliotheken und Symbolen haben.

Informationen

Unabhängig von dem Installationstyp (eigenständig oder Client/Server) müssen Sie Ihre Windows-Sitzung im Vollzugriffsmodus starten, um SOLIDWORKS Electrical zu installieren.

Sie können nur eine Version von SOLIDWORKS Electrical auf einem Computer installieren. Wenn Sie SOLIDWORKS installieren und SOLIDWORKS Electrical als eines der zu installierenden Produkte auswählen, entfernt das Installationsprogramm die alte Version von SOLIDWORKS Electrical.

Wenn Sie den SOLIDWORKS Installations-Manager starten, erkennt er automatisch die vorhandenen Versionen von SOLIDWORKS Electrical, die auf der Workstation oder auf dem Server installiert sind.

Sichern Sie immer Ihre bestehende SOLIDWORKS Electrical Umgebung, bevor Sie eine neue Version installieren. Wählen Sie in SOLIDWORKS Electrical Schematic Datei > Anwendungsumgebung archivieren oder in SOLIDWORKS Electrical 3D SOLIDWORKS Electrical > Extras > Anwendungsumgebung archivieren aus.

Inhaltsverzeichnis

  • Anforderungen zum Installieren von SOLIDWORKS Electrical

  • Eigenständige oder Client/Server-Installation

    Sie können SOLIDWORKS Electrical in zwei Modi installieren. Im eigenständigen Modus installieren Sie die Software auf der Workstation. Im Client-/Servermodus teilen sich die Benutzer die Daten.

  • Konfigurieren des Collaborative Server

  • Konfigurieren von Microsoft SQL Server

  • Festlegen der Datenposition


Anforderungen zum Installieren von SOLIDWORKS Electrical

Die aktuellen Systemanforderungen finden Sie unter Systemanforderungen.

Übergeordnetes Thema SOLIDWORKS Electrical
Eigenständige oder Client/Server-Installation
Konfigurieren des Collaborative Server
Konfigurieren von Microsoft SQL Server
Festlegen der Datenposition


Eigenständige oder Client/Server-Installation

Sie können SOLIDWORKS Electrical in zwei Modi installieren. Im eigenständigen Modus installieren Sie die Software auf der Workstation. Im Client-/Servermodus teilen sich die Benutzer die Daten.

SOLIDWORKS Electrical muss immer eine Verbindung zu einer Instanz von SQL Server herstellen.

Übergeordnetes Thema SOLIDWORKS Electrical
Anforderungen zum Installieren von SOLIDWORKS Electrical
Konfigurieren des Collaborative Server
Konfigurieren von Microsoft SQL Server
Festlegen der Datenposition

Stand-Alone Installation

Bei der ersten Installation MÜSSEN Sie alle Komponenten auf der Workstation installieren.

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • Anwendungsdaten
  1. Klicken Sie auf der Registerkarte Zusammenfassung im Abschnitt Produktauswahl auf Ändern und wählen Sie alle Komponenten von SOLIDWORKS Electrical aus.
  2. Wenn Sie die Installationsoptionen ändern möchten, klicken Sie auf der Registerkarte Zusammenfassung im Abschnitt Optionen für Electrical auf Ändern. Es ist möglich, eine neue Instanz von SQL Server zu erstellen oder eine vorhandene zu verwenden. Weitere Informationen finden Sie in den entsprechenden Kapiteln zu Daten und Microsoft SQL Server in dieser Dokumentation. Verwenden Sie im Zweifelsfall die Standardoptionen.
  3. Klicken Sie zum Fortfahren auf Jetzt installieren.
Wenn SOLIDWORKS Electrical bereits auf der Workstation installiert ist, wird das Programm vom SOLIDWORKS Installations-Manager automatisch gefunden und Sie werden aufgefordert, es zu aktualisieren. Installieren Sie alle Komponenten, ohne die Optionen für Electrical zu ändern.

Client-/Serverinstallation

Bei einer Client-/Serverinstallation können Sie die Daten für mehrere Benutzer freigeben.

Auf dem Server müssen Sie die folgenden Komponenten installieren:
  • Collaborative Server
  • Anwendungsdaten
  • SQL Server
Auf den Clients müssen Sie die folgenden Komponenten installieren:
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. Installieren Sie auf dem Server die Serverkomponenten.
  2. Klicken Sie auf der Registerkarte Willkommen beim SOLIDWORKS Installations-Manager auf Serverkomponente installieren.
  3. Wählen Sie die Option SOLIDWORKS Electrical aus.
  4. Auf der Registerkarte Zusammenfassung können Sie die Installationsoptionen ändern. Weitere Informationen finden Sie in den entsprechenden Kapiteln zu Daten und Microsoft SQL Server in dieser Dokumentation. Verwenden Sie im Zweifelsfall die Standardoptionen.
  5. Klicken Sie zum Fortfahren auf Jetzt installieren.
  6. Installieren Sie auf den Clients die Anwendungen.
  7. Klicken Sie auf der Registerkarte Willkommen beim SOLIDWORKS Installations-Manager auf Auf diesem Computer installieren.
  8. Klicken Sie auf der Registerkarte Zusammenfassung im Abschnitt Produktauswahl auf Ändern und deaktivieren Sie die Option Electrical Server.
  9. Klicken Sie auf der Registerkarte Zusammenfassung im Abschnitt Optionen für Electrical auf Ändern und ändern Sie die Einstellungen, um eine Verbindung zum Server herzustellen.
  10. Klicken Sie zum Fortfahren auf Jetzt installieren.
Wenn SOLIDWORKS Electrical bereits auf der Workstation oder auf dem Server installiert ist, wird das Programm vom SOLIDWORKS Installations-Manager automatisch gefunden und Sie werden aufgefordert, es zu aktualisieren. Verwenden Sie denselben Vorgang wie bei der ersten Installation, um die Software zu aktualisieren.


Konfigurieren des Collaborative Server

Collaborative Server ist ein Windows-Dienst, der fortwährend ausgeführt werden muss und eine konstante, ununterbrochene, bidirektionale Kommunikation mit Clients durch Firewalls und Virenscanner aufrechterhalten muss.

Um Collaborative Server entweder im Einzel- oder im Servermodus zu konfigurieren, müssen Sie die folgenden Parameter festlegen:
  • Der Computer-Name (z. B. LOCALHOST oder MyMachine) oder seine IP-Adresse (z. B. 127.0.0.1 oder 192.168.999.999).
  • Die Portnummer (standardmäßig 26666).

Sie können Collaborative Server während der Installation oder später über Extras > Anwendungseinstellungen konfigurieren.

Um eine ununterbrochene bidirektionale Kommunikation zu gewährleisten, überprüfen Sie, ob die Portnummern 26666 bis 26676 (wenn 10 Benutzer gleichzeitig verbunden sind) auf dem System verfügbar sind, auf dem Collaborative Server installiert ist. Wenn nicht, bitten Sie den Systemadministrator, einen anderen Port für SOLIDWORKS Electrical zu suchen.

Übergeordnetes Thema SOLIDWORKS Electrical
Anforderungen zum Installieren von SOLIDWORKS Electrical
Eigenständige oder Client/Server-Installation
Konfigurieren von Microsoft SQL Server
Festlegen der Datenposition


Konfigurieren von Microsoft SQL Server

Stellen Sie sicher, dass für alle Installationen von SOLIDWORKS Electrical eine Instanz der SQL Server-Datenbank zur Verfügung steht. Es kann eine vorhandene, bereits auf dem System installierte SQL Server-Datenbank verwendet werden oder Sie können im Rahmen der Installation von SOLIDWORKS Electrical eine neue Instanz installieren.

Wenn Sie eine neue Instanz von SQL Server installieren, bietet die SOLIDWORKS Installation eine kostenlose Version von Microsoft SQL Express 2022. Diese Version ist auf 1 CPU, 1 GB Speicher und 10 GB Daten beschränkt. Speicher und CPU sind für 10 gleichzeitige Benutzer ausreichend.

Wenn Sie SQL Server Express 2022 installieren, überprüfen Sie, ob Serversoftware und -hardware die unter Systemanforderungen aufgeführten Anforderungen erfüllen.

Wenn es mehr als 10 gleichzeitige Benutzer auf demselben Server gibt, sollten Sie eine Vollversion von SQL Server erwerben und installieren. Verwenden Sie den für die Installation von SOLIDWORKS Electrical mit einer vorhandenen Instanz von SQL Server beschriebenen Workflow.

Informationen zu SQL Server Express 2022 finden Sie in der Dokumentation zu Microsoft SQL Server.

Übergeordnetes Thema SOLIDWORKS Electrical
Anforderungen zum Installieren von SOLIDWORKS Electrical
Eigenständige oder Client/Server-Installation
Konfigurieren des Collaborative Server
Festlegen der Datenposition

Verwalten von Daten in SOLIDWORKS Electrical

Viele Programme verwenden eine einzelne Datenbank, die alle Programmdaten enthält. Dies ist bei SOLIDWORKS Electrical nicht der Fall. Jedem Projekt in SOLIDWORKS Electrical wird eine eindeutige ID-Nummer zugewiesen, und jedes Projekt hat eine verwandte Datenbank, die anhand der eindeutigen ID-Nummer identifiziert werden kann. Wenn beispielsweise im Projekt-Manager für SOLIDWORKS Electrical ein Projekt mit ID#112 vorliegt, lautet der Name der zugeordneten Datenbank “tew_project_data_112”.

Der Vorteil einer eindeutigen Datenbank für jedes Projekt liegt darin, dass die Verarbeitungszeit drastisch verringert wird. Darüber hinaus ist im Fall eines kritischen Datenbankfehlers nur ein Projekt betroffen, sodass die Integrität der meisten Programminformationen bewahrt wird.

Einige Unternehmen haben aber Richtlinien, die die Erstellung neuer Datenbanken einschränken. Bei der Ausführung von SOLIDWORKS Electrical darf es keine Einschränkungen für das Erstellen neuer Datenbanken durch Benutzer geben. Erkundigen Sie sich beim System- oder der Datenbankadministrator, ob Konfigurationseinstellungen vorhanden sind, durch die Benutzer am Erstellen neuer Datenbanken gehindert werden.

Neue Instanzen von SQL Server

Um eine neue Instanz von SQL Server zu installieren, benötigen Sie volle Administratorrechte für den Server und für alle Client-Systeme. Sie müssen auch sicherstellen, dass Clients Schreib-/Leseberechtigungen für die Datenbank haben, damit Projekte, Bibliotheken, Symbole und andere Projektdaten erstellt und geändert werden können.

Wenn Sie eine neue Instanz von SQL Server installieren, müssen Sie den Standardnamen ändern.

Vorhandene Instanzen von SQL Server

Sie benötigen ein Benutzerkonto mit vollen Administratorrechten für die SQL Server-Datenbank, um neue SOLIDWORKS Electrical Datenbanken zu installieren oder eine Verbindung zu einer SOLIDWORKS Electrical Installation auf einer vorhandenen Instanz von SQL Server herzustellen.

Sie müssen SQL Server für die Authentifizierung im gemischten Modus aktivieren, damit SOLIDWORKS Electrical richtig funktioniert. Die Authentifizierung im gemischten Modus ermöglicht die Verwendung von Windows- oder SQL Server-Anmeldeinformationen.

Um eine Verbindung zu einer vorhandenen SQL Server-Datenbank herzustellen, können Sie die Windows- oder die SQL Server-Authentifizierung verwenden. Geben Sie einen Benutzernamen und ein Passwort für eine Windows- oder SQL Server-Anmeldung ein, die über die vollen Administratorrechte für SQL Server verfügt.

Sie können bei der Installation für eine Verbindung zu SQL Server nicht den „TEW“-Benutzer verwenden. Kontaktieren Sie Ihren SQL Server-Administrator oder Systemadministrator, um die richtigen Anmeldeinformationen für SQL Server zu erhalten.

SOLIDWORKS Electrical Datenbanken

Nach der Installation von SOLIDWORKS Electrical erstellt das Installationsprogramm die folgenden Datenbanken in der SQL Server-Instanz.

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


Festlegen der Datenposition

Wählen Sie für die Datenposition ein Verzeichnis zum Speichern von Programmdaten wie Teile, Vorlagen und 2D- bzw. 3D-Symbole aus. Diese Position muss ein dediziertes Verzeichnis sein. Es darf sich nicht um ein Stammverzeichnis oder dasselbe Verzeichnis handeln, in dem die SOLIDWORKS Daten gespeichert werden.

Das Standardverzeichnis lautet C:\ProgramData\SOLIDWORKS Electrical.

Bei einer Client-/Serverinstallation müssen Sie das Datenverzeichnis freigeben.

Das Installationsprogramm erstellt im Standardverzeichnis einen neuen Ordner namens Update, in dem alle neuen Daten gespeichert werden.

Wenn Sie SOLIDWORKS Electrical zum ersten Mal starten, führt das Programm die im Ordner Update gespeicherten Daten automatisch mit den vorhandenen Daten zusammen. In dem Assistenten Datenaktualisierung können Sie die Daten auswählen, die der Anwendung und der SQL Server-Datenbank hinzugefügt werden sollen.

Übergeordnetes Thema SOLIDWORKS Electrical
Anforderungen zum Installieren von SOLIDWORKS Electrical
Eigenständige oder Client/Server-Installation
Konfigurieren des Collaborative Server
Konfigurieren von Microsoft SQL Server


SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize bietet eine Suite aus eigenständigen Werkzeugen, die branchenführende Rendering-Kapazitäten mit designorientierten Funktionen und Workflows verbinden, damit Sie äußerst realistische Bilder von 3D-CAD-Modellen erstellen können.

SOLIDWORKS Visualize Produkte sind in zwei Paketen verfügbar:
  • Standard
  • Professional

Eine kostenlose Version von SOLIDWORKS Visualize Standard ist in jeder Lizenz von SOLIDWORKS Professional und Premium bei aktivem Abonnement enthalten. Für SOLIDWORKS Kunden mit eigenständiger Aktivierung benötigen Sie eine zusätzliche Seriennummer. Wenden Sie sich an Ihren SOLIDWORKS Administrator oder Fachhändler, wenn Sie Ihre SOLIDWORKS Visualize Seriennummer nicht kennen.

SOLIDWORKS Visualize unterstützt auch SolidNetWork Licensing (SNL)-Lizenztypen wie Netzwerklizenzen sowie die Offline-Aktivierung.

Mit dem SOLIDWORKS Installations-Manager (SLDIM) können Sie SOLIDWORKS Visualize im Rahmen der Einzelinstallation (Auf diesem Computer installieren) installieren. Sie können es als eigenständige Anwendung installieren. Dies ist von Vorteil, wenn Sie separate Computer für Modellierung und Rendering nutzen möchten. Es verbraucht keine SOLIDWORKS Lizenz.

SOLIDWORKS Visualize Boost ist ein Dienst, der Ihnen ermöglicht, Rendering von einem Computer, auf dem SOLIDWORKS Visualize Professional ausgeführt wird, auf mehrere Computer im Netzwerk zu verteilen. Sie können andere Aufgaben auf Ihrem Computer ausführen, während das gerenderte Bild erzeugt wird, und die endgültigen gerenderten Bilder werden schneller verfügbar gemacht. Sie können auch Visualize Boost als Teil der Einzelinstallation (Auf diesem Computer installieren) im SOLIDWORKS Installations-Manager installieren.

Eine kostenlose Version von SOLIDWORKS Visualize Boost ist in jeder Lizenz von SOLIDWORKS Visualize Professional bei aktivem Abonnement enthalten.
Visualize Boost ist ein Produkt-Add-on nur für Visualize Professional. Mit Visualize Standard funktioniert Visualize Boost nicht.

Inhaltsverzeichnis

  • Systemanforderungen für SOLIDWORKS Visualize

  • Installieren von SOLIDWORKS Visualize mit dem SOLIDWORKS Installations-Manager

  • Installieren von Visualize Boost mit dem SOLIDWORKS Installations-Manager.


Systemanforderungen für SOLIDWORKS Visualize

Um eine optimale Leistung und Einrichtung von SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost zu gewährleisten, befolgen Sie vor der Installation die folgenden Richtlinien:
  • Stellen Sie sicher, dass Sie für jedes Produkt eine separate Seriennummer haben, bevor Sie SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost installieren.
  • Stellen Sie sicher, dass jeder Computer, auf dem SOLIDWORKS Visualize oder SOLIDWORKS Visualize Boost ausgeführt wird, die unter Systemanforderungen aufgeführten Anforderungen erfüllt.
  • Installieren Sie die SOLIDWORKS Visualize Boost Anwendung auf dedizierten Rendering-Computern innerhalb desselben Netzwerks. Diese Computer sollten sich von denen unterscheiden, auf denen SOLIDWORKS Visualize Professional ausgeführt wird, um Rendering-Aufgaben auszulagern.
  • Wenn kein geeigneter Grafikprozessor gefunden wird, verwenden sowohl SOLIDWORKS Visualize als auch SOLIDWORKS Visualize Boost stattdessen den zentralen Prozessor (CPU). Weitere Informationen zu bestimmten Grafikkarten und Treibern finden Sie unter SOLIDWORKS Hardware-Zertifizierung.

Für GPU-Unterstützung mit 3DS Stellar Physically Correct

Stellar Genauer Rendering-Modus:
  • NVIDIA-Grafikkarte, die mindestens auf der Maxwell-Mikroarchitektur basiert
  • Empfohlene Treiberversion 538.78 mit Unterstützung für CUDA 12.2.
  • Mindestens 4 GB Videospeicher
Stellar Schneller Rendering-Modus:
  • NVIDIA-Grafikkarte, die mindestens auf der Turing-Mikroarchitektur (mit RT-Kernen) basiert
  • Verwendet die gleiche Treiberversion und den gleichen Speicherbedarf wie der Modus Genau

Für GPU-Unterstützung mit AMD ProRender

AMD ProRender Rendering-Modi Schnell und Genau:
  • Eine GPU und ein Treiber, die den Vulkan-Standard unterstützen
Übergeordnetes Thema SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost


Installieren von SOLIDWORKS Visualize mit dem SOLIDWORKS Installations-Manager

So installieren Sie SOLIDWORKS Visualize:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Wählen Sie auf der Seite Willkommen die Option Auf diesem Computer installieren aus.
  3. Führen Sie die folgenden Schritte durch:
    1. Auf der Seite Seriennummer erweitern Sie Visualisierung.
    2. Wählen Sie SOLIDWORKS Visualize aus und geben Sie die Seriennummer ein.
    3. Klicken Sie auf Weiter.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.
Befolgen Sie die Anweisungen im Produktaktivierungsassistenten, um Ihr Produkt zu aktivieren.

Klicken Sie nach der Aktivierung doppelt auf das SOLIDWORKS Visualize Verknüpfungssymbol auf dem Desktop, um die Anwendung zu starten, oder klicken Sie im Windows-Menü Start auf SOLIDWORKS Version > SOLIDWORKS Visualize Version.

Inhaltsverzeichnis

  • Aufgaben nach der Installation

Übergeordnetes Thema SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost


Aufgaben nach der Installation

Nach der Installation müssen einige Aufgaben zur Konfiguration von SOLIDWORKS Visualize ausgeführt werden.

Weitere Informationen finden Sie unter Erste Schritte mit SOLIDWORKS Visualize in der SOLIDWORKS Visualize-Hilfe.

Inhaltsverzeichnis

  • Erstellen des Inhaltsordners

  • Zugriff auf die Hilfe, Lehrbücher, Systeminformationen und Lizenzen

Übergeordnetes Thema Installieren von SOLIDWORKS Visualize mit dem SOLIDWORKS Installations-Manager


Erstellen des Inhaltsordners

Wenn Sie die Software zum ersten Mal auszuführen, fragt SOLIDWORKS Visualize Sie nach einem Speicherort, um einen Ordner Inhalt zu erstellen.

Der Ordner Inhalt enthält folgende Unterordner, wo Sie Ressourcen für Ihre Projekte speichern können:
Unterordner | Speichert
Kameras | Standardmäßige Kameras und Kameras, die Sie gespeichert haben
Umgebungen | HDR-Bilder (High Dynamic Range)
Paletten | Hintergrundbilder
Bilder | Renderings und Schnappschüsse
Erscheinungsbilder | Materialien in Ihrer Erscheinungsbild-Bibliothek Der Inhalt wird aktualisiert, wenn Sie ein Erscheinungsbild zur Bibliothek hinzufügen.
Modelle | Modelldateien Standardmäßig sucht SOLIDWORKS Visualize diesen Ordner zuerst, wenn Sie Datei > Importieren für ein Modell verwenden.
Platten | Standardmäßige 2D-Bilder zur Verwendung in Hintergrundbildern
Projekte | Native Projektdateien im Format .SVPJ
Texturen | 2D-Texturen zur Verwendung in Erscheinungsbildern
Übergeordnetes Thema Aufgaben nach der Installation


Zugriff auf die Hilfe, Lehrbücher, Systeminformationen und Lizenzen

Das Menü „Hilfe“ enthält Dokumentationen und Optionen zur Aktualisierung der Software sowie zur Fehlerbehebung in Ihrem System.

Visualize Hilfe | Öffnet die SOLIDWORKS Visualize Online-Hilfe.
Visualize Lehrbücher | Öffnet MySolidWorks für den Zugriff auf die SOLIDWORKS Visualize Lehrbücher.
Versionshinweise | Zeigt Online-Versionshinweise für die aktuelle Version an.
Neue Funktionen | Zeigt die neuen Funktionen für SOLIDWORKS Produkte an.
Systeminformationen | Führt eine Systemprüfung für die SOLIDWORKS Visualize Software mit Ihrer PC-Hardware durch und schlägt bei Bedarf Upgrades vor.
Nach Aktualisierungen suchen | Prüft den Server auf die neueste SOLIDWORKS Visualize Aktualisierung.
Lizenz aktivieren | (Arbeitsplatzgebundene Lizenzen) Verwendet den SOLIDWORKS Produktaktivierungsassistenten zur Aktivierung des Produkts.
Lizenz deaktivieren | (Arbeitsplatzgebundene Lizenzen) Verwendet den SOLIDWORKS Produktaktivierungsassistenten zur Deaktivierung des Produkts.
SolidNetWork License Manager | Verwendet den SOLIDWORKS Produktaktivierungsassistenten zur Deaktivierung des Produkts.
Visualize Info | Zeigt die Versionsnummer und Lizenzinformationen Ihres Exemplars von SOLIDWORKS Visualize.
Übergeordnetes Thema Aufgaben nach der Installation


Installieren von Visualize Boost mit dem SOLIDWORKS Installations-Manager.

Sie installieren Visualize Boost mit dem SOLIDWORKS Installations-Manager. Es erfordert eine separate Seriennummer.

Sie sollten Visualize Boost auf anderen Rechnern als denen installieren, auf denen SOLIDWORKS Visualize Professional ausgeführt wird. Die Rendering-Leistung lässt sich maximieren, indem Sie Visualize Boost auf Computern mit mehreren Grafikprozessoren (GPUs) installieren.

So installieren Sie SOLIDWORKS Visualize Boost:

  1. Starten Sie den SOLIDWORKS Installations-Manager.
  2. Wählen Sie auf der Seite Willkommen die Option Auf diesem Computer installieren aus.
  3. Führen Sie die folgenden Schritte durch:
    1. Auf der Seite Seriennummer erweitern Sie Visualisierung.
    2. Wählen Sie SOLIDWORKS Visualize Boost aus und geben Sie die Seriennummer ein.
    3. Klicken Sie auf Weiter.
  4. Befolgen Sie die Anweisungen für Systemwarnungen und klicken Sie auf Weiter.
  5. Akzeptieren Sie auf der Seite Zusammenfassung die Bedingungen des SOLIDWORKS Lizenzvertrags und klicken Sie auf Jetzt installieren.
Befolgen Sie die Anweisungen im Produktaktivierungsassistenten, um Ihr Produkt zu aktivieren.

Öffnen Sie nach der Aktivierung die App, indem Sie auf die Desktop-Verknüpfung für SOLIDWORKS Visualize Boost doppelklicken [image].

Inhaltsverzeichnis

  • Konfigurieren von Visualize Boost

    Sie können die primäre Visualize Boost Maschine als Koordinator und zusätzliche Maschinen im Rendering-Cluster als Knoten konfigurieren.

Übergeordnetes Thema SOLIDWORKS Visualize und SOLIDWORKS Visualize Boost


Konfigurieren von Visualize Boost

Sie können die primäre Visualize Boost Maschine als Koordinator und zusätzliche Maschinen im Rendering-Cluster als Knoten konfigurieren.

Visualize Boost ermöglicht Ihnen das Rendern von Bildern auf einem einzelnen Computer oder über eine Gruppe von Computern hinweg. Die Einrichtung ist einfach und intuitiv. Ein primärer Computer, der Koordinator, verwaltet das Cluster und verteilt die Rendering-Jobs aus SOLIDWORKS Visualize. Zusätzliche Maschinen, die Knoten genannt werden, stellen eine Verbindung zum Koordinator her, der diese Tasks in einem Netzwerk unterstützt. In einer Renderfarm führt jede Maschine im Cluster kontinuierlich eine Instanz von Visualize Boost aus.

So konfigurieren Sie Visualize Boost:

  1. Visualize Boost öffnen:
    • Doppelklicken Sie auf die Desktopverknüpfung für Visualize Boost [image].
    • Klicken Sie im Windows-Menü Start auf SOLIDWORKS <Version> > SOLIDWORKS Visualize Boost <Version>.
    Nach der Aktivierung identifiziert und zeigt das Fenster „Visualize Boost“ den Namen und die IP-Adresse des lizenzierten Computers an.
  2. Klicken Sie in Visualize Boost auf Datei > Einstellungen.
  3. Im Dialogfeld Einstellungen:
    1. Wählen Sie eine Maschine als Koordinator aus. Lassen Sie den Koordinator deaktiviert, während Sie alle anderen Knoten konfigurieren.
    2. Übernehmen Sie die Standardwerte 8001 für den Boost-Anschluss und 8002 für den DStellar-Anschluss.
      Sie können diese Anschlüsse aktualisieren, um die Netzwerkanforderungen zu erfüllen. Achten Sie darauf, dass Sie Firewall-Ausnahmen für die Knotenkommunikation hinzufügen. Wenden Sie sich bei Fragen an Ihren Netzwerkadministrator.
  4. Optional: Zu den weiteren Parametern zählen:
    Option | Bezeichnung
    Sprache | Die Maschine verwendet automatisch die Sprache des Betriebssystems.
    Thema | Wählen Sie zwischen einem hellen oder dunklen Hintergrund für das Design aus. Diese Einstellung wirkt sich auf SOLIDWORKS Visualize aus, wenn die Software auf demselben Computer wie Visualize Boost installiert ist.
    Benachrichtigungen aktiviert | Zeigt Meldungen von DStellar.Boost im Windows-Benachrichtigungsbereich an.
    Exportieren | Speichert die Konfigurationseinstellungen von Visualize Boost in einer .json-Datei.
    Importieren | Lädt vorhandene Einstellungen in eine Instanz von Visualize Boost in einer .json-Datei.
  5. Klicken Sie auf Anwenden.
Informationen zum Abschluss der Einrichtung finden Sie in den Anweisungen unter Arbeiten mit Visualize Boost.
Übergeordnetes Thema Installieren von Visualize Boost mit dem SOLIDWORKS Installations-Manager.


Lizenzadministration

Sie können nach der Installation die SOLIDWORKS Lizenzen aktivieren, indem Sie entweder einzelne Computer aktivieren (Computeraktivierung) oder variable Netzwerklizenzen auf einem Server aktivieren (SolidNetWork Lizenzierung).

In der Regel Typischerweise wird für Installationen auf Einzel-Computern eine Lizenzaktivierung verwendet; Sie können aber die Software einzeln installieren und die Lizenzen über den SolidNetWork License Manager steuern. Ebenso können Sie, obwohl an größeren Standorten normalerweise variable Netzwerklizenzen verwendet werden, die Installationen von einem Administrator-Installationsabbild verwenden, und dann die Seriennummern von den Einzel-Computern aus aktivieren.

Inhaltsverzeichnis

  • Verwalten von Einzellizenzen

    Sie können eine einzelne Lizenz für die Computeraktivierung festlegen.

  • Lizenzen mit einem SolidNetWork License Manager verwalten

    Der SolidNetWork License Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.


Verwalten von Einzellizenzen

Sie können eine einzelne Lizenz für die Computeraktivierung festlegen.

In der Regel besteht die Verwaltung von Einzellizenzen aus der Aktivierung und Deaktivierung von Lizenzen direkt aus der SOLIDWORKS Software.

Die Aktivierung ist ein Vorgang der Produktlizenzierung und -registrierung für SOLIDWORKS Einzelplatzlizenzen (nicht für SolidNetWork Lizenzen). Wenn Ihre Produktlizenz noch nicht aktiviert wurde, versucht SOLIDWORKS in der Regel, sie zu aktivieren, wenn Sie das Produkt starten.

Ab SOLIDWORKS 2022 und höher müssen Sie beim Erwerb einer unbefristeten Lizenz von SOLIDWORKS die Lizenz einmal pro Jahr reaktivieren. Eine unbefristete Lizenz läuft nie ab, muss aber reaktiviert werden. SOLIDWORKS fordert Sie auf, die unbefristete Lizenz vor dem erforderlichen Reaktivierungsdatum zu reaktivieren.

Sie können Einzellizenzen deaktivieren, indem Sie in SOLIDWORKS auf [image] > Lizenzen > Deaktivieren klicken.

Übergeordnetes Thema Lizenzadministration
Lizenzen mit einem SolidNetWork License Manager verwalten

Aktivierung einer Lizenz

Sie müssen die Lizenz für einen einzelnen Computer aktivieren, bevor Sie SOLIDWORKS Produkte auf ihm laufen lassen können.

Die Aktivierung erfordert einen Internetanschluss oder eine E-Mail-Adresse. Nach der Aktivierung müssen Sie nicht Online sein, um das Produkt zu nutzen. Wenn Sie keinen E-Mail-Zugriff auf dem Rechner haben, auf dem Sie dieses Produkt nutzen, können Sie die Aktivierungsdatei speichern und von einem anderen Rechner senden.

Dieser Vorgang:
  • Aktiviert alle Software-Lizenzen der gesamten SOLIDWORKS Produktlinie.
  • Ermöglicht Ihnen, Lizenzen von einem Rechner auf einen anderen zu übertragen.
  • Kann sofort (empfohlen) oder innerhalb von 30 Tagen nach der Installation durchgeführt werden.
  • Macht Dongles überflüssig. Wenn Sie jedoch frühere Versionen von SOLIDWORKS nutzen, die keine Aktivierung erfordern, benötigen Sie weiterhin Dongles.

Systemadministratoren, die mehrere Seriennummern zu verwalten haben, können den Administrator-Installationsabbild-Options-Editor verwenden. Einzelheiten finden Sie unter Administrator-Installationsabbild Options-Editor.

Aktivieren einer Lizenz:

  1. Starten Sie SOLIDWORKS.
  2. Starten Sie die SOLIDWORKS Produktaktivierung mittels einer der folgenden Methoden:
    • Wenn Sie die Lizenz für diesen Rechner noch nicht aktiviert haben, dann erscheint das Fenster SOLIDWORKS Produktaktivierung automatisch, wenn Sie die SOLIDWORKS Software starten.
    • Sollte das Fenster SOLIDWORKS Produktaktivierung nicht automatisch angezeigt werden, starten Sie die Aktivierung, indem Sie auf [image] > Lizenzen > Aktivieren klicken.
  3. Wählen Sie die Liste Produkt aus, um das Produkt anzugeben, dessen Lizenz Sie aktivieren möchten.
  4. Spezifizieren Sie automatische Aktivierung über das Internet oder manuelle Aktivierung mittels E-Mail.
  5. Geben Sie ihre Kontaktinformationen bekannt.
  6. Klicken Sie auf Weiter.
    • Internet: Die Aktivierung findet automatisch statt.
    • E-Mail: Klicken Sie auf Speichern, um eine Anforderungsdatei zu erstellen, und senden Sie die Datei dann an activation@solidworks.com. Wenn Sie die E-Mail mit der Antwortdatei erhalten, extrahieren Sie die Datei aus der E-Mail und klicken Sie danach auf Öffnen, um sie zu laden.
      Falls notwendig, können Sie die Anwendung beenden und den Aktivierungsvorgang nochmals ausführen, um die Antwortdatei zu öffnen.
  7. Klicken Sie auf Fertig stellen.
Administrator-Installationsabbild Options-Editor

Eine Lizenz reaktivieren

Wenn Sie über unbefristete kommerzielle oder Lehrlizenzen für SOLIDWORKS 2022 und nachfolgende Produkte verfügen, müssen Sie diese Lizenzen einmal pro Jahr reaktivieren. Die SOLIDWORKS Produktaktivierung fordert Sie dazu auf, dies vor dem erforderlichen Reaktivierungsdatum zu tun.

So reaktivieren Sie eine Lizenz:

  1. Starten Sie SOLIDWORKS.
    Die SOLIDWORKS Produktaktivierung fordert Sie zur Reaktivierung auf. Für jede SOLIDWORKS Produktlizenz wird Folgendes angezeigt:
    • Das Ablaufdatum der aktuellen Aktivierung
    • Die für die weitere Nutzung des Produkts Erforderliche Aktion, beispielsweise die Reaktivierung einer unbefristeten Lizenz oder die Erneuerung und Reaktivierung einer befristeten oder Testlizenz.
  2. Klicken Sie auf Jetzt reaktivieren, um den Produktaktivierungsassistenten zu starten.

    Wenn Sie die Lizenz nicht sofort reaktivieren möchten, klicken Sie auf Später erinnern. Klicken Sie beispielsweise in SOLIDWORKS auf [image] > Lizenzen > Aktivieren, um den Produktaktivierungsassistenten zu starten. Siehe Aktivierung einer Lizenz.

Übertragen einer Lizenz

Um eine SolidNetWork Lizenz auf einen neuen oder aktualisierten Computer zu verschieben, deaktivieren Sie sie zunächst auf dem Lizenzschlüssel-Server der Dassault Systèmes SOLIDWORKS Corporation. Reaktivieren Sie sie dann auf dem anderen Computer.

Wenn Sie die Lizenz nicht an Dassault Systèmes SolidWorks Corporation zurückgeben konnten (z. B. aufgrund eines Festplattenfehlers), ist die Reaktivierung in den meisten Fällen dennoch erfolgreich. Ist dies nicht der Fall, wenden Sie sich an Ihren Fachhändler, um Unterstützung zu erhalten.

So verschieben Sie eine Lizenz:

  1. Klicken Sie in SOLIDWORKS auf [image] > Lizenzen > Deaktivieren und folgen Sie den Anweisungen.
  2. Gehen Sie zur Reaktivierung zum neuen oder aktualisierten Computer, und aktivieren Sie die Lizenz wie bei der ursprünglichen Aktivierung. Weitere Informationen finden Sie unter Aktivierung einer Lizenz.


Lizenzen mit einem SolidNetWork License Manager verwalten

Der SolidNetWork License Manager unterstützt mehrere Lizenz-Clients, indem Lizenzen an Clients im Netzwerk vergeben werden. Durch den variablen Einsatz von Lizenzen kann die Anzahl der Anwender über die Anzahl der Lizenzen hinausgehen.

Dieses Bild zeigt eine typische SolidNetWorks Lizensierungs-Installation:

Diese Abbildung zeigt:
  • SolidNetWork License Manager ist nur auf dem License Manager Computer installiert und aktiviert.
  • Auf Lizenz-Client-Computern ist keine zusätzliche SolidNetWork spezifische Software installiert.

    Wenn Sie bei der Installation eine SolidNetWork Lizenzseriennummer angeben, identifiziert der SOLIDWORKS Installations-Manager diesen Computer als einen SolidNetWork Lizenz-Client. Der SOLIDWORKS Installations-Manager fragt Sie nach dem Namen des SolidNetWork License Manager Computers und der Portnummer, um den Client mit dem License Manager zu verbinden.

  • Beim License Manager und allen Lizenz-Clients muss TCP/IP (Transmission Control Protocol/Internet Protocol)-Verbindung zur Verfügung stehen.

Inhaltsverzeichnis

  • Installation von SolidNetWork Lizenzen – Übersicht

    Bevor Sie die SOLIDWORKS Client-Software auf einem beliebigen Computer installieren können, müssen Sie den SolidNetWork License Manager Server zunächst mit dem SOLIDWORKS Installations-Manager auf mindestens einem Computer installieren. Anschließend können Sie den Produktaktivierungsassistenten verwenden, um Seriennummern für unbefristete und befristete Lizenzen hinzuzufügen und zu aktivieren.

  • SolidNetWork License Manager starten

    Sie können den SolidNetWork License Manager vom Windows Start-Menü aus starten.

  • SolidNetWork License Manager aktualisieren

    Für Hauptversionen von SOLIDWORKS verläuft das Upgrade von License Manager wie folgt: alten License Manager deinstallieren, neuen License Manager installieren, SolidNetWork License reaktivieren.

  • Verschieben einer SolidNetWork Lizenz

    Um die Lizenz auf einen neuen oder aktualisierten Computer zu verschieben, geben Sie sie zunächst durch Deaktivieren an den Lizenzschlüssel-Server der Dassault Systèmes SOLIDWORKS Corporation zurück, und reaktivieren Sie sie auf dem anderen Computer.

  • SolidNetWork Lizenzdateien löschen

    Vor einem Upgrade auf neue Lizenzen können Sie abgelaufene SolidNetWork Lizenzdateien löschen.

  • Leihen und Rückgabe von SolidNetWork-Lizenzen

    Sie können sich eine SolidWorks Lizenz leihen, um die Software von einem externen Standort aus zu verwenden. Da die Lizenz von dem Pool der verfügbaren Lizenzen entfernt wurde, muss eine geborgte Lizenz zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

  • Verwalten des Zugriffs auf SOLIDWORKS Versionen

    Sie können den Zugriff der Benutzer auf bestimmte Versionen von SOLIDWORKS in einer SolidNetWork Umgebung unterbinden. Diese Funktion ermöglicht Ihnen, die Versionen von SOLIDWORKS zu verwalten, die von verschiedenen Personen, Projekten und Unternehmenseinheiten genutzt werden.

  • Leerlaufzeit der Lizenz überwachen

    SOLIDWORKS kann die Leerlaufzeit des SolidNetWork License Managers erkennen, sodass Lizenzen, die eine bestimmte Zeit lang nicht verwendet wurden, der Gruppe der verfügbaren Lizenzen hinzugefügt werden.

  • Temporäre Lizenz verwenden

    Eine temporäre „any“-Lizenz kann genutzt werden, wenn die SolidNetWork Lizenz nicht zur Verfügung steht.

  • SolidNetWork-Lizenzen mit Zusatzanwendungen

    Sie können den SolidNetWork License Manager verwenden, um Lizenzen für die wichtigsten SOLIDWORKS Zusatzanwendungen zu verteilen.

  • Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License

    SolidNetWork License Benutzer können steuern, welche der SOLIDWORKS® Simulation Lizenzen in ihrem Lizenzpool verwendet werden soll, wenn SOLIDWORKS Simulation hinzugefügt wird. Sie können auch ein Upgrade der SOLIDWORKS Simulation Lizenz durchführen, ohne die Zusatzanwendung zu entfernen, falls ein höherer Lizenztyp für erweiterte Studien erforderlich ist.

  • Laden von Flow Simulation Modulen

    Als Kunde mit SolidNetWork License können Sie anhand von zwei Methoden steuern, wie die Zusatzanwendungsmodule HVAC und Elektronikkühlung für Flow Simulation geladen werden sollen.

  • Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics

    Wenn Sie SOLIDWORKS Simulation, Plastics oder Flow Simulation Studien ausführen, bleiben die Netzwerklizenzen aktiv und es tritt keine Zeitüberschreitung auf. SOLIDWORKS behält die Lizenzen während des Berechnungsprozesses bei, der als Aktivität betrachtet wird.

  • Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden

    Sie können einen Computer in einem Netzwerk so konfigurieren, dass er sowohl als Lizenzmanager bei der Verteilung von SolidNetWork Lizenzen und als Administrator-Installationsabbild-Ablageort fungiert, von dem aus Anwender SOLIDWORKS Software installieren können.

  • SolidNetWork License Manager deinstallieren

    Vor der Aktualisierung des SolidNetWork License Manager müssen Sie den alten License Manager deinstallieren, bevor Sie den neuen installieren.

  • FlexNet Publisher-Lizenzverwaltung

    Die Lizenzierung von SolidNetWork basiert auf der Lizenzverwaltung von FlexNet Publisher®.

Übergeordnetes Thema Lizenzadministration
Verwalten von Einzellizenzen


Installation von SolidNetWork Lizenzen – Übersicht

Bevor Sie die SOLIDWORKS Client-Software auf einem beliebigen Computer installieren können, müssen Sie den SolidNetWork License Manager Server zunächst mit dem SOLIDWORKS Installations-Manager auf mindestens einem Computer installieren. Anschließend können Sie den Produktaktivierungsassistenten verwenden, um Seriennummern für unbefristete und befristete Lizenzen hinzuzufügen und zu aktivieren.

Wenn Sie die SOLIDWORKS Client-Software auf einem Computer installieren, geben Sie eine SolidNetWork Lizenzseriennummer an. Der SOLIDWORKS Installations-Manager identifiziert diesen Computer als SolidNetWork Lizenz-Client und fordert Sie zur Eingabe des Computernamens und der Portnummer des SolidNetWork License Manager Servers auf. Wenn der SolidNetWork License Manager Server nicht installiert ist oder wenn der Name oder die Portnummer falsch ist, wird ein Fehler angezeigt.

Aktivierungsprozess

Bevor Anwender SOLIDWORKS Produkte auf ihren individuellen Computern ausführen können, muss auf dem SolidNetWork License Manager Server Computer eine SolidNetWork Lizenz aktiviert werden.

Die Aktivierung erfordert eine aktive Internetverbindung oder eine E-Mail-Adresse. Nach der Aktivierung müssen Sie nicht Online sein, um das Produkt zu nutzen. Wenn Sie keinen E-Mail-Zugriff auf dem Rechner haben, auf dem Sie dieses Produkt nutzen, können Sie die Aktivierungsdatei speichern und von einem anderen Rechner senden.

Dieser Vorgang:
  • Aktiviert den SOLIDWORKS SolidNetWork License Manager mit SolidNetWork Lizenzen über SOLIDWORKS Produkte hinweg.
  • Erlaubt es Ihnen, SolidNetWork Lizenzrechte von einem SolidNetWork License Manager Computer auf einen anderen zu verschieben.
  • Damit können Sie SolidNetWork Lizenzrechte auf einen SolidNetWork License Manager Computer installieren und aktivieren.
  • Dies muss durchgeführt werden, bevor Sie die SolidNetWork Lizenzen verwenden können.
  • Macht Dongles überflüssig. Wenn Sie eine SolidNetWork Lizenz für diese Version von SOLIDWORKS aktivieren, werden SolidNetWork Lizenzen für vorherige Versionen von SOLIDWORKS aktiviert. Den Dongle müssen Sie nicht behalten.

Inhaltsverzeichnis

  • SolidNetWork License Manager Server installieren

    SolidNetWork License Manager Server unterstützt mehrere Lizenz-Clients. Er verteilt die Lizenzen an die Clients auf dem Netzwerk.

  • Aktivieren von SolidNetWork Lizenzen

    Bevor Anwender SOLIDWORKS Produkt auf ihren einzelnen Computern ausführen können, muss eine SolidNetWork Lizenz auf dem SolidNetWork License Manager-Computer aktiviert werden.

  • Manuelle Aktivierung mit einem SolidNetWork License Manager Server

    Wenn Sie SolidNetWork License Manager Server installieren oder upgraden, müssen Sie die Lizenz aktivieren oder reaktivieren. Sie können die Lizenz entweder über das Internet oder manuell aktivieren oder reaktivieren.

  • SolidNetWork License Clients installieren

  • SolidNetWork Lizenzen mit Firewalls verwenden

    Wenn Ihr Computer mit einer Firewall arbeitet, müssen Sie die Ports so konfigurieren, dass sie SolidNetWork Lizenzen unterstützen.

  • SolidNetWork License reaktivieren

    Die Reaktivierung gilt für SolidNetWork License Produkte, nachdem ein Unternehmen den SolidNetwork License Manager Server auf Version 2022 oder höher aktualisiert hat. Auch wenn die installierten Produkte von einer früheren Version stammen, müssen die Lizenzen ab Version 2022 auf dem Server einmal im Jahr reaktiviert werden.

  • Triaden-Lizenz-Manager-Installation

    Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Wenn der Computer, der die Lizenzdatei verwaltet, nicht verfügbar ist, übernimmt einer der beiden anderen Computer.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


SolidNetWork License Manager Server installieren

SolidNetWork License Manager Server unterstützt mehrere Lizenz-Clients. Er verteilt die Lizenzen an die Clients auf dem Netzwerk.

Wenn Sie ein Upgrade von einer früheren Version von SolidNetWork License Manager Server durchführen, bei der Hardware-Dongles zur Lizenzaktivierung verwendet wurden, entfernen Sie den Hardware-Dongle, bevor Sie die neue Version von SolidNetWork License Manager Server installieren.

  1. Starten Sie den SOLIDWORKS Installations-Manager wie in Installationsmedien herunterladen beschrieben.
  2. Wählen Sie als Installationstyp Server-Komponenten installieren aus und klicken Sie auf SolidNetWork License Manager (verteilte Lizenzierung) auf diesem Computer installieren.
  3. Überprüfen Sie auf der Seite Übersicht den Installationsort und den Hintergrund-Downloader, stimmen Sie den Lizenzbedingungen zu und klicken Sie auf Jetzt installieren.
  4. Fügen Sie im SOLIDWORKS Produktaktivierungsassistenten für SolidNetWork License Manager Server eine Seriennummer hinzu und aktivieren Sie mindestens eine Lizenz. Siehe Seriennummern hinzufügen und SolidNetWork Lizenzen aktivieren.
Übergeordnetes Thema Installation von SolidNetWork Lizenzen – Übersicht
Aktivieren von SolidNetWork Lizenzen
Manuelle Aktivierung mit einem SolidNetWork License Manager Server
SolidNetWork License Clients installieren
SolidNetWork Lizenzen mit Firewalls verwenden
SolidNetWork License reaktivieren
Triaden-Lizenz-Manager-Installation


Aktivieren von SolidNetWork Lizenzen

Bevor Anwender SOLIDWORKS Produkt auf ihren einzelnen Computern ausführen können, muss eine SolidNetWork Lizenz auf dem SolidNetWork License Manager-Computer aktiviert werden.

Aktivieren einer SolidNetWork Lizenz:

  1. Starten Sie den SolidNetWork License Manager, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager ServerVersion klicken.
  2. Optional: Wenn Sie die SolidNetWork Lizenz noch nicht aktiviert haben, werden Sie von der Software aufgefordert, dies zu tun. Klicken Sie auf Ja.
    Der SOLIDWORKS Produktaktivierungs-Assistent wird gestartet.
  3. Optional: Wenn eine Firewall vorhanden ist, wählen Sie die Option Eine Firewall ist auf diesem Server aktiviert aus.
  4. Geben Sie auf der Seite SolidNetWork Lizenz-Server-Informationen die Portnummer ein und klicken Sie dann auf Weiter.
  5. Unter Seriennr.: Wählen Sie bestimmte Seriennummern aus oder klicken Sie auf Alle auswählen, um all Ihre SOLIDWORKS Seriennummern zu markieren und zu aktivieren.
    1. Wählen Sie die Option Automatisch über das Internet (empfohlen) aus.
    2. Geben Sie unter Kontaktinformationen eine E-Mail-Adresse an.
    Das Dialogfeld Aktivierung/Reaktivierung erfolgreich zeigt die Produkte an, die aktiviert wurden.
  6. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager Server installieren
Manuelle Aktivierung mit einem SolidNetWork License Manager Server
SolidNetWork License Clients installieren
SolidNetWork Lizenzen mit Firewalls verwenden
SolidNetWork License reaktivieren
Triaden-Lizenz-Manager-Installation


Manuelle Aktivierung mit einem SolidNetWork License Manager Server

Wenn Sie SolidNetWork License Manager Server installieren oder upgraden, müssen Sie die Lizenz aktivieren oder reaktivieren. Sie können die Lizenz entweder über das Internet oder manuell aktivieren oder reaktivieren.

Bei manueller Aktivierung:
  • Bei einem neuen SolidNetWork License Manager Server müssen Sie zweimal aktivieren, um den Server korrekt zu konfigurieren. Sie initialisieren das Lizenzsystem auf dem Server, wenn Sie es das erste Mal aktivieren. Wenn Sie den Vorgang das zweite Mal ausführen, aktivieren Sie die Lizenz.
  • Beim Upgrade von SolidNetWork License Manager Server müssen Sie die vorhandene Lizenz reaktivieren. Wenn es für den Server keine aktivierten Lizenzen gibt, führen Sie die Aktivierung durch, indem Sie auf der Registerkarte „Server-Administration“ auf Modifizieren klicken.
Übergeordnetes Thema Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager Server installieren
Aktivieren von SolidNetWork Lizenzen
SolidNetWork License Clients installieren
SolidNetWork Lizenzen mit Firewalls verwenden
SolidNetWork License reaktivieren
Triaden-Lizenz-Manager-Installation


SolidNetWork License Clients installieren

Wenn Sie die CAD-Software SOLIDWORKS auf einem Computer installieren, geben Sie eine SolidNetWork License Seriennummer an. Der SOLIDWORKS Installations-Manager identifiziert diesen Computer als SolidNetWork License Client und fordert Sie zur Eingabe von Name und Nummer des SolidNetWork License Manager Computers auf. Wenn der SolidNetWork License Manager Server nicht installiert ist oder wenn der Name oder die Portnummer falsch ist, wird ein Fehler angezeigt.

So installieren Sie SOLIDWORKS mit einer SolidNetWork License:

  1. Starten Sie den SOLIDWORKS Installations-Manager wie in Installationsmedien herunterladen beschrieben.
  2. Klicken Sie auf der Seite „Willkommen“ auf Auf diesem Computer installieren, wenn dies für diese Hauptversion die erste SOLIDWORKS Installation auf diesem Computer ist.
    Wenn Sie von einer aktuellen Version aktualisieren und von einer Einzellizenz auf SolidNetWork Lizenzierung wechseln, klicken Sie auf Einzelinstallation (auf diesem Computer) ändern. Einzelheiten finden Sie unter Von Einzellizenzen auf SolidNetWork-Lizenzen aktualisieren .
  3. Geben Sie im Dialogfeld Server hinzufügen die Adresse des SolidNetWork License Manager in folgender Form ein:

    port@ComputerName

    Die Portnummer muss dieselbe sein, die für den License Manager verwendet wird. Der Standardwert lautet 25734.

    Der SOLIDWORKS Installations-Manager versucht zu prüfen, ob auf diesen SolidNetWork License Manager zugegriffen werden kann. Wenn Sie noch keinen License Manager installiert haben, wird diese Validierung fehlschlagen. Sie können jedoch mit der Installation des Lizenz-Clients fortfahren.
  4. Schließen Sie die SOLIDWORKS Installation ab, indem Sie die Anleitungen des SOLIDWORKS Installations-Managers befolgen.
Übergeordnetes Thema Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager Server installieren
Aktivieren von SolidNetWork Lizenzen
Manuelle Aktivierung mit einem SolidNetWork License Manager Server
SolidNetWork Lizenzen mit Firewalls verwenden
SolidNetWork License reaktivieren
Triaden-Lizenz-Manager-Installation


SolidNetWork Lizenzen mit Firewalls verwenden

Wenn Ihr Computer mit einer Firewall arbeitet, müssen Sie die Ports so konfigurieren, dass sie SolidNetWork Lizenzen unterstützen.

In der Firewall-Software müssen Sie zwei SolidNetWork Lizenzports zur Firewall-Ausnahmenliste hinzufügen (z. B. SNL-in-port und SNL-out-port). Wenden Sie sich bei Fragen zu Einzelheiten der Konfiguration dieser Ports an Ihren Systemadministrator.

Wenn Sie Windows Firewall auf einem unterstützten Windows-Betriebssystem verwenden, müssen Sie die Ports auf dem SolidNetWork License Manager-Computer sowie die SolidNetWork Lizenzdatei ändern, um die Lizenzen auf die Lizenz-Client-Computer zu verteilen.

License Manager Computerports für eine Windows Firewall modifizieren

  1. Klicken Sie auf Start und öffnen Sie Windows-Sicherheit.
  2. Wählen Sie Firewall- & Netzwerkschutz > Erweiterte Einstellungen und klicken Sie auf Ja, um die Änderungen zu bestätigen.
  3. Wählen Sie im Dialogfeld Windows Defender Firewall mit erweiterter Sicherheit die Option Eingehende Regeln > Neue Regel.
  4. Wählen Sie im Assistenten für neue eingehende Regeln den Regeltyp Port aus und klicken Sie auf Weiter.
  5. Geben Sie die Portnummer unter Bestimmte lokale Ports: ein. (Beispiel: 80, 25734, 443) und klicken Sie dann auf Weiter.
  6. Wählen Sie Name. Geben Sie einen Namen ein (z. B. SNL-Porteingang).
  7. Klicken Sie auf Fertig stellen.

SolidNetWork License Manager-Einstellungen für eine Windows Firewall modifizieren

  1. Starten Sie SolidNetWork License Manager, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version klicken.
  2. Klicken Sie auf der Registerkarte Server-Administration unter License Server auf Stop. Klicken Sie zum Bestätigen auf Ja und auf OK, um den License-Server vollkommen zu stoppen.
  3. Klicken Sie unter Lizenzinformation auf Modifizieren.
  4. Wählen Sie unter Server-Typ das Server-Arrangement für Ihr Netzwerk aus (Einzel-Server oder Triade) und klicken Sie dann auf Weiter.
  5. Unter Server-Information:
    1. Wählen Sie Eine Firewall ist auf diesem Server aktiviert.
    2. Die Portnummer und die Portnummer der Händlerdomäne sollten die Portnummern enthalten, die für die Windows-Firewall festgelegt wurden (Details finden Sie im oben beschriebenen Vorgang).
    3. Wählen Sie Optionsdatei aus und klicken Sie auf Durchsuchen, um die Datei zu suchen. Klicken Sie auf Bearbeiten, um Parameter der Datei zu ändern.
    Die Optionsdatei ermöglicht dem Lizenzadministrator, verschiedene Bedienparameter der FlexNet-Lizenzierung zu steuern.

    Empfehlung: Sie finden die Optionsdatei im SolidNetWork License Manager Installationsverzeichnis (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt). Diese Datei muss sich im selben Verzeichnis wie die Datei sw_d.lic befinden.

    Weitere Informationen zur Optionsdatei finden Sie in der FlexNet Publisher Lizenz-Administrationsanleitung im Installationsverzeichnis des SolidNetWork License Manager:

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Übergeordnetes Thema Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager Server installieren
Aktivieren von SolidNetWork Lizenzen
Manuelle Aktivierung mit einem SolidNetWork License Manager Server
SolidNetWork License Clients installieren
SolidNetWork License reaktivieren
Triaden-Lizenz-Manager-Installation


SolidNetWork License reaktivieren

Die Reaktivierung gilt für SolidNetWork License Produkte, nachdem ein Unternehmen den SolidNetwork License Manager Server auf Version 2022 oder höher aktualisiert hat. Auch wenn die installierten Produkte von einer früheren Version stammen, müssen die Lizenzen ab Version 2022 auf dem Server einmal im Jahr reaktiviert werden.

Innerhalb von 30 Tagen vor dem Reaktivierungsdatum erhalten Benutzer der SOLIDWORKS Netzwerkprodukte eine Benachrichtigung, dass die Lizenzen ablaufen werden. Die Administratoren müssen über das Ablaufen der Lizenzen informiert sein, um sie rechtzeitig reaktivieren zu können.

Gehen Sie wie folgt vor, um eine SolidNetWork Lizenz zu reaktivieren:

  1. Starten Sie den SolidNetWork License Manager Server, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version klicken.
  2. Klicken Sie auf der Registerkarte Server-Administration unter Lizenzinformationen auf Reaktivieren.

  3. Wählen Sie unter Seriennummer die Option Alle für alle Lizenzen aus oder geben Sie eine Lizenznummer ein, um nach einer bestimmten Lizenz zu suchen.

    Im Dialogfeld Lizenzen reaktivieren werden alle Lizenzablaufdaten und Reaktivierungsdaten, die innerhalb von 30 Tagen liegen, rot hervorgehoben. Sternchen markieren Lizenzen, die verlängert werden müssen.

  4. Klicken Sie auf Reaktivieren.
Übergeordnetes Thema Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager Server installieren
Aktivieren von SolidNetWork Lizenzen
Manuelle Aktivierung mit einem SolidNetWork License Manager Server
SolidNetWork License Clients installieren
SolidNetWork Lizenzen mit Firewalls verwenden
Triaden-Lizenz-Manager-Installation


Triaden-Lizenz-Manager-Installation

Triaden-Lizenz-Manager verwenden drei Computer, damit höchste Stabiblität gewährleistet wird. Wenn der Computer, der die Lizenzdatei verwaltet, nicht verfügbar ist, übernimmt einer der beiden anderen Computer.

Voraussetzungen für die Verwendung von Triaden-Lizenz-Managern:
  • Installieren Sie Triaden-Lizenz-Manager auf stabilen Computern, die nicht oft heruntergefahren werden.
  • Die drei Lizenz-Manager sollten sich im selben Subnetz befinden. Sie sollten Triaden-Lizenz-Manager niemals mit langsamen Verbindungen oder Wählverbindungen konfigurieren.
  • In einer Triaden-Lizenz-Manager-Umgebung sollte der Systemadministrator sofort feststellen können, wenn ein Lizenz-Manager-Computer abstürzt und diesen so schnell wie möglich wieder starten.
    Wenn nur zwei Lizenz-Manager-Computer betrieben werden, ist dies ungünstiger als wenn nur ein einzelner Lizenz-Manager-Computer betrieben wird, da dann zwei Schwachpunkte für einen Ausfall vorliegen.

Inhaltsverzeichnis

  • Installation des Initial Triad License Manager

    Dieses Verfahren beschreibt die Installation von SolidNetWork License Manager auf dem ersten Computer in der Triade.

  • Den Triad License Manager auf weiteren Computern installieren

    Befolgen Sie diese Anweisungen für die Installation der SolidNetWork License Manager-Software auf dem zweiten und dritten Computer in der Triade. Dieses Verfahren entspricht fast der Installation der Software auf dem ersten Computer, mit Ausnahme der Schritte 2(f) und 2(i).

Übergeordnetes Thema Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager Server installieren
Aktivieren von SolidNetWork Lizenzen
Manuelle Aktivierung mit einem SolidNetWork License Manager Server
SolidNetWork License Clients installieren
SolidNetWork Lizenzen mit Firewalls verwenden
SolidNetWork License reaktivieren


Installation des Initial Triad License Manager

Dieses Verfahren beschreibt die Installation von SolidNetWork License Manager auf dem ersten Computer in der Triade.

  1. Installieren Sie auf dem ersten Triaden-Lizenzverwaltungscomputer den SolidNetWork License Manager mithilfe des SOLIDWORKS Installations-Managers:
    1. Starten Sie den SOLIDWORKS Installations-Manager wie in Installationsmedien herunterladen beschrieben.
    2. Wählen Sie als Installationstyp Server-Komponenten installieren aus und klicken Sie auf SolidNetWork License Manager (verteilte Lizenzierung) auf diesem Computer installieren.
    3. Überprüfen Sie auf der Seite Zusammenfassung den Installationsort und die Download-Optionen für den SolidNetWork License Manager und klicken Sie auf Jetzt installieren, um den SOLIDWORKS Installations-Manager-Prozess abzuschließen.
  2. Konfigurieren Sie den Initial Triad License Manager Computer mit dem SolidNetWork License Manager:
    1. Den SolidNetWork License Manager starten Klicken Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version.

      Da dies das erste Mal ist, dass Sie den SolidNetWork License Manager auf diesem Computer ausführen, werden Sie gefragt, ob Sie ihn jetzt aktivieren möchten.

    2. Klicken Sie auf Nein.

      Die Registerkarte „Server-Administration“ von SOLIDWORKS SolidNetWork License Manager wird angezeigt.

    3. Klicken Sie auf der Registerkarte „Server-Administration“ unter Erweiterte Optionen auf Optionen.
    4. Klicken Sie im SolidNetWork Server-Lizenzmodus auf Eine Lizenzdatei verwenden und dann auf OK.
    5. Klicken Sie unter Lizenzinformation auf Modifizieren.
      Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.
    6. Wählen Sie unter Server-Typ die Option Triade aus, und klicken Sie auf Weiter.
    7. Verifizieren Sie im Bereich „Server-Information“, dass der Computername und die Portnummer des Initial Triad License Manager Computers korrekt sind, und klicken Sie dann auf Weiter.

      Prüfen Sie, ob die Adresse der Netzwerkschnittstellenkarte (NIC) den Informationen in der Lizenzdatei von SOLIDWORKS entspricht und ob die Portnummer für den Triad License Manager Computer korrekt ist. Die NIC-Adresse wird auch als MAC-Adresse (Media Access Control Address) bezeichnet. Klicken Sie dann auf Weiter.

      Um die NIC-Adresse zu ermitteln, öffnen Sie ein Eingabeaufforderungsfenster und geben Sie folgende Zeichenfolge ein:

      ipconfig /all

      Wenn Ihr Computer eine Firewall verwendet, müssen Sie darüber hinaus u. U. Angaben auf diesem Bildschirm machen. Weitere Informationen finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.

    8. Geben Sie unter Triaden-Partner Server-Information den Computernamen und die Host-ID-Werte für die beiden anderen Triaden-Lizenzverwaltungscomputer ein und klicken Sie auf Weiter.
      Dadurch wird sichergestellt, dass ein Client-Computer eine Lizenz von den beiden anderen Servern erhalten kann, wenn ein Triaden-Lizenzmanager nicht verfügbar ist.
    9. Klicken Sie auf dem Bildschirm Lizenzen auf Lesen, um zur SolidNetWork Lizenzdatei zu gelangen und sie zu öffnen.
      Die Lizenzen werden im Dialogfeld SolidNetWork Lizenzdatei-Assistent aufgeführt. Verwenden Sie für diesen Computer eine Lizenzdatei, die Sie von einem Fachhändler oder vom Dassault Systèmes SOLIDWORKS Kundensupport erhalten haben.
    10. Klicken Sie auf Fertig stellen.
    11. Klicken Sie auf OK, um den Vorgang zu beenden, und auf Fertig stellen, um den SolidNetWork License Manager zu schließen.
Übergeordnetes Thema Triaden-Lizenz-Manager-Installation
Den Triad License Manager auf weiteren Computern installieren
SolidNetWork Lizenzen mit Firewalls verwenden


Den Triad License Manager auf weiteren Computern installieren

Befolgen Sie diese Anweisungen für die Installation der SolidNetWork License Manager-Software auf dem zweiten und dritten Computer in der Triade. Dieses Verfahren entspricht fast der Installation der Software auf dem ersten Computer, mit Ausnahme der Schritte 2(f) und 2(i).

Es wird angenommen, dass Sie bereits mindestens einen Triad License Manager auf einem anderen Computer installiert haben.

  1. Installieren Sie den den SolidNetWork License Manager mit dem SOLIDWORKS Installations-Manager auf dem Triaden-Lizenzverwaltungscomputer:
    1. Starten Sie den SOLIDWORKS Installations-Manager wie in Installationsmedien herunterladen beschrieben.
    2. Wählen Sie als Installationstyp Server-Komponenten installieren aus und klicken Sie auf SolidNetWork License Manager (verteilte Lizenzierung) auf diesem Computer installieren.
    3. Überprüfen Sie auf der Seite Zusammenfassung den Installationsort und die Download-Optionen für den SolidNetWork License Manager und klicken Sie auf Jetzt installieren, um den SOLIDWORKS Installations-Manager-Prozess abzuschließen.
  2. Konfigurieren Sie den Triad License Manager Computer mithilfe des SolidNetWork License Manager.
    1. Den SolidNetWork License Manager starten Klicken Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version.
      Da dies das erste Mal ist, dass Sie den SolidNetWork License Manager auf diesem Computer ausführen, werden Sie gefragt, ob Sie ihn jetzt aktivieren möchten.
    2. Klicken Sie auf Nein.
      Es erscheint die Registerkarte "Server-Administration" des SOLIDWORKS SolidNetWork License Managers.
    3. Klicken Sie in Erweiterte Optionen auf Optionen.
      Das Dialogfeld Erweiterte Optionen wird geöffnet.
    4. Klicken Sie im SolidNetWork Server-Lizenzmodus auf Eine Lizenzdatei verwenden und dann auf OK.
      Das Dialogfeld Erweiterte Optionen wird geschlossen.
    5. Klicken Sie unter Lizenzinformation auf Modifizieren.
      Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.
    6. Wählen Sie unter Server-Typ die Optionen Triade und Server-/Lizenzinformation abstimmen aus, und klicken Sie anschließend auf Weiter.
    7. Geben Sie unter Triaden-Server-Information den Computernamen und die Host-ID-Werte ein. Klicken Sie dann auf Weiter.
      Dadurch wird sichergestellt, dass ein Client-Computer eine Lizenz von den beiden anderen Servern erhalten kann, wenn ein License Manager nicht verfügbar ist.
    8. Klicken Sie auf dem Bildschirm Lizenzen auf Lesen, um zur SolidNetWork Lizenzdatei zu gelangen und sie zu öffnen.
      Die Lizenzen werden im Dialogfeld SolidNetWork Lizenzdatei-Assistent aufgeführt.
    Diese Lizenzdatei wird durch den ersten Triaden-Lizenz-Computer generiert, den Sie konfiguriert haben. Normalerweise befindet sich die Lizenzdatei unter \licenses\sw_d.lic. Zum Beispiel: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. Klicken Sie auf Fertig stellen.
      Eine Warnung im Dialogfeld SolidNetWork Lizenzdatei-Assistent wird eingeblendet.
    2. Klicken Sie auf OK, um den SolidNetWork Lizenzdatei-Assistenten zu schließen, und dann auf Fertig stellen, um den SolidNetWork License Manager abzuschließen.

Wiederholen Sie diesen Vorgang für den dritten Triaden-Lizenz-Computer.

Übergeordnetes Thema Triaden-Lizenz-Manager-Installation
Installation des Initial Triad License Manager


SolidNetWork License Manager starten

Sie können den SolidNetWork License Manager vom Windows Start-Menü aus starten.

Klicken Sie in Windows auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version.

Über denselben Pfad aus dem Windows Startmenü können Sie den SolidNetWork License Manager Client Version öffnen.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


SolidNetWork License Manager aktualisieren

Für Hauptversionen von SOLIDWORKS verläuft das Upgrade von License Manager wie folgt: alten License Manager deinstallieren, neuen License Manager installieren, SolidNetWork License reaktivieren.

Ein License Manager für eine neuere Version kann Lizenzen für Client Computer verteilen, die auch die frühere Version beibehalten.

  1. Starten Sie SolidNetWork License Manager, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version klicken.
  2. Stellen Sie auf der Registerkarte Lizenzverwendung sicher, dass keine Client-Computer im Netzwerk SOLIDWORKS ausführen.
  3. Den alten License Manager deinstallieren. Einzelheiten finden Sie unter SolidNetWork License Manager deinstallieren.
  4. Installieren Sie den neuen License Manager und reaktivieren Sie die SolidNetWork License auf dem License Manager Computer. Einzelheiten finden Sie unter SolidNetWork License Manager Server installieren.

Wenn Sie den SolidNetWork License Manager auf einem Computer aktualisieren, der auch die SOLIDWORKS Anwendung ausführt, müssen Sie die SolidNetWork License Manager und Clients aktualisieren, bevor Sie neue SOLIDWORKS Anwendungs-Service-Packs auf diesem Computer installieren.

Wenn Sie den License Manager auf einem Computer aktualisieren, der Administrator-Installationsabbilder hostet, müssen Sie den License Manager aktualisieren, bevor Sie die Administrator-Installationsabbilder aktualisieren. Einzelheiten finden Sie unter Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


Verschieben einer SolidNetWork Lizenz

Um die Lizenz auf einen neuen oder aktualisierten Computer zu verschieben, geben Sie sie zunächst durch Deaktivieren an den Lizenzschlüssel-Server der Dassault Systèmes SOLIDWORKS Corporation zurück, und reaktivieren Sie sie auf dem anderen Computer.

Wenn Sie die Lizenz nicht an Dassault Systèmes SolidWorks Corporation zurückgeben konnten (z. B. aufgrund eines Festplattenfehlers), ist die Reaktivierung in den meisten Fällen dennoch erfolgreich. Ist dies nicht der Fall, wenden Sie sich an Ihren Fachhändler, um Unterstützung zu erhalten.

Gehen Sie wie folgt vor, um eine SolidNetWork Lizenz zu verschieben:

  1. Starten Sie den SolidNetWork License Manager Server, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version klicken.
  2. Klicken Sie auf der Registerkarte Server-Administration unter Lizenzinformationen auf Modifizieren. Der SOLIDWORKS Produktaktivierungsassistent wird gestartet.
  3. Wählen Sie unter Was möchten Sie tun? die Option Produktlizenz(en) auf einen neuen/aktualisierten Computer verschieben und klicken Sie dann auf Weiter.
  4. Unter Seriennummer: Wählen Sie die Seriennummern aus oder klicken Sie auf Alle auswählen, um all Ihre SOLIDWORKS Seriennummern zu aktivieren.
    1. Wählen Sie die Option Automatisch über das Internet (empfohlen) aus.
    2. Geben Sie unter Kontaktinformationen (Verpflichtend) eine E-Mail-Adresse an.
  5. Das Meldungsfeld Deaktivierung erfolgreich wird angezeigt.
    Die Deaktivierung der Produktlizenz wird abgeschlossen.
  6. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


SolidNetWork Lizenzdateien löschen

Vor einem Upgrade auf neue Lizenzen können Sie abgelaufene SolidNetWork Lizenzdateien löschen.

  1. Starten Sie den SolidNetWork License Manager, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server klicken.
  2. Klicken Sie auf der Registerkarte Server-Administration unter Lizenzinformationen auf Modifizieren und anschließend auf Weiter.
  3. Wählen Sie auf der Seite SOLIDWORKS Produkt aktivieren/deaktivieren die abgelaufenen SolidNetWork Lizenzdateien aus und klicken Sie auf Entfernen.
  4. Klicken Sie auf Fertig stellen und OK, um den Vorgang zu beenden.
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


Leihen und Rückgabe von SolidNetWork-Lizenzen

Sie können sich eine SolidWorks Lizenz leihen, um die Software von einem externen Standort aus zu verwenden. Da die Lizenz von dem Pool der verfügbaren Lizenzen entfernt wurde, muss eine geborgte Lizenz zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

Geliehene Lizenzen sind nur für den aktuellen Benutzer und auf dem Rechner, für den sie ausgeliehen wurden, gültig. Eine Verschiebung auf andere Computer ist nicht möglich.

Die Lizenz wird auf bestimmte Zeit bis maximal 30 Tage verliehen (oder laut Definition durch den Systemadministrator), und die Lizenz wird aus einem Pool verfügbarer Lizenzen entnommen.

Das Ausleihen und Zurückgeben einer Lizenz funktioniert nicht, wenn die SOLIDWORKS Lizenz verwendet wird.

Der Systemadministrator kann das Entleihen anpassen:
  • Er kann Anwender oder Gruppen definieren, die Lizenzen ausleihen dürfen
  • Er kann die Anzahl der Lizenzen festlegen, die ausgeliehen werden können

Weitere Details finden Sie unter SolidNetWork_Lizenz_Manager_Installationsverzeichnis\Docs\flexuser\licensingenduserguide.pdf.

Inhaltsverzeichnis

  • SolidNetWork Lizenzen ausleihen

  • Rückgabe einer SolidNetWork Leihlizenz

    Da eine Leihlizenz aus dem Pool der verfügbaren Lizenzen entfernt wurde, muss diese Leihlizenz zunächst zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


SolidNetWork Lizenzen ausleihen

Starten Sie den SolidNetWork License Manager immer über das Startmenü. Sie müssen mit dem SolidNetWork License Manager verbunden sein, um die Lizenz zu beziehen.

Diese Schritte können je nach Systemkonfiguration unterschiedlich ausfallen. Weitere Anweisungen und Optionen finden Sie in der Microsoft Windows-Dokumentation.
  1. Starten Sie den SolidNetWork License Manager auf dem Client-Computer, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Client Version klicken.
  2. Führen Sie auf der Registerkarte Ausleihen einer Lizenz folgende Schritte aus:
    1. Wählen Sie unter Ausleihen bis ein Datum aus.
    2. Wählen Sie unter Verfügbare Produktlizenzen die Produkte aus, die Sie ausleihen möchten, und klicken Sie auf Ausleihen.
    3. Wählen Sie im Dialogfeld Produkt auswählen das Produkt aus der Liste aus und bestätigen Sie mit OK.
    4. Klicken Sie unten im Dialogfeld auf Aktualisieren.
      Die Spalte Ausleihen bis gibt an, wann die Lizenzen zurückgegeben werden müssen.
  3. Klicken Sie auf OK.

Auf der Registerkarte „Lizenzverwendung“ können Sie auch Informationen zu Gesamtanzahl an Lizenzen, Freie Lizenzen und Vom Benutzer verwendete Lizenzen sowie Ausgeliehen bis anzeigen.

Wählen Sie Nur geliehene Lizenzen verwenden (Schnellerer Start) aus, wenn Sie remote arbeiten und Ihre SOLIDWORKS Anwendungen nur langsam geöffnet werden.

Diese Option blockiert Abfragen zu Ihren Lizenzservern, die in einigen Umgebungen langsam sein können. Die Anwendungen können schneller gestartet werden, weil keine Abfragen erfolgen und nur die Lizenzen verwendet werden, die Sie ausgeliehen haben.

Starten Sie die Anwendungen neu, damit diese Option wirksam wird.

Übergeordnetes Thema Leihen und Rückgabe von SolidNetWork-Lizenzen
Rückgabe einer SolidNetWork Leihlizenz


Rückgabe einer SolidNetWork Leihlizenz

Da eine Leihlizenz aus dem Pool der verfügbaren Lizenzen entfernt wurde, muss diese Leihlizenz zunächst zurückgegeben werden, bevor sie wieder zur Verfügung stehen kann.

  1. Starten Sie den SolidNetWork License Manager auf dem Client-Computer, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Client Version klicken.
  2. Führen Sie auf der Registerkarte Ausleihen einer Lizenz folgende Schritte aus:
    1. Wählen Sie unter „Geliehene Produktlizenzen“ die Produkte aus, die Sie zurückgeben möchten, und klicken Sie auf Zurückgeben.
    2. Klicken Sie auf Aktualisieren. Die Spalte Ausgeliehen bis wird geleert, was darauf hinweist, dass die Lizenzen zurückgegeben wurden.
  3. Klicken Sie auf OK.

Auf der Registerkarte „Lizenzverwendung“ können Sie auch die Gesamtanzahl der Lizenzen anzeigen.

Abgelaufene Lizenzen müssen nicht mehr zurückgegeben werden. Die Lizenz wird um Mitternacht des Ablaufdatums in die Gruppe der zurückgegebenen Lizenzen im SolidNetWork License Manager zurückgegeben und die Anwendungen auf dem entfernten System können nicht mehr ausgeführt werden.
Übergeordnetes Thema Leihen und Rückgabe von SolidNetWork-Lizenzen
SolidNetWork Lizenzen ausleihen


Verwalten des Zugriffs auf SOLIDWORKS Versionen

Sie können den Zugriff der Benutzer auf bestimmte Versionen von SOLIDWORKS in einer SolidNetWork Umgebung unterbinden. Diese Funktion ermöglicht Ihnen, die Versionen von SOLIDWORKS zu verwalten, die von verschiedenen Personen, Projekten und Unternehmenseinheiten genutzt werden.

So verwalten Sie die Zugriffsberechtigung für SOLIDWORKS Versionen mithilfe einer FlexNet Optionsdatei:

  1. Erstellen Sie im Installationsverzeichnis des SolidNetWork License Manager eine Textdatei:
    SolidNetWork_License_Manager_Installationsverzeichnis\Licenses\sw_d.opt
  2. Zum Verwalten der Zugriffsberechtigung für eine bestimmte Version von SOLIDWORKS fügen Sie in der Lizenzdatei die folgende Syntax neben SOLIDWORKS hinzu:
    :SWVERSION=xx wobei xx die Version des SOLIDWORKS Produkts ist, das Sie verwalten möchten.
  3. Zum Verwalten mehrerer Versionen von SOLIDWORKS fügen Sie für jede Version, die Sie verwalten möchten, eine Zeile hinzu.

    Nicht alle FlexNet Optionen werden unterstützt. Die unterstützten Optionen der Versionsfilter sind:

    INCLUDE | Nur dem Benutzer oder der Gruppe die Möglichkeit zum Starten der spezifischen Version gewähren. Allen anderen Benutzern ist es nicht gestattet, diese Version zu starten.
    INCLUDE_BORROW | Nur dem Benutzer oder der Gruppe die Möglichkeit zum Ausleihen der spezifischen Version gewähren. Allen anderen Benutzern ist es nicht gestattet, diese Version auszuleihen.
    EXCLUDE | Den aufgelisteten Benutzer oder die Gruppe daran hindern, die spezifische Version von SOLIDWORKS zu starten. EXCLUDE ersetzt INCLUDE.
    EXCLUDE_BORROW | Den aufgelisteten Benutzer oder die Gruppe daran hindern, die spezifische Version von SOLIDWORKS auszuleihen. EXCLUDE ersetzt INCLUDE.
    Beispiele:
    1 | SWVERSION=32.0 bezieht sich auf SOLIDWORKS 2025
    SWVERSION=31.0 bezieht sich auf SOLIDWORKS 2024
    2 | INCLUDE solidworks:SWVERSION=32.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=32.0 USER jane
    Diese Zeilen in der Optionsdatei würden nur jane erlauben, SOLIDWORKS 2025, auszuführen. Alle anderen Anwender können SOLIDWORKS 2025 weder starten noch ausleihen, aber sie können andere Versionen von SOLIDWORKS ausführen und ausleihen. jane kann ebenfalls andere SOLIDWORKS Versionen ausführen und ausleihen.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=32.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=31.0 GROUP chicago
    EXCLUDE solidworks USER don
    Diese Zeilen definieren eine GROUP von Benutzern namens chicago, wobei diesen Benutzern der Zugriff auf SOLIDWORKS 2025 und SOLIDWORKS 2024 verweigert wird. Sie können aber jede andere Version von SOLIDWORKS ausführen. Der Benutzer don kann keine Version von SOLIDWORKS ausführen.
    4 | EXCLUDE swinspection_std:SWVERSION=32.0 HOST machine1
    Diese Zeile hindert alle Benutzer auf machine1 daran, SOLIDWORKS Inspection 2025 zu starten.

    Informationen zu FlexNet finden Sie in der FlexNet Publisher Lizenz-Administrationsanleitung im Installationsverzeichnis von SolidNetWork License Manager (\Docs\flexuser\fnp_LicAdmin.pdf).

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


Leerlaufzeit der Lizenz überwachen

SOLIDWORKS kann die Leerlaufzeit des SolidNetWork License Managers erkennen, sodass Lizenzen, die eine bestimmte Zeit lang nicht verwendet wurden, der Gruppe der verfügbaren Lizenzen hinzugefügt werden.

  1. Erstellen Sie im Installationsverzeichnis des SolidNetWork License Manager eine Textdatei:
    SolidNetWork_License_Manager_Installationsverzeichnis\Licenses\sw_d.opt
  2. Fügen Sie die folgende Zeile zur Datei hinzu:
    TIMEOUTALL Sekunden

    wobei Sekunden einer Zahl größer oder gleich 900 (15 Minuten) entspricht (zulässige Mindestdauer).

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


Temporäre Lizenz verwenden

Eine temporäre „any“-Lizenz kann genutzt werden, wenn die SolidNetWork Lizenz nicht zur Verfügung steht.

Standardmäßig kann der SolidNetWork License Manager jeweils nur einen Server aktivieren. Um in einer Testumgebung zu arbeiten, können Sie beim technischen Support eine temporäre Lizenzdatei anfordern und eine „any“-Lizenz in den SolidNetWork License Manager auf einem anderen Server laden. Wenn Sie mit einem Offline-Server arbeiten, können Sie die gleichen Anweisungen befolgen, um eine aktivierungsfreie Lizenz zu laden.

Durch die Nutzung der „any“-Lizenzdatei erklären Sie sich bereit, nach Erhalt einer SolidNetWork Lizenz von der Dassault Systèmes SOLIDWORKS Corporation eine Lizenz zu implementieren. Die Einhaltung der Lizenzbeschränkungen ist weiterhin erforderlich.

So nutzen Sie eine „any“-Lizenz:

  1. Starten Sie den SolidNetWork License Manager, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version klicken.
  2. Wenn die Software Sie zur Aktivierung auffordert, klicken Sie auf Nein.
  3. Klicken Sie auf der Registerkarte „Server-Administration“ auf Erweiterte Optionen > Optionen.
  4. Klicken Sie unter „SolidNetWork-Server-Lizenzmodus“ auf Lizenzdatei verwenden und dann auf OK.
  5. Klicken Sie auf der Registerkarte „Server-Administration“ unter Lizenzinformationen auf Modifizieren.
    Der SolidNetWork Lizenzdatei-Assistent wird eingeblendet.
  6. Wählen Sie unter Server-Typ die Option Einzel aus und klicken Sie auf Weiter.
  7. Wählen Sie Dongle-ID aus und geben Sie Beliebig oder die NIC-Adresse für Serverinformationen ein. Klicken Sie dann auf Weiter.

    Klicken Sie auf Abbrechen, wenn die folgende Meldung angezeigt wird: Konnte die Dongle-ID-Nummer nicht lesen.

    Wenn Ihr Computer mit einer Firewall arbeitet, müssen Sie u. U. zusätzliche Spezifizierungen auf diesem Bildschirm vornehmen. Weitere Informationen hierzu finden Sie unter SolidNetWork Lizenzen mit Firewalls verwenden.
  8. Klicken Sie unter „Lizenzen“ auf Lesen, um die Lizenzdatei zu lesen.
  9. Navigieren Sie im Dialogfeld Lesen zur Datei SNL_ANY.txt oder SNL_(NIC Card Number).txt, die vom technischen Support zur Verfügung gestellt wird, und klicken Sie auf Öffnen. Klicken Sie auf OK.
    Der SolidNetWork Lizenzdatei-Assistent listet die Lizenzen aus der Textdatei auf.
    Klicken Sie auf Entfernen, um temporäre Lizenzeinträge zu löschen, die in der Liste abgelaufen sind.
  10. Klicken Sie auf Fertigstellen, um den SolidNetWork Lizenzdatei-Assistenten zu schließen.
  11. Aktivieren Sie eine „any“-Lizenz:
    1. Klicken Sie auf der Registerkarte „Server-Administration“ auf Erweiterte Optionen > Optionen.
    2. Wählen Sie im SolidNetWork Server Lizenzmodus Lizenzdatei verwenden aus und klicken Sie auf OK.
    3. Klicken Sie auf der Registerkarte „Server-Administration“ auf Modifizieren > Produktlizenz(en) aktivieren/reaktivieren.
    4. Wählen Sie die Seriennummer aus, geben Sie Kontaktinformationen ein und wählen Sie die Aktivierungsmethode aus. Befolgen Sie bei einer manuellen Aktivierung die Anweisungen.
    5. Klicken Sie auf Fertig stellen, um die Aktivierung zu bestätigen.
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


SolidNetWork-Lizenzen mit Zusatzanwendungen

Sie können den SolidNetWork License Manager verwenden, um Lizenzen für die wichtigsten SOLIDWORKS Zusatzanwendungen zu verteilen.

  • Eine gleiche Anzahl von SOLIDWORKS Software-Lizenzen und SOLIDWORKS Zusatzanwendungslizenzen ist nicht erforderlich.
  • Um eine Lizenz für eine Zusatzanwendung auszuchecken, müssen Sie zuerst eine Lizenz für SOLIDWORKS auschecken.
  • Um eine Lizenz für eine Zusatzanwendung auszuleihen, müssen Sie sowohl die SOLIDWORKS Software-Lizenz als auch die SOLIDWORKS Produktlizenz, die die Zusatzanwendung beinhaltet, ausleihen. Eine SOLIDWORKS Standard Lizenz wird standardmäßig ausgeliehen. Jedoch müssen Sie sich eine SOLIDWORKS Professional, SOLIDWORKS Premium oder SOLIDWORKS Ultimate Produktlizenz ausleihen, um eine Zusatzanwendung zu aktivieren.
  • Eine Zusatzanwendungslizenz freigeben:
    • Klicken Sie in SOLIDWORKS auf Extras > Zusatzanwendungen und deaktivieren Sie die Zusatzanwendung.
    • Beenden Sie SOLIDWORKS.
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License

SolidNetWork License Benutzer können steuern, welche der SOLIDWORKS® Simulation Lizenzen in ihrem Lizenzpool verwendet werden soll, wenn SOLIDWORKS Simulation hinzugefügt wird. Sie können auch ein Upgrade der SOLIDWORKS Simulation Lizenz durchführen, ohne die Zusatzanwendung zu entfernen, falls ein höherer Lizenztyp für erweiterte Studien erforderlich ist.

  1. So verwenden Sie eine bestimmte SOLIDWORKS Simulation Lizenz:
    1. Klicken Sie in SOLIDWORKS auf Extras > Zusatzanwendungen und wählen Sie im Dialogfeld Zusatzanwendung die Option SOLIDWORKS Simulation aus.
    2. Klicken Sie in SOLIDWORKS Simulation (CommandManager) auf den Abwärtspfeil [image], um eine Liste der Lizenzen auf Ihrem Server anzuzeigen, die Simulation unterstützen können.

    3. Wählen Sie die entsprechende SOLIDWORKS Simulation Lizenz aus.
  2. Um Ihre aktuelle SOLIDWORKS Simulation Lizenz zu überprüfen oder zu ändern, klicken Sie in SOLIDWORKS Simulation (CommandManager) auf den Abwärtspfeil [image].

    Die verwendete Lizenz ist mit einem Häkchen markiert. Wenn erweiterte Lizenztypen verfügbar sind, können Sie ein Upgrade durchführen.
    Sie können eine SOLIDWORKS Simulation Lizenz nicht herabstufen. Deaktivieren Sie die SOLIDWORKS Simulation Zusatzanwendung und fügen Sie die Lizenz auf einer niedrigeren Ebene erneut hinzu.
  3. Optional: Um die Zusatzanwendung zu deaktivieren, klicken Sie auf „SOLIDWORKS Simulation“ (CommandManager) oder löschen Sie sie unter Extras > Zusatzanwendungen.
In den folgenden Fällen wird weiterhin die Lizenzreihenfolge verwendet:
  • Wenn SOLIDWORKS Simulation gestartet wird.
  • Wenn SOLIDWORKS Simulation unter Extras > Zusatzanwendungen hinzugefügt wird.
  • Wenn Sie auf „SOLIDWORKS Simulation“ klicken, ohne eine Lizenz in der Dropdown-Liste anzugeben.
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


Laden von Flow Simulation Modulen

Als Kunde mit SolidNetWork License können Sie anhand von zwei Methoden steuern, wie die Zusatzanwendungsmodule HVAC und Elektronikkühlung für Flow Simulation geladen werden sollen.

Mit der ersten Methode können Sie das Standardverhalten für die Zusatzanwendungen beim Laden von Flow Simulation festlegen. Die Option Flow Simulation Zusatzanwendungsmodule automatisch laden, wenn diese verfügbar sind befindet sich auf der Registerkarte SolidNetWork License Manager Client > Lizenz-Reihenfolge. Deaktivieren Sie diese Option, wenn Sie keine Flow Simulation Zusatzanwendungen benötigen. Die Zusatzanwendungsmodule für HVAC und Elektronikkühlung werden nicht geladen, wenn Flow Simulation mit vorhandenen Methoden hinzugefügt wird.

Mit der zweiten Methode können Sie das Standardverhalten außer Kraft setzen und die Zusatzanwendungsmodule HVAC und Elektronikkühlung beim Laden von Flow Simulation einbeziehen. Klicken Sie auf den Abwärtspfeil [image] auf SOLIDWORKS Flow Simulation (SOLIDWORKS® Zusatzanwendungs-Symbolleiste) oder SOLIDWORKS Flow Simulation mit einem oder beiden zu ladenden Zusatzmodulen.

Ohne diese Methoden werden die Lizenzen für die Zusatzanwendungsmodule unabhängig davon genutzt, ob Sie sie benötigen oder nicht, und können anderen Benutzern in Ihrem Netzwerk verweigert werden.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics

Wenn Sie SOLIDWORKS Simulation, Plastics oder Flow Simulation Studien ausführen, bleiben die Netzwerklizenzen aktiv und es tritt keine Zeitüberschreitung auf. SOLIDWORKS behält die Lizenzen während des Berechnungsprozesses bei, der als Aktivität betrachtet wird.

Inaktivitätszeiträume, die durch eine Zeitüberschreitungsoption definiert sind, werden erst nach Abschluss der Studienberechnung wirksam.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden

Sie können einen Computer in einem Netzwerk so konfigurieren, dass er sowohl als Lizenzmanager bei der Verteilung von SolidNetWork Lizenzen und als Administrator-Installationsabbild-Ablageort fungiert, von dem aus Anwender SOLIDWORKS Software installieren können.

Die Client-Computer können eine Lizenz vom License Manager erhalten und dann die SOLIDWORKS Anwendung vom selben Computer aus installieren.

Für diese Konfiguration müssen der Lizenz-Manager und das Administrator-Installationsabbild auf demselben Computer installiert sein. Den Lizenz-Manager zuerst installieren und dann das Administrator-Installationsabbilderstellen und verwenden.
Weitere Informationen finden Sie unter:
  • SolidNetWork License Manager Server installieren
  • Bereitstellung für mehrere Clients
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
SolidNetWork License Manager deinstallieren
FlexNet Publisher-Lizenzverwaltung


SolidNetWork License Manager deinstallieren

Vor der Aktualisierung des SolidNetWork License Manager müssen Sie den alten License Manager deinstallieren, bevor Sie den neuen installieren.

  1. Starten Sie SolidNetwork License Manager, indem Sie auf Start > SOLIDWORKS Werkzeuge Version > SolidNetWork License Manager Server Version klicken.
  2. Verifizieren Sie, dass in diesem Netzwerk kein Client-Computer SOLIDWORKS ausführt.
    Auf der Registerkarte Lizenzverwendung sind alle Clients aufgeführt, die SOLIDWORKS ausführen.
  3. Wenn Sie die SolidNetWork Lizenz auf einen anderen Computer verschieben möchten, deaktivieren Sie auf diesem Computer, bevor Sie den SolidNetWork License Manager entfernen.
    Informationen über das Verschieben von SolidNetWork Lizenzen finden Sie unter Eine SolidNetWork Lizenz verschieben.
  4. Klicken Sie auf der Registerkarte Server-Administration unter License Server auf Stop.
  5. Klicken Sie auf OK, um den License Manager zu beenden.
  6. Klicken Sie in Windows auf Systemsteuerung > Programme und Funktionen.
  7. Wählen Sie SOLIDWORKS SolidNetWork License Manager, klicken Sie auf Deinstallieren und bestätigen Sie die Deinstallation.
  8. Löschen Sie unter Verwendung von Datei-Explorer den Ordner SOLIDWORKS SolidNetWork License Manager.
    (In der Regel befindet sich dieser Ordner unter Program Files (x86) im SOLIDWORKS Installationsverzeichnis.)

Sie können jetzt eine neue Version des License Managers installieren. Weitere Informationen finden Sie unter SolidNetWork License Manager Server installieren.

Wenn sich auf dem SolidNetWork License Manager-Computer ein Hardware-Dongle befindet, entfernen Sie den Hardware-Dongle, bevor Sie die neue Version des SolidNetWork License Managers installieren.
Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
FlexNet Publisher-Lizenzverwaltung
SolidNetWork License Manager Server installieren


FlexNet Publisher-Lizenzverwaltung

Die Lizenzierung von SolidNetWork basiert auf der Lizenzverwaltung von FlexNet Publisher®.

Weitere Informationen zur Verwaltung von FlexNet Publisher Lizenzen finden Sie in der FlexNet Publisher Lizenz-Administrationsanleitung im Installationsverzeichnis des SolidNetWork License Manager: C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Die neuesten Informationen zur Lizenzverwaltung von FlexNet Publisher erhalten Sie über Flexera® Software.

Sie finden die FlexNet-Version im Protokoll auf dem Lizenzserver. Öffnen Sie den SolidNetwork License Manager Server und klicken Sie auf Server-Administration > Protokoll anzeigen. Das Protokoll listet die FlexNet-Lizenzierungsversion am Anfang in Klammern auf.

Übergeordnetes Thema Lizenzen mit einem SolidNetWork License Manager verwalten
Installation von SolidNetWork Lizenzen – Übersicht
SolidNetWork License Manager starten
SolidNetWork License Manager aktualisieren
Verschieben einer SolidNetWork Lizenz
SolidNetWork Lizenzdateien löschen
Leihen und Rückgabe von SolidNetWork-Lizenzen
Verwalten des Zugriffs auf SOLIDWORKS Versionen
Leerlaufzeit der Lizenz überwachen
Temporäre Lizenz verwenden
SolidNetWork-Lizenzen mit Zusatzanwendungen
Auswählen einer SOLIDWORKS Simulation Lizenz mit einer SolidNetWork License
Laden von Flow Simulation Modulen
Zeitüberschreitung bei Inaktivität in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation und SOLIDWORKS Plastics
Den selben Computer für den Lizenz-Manager und Administrator-Installationsabbilder verwenden
SolidNetWork License Manager deinstallieren


Problembehebung

Schlagen Sie unter diesen Themen nach, wenn Sie Hilfe bei der Problembehebung bei Installationsproblemen benötigen.

Inhaltsverzeichnis

  • Netzwerk-Lizenz-Benutzung

  • SOLIDWORKS Installations-Manager-Protokolldateien

    Die Protokolldateien des SOLIDWORKS Installations-Managers stehen Ihnen zur Problembehebung bei Installationsproblemen zur Verfügung.

  • SOLIDWORKS Installations-Manager Download-Ordner

    Der SOLIDWORKS Installations-Manager kann die benötigten Installationsdateien in einen von Ihnen festgelegten Ordner herunterladen. Diese Hilfe gibt Antworten auf häufig gestellte Fragen zum Download-Ordner.

  • Problembehebung bei Netzwerklizenzen

    Wenn die Installation des SolidNetWork Lizenz-Managers fehlschlägt, überprüfen Sie diese möglichen Erklärungen.

  • Problembehebung bei Aktualisierungen

    Wenn Sie während der Aktualisierung auf eine neue SOLIDWORKS Version Probleme haben, überprüfen Sie diese möglichen Erklärungen.

  • Überprüfen von Grafikkarten bei der Installation oder Aktualisierung

    Nach dem Installieren oder Aktualisieren von SOLIDWORKS auf Ihrem Computer sollten Sie SOLIDWORKS Rx ausführen, um sicherzustellen, dass Ihr Computer eine unterstützte Grafikkarte und einen unterstützten Grafikkartentreiber verwendet.


Netzwerk-Lizenz-Benutzung

Dieses Dialogfeld wird geöffnet, wenn für ein Produkt auf dem Server keine Lizenz mehr zur Verfügung steht.

Klicken Sie auf den Pfeil im Feld Produkt, um die Produktauswahl einzublenden. Zur Auswahl stehen unter anderem SOLIDWORKS und alle erwerbbaren Zusatzanwendungen.

Lizenzen insgesamt ist die Gesamtzahl der Lizenzen, die Sie erworben haben.

Verfügbare Lizenzen ist die Anzahl an Lizenzen, die nicht verwendet werden.

Das Feld Lizenzen verwendet von enthält Informationen zu den Personen, die über eine Lizenz verfügen.

Übergeordnetes Thema Problembehebung
SOLIDWORKS Installations-Manager-Protokolldateien
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Netzwerklizenzen
Problembehebung bei Aktualisierungen
Überprüfen von Grafikkarten bei der Installation oder Aktualisierung


SOLIDWORKS Installations-Manager-Protokolldateien

Die Protokolldateien des SOLIDWORKS Installations-Managers stehen Ihnen zur Problembehebung bei Installationsproblemen zur Verfügung.

Diese Protokolldateien befinden sich im gleichen Ordner wie die anderen SOLIDWORKS Anwendungsprotokolldateien.

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

Wenn Sie den Installations-Manager von einem Systemkonto aus ausführen, befinden sich die Protokolle in diesem Ordner:
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
Um die Protokolldateiverzeichnisse zu sehen, müssen Sie u. U. die Windows-Ordner-Option Alle Dateien und Ordner anzeigen konfigurieren.

Wenn sich die Anwendungsdaten auf einem anderen Laufwerk als C: befinden, muss der Verzeichnispfad entsprechend angepasst werden.

Dieses Verzeichnis enthält die Datei SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, ein allgemeines Protokoll des Fortschritts des SOLIDWORKS Installation-Managers.

Das Unterverzeichnis Andere Protokolldateien enthält weitere detaillierte Protokolldatei-Informationen.

Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Netzwerklizenzen
Problembehebung bei Aktualisierungen
Überprüfen von Grafikkarten bei der Installation oder Aktualisierung


SOLIDWORKS Installations-Manager Download-Ordner

Der SOLIDWORKS Installations-Manager kann die benötigten Installationsdateien in einen von Ihnen festgelegten Ordner herunterladen. Diese Hilfe gibt Antworten auf häufig gestellte Fragen zum Download-Ordner.

Frage Antwort
Wie werden die Dateien in diesen Ordner installiert?

Führen Sie setup.exe aus. Eventuell müssen Sie noch einige Dateien herunterladen, wenn Sie Elemente zur Installation auswählen, die noch nicht heruntergeladen wurden.

Installieren Sie nicht mit msiexec (siehe unten).
Kann ich MSI-Dateien manuell von diesem Ordner mit msiexec oder einer anderen Anwendung installieren?

Nein. Der Installations-Manager lädt einige Dateien nicht herunter, die für die Ausführung von msiexec benötigt würden.
Kann ich denselben Download-Ordner für alle Versionen auswählen?

Heruntergeladenen Ordner sind versionsspezifisch. Der SOLIDWORKS Installations-Manager erstellt automatisch einen versionsspezifischen Unterordner im spezifizierten Ordner.

Ich habe einige Produkte manuell von der Dassault Systèmes SOLIDWORKS Corporation Website heruntergeladen. Kann der Installations-Manager auch diese installieren?
Manuell heruntergeladene Dateien können vom SOLIDWORKS Installations-Manager verwendet werden. Es ist jedoch besser, den SOLIDWORKS Installations-Manager auszuführen, wobei die Option zum Dateien-Download ausgewählt wird. Der SOLIDWORKS Installations-Manager zeigt, welche Dateien Sie basierend auf Ihrer Installation benötigen und umfasst Links für den Download der einzelnen benötigten Dateien. Sie können diese Option verwenden, wenn die Download-Seite nicht funktioniert (meist aufgrund von Download-Beschränkungen durch einen Proxy-Server).
Wenn Sie in einem Dialogfeld angeben müssen, ob Sie während eines Downloads oder einer Installation die Dateien speichern oder ausführen möchten, wählen Sie stets die Option Speichern.
Können die heruntergeladenen Dateien von mehreren Anwendern gemeinsam verwendet werden?

Ja. Laden Sie dazu die Dateien auf ein freigegebenes Netzwerk. Jeder Client kann dann den SOLIDWORKS Installations-Manager vom freigegebenen Netzwerk ausführen.

Es sind keine weiteren Downloads erforderlich, es sei denn, ein Anwender wählt einige Elemente zur Installation aus, die während des ersten Downloads nicht ausgewählt waren, oder wenn der Computer, der diesen Download zur Installation verwendet, einen anderen Satz von Voraussetzungen hat als der Computer, auf den Sie die Dateien heruntergeladen haben.

Wenn Sie im Namen anderer einen Download ausführen, aber nicht installieren, wählen Sie bei der Installation die Option Nur Download. Mit dieser Option können Sie Produkte unabhängig davon, was auf Ihrem System installiert ist, auswählen. Sie können diese Option jedoch nicht für den Download von Patches oder die Erstellung von Administrator-Installationsabbildern verwenden.
Wie weiß ich, dass eine neue Version von SOLIDWORKS Produkten verfügbar ist?
Sie werden in den folgenden Fällen benachrichtigt, wenn eine neue Version verfügbar ist:
  • Wenn Sie nach Aktualisierungen suchen ( Start > SOLIDWORKS Installations-Manager > Nach Aktualisierungen suchen).
  • Wenn Sie den SOLIDWORKS Hintergrund-Downloader aktiviert haben.
  • Wenn Sie eine installierte Version von SOLIDWORKS unter Windows Programme hinzufügen/entfernen auswählen und auf Ändern klicken.
  • Wenn Sie eine ältere Version des Installations-Managers (sldIM.exe) von einem Download-Ordner aus ausführen.
In diesen Fällen haben Sie die Möglichkeit, eine neuere Version herunterzuladen. Der SOLIDWORKS Installations-Manager wird die neuere Version von sich selbst und keine Installationsdateien herunterladen und ausführen. Sobald die neuere Version des SOLIDWORKS Installations-Managers ausgeführt wird, können Sie einen Satz von Installationsoperationen auswählen. Der SOLIDWORKS Installations-Manager stellt dann fest, welche Installationsdateien benötigt werden (und früher noch nicht heruntergeladen wurden) und bietet an, diese Dateien herunterzuladen.
Warum lässt mich der SOLIDWORKS Installations-Manager kein anderes Service Pack eines Produkts zur Installation auswählen?

Jede Version des SOLIDWORKS Installations-Managers ist nur für die Installation einer bestimmten Version von SOLIDWORKS Produkten entwickelt. Wenn Sie ein anderes Service Pack installieren möchten, müssen Sie den SOLIDWORKS Installations-Manager dieser Version ausführen. Im vorhergehenden Element erfahren Sie, wie Sie die neueste verfügbare Version finden.
Warum darf der SOLIDWORKS Installations-Manager diese Dateien nicht herunterladen?

Wenn Proxy-Server-Beschränkungen Anwendungen am Download von Dateien hindern, kann der SOLIDWORKS Installations-Manager Dateien nicht automatisch herunterladen.

Sie können Dateien manuell herunterladen und sie anschließend mit dem SOLIDWORKS Installations-Manager installieren. Um einzelne Dateien herunterzuladen, wählen Sie die entsprechende Option im SOLIDWORKS Installations-Manager (z. B. manual download method (Manueller Download) auf der Seite Download-Optionen). Basierend auf Ihrer Produktauswahl und den Systemanforderungen, wird eine Webseite in einem separaten Fenster mit Links für den manuellen Download der erforderlichen Dateien angezeigt.
Nicht alle meine SOLIDWORKS Produkte werden auf das neueste Service Pack aktualisiert. Warum habe ich laut Option „Nach Aktualisierungen suchen“ die neueste Version?

Die Option Nach Aktualisierungen suchen informiert Sie darüber, ob Sie die letzte Version des SOLIDWORKS Installations-Managers installiert haben (oder ausführen).

Wenn Sie alle Produkte auf die neueste Version aktualisieren möchten, die unter Systemsteuerung > Programme > Programme und Funktionen installiert ist, wählen Sie die neueste installierte Version von SOLIDWORKS und klicken Sie auf Ändern.
Kann ich eine DVD in einen Download-Ordner kopieren?

Ja, aber Installationen können fehlschlagen, wenn Sie nicht den gesamten Inhalt aller DVDs kopieren, die für ein bestimmtes Betriebssystem freigegeben wurden. Der SOLIDWORKS Installations-Manager sucht nach den Dateien swdata*.id, um die Version festzustellen. Wenn diese Dateien fehlen, können die Installationsdateien, die Sie kopiert haben, nicht erkannt werden. Ein Download wird gefordert.
Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager-Protokolldateien
Problembehebung bei Netzwerklizenzen
Problembehebung bei Aktualisierungen
Überprüfen von Grafikkarten bei der Installation oder Aktualisierung


Problembehebung bei Netzwerklizenzen

Wenn die Installation des SolidNetWork Lizenz-Managers fehlschlägt, überprüfen Sie diese möglichen Erklärungen.

Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager-Protokolldateien
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Aktualisierungen
Überprüfen von Grafikkarten bei der Installation oder Aktualisierung

Zugriff auf SolidNetWork Lizenz-Protokolldateien

Wenn ein Lizenzfehler auftritt, kann die Antwort oft in der Datei SNL_Manager_Installationsverzeichnis\lmgrd.log gefunden werden.

Konnte keine Lizenz für SOLIDWORKS erhalten. Kann nicht zum License Server verbinden.

In der Regel wird dieses Problem durch die Porteinstellungen verursacht.

  • Porteinstellungen zwischen dem SolidNetWork License Manager und dem Lizenz-Client stimmen u.U. nicht überein.
  • Weitere Anschlusseinstellungen für mehrere Versionen des SolidNetWork License Manager wurden möglicherweise nicht festgelegt.
  • Überprüfen Sie anhand des Servernamens, ob der Client-Computer den Server richtig auflösen kann und das Routing zum Server korrekt erfolgt.
Details zu den Anschlusseinstellungen für die SolidNetWork Lizenz-Manager und Clients finden Sie in SolidNetWork Lizenzen mit Firewalls verwenden.
SolidNetWork Lizenzen mit Firewalls verwenden


Problembehebung bei Aktualisierungen

Wenn Sie während der Aktualisierung auf eine neue SOLIDWORKS Version Probleme haben, überprüfen Sie diese möglichen Erklärungen.

Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager-Protokolldateien
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Netzwerklizenzen
Überprüfen von Grafikkarten bei der Installation oder Aktualisierung

Ändern oder Reparieren einer Quelle, die verschoben wurde

Wenn SOLIDWORKS installiert ist, merkt sich der SOLIDWORKS Installations-Manager den Speicherort der Installationsquellen (Datenträger, Datenträgerabbild in einem Netzwerk usw.). Es wird erwartet, dass die Quellen beim Ändern oder Reparieren am selben Ort verfügbar sind.

Wenn die Quelle an einen anderen Ort verlagert oder gelöscht wurde oder sich das Quellmedium geändert hat, produziert der SOLIDWORKS Installations-Manager eine Fehlermeldung. Sie können die Installationsquellen jedoch ändern oder reparieren, indem Sie zu einem anderen Speicherort wechseln, solange dieser die gleiche Datei- und Ordnerstruktur enthält.


Überprüfen von Grafikkarten bei der Installation oder Aktualisierung

Nach dem Installieren oder Aktualisieren von SOLIDWORKS auf Ihrem Computer sollten Sie SOLIDWORKS Rx ausführen, um sicherzustellen, dass Ihr Computer eine unterstützte Grafikkarte und einen unterstützten Grafikkartentreiber verwendet.

So überprüfen Sie Grafikkarten bei der Installation oder Aktualisierung:

  1. Wenn der Installations-Manager die Installation abgeschlossen hat und die Seite Fertig stellen anzeigt, klicken Sie unter System überprüfen auf Systemdiagnose ausführen.

    SOLIDWORKS Rx wird gestartet und führt die Diagnose aus.

  2. SOLIDWORKS Rx prüft, ob die Grafikkarte und der Grafikkartentreiber unterstützt werden.
    Wenn die Grafikkarte unterstützt wird, der Treiber jedoch nicht, kann eine Statusmeldung einen Hinweis auf eine Treiberaktualisierung geben.

Bei jedem zehnten Start von SOLIDWORKS wir die Meldung System überprüfen eingeblendet, die empfiehlt, wieder die Systemdiagnose auszuführen. Zum Unterdrücken dieser Benachrichtigungen klicken Sie im Windows-Benachrichtigungsbereich mit der rechten Maustaste auf SOLIDWORKS Resource Monitor [image] und dann auf Grafische Benachrichtigungen deaktivieren.

Sie können die Grafikkarte und den Treiber jederzeit überprüfen, indem Sie im Windows-Benachrichtigungsbereich mit der rechten Maustaste auf „SOLIDWORKS Resource Monitor“ klicken. Über das Menü können Sie:
  • Hilfe für den SOLIDWORKS Resource Monitor anzeigen
  • Systemdiagnosen ausführen
  • Grafische Benachrichtigungen deaktivieren
  • Subskriptionsbenachrichtigungen deaktivieren
  • Zertifizierte Grafiktreiber anzeigen
Übergeordnetes Thema Problembehebung
Netzwerk-Lizenz-Benutzung
SOLIDWORKS Installations-Manager-Protokolldateien
SOLIDWORKS Installations-Manager Download-Ordner
Problembehebung bei Netzwerklizenzen
Problembehebung bei Aktualisierungen


SOLIDWORKS Installations-Manager-Anwendungshilfe

Der SOLIDWORKS Installations-Manager ist eine eigenständige Anwendung, die Ihre SOLIDWORKS Produkte installiert und aktualisiert.

Der SOLIDWORKS Installations-Manager ist das primäre Werkzeug zum Herunterladen, Installieren, Modifizieren, Aktualisieren, Reparieren und Entfernen der SOLIDWORKS Software.

Sie können den SOLIDWORKS Installations-Manager von folgenden Orten aus ausführen:
  • Von einer SOLIDWORKS DVD oder einem freigegebenen Quell- oder Download-Ordner (für die Installation einer neuen Version)
  • Von der Seite Systemsteuerung, Software (zum Modifizieren oder Entfernen einer bestehenden Version)
  • Über eine geplante oder manuelle Aktualisierungsüberprüfung (für das Ermitteln, den Download und die Installation neuer Versionen.

Jede SOLIDWORKS Version verfügt über eine zugehörige SOLIDWORKS Installations-Manager-Version.

Inhaltsverzeichnis

  • SOLIDWORKS Hintergrund-Downloader

    SOLIDWORKS Hintergrund-Downloader führt Datei-Downloads in Hintergrundprozessen (z. B. wenn eine neue Service Pack-Version gefunden wurde) aus, was es Ihnen ermöglicht, weiter zu arbeiten, während Sie downloaden. Wenn der Download abgeschlossen ist, können Sie entscheiden, ob Sie die Installation nun durchführen möchten, den Download auf einen anderen Zeitpunkt verschieben oder ihn entfernen möchten.

  • Angeben von Optionen für den Installations-Manager

    Zu diesen Optionen gehören Einstellungen für die Protokollierung, den Internetzugang und die Sprache, die im Installations-Manager verwendet wird.

  • Nach Aktualisierungsergebnissen suchen

    Die Option Nach Updates suchen sucht nach neueren Versionen von SOLIDWORKS.

  • Administrator-Installationsabbild-Position

    Geben Sie den Installationsspeicherort des Administrator-Installationsabbilds an.

  • Download-Optionen

    Geben Sie Einzelheiten zum Durchführen des Download-Vorgangs an, z. B. den Speicherort der heruntergeladenen Dateien, die Download-Methode und ob die heruntergeladenen Dateien installiert werden sollen.

  • Download-Optionen für SOLIDWORKS Installations-Manager-Dateien

    Sie haben beschlossen, eine spätere Version des SOLIDWORKS Installations-Managers herunterzuladen. Verwenden Sie diesen Bildschirm, um zu definieren, wo und wie er heruntergeladen werden soll.

  • Produkt-Installationsdateien herunterladen

    Definieren Sie, wo und wie fehlende Dateien für das betreffende Produkt heruntergeladen werden sollen.

  • Download-Verlauf

    Der SOLIDWORKS Installations-Manager lädt während dieses Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.

  • Download-Ergebnisse

    Gibt an, ob der Download erfolgreich durchgeführt wurde, während des Vorgangs fehlgeschlagen ist oder abgebrochen wurde.

  • Installationsfehler / Installation abgebrochen

    Bei der Installation ist ein Fehler aufgetreten oder sie wurde abgebrochen.

  • Installation vollständig

    Der SOLIDWORKS Installations-Manager hat die Verarbeitung abgeschlossen.

  • Installationsort

  • Aktualisierungsoptionen

    Auf diesem Computer sind eine oder mehrere SOLIDWORKS Hauptversionen installiert. Sie können eine neue Installation erstellen, die parallel zu der älteren Version existiert, oder Sie können ein Upgrade durchführen, das die ältere Version entfernt.

  • Installationsfortschritt

    Dieser Bildschirm zeigt den Verlauf der Installation.

  • Installationstyp

    Sie können den Installationsvorgang angeben, den Sie ausführen möchten. So können Sie beispielsweise eine neue Installation erstellen, eine vorhandene Installation ändern oder reparieren, ein Administrator-Installationsabbild erstellen, Verwaltungsserverprodukte installieren oder Dateien herunterladen, um diese gemeinsam zu nutzen und auf anderen Computern zu installieren.

  • Installieren und Verwalten mehrerer Computer

    Der SOLIDWORKS Installations-Manager bietet die folgenden Werkzeuge zum Installieren auf mehreren SOLIDWORKS Computern und deren Verwaltung.

  • Manueller Download

    Sie haben sich für das manuelle Herunterladen von Dateien entschieden (oder Sie haben diese Entscheidung möglicherweise getroffen, als Sie den SOLIDWORKS Installations-Manager zum letzten Mal ausgeführt haben).

  • Neuere Version verfügbar

    Der Installations-Manager hat eine neuere Version von SOLIDWORKS Produkten gefunden. Sie können die Version von der ursprünglichen Installations-DVD oder dem ursprünglichen Download installieren oder die neuere Version herunterladen und installieren.

  • Keine neuen Versionen verfügbar

    Es stehen keine neueren Versionen zum Download bereit. Fahren Sie mit der Installation der angegebenen Version fort.

  • Festgestellte Prozesse

    Der SOLIDWORKS Installations-Manager hat auf diesem Computer laufende Prozesse festgestellt, die eine erfolgreiche Installation verhindern könnten.

  • Produktauswahl

    Sie können die Produktkomponenten angeben, die installiert, modifiziert, heruntergeladen oder entfernt werden sollen.

  • Produkte zum Herunterladen

    Wählen Sie SOLIDWORKS Produkte zum Herunterladen an einen bestimmten Ablageort aus.

  • Zu reparierende Produkte

    Wenn Sie Diese Installation reparieren auswählen, zeigt dieser Bildschirm die SOLIDWORKS Produkte mit den Versionsnummern an, die von dieser Version des SOLIDWORKS Installations-Managers repariert werden können.

  • Seriennummern

    Seriennummern verknüpfen Ihren Computer mit den von Ihnen erworbenen SOLIDWORKS Produkten.

  • Server-Installation

    Die Server-Produkte, die Sie zu installieren versuchen, sind mit den Ergebnissen der Installation aufgeführt.

  • Zusammenfassung

    Der SOLIDWORKS Installations-Manager verfügt über alle für die Durchführung der Installation erforderlichen Informationen.

  • Warnungen bei der Systemprüfung

    Die Systemprüfung hat Probleme gemeldet, die sich auf die weitere Installation auswirken könnten. In den meisten Fällen sollten Sie mit dem SOLIDWORKS Installations-Manager fortfahren können.

  • Bohrungsassistent/Toolbox-Optionen

    Wenn Sie SOLIDWORKS Toolbox installieren, enthält SOLIDWORKS eine Standardbibliothek von Bohrungstypen und Hardware.

  • Produkte deinstallieren

    Wenn Sie die Option zum Entfernen oder Deinstallieren von Programmen in der Systemsteuerung auswählen, zeigt dieser Bildschirm die SOLIDWORKS Produkte (mit Versionsnummern) an, die von dieser Version des SOLIDWORKS Installations-Managers deinstalliert werden können. Sie können zwischen einer Standard-, benutzerdefinierten oder vollständige Deinstallation wählen.


SOLIDWORKS Hintergrund-Downloader

SOLIDWORKS Hintergrund-Downloader führt Datei-Downloads in Hintergrundprozessen (z. B. wenn eine neue Service Pack-Version gefunden wurde) aus, was es Ihnen ermöglicht, weiter zu arbeiten, während Sie downloaden. Wenn der Download abgeschlossen ist, können Sie entscheiden, ob Sie die Installation nun durchführen möchten, den Download auf einen anderen Zeitpunkt verschieben oder ihn entfernen möchten.

Hintergrund-Downloader wird standardmäßig aktiviert, wenn Sie SOLIDWORKS installieren.

Wenn der Installations-Manager ausgeführt wurde, um eine Installation oder einen Download auszuführen, wird der Hintergrund-Downloader angehalten. Der Downloader hält jeden Download an und lässt nicht zu, dass neue Downloads gestartet werden und dass der Download-Zielordner geändert wird.

Sie können den Hintergrund-Downloader während der Installation deaktivieren. Deaktivieren Sie auf der Seite „Zusammenfassung“ unter „Download-Optionen“ die Option Hintergrund-Downloader für zukünftige Service Packs verwenden.

Wenn es aktiviert ist, erscheint dieses Symbol im Windows-Infobereich in der Symbolleiste:

Durch Klicken auf dieses Symbol kann auf folgende Optionen zugegriffen werden:
  • Hilfe für Hintergrund-Downloader
  • Download anhalten
  • Download wieder aufnehmen
  • Download abbrechen
  • Installationsoptionen
  • Download-Einstellungen ändern
  • Nach Aktualisierungen suchen
  • Automatisch nach Aktualisierungen suchen
  • Aktualisierungen automatisch herunterladen
  • Hintergrund-Downloader deaktivieren

Hilfe für Hintergrund-Downloader

Öffnen Sie dieses Hilfethema für den Hintergrund-Downloader in der SOLIDWORKS Installationsanleitung.

Download anhalten/wieder aufnehmen

Wenn ein Download im Hintergrund ausgeführt wird, klicken Sie auf Download anhalten, um den Download anzuhalten. Wenn Sie den Download später fortsetzen wollen, klicken Sie auf Download wieder aufnehmen.

Download abbrechen

Wenn ein Download ausgeführt wird, brechen Sie den Download ab und löschen Sie alle bereits heruntergeladene Dateien.
Ein abgebrochener Download kann nicht wieder aufgenommen werden.

Installationsoptionen

Wenn ein Download abgeschlossen ist, können Sie aus den folgenden Optionen auswählen:
  • Jetzt installieren: Heruntergeladene Dateien installieren.
  • Erinnere mich später: Heruntergeladene Dateien nicht installieren, aber eine Erinnerungsmeldung einrichten.
  • Diesen Download löschen: Heruntergeladene Dateien nicht installieren und löschen. (Diese Option sollte gewählt werden, wenn Sie sich entschieden haben, die heruntergeladenen Dateien nicht zu installieren.)

Download-Einstellungen ändern

Ändern Sie den Speicherort für die vom Hintergrund-Downloader heruntergeladenen Dateien.

Diese Option ist nicht verfügbar, wenn ein Download läuft oder angehalten wurde.
Sie können auch die Anzahl der Tage zwischen Überprüfungen auf Aktualisierungen festlegen.

Nach Aktualisierungen suchen

Die Funktion Nach Aktualisierungen suchen des SOLIDWORKS Installations-Managers wird ausgeführt.

Automatisch nach Aktualisierungen suchen

Die Funktion Nach Aktualisierungen suchen wird regelmäßig ausgeführt und Sie werden benachrichtigt, wenn Aktualisierungen zum Download bereit stehen.

Aktualisierungen automatisch herunterladen

Die Funktion Nach Aktualisierungen suchen wird regelmäßig ausgeführt und bereitgestellte Aktualisierungen werden heruntergeladen.

Deaktivieren und Reaktivieren von SOLIDWORKS Hintergrund-Downloader

Sie können den Hintergrund-Downloader deaktivieren, indem Sie auf das Symbol in der Windows-Systemleiste klicken und Hintergrund-Downloader deaktivieren wählen.

Um den Hintergrund-Downloader wieder zu aktivieren, klicken Sie auf Start > SOLIDWORKS Installations-Manager > SOLIDWORKS Hintergrund-Downloader.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Angeben von Optionen für den Installations-Manager

Zu diesen Optionen gehören Einstellungen für die Protokollierung, den Internetzugang und die Sprache, die im Installations-Manager verwendet wird.

So geben Sie die Optionen für den Installations-Manager vor der Installation der Software an:

  1. Klicken Sie im Installations-Manager mit der rechten Maustaste auf das SOLIDWORKS Symbol in der Titelleiste und wählen Sie:
    Option | Bezeichnung
    Installations-Protokollierungsstufen Stellt die Protokollierungsstufe auf Hoch, Mittel oder Niedrig ein. Bei höheren Stufen werden mehr Daten für die Fehlerbehebung erfasst, die Installation verlangsamt sich aber möglicherweise. Niedrig (am schnellsten) ist die Standardeinstellung und bietet die beste Leistung und Stabilität.

    Mit Windows Installer-Protokolldateien erstellen (langsam) können Sie Protokolle im selben Ordner wie andere Installationsprotokolle speichern.
    Administrator-Installationsabbild-Optionen | Wählen Sie Kurze Dateinamen verwenden (8.3-Format) oder Vollständige Ordner- und Dateinamen verwenden aus.
    Installationsprotokolle abfragen | Gibt an, wo die Installationsprotokolle gespeichert werden. Der Installations-Manager speichert diese Dateien in der Datei IM_Logs.zip.
    Internet-Zugriff deaktivieren
    Sprache | Gibt die Sprache an, die im Installations-Manager verwendet wird. Die Standardeinstellung ist Englisch.
  2. Klicken Sie auf Schließen.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Nach Aktualisierungsergebnissen suchen

Die Option Nach Updates suchen sucht nach neueren Versionen von SOLIDWORKS.

Wenn Sie über Administratorrechte für den Computer verfügen, können Sie Nach Updates suchen manuell ausführen:
  • Klicken Sie in Windows auf Start > SOLIDWORKS Installations-Manager > Auf Aktualisierungen prüfen.
  • Klicken Sie in SOLIDWORKS auf [image] > Auf Aktualisierungen prüfen.
Die Funktion Nach Updates suchen ist bei Clients, die von Administrator-Installationsabbildern installiert wurden, nicht verfügbar.

Neue Version verfügbar

Der SOLIDWORKS Installations-Manager hat eine neuere Version von SOLIDWORKS Produkten gefunden. Sie können auf eine neuere Version aktualisieren, indem Sie den SOLIDWORKS Installations-Manager für diese Version auswählen.

Die neuere Version kann Installationsdateien auf der Basis der Produkte herunterladen, die Sie bei der Installation ausgewählt haben. Sie können die heruntergeladenen Dateien mit anderen Anwendern, die auch den SOLIDWORKS Installations-Manager für die Installationen verwenden, gemeinsam verwenden.

Diese Downloads sind nur für die Verwendung durch den SOLIDWORKS Installations-Manager geeignet.
Folgende Optionen stehen zur Verfügung:
  • Falls mehrere Versionen verfügbar sind, können Sie eine Version aus der Liste auswählen.
  • Für Details zu dieser Version klicken Sie auf Inhalt der Aktualisierung prüfen.
Durch Klicken auf Weiter wird die ausgewählte Version des SOLIDWORKS Installations-Managers abgerufen und ausgeführt.

Keine neuen Downloads verfügbar/Es kann nicht nach neuen Versionen gesucht werden

Der SOLIDWORKS Installations-Manager hat keine neuere Version von SOLIDWORKS Produkten gefunden, entweder weil Sie bereits die aktuellste zur Verfügung stehende Version installieren oder weil die zur Überprüfung erforderliche Verbindung zur SOLIDWORKS Website nicht hergestellt werden konnte.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Administrator-Installationsabbild-Position

Geben Sie den Installationsspeicherort des Administrator-Installationsabbilds an.

Beim Erstellen eines Administrator-Installationsabbilds sind die folgenden Optionen verfügbar:
Neue Installationsabbild-Position | Dies ist der Verzeichnisort, an dem der SOLIDWORKS Installations-Manager das neue Installationsabbild erstellt. | Dieses Verzeichnis kann kein bestehendes Administrator-Installationsabbild enthalten. Das Administratorabbild muss sich in einem freigegebenen Ordner befinden, damit es den Clients bereitgestellt werden kann.
Geschätzter erforderlicher Speicher für Abbilderstellung | Dies ist der für das Administrator-Installationsabbild erforderliche zusätzliche Speicher. | Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Anforderungen bzgl. des Installationsabbilds zu erfüllen.
Installationsabbild erstellen von | Die ist der Verzeichnisort, von dem aus Sie SOLIDWORKS Produkte installieren. Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Einzelheiten finden Sie unter Download-Optionen.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Download-Optionen

Geben Sie Einzelheiten zum Durchführen des Download-Vorgangs an, z. B. den Speicherort der heruntergeladenen Dateien, die Download-Methode und ob die heruntergeladenen Dateien installiert werden sollen.

Der SOLIDWORKS Installations-Manager unterstützt die elektronische Software-Bereitstellung (ESD). Wenn Sie nicht von einer SOLIDWORKS DVD installieren, werden Sie aufgefordert, die Quelle für die SOLIDWORKS Produkte, die Sie installieren, anzugeben.

Für Antworten zu Fragen über den Download-Ordner siehe SOLIDWORKS Installations-Manager Download-Ordner.

Was möchten Sie tun?

Wählen Sie eine der folgenden Optionen aus:

Herunterladen und installieren/Download und Abbild erstellen

Nach erfolgtem Download führt der SOLIDWORKS Installations-Manager eine Installation mit den heruntergeladenen Dateien aus.

Nur Download. Sie können einmal herunterladen und dann heruntergeladene Dateien auf mehreren Computern verwenden.

Der SOLIDWORKS Installations-Manager führt nach Abschluss des Downloads keine Installation aus.

Normalerweise würden Sie diese Option dann auswählen, wenn Sie die Dateien zum Konfigurieren einer Installationsdatei herunterladen, die auf mehreren Computern verwendet werden soll.

Wenn Sie diese Option auswählen, werden Sie aufgefordert, einen von zwei Dateisätzen auszuwählen, der heruntergeladen werden soll:
  • Dateien für DIESEN Computer: Der Download umfasst nur die Dateien, die in dem aktuell auf diesem Computer befindlichen Installationsdateisatz fehlen.
    Dies sollte ein kleineres Download sein, weil es nur Folgendes enthält:
    • Nur Dateien für die auf der Seite „Produktauswahl“ ausgewählte Produkte
    • Nur die für Ihren Computer erforderlichen, aber noch nicht installierten Dateien

    Wenn Sie jedoch versuchen, diesen heruntergeladenen Dateisatz auf einem anderen Computer zu verwenden, um eine Installation vorzunehmen, könnten einige Dateien fehlen (da sich der Installationsdateisatz auf dem anderen Computer von diesem unterscheiden könnte). Mit diesen Download-Dateien können Sie die Installation auf einem anderen Computer durchführen, aber wenn die Installation ausgeführt wird, müssen Sie möglicherweise zusätzliche Dateien herunterladen, um den Installationsdateisatz auf diesem Computer zu vervollständigen.

  • Dateien für die Verwendung auf JEDEM Computer: Der Download umfasst den vollständigen Installationsdateisatz, mit dessen Hilfe diese Version auf jedem beliebigen Computer installiert werden kann.

    Dieser Download ist umfangreicher, weil es den vollständigen Dateisatz umfasst, den Sie zum Installieren dieser Version eines beliebigen Produkts auf jedem Computer verwenden können.

    Wenn Sie einen begrenzten Satz herunterzuladender Produkte angegeben haben, ignoriert diese Option diese Festlegung und lädt alle in der Produktversion enthaltenen Produkte herunter.

    Der Download enthält alle zum Erstellen eines Administrator-Installationsabbilds benötigten Dateien, also nicht nur diejenigen, die zur Durchführung einer individuellen Installation erforderlich sind.

Nur installieren/Nur Abbild erstellen. Ich habe bereits alle erforderlichen Installationsdateien.

Der SOLIDWORKS Installations-Manager lädt keine Dateien herunter, sondern verwendet die im ausgewählten Verzeichnis befindlichen Dateien.

Klicken Sie auf Durchsuchen, um zu einem anderen Speicherort zu navigieren. So können Sie z. B. zu einer Installations-DVD oder einem Download-Ordner navigieren, solange sich an diesem Speicherort alle benötigten Dateien befinden.

Wenn Sie eine Fehlermeldung erhalten, dass der Ordner nicht vollständig ist, Sie aber davon ausgegangen sind, dass alle Installationsdateien vorhanden sind, sind mögliche Erklärungen folgende:
  • Sie habe eine Komponente zur Installation ausgewählt, die früher noch nicht heruntergeladen wurde, oder sie wurde standardmäßig ausgewählt.
  • Die Dateien wurden auf einem anderen Computer mit anderen Systemanforderungen heruntergeladen.
  • Sie haben früher eine Client-Installation ausgeführt und erstellen nun ein Administrator-Installationsabbild, für das ein größerer Dateisatz erforderlich ist.

Sie können entweder zu einem Ordner navigieren, der alle Dateien enthält (z. B. zu einer DVD), oder eine der Download-Optionen auswählen.

Wohin sollen die erforderlichen Dateien heruntergeladen werden?

Dies ist der Download-Ordner.

In manchen Fällen ist diese Option zwar sichtbar, aber deaktiviert. Wenn z. B. Nur installieren angegeben wird, installiert der SOLIDWORKS Installations-Manager alle heruntergeladenen Dateien aus dem für diese Option ausgewählten Verzeichnis, anstatt einen eigenen Download-Ordner zu verwenden.

Ob Sie diese Dateien nun herunterladen oder auf sie von lokaler Stelle zugreifen – alle Dateien müssen in denselben Download-Ordner heruntergeladen werden.

Geschätzte Download-Größe

Der geschätzte Festplattenspeicherbedarf für den Download basiert auf der vollständigen ausgewählten Liste, ungeachtet dessen, ob es sich um einen neuen Download handelt oder ob Sie einen Download von einer früheren Sitzung weiterführen.

Wenn Sie z. B. einen früheren Download wieder aufnehmen, verarbeitet der SOLIDWORKS Installations-Manager nur diejenigen Dateien, die noch nicht heruntergeladen wurden. Die Download-Zeit könnte unter der Schätzung liegen.

Wenn eine Datei im Rahmen des vorherigen Downloads vollständig heruntergeladen wurde, ist ihre Größe in dieser Schätzung nicht enthalten. Daher ist die Schätzung möglicherweise größer als der tatsächliche Umfang des Downloads

Wie möchten Sie die Dateien herunterladen?

Manueller Download

In manchen Fällen verhindert ein Proxy-Server vom SOLIDWORKS Installations-Manager initiierte automatische Downloads.

Wenn Sie diese Option auswählen, können Sie die Dateien manuell über eine Webseite herunterladen und die Installationsvorgänge dann innerhalb des SOLIDWORKS Installations-Managers abschließen. Diese Webseite wird vom SOLIDWORKS Installations-Manager so angepasst, dass nur diejenigen Dateien heruntergeladen werden, die zum Abschließen der Installation erforderlich sind.

Verwenden des SOLIDWORKS Hintergrund-Downloader

Sie können diesen Downloadvorgang mit dem SOLIDWORKS Hintergrund-Downloader abschließen. Auch können Sie mit dem Downloader SOLIDWORKS Service Pack-Versionen herunterladen, sobald sie zur Verfügung gestellt werden.

Der SOLIDWORKS Hintergrund-Downloader kann neue Service Pack-Aktualisierungen automatisch im Hintergrund erkennen und herunterladen und benachrichtigt Sie, wenn der Download abgeschlossen ist und die Dateien installiert werden können. Einzelheiten finden Sie unter SOLIDWORKS Hintergrund-Downloader.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Download-Optionen für SOLIDWORKS Installations-Manager-Dateien

Sie haben beschlossen, eine spätere Version des SOLIDWORKS Installations-Managers herunterzuladen. Verwenden Sie diesen Bildschirm, um zu definieren, wo und wie er heruntergeladen werden soll.

Für Antworten zu Fragen über den Download-Ordner siehe SOLIDWORKS Installations-Manager Download-Ordner.

Dieser Bildschirm erscheint nur, wenn ein Problem mit den Download-Standardordner vorliegt (wenn z. B. kein Schreib- oder Netzwerkzugriff verfügbar ist). Normalerweise können Sie einfach ein alternatives Download-Verzeichnis angeben, um weitermachen zu können.

Download-Verzeichnis

Wählen Sie den Zielordner für die SOLIDWORKS Installations-Manager Dateien aus.

Es werden der Umfang des Downloads sowie der benötigte Speicherplatz angezeigt. Die Menge des erforderlichen Speicherplatzes beinhaltet extra Speicherplatz für das Entpacken bestimmter Downloads und ist größer als die tatsächliche Größe des Downloads.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Produkt-Installationsdateien herunterladen

Definieren Sie, wo und wie fehlende Dateien für das betreffende Produkt heruntergeladen werden sollen.

Der SOLIDWORKS Installations-Manager lädt während des Download-Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.

Das Abbrechen auf diesem Bildschirm führt zum Abbruch der restlichen Installationssequenz.

Informationen zu den Konsequenzen eines Abbruchs und Anweisungen zum Abschließen unterbrochener Installationen finden Sie unter Installationsfehler / Installation abgebrochen.

Download-Verzeichnis

Wählen Sie den Zielordner für die heruntergeladenen Dateien aus.

Der Umfang des Downloads und der benötigte Speicherplatz werden angezeigt. Der erforderliche Speicherplatz beinhaltet extra Speicherplatz für das Entpacken bestimmter Downloads und ist größer als der tatsächliche Umfang des Downloads.

Antworten auf Fragen zum Download-Ordner finden Sie unter SOLIDWORKS Installations-Manager Download-Ordner.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Installationsfehler / Installation abgebrochen
SOLIDWORKS Installations-Manager Download-Ordner


Download-Verlauf

Der SOLIDWORKS Installations-Manager lädt während dieses Vorgangs alle Dateien herunter, verifiziert und extrahiert sie gleichzeitig.

Um den Download nach dem Start abzubrechen, klicken Sie auf Abbrechen.

Wenn Sie den Download abbrechen oder der Download fehlschlägt, informiert Sie der Bildschirm Download abgebrochen oder Download-Problem darüber, welche Downloads nicht abgeschlossen wurden, und ermöglicht die Fortsetzung des Downloads oder das Schließen der Anwendung.

Für Antworten zu Fragen über den Download-Ordner siehe SOLIDWORKS Installations-Manager Download-Ordner.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Download-Ergebnisse

Gibt an, ob der Download erfolgreich durchgeführt wurde, während des Vorgangs fehlgeschlagen ist oder abgebrochen wurde.

Download-Problem/Download abgebrochen

Wenn Download-Problem angezeigt wird, ist der SOLIDWORKS Installations-Manager auf Probleme gestoßen, die die Durchführung des Downloads verhinderten.

Wenn Download abgebrochen wird, haben Sie den Herunterladevorgang vor seinem Abschluss abgebrochen.

Fahren Sie wie folgt fort:

Download wiederholen/Automatische Downloads wiederholen | Um den automatischen Download an der Stelle fortzusetzen, an der Sie ihn abgebrochen hatten, wählen Sie diese Option aus und klicken Sie auf Download wiederholen oder Download fortsetzen.
Dateien einzeln in einem Webbrowser downloaden | In manchen Fällen verhindert ein Proxy-Server vom SOLIDWORKS Installations-Manager initiierte automatische Downloads. | Wenn Sie diese Option auswählen, können Sie die Dateien manuell über eine Webseite herunterladen und die Installationsvorgänge dann innerhalb des SOLIDWORKS Installations-Managers abschließen. Diese Webseite wird vom SOLIDWORKS Installations-Manager so angepasst, dass nur diejenigen Dateien heruntergeladen werden, die zum Abschließen der Installation erforderlich sind.

Download abgeschlossen

Der Bildschirm „Download abgeschlossen“ erscheint, wenn der Download abgeschlossen ist und Sie die Option Nur Download ausgewählt haben.

Klicken Sie auf Fertigstellen, um den SOLIDWORKS Installations-Manager zu beenden.

Versuchen Sie nicht, diese Produkte manuell zu installieren. Verwenden Sie zum Installieren der heruntergeladenen Dateien den SOLIDWORKS Installations-Manager.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Installationsfehler / Installation abgebrochen

Bei der Installation ist ein Fehler aufgetreten oder sie wurde abgebrochen.

Wenn ein Fehler oder ein Abbruch eintritt:
  • Produkte, die vor dem Fehler oder Abbruch installiert wurden, bleiben auf dem Computer.
  • Das Produkt, das während des Abbruchs installiert wurde, wird, wenn möglich, zurückgesetzt, sodass keine teilweisen Installationen vorliegen.
  • Die übrigen Produkte werden weder installiert noch deinstalliert. Unter Noch nicht versucht wird eine Liste bereitgestellt.

    Um das Installieren oder Deinstallieren dieser Produkte fortzusetzen, klicken Sie auf den bereitgestellten Link.

Der SOLIDWORKS Installations-Manager installiert zunächst erforderliche Dateien, die auf dem Computer noch nicht installiert sind, wie etwa .NET Framework.

Inhaltsverzeichnis

  • Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation

    Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation erneut ausführen, wodurch sie vom Punkt des Eintretens des Problems an fortgesetzt wird.

  • Reparieren einer Installation

    Wenn Sie Probleme mit einem installierten SOLIDWORKS Produkt haben, können Sie den SOLIDWORKS Installations-Manager für die Reparatur der Installation verwenden.

  • Kontaktaufnahme mit dem SOLIDWORKS Fachhändler

    Wenn das Ändern oder Reparieren der Installation fehlschlägt, wenden Sie sich an Ihren SOLIDWORKS Fachhändler vor Ort mit den Informationen, die auf dem Bildschirm angezeigt werden. Möglicherweise müssen Sie eine Zip-Datei der Protokolldateien des SOLIDWORKS Installations-Managers bereitstellen.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation

Wenn während der Installation ein Fehler oder ein Abbruch stattfindet, können Sie die Installation erneut ausführen, wodurch sie vom Punkt des Eintretens des Problems an fortgesetzt wird.

  1. Notieren Sie sich die Fehlermeldung und den Produktcode für die Installation, die fehlgeschlagen ist, so wie sie auf dem Bildschirm Installationsfehler oder Installation abgebrochen angezeigt werden.
    Wenn Sie zur Eingabe einer Quelldatei aufgefordert werden und Sie keine vorhandene SOLIDWORKS Installation ändern, ist u. U. die Installation oder der Computer beschädigt. Wenden Sie sich an Ihren SOLIDWORKS Fachhändler.
  2. Starten Sie den Computer neu.
  3. Um sicherzustellen, dass keine SOLIDWORKS Produkte ausgeführt werden, drücken Sie in Windows Ctr+Alt+Del, um den Task Manager zu öffnen.
  4. Wenn auf der Registerkarte Prozesse einige der folgenden Prozesse unter Name angezeigt werden, wählen Sie sie aus, und klicken Sie auf Prozess beenden.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Wenn die Anwendung bereits installiert ist und Sie versuchen, sie zu ändern oder zu entfernen, versuchen Sie, die Installation zu reparieren. Weitere Informationen hierzu finden Sie unter Reparieren einer Installation.
  6. Klicken Sie in Windows auf Start > Systemsteuerung > Programme und Funktionen.
  7. Wählen Sie die SOLIDWORKS Version aus, die fehlgeschlagen ist.
    Wenn kein Eintrag für die SOLIDWORKS Version vorliegt, die Sie zu installieren versuchen, wiederholen Sie den Installationsvorgang.
  8. Führen Sie einen der folgenden Schritte aus:
    • Um den Vorgang zu wiederholen, klicken Sie auf Ändern, und wählen Sie alle Produkte aus, die nicht installiert oder während der Installation übersprungen wurden.

    • Um die fehlgeschlagene Installation zu überspringen, klicken Sie auf Ändern, und wählen Sie alle Produkte aus, die während der Installation übersprungen wurden. Deaktivieren Sie das Produkt, das nicht installiert wurde.

    • Um die Installation abzubrechen, klicken Sie auf Entfernen, und wählen Sie alle Produkte aus, die installiert wurden.
    Dies stellt keine frühere Version von Produkten, die aktualisiert werden, wieder her.
Übergeordnetes Thema Installationsfehler / Installation abgebrochen
Reparieren einer Installation
Kontaktaufnahme mit dem SOLIDWORKS Fachhändler


Kontaktaufnahme mit dem SOLIDWORKS Fachhändler

Wenn das Ändern oder Reparieren der Installation fehlschlägt, wenden Sie sich an Ihren SOLIDWORKS Fachhändler vor Ort mit den Informationen, die auf dem Bildschirm angezeigt werden. Möglicherweise müssen Sie eine Zip-Datei der Protokolldateien des SOLIDWORKS Installations-Managers bereitstellen.

  1. Suchen Sie die Protokolldateien. Für Windows:
    C:\Benutzer\Benutzername\AppData\Roaming\SOLIDWORKS\Installation Logs\installierte_Version\.
    Wenn Sie den Ordner nicht finden können, ist er u. U. ausgeblendet. Klicken Sie in Datei-Explorer auf Tools (Werkzeuge) > Folder Options (Ordneroptionen). Wählen Sie auf der Registerkarte Ansicht unter Erweiterte Einstellungen die Option Show hidden files, folders, and drives (Versteckte Dateien, Ordner und Laufwerke anzeigen) für Hidden files and folders (Versteckte Dateien und Ordner).
  2. Komprimieren Sie den vollständigen Inhalt des Ordners, einschließlich aller Unterordner.
Übergeordnetes Thema Installationsfehler / Installation abgebrochen
Wiederherstellung nach einer fehlgeschlagenen oder abgebrochenen Installation
Reparieren einer Installation


Installation vollständig

Der SOLIDWORKS Installations-Manager hat die Verarbeitung abgeschlossen.

Möglicherweise wird eine oder mehrere der folgenden Optionen angezeigt.

Neue Funktionen

Bei Einzelinstallationen wird bei Beenden des Installationsvorgangs ein Dokument angezeigt, das die neuen Funktionen in SOLIDWORKS und den Zusatzanwendungen beschreibt.

Bei Installationen mit Administrator-Installationsabbild wird das Dokument auf den Client-Computern angezeigt, wenn diese die Installation abschließen.

Nehmen Sie am SOLIDWORKS Anwendererfahrungs-Verbesserungsprogramm teil

Leistungsdaten werden zur Produktverbesserung an die SOLIDWORKS Corporation gesendet. Das Verfahren ist transparent und die gewonnenen Daten werden geschützt. Wählen Sie eine der folgenden Optionen aus:
  • Ja, ich möchte teilnehmen
  • Nein danke
  • Erinnere mich später
Nähere Informationen dazu finden Sie auf der Website des Anwendererfahrungs-Optimierungsprogramms.

Erstellung des Administrator-Installationsabbilds ist abgeschlossen

Nach Abschluss der Erstellung des Administrator-Installationsabbilds können Sie auf Customize Image (Abbild anpassen) klicken, um den Administrator-Installationsabbild Options-Editor auszuführen und das Abbild anzupassen.

Klicken Sie auf Anleitung für die Installation dieses Abbilds auf einem Client., um eine Anleitung zur Verwendung des Options-Editors anzuzeigen.

Details zur Konfiguration eines Administrator-Installationsabbilds mit dem Options-Editor finden Sie unter Administrator-Installationsabbild Options-Editor.

Klicken Sie auf Bild anpassen, um den Administrator-Installationsabbild Options-Editor zu starten und die Optionseinstellungen für dieses Administrator-Installationsabbild anzupassen.
Sie können den Options-Editor auch starten, indem Sie auf sldAdminOptionEditor.exe im Ordner SOLIDWORKS Admin doppelklicken.

Inhaltsverzeichnis

  • Suchen nach SOLIDWORKS Aktualisierungen

    Wenn Sie über Administratorrechte auf dem Computer verfügen, können Sie mithilfe des SOLIDWORKS Installations-Managers manuell nach Aktualisierungen suchen oder regelmäßige, automatische Überprüfungen auf Aktualisierungen konfigurieren.

  • SOLIDWORKS Anwendererfahrungs-Optimierungsprogramm

    Während der Installation von SOLIDWORKS können Sie festlegen, dass Leistungsdaten an die SOLIDWORKS Corporation gesendet werden, was zur Produktverbesserung beiträgt.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Administrator-Installationsabbild Options-Editor


Suchen nach SOLIDWORKS Aktualisierungen

Wenn Sie über Administratorrechte auf dem Computer verfügen, können Sie mithilfe des SOLIDWORKS Installations-Managers manuell nach Aktualisierungen suchen oder regelmäßige, automatische Überprüfungen auf Aktualisierungen konfigurieren.

  1. Starten Sie den SOLIDWORKS Installations-Manager, indem Sie einen der folgenden Vorgänge ausführen:

    • Klicken Sie in der SOLIDWORKS Anwendung auf Hilfe > Auf Aktualisierungen prüfen.

    • Klicken Sie in Windows auf Start > Programme > SOLIDWORKS Installations-Manager > Auf Aktualisierungen prüfen.

    Sie können auch auf Start > SOLIDWORKS Installations-Manager > SOLIDWORKS Hintergrund-Downloader klicken. Klicken Sie im Windows-Benachrichtigungsbereich mit der rechten Maustaste auf SOLIDWORKS Hintergrund-Downloader und klicken Sie auf Auf Aktualisierungen prüfen.
    Der SOLIDWORKS Installations-Manager gibt an, ob Aktualisierungen verfügbar sind.
  2. Wenn Aktualisierungen verfügbar sind, haben Sie die Wahl, ob sie heruntergeladen und installiert werden sollen.
  3. Um regelmäßige, automatische Überprüfungen auf das Vorhandensein von Aktualisierungen zu aktivieren, wählen Sie, nachdem der SOLIDWORKS Installations-Manager die Bearbeitung abgeschlossen hat, die Option Nach Aktualisierungen alle __ Tage suchen aus, und geben Sie die Häufigkeit dieser Überprüfungen an.
Übergeordnetes Thema Installation vollständig
SOLIDWORKS Anwendererfahrungs-Optimierungsprogramm


SOLIDWORKS Anwendererfahrungs-Optimierungsprogramm

Während der Installation von SOLIDWORKS können Sie festlegen, dass Leistungsdaten an die SOLIDWORKS Corporation gesendet werden, was zur Produktverbesserung beiträgt.

SOLIDWORKS verwendet diese Informationen, um Tendenzen bei der Produktnutzung und der Qualität festzustellen. Unser Ziel ist es, die höchstmögliche Produktqualität zu liefern, und die Leistungsprotokolle spielen eine wichtige Rolle in diesem Prozess.

Der Vorgang ist transparent. Alle Informationen in den Protokolldateien werden vertraulich behandelt. Sie werden für keine anderen Zwecke genutzt, und niemand wird Sie kontaktieren.

Nähere Informationen dazu finden Sie auf der Website des Anwendererfahrungs-Optimierungsprogramms.

Übergeordnetes Thema Installation vollständig
Suchen nach SOLIDWORKS Aktualisierungen


Installationsort

Für Installationen mit Ausnahme der Administrator-Installationsabbilderstellung gelten die folgenden Optionen:
Ausgewählte Produkte installieren in | Dies ist der Verzeichnisort, an dem Sie SOLIDWORKS installieren. Beim Aktualisieren oder Ändern einer Installation müssen alle Dateien in das bestehende Installationsverzeichnis installiert werden. In diesem Fall können Sie das Verzeichnis, in dem sich die vorhandene SOLIDWORKS Installation befindet, nicht ändern.
Geschätzter erforderlicher Speicher für Installation | Dies ist der Speicherbedarf, der für die zur Installation oder Änderung der ausgewählten Produkte zusätzlich benötigt wird. | Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Installationsanforderungen zu erfüllen.
Installieren von | Dies ist der Verzeichnisort, von dem aus Sie SOLIDWORKS installieren. Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Weitere Informationen finden Sie unter Download-Optionen.
Fragen Sie bei Ihrem Systemadministrator nach, bevor Sie eines der SOLIDWORKS Installationsverzeichnisse ändern.

Administrator-Installationsabbild-Positionen

Beim Erstellen eines Administrator-Installationsabbilds sind die folgenden Optionen verfügbar:
Neue Installationsabbild-Position | Dies ist der Verzeichnisort, an dem der SOLIDWORKS Installations-Manager das neue Installationsabbild erstellt. | Dieses Verzeichnis kann kein bestehendes Administrator-Installationsabbild enthalten.
Geschätzter erforderlicher Speicher für Abbilderstellung | Dies ist der für das Administrator-Installationsabbild erforderliche zusätzliche Speicher. | Stellen Sie sicher, dass sich auf der Festplatte, auf der das Programm installiert werden soll, genügend freier Speicher befindet, um die Anforderungen bzgl. des Installationsabbilds zu erfüllen.
Installationsabbild erstellen von | Dies ist der Verzeichnisort, von dem aus Sie SOLIDWORKS Produkte installieren. Diese Option wird nur angezeigt, wenn die Option Nur installieren ausgewählt wurde. Weitere Informationen finden Sie unter Download-Optionen.
Bestehende Installationsabbild-Position | Wenn ein vorhandenes Administrator-Installationsabbild aktualisiert wird, erstellt der SOLIDWORKS Installations-Manager ein neues Installationsbild auf der Grundlage der Einstellungen für dieses bestehende Installationsabbild. Das bereits vorhandene Installationsabbild wird nicht geändert. Hier wird das Verzeichnis des ursprünglichen Installationsabbilds angezeigt, das Sie auf dem Willkommen-Bildschirm angegeben haben.

Versionsspezifische Verzeichnispfade vermeiden

Falls Sie in einem Installationsverzeichnis eine Versionsnummer angeben (z. B. C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2023\) und diese Installation dann auf SOLIDWORKS 2024 aktualisieren, erhält das SOLIDWORKS 2024 Installationsverzeichnis die Bezeichnung SOLIDWORKS 2023.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Download-Optionen


Aktualisierungsoptionen

Auf diesem Computer sind eine oder mehrere SOLIDWORKS Hauptversionen installiert. Sie können eine neue Installation erstellen, die parallel zu der älteren Version existiert, oder Sie können ein Upgrade durchführen, das die ältere Version entfernt.

Erstellen einer neuen Installation von SOLIDWORKS Version.

Wenn Sie eine neue Installation erstellen, können Sie auswählen, welche SOLIDWORKS Produkte installiert werden sollen.

Für jedes der ausgewählten Produkte wird eine neue Installation dieser Hauptversion erstellt. Die älteren Hauptversionen verbleiben auf dem Rechner, mit Ausnahme von SOLIDWORKS Electrical und SOLIDWORKS PDM Client.

Wenn Sie ein Produkt löschen, wird die neue Version nicht installiert.

Die Erstellung einer neuen Installation ist sinnvoll, wenn Sie auf die ältere Version von SOLIDWORKS zugreifen möchten, nachdem die neuere Version installiert wurde. Wen Sie z. B. Dateien gemeinsam mit anderen Anwendern nutzen, die noch die ältere Version ausführen, können Sie mit Dateien, die in der neueren Version gespeichert wurden, Kompatibilitätsprobleme zwischen den beiden Versionen vermeiden.

Aktualisieren von SOLIDWORKS previous_major_version auf SOLIDWORKS current_major_version.

Wenn Sie ein Upgrade durchführen, können Sie auswählen, welche SOLIDWORKS Produkte aktualisiert werden sollen. Für jedes ausgewählte Produkt wird eine neue Installation erstellt und ältere Versionen werden entfernt.

Wenn Sie die Auswahl eines Produkts aufheben, wird die neue Version nicht installiert und die ältere Version verbleibt auf dem Rechner.

Überlegungen zu SOLIDWORKS Electrical und SOLIDWORKS PDM Client

Sie können nur eine Version von SOLIDWORKS Electrical auf einem Computer installieren. Wenn Sie eine neue Installation von SOLIDWORKS erstellen und SOLIDWORKS Electrical als eines der zu installierenden Produkte auswählen, wird die alte Version von SOLIDWORKS Electrical entfernt.

Sichern Sie Ihre bestehende SOLIDWORKS Electrical Umgebung, bevor Sie eine neue Version installieren. Wählen Sie in SOLIDWORKS Electrical Schematic Datei Anwendungsumgebung archivieren oder in SOLIDWORKS Electrical 3D SOLIDWORKS Electrical > Extras > Anwendungsumgebung archivieren aus.

Die Hauptversion von SOLIDWORKS PDM Client muss mit der Hauptversion von SOLIDWORKS PDM Server übereinstimmen. Wenn Sie SOLIDWORKS PDM Server nicht aktualisieren möchten, wählen Sie SOLIDWORKS PDM Client nicht für das Upgrade aus.

Verwenden Sie zum Entfernen eines Produkts in Windows die Funktion Programme hinzufügen/entfernen. Einzelheiten finden Sie unter Entfernen einer Installation.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Entfernen einer Installation


Installationsfortschritt

Dieser Bildschirm zeigt den Verlauf der Installation.

Um die Installation nach dem Start abzubrechen, klicken Sie auf Abbrechen.

Informationen zu den Konsequenzen eines Abbruchs und Anweisungen zum Abschließen unterbrochener Installationen finden Sie unter Installationsfehler.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Installationstyp

Sie können den Installationsvorgang angeben, den Sie ausführen möchten. So können Sie beispielsweise eine neue Installation erstellen, eine vorhandene Installation ändern oder reparieren, ein Administrator-Installationsabbild erstellen, Verwaltungsserverprodukte installieren oder Dateien herunterladen, um diese gemeinsam zu nutzen und auf anderen Computern zu installieren.

Wenn die neueste Version der SOLIDWORKS Software bereits auf Ihrem Computer installiert ist, haben Sie die Möglichkeit, sie zu modifizieren oder zu reparieren.

Einzelinstallation

Installieren Sie SOLIDWORKS Produkte auf diesem Computer.

Diese Option wird nur angezeigt, wenn die Version aktuell nicht auf diesem Computer installiert ist.

Einzelinstallation ändern

Modifizieren Sie die bestehende SOLIDWORKS Installation auf diesem Computer.

Diese Option wird nur angezeigt, wenn die Version aktuell auf diesem Computer installiert ist.
Die folgenden Modifizierungen sind möglich:
  • Hinzufügen oder Entfernen von SOLIDWORKS Produktkomponenten
  • Umsteigen zu einem anderen SOLIDWORKS Paket (z. B. SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate usw.)
  • Ändern der SOLIDWORKS Seriennummerneinstellung
    Wenn Sie bei einer früheren Installation bereits eine SOLIDWORKS Seriennummer angegeben haben, werden Sie vom SOLIDWORKS Installations-Manager möglicherweise nicht erneut zu deren Eingabe aufgefordert. Um die Seriennummer zu ändern, müssen Sie diese Option auswählen.

Einzelinstallation reparieren

Reparieren Sie die bestehende SOLIDWORKS Installation auf diesem Computer.

Diese Option wird nur angezeigt, wenn die Version aktuell auf diesem Computer installiert ist.
Die Reparatur überprüft, ob alle Dateien vorhanden und ordnungsgemäß registriert sind, und repariert Probleme, die gefunden werden. Daten, die Sie erstellt haben, sind davon nicht betroffen.
  • Stellen Sie sicher, dass ein Produkt, das repariert werden soll, ausgewählt ist.
  • Deaktivieren Sie Kontrollkästchen für Produkte, die nicht repariert werden sollen.
Eine Einzelinstallation kann repariert werden. Eine Administrator-Installationsabbild-Installation kann nicht repariert werden; Sie müssen mithilfe des Administrator-Installationsabbilds eine Deinstallation vornehmen.

Administrator-Installationsabbild

Erstellen oder aktualisieren Sie ein Administrator-Installationsabbild, das auf mehreren Computern bereitgestellt wird.

Einzelheiten zum Installieren von SOLIDWORKS auf mehreren Clients mithilfe von Administrator-Installationsabbildern finden Sie unter Verwenden von Administrator-Installationsabbildern.

Beim Erstellen oder Aktualisieren von Administrator-Installationsabbildern:
  • Sie können zum Konfigurieren des neuen oder aktualisierten Installationsabbilds die Installationseinstellungen eines bestehenden Installationsabbilds oder die standardmäßigen SOLIDWORKS Installationseinstellungen verwenden.
  • Wenn Sie ein bestehendes Installationsabbild aktualisieren:
    • Der SOLIDWORKS Installations-Manager erstellt eine neue Kopie des Installationsabbilds, auch wenn Sie eine Aktualisierung vornehmen. Das ursprüngliche Installationsabbild wird nicht modifiziert.
    • Sie können das aktualisierte Installationsabbild mit Dateien aus dem bestehenden, von Ihnen aktualisierten Installationsabbild erstellen. Dies hat einen kleineren Download zur Folge.
    Wenn Sie kein Installationsabbild angeben, für das ein Service Pack zum Aktualisieren des älteren Installationsabbilds verfügbar ist, können Sie die Vorteile des kleineren Downloads nicht nutzen.

Server-Produkte

SOLIDWORKS Server-Produkte sind SOLIDWORKS Electrical, SOLIDWORKS PDM und SolidNetWork License Manager.

Bei SOLIDWORKS Electrical und SOLIDWORKS PDM können Sie die Client- und Serverwerkzeuge auf demselben Computer oder auf unterschiedlichen Computern installieren.

Einzelheiten zum Installieren dieser Server finden Sie unter den entsprechenden Themen in der Hilfe.

Alle Dateien herunterladen und teilen

Laden Sie die Installationsdateien für ausgewählte SOLIDWORKS Produkte herunter, ohne die Produkte zu installieren.

Diese Option wird nicht angezeigt, wenn Sie die Installation von einer DVD durchführen.
Der Inhalt der heruntergeladenen Dateien ist mit dem Inhalt der Dateien identisch, die auf den SOLIDWORKS Installations-DVDs verfügbar sind. Bei Auswahl dieser Option wird der vollständige Installationsdateisatz heruntergeladen, ungeachtet dessen, welche Dateien bereits auf dem Computer installiert sind. Anschließend können Sie die Dateien auf einen Wechseldatenträger oder in ein Netzwerkverzeichnis kopieren und sie verwenden, um die SOLIDWORKS Software auf anderen Computern zu installieren. Sie können diese Methode auch verwenden, um einen Server einzurichten, von dem Anwender Installationen ausführen können.
Diese Methode unterscheidet sich von der Erstellung eines Administrator-Installationsabbilds.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Administrator-Installationsabbilder verwenden
Lizenzen mit einem SolidNetWork License Manager verwalten
SOLIDWORKS Electrical


Installieren und Verwalten mehrerer Computer

Der SOLIDWORKS Installations-Manager bietet die folgenden Werkzeuge zum Installieren auf mehreren SOLIDWORKS Computern und deren Verwaltung.

SOLIDWORKS Administrator-Installationsabbilder

Wenn Sie SOLIDWORKS auf mehreren Computern installieren, können Sie ein Administrator-Installationsabbild erstellen und dann die Anwendung auf anderen Computern bereitstellen.

SOLIDWORKS PDM

SOLIDWORKS PDM ist ein Produkt zur Dokumentenverwaltung, das auf derselben Client-/Server-Architektur basiert wie SOLIDWORKS Enterprise PDM. Es ist in zwei Versionen verfügbar: Standard und Professional. SOLIDWORKS PDM verwendet eine Microsoft SQL Server-Datenbank für die Verwaltung von Dateitresoren.

SolidNetWork Lizenz-Manager

Der SolidNetWork License Manager ermöglicht durch den variablen Einsatz von Lizenzen, dass die Anzahl der Anwender über die Anzahl der Lizenzen hinausgeht. Wenn eine Client-Lizenz nicht in Verwendung ist, ist sie für einen anderen SOLIDWORKS Anwender verfügbar.

Sie können den SolidNetWork License Manager auch dafür verwenden, Lizenzen für die wichtigsten SOLIDWORKS Zusatzanwendungen (z. B. FeatureWorks) zu verteilen.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Manueller Download

Sie haben sich für das manuelle Herunterladen von Dateien entschieden (oder Sie haben diese Entscheidung möglicherweise getroffen, als Sie den SOLIDWORKS Installations-Manager zum letzten Mal ausgeführt haben).

Klicken Sie auf den Link, um eine automatisch erzeugte Webseite zu öffnen, die eine vollständige Liste der Dateien enthält, die Sie zum Abschließen des Downloads benötigen.

Sie müssen die Dateien in einen auf der Seite „Zusammenfassung“ angegebenen Ordner herunterladen. Die Installation kann erst beginnen, wenn alle Dateien in diesen Ordner heruntergeladen wurden.

Nachdem Sie die Dateien manuell heruntergeladen haben, klicken Sie auf Weiter, um fortzufahren.

Wenn Sie einen automatischen Download wünschen, können Sie diese Option anders einstellen, indem Sie zur Seite „Zusammenfassung“ zurückkehren und unter „Download-Optionen“ die entsprechende Änderung vornehmen.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Neuere Version verfügbar

Der Installations-Manager hat eine neuere Version von SOLIDWORKS Produkten gefunden. Sie können die Version von der ursprünglichen Installations-DVD oder dem ursprünglichen Download installieren oder die neuere Version herunterladen und installieren.

Wenn Sie von einem Download installieren

Wählen Sie eine der folgenden Optionen aus:
  • Installation von Version fortsetzen.

    Wählen Sie diese Option aus, um die Version des ersten Downloads zu installieren.

  • Eine neue Version herunterladen und installieren: Version.

    Wählen Sie diese Option zum Herunterladen und Installieren der neuen Version aus. Wenn mehrere neue Versionen verfügbar sind, können Sie die Version für den Download und die Installation auswählen.

Wenn Sie von einer DVD installieren

Wählen Sie unter Möchten Sie die neuere Version verwenden? eine der folgenden Optionen:
  • Nein, Version weiter von dieser DVD installieren. Sie können danach aktualisieren.

    Wählen Sie diese Option aus, um mit der Installation mittels des aktuellen Installations-Managers fortzufahren.

    Nach der Installation können Sie mit dem Installations-Manager prüfen, ob Aktualisierungen vorhanden sind, und diese installieren. Klicken Sie auf Start > SOLIDWORKS Installations-Manager > Nach Updates suchen, um zu prüfen, ob Aktualisierungen zum Herunterladen verfügbar sind.
    Nach Updates suchen ist nur verfügbar, wenn Sie über Administratorrechte auf dem Computer verfügen.

    Dies hat einen kleineren Download zur Folge. Andererseits handelt es sich hierbei um einen Zwei-Schritt-Vorgang und sind die heruntergeladenen Dateien versionsspezifisch (und können von anderen Anwendern, die andere Versionen verwenden, nicht genutzt werden).

  • Ja, Installation mit dieser DVD ausführen; dann herunterladen und auf version aktualisieren.

    Wählen Sie diese Option, um eine spätere Version des Installations-Managers herunterzuladen und auszuführen, um SOLIDWORKS Produkte für diese Version zu installieren.

    Wenn zur Aktualisierung der DVD-Version eine kleine Service Pack-Version verfügbar ist, installiert der Installations-Manager die Originalversion von der DVD und aktualisiert das Programm dann mit dem Service Pack. Dies hat einen kleineren Download zur Folge.

    Sie können das gleiche Ergebnis erzielen, wenn Sie die Option zur Fortsetzung der Installation von der DVD auswählen und die Aktualisierung später durchführen.

    Diese Option hat den Vorteil, dass sie nur einen einzigen Verfahrensschritt erfordert.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Keine neuen Versionen verfügbar

Es stehen keine neueren Versionen zum Download bereit. Fahren Sie mit der Installation der angegebenen Version fort.

Um mit der Installation fortzufahren, klicken Sie auf Weiter.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Festgestellte Prozesse

Der SOLIDWORKS Installations-Manager hat auf diesem Computer laufende Prozesse festgestellt, die eine erfolgreiche Installation verhindern könnten.

  • Um die Installation fortzusetzen, führen Sie einen der folgenden Schritte aus:
    • Schließen Sie die betroffenen Prozesse (z. B. den Microsoft Windows Task-Manager) und klicken Sie auf Wiederholen.
    • Klicken Sie auf Ignorieren, um ohne Schließen der Prozesse fortzufahren.
  • Zum Beenden der Installation klicken Sie auf Abbrechen.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Produktauswahl

Sie können die Produktkomponenten angeben, die installiert, modifiziert, heruntergeladen oder entfernt werden sollen.

Auf der Produktliste:
  • Die Produktliste ist die Liste aller Produkte, die in dem über der Produktliste angegebenen Paket verfügbar sind.
  • Klicken Sie, um die projizierte Aktion für eine bestimmte Komponente zu sehen, auf den Namen der Komponente (aber nicht auf das Kontrollkästchen). Die gewünschte Installationsaktion erscheint im Informationsfeld unter der Produktauflistung.
  • Sie können auf das Kontrollkästchen neben der Produktkomponente klicken, um die Installationsaktion für diese Komponente zu ändern. (Beispiel: Wenn Sie Komponenten installieren oder entfernen, legt die Aktivierung des Kontrollkästchens fest, dass die Komponente zu installieren oder zu entfernen ist, und die Deaktivierung des Kontrollkästchens legt fest, dass die Komponente nicht zu installieren oder zu entfernen ist.)
  • Wenn Sie eine Modifizierungsinstallation durchführen, erscheint links von den einzelnen Komponenten ein Sternchen (*), wenn Sie eine Änderung an der Produktauswahl vornehmen.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird neben der Komponente das Symbol - angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.

Wenn Sie ein Service Pack anwenden, können Sie SOLIDWORKS Features (wie z. B. FeatureWorks), die unter SOLIDWORKS erscheinen, nicht auswählen. Der Grund dafür ist, dass Sie ein Feature weder hinzufügen oder entfernen können, wenn Sie diese Art von Aktualisierung auswählen.

Die Operationen, die vom SOLIDWORKS Installations-Manager ausgeführt werden, werden von einer Reihe von Produkt-Koexistenzregeln gesteuert. Einzelheiten finden Sie unter Produkt-Koexistenzregeln.

Der SOLIDWORKS Installations-Manager wählt standardmäßig die folgenden Produktkomponenten aus:
  • Wenn Sie eine Aktualisierung oder eine Service Pack-Aktualisierung durchführen, wählt der SOLIDWORKS Installations-Manager die aktuell installierten Produkte aus.
  • Andernfalls wählt der SOLIDWORKS Installations-Manager alle Produkte aus, für die Sie eine Berechtigung besitzen.
Um die Installations- oder Download-Zeit zu verkürzen und den Festplatten-Speicherbedarf zu verringern, klappen Sie die Produktkomponenten auf, und entfernen Sie die Markierung aus dem Kontrollkästchen für die nicht benötigten Komponenten.

Wenn der SOLIDWORKS Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie auf Verschiedene Pakete oder Produkte auswählen klicken, um ein anderes aufgeführtes Produktpaket (z. B. SOLIDWORKS Professional oder SOLIDWORKS Premium oder SOLIDWORKS Ultimate) für die Installation oder Modifikation zu bestimmen. Der SOLIDWORKS Installations-Manager führt alle SOLIDWORKS Produkte auf Ihrem Installationsmedium auf, die mit dem ausgewählten Paket kompatibel sind. Sie können alle Produkte auswählen, die Sie käuflich erworben haben oder zu deren Evaluierung Sie berechtigt sind.

SOLIDWORKS Suche

SOLIDWORKS Suche bietet eine leistungsstarke Volltextsuche in SOLIDWORKS Dokumenten. Die Suche zeigt eine Vorschau und die Dateiposition und den -namen an.

Nach der Installation indiziert SOLIDWORKS Suche SOLIDWORKS Dokumente, um schnellere Suchvorgänge zu gewährleisten. Nur SOLIDWORKS Dateien werden standardmäßig indiziert.

Sprachunterstützung

Blenden Sie das SOLIDWORKS Produkt und die Komponente Sprachen ein, um die installierbaren Sprachen anzuzeigen.

Die Spezifikation Sprachen begrenzt nur die Sprachen, die für das SOLIDWORKS Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. Zum Beispiel werden für eDrawings® und SOLIDWORKS PDM alle vorhandenen Sprachen installiert.

Benötigter Speicherplatz

Der SOLIDWORKS Installations-Manager gibt entweder die Gesamtinstallationsgröße oder die Gesamt-Download-Größe unten auf der Seite an.

  • Wenn Sie die Option Nur Download ausgewählt haben, wird die Größe des Downloads angezeigt. Download-Größe ist die Gesamtmenge des Festplattenspeicherbedarfs für alle heruntergeladenen Dateien (Extrabedarf für das Entpacken der Dateien nach dem Download nicht eingerechnet). Es handelt sich dabei um einen Schätzwert.
    Alle Dateien, die für die Installation erforderlich sind, sind in der Gesamt-Download-Größe erfasst. Wenn einige Dateien bereits in den aktuellen Download-Ordner heruntergeladen wurden, werden sie nicht erneut heruntergeladen. Folglich kann die aktuelle Download-Größe kleiner sein als die angezeigte Gesamt-Download-Größe oder es kann auch sein, dass Sie keine Dateien herunterladen müssen.
  • Ansonsten wird Installationsgröße angezeigt. Installationsgröße ist die Änderung des Festplattenspeicherbedarfs, die auftritt, wenn diese Installation abgeschlossen ist. Aufgrund der Dateikomprimierung sind diese Zahlen stets lediglich Schätzwerte.

    Wenn Sie eine bestehende Installation aktualisieren oder entfernen, kann die Installationsgröße Null sein.

    Die angezeigte Zahl beinhaltet nicht den Speicherplatz, der für den Download oder das Extrahieren der Installationsdateien erforderlich ist.

    Wenn Downloads erforderlich sind und Sie auf dasselbe Laufwerk herunterladen, könnte der tatsächliche Speicherbedarf bedeutend größer sein als die angezeigte Installationsgröße.

    Um die Download- oder Installationszeit für zukünftige Modifizierungen zu reduzieren, löschen Sie die heruntergeladenen Dateien nach der Installation nicht. Folgeaktualisierungen und Patches benötigen normalerweise Zugriff auf den letzten vollständigen Installationsdateisatz.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Produkt-Koexistenzregeln


Produkte zum Herunterladen

Wählen Sie SOLIDWORKS Produkte zum Herunterladen an einen bestimmten Ablageort aus.

Die Produkte, die heruntergeladen werden können, werden durch die Seriennummer, die Sie bereitgestellt haben, bestimmt:

  • Die Aktion, die für die einzelnen Komponenten ausgeführt werden soll, wird rechts von einem jeden Element angezeigt.
  • Wenn zu einer Komponente optionale Unterkomponenten gehören, wird neben der Komponente das Symbol + angezeigt. Um die verfügbaren Unterkomponenten einer Komponente anzuzeigen, klicken Sie auf das Symbol +.
  • Wenn eine Komponente erweitert wurde, um optionale Unterkomponenten anzuzeigen, wird das Symbol - neben der Komponente angezeigt. Um die Unterkomponentenliste zuzuklappen, klicken Sie auf das Symbol -.
  • Klicken Sie auf das Kontrollkästchen links von jeder Komponente, um auszuwählen, wie es vom SOLIDWORKS Installations-Manager gehandhabt werden soll.
Der SOLIDWORKS Installation-Manager lädt alle Produktkomponenten herunter, für die Sie eine Berechtigung haben, sofern Sie nichts anderes festlegen. Um die Download-Zeit zu verkürzen und den Festplatten-Speicherbedarf zu verringern, klappen Sie die Produktkomponenten auf und wählen Sie die Komponenten, die Sie nicht benötigen.

Wenn der SOLIDWORKS Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie ein SOLIDWORKS Paket zum Herunterladen auswählen. Der SOLIDWORKS Installations-Manager führt alle SOLIDWORKS Produkte auf, die mit dem ausgewählten Paket kompatibel sind.

Wenn der SOLIDWORKS Installations-Manager die Produkte, für die Sie eine Berechtigung haben, nicht verifizieren konnte, können Sie auf Verschiedene Pakete oder Produkte auswählen klicken, um ein anderes aufgeführtes Produktpaket (z. B. SOLIDWORKS Professional oder SOLIDWORKS Premium oder SOLIDWORKS Ultimate) für die Installation oder Modifikation zu bestimmen. Der SOLIDWORKS Installations-Manager führt alle SOLIDWORKS Produkte auf Ihrem Installationsmedium auf, die mit dem ausgewählten Paket kompatibel sind. Sie können alle Produkte auswählen, die Sie käuflich erworben haben oder zu deren Evaluierung Sie berechtigt sind.

Sprachunterstützung

Die Spezifikation „Sprachen“ limitiert nur die Sprachen, die für das SOLIDWORKS Produkt installiert werden. Andere Produktinstallationen sind von dieser Spezifikation nicht betroffen. Für eDrawings® werden beispielsweise alle Sprachen installiert.

Benötigter Speicherplatz

Basierend auf den ausgewählten Produkten wird der Speicherplatz angezeigt, der für die Durchführung des Downloads benötigt wird. Download-Größe ist die Gesamtmenge des Festplattenspeicherbedarfs für alle heruntergeladenen Dateien (Extrabedarf für das Entpacken der Dateien nach dem Download nicht eingerechnet). Es handelt sich dabei um einen Schätzwert.

Um die Download- oder Installationszeit für zukünftige Aktualisierungen und Patches zu reduzieren, löschen Sie die heruntergeladenen Dateien nach der Installation nicht. Folgeaktualisierungen und Patches benötigen normalerweise Zugriff auf den letzten vollständigen Installationsdateisatz.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Zu reparierende Produkte

Wenn Sie Diese Installation reparieren auswählen, zeigt dieser Bildschirm die SOLIDWORKS Produkte mit den Versionsnummern an, die von dieser Version des SOLIDWORKS Installations-Managers repariert werden können.

Die Reparatur überprüft, ob alle Dateien vorhanden und ordnungsgemäß registriert sind, und repariert Probleme, die gefunden werden. Daten, die Sie erstellt haben, sind davon nicht betroffen.
  • Stellen Sie sicher, dass ein Produkt, das repariert werden soll, ausgewählt ist.
  • Deaktivieren Sie Kontrollkästchen für Produkte, die nicht repariert werden sollen.

Klicken Sie auf Reparieren, um mit dem Reparieren der ausgewählten Produkte zu beginnen.

Eine Einzelinstallation kann repariert werden. Eine Administrator-Installationsabbild-Installation kann nicht repariert werden; Sie müssen das Administrator-Installationsabbild erneut installieren.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Seriennummern

Seriennummern verknüpfen Ihren Computer mit den von Ihnen erworbenen SOLIDWORKS Produkten.

Wenn auf Ihrem Computer bereits SOLIDWORKS Produkte installiert sind, werden standardmäßig deren Seriennummern angezeigt:
  • Wenn Ihre SOLIDWORKS Seriennummer nicht angezeigt wird, geben Sie sie ein.
  • Wenn Sie Seriennummern für Produkte haben, die nicht in Ihrer SOLIDWORKS Lizenz enthalten sind, geben Sie sie in die entsprechenden Felder ein.

Wenn Sie eine Internetverbindung haben, bestimmen die von Ihnen angegebenen Seriennummern, zu welchen Produkten Sie berechtigt sind, während Sie den Installationsprozess fortsetzen.

Da es viele Möglichkeiten gibt, SOLIDWORKS Produkte zu erwerben, können einige Seriennummern zwei oder mehr Produkte abdecken. So kann eine SOLIDWORKS Seriennummer Ihnen beispielsweise gestatten, SOLIDWORKS Simulation zu installieren, ohne eine separate SOLIDWORKS Simulation Seriennummer eingeben zu müssen. Zudem benötigen einige Produkte keine Seriennummer. Wenn Sie Fragen zu Ihren Seriennummern haben, wenden Sie sich an Ihren Fachhändler.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Server-Installation

Die Server-Produkte, die Sie zu installieren versuchen, sind mit den Ergebnissen der Installation aufgeführt.

Server-Installationsstatus

Installationen von Server-Produkten werden über eine externe Installationsanwendung durchgeführt. Wenn diese Anwendung nicht geöffnet ist, müssen Sie zu ihr wechseln, um die Installation abzuschließen.

Klicken Sie auf Abbrechen, um die Server-Produkt-Installationen zu beenden.

Server-Installation abgeschlossen

Die externe Installationsanwendung wurde erfolgreich abgeschlossen.

Klicken Sie auf Fertig stellen oder Weiter.
  • Wenn Sie auch andere Administrator-Produkte (z. B. ein SOLIDWORKS Administrator-Installationsabbild) installieren, wird diese Installation fortgesetzt.
  • Falls es sich bei den Server-Produkt-Installationen um den einzigen Installationsvorgang handelt, wird der SOLIDWORKS Installations-Manager geschlossen.

Server-Installation abgebrochen oder fehlgeschlagen

Wenn die Installation eines Server-Produkts fehlschlug oder abgebrochen wurde, während sie bereits lief, werden die Server, die nicht installiert wurden, aufgeführt.

Klicken Sie auf Schließen oder Weiter.
  • Wen Sie Installationen weiterer Administrator-Produkte ausgewählt haben, wird der SOLIDWORKS Installations-Manager fortgesetzt.
  • Falls es sich bei den Server-Produkt-Installationen um den einzigen Installationsvorgang handelt, wird der SOLIDWORKS Installations-Manager geschlossen.

Weitere Informationen

Details über die Installation, Konfiguration und Verwendung von SolidNetWork License Manager finden Sie unter Lizenzen mit einem SolidNetWork License Manager verwalten.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Zusammenfassung

Der SOLIDWORKS Installations-Manager verfügt über alle für die Durchführung der Installation erforderlichen Informationen.

Fahren Sie wie folgt fort: | Klicken Sie auf Jetzt Aktion, um den Installationsvorgang zu starten (z. B. Jetzt installieren, Jetzt erstellen, Jetzt herunterladen, Jetzt modifizieren).
Ändern der Installationseinstellungen: | Klicken Sie für den Abschnitt, an dem Sie Änderungen vornehmen möchten, auf ÄNDERN [image] (z. B. Produkte, Installationsort, Toolbox Optionen).
Abbrechen:. | Klicken Sie auf Abbrechen, um den SOLIDWORKS Installations-Manager zu beenden, ohne Installationskomponenten zu ändern.
Zurückkehren zu einer vorherigen Seite: | Klicken Sie auf Zurück, um zu einer vorherigen Seite im SOLIDWORKS Installations-Manager zurückzukehren.
Anzeigen von Informationen über eine bestimmte Gruppe von Installationsoptionen (z. B. Produkte, Installationsort, Toolbox Optionen usw.):
  1. Klicken Sie neben dem Abschnitt, für den Sie Informationen einsehen möchten, auf ÄNDERN [image].
  2. Klicken Sie auf der daraufhin angezeigten Detailseite auf Hilfe, um Informationen über die Einstellungen dieser Installationsoption anzuzeigen.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Warnungen bei der Systemprüfung

Die Systemprüfung hat Probleme gemeldet, die sich auf die weitere Installation auswirken könnten. In den meisten Fällen sollten Sie mit dem SOLIDWORKS Installations-Manager fortfahren können.

Es folgen Warnungen, die in diesem Stadium ausgegeben werden können, und entsprechende empfohlene Maßnahmen.

Probleme bei der Seriennummervalidierung

Der Installations-Manager konnte nicht nach neuen Versionen suchen, da Ihre Seriennummer nicht validiert werden konnte. Wenn Sie eine aktive Verbindung zum Server haben und eine gültige Seriennummer eingegeben haben, könnte dies auf ein temporäres Problem auf unserem Server hinweisen. Versuchen Sie es später noch einmal.

Seriennummervalidierung: Der Installations-Manager konnte Ihre Seriennummer nicht validieren, um die Produkte zu ermitteln, zu deren Installation Sie berechtigt sind. Sie werden weiterhin die Produkte, die Sie installieren möchten, auswählen aber keine Installationsdateien herunterladen können. Sie müssen einen vollständigen Satz an Download-Quelldateien oder eine DVD für die Installation bereit stellen.

Auflösung:
  • Prüfen Sie die Internetverbindung. Für die Seriennummervalidierung ist eine funktionierende Internetverbindung erforderlich.
  • Überprüfen Sie, ob die eingegebene Seriennummer für die Produkte gilt, die Sie installieren möchten.
  • Bei bestimmten Installationen ist es erforderlich, dass zum Zeitpunkt der Freigabe der Version ein gültiger Subskriptionsvertrag besteht. Nähere Informationen dazu erhalten Sie von Ihrem SOLIDWORKS Fachhändler.
  • In den meisten Fällen können Sie die Installation fortsetzen, vorausgesetzt, Sie installieren von einer DVD oder einem zuvor heruntergeladenen Dateisatz.

Neuere Version verfügbar

Neuere Version verfügbar

Neue Versionen verfügbar

Eine neuere Version dieses Produkts steht zum Download bereit.

Auflösung: Beim Ausführen der Funktion "Nach Aktualisierungen suchen" werden Sie möglicherweise aufgefordert, eine neuere Version zu installieren, die zum Download auf der SOLIDWORKS Website bereit steht. Sie können den Vorgang mit der ursprünglich angegebenen Version fortsetzen oder die neuere Version herunterladen und den Vorgang mit der neueren Version fortsetzen.

Neueste verfügbare Version

Dies ist die neueste verfügbare Version. Klicken Sie zum Fortfahren auf "Weiter".

Keine neuen Downloads verfügbar

Lösung: Diese Meldung kann erscheinen, wenn während einer Installation oder Modifizierung nach Aktualisierungen gesucht wird. Die Meldung weist darauf hin, dass Sie die neuste verfügbare Version installieren bzw. installiert haben.

Probleme mit der Internetverbindung

Internetverbindung: Der Installations-Manager konnte keine Verbindung zum SOLIDWORKS Server herstellen, um die Produkte zu ermitteln, zu deren Installation Sie berechtigt sind. Sie werden weiterhin die Produkte, die Sie installieren möchten, auswählen aber keine Installationsdateien herunterladen können. Sie müssen Quelldateien auf DVD oder einen zuvor heruntergeladenen Dateisatz bereitstellen.

Es kann nicht nach neuen Versionen gesucht werden

Der Installations-Manager konnte nicht nach neuen Versionen suchen, da eine Verbindung zum Server nicht hergestellt werden konnte.

Lösung:
  • Prüfen Sie die Internetverbindung.
  • Sie können die Installation fortsetzen, vorausgesetzt, Sie installieren von einer DVD oder einem zuvor heruntergeladenen Dateisatz.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Bohrungsassistent/Toolbox-Optionen

Wenn Sie SOLIDWORKS Toolbox installieren, enthält SOLIDWORKS eine Standardbibliothek von Bohrungstypen und Hardware.

Einzelheiten zur Konfiguration, Erweiterung und Verwendung von SOLIDWORKS Toolbox finden Sie in der SOLIDWORKS Hilfe im Abschnitt „Toolbox“.

Bevor Sie eine SOLIDWORKS Toolbox verwenden, stellen Sie sicher, dass Sie sie entsprechend Ihrer Unternehmens- oder Gruppenrichtlinie konfigurieren. In vielen Fällen konfiguriert und unterhält eine Gruppe eine zentrale Toolbox. Lassen Sie sich vom SOLIDWORKS Administrator über die Auswahl einer Toolbox während der SOLIDWORKS Installation beraten.

Sie können die ausgewählte SOLIDWORKS Toolbox nach der Installation wieder ändern. Klicken Sie in SOLIDWORKS auf Extras > Optionen. Klicken Sie auf der Registerkarte Systemoptionen auf Bohrungsassistent/Toolbox.

In den folgenden Abschnitten sind alle Optionen beschrieben, die auf diesem Bildschirm für alle Konfigurationen möglich sind. Die tatsächlich angezeigten Toolbox Optionen hängen von den bereits vorhandenen SOLIDWORKS und Toolbox Konfigurationen auf diesem Computer und den bisher ausgewählten Optionen des SOLIDWORKS Installations-Managers ab.

Erstellen einer neuen new-version Toolbox

Erstellen Sie eine neue Version von SOLIDWORKS Toolbox auf diesem Computer.

Wenn Sie eine neue Version erstellen, erweitern Sie im Bildschirm für die Produktauswahl SOLIDWORKS > SOLIDWORKS Toolbox und wählen Sie die Normen aus, die für die Toolbox unterstützt werden sollen. Alle Normen sind standardmäßig ausgewählt.

Keine der auf diesem Computer bereits vorhandenen Toolboxes werden modifiziert.

Referenzieren oder Aktualisieren einer vorhandenen Toolbox

Verwenden Sie eine bestehende Toolbox. Klicken Sie auf Durchsuchen, um den Ablageort der Toolbox festzulegen, die zusammen mit dieser Installation verwendet werden soll.

  • Wenn die Toolbox für eine ältere SOLIDWORKS Hauptversion konfiguriert ist, wird sie auf diese Version aktualisiert. Alle an dieser Toolbox vorgenommenen Anpassungen bleiben in der aufgerüsteten Toolbox erhalten.
    Durch die Aktualisierung einer Toolbox auf eine neue SOLIDWORKS Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SOLIDWORKS Hauptversionen ausgeführt werden.
  • Wenn die Toolbox für diese SOLIDWORKS Version konfiguriert ist (was der Fall sein könnte, wenn Sie eine bereits aktualisierte Toolbox auf einem freigegebenen Netz festlegen), findet keine Aktualisierung dieser Toolbox statt.
  • Wenn Sie eine Toolbox in einer SOLIDWORKS PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Hinweise zur Konfiguration von SOLIDWORKS Toolbox.

Diese Option erscheint in allen Installationsszenarien mit Ausnahme des Szenarios für die Erstellung eines Administrator-Installationsabbilds.

Aktualisieren einer previous-version Toolbox

Kopieren Sie eine für eine ältere Hauptversion konfigurierte Toolbox an einen neuen Speicherort und aktualisieren Sie diese Kopie auf diese Version.

Diese Option erscheint, wenn auf diesem Computer eine ältere SOLIDWORKS Hauptversion installiert ist, Sie aber entschieden haben, diese Installation dieser Version nicht zu aktualisieren.
Der Zweck dieser Option besteht in der Aktualisierung einer Toolbox für eine ältere installierte SOLIDWORKS Hauptversion, ohne dass Anwender, die die ältere Toolbox Version verwenden, in ihrer Arbeit beeinträchtigt werden.

Wenn Sie eine Toolbox in einer SOLIDWORKS PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Hinweise zur Konfiguration von SOLIDWORKS Toolbox.

Aktualisieren dieser installierten previous-version Toolbox

Aktualisieren Sie diese Toolbox auf die neuere Version.
Durch die Aktualisierung einer Toolbox auf eine neue SOLIDWORKS Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SOLIDWORKS Hauptversionen ausgeführt werden.

Diese Option wird angezeigt, wenn Sie eine ältere SOLIDWORKS Hauptversion auf diese Version aktualisieren und auf diesem Computer eine für diese ältere Version konfigurierte Toolbox vorgefunden wird.

Wenn Sie eine Toolbox in einer SOLIDWORKS PDM Umgebung aktualisieren, sind zusätzliche Verfahren erforderlich. Einzelheiten finden Sie unter Hinweise zur Konfiguration von SOLIDWORKS Toolbox.

Gebrauch der installierten current-version Toolbox

Der SOLIDWORKS Installations-Manager hat auf diesem Computer eine Toolbox festgestellt, die für diese SOLIDWORKS Hauptversion konfiguriert ist.

Wenn Sie diese Option auswählen, verwendet SOLIDWORKS diese Toolbox. Es findet keine Aktualisierung statt.

Diese Option erscheint, wenn auf diesem Computer eine ältere SOLIDWORKS Hauptversion installiert ist, aber eine Toolbox für diese Version konfiguriert ist. Diese Situation kann eintreten, wenn auf einem Computer, auf dem noch eine ältere SOLIDWORKS Version läuft, eine freigegebene Toolbox erstellt wird.

Toolbox Ablageort für den Client-Computer festlegen

Legen Sie einen Netzwerk- oder Verzeichnisort als Toolbox Standardablageort fest, wenn Clients eine Installation von einem Administrator-Installationsabbild aus durchführen.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SOLIDWORKS Hauptversion konfiguriert ist, aktualisiert der SOLIDWORKS Installations-Manager diese Toolbox.

Diese Option erscheint, wenn Sie ein neues Administrator-Installationsabbild erstellen.

Toolbox, auf die im bestehenden Installationsabbild für den Client-Computer Bezug genommen wird, aktualisieren oder verwenden

Verwenden Sie den Toolbox-Speicherort, der in einem bestehenden Administrator-Installationsabbild angegeben ist, das Sie aktualisieren.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SOLIDWORKS Hauptversion konfiguriert ist, aktualisiert der SOLIDWORKS Installations-Manager diese Toolbox.

Anderen Toolbox Ablageort für den Client-Computer festlegen

Geben Sie einen anderen Toolbox-Speicherort als denjenigen an, der in einem bestehenden Administrator-Installationsabbild angegeben ist, das Sie aktualisieren.
Wenn dieser Speicherort zum Zeitpunkt der Client-Installation eine Toolbox enthält, die für eine ältere SOLIDWORKS Hauptversion konfiguriert ist, aktualisiert der SOLIDWORKS Installations-Manager diese Toolbox.

Inhaltsverzeichnis

  • Hinweise zur Konfiguration von SOLIDWORKS Toolbox

    SOLIDWORKS Toolbox bietet leistungsfähige und komplexe Funktionen. In diesem Thema sind einige Konzepte zusammengefasst, die vor der Konfiguration einer Toolbox mit dem SOLIDWORKS Installations-Manager in Betracht zu ziehen sind.

  • UNC-Format

    Die Uniform (bzw. Universal) Naming Convention ist ein Format, das zur Beschreibung eines freigegebenen Dateispeicherorts eine bestimmte Dateinamensyntax vorschreibt.

Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe
Hinweise zur Konfiguration von SOLIDWORKS Toolbox


Hinweise zur Konfiguration von SOLIDWORKS Toolbox

SOLIDWORKS Toolbox bietet leistungsfähige und komplexe Funktionen. In diesem Thema sind einige Konzepte zusammengefasst, die vor der Konfiguration einer Toolbox mit dem SOLIDWORKS Installations-Manager in Betracht zu ziehen sind.

Weitere Informationen über SOLIDWORKS Toolbox

Einzelheiten zur Konfiguration, Erweiterung und Verwendung von SOLIDWORKS Toolbox finden Sie in der SOLIDWORKS [image] Hilfe im Abschnitt „Toolbox“.

Gebrauch einer freigegebenen Toolbox

Bei der Installation von Toolbox können Toolbox Daten auf dem lokalen Computer oder in einem freigegebenen Verzeichnis gespeichert werden. Empfohlen wird die Speicherung der Toolbox Daten in einem freigegebenen Netzwerkverzeichnis. Durch die Verwendung eines gemeinsamen Verzeichnisses ist sichergestellt, dass alle SOLIDWORKS Anwender dieselben Verbindungselementdaten verwenden.

Wenn dies eine Erstinstallation ist, gehen Sie zum neuen freigegebenen Verzeichnis, in dem Toolbox installiert werden soll.

Aktualisierung einer bestehenden Toolbox Anwendung

Durch die Aktualisierung einer Toolbox auf eine neue SOLIDWORKS Hauptversion wird diese Toolbox mit jedem Computer inkompatibel, auf dem ältere SOLIDWORKS Hauptversionen ausgeführt werden.

Wenn andere Computer auf der vorherigen Hauptversion bleiben und weiterhin eine für diese Version konfigurierte Toolbox benötigen, erstellen Sie eine Kopie dieser Toolbox und aktualisieren Sie diese Kopie. Die neue SOLIDWORKS Installation aktualisiert die Kopie der Toolbox, und die vorherigen SOLIDWORKS Installationen verwenden weiterhin die alte Toolbox.

Toolbox Zugriff konfigurieren

Wenn Sie nach der Installation auf Toolbox Komponenten zugreifen, überprüft SOLIDWORKS die Toolbox Konfiguration und macht Vorschläge zur Verbesserung des Zugriffs und der Leistung.

Verwenden Sie für den Zugriff auf Toolbox auf einem freigegebenen Netz (empfohlen), einen UNC-Pfad zum Server, auf dem die freigegebene Toolbox installiert wurde. Einzelheiten finden Sie unter UNC-Format.

Der Administrator kann ein Passwort für Toolbox erstellen sowie Zugriffsrechte und Anwendereinstellungen für die Arbeitsgruppe festlegen. Durch die Beschränkung des Zugriffs auf die Konfiguration und die Einrichtung gemeinsamer Anwendereinstellungen wird sichergestellt, dass konsistente Toolbox Daten verwendet werden.

Aktualisieren von Toolbox in einer SOLIDWORKS PDM Umgebung

Wenn Sie die SOLIDWORKS Software aktualisieren, wird auch Toolbox aktualisiert, sofern Teile hinzugefügt wurden. Wenn sich das Toolbox Stammverzeichnis in einem Tresor von SOLIDWORKS PDM befindet, müssen Sie vor der SOLIDWORKS Aktualisierung den Toolbox Ordner vorbereiten.

Auf dem ersten System, auf dem die Aktualisierung durchgeführt werden soll, müssen Sie die Toolbox Datenbank auschecken und mit dem Befehl Neueste Version holen die Toolbox Dateien in den lokalen Cache herunterladen. Bei anderen zu aktualisierenden Systemen müssen nur die Toolbox Dateien heruntergeladen werden.

Vor der Aktualisierung:
  • Stellen Sie sicher, dass eine komplette aktuelle Sicherung der Tresordatenbank und des Archivs vorhanden ist.
  • Stellen Sie sicher, dass die Toolbox Teile nicht ausgecheckt sind oder von ausgecheckten Baugruppen verwendet werden.

Aktualisierung von Toolbox:

  1. Melden Sie sich im Datei-Explorer beim Tresor als Benutzer mit vollständigen Berechtigungen an (Auschecken, Einchecken, Hinzufügen, Löschen).
  2. Klicken Sie mit der rechten Maustaste auf den Toolbox Ordner und wählen Sie Neueste Version holen, um alle Toolbox Dateien und die Toolbox Datenbank in den lokalen Cache zu kopieren.
    Bei einem dezentralen Archivserver kann dies mehrere Minuten dauern.
  3. Sehen Sie sich die Toolbox Datenbankdatei (SWBrowser.mdb) oder (swbrowser.sldedb) unter \Toolbox_folder_name\lang\your_lang an.
  4. Führen Sie zur Aktualisierung den SOLIDWORKS Installations-Manager aus.
  5. Stellen Sie auf dem Bildschirm Zusammenfassung sicher, dass der Installationsort für Toolbox Optionen der Ablageort im Tresor ist.

    Wenn dies nicht der Fall ist, klicken Sie auf Ändern, wählen Sie Bestehende Toolbox referenzieren oder aktualisieren und wählen Sie den Toolbox Speicherort im Tresor aus.

  6. Checken Sie nach Abschluss der Aktualisierung den Toolbox Ordner im Datei-Explorer ein, um dem Tresor neue oder aktualisierte Dateien hinzuzufügen, damit andere Benutzer mit Toolbox arbeiten können.
  7. Navigieren Sie bei Aktualisierungen zu Ihrem Toolbox Ordner im Tresor und vergewissern Sie sich, dass die folgenden Dateien vorhanden sind:
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      Ist dies nicht der Fall, wenden Sie sich an Ihren Fachhändler.

  8. Aktualisieren Sie den Rest der Computer, die SOLIDWORKS PDM Integration mit Toolbox verwenden:
    1. Melden Sie sich im Datei-Explorer im Tresor als Benutzer mit mindestens Leseberechtigung für den Toolbox Ordner an.
    2. Klicken Sie mit der rechten Maustaste auf den Toolbox Ordner und wählen Sie Neueste Version holen, um die Toolbox Dateien in den lokalen Cache-Speicher zu kopieren.
    3. Führen Sie zur Aktualisierung den SOLIDWORKS Installations-Manager aus.

      Das Installationsprogramm erkennt, dass Toolbox bereits aktualisiert wurde.

Bezüglich Details zur Toolbox Konfiguration in SOLIDWORKS PDM siehe Toolbox konfigurieren in der SOLIDWORKS PDM Administrationswerkzeug-Hilfe.

Übergeordnetes Thema Bohrungsassistent/Toolbox-Optionen
UNC-Format


UNC-Format

Die Uniform (bzw. Universal) Naming Convention ist ein Format, das zur Beschreibung eines freigegebenen Dateispeicherorts eine bestimmte Dateinamensyntax vorschreibt.

\\Server\Datenträger\Pfad

Beispiel:

\\Disk_Server\SOLIDWORKS\AdminImage

Übergeordnetes Thema Bohrungsassistent/Toolbox-Optionen
Hinweise zur Konfiguration von SOLIDWORKS Toolbox


Produkte deinstallieren

Wenn Sie die Option zum Entfernen oder Deinstallieren von Programmen in der Systemsteuerung auswählen, zeigt dieser Bildschirm die SOLIDWORKS Produkte (mit Versionsnummern) an, die von dieser Version des SOLIDWORKS Installations-Managers deinstalliert werden können. Sie können zwischen einer Standard-, benutzerdefinierten oder vollständige Deinstallation wählen.

Die Standarddeinstallation entfernt Programmdateien und Ordner eines SOLIDWORKS Produkts. Standardmäßig werden alle SOLIDWORKS Produkte für die ausgewählte Version für eine Standarddeinstallation festgelegt.

In einer benutzerdefinierten Deinstallation werden eines oder mehrere der folgenden Elemente entfernt: Programmdateien und Ordner, Registrierungsschlüssel und Datenordner, wie SOLIDWORKS Toolbox, sowie Dateien und Ordner aus dem ursprünglichen Download-Verzeichnis.

In einer vollständigen Deinstallation werden die Installationsverzeichnisse, Registrierungsschlüssel und Datenordner entfernt.

Ein Produkt deinstallieren:
  1. Wählen Sie auf dem Bildschirm Deinstallieren das Produkt aus.

    Wenn Sie alle Produkte deinstallieren, wird auch der Solidworks Installations-Manager deinstalliert.

  2. Deaktivieren Sie die Produkte, die nicht entfernt werden sollen.

    Wenn Sie ein Produkt behalten, wird der SOLIDWORKS Installations-Manager nicht deinstalliert.

  3. Wählen Sie, ob eine benuterzdefinierte oder vollständige Deinstallation durchgeführt werden soll.
    1. Klicken Sie auf Ändern in Erweiterte Optionen.

      Der Bildschirm Erweiterte Optionen wird eingeblendet. Die Option Programmdateien und Ordner ist aktiviert.

    2. Wählen Sie eine oder mehrere Optionen aus, um eine benutzerdefinierte Deinstallation auszuführen, oder wählen Sie alle Optionen, um eine vollständige Deinstallation durchzuführen.
    3. Klicken Sie auf Zurück zu Übersicht.
    4. Klappen Sie auf dem Bildschirm Übersicht Erweiterte Optionen auf, um die Deinstallationsmethode und die Einträge anzuzeigen.
  4. Klicken Sie auf Elemente entfernen.
Wenn Sie auf Elemente entfernen klicken, beginnt der SOLIDWORKS Installations-Manager unverzüglich mit dem Entfernen von Produkten.
Übergeordnetes Thema SOLIDWORKS Installations-Manager-Anwendungshilfe


Installation

SOLIDWORKS Connected bietet Zugriff auf alle 3DEXPERIENCE Services und Apps, zu deren Nutzung Sie aufgrund Ihrer Rolle berechtigt sind.

Lizenzierung

Auf der 3DEXPERIENCE Platform wird eine Lizenzierung nach benannten Benutzern verwendet. Eine Lizenz wird zugewiesen, wenn ein Administrator Ihnen eine Rolle erteilt. Über eine Rolle wird festgelegt, welche 3DEXPERIENCE Services und Apps Sie verwenden dürfen. Sie können Ihre Lizenz auf jedem Gerät verwenden. Die Lizenz ist nicht an einen bestimmten Computer gebunden.

Weitere Informationen finden Sie in den Grundlagen zur DS Lizenzierung.

3DEXPERIENCE Launcher

Wenn Sie SOLIDWORKS Connected zum ersten Mal installieren, werden Sie von der 3DEXPERIENCE Platform aufgefordert, den 3DEXPERIENCE Launcher herunterzuladen und zu installieren. Der Launcher ist ein Hintergrunddienst, der native Apps wie SOLIDWORKS Connected beim Zugriff auf die Platform unterstützt. Das Symbol für den Launcher [image] wird nach der Installation in der Windows-Taskleiste angezeigt.

Weitere Informationen finden Sie unter 3DEXPERIENCE Launcher. Für den Zugriff auf die Dassault Systèmes Benutzerunterstützung sind 3DEXPERIENCE Anmeldeinformationen erforderlich.


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost ist eine App, die Ihnen ermöglicht, Rendering von einem Computer, auf dem SOLIDWORKS Visualize Professional ausgeführt wird, auf mehrere Computer im Netzwerk zu verteilen.

Sie können andere Aufgaben auf Ihrem Computer ausführen, während das Rendering im Hintergrund durchgeführt wird und die endgültigen gerenderten Bilder werden schneller bereit gemacht. Bilder können auf einem einzelnen Computer oder in einem Cluster mit mehreren Computern, auf denen Visualize Boost ausgeführt wird, gerendert werden.

Jedes aktive Abonnement von SOLIDWORKS Visualize Professional enthält eine kostenlose Lizenz von SOLIDWORKS Visualize Boost.

Die Leistungsverstärkung, z. B. eine schnellere Rendering-Zeit, hängt von der Leistung der Visualize Boost Computer ab. Maschinen mit besseren GPUs bieten bessere Verbesserungen.


Von Einzellizenzen auf SolidNetWork-Lizenzen aktualisieren

Sie können einen Computer von einer SOLIDWORKS Einzellizenz auf eine SolidNetWork Lizenz aktualisieren, indem Sie die SolidNetWork Lizenzseriennummer in den SOLIDWORKS Installationsmanager eingeben.

Wenn auf einem Computer SOLIDWORKS nicht installiert ist, können Sie SolidNetWork Lizenzierung spezifizieren, indem Sie die SolidNetWork Seriennummer eingeben, wenn Sie eine Installation mittels dem SOLIDWORKS Installations-Manager vornehmen.

Wenn auf einem Computer SOLIDWORKS bereits installiert ist und Sie von einer Einzellizenz auf SolidNetWork Lizenzierung umsteigen, können Sie für den Client-Computer die Installation modifizieren und die SolidNetWork Lizenzseriennummer statt der Einzellizenzseriennummer angeben, wenn Sie den SOLIDWORKS Installations-Manager ausführen. Weitere Informationen finden Sie unter Modifizieren einer Installation.
Wenn Sie SOLIDWORKS von einem Administrator-Installationsabbild installiert haben, ist die Option zum Modifizieren nicht verfügbar. Sie müssen mit dem Administrator-Options-Editor Änderungen am Administrator-Installationsabbild vornehmen, den Client deinstallieren und die Installation wiederholen.


Arbeiten mit Visualize Boost

Um ein verteiltes Rendering zu ermöglichen, müssen Sie SOLIDWORKS Visualize nach der Konfiguration mit Visualize Boost verbinden.

Für eine Boost Verbindung sind die IP-Adresse des Koordinators und die Werte für den Boost-Anschluss in SOLIDWORKS Visualize erforderlich.

Lassen Sie Visualize Boost und SOLIDWORKS Visualize für die folgenden Schritte geöffnet.

So verbinden Sie SOLIDWORKS Visualize mit Visualize Boost:

  1. Öffnen Sie Visualize Boost, indem Sie auf die Desktop-Verknüpfung [image] doppelklicken.
  2. Doppelklicken Sie in Visualize Boost auf die IP-Adresse des Koordinators, um sie in die Zwischenablage zu kopieren.
  3. Klicken Sie in SOLIDWORKS Visualize auf Extras > Optionen > Boost und drücken Sie STRG+V, um die IP-Adresse des Koordinators einzufügen.
  4. Wiederholen Sie die Schritte 2 und 3, um den Boost-Anschluss von Visualize Boost in SOLIDWORKS Visualize zu kopieren.
    Der in Visualize Boost und SOLIDWORKS Visualize Boost angegebene Boost-Anschluss muss identisch sein.
    Das Steuerelement Boost-Status wird in SOLIDWORKS Visualize angezeigt.
  5. Klicken Sie auf OK, um das Dialogfeld Optionen zu schließen.
  6. Um eine Verbindung mit Boost herzustellen, klicken Sie auf das Steuerelement Boost-Status [image] oder trennen Sie die Verbindung [image] in den folgenden Schnittstellen:
    • Voransichtsanzeige
    • Seite „Qualität“ des Rendering-Assistenten
    • Extras Optionen Registerkarte Boost

Einzelheiten zur Boost-Konfiguration finden Sie unter SOLIDWORKS Visualize Boost.


Neuen SolidNetWork License Server initialisieren

So initialisieren Sie einen neuen SolidNetWork License Server:

  1. Klicken Sie nach der Installation und dem Öffnen von SolidNetWork License Manager Server auf Ja, wenn Sie zur Aktivierung aufgefordert werden.
  2. Überprüfen Sie im Dialogfeld SolidNetWork License Serverinformationen die Firewall und die Ports und klicken Sie auf Weiter.
  3. Wählen Sie im Produktaktivierungsassistenten die Seriennummern aus, die aktiviert werden sollen, wählen Sie als Aktivierungsmethode Manuell per E-Mail aus und geben Sie die E-Mail-Kontaktinformationen ein.

    Bei der manuellen Methode müssen Sie eine Anforderungsdatei erstellen und per E-Mail an activation@solidworks.com senden. Wenn Sie die E-Mail mit der Lizenzantwortdatei erhalten, extrahieren Sie die Datei und klicken Sie auf Öffnen, um sie auf den Server zu laden.

    Sie können den Produktaktivierungsassistenten schließen und erneut ausführen, um die Antwortdatei zu öffnen und zu laden.

  4. Wenn Sie eine Meldung erhalten, dass die Initialisierung erfolgreich war, klicken Sie auf OK und klicken Sie im Produktaktivierungsassistenten auf Fertig stellen.


Neuen SolidNetWork License Manager Server manuell aktivieren

Öffnen Sie den SolidNetWork License Manager Server nach seiner Initialisierung und erstellen Sie eine zweite Anforderung, um die Aktivierung abzuschließen.

So aktivieren Sie einen neuen SolidNetWork License Manager Server manuell:

  1. Wählen Sie eine der folgenden Optionen aus:
    • Wenn Sie zur Aktivierung aufgefordert werden, klicken Sie auf Ja.
    • Wenn die Eingabeaufforderung nicht angezeigt wird, klicken Sie auf der Registerkarte Server-Administration auf Modifizieren.
    Standardmäßig ist in den erweiterten Optionen Aktivierung verwenden ausgewählt.
  2. Überprüfen Sie im Dialogfeld „SolidNetWork License Serverinformationen“ die Firewall und die Ports und klicken Sie auf Weiter.
  3. Wählen Sie im Produktaktivierungsassistenten die Seriennummern aus, die aktiviert werden sollen, geben Sie E-Mail-Kontaktinformationen ein und wählen Sie Manuell per E-Mail als Aktivierungsmethode aus.
  4. Führen Sie die folgenden Schritte aus, um eine Anforderungsdatei zu erstellen und an activation@solidworks.com zu senden. Wenn Sie die Lizenzantwortdatei erhalten, klicken Sie auf Öffnen, um die Datei zu laden.
  5. Klicken Sie nach der Aktivierung auf Fertig stellen.


SolidNetWork License Manager Server nach Upgrade manuell aktivieren

Öffnen Sie den SolidNetWork License Manager Server nach seinem Upgrade mit dem SOLIDWORKS Installations-Manager.

So aktivieren Sie SolidNetWork License Manager Server nach dem Upgrade manuell:

  1. Klicken Sie auf der Registerkarte Server-Administration unter Lizenzinformationen auf Reaktivieren.
    Wenn Sie die Lizenzen vor der Deinstallation und dem Upgrade von SolidNetWork License Manager Server deaktiviert haben, klicken Sie stattdessen auf der Registerkarte Server-Administration auf Modifizieren. Reaktivieren ist nur verfügbar, wenn aktivierte Lizenzen auf dem Server vorhanden sind.

    Fahren Sie mit Schritt 3 fort.

  2. Wählen Sie im Dialogfeld Reaktivieren die installierten Seriennummern aus, um die zugehörigen Lizenzen anzuzeigen, und klicken Sie auf Reaktivieren.
  3. Überprüfen Sie im Dialogfeld SolidNetWork License Serverinformationen die Firewall und die Ports und klicken Sie auf Weiter.
  4. Wählen Sie im Produktaktivierungsassistenten die Seriennummern aus, die aktiviert werden sollen, geben Sie E-Mail-Kontaktinformationen ein und wählen Sie Manuell per E-Mail als Aktivierungsmethode aus.
    Die manuelle Aktivierung ist ein einfacher Vorgang. Die Anweisungen im Produktaktivierungsassistenten führen Sie durch das Verfahren.
  5. Klicken Sie nach der Aktivierung auf Fertig stellen.