Installation et administration de SOLIDWORKS

Ce guide couvre l'installation, les licences, la mise à niveau et l'administration des produits SOLIDWORKS pour les installations individuelles et multiples.

Installations individuelles | Déploiement de plusieurs installations
Installation Installation sur un ou plusieurs ordinateurs. | Installation Création d'une image administrative déployée sur plusieurs ordinateurs clients.
Licence Activation de machine ou licence réseau. | Licence Activation de machine ou licence réseau.
Mises à niveau Mise à niveau d'ordinateurs individuels vers une nouvelle version. | Mises à niveau Mise à niveau de plusieurs ordinateurs vers une nouvelle version en mettant à niveau l'image administrative utilisée pour l'installation sur ces ordinateurs.
Administration Modification, réparation et suppression des installations, mises à niveau vers les nouvelles versions. | Administration Mise à niveau d'images administratives et de clients, et administration des licences réseau.

Le Gestionnaire d'installation SOLIDWORKS permet de configurer les paramètres des composants de produits SOLIDWORKS, y compris SOLIDWORKS, SOLIDWORKS Toolbox, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS Visualize et SOLIDWORKS SolidNetWork License Manager.

SolidNetWork License Manager prend en charge les clients de licence multiples en distribuant les licences aux clients du réseau. Le nombre d'utilisateurs peut ainsi dépasser le nombre de licences en utilisant des licences flottantes.

Table des matières

  • Installation individuelle ou image administrative

    Faut-il installer les produits SOLIDWORKS individuellement sur chaque ordinateur ou créer une image administrative et déployer l'installation sur tous les clients en une seule commande?

  • Vérifier le système et les logiciels requis

    Avant l'installation, assurez-vous que votre système satisfait aux exigences du matériel, du système d'exploitation et des produits Microsoft. Les modules complémentaires, tels que SOLIDWORKS Electrical, SOLIDWORKS Visualize et eDrawings ont des exigences supplémentaires.

  • Télécharger le média d'installation

    Tous les médias d'installation sont disponibles sur la page de téléchargements SOLIDWORKS.

  • Installation des applications 3DEXPERIENCE

    Si vous gérez des données avec la plateforme 3DEXPERIENCE, vous pouvez acquérir le rôle de Collaborative Designer for SOLIDWORKS pour connecter votre environnement de bureau à la plateforme.


Installation individuelle ou image administrative

Faut-il installer les produits SOLIDWORKS individuellement sur chaque ordinateur ou créer une image administrative et déployer l'installation sur tous les clients en une seule commande?

Si l'installation concerne un seul ordinateur ou si vous gérez des douzaines ou des centaines d'ordinateurs, la question ne se pose pas. Si vous êtes entre les deux, laissez-vous guider par la comparaison suivante.

Installation individuelle | Image administrative
Les utilisateurs assurent eux-mêmes l'administration de SOLIDWORKS. | L'administrateur système peut personnaliser plusieurs installations avec l'Editeur d'options, en indiquant des options d'installation telles que la création d'une nouvelle installation ou la mise à niveau d'une installation existante, l'exécution de l'installation en tant qu'utilisateur administratif, l'exécution des commandes externes avant ou après l'installation ou différents groupements de produits, etc.
Les ordinateurs doivent être physiquement accessibles à la personne qui réalise l'installation. | Les ordinateurs clients peuvent être distants du moment qu'ils sont accessibles à partir du même réseau.
Vous pouvez installer des versions, service packs ou produits différents sur des ordinateurs distincts avec des paramètres différents. | Les images administratives assurent la cohérence entre les versions, les service packs, les produits et les paramètres pour les installations multiples, lorsque vous utilisez l'Editeur d'options
Les ordinateurs doivent avoir un accès au réseau ou à une messagerie électronique. Une connexion au réseau ou à une messagerie électronique est nécessaire pour activer SOLIDWORKS et télécharger des fichiers. L'accès réseau est également nécessaire lors de la collecte des licences d'un serveur de licences réseau.

Une connexion au réseau local est nécessaire pour déployer l'application; les lecteurs média ne sont pas nécessaires sur les ordinateurs clients.

Les clients peuvent être mis à jour automatiquement. Tous les clients déployés à partir de la même image administrative ont le même service pack. Pour maintenir plusieurs versions, vous pouvez créer plusieurs images administratives.

L'activation de licence peut être automatisée.

Une image administrative nécessite de l'espace disque supplémentaire sur le serveur; l'espace requis sur les clients est le même que pour les installations individuelles.

Sujet parent Installation et administration de SOLIDWORKS
Vérifier le système et les logiciels requis
Télécharger le média d'installation
Installation des applications 3DEXPERIENCE


Vérifier le système et les logiciels requis

Avant l'installation, assurez-vous que votre système satisfait aux exigences du matériel, du système d'exploitation et des produits Microsoft. Les modules complémentaires, tels que SOLIDWORKS Electrical, SOLIDWORKS Visualize et eDrawings ont des exigences supplémentaires.

Pour garantir la bonne installation et une performance optimale, voir Configuration du système.

Sujet parent Installation et administration de SOLIDWORKS
Installation individuelle ou image administrative
Télécharger le média d'installation
Installation des applications 3DEXPERIENCE


Télécharger le média d'installation

Tous les médias d'installation sont disponibles sur la page de téléchargements SOLIDWORKS.

Si vous ne pouvez pas accéder à la page de téléchargements SOLIDWORKS, contactez votre revendeur afin d'obtenir les DVD.

Pour télécharger le média d'installation :

  1. Connectez-vous à la page de téléchargements SOLIDWORKS en tant que client sous contrat de maintenance avec votre adresse de messagerie et votre mot de passe ou votre numéro de série SOLIDWORKS.
  2. Sur la page de téléchargements, sous Sélectionner la version, sélectionnez l'année.
  3. Sélectionnez l'onglet SOLIDWORKS pour Produits SOLIDWORKS.
  4. Dans la zone Produit, sélectionnez un Service Pack.
    Pour la dernière version majeure, sélectionnez la version 0.0 des produits SOLIDWORKS.
  5. Cliquez sur Accepter le contrat et continuer pour accepter les conditions du contrat de licence.
  6. Cliquez sur Télécharger.
    Votre navigateur Web télécharge SolidworksSetup.exe à l'emplacement par défaut C:\Users\Username\Downloads.
  7. Décompressez SolidworksSetup.exe dans le dossier Downloads.
    Vous pouvez également décompresser SolidworksSetup.exe à l'emplacement de votre choix.
  8. Exécutez setup.exe avec des autorisations administratives.
  9. Dans le Gestionnaire d'installation, cliquez sur Télécharger et partager tous les fichiers.
    Créez des installations individuelles ou des images administratives sur plusieurs ordinateurs avec un seul téléchargement, puis suivez les invites pour terminer le processus.

    Le Gestionnaire d'installation télécharge le support d'installation pour vous.

    Cette option est utile pour :
    • Installation du logiciel sur un petit nombre d'ordinateurs
    • Téléchargement à l'aide d'un lecteur portable ou d'un lecteur réseau
    • Installation de service packs
    Pour télécharger les fichiers d'installation de votre choix, suivez les invites pour sélectionner la méthode de téléchargement manuel.
Sujet parent Installation et administration de SOLIDWORKS
Installation individuelle ou image administrative
Vérifier le système et les logiciels requis
Installation des applications 3DEXPERIENCE


Installation des applications 3DEXPERIENCE

Si vous gérez des données avec la plateforme 3DEXPERIENCE, vous pouvez acquérir le rôle de Collaborative Designer for SOLIDWORKS pour connecter votre environnement de bureau à la plateforme.

Ce rôle permet d'accéder aux apps 3DEXPERIENCE, qui autorisent les produits SOLIDWORKS Desktop à enregistrer, rechercher et gérer les données stockées sur la plate-forme. Vous pouvez également utiliser l'app SOLIDWORKS Connected basée sur le Web. Pour plus de détails sur l'installation, voir Installation.

Vous installez et activez ces applications depuis 3DEXPERIENCE Platform, et non depuis le Gestionnaire d'installation SOLIDWORKS. Pour obtenir des instructions d'installation, dans l'Aide de SOLIDWORKS, reportez-vous à Utilisation de 3DEXPERIENCE Platform et des apps 3DEXPERIENCE > Installation des apps 3DEXPERIENCE.

Sujet parent Installation et administration de SOLIDWORKS
Installation individuelle ou image administrative
Vérifier le système et les logiciels requis
Télécharger le média d'installation
https://help.solidworks.com


Installations individuelles

Table des matières

  • Installation sur des ordinateurs individuels

    Il existe plusieurs méthodes pour installer SOLIDWORKS sur un ordinateur individuel.

  • Administration d'installations individuelles

    De manière générale, l'administration d'installations individuelles consiste à modifier, réparer, supprimer et mettre à niveau les installations.


Installation sur des ordinateurs individuels

Il existe plusieurs méthodes pour installer SOLIDWORKS sur un ordinateur individuel.

L'installation est réalisée par le Gestionnaire d'installation SOLIDWORKS, qui personnalise l'installation en fonction des produits achetés. Avant de commencer l'installation:

  • Si vous installez SOLIDWORKS en licence monoposte, préparez votre numéro de série SOLIDWORKS.
  • Vérifiez que votre connexion Internet fonctionne. La connexion est nécessaire pour la vérification des droits.
  • Créez un ID 3DEXPERIENCE. Pour plus d'informations sur la création d'un ID 3DEXPERIENCE, reportez-vous à https://www.3ds.com/support.
  • Assurez-vous que vous êtes l'administrateur désigné pour votre compte ou que votre administrateur vous a répertorié comme contact.

Le Gestionnaire d'installation SOLIDWORKS installe plusieurs composants Microsoft, notamment Microsoft Visual Studio Tools for Applications, Visual Basic et .NET Framework. Si la version demandée de tous les composants Windows prérequis n'est pas installée sur votre ordinateur, le Gestionnaire d'installation SOLIDWORKS l'installe automatiquement avant d'installer les produits SOLIDWORKS.

Le logiciel SOLIDWORKS Chromium Embedded Framework (CEF) est un autre composant installé par le Gestionnaire d'installation SOLIDWORKS. Son objectif est de présenter le contenu des applications SOLIDWORKS et de 3DEXPERIENCE Platform.

SOLIDWORKS Login Manager est également installé par le Gestionnaire d'installation SOLIDWORKS. Il permet de se connecter à 3DEXPERIENCE Marketplace et aux applications 3DEXPERIENCE.

Méthode d'installation Résumé du processus
Téléchargement à partir de la page de téléchargements SOLIDWORKS

Tous les médias d'installation sont disponibles sur la page de téléchargements SOLIDWORKS.

  1. Accédez à la page de téléchargements SOLIDWORKS.
  2. Connectez-vous avec votre ID 3DEXPERIENCE.
  3. Sur la page Téléchargements, sous Sélectionner la version, sélectionnez l'année.
  4. Cliquez sur l'onglet SOLIDWORKS pour Produits SOLIDWORKS et, sous Produit, sélectionnez un Service Pack.
  5. Cliquez sur Accepter le contrat et continuer pour accepter les conditions du contrat de licence.
  6. Cliquez sur Télécharger.
Vous devez disposer d'une connexion Internet opérationnelle avec un accès de connexion à la page Téléchargements.

Si vous ne pouvez pas accéder à la page de téléchargements, contactez votre revendeur afin d'obtenir le support d'installation.
A l'aide d'un répertoire de téléchargement sur un serveur. Dans le répertoire de téléchargement, double-cliquez sur setup.exe.

Le répertoire de téléchargement doit être accessible depuis l'ordinateur sur lequel vous installez les produits SOLIDWORKS ; il doit aussi contenir tous les fichiers d'installation de SOLIDWORKS pour que l'installation puisse commencer. Le Gestionnaire d'installation SOLIDWORKS peut vous aider à trouver les fichiers manquants si vous avez accès à Internet et accès au répertoire de téléchargement.
Mettre à jour une installation SOLIDWORKS existante à l'aide de la commande Vérifier la disponibilité de mises à jour Effectuez l'une des opérations suivantes:
  • Dans SOLIDWORKS, cliquez sur [image] > Vérifier la disponibilité de mises à jour.
  • Dans Windows, cliquez sur Démarrer > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour.
Vous pouvez également cliquer sur Démarrer > Gestionnaire d'installation SOLIDWORKS > Téléchargement en arrière-plan SOLIDWORKS. Dans la zone de notification Windows, cliquez avec le bouton droit de la souris sur Téléchargements en arrière-plan SOLIDWORKS, puis cliquez sur Vérifier la disponibilité de mises à jour.
Vous devez disposer d'une connexion Internet en état de fonctionnement et de privilèges d'administrateur sur l'ordinateur.

Dans le gestionnaire d'installation SOLIDWORKS, vous pouvez également choisir l'option Télécharger et partager tous les fichiers, y compris le logiciel requis. Cette option est utile si vous installez le logiciel sur quelques machines et que vous souhaitez copier le téléchargement à l'aide d'un lecteur portable ou d'un lecteur réseau. Elle est également utile pour l'installation des Service Packs, car la version complète et le Service Pack sont contenus dans une seule installation.

Une fois l'installation terminée, démarrez l'application SOLIDWORKS et activez la licence.

Pour afficher la liste des produits installés sur votre machine, dans le menu principal de SOLIDWORKS -
  • Cliquez sur [image] > Mes produits
  • Cliquez sur Accueil dans le volet des tâches, Ressources SOLIDWORKS > Mes produits
  • Cliquez sur Démarrer > Outils SOLIDWORKS version > Mes produits.

Les coches dans la boîte de dialogue indiquent les produits que vous ou votre organisation possédez en fonction de vos licences d'activation et réseau. Si vous souhaitez en savoir plus sur les produits SOLIDWORKS, cliquez sur le lien au-dessus de chaque catégorie de produit.

Si vous avez une licence SOLIDWORKS, pour savoir quelles sont les licences en cours d'utilisation, sous Windows, cliquez sur l'onglet Démarrer > Outils SOLIDWORKS <version> > SolidNetWork License Manager Client > Utilisation de la licence.

Sujet parent Installations individuelles
Administration d'installations individuelles


Administration d'installations individuelles

De manière générale, l'administration d'installations individuelles consiste à modifier, réparer, supprimer et mettre à niveau les installations.

Table des matières

  • Modifier une installation

    Vous pouvez modifier une installation pour installer des produits qui n'ont pas été installés ou supprimer des produits, à condition que l'installation précédente ait été effectuée avec un ensemble complet de fichiers d'installation. Cette option n'est pas disponible si vous avez mis à niveau l'installation précédente avec un service pack.

  • Réparer une installation

    Si vous rencontrez des problèmes avec un produit SOLIDWORKS installé, vous pouvez utiliser le Gestionnaire d'installation SOLIDWORKS pour réparer l'installation.

  • Restaurer un service pack antérieur dans une installation individuelle

  • Supprimer une installation

    Vous pouvez supprimer une installation sur un ordinateur individuel ou dans un environnement client/serveur.

  • Mettre à niveau vers une nouvelle version

    Plusieurs méthodes permettent de mettre à niveau une installation individuelle vers une nouvelle version de SOLIDWORKS.

  • Règles de coexistence des produits

    Ces règles de coexistence déterminent la façon dont les nouveaux produits sont installés et les produits existants mis à niveau.

Sujet parent Installations individuelles
Installation sur des ordinateurs individuels


Modifier une installation

Vous pouvez modifier une installation pour installer des produits qui n'ont pas été installés ou supprimer des produits, à condition que l'installation précédente ait été effectuée avec un ensemble complet de fichiers d'installation. Cette option n'est pas disponible si vous avez mis à niveau l'installation précédente avec un service pack.

Si vous avez acheté un complément après avoir installé SOLIDWORKS, vous pouvez modifier l'installation pour y inclure le nouveau complément. Vous devez installer le complément sur chaque ordinateur individuel.

  1. Assurez-vous qu'aucune session SOLIDWORKS n'est en cours.
  2. Sous Windows, sélectionnez Paramètres > Applications > Applications installées.
  3. Sélectionnez l'installation SOLIDWORKS que vous souhaitez modifier puis cliquez sur Modifier.
  4. Sur l'écran Bienvenue dans le Gestionnaire d'installation de SOLIDWORKS, cliquez sur Modifier votre installation.
  5. Sur l'écran Numéro de série, vérifiez que les numéros de série appropriés sont sélectionnés.
  6. Sur l'écran Sélection des produits, sélectionnez les produits à installer ou supprimer.
    Lorsque vous modifiez une installation:
    • Aucun produit n'est installé ou supprimé par défaut, même si vous indiquez un nouveau numéro de série. Vous devez modifier l'action d'installation sur chaque produit ou composant.
    • Pour visualiser l'action que vous projetez pour un composant particulier, cliquez sur le nom du composant (mais pas dans la case à cocher). L'installation projetée s'affiche dans le champ d'information situé sous l'entrée de produit dans la liste.
    • Vous pouvez cocher la case adjacente au composant du produit pour changer l'action d'installation de ce composant. (A titre d'exemple, si vous installez ou supprimez des composants, la sélection de la case à cocher indique que le composant doit être installé ou supprimé et la suppression de la sélection de la case à cocher indique que le composant ne doit ni être installé ni supprimé).
    • Lorsque vous modifiez une action d'installation de composant de la spécification initiale, un astérisque (*) apparaît à côté de ce composant dans la liste.
    • Si un composant dispose de sous-composants d'installation optionnels, une icône [image] est visible à côté de son nom. Pour afficher les sous-composants disponibles pour un composant, cliquez sur l'icône [image].
    • Si un composant est développé de façon à afficher des sous-composants optionnels, une icône [image] s'affiche à côté de son nom. Pour réduire la liste des sous-composants, cliquez sur l'icône [image] .
  7. Dans l'écran Résumé, cliquez sur Modifier maintenant.
  8. Dans l'écran L'installation est terminée, cliquez sur Terminer.
Sujet parent Administration d'installations individuelles
Réparer une installation
Restaurer un service pack antérieur dans une installation individuelle
Supprimer une installation
Mettre à niveau vers une nouvelle version
Règles de coexistence des produits


Réparer une installation

Si vous rencontrez des problèmes avec un produit SOLIDWORKS installé, vous pouvez utiliser le Gestionnaire d'installation SOLIDWORKS pour réparer l'installation.

Pour réparer une installation, votre ordinateur doit disposer de tous les fichiers source de l'installation précédente et de tous les Service Packs appliqués. Ils doivent se trouver à l'emplacement où vous les avez installés à l'origine.

Vous pouvez réparer une installation individuelle. Vous ne pouvez pas réparer une image administrative; vous devez la désinstaller puis la réinstaller.
  1. Ouvrez le Panneau de configuration Windows et cliquez sur Programmes > Programmes et Fonctionnalités.
  2. Cliquez avec le bouton droit de la souris sur la version de SOLIDWORKS que vous souhaitez réparer et cliquez sur Modifier.
  3. Sur l'écran Bienvenue dans le Gestionnaire d'installation de SOLIDWORKS, cliquez sur Réparer votre installation, puis sur Suivant.
  4. Sur l'écran Produits à réparer, sélectionnez le produit à réparer.
  5. Désactivez le reste des produits sur l'écran.
  6. Cliquez sur Réparer.
Sujet parent Administration d'installations individuelles
Sujet parent Erreurs d'installation / Installation annulée
Modifier une installation
Restaurer un service pack antérieur dans une installation individuelle
Supprimer une installation
Mettre à niveau vers une nouvelle version
Règles de coexistence des produits
Récupération d'une installation qui a échoué ou qui a été annulée
Contacter le revendeur SOLIDWORKS


Restaurer un service pack antérieur dans une installation individuelle

Pour restaurer une installation individuelle à une version du service pack de la famille de la version majeure actuelle, désinstallez la version du service pack installée actuellement sur l'ordinateur puis réinstallez la version antérieure.
Sujet parent Administration d'installations individuelles
Modifier une installation
Réparer une installation
Supprimer une installation
Mettre à niveau vers une nouvelle version
Règles de coexistence des produits


Supprimer une installation

Vous pouvez supprimer une installation sur un ordinateur individuel ou dans un environnement client/serveur.

  1. Assurez-vous qu'aucune session SOLIDWORKS n'est en cours.
  2. Si vous souhaitez transférer la licence SOLIDWORKS sur un autre ordinateur, désactivez la licence avant de supprimer l'installation SOLIDWORKS sur cet ordinateur.
    Pour plus d'informations, voir Transférer une licence.
  3. Ouvrez le Panneau de configuration Windows et cliquez sur Programmes et Fonctionnalités.
  4. Sélectionnez le composant du produit à supprimer, puis cliquez sur Désinstaller.
    Dans certains cas, il se peut qu'il y ait plusieurs composants Service Pack de SOLIDWORKS pour une version majeure donnée. Pour supprimer une version majeure de SOLIDWORKS, supprimez tous les éléments Service Pack de cette version majeure.
  5. Sur l'écran Désinstallation:
    1. Sélectionnez les produits à supprimer.
      Par défaut, tous les composants des produits sont sélectionnés.
    2. Désélectionnez les produits que vous ne voulez pas supprimer.
    3. Cliquez sur Modifier dans Options avancées.
      L'écran Options avancées apparaît et l'option Fichiers et dossiers programme est sélectionnée
    4. Sélectionnez une option ou plus pour une désinstallation personnalisée ou toutes les options pour une désinstallation complète.
      Par défaut, le Gestionnaire d'installation SOLIDWORKS effectue une désinstallation complète et supprime tous les fichiers et dossiers ajoutés lors de l'installation.
    5. Cliquez sur Retour au résumé.
    6. Sur l'écran Résumé, développez Options avancées pour afficher la méthode de désinstallation et les entrées.
    7. Cliquez sur Supprimer des éléments.
Sujet parent Administration d'installations individuelles
Sujet parent Administration d'installations multiples
Modifier une installation
Réparer une installation
Restaurer un service pack antérieur dans une installation individuelle
Mettre à niveau vers une nouvelle version
Règles de coexistence des produits
Mettre à niveau des images administratives vers une nouvelle version
Administration des mises à jour de produits au moyen des service packs
Transférer une licence


Mettre à niveau vers une nouvelle version

Plusieurs méthodes permettent de mettre à niveau une installation individuelle vers une nouvelle version de SOLIDWORKS.

Vous pouvez mettre à niveau vers une nouvelle version quand vous:
  • Recevez un nouveau média d'installation
  • Etes notifié de mises à jour lors du démarrage de SOLIDWORKS.
  • Vérifiez manuellement la disponibilité de mises à jour.
  • Démarrez une nouvelle occurrence du Gestionnaire d'installation SOLIDWORKS.

Lorsque installez une nouvelle version majeure, vous pouvez mettre à niveau une version majeure installée précédemment ou installer la nouvelle version en parallèle. Si vous installez une version Service Pack d'une version majeure installée précédemment, cette version est mise à jour automatiquement.

Sujet parent Administration d'installations individuelles
Modifier une installation
Réparer une installation
Restaurer un service pack antérieur dans une installation individuelle
Supprimer une installation
Règles de coexistence des produits

Vérifier manuellement la disponibilité de mises à jour

Si vous disposez de privilèges d'administrateur sur l'ordinateur, vous pouvez vérifier la disponibilité de mises à jour d'une version SOLIDWORKS installée au moyen d'une des méthodes suivantes.

  • Dans SOLIDWORKS, cliquez sur [image] > Vérifier la disponibilité de mises à jour.
  • Dans Windows, cliquez sur Démarrer > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour.
Vous pouvez également cliquer sur Démarrer > Gestionnaire d'installation SOLIDWORKS > Téléchargement en arrière-plan SOLIDWORKS. Dans la zone de notification Windows, cliquez avec le bouton droit de la souris sur Téléchargements en arrière-plan SOLIDWORKS, puis cliquez sur Vérifier la disponibilité de mises à jour.

Mises en garde relatives aux mises à niveau

Il n'est pas toujours possible d'appliquer une mise à niveau majeure aux produits pour lesquels plusieurs versions majeures différentes sont installées ou d'appliquer une mise à niveau entre des versions majeures en une seule opération.

Dans ce cas, le Gestionnaire d'installation SOLIDWORKS simule la mise à niveau en installant d'abord la nouvelle version, puis en supprimant l'ancienne. Actuellement, seul le produit SOLIDWORKS principal prend en charge les mises à niveau majeures.

Les conséquences sont les suivantes :
  • Lors de la mise à niveau du produit SOLIDWORKS principal entre des versions majeures :
    • Votre emplacement d'installation existant ne change pas.
    • La mise à niveau peut être annulée si une erreur survient ou si vous y mettez fin.
  • Lorsque d'autres produits sont mis à niveau entre des versions majeures :
    • Chaque produit est d'abord installé en tant que nouveau produit à un nouvel emplacement, puis l'installation d'origine est supprimée.
    • Une fois commencée, la mise à niveau peut être annulée si une erreur survient ou si vous y mettez fin.


Règles de coexistence des produits

Ces règles de coexistence déterminent la façon dont les nouveaux produits sont installés et les produits existants mis à niveau.

Règle | Exemples
Plusieurs versions majeures du produit SOLIDWORKS principal sont autorisées, à l'exception des produits mentionnés ci-dessous. | SOLIDWORKS 2024 SP3.0 et SOLIDWORKS 2025 SP0.0 peuvent coexister sur le même ordinateur.
Plusieurs service packs de la même version majeure ne sont pas autorisés. | SOLIDWORKS 2025 SP0.0 et 2025 SP1.0 ne peuvent pas coexister sur le même ordinateur. Si vous installez SOLIDWORKS 2025 SP1.0 sur un ordinateur où SOLIDWORKS 2025 SP0.0 est déjà installé, le Gestionnaire d'installation SOLIDWORKS remplace SP0.0 par SP1.0.
Une seule version des produits suivants est permise sur l'ordinateur :
  • SolidNetWork License Manager
 Si SolidNetWork License Manager 2024 SP3.0 est installé, SolidNetWork License Manager est mis à niveau vers 2025 SP0.0, même si une version majeure antérieure de SOLIDWORKS existe sur l'ordinateur.
Une seule version du produit suivant est permise sur l'ordinateur :
  • SOLIDWORKS Electrical
 Si vous créez une nouvelle installation de SOLIDWORKS Electrical 2025 SP1.0, le Gestionnaire d'installation SOLIDWORKS supprime automatiquement toutes les versions précédentes de SOLIDWORKS Electrical présentes sur l'ordinateur. Sauvegardez votre environnement SOLIDWORKS Electrical avant de le mettre à niveau.
Une seule version des produits suivants est permise sur l'ordinateur :
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

Si vous installez SOLIDWORKS 2025 SP0.0 ou SP1.0, vous devez également mettre à niveau vers SOLIDWORKS 2025 PDM Server et PDM Client.

Si vous installez SOLIDWORKS 2025 PDM Server, vous devez utiliser le processus d'installation de PDM Server pour installer SOLIDWORKS PDM Client. N'installez pas SOLIDWORKS PDM Client séparément avec le processus d'installation du client.

SOLIDWORKS PDM Client doit être la même version et le même service pack que SOLIDWORKS PDM Server sur le même ordinateur.

Voir SOLIDWORKS PDM et SOLIDWORKS Manage pour plus d'informations.

Une seule version d'un produit inclus peut être installée pour n'importe quelle version majeure de SOLIDWORKS. Toutefois, les versions des produits inclus dans différentes versions majeures de SOLIDWORKS peuvent coexister. | Si SOLIDWORKS 2025 SP0.0 est mis à niveau vers 2025 SP1.0, SOLIDWORKS Composer 2025 SP0.0 est automatiquement mis à niveau vers 2025 SP1.0. Cependant, SOLIDWORKS Composer 2024 SP4.0 peut coexister avec SOLIDWORKS Composer 2025 SP0.0 ou avec SOLIDWORKS Composer 2025 SP1.0.
Sujet parent Administration d'installations individuelles
Modifier une installation
Réparer une installation
Restaurer un service pack antérieur dans une installation individuelle
Supprimer une installation
Mettre à niveau vers une nouvelle version


Installations multiples

Table des matières

  • Déployer vers des clients multiples

    Vous pouvez installer SOLIDWORKS sur plusieurs clients en créant une image administrative, puis en déployant l'installation vers les clients.

  • Utilisation des images administratives

    Une image administrative permet de réaliser des installations configurables des produits SOLIDWORKS à partir d'un emplacement de réseau unique.

  • Déploiement avec la ligne de commande

    Vous pouvez déployer une image administrative automatiquement en utilisant une Invite ou un fichier de commandes (installation silencieuse).

  • Administration d'installations multiples

    Dans le cas des installations multiples, les tâches administratives comprennent la mise à niveau des images administratives vers de nouvelles versions, l'application de services packs et la suppression d'installations.


Déployer vers des clients multiples

Vous pouvez installer SOLIDWORKS sur plusieurs clients en créant une image administrative, puis en déployant l'installation vers les clients.

Le processus de déploiement des clients multiples est le suivant:
  1. Création d'une image administrative.
    • Créer une image administrative à partir du gestionnaire d'installation SOLIDWORKS
  2. Déploiement de l'image administrative sur les clients.
    • Déployer une image administrative sur des clients par méthode d'ouverture/manuelle (courrier électronique)
    • Déploiement d'une image administrative sur des clients méthode automatique/poussée
    • Installer depuis l'image administrative en utilisant la ligne de commande
  3. Implémentation des licences.
    • Administrer les licences individuelles
    • Administrer des licences avec SolidNetWork License Manager
Sujet parent Installations multiples
Utilisation des images administratives
Déploiement avec la ligne de commande
Administration d'installations multiples


Utilisation des images administratives

Une image administrative permet de réaliser des installations configurables des produits SOLIDWORKS à partir d'un emplacement de réseau unique.

Vous pouvez installer l'image administrative à partir de n'importe quel ordinateur sur le réseau, notamment un ordinateur client.
  • L'image administrative doit se trouver dans un dossier partagé.
  • Si tous les produits sont inclus, l'image administrative peut prendre jusqu'à 17 Go d'espace disque.
  • Si vous mettez à jour le nom du partage lorsque vous mettez à niveau l'image administrative, le client est automatiquement mis à jour au prochain démarrage de l'application. Pour plus de détails, voir Mise à niveau d’une image administrative.
  • Lors du déploiement d'une image administrative, le chemin de l'image doit comporter moins de 58 caractères.
  • Les clients doivent avoir des privilèges d'administration sur leur ordinateur. Si un client ne dispose pas des privilèges suffisants, il peut exécuter une installation sous un autre nom d'utilisateur. Cette option est pratique lorsqu'un utilisateur individuel ne dispose pas sur son ordinateur des permissions administratives locales qui sont requises pour l'installation des produits SOLIDWORKS.

    Voir Mise en place des installations à partir de l'Editeur d'options. Une autre méthode y est également décrite pour installer des images lorsqu'un client ne dispose pas des privilèges suffisants.

  • Si la journalisation Windows est activée ou si vous utilisez la fonctionnalité d'état dans l'Editeur d'options du Gestionnaire d'images administratives, vous devez avoir les autorisations en lecture/écriture pour ce dossier : {Administrative image directory}\x64\Logs.

Après avoir créé une image administrative, l'Editeur d'options du Gestionnaire d'images administratives peut gérer les paramètres de l'option pour les utilisateurs et les groupes effectuant une installation à partir de cette image. Pour plus de détails, voir Editeur d'options du Gestionnaire d'images administratives.

Table des matières

  • Types d'images administratives

    Vous pouvez utiliser l'éditeur d'options du Gestionnaire d'images administratives pour créer plusieurs types d'images pour les utilisateurs à distance et pour ceux qui utilisent votre réseau.

  • Créer une image administrative à partir du gestionnaire d'installation SOLIDWORKS

    Si vous installez SOLIDWORKS sur plusieurs ordinateurs, vous pouvez créer une image administrative, puis déployer l'application sur d'autres ordinateurs.

  • Editeur d'options du Gestionnaire d'images administratives

    L'Editeur d'options du Gestionnaire d'images administratives vous permet de personnaliser les paramètres d'installation pour les groupes d'ordinateurs et pour les ordinateurs individuels..

  • Outil Administrateur des paramètres

Sujet parent Installations multiples
Déployer vers des clients multiples
Déploiement avec la ligne de commande
Administration d'installations multiples
Mise à niveau de clients à partir d'images administratives


Types d'images administratives

Vous pouvez utiliser l'éditeur d'options du Gestionnaire d'images administratives pour créer plusieurs types d'images pour les utilisateurs à distance et pour ceux qui utilisent votre réseau.

Type d'image administrative Description
Standard

Il s'agit de l'image par défaut pour toutes les nouvelles images administratives.

Cette image administrative du programme d'installation Windows convient parfaitement aux utilisateurs qui disposent d'un accès fiable à l'ensemble du réseau de l'entreprise. Elle stocke tous les fichiers requis pour installer les produits SOLIDWORKS sélectionnés dans un dossier d'images partagé.

Lorsque les utilisateurs passent à un nouveau Service Pack, ils peuvent télécharger et appliquer des fichiers de correctif et n'ont pas besoin de télécharger l'image entière.
Client à distance

Cette image est conçue pour les utilisateurs à distance qui ne disposent pas d'un accès fiable au réseau de l'entreprise.

Lorsqu'ils installent ce type d'image, les utilisateurs à distance reçoivent toutes les options d'installation que vous spécifiez, comme le numéro de série et les produits à installer.

Les utilisateurs téléchargent les fichiers nécessaires sur Internet via la page de téléchargements SOLIDWORKS. Nous vous recommandons d'accéder à ces fichiers et de les installer en passant par Internet pour plus de fiabilité et pour réduire la charge sur les réseaux de l'entreprise.

Les utilisateurs à distance installent cette image en utilisant les mêmes techniques prises en charge par l'image administrative standard. Vous pouvez toujours exécuter le script des installations en utilisant les fichiers sldim.exe et startwinstall.exe.

Les fichiers d'installation téléchargent un chemin spécifié dans l'éditeur d'options du Gestionnaire d'images administratives avant l'installation. Les utilisateurs doivent accéder au dossier de l'image administrative pour démarrer l'installation et exécuter des fichiers de lots ou de paramètres qui y sont hébergés.

Les utilisateurs à distance doivent disposer de suffisamment d'espace disque pour stocker tous les fichiers dans l'image, même si les utilisateurs peuvent supprimer l'image une fois l'installation terminée.
Compressé(e)

L'image administrative compressée est conçue pour les organisations qui ont besoin de copier des images administratives sur plusieurs sites ou machines client et qui veulent minimiser l'impact sur le réseau.

Cette image est 60 % plus petite qu'une image administrative standard mais elle met autant de temps à exécuter les installations. Elle prend en charge toutes les opérations d'installation telles que la modification et la réparation.

Les images administratives compressées disposent également de chemins d'accès courts. Ainsi, lorsque des images sont stockées dans des structures de dossiers profondes, aucun problème ne survient.

Lorsque les utilisateurs passent à un nouveau Service Pack, ils doivent télécharger l'image entière et pas seulement les correctifs.
Sujet parent Utilisation des images administratives


Créer une image administrative à partir du gestionnaire d'installation SOLIDWORKS

Si vous installez SOLIDWORKS sur plusieurs ordinateurs, vous pouvez créer une image administrative, puis déployer l'application sur d'autres ordinateurs.

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.

    Voir Télécharger le média d'installation.

  2. Depuis l'écran Bienvenue, sélectionnez Créer une image administrative à déployer sur plusieurs ordinateurs et sélectionnez l'une des options suivantes :
    Option | Description
    Créer une nouvelle image en utilisant les paramètres par défaut. | Créer l'image à l'aide des paramètres de configuration par défaut (sans se baser sur les paramètres définis pour une image administrative existante sur votre site).
    Créer une nouvelle image en utilisant les paramètres et les fichiers d'une image existante. | Créer l'image à l'aide des paramètres de configuration indiqués pour une image administrative existante sur votre site. Cliquez sur Parcourir pour indiquer le répertoire d'installation de l'image administrative existante.
  3. Saisissez vos numéros de série SOLIDWORKS.
  4. Cliquez sur Modifier pour modifier les produits ou les options par défaut qui incluent :
    • Emplacement de l'image administrative
    • Type d'image administrative
  5. Acceptez le contrat de licence et cliquez sur Créer maintenant.
  6. Cliquez sur Personnaliser l'image pour ouvrir et afficher les paramètres dans l'Editeur d'options du Gestionnaire d'images administratives.
  7. Facultatif : Cliquez sur Créer un raccourci bureau pour accéder à l'image sur votre bureau.
Sujet parent Utilisation des images administratives


Editeur d'options du Gestionnaire d'images administratives

L'Editeur d'options du Gestionnaire d'images administratives vous permet de personnaliser les paramètres d'installation pour les groupes d'ordinateurs et pour les ordinateurs individuels..

Après la création de l'image administrative, le Gestionnaire d'installation SOLIDWORKS vous demande de démarrer l'Editeur d'options. Vous pouvez également démarrer l'Editeur d'options en double cliquant sur sldAdminOptionEditor.exe dans le dossier de l'image administrative.

Si vous souhaitez spécifier différentes configurations d'installation pour des groupes de machines ou des machines spécifiques, dans l'Editeur d'options, sélectionnez des machines. Spécifiez ensuite les options d'installation de ces machines.

Toutes les boîtes de dialogue qui invitent à choisir un chemin de fichier ou de dossier incluent une option vous permettant de lier un dossier sélectionné à une variable d'environnement. Par exemple, si vous sélectionnez C:\Program Files\SOLIDWORKS Corp, le chemin d'accès au fichier est mappé à %ProgramFiles%\SOLIDWORKS Corp. Les variables les plus courantes sont %ProgramFiles% et %SystemDrive%.

Vous ne pouvez pas mapper tous les chemins à des variables d'environnement. Par exemple, vous ne pouvez pas mapper Z:\SOLIDWORKS Data à une variable d'environnement.

Table des matières

  • Ajouter et supprimer des groupes et des ordinateurs

    L'Editeur d'options du Gestionnaire d'images administratives vous permet d'indiquer les différentes configurations d'installation pour les groupes d'ordinateurs et pour les ordinateurs individuels.

  • Affichage et édition des paramètres d'option

    L'Editeur d'option du Gestionnaire d'images administratives SOLIDWORKS vous permet de visualiser et de modifier les paramètres d'option pour les groupes et les ordinateurs spécifiés pour l'image.

  • Mise en place des installations à partir de l'Editeur d'options

    Vous pouvez déployer les installations directement depuis l'Editeur d'options en vous servant d'une méthode manuelle ou Push.

  • Quitter l'Editeur d'options

    Vous pouvez cliquer sur OK ou sur Fermer pour appliquer les modifications et quitter l'Editeur d'options.

  • Création d'un raccourci sur le Bureau vers l'Editeur d'options

    Vous pouvez créer un raccourci sur le bureau Windows vers l'Editeur d'options pour une image administrative donnée à partir de l'application.

  • Déployer une image administrative sur des clients par courrier électronique

    Après avoir créé un répertoire d'image administrative partagé, vous pouvez le notifier aux clients par courrier électronique.

Sujet parent Utilisation des images administratives


Ajouter et supprimer des groupes et des ordinateurs

L'Editeur d'options du Gestionnaire d'images administratives vous permet d'indiquer les différentes configurations d'installation pour les groupes d'ordinateurs et pour les ordinateurs individuels.

Par exemple, vous pouvez configurer plusieurs ordinateurs afin d'utiliser un sous-ensemble de composants de produits disponibles dans l'image, alors qu'un autre groupe pourrait utiliser un autre sous-ensemble de composants. Bien que vous utilisiez une seule image administrative, les paramètres de groupe de l'Editeur d'options vous permettent d'installer différents sous-ensembles de produits sur différents groupes d'ordinateurs. Vous pouvez déplacer les paramètres entre les différents groupes et modifier des groupes d'ordinateurs.

Vous pouvez également diviser les groupes d'ordinateurs en sous-groupes. Les sous-groupes héritent des paramètres du groupe parent, mais vous pouvez changer les paramètres individuels pour chaque sous-groupe.

Pour ajouter un groupe:
  1. Cliquez à l'aide du bouton droit de la souris sur Paramètres globaux puis sur Ajouter un groupe.
  2. Entrez le nom du groupe.

Pour ajouter des ordinateurs:
  1. Cliquez à l'aide du bouton droit de la souris sur Paramètres globaux puis sur Ajouter un ordinateur.
    Si vous cliquez sur un groupe existant à l'aide du bouton droit de la souris, des ordinateurs sont ajoutés à ce groupe. Sinon, ils sont ajoutés au premier niveau.
  2. Effectuez l'une des opérations suivantes :
    • Sélectionnez Par nom d'ordinateur et saisissez un nom d'ordinateur.
      Un nom d'ordinateur ne peut pas inclure le nom du domaine. Par exemple, pluto.solidworks.com est invalide.
    • Sélectionnez Par adresse IP et saisissez l'adresse IP d'un ordinateur.
    • Sélectionnez Par plage d'adresses IP et saisissez l'adresse IP de début et l'adresse IP de fin de la plage.
    • Cliquez sur Ajouter plusieurs ordinateurs pour indiquer le nom des ordinateurs. Vous pouvez séparer les noms d'ordinateurs par un retour à la ligne, un espace, une tabulation, une virgule, un point, deux-points ou un point-virgule. Vous pouvez également copier et coller une liste de noms d'ordinateurs depuis un fichier délimité (par exemple, au format *.xls ou *.cvs) dans la boîte de dialogue.

    Si vous ajoutez des machines par nom, adresse IP et plage d'adresses IP, la machine d'installation recherche une correspondance dans l'ordre suivant : Nom de la machine, Adresse IP, puis Plage d'adresses IP. Les options d'installation seront appliquées à la machine d'installation en fonction de la première correspondance trouvée.

Pour déplacer un ordinateur existant vers un sous-groupe :

faites glisser l'ordinateur dans le groupe ou le sous-groupe.

Pour déplacer un ordinateur en dehors d'un groupe ou sous-groupe :

faites glisser l'ordinateur sur Paramètres globaux ou bien sur un groupe ou sous-groupe différent.

Pour supprimer un groupe, un sous-groupe ou un ordinateur :

à l'aide du bouton droit de la souris, cliquez sur le groupe, le sous-groupe ou l'ordinateur, puis cliquez sur Supprimer le groupe ou Supprimer l'ordinateur.

Si vous supprimez un groupe, tous les ordinateurs de ce groupe sont supprimés.

Pour supprimer tous les groupes et tous les ordinateurs:

Cliquez à l'aide du bouton droit de la souris sur Paramètres globaux puis cliquez sur Tout supprimer.

Sujet parent Editeur d'options du Gestionnaire d'images administratives
Affichage et édition des paramètres d'option
Mise en place des installations à partir de l'Editeur d'options
Quitter l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options
Déployer une image administrative sur des clients par courrier électronique


Affichage et édition des paramètres d'option

L'Editeur d'option du Gestionnaire d'images administratives SOLIDWORKS vous permet de visualiser et de modifier les paramètres d'option pour les groupes et les ordinateurs spécifiés pour l'image.

  • Lorsque vous lancez l'Editeur d'option pour la première fois, les paramètres d'option s'affichent en mode lecture seule. L'icône Modifier [image] n'est pas grisée.

    Lorsque vous cliquez sur Paramètres globaux, un récapitulatif des paramètres d'option d'un groupe ou d'un ordinateur s'affiche pour cet élément:

    Zone d'action | Paramètres d'option affichés
    Paramètres globaux | Tous les paramètres d'option spécifiés pour l'image administrative.
    Groupe | Change dans les paramètres de groupe relatifs aux paramètres globaux
    Machine | Change dans les paramètres de l'ordinateur relatifs au groupe
  • Pour modifier les paramètres d'option, cliquez sur Modifier [image]. L'icône est grisée et une liste des paramètres d'option plus détaillée s'affiche.

    Lorsque vous cliquez sur Paramètres globaux, un groupe ou un ordinateur vous permettent de changer les paramètres d'option pour cet élément. Lorsque vous modifiez un paramètre d'option qui diffère des paramètres globaux ou des paramètres de groupe hérités, ce paramètre d'option est mis en surbrillance.

    Si vous recliquez sur l'icône Modifier [image], le mode de lecture seule est restauré à l'affichage.

    Si vous apportez des modifications, l'Editeur d'option vous invite à les enregistrer ou à les ignorer lorsque vous quittez.

Table des matières

  • Indiquer des paramètres d'option pour les groupes et les ordinateurs

    Vous pouvez indiquer des paramètres d'option pour tous les ordinateurs (Paramètres globaux), groupes d'ordinateurs et ordinateurs individuels.

  • Paramètres d'options relatifs à l'image administrative

    L'Editeur d'options permet de spécifier les paramètres relatifs aux options de clients ou de groupes individuels, y compris les numéros de série, les options d'installation du client, quels composants sont installés, et l'emplacement de Toolbox.

  • Héritage des paramètres d'option globaux et de groupe

    Les paramètres d'option pour Paramètres globaux ou de groupe sont hérités par des éléments situés dessous.

  • Personnalisation des paramètres pour chaque ordinateur

    Vous pouvez également modifier des paramètres que vous avez appliqués à des ordinateurs spécifiques en cliquant avec le bouton droit sur le nom de l'ordinateur.

Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Mise en place des installations à partir de l'Editeur d'options
Quitter l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options
Déployer une image administrative sur des clients par courrier électronique


Indiquer des paramètres d'option pour les groupes et les ordinateurs

Vous pouvez indiquer des paramètres d'option pour tous les ordinateurs (Paramètres globaux), groupes d'ordinateurs et ordinateurs individuels.

  1. Dans l'Editeur d'options, cliquez sur l'objet à modifier (par exemple, Paramètres globaux, un groupe ou un ordinateur).
  2. A droite, cliquez sur Modifier [image].
    L'icône est grisée et une liste des paramètres d'option plus détaillée s'affiche.
  3. Modifiez les paramètres d'option en cliquant sur les paramètres d'option à droite de l'article sélectionné sur la gauche.
    Les modifications apportées aux paramètres d'option remplaçant les Paramètres globaux ou les paramètres de groupe sont mises en surbrillance.
  4. Cliquez sur OK ou Fermer pour sauvegarder vos modifications.
    Option | Description
    OK | L'Editeur d'options enregistre vos modifications et se ferme.
    Fermer | L'Editeur d'options demande si vous voulez enregistrer les modifications apportées et se ferme.
Sujet parent Affichage et édition des paramètres d'option
Paramètres d'options relatifs à l'image administrative
Héritage des paramètres d'option globaux et de groupe
Personnalisation des paramètres pour chaque ordinateur


Paramètres d'options relatifs à l'image administrative

L'Editeur d'options permet de spécifier les paramètres relatifs aux options de clients ou de groupes individuels, y compris les numéros de série, les options d'installation du client, quels composants sont installés, et l'emplacement de Toolbox.

Numéros de série

Saisissez les numéros de série pour installer les produits sur les ordinateurs client.
Comme il existe différentes façons d'acheter les produits SOLIDWORKS, certains numéros de série couvrent deux produits ou plus. Ainsi, un numéro de série SOLIDWORKS peut vous permettre d'installer SOLIDWORKS Simulation sans entrer de numéro de série SOLIDWORKS Simulation séparé. De plus, certains produits ne requièrent pas de numéro de série. Si vous avez des questions au sujet de vos numéros de série, contactez votre revendeur (VAR).
Si vous gérez les licences à l'aide SolidNetWork :
  • Dans le premier champ du numéro de série, saisissez le numéro de série de SolidNetWork.
  • Dans le champ Port serveur SNL@serveur, saisissez le nom du serveur et le port SolidNetWork License Manager au format suivant nnnnn<nomserveur. Utilisez des points virgules pour séparer les saisies.

Pour de plus amples informations sur la licence SolidNetWork, voir Présentation de l'installation des licences SolidNetWork.

Options d'installation du client

Comment souhaitez-vous effectuer les installations de clients de versions majeures? Vous pouvez indiquer comment les installations de clients gèrent une installation de la version majeure antérieure existante :
  • Mettre à niveau une version majeure existante.

    Indiquez cette option pour remplacer l'installation de la version majeure antérieure par l'installation de la nouvelle version.

  • Créer une nouvelle version majeure.

    Indiquez cette option pour conserver la version majeure antérieure et créer une autre installation pour la nouvelle version majeure. Pour indiquer l'emplacement de l'installation de la nouvelle version, cliquez sur Parcourir.
Souhaitez-vous désinstaller la version précédente la plus récente avant d'installer une nouvelle version majeure? Vous pouvez spécifier si vous souhaitez désinstaller la version majeure antérieure existante :
  • Ne pas désinstaller.

    Sélectionnez cette option pour garder l'installation de la version majeure antérieure.

  • Désinstaller la version la plus récente.
  • Désinstaller toutes les versions.
Comment souhaitez-vous appliquer les paramètres SOLIDWORKS ? Vous pouvez spécifier un fichier de paramètres en démarrant le logiciel. Les installations de clients se réfèrent à un fichier de paramètres. Enregistrez le fichier de paramètres (*.sldsettings) dans un chemin d'accès UNC partagé visible de toutes les installations. Spécifiez un chemin d'accès au fichier *.sldsettings avant d'installer SOLIDWORKS. Les installations de clients détectent le chemin d'accès au fichier *.sldsettings lors de l'installation.
Sécurisez le fichier *.sldsettings en définissant des autorisations de fichiers Windows qui limitent l'accès en écriture aux utilisateurs désignés.

Pour créer ou modifier un fichier *.sldsettings, cliquez sur Lancer l'Administrateur de paramètres. L'outil Administrateur de paramètres de SOLIDWORKS vous permet de définir les options système de SOLIDWORKS à appliquer et éventuellement à verrouiller pour les utilisateurs. Vous pouvez également définir comment et quand appliquer les paramètres à des installations individuelles. Vous pouvez modifier le fichier *.sldsettings à tout moment en exécutant l'outil Administrateur de paramètres et en écrasant le fichier existant.

Vous pouvez utiliser différents fichiers *.sldsettings pour les différents ordinateurs ou groupes.

Le chemin d'accès au fichier *.sldsettings se définit lors de l'installation. Une fois le déploiement effectué, vous ne devez ni renommer, ni déplacer le fichier *.sldsettings.

Vous devez disposer d'une installation existante de SOLIDWORKS [version majeure actuelle] pour pouvoir exécuter l'outil Administrateur des paramètres.
Comment souhaitez-vous activer les installations clients? Vous pouvez indiquer si l'activation des produits doit être automatique après avoir exécuté l'installation ou si l'utilisateur doit s'en charger manuellement.
  • Activation automatique lorsque chaque installation client est terminée.

    La sélection de ce paramètre d'option permet l'exécution automatique de l'activation du produit. Saisissez l'adresse e-mail qui sera fournie lors de l'exécution de l'activation sur l'ordinateur client.

  • Pas d'activation automatique.

    Spécifie que l'activation de produit ne se fait pas automatiquement. L'utilisation du client effectue l'activation après l'installation.

Options d'administration

Créer un journal de diagnostic lors de chaque installation. | Une installation de clients peut créer un journal de diagnostic pour dépanner les problèmes d'installation. La création de ce journal peut ralentir l'installation du client. Le fichier journal est stocké dans Répertoire de l'image administrative}\x64\Logs\<nom_ordinateur>.
Exécuter l'installation sous un autre nom d'utilisateur.

Vous pouvez spécifier un autre utilisateur disposant des autorisations administratives pour exécuter l'installation au lieu de l'utilisateur connecté. Cette option s'avère pratique lorsque les utilisateurs ne disposent pas d'autorisations administratives locales sur leur ordinateur (lesquelles sont requises pour l'installation des produits SOLIDWORKS).

Une méthode alternative de déploiement et d'installation est disponible quand les clients n'ont pas de privilèges d'administrateur. Voir Mise en place des installations à partir de l'Editeur d'options.
Exécuter un programme avant ou après l'installation. | Vous pouvez indiquer qu'un programme personnalisé soit exécuté avant ou après l'installation client.
Voulez-vous que les clients participent au Programme Expérience Client de SOLIDWORKS ? | Vous pouvez indiquer que les machines client participent au Programme Expérience Client de SOLIDWORKS. Des informations au sujet des performances sont envoyées à SOLIDWORKS Corporation dans le but d'améliorer le produit. Le processus est transparent et confidentiel. Pour plus de détails, visitez le site Web du Programme d'amélioration de l'expérience utilisateur.

Limitations des options Exécuter un programme avant ou après l'installation.

Ces options vous permettent d'exécuter d'autres programmes d'installation ou des scripts sur les ordinateurs clients avant ou après le déploiement de SOLIDWORKS, par exemple un script qui installe Microsoft Office.

L'utilisation de ces options est limitée. Un échec se produit si vous utilisez l'une de ces options pour déployer un programme d'installation ou un script qui affiche une interface utilisateur, par exemple un script qui affiche des boîtes de dialogue. Lorsque le déploiement automatique de SOLIDWORKS est en cours d'exécution, il ne peut pas installer SOLIDWORKS sur les ordinateurs cibles.

Pour utiliser les options Exécuter un programme avant l'installation et Exécuter un programme après l'installation, sélectionnez uniquement les programmes qu'il est possible d'installer en mode silencieux.

Logiciel à installer

Vous pouvez indiquer quels composants des produits SOLIDWORKS doivent être installés.
  • Le fait de cocher la case adjacente au composant du produit inclut celui-ci à l'installation de clients.
  • Si vous ne cochez pas cette case, le composant n'est pas installé.
  • Si un composant dispose de sous-composants d'installation optionnels, une icône + est visible à côté de son nom. Pour afficher les sous-composants disponibles pour un composant, cliquez sur l'icône +.
  • Si un composant est développé de façon à afficher des sous-composants optionnels, une icône - s'affiche à côté de son nom. Pour réduire la liste des sous-composants, cliquez sur l'icône -.
La spécification des Langues limite le nombre de langues installées pour le produit SOLIDWORKS uniquement. Les installations d'autres produits ne sont pas affectées par cette spécification. Par exemple, eDrawings® installe toutes les langues.

Options Toolbox

Vous pouvez indiquer les normes à prendre en charge et l'emplacement de Toolbox par défaut pour les installations des clients.

Il y a souvent plusieurs utilisateurs accédant à Toolbox partagé, généralement via un emplacement réseau (par ex. un chemin UNC, un dossier partagé ou un lecteur réseau commun).

Si l'emplacement contient une version majeure antérieure de Toolbox, l'installation de clients met à niveau cette version de Toolbox vers la nouvelle version majeure. Les fichiers ne sont plus compatibles avec les anciennes versions majeures de SOLIDWORKS.
Si certains clients continuent d'utiliser une version plus ancienne de SOLIDWORKS, vous devez définir un emplacement différent pour le réseau Toolbox pour les clients qui effectueront la mise à niveau vers une version plus récente.

Pour de plus amples informations sur l’administration SOLIDWORKS Toolbox, voir Toolbox dans l'Aide de SOLIDWORKS.

Installation du logiciel Toolbox sans installer les données Toolbox

Si votre environnement possède un emplacement PDM ou Toolbox/Assistance pour le perçage partagé, vous pouvez définir les installations de clients de sorte qu'elles n'installent pas, ni ne mettent à niveau les données Toolbox dans cet emplacement.

Pour ce faire :
  • Vous n'avez pas encore spécifié la vue locale SOLIDWORKS PDM avant d'installer SOLIDWORKS.
  • Les fichiers de l'emplacement sont en cours d'utilisation et pourraient bloquer les installations SOLIDWORKS.
  • L'emplacement n'est pas disponible et pourrait bloquer les installations SOLIDWORKS.

Lorsque vous configurez les installations de clients pour qu'elles n'installent pas les données Toolbox, le logiciel SOLIDWORKS et les paramètres pointent vers l'emplacement Assistance pour le perçage/Toolbox, mais vous devez installer les données dans un emplacement central ultérieurement.

Pour installer le logiciel SOLIDWORKS sans inclure les données de l'Assistance pour le perçage/Toolbox :
  • Lorsque vous êtes invité à installer/mettre à niveau les fichiers Toolbox, sélectionnez Non, installer le logiciel Toolbox sans inclure les fichiers de données.

Au moins une personne, généralement l'administrateur CAD, doit installer ou mettre à niveau les données de l'Assistance pour le perçage/Toolbox dans l'emplacement central pour que le logiciel fonctionne correctement. Toute personne de l'entreprise peut réaliser cette tâche avec une seule installation manuelle du logiciel SOLIDWORKS. Si vous gérez Toolbox dans SOLIDWORKS PDM, suivez les étapes énoncées à la section Toolbox du Guide d'administration de SOLIDWORKS PDM pour installer ou mettre à niveau les données Toolbox.

Options de client SOLIDWORKS PDM

Vous pouvez sélectionner les options suivantes pour déployer les clients SOLIDWORKS PDM et les compléments :

  • Type de produit PDM
  • Type de client PDM
  • Fonctions
  • Vue du coffre-fort

    Pour ouvrir l'Assistant de configuration des vues, vous devez exécuter l'Editeur d'options du Gestionnaire d'images administratives sur une machine où le client a installé SOLIDWORKS PDM.

    Pour créer la vue de coffre-fort sur l'ordinateur client, vous avez besoin d'un fichier Conisio View Setup (.cvs) qui définit les paramètres de configuration de la vue de coffre-fort sur celui-ci. Vous pouvez faire référence à un fichier .cvs existant ou le créer à partir de l'Editeur d'options du Gestionnaire d'images administratives.

Reportez-vous à la section sur SOLIDWORKS PDM dans l'Aide de SOLIDWORKS pour plus d'informations sur ces clients et compléments.

Options de SolidWorks Electrical

Vous pouvez spécifier les paramètres suivants pour les composants administratifs de SOLIDWORKS Electrical :
  • Chemin d'accès aux données
  • Nom et numéro de port de l'ordinateur Collaborative Server
  • Nom et mot de passe de l'ordinateur SQL Server

Voir SOLIDWORKS Electrical pour plus d'informations sur ces composants.

Sujet parent Affichage et édition des paramètres d'option
Indiquer des paramètres d'option pour les groupes et les ordinateurs
Héritage des paramètres d'option globaux et de groupe
Personnalisation des paramètres pour chaque ordinateur
Présentation de l'installation des licences SolidNetWork
Mise en place des installations à partir de l'Editeur d'options
SOLIDWORKS Electrical


Héritage des paramètres d'option globaux et de groupe

Les paramètres d'option pour Paramètres globaux ou de groupe sont hérités par des éléments situés dessous.

Par exemple :
  • Les paramètres définis pour Paramètres globaux sont hérités par tous les groupes et ordinateurs.
  • Les paramètres définis pour un groupe sont hérités par tous les sous-groupes et ordinateurs au sein du groupe.

Vous pouvez modifier les paramètres d'option pour un groupe, un sous-groupe ou un ordinateur pour écraser les paramètres hérités ou par défaut. Lorsque vous modifiez un paramètre hérité en changeant sa valeur par défaut ou héritée, cette option est mise en surbrillance.

Pour restaurer les paramètres d'option aux valeurs héritées d'origine, cliquez à l'aide du bouton droit de la souris sur le groupe, le sous-groupe ou l'ordinateur, puis cliquez sur l'une des options suivantes :
  • Restaurer les paramètres globaux (pour un groupe, un sous-groupe ou un ordinateur qui n'est pas membre du groupe)
  • Restaurer les paramètres du groupe (pour un ordinateur qui est membre du groupe)
  • Restaurer les paramètres du groupe sur tous les membres (pour tous les membres de ce groupe en même temps)
Sujet parent Affichage et édition des paramètres d'option
Indiquer des paramètres d'option pour les groupes et les ordinateurs
Paramètres d'options relatifs à l'image administrative
Personnalisation des paramètres pour chaque ordinateur


Personnalisation des paramètres pour chaque ordinateur

Vous pouvez également modifier des paramètres que vous avez appliqués à des ordinateurs spécifiques en cliquant avec le bouton droit sur le nom de l'ordinateur.

A partir du menu contextuel, vous pouvez exécuter les tâches suivantes pour chaque ordinateur :
  • Renommer
  • Supprimer l'ordinateur
  • Restaurer les paramètres globaux
  • Editer les notes
  • Options d'édition

L'édition d'options vous permet de modifier toutes les options pour l'ordinateur, par exemple les options d'installation client et les options administratives.

Sujet parent Affichage et édition des paramètres d'option
Indiquer des paramètres d'option pour les groupes et les ordinateurs
Paramètres d'options relatifs à l'image administrative
Héritage des paramètres d'option globaux et de groupe


Mise en place des installations à partir de l'Editeur d'options

Vous pouvez déployer les installations directement depuis l'Editeur d'options en vous servant d'une méthode manuelle ou Push.

  • Utilisez la page Déployer manuellement de l'Editeur d'options pour envoyer aux utilisateurs par courrier électronique des instructions sur la façon de démarrer l'installation. Utilisez cette méthode quand les utilisateurs ont des privilèges d'administrateur pour leurs ordinateurs clients.
    Sous Options d'administration, vous pouvez attribuer des autorisations administratives à des utilisateurs en sélectionnant Exécuter l'installation sous un autre nom d'utilisateur.
  • Utilisez la page Déployer automatiquement de l'Editeur d'options pour pousser automatiquement des installations sur des ordinateurs cibles. Utilisez cette méthode quand des utilisateurs n'ont pas de privilèges d'administrateur pour installer des logiciels sur leurs systèmes. Vous pouvez également réaliser des installations personnalisées avec cette méthode.

Pour déployer manuellement ou automatiquement, vous devez stocker le répertoire d'installation de l'image administrative en un répertoire partagé de Windows, de sorte qu'il soit disponible via un emplacement réseau, par exemple \\machine\shared_directory. Vous pouvez également rendre l'image disponible en la copiant vers un répertoire local sur chaque machine, comme C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0.

Table des matières

  • Utilisation d'un chemin UNC pour déployer une image administrative

    Au lieu de mapper les emplacements des lecteurs réseau, utilisez un chemin UNC (\\machine_name\share_name) lorsque vous spécifiez un emplacement réseau pour le répertoire d'installation de l'image administrative.

  • Utilisation de StartSWInstall.exe pour déployer une image administrative

  • Déployer manuellement

    Vous pouvez utiliser cette méthode si les utilisateurs ont les privilèges nécessaires pour effectuer l'installation sur leurs systèmes.

  • Prérequis pour le déploiement automatique

    Le déploiement automatique est efficace pour les utilisateurs qui ne disposent pas de privilèges d'administration, car il garantit une installation en toute transparence du logiciel.

  • Déploiement automatique

  • Test d'une configuration pour un déploiement Push

    L'onglet Déployer automatiquement dans l'Editeur d'options du Gestionnaire d'images administratives contient une fonction de test.

Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Affichage et édition des paramètres d'option
Quitter l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options
Déployer une image administrative sur des clients par courrier électronique


Utilisation d'un chemin UNC pour déployer une image administrative

Au lieu de mapper les emplacements des lecteurs réseau, utilisez un chemin UNC (\\machine_name\share_name) lorsque vous spécifiez un emplacement réseau pour le répertoire d'installation de l'image administrative.

Les lecteurs réseau mappés ne sont pas compatibles avec les méthodes d'installation poussée et automatique, ni avec Exécuter l'installation sous un autre nom d'utilisateur de la méthode d'ouverture et manuelle.

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Utilisation de StartSWInstall.exe pour déployer une image administrative

Vous pouvez installer ou désinstaller une image administrative sur les clients en exécutant la commande admin_image_install_dir\ StartSWInstall.exe. Cette méthode permet d'installer SOLIDWORKS à l'aide des options, des ordinateurs et des groupes définis dans l'Editeur d'options du Gestionnaire d'images administratives.

Vous pouvez ajouter à la commande StartSWInstall.exe les commutateurs suivants :
Commutateur | Description
/install | Installe l'image administrative sur les ordinateurs clients.
/uninstall Désinstalle le logiciel des ordinateurs clients, avec deux commutateurs facultatifs :

/removedata

Disponible pour la désinstallation seulement. Supprime les fichiers de données et les dossiers de SOLIDWORKS durant la désinstallation.

/removeregistry

Disponible pour la désinstallation seulement. Supprime les entrées de Registre de SOLIDWORKS durant la désinstallation.
/showui | Affiche une fenêtre de progression pour le Gestionnaire d'installation de SOLIDWORKS. Sinon, le Gestionnaire d'installation de SOLIDWORKS est masqué pour l'utilisateur.
/now | Démarre immédiatement l'installation ou la désinstallation. La boîte de dialogue d'avertissement de 5 minutes ne s'affiche pas.

StartSWInstall.exe est préférable à l'utilisation de StartSWInstall.hta lorsque vous souhaitez que l'installation continue sans interaction avec l'utilisateur, mais ne voulez pas utiliser le déploiement automatique depuis l'Editeur d'options d'image administrative.

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Déployer manuellement

Vous pouvez utiliser cette méthode si les utilisateurs ont les privilèges nécessaires pour effectuer l'installation sur leurs systèmes.

Pour déployer des installations manuellement en utilisant le courrier électronique :

  1. Dans l'Editeur d'options, cliquez sur Mettre en place.
    La disponibilité et le statut de l'installation s'affichent pour chaque ordinateur.
  2. Cliquez sur Envoyer courrier électronique.
  3. Indiquez le chemin d'accès au réseau pour le répertoire d'installation d'images administratives.
    En principe, le chemin d'accès au répertoire d'installation d'images administratives est indiqué au début comme chemin d'accès à un fichier Windows (par exemple C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0). La boîte de dialogue indique Il ne s'agit pas d'un chemin d'accès réseau.
    1. Cliquez sur Parcourir pour indiquer l'emplacement réseau du répertoire d'installation de cette image administrative.
    2. Naviguez jusqu'à l'ordinateur où l'image administrative est installée et sélectionnez le répertoire partagé Windows indiqué comme répertoire d'installation d'image administrative.
      Ne naviguez pas à l'intérieur du répertoire partagé de l'image administrative (par exemple, dans les sous-répertoires 64bits).
    3. Cliquez sur OK.
      La boîte de dialogue indique Il s'agit d'un chemin d'accès réseau.
    Un courrier électronique est généré pour indiquer au propriétaire de l'ordinateur comment effectuer l'installation à partir de l'image administrative à l'aide de l'emplacement réseau pour le fichier StartSWInstall.hta dans l'image administrative.
  4. Envoyez le courrier électronique aux utilisateurs responsables de l'installation de SOLIDWORKS.

Dans le message électronique, les utilisateurs peuvent double-cliquer sur le lien correspondant à l'emplacement réseau de StartSWInstall.hta afin d'installer SOLIDWORKS à partir de l'image administrative.

Dans l'Editeur d'options, Etat de l'installation indique :
En attente | L'utilisateur n'a pas encore exécuté l'installation sur cet ordinateur.
Réussi | L'utilisateur a exécuté l'installation sur cet ordinateur.
Echoué | L'utilisateur a exécuté l'installation sur cet ordinateur mais elle a échoué.
Les autres messages d'état qui peuvent s'afficher sont les suivants : Installé avec succès, Désinstallé avec succès, Installation, Désinstallation, Démarrage requis, Echec de l'installation, et Echec de la désinstallation.
En haut de la colonne Etat, cliquez sur la flèche verte pour actualiser et afficher les informations mises à jour.
Sujet parent Mise en place des installations à partir de l'Editeur d'options


Prérequis pour le déploiement automatique

Le déploiement automatique est efficace pour les utilisateurs qui ne disposent pas de privilèges d'administration, car il garantit une installation en toute transparence du logiciel.

Pour utiliser le déploiement automatique, le client et le serveur doivent appartenir au même domaine Active Directory. Cette configuration permet de transférer les tâches d'installation vers les machines cibles, où elles sont exécutées par le Planificateur de tâches Microsoft sans aucune action de l'utilisateur.

Avec une installation poussée, le planificateur des tâches exécute une tâche qui démarre le Gestionnaire d'installation SOLIDWORKS sur un ordinateur client en utilisant les identifiants spécifiés par un administrateur dans l'Editeur d'options. Le Planificateur de tâches s'exécute sous le compte LocalSystem de l'ordinateur. Ce compte est représenté sur le réseau comme un principe de sécurité de l'ordinateur. Le principe de sécurité de l'ordinateur doit avoir les accès suivants :
  • Accès en lecture au dossier Images Admin.
  • Accès en lecture et écriture au dossier Images Admin.\x64\journaux.

Dans Active Directory, lorsque vous ajoutez un ordinateur à un groupe faisant partie d'un Dossier partagé, sélectionnez Types d'objets et Ordinateurs.

De plus, l'ordinateur serveur de l'image administrative et les machines clientes cibles doivent être membres du même domaine Active Directory.

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Déploiement automatique

Pour déployer automatiquement en poussant des installations vers des systèmes utilisateur :

  1. Dans l'Editeur d'options, cliquez sur l'onglet Déployer automatiquement.
    La disponibilité et le statut de l'installation s'affichent pour chaque ordinateur.
  2. Dans la colonne Déploiement, sélectionnez les ordinateurs et les groupes clients cibles.
    Sélectionnez un ou plusieurs ordinateurs ou groupes dans la colonne Déploiement avant de démarrer le processus de déploiement.
  3. Sous Moment d'installation, sélectionnez Maintenant pour déployer tout de suite ou Plus tard pour planifier une date et une heure spécifiques pour le déploiement.
  4. Sous Options du client, choisissez parmi les options suivantes :
    • Installer ou mettre à niveau SOLIDWORKS 2025
    • Désinstaller SOLIDWORKS 2025
      Si vous choisissez de désinstaller, vous pouvez choisir de désinstaller les entrées de registre et les fichiers et les dossiers de données avec les fichiers et les dossiers de programme.
  5. Sélectionnez Redémarrer automatiquement l'ordinateur si vous souhaitez qu'un ou plusieurs ordinateurs cibles redémarrent, si nécessaire, pendant ou après le déploiement.
  6. Saisissez les Infos d'identification du client d'une ou de plusieurs ordinateurs cibles.
  7. Cliquez sur Déploiement pour démarrer le processus de déploiement.
Dans l'Editeur d'options, l'Etat de l'installation indique :
En attente | L'installation n'a pas encore été exécutée sur cet ordinateur.
Réussi | L'installation est terminée sur cet ordinateur.
Echoué | L'installation a échoué sur cet ordinateur.

Les autres messages d'état qui peuvent s'afficher sont les suivants : Installé avec succès, Désinstallé avec succès, Planification, Connexion, Installation, Désinstallation, Démarrage requis, Installation planifiée, Désinstallation planifiée, Echec de l'installation, Echec de la désinstallation, Echec de la connexion et Echec de la planification.

Sujet parent Mise en place des installations à partir de l'Editeur d'options


Test d'une configuration pour un déploiement Push

L'onglet Déployer automatiquement dans l'Editeur d'options du Gestionnaire d'images administratives contient une fonction de test.

Vous pouvez exécuter une installation fictive qui entraîne les systèmes utilisés pour le déploiement, par exemple :
  • Connexion à l'ordinateur cible.
  • Création d'une tâche d'installation sur cet ordinateur.
  • Fin de la tâche d'installation sur cet ordinateur.
  • Mise à jour du statut et des journaux sur l'image administrative.
  • Détection d'un programme à exécuter avant ou après l'installation.

Le test vérifie le chemin des fichiers, valide les autorisations et indique que l'installation s'est terminée avec succès. Il n'installe pas de logiciel et ne modifie pas le registre sur le système cible. Si un système échoue sur un ordinateur cible, le test indique quel système a échoué.

Les info-bulles fournissent des informations sur les échecs. Vous pouvez exporter les résultats vers une feuille de calcul .xml ou .csv, ce qui est utile pour examiner plusieurs échecs ou partager les résultats avec d'autres personnes du service de support technique.

Pour tester une configuration en vue d'un déploiement Push :

  1. Avec le Gestionnaire d'installation, créez une Image administrative.
  2. Démarrez l'Editeur d'options du Gestionnaire d'images administratives :

    Vous pouvez démarrer l'option lorsque le Gestionnaire d'installation a terminé de créer l'image administrative, ou double-cliquer sur sldAdminOptionEditor.exe dans le dossier des images administratives.

  3. Dans l'onglet Configuration, ajoutez un ou plusieurs ordinateurs.
  4. Cliquez sur Déployer automatiquement :
    1. Fournissez un nom d'utilisateur et un mot de passe d'administrateur de domaine.
    2. Sélectionnez un ou plusieurs ordinateurs à tester.
    3. Cliquez sur Test.
  5. Lorsque le test de configuration s'affiche, cliquez sur Exécuter le test.
  6. Accordez quelques minutes au test pour qu'il s'exécute, ou cliquez sur Annuler le test quand vous le souhaitez.
  7. Examinez et corrigez les éventuels problèmes de configuration.
Sujet parent Mise en place des installations à partir de l'Editeur d'options


Quitter l'Editeur d'options

Vous pouvez cliquer sur OK ou sur Fermer pour appliquer les modifications et quitter l'Editeur d'options.

  • Cliquez sur OK pour appliquer les modifications des paramètres des options et quittez l'Editeur d'options.
  • Cliquez sur le bouton Fermer de l'application Windows pour quitter l'Editeur d'options. Si le logiciel détecte des modifications non enregistrées, il vous invite à les enregistrer.
Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Affichage et édition des paramètres d'option
Mise en place des installations à partir de l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options
Déployer une image administrative sur des clients par courrier électronique


Création d'un raccourci sur le Bureau vers l'Editeur d'options

Vous pouvez créer un raccourci sur le bureau Windows vers l'Editeur d'options pour une image administrative donnée à partir de l'application.

  1. Démarrez l'Editeur d'options.
    A titre d'exemple, dans l'Explorateur de fichiers, naviguez vers le répertoire d'installation d'images administratives et double-cliquez sur sldAdminOptionEditor.exe.
  2. Cliquez sur Créer un raccourci sur le Bureau vers cet Editeur d'options.
    Un raccourci vers l'Editeur d'options pour l'image administrative s'affiche sur le bureau Windows.
Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Affichage et édition des paramètres d'option
Mise en place des installations à partir de l'Editeur d'options
Quitter l'Editeur d'options
Déployer une image administrative sur des clients par courrier électronique


Déployer une image administrative sur des clients par courrier électronique

Après avoir créé un répertoire d'image administrative partagé, vous pouvez le notifier aux clients par courrier électronique.

Configurez le répertoire d'image administrative à partager sur un ordinateur accessible à d'autres ordinateurs (par exemple, par l'intermédiaire d'un chemin UNC).

Vous pouvez envoyer un courriel contenant un lien vers rép_install_image_admin\StartSWInstall.hta à tous les clients. Les clients peuvent alors cliquer sur ce lien puis sur Installer les produits SOLIDWORKS maintenant : l'installation est alors immédiatement lancée depuis l'image administrative.

Si vous mettez à niveau une image administrative vers une nouvelle version de SOLIDWORKS, vous pouvez configurer votre emplacement d'image administrative et partager les propriétés : tous les clients installés auparavant à l'aide de cette image sont alors automatiquement mis à niveau. Pour plus de détails, voir Mise à niveau de clients à partir d'images administratives.
Sujet parent Editeur d'options du Gestionnaire d'images administratives
Ajouter et supprimer des groupes et des ordinateurs
Affichage et édition des paramètres d'option
Mise en place des installations à partir de l'Editeur d'options
Quitter l'Editeur d'options
Création d'un raccourci sur le Bureau vers l'Editeur d'options


Outil Administrateur des paramètres

Vous pouvez utiliser l'outil Administrateur des paramètres pour spécifier les options système qui sont appliquées lors du déploiement ou de la mise à niveau du logiciel SOLIDWORKS, et pour empêcher les utilisateurs de modifier ces options. Cet outil remplace l'Assistance pour les paramètres de SOLIDWORKS s'il s'agit de déployer des paramètres. Toutefois l'Assistance reste disponible pour copier des paramètres.

Il existe trois étapes pour utiliser l'outil Administrateur des paramètres avec l'Editeur d'options du Gestionnaire d'images administratives :
  1. Créez une image administrative pour accéder à l'outil.
  2. Utilisez l'Administrateur des paramètres pour générer un fichier *.sldsettings contenant les options SOLIDWORKS que vous avez sélectionnées.
  3. Incluez le fichier *.sldsettings dans les installations SOLIDWORKS.
Si vous utilisez le complément 3DEXPERIENCE, vous pouvez également déployer un fichier *.sldsettings en dehors d'une image administrative. L'un des avantages de cette méthode est que les paramètres sont automatiquement déployés lors de la connexion.
  1. Pour accéder à l'outil Administrateur des paramètres, suivez les étapes indiquées dans la section Accès à l'outil Administrateur des paramètres.
  2. Suivez les instructions pour appliquer et verrouiller les paramètres.
  3. Dans 3DEXPERIENCE, à partir du Compass, développez Mes rôles et cliquez sur l'application Platform Manager. Accédez à Contenu > Centre de configuration des espaces de collaboration > Collaboration CAO > SOLIDWORKS > Paramètres > Ressources > Paramètres CAO.
  4. Dans Paramètres CAO, recherchez, chargez et téléchargez le fichier *.sldsettings.

Table des matières

  • Accès à l'outil Administrateur des paramètres

    Pour accéder à l'outil Administrateur des paramètres, vous devez d'abord créer une image administrative.

  • Utilisation de l'outil Administrateur des paramètres

  • Application et verrouillage des options

  • Terminer le paramétrage des options

  • Insertion du fichier sldsettings dans les installations SOLIDWORKS

Sujet parent Utilisation des images administratives


Accès à l'outil Administrateur des paramètres

Pour accéder à l'outil Administrateur des paramètres, vous devez d'abord créer une image administrative.

Vous pouvez lancer l'outil Administrateur des paramètres depuis une image administrative.

Pour accéder à l'outil Administrateur des paramètres :

  1. Exécutez sldAdminOptionEditor.exe dans le dossier de l'image administrative.
  2. Dans l'Editeur d'options du Gestionnaire d'images administratives, cliquez sur Modifier [image].
  3. Dans la section Options d'installation du client, procédez comme suit :
    1. Cliquez sur Utiliser un fichier de paramètres exporté de l'Administrateur des paramètres SOLIDWORKS.
    2. Cliquez sur Lancer l'Administrateur de paramètres.
      Pour accéder à Lancer l'Administrateur de paramètres, SOLIDWORKS <version> doit être installé sur l'ordinateur qui exécute sldAdminOptionEditor.exe.
Sujet parent Outil Administrateur des paramètres


Utilisation de l'outil Administrateur des paramètres

Pour utiliser l'Outil Administrateur des paramètres :

  1. Dans l'onglet Bienvenue, sélectionnez les options suivantes :
    • Ensemble d'options par défaut pour démarrer avec cette version de SOLIDWORKS.
    • Importer les options SOLIDWORKS 2025 depuis cet ordinateur.
    • Rechercher un fichier sldreg existant.
    • Rechercher un fichier .sldsettings existant.
    Le fichier *.sldreg est généré par l'Assistance pour les paramètres de SOLIDWORKS, et le fichier *.sldsettings est généré par l'outil Administrateur des paramètres.
  2. Cliquez sur Suivant.
Sujet parent Outil Administrateur des paramètres


Application et verrouillage des options

Dans l'onglet Options du système, deux colonnes de cases à cocher vous permettent de sélectionner les options à appliquer et les options appliquées à verrouiller pour que les utilisateurs ne puissent pas les modifier.

Lorsque les utilisateurs accèdent à la boîte de dialogue Options du système dans le logiciel SOLIDWORKS, les options verrouillées apparaissent indisponibles avec une icône de verrou [image]. Cependant, vous pouvez créer un mot de passe qui permet aux utilisateurs de déverrouiller les options. Lorsque les utilisateurs survolent une option verrouillée, une info-bulle affiche votre nom et votre e-mail, pour qu'ils puissent vous contacter et demander ce mot de passe.

Pour appliquer et verrouiller des options :

  1. Dans l'onglet Options du système, procédez comme suit :
    1. Pour appliquer une option du système, sélectionnez-la et cochez la case correspondante dans la colonne Appliquer.
    2. Pour verrouiller une option du système, sélectionnez-la et cochez les cases correspondantes à la fois dans les colonnes Appliquer et Verrouiller.
      Lorsque les utilisateurs accèdent à l'onglet Options du système, ces options s'affichent avec un verrou [image].
  2. Selon l'option, vous pouvez avoir à spécifier des paramètres supplémentaires pour l'option.
  3. Vous pouvez également empêcher les utilisateurs d'ignorer les messages en appliquant des contrôles pour les Messages/Erreurs/Avertissements.
    1. Cliquez sur Messages/Erreurs/Avertissements.
    2. Sélectionnez Appliquer et éventuellement Verrouiller pour les messages que vous souhaitez gérer.
    3. Définissez le message sur Afficher ou Ne pas afficher.

      Si vous sélectionnez Afficher, le message est supprimé d'une liste de messages ignorés par l'utilisateur et s'affiche à l'utilisateur au moment voulu. Si vous sélectionnez Ne pas afficher, le message est automatiquement ajouté à une liste de messages ignorés par l'utilisateur, et ne s'affiche pas lorsque l'utilisateur travaille sur un modèle.

      Ce tableau décrit le comportement dans le logiciel :
      Appliquer | Verrouiller | Montrer | Ne pas afficher | Comportement
      X | X | Forcer le message à s'afficher.
      X | X | Ignore le message et ajoute le message à la liste des messages ignorés.
      X | X | X | Force le message à s'afficher et désactive l'option pour Ne plus afficher dans la boîte de message.
      X | X | X | Ignore le message et empêche l'utilisateur de l'activer dans Outils > Options > Messages/Erreurs/Avertissements.
  4. Dans l'onglet Options du système, cliquez sur Suivant.
Sujet parent Outil Administrateur des paramètres


Terminer le paramétrage des options

Pour terminer le paramétrage des options :

  1. Sur l'onglet Terminer, sélectionnez quand les options du système sont applicables :
    • La première fois qu'un utilisateur démarre le logiciel.
    • à chaque démarrage du logiciel.
    • et si les personnalisations s'appliquent en même temps.
  2. Vous pouvez choisir d'appliquer les options verrouillées lorsque les utilisateurs sont hors réseau, et d'autoriser l'API à remplacer les options verrouillées.
  3. Pour les options système verrouillées, vous devez fournir votre Nom et une adresse e-mail. Le logiciel SOLIDWORKS affiche ces informations dans une info-bulle lorsque les utilisateurs déplacent la souris sur une option verrouillée.
  4. Vous pouvez également autoriser les utilisateurs à remplacer les options verrouillées. Vous devez alors spécifier un Mot de passe que vous pouvez fournir aux utilisateurs.
  5. Cliquez sur Enregistrer afin de générer un fichier *.sldsettings pour le déploiement.
Sujet parent Outil Administrateur des paramètres


Insertion du fichier sldsettings dans les installations SOLIDWORKS

Pour inclure un fichier *.sldsettings dans votre installation, procédez comme suit :

  1. Double-cliquez sur sldAdminOptionEditor.exe dans le dossier des images administratives.
  2. Dans l'Editeur d'options du Gestionnaire d'images administratives, cliquez sur Modifier.
  3. Dans la section Options d'installation du client, procédez comme suit :
    1. Cliquez sur Utiliser un fichier de paramètres exporté de l'Administrateur des paramètres SOLIDWORKS.
    2. Cliquez sur Editer la trajectoire et naviguez jusqu'au fichier *.sldsettings.
    Vous pouvez créer et appliquer des fichiers *.sldsettings distincts pour différents groupes ou ordinateurs.
  4. Déployez et installez le logiciel SOLIDWORKS.

Après le déploiement, vous pouvez répéter l'étape 2 pour modifier un fichier *.sldsettings existant à tout moment. Le logiciel SOLIDWORKS lit le fichier *.sldsettings modifié au démarrage suivant.

Sujet parent Outil Administrateur des paramètres


Déploiement avec la ligne de commande

Vous pouvez déployer une image administrative automatiquement en utilisant une Invite ou un fichier de commandes (installation silencieuse).

Pour déployer une image administrative à l'aide de la ligne de commande pour des clients SOLIDWORKS PDM, voir le Guide d'installation de SOLIDWORKS PDM.

Table des matières

  • Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative

    Après avoir créé l'image administrative et avant de notifier les clients, vous devez installer les composants Microsoft Windows qui ne peuvent pas être installés par les images administratives créées en utilisant la ligne de commande ou Microsoft Active Directory.

  • Installer depuis l'image administrative en utilisant la ligne de commande

    Vous pouvez déployer des installations à partir d'une image administrative en utilisant la ligne de commande.

  • Propriétés de la ligne de commande

    Les propriétés de la ligne de commande décrites ici comprennent les propriétés de fonctions, les propriétés globales, les propriétés spécifiques aux produits et les conventions d'emplacements de Windows.

  • Déployer une image administrative en utilisant Microsoft Active Directory

    Le déploiement avec Microsoft Active Directory est pris en charge dans le cadre du déploiement du produit SOLIDWORKS principal sur les clients.

Sujet parent Installations multiples
Déployer vers des clients multiples
Utilisation des images administratives
Administration d'installations multiples


Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative

Après avoir créé l'image administrative et avant de notifier les clients, vous devez installer les composants Microsoft Windows qui ne peuvent pas être installés par les images administratives créées en utilisant la ligne de commande ou Microsoft Active Directory.

L'installation manuelle de ces composants Windows n'est nécessaire que si vous installez à partir d'une image administrative à l'aide de la ligne de commande ou via Microsoft Active Directory. Si vous utilisez le Gestionnaire d'installation SOLIDWORKS pour créer et installer l'image administrative, ces composants Windows sont installés automatiquement.
Voici un résumé des fichiers requis par SOLIDWORKS dans les composants Windows :
Windows Performance Toolkit | Active la journalisation étendue dans SOLIDWORKS Rx.
Visual C++ 2022 Redistributable Package | Contient les composants d'exécution pour Microsoft Visual C++. La version 2022 doit être installée.
Visual Basic for Applications 7.1 | Fournit la prise en charge des macros Visual Basic.
Visual Studio Tools for Application 2022 | Facultatif. Contient un ensemble d'outils pour la prise en charge des applications Visual Studio 2022 (VSTA17).
.NET Framework 4.8 | Contient le Common Language Runtime (CLR) et les composants du .NET Framework nécessaires à l'exécution des applications .NET Framework 4.8.
SWCEF | Chromium Embedded Framework (CEF) est utilisé pour afficher le contenu de 3DEXPERIENCE platform.
Microsoft Edge WebView2 | Requis pour afficher le contenu Web.
SOLIDWORKS Login Manager | Permet de se connecter à 3DEXPERIENCE Marketplace et à d'autres applications 3DEXPERIENCE.
Visual C++ Redistributable Package et .NET Framework 4.8 sont requis pour tous les produits SOLIDWORKS, pas seulement pour le produit SOLIDWORKS principal.

Ces composants doivent être inclus dans des sous-répertoires du répertoire de l'image administrative.

Le tableau suivant identifie les fichiers requis pour chaque système d'exploitation pris en charge.
Système d'exploitation : Windows Server 2019 64 bits et Windows Server 2022 64 bits
L'installation sur Windows Server 2019 et 2022 est prise en charge pour SOLIDWORKS PDM Server et SOLIDWORKS SolidNetWork License Manager.
Windows Performance Toolkit : | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package: | vc_redist.x86.exe vc_redist.x64.exe Les deux doivent être installés.
Visual Basic 7.1 : | vba71.msi et vba71_1033.msi Plus un package de langue facultatif.
.NET Framework 4.8 : | ndp48-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge WebView2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
Système d'exploitation : Windows 10 et Windows 11 64 bits
Windows Performance Toolkit : | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package: | vc_redist.x86.exe vc_redist.x64.exe Les deux doivent être installés.
Visual Basic 7.1 : | vba71.msi et vba71_1033.msi Plus un package de langue facultatif.
.NET Framework 4.8 : | .NET 4.8 fait partie du système d'exploitation, qui satisfait à cette condition.
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge WebView2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

Table des matières

  • Installer les composants Windows prérequis depuis la ligne de commande sur des systèmes d'exploitation 64 bits

    Vous pouvez suivre ce processus pour installer les prérequis Windows pour une installation d'image administrative utilisant la ligne de commande sur des versions 64 bits de Windows.

Sujet parent Déploiement avec la ligne de commande
Installer depuis l'image administrative en utilisant la ligne de commande
Propriétés de la ligne de commande
Déployer une image administrative en utilisant Microsoft Active Directory


Installer les composants Windows prérequis depuis la ligne de commande sur des systèmes d'exploitation 64 bits

Vous pouvez suivre ce processus pour installer les prérequis Windows pour une installation d'image administrative utilisant la ligne de commande sur des versions 64 bits de Windows.

Pour installer plusieurs composants en un seule opération, créez un fichier de commandes contenant les commandes fournies dans les procédures suivantes et utilisez-le pour forcer les composants sur les ordinateurs clients.

  1. Assurez-vous que l'ordinateur cible dispose d'au moins 620 Mo d'espace libre et un répertoire TEMP valide.
  2. Installez Visual C++ VERSION Redistributable Packages. Les versions 32 et 64 bits de chaque package doivent toutes deux être installées.
    Installez le package pour VERSION = 2022.

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. Installez Microsoft .NET Framework 4.8 :
    répertoire_image_administrative\.Net_Framework_4.8\ndp48-x86-x64-allos-enu.exe
  4. Installez Visual Studio Tools for Applications 2022 :
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. Installez Visual Basic 7.1:
    administrative_image_directory\Microsoft_VBA\vba71.msi et administrative_image_directory\Microsoft_VBA\vba71_1033.msi sont nécessaires pour toutes les langues.
    Seule la version 64 bits de ce package doit être installée.

    De plus, installer le package suivant pour la langue souhaitée :

    vba71_1028.msi | Chinois
    vba71_1031.msi | Allemand
    vba71_1036.msi | Français
    vba71_1040.msi | Italien
    vba71_1041.msi | Japonais
    vba71_1042.msi | Coréen
    vba71_1046.msi | Portugais brésilien
    vba71_2052.msi | Chinois simplifié
    vba71_3082.msi | Espagnol
    L'anglais, le tchèque, le polonais le russe et le turc ne nécessitent pas de packages de langue supplémentaires.
  6. Installez SOLIDWORKS Chromium Embedded Framework (SWCEF) :
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. Installez SOLIDWORKS Login Manager :
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
Sujet parent Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative


Installer depuis l'image administrative en utilisant la ligne de commande

Vous pouvez déployer des installations à partir d'une image administrative en utilisant la ligne de commande.

Pour effectuer une installation silencieuse:

  1. Ouvrez une fenêtre d'invite de commandes (sous Windows, cliquez sur Démarrer > Exécuter).
  2. Saisissez la commande msiexec.exe avec les commutateurs /i et /qb et spécifiez les propriétés des options qui ne sont pas les valeurs par défaut comme indiqué ci-dessous.

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

Les propriétés de la ligne de commande de composants d'installation individuelle incluent :
  • Propriétés des fonctions de la ligne de commande
  • Propriétés générales de la ligne de commande
  • eDrawings Propriétés de la ligne de commande
  • Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation

Utilisez les exemples suivants comme modèles pour une installation silencieuse.

Client SOLIDWORKS

  • Produit principal SOLIDWORKS (anglais)
  • Complément de la boîte à outils
  • Participation au programme expérience client
  • Français

SOLIDWORKS:

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

Le composant d'installation de la langue française de SOLIDWORKS doit être installé séparément :

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

Lorsque vous indiquez les commandes d'installation du composant de la langue SOLIDWORKS, ne spécifiez pas d'arguments de ligne de commande.

Client eDrawings

  • Toutes les fonctions

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

En raison de la complexité technique inhérente à l'installation de SOLIDWORKS Electrical avec Microsoft SQL Server, les exemples de ligne de commande pour SOLIDWORKS Electrical sont exclus de la documentation.

SOLIDWORKS Visualize et Visualize Boost

Pour SOLIDWORKS Visualize :

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

Pour SOLIDWORKS Visualize Boost :

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

Sujet parent Déploiement avec la ligne de commande
Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative
Propriétés de la ligne de commande
Déployer une image administrative en utilisant Microsoft Active Directory


Propriétés de la ligne de commande

Les propriétés de la ligne de commande décrites ici comprennent les propriétés de fonctions, les propriétés globales, les propriétés spécifiques aux produits et les conventions d'emplacements de Windows.

Table des matières

  • Propriétés des fonctions de la ligne de commande

    L'installation de SOLIDWORKS prend en charge ces propriétés ADDLOCAL pour le déploiement avec la ligne de commande.

  • Propriétés générales de la ligne de commande

    Chaque propriété est définie pour une installation administrative et individuelle, sauf indication contraire. Les numéros de série peuvent être définis à la fois pour l'installation administrative et pour l'installation individuelle en utilisant les propriétés générales.

  • eDrawings Propriétés de la ligne de commande

    Ces propriétés de ligne de commande sont spécifiques à eDrawings ®.

  • Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player

    Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Composer et à SOLIDWORKS Composer Player.

  • Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation

    Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Flow Simulation.

  • Propriétés de la ligne de commande de SOLIDWORKS Simulation

    Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Inspection.

  • Propriétés de la ligne de commande de SOLIDWORKS Visualize

    Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Visualize.

  • Emplacements des fichiers MSI pour les images administratives

    Pour créer des images administratives à partir de la ligne de commande, les fichiers des composants de produit .msi sont stockés à ces emplacements sur le média SOLIDWORKS.

Sujet parent Déploiement avec la ligne de commande
Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative
Installer depuis l'image administrative en utilisant la ligne de commande
Déployer une image administrative en utilisant Microsoft Active Directory


Propriétés des fonctions de la ligne de commande

L'installation de SOLIDWORKS prend en charge ces propriétés ADDLOCAL pour le déploiement avec la ligne de commande.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
Lors de la spécification des propriétés pour l'installation avec la ligne de commande:
  • SOLIDWORKS ne prend pas en charge l'installation de produits avec l'option ADDSOURCE.
  • Les noms des propriétés doivent respecter la casse, ne peuvent pas contenir d'espace ou de tiret et doivent être séparés par une virgule.
Sujet parent Propriétés de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés générales de la ligne de commande

Chaque propriété est définie pour une installation administrative et individuelle, sauf indication contraire. Les numéros de série peuvent être définis à la fois pour l'installation administrative et pour l'installation individuelle en utilisant les propriétés générales.

Propriété | Description
ENABLEPERFORMANCE Indique si l'application doit automatiquement transmettre des données de performance à SOLIDWORKS Corporation.

1

Envoyer des données sur les performances.

0

Ne pas envoyer de données sur les performances.
INSTALLDIR | Dossier d'installation de SOLIDWORKS.
MBDSERIALNUMBER | Numéro de série du produit SOLIDWORKS MBD (Model Based Definition).
MOTIONSERIALNUMBER | Numéro de série du produit SOLIDWORKS Motion.
OFFICEOPTION Spécifiez le produit à installer :
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL Indiquez ALL pour mettre à jour toutes les fonctions installées.
Spécifiez cette propriété uniquement lors d'une mise à jour vers un nouveau Service Pack d'une version majeure existante (par exemple, mise à jour d'une installation SOLIDWORKS 2025 SP01 existante vers SOLIDWORKS 2025 SP02).
REINSTALLMODE Options de réinstallation de Microsoft Installer.

Par exemple, lors de la mise à jour d'une installation d'une version de Service Pack à une autre dans la même version majeure, vous devez indiquer REINSTALLMODE=vomus.

Pour plus d'informations sur les paramètres de REINSTALLMODE, voir la documentation de Windows Installer à l'adresse www.microsoft.com.

Spécifiez cette propriété uniquement lors d'une mise à jour vers un nouveau Service Pack d'une version majeure existante (par exemple, mise à jour d'une installation SOLIDWORKS 2025 SP01 existante vers SOLIDWORKS 2025 SP02). Ne spécifiez pas cette propriété lors de la première installation d'une nouvelle version majeure de SOLIDWORKS.
SERVERLIST Liste de serveurs SolidNetWork.
La liste de serveurs SolidNetWork est une liste délimitée de chaînes, chacune d'entre elles fait référence à un numéro de port sur un serveur au format :
  • Trièdre (délimité par des virgules) =xxxxx@nom_serveur1,yyyyy@nom_serveur2,zzzzz@nom_serveur3
  • Non trièdre (délimité par des points-virgules) = xxxxx@nom_serveur1;yyyyynom_serveur2;zzzzz@nom_serveur3
X et Y représentent un seul chiffre. Ne mettez pas de séparateur après le dernier serveur de la liste.
SIMULATIONSERIALNUMBER | Numéro de série du produit SOLIDWORKS Motion.
SOLIDWORKSSERIALNUMBER | Numéro de série du produit SOLIDWORKS, y compris tous les compléments.
SWMIGRATE Version de SOLIDWORKS à mettre à niveau telle qu'elle apparaîtrait dans la boîte de dialogue Choix de l'installation SOLIDWORKS. Par exemple :

SWMIGRATE="SOLIDWORKS 2025 x64 Edition SP01"

Indiquez cette propriété uniquement lors de l'installation d'une nouvelle version majeure alors que la version majeure antérieure est toujours installée. N'indiquez pas cette propriété lors de la mise à niveau d'une version de Service Pack à une autre dans la même version majeure.
TOOLBOXFOLDER Dossier d'installation des fichiers SOLIDWORKS Toolbox.

Par exemple : TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Si votre environnement possède un emplacement PDM ou Toolbox/Assistance pour le perçage partagé, vous pouvez spécifier une installation de clients de sorte qu'elle n'installe pas, ni ne mette à niveau les données Toolbox dans cet emplacement avec la propriété NOTTOOLBOXSETUP. Spécifiez les paramètres suivants :

0 | Installer les fichiers Toolbox.
1 | Ne pas installer les fichiers Toolbox.
TRANSFORMS Contient des informations spécifiques à la langue en format :
TRANSFORMS numéro.mst
  • Chinois (1028)
  • Chinois simplifié (2052)
  • Tchèque (1029)
  • Anglais (1033)
  • Français (1036)
  • Allemand (1031)
  • Italien (1040)
  • Japonais (1041)
  • Coréen (1042)
  • Polonais (1045)
  • Portugais (Brésil) (1046)
  • Russe (1049)
  • Espagnol (1034)
  • Turc (1055)
UPGRADESWINSTALL
Indiquez s'il faut ou non mettre à niveau une version existante de SOLIDWORKS vers la version actuelle.
0 | Nouvelle installation, ne pas mettre à jour.
1 | Mettre à jour
Indiquez cette propriété uniquement lors de l'installation d'une nouvelle version majeure alors que la version majeure antérieure est toujours installée. Ne spécifiez pas cette propriété en cas de mise à niveau d'un Service Pack vers un autre faisant partie de la même version majeure.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


eDrawings Propriétés de la ligne de commande

Ces propriétés de ligne de commande sont spécifiques à eDrawings ®.

Propriété | Description
ADDLOCAL Spécifie quelle portion de l'application eDrawings doit être installée.
All est l'option recommandée.
Syntaxe de la ligne de commande | Fonction
All | Installe tous les composants. L'application eDrawings vérifie que les applications de publication pour SOLIDWORKS et AutoCAD sont installées pour valider l'installation.
CALS | Visionner des fichiers CAL dans l'eDrawings Viewer
Inventor | Créer des fichiers eDrawings à partir de l'application Autodesk Inventor.
eDrawingsViewer | Visionner des fichiers eDrawings et autres.
ProE | Visionner des fichiers ProE à l'aide d'eDrawings Viewer
DXFDWGTranslator | Visionner des fichiers DXF/DWG dans l'eDrawings Viewer.
Shortcuts | Installer un raccourci sur le bureau.
XML3D | Visionner des fichiers 3D XML dans l'eDrawings Viewer.
INSTALLDIR | Spécifie le dossier d'installation pour eDrawings
SNLSERVER Entrez le port@nomserveur pour votre serveur SolidNetWork License. Utilisez des points-virgules pour séparer plusieurs combinaisons de port@nomserveur .

Un nom de serveur de port pour SNLSERVER et une SERVERLIST sont uniquement requis pour la configuration du serveur SNL de SOLIDWORKS.

La liste de serveurs SolidNetWork est une liste délimitée de chaînes, chacune d'entre elles fait référence à un numéro de port sur un serveur au format :
  • Trièdre (délimité par des virgules)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

  • Non trièdre (délimité par des points-virgules)

    = xxxx@server_name1,yyyy@server_name2,zzzz@server_name3

X et Y représentent un seul chiffre. Ne mettez pas de point-virgule après le dernier serveur de la liste.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player

Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Composer et à SOLIDWORKS Composer Player.

Pour SOLIDWORKS Composer :

Propriété | Description
ACTIVSERIALNUMBER | Numéro de série de SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | C'est facultatif Numéro de série de SOLIDWORKS Composer Player Pro.
ADDLOCAL Facultatif. Si vous installez l'application complète, vous n'avez pas besoin de spécifier la propriété ADDLOCAL.
Pour une installation personnalisée, utilisez ADDLOCAL ainsi que les éléments requis suivants :
  • Licensing
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
Vous pouvez également utiliser ADDLOCAL avec Sync3Dvia, mais ce n'est pas requis.
INSTALLDIR | Spécifie le dossier d'installation du logiciel SOLIDWORKS Composer.

Pour SOLIDWORKS Composer Player :

Propriété | Description
ACTIVSERIALNUMBERPLAYERPRO | C'est facultatif Numéro de série de SOLIDWORKS Composer Player Pro.
INSTALLDIR | Spécifie le dossier d'installation du logiciel SOLIDWORKSComposer Player.
Sur les ordinateurs où SOLIDWORKS n'est pas installé, vous devez utiliser SOLIDWORKS Translator pour importer des fichiers SOLIDWORKS dans SOLIDWORKS Composer. Pour déployer SOLIDWORKS Translator, vous devez utiliser le Gestionnaire d'installation SOLIDWORKS. Vous ne pouvez pas utiliser la ligne de commande.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation

Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Flow Simulation.

Propriété | Description
ACTIVSERIALNUMBER Numéro de série de SOLIDWORKS Flow Simulation autonome.

(Installations individuelles et installations de clients réalisées à partir d'une image administrative)
CWUPGRADEINSTALL Met à niveau une version existante d'une application SOLIDWORKS Flow Simulation spécifique.
1 | Mise à jour
2 | Nouvelle installation; nouveau répertoire

(Installations individuelles et installations de clients réalisées à partir d'une image administrative)
INSTALLDIR Spécifie l'installation d'une application SOLIDWORKS Flow Simulation spécifique.

(Installations individuelles uniquement)
SERVERLIST | Liste de chaînes de texte délimitées par des pointsvirgules, chacune d'entre elles faisant référence à un numéro de port sur un serveur: xxxxx@nom_serveur1; yyyyy@nom_serveur2;& où x et y représentent un seul chiffre. Ne mettez pas de point-virgule après le dernier serveur de la liste.
SOLIDWORKSPATH Indique le dossier dans lequel est installé le logiciel SOLIDWORKS.

(Installations individuelles et installations de clients réalisées à partir d'une image administrative)
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés de la ligne de commande de SOLIDWORKS Simulation

Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Inspection.

Propriété | Description
ACTIVSERIALNUMBER | Numéro de série de SOLIDWORKS Inspection. (Installations individuelles et installations de clients réalisées à partir d'une image administrative)
INSTALLDIR | Spécifie l'installation pour le logiciel d'application SOLIDWORKS Inspection. (Installations individuelles uniquement)
SERVERLIST | Liste de chaînes de texte délimitées par des pointsvirgules, chacune d'entre elles faisant référence à un numéro de port sur un serveur: xxxxx@nom_serveur1; yyyyy@nom_serveur2;& où x et y représentent un seul chiffre. Ne mettez pas de point-virgule après le dernier serveur de la liste.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize
Emplacements des fichiers MSI pour les images administratives


Propriétés de la ligne de commande de SOLIDWORKS Visualize

Ces propriétés de ligne de commande sont spécifiques à SOLIDWORKS Visualize.

Propriété | Description
ACTIVSERIALNUMBER | Numéro de série SOLIDWORKS Visualize. (Installations individuelles et installations de clients réalisées à partir d'une image administrative)
INSTALLDIR | Spécifie l'installation pour le logiciel d'application SOLIDWORKS Visualize. (Installations individuelles uniquement)
SERVERLIST | Liste de chaînes de texte délimitées par des pointsvirgules, chacune d'entre elles faisant référence à un numéro de port sur un serveur: xxxxx@nom_serveur1; yyyyy@nom_serveur2;& où x et y représentent un seul chiffre. Ne mettez pas de point-virgule après le dernier serveur de la liste.
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Emplacements des fichiers MSI pour les images administratives


Emplacements des fichiers MSI pour les images administratives

Pour créer des images administratives à partir de la ligne de commande, les fichiers des composants de produit .msi sont stockés à ces emplacements sur le média SOLIDWORKS.

SOLIDWORKS (produit principal, anglais)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (composants pour des langues autres que l'anglais)

Chinois Traditionnel | swwi\lang\chinese\chinese.msi
Chinois simplifié | swwi\lang\chinese-simplified\chinese-simplified.msi
Tchèque | swwi\lang\czech\czech.msi
Français | swwi\lang\french\french.msi
Allemand | swwi\lang\german\german.msi
Italien | swwi\lang\italian\italian.msi
Japonais | swwi\lang\japanese\japanese.msi
Coréen | swwi\lang\korean\korean.msi
Polonais | swwi\lang\polish\polish.msi
Portugais (brésilien) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
Russe | swwi\lang\russian\russian.msi
Espagnol | swwi\lang\spanish\spanish.msi
Turc | swwi\lang\turkish\turkish.msi

DocManager API

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Simulation d'écoulement

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace for SOLIDWORKS

marketplace\3dexperience marketplace.msi

Gestionnaire de licences SolidNetWork

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage Client

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional fournit une API, mais elle n'est disponible que pour le client et n'est pas disponible dans un fichier .msi. Pour plus d'informations, voir le Guide API dans le répertoire install\API du client SOLIDWORKS PDM.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
Sujet parent Propriétés de la ligne de commande
Propriétés des fonctions de la ligne de commande
Propriétés générales de la ligne de commande
eDrawings Propriétés de la ligne de commande
Propriétés de la ligne de commande de SOLIDWORKS Composer/Composer Player
Propriétés de la ligne de commande de SOLIDWORKS Flow Simulation
Propriétés de la ligne de commande de SOLIDWORKS Simulation
Propriétés de la ligne de commande de SOLIDWORKS Visualize


Déployer une image administrative en utilisant Microsoft Active Directory

Le déploiement avec Microsoft Active Directory est pris en charge dans le cadre du déploiement du produit SOLIDWORKS principal sur les clients.

Microsoft Active Directory est un service d'annuaire pour la gestion des clients et des serveurs dans les environnements réseau. Il simplifie les tâches de gestion, de migration et de déploiement.

Contactez votre revendeur pour obtenir des informations sur l'installation de SOLIDWORKS via Microsoft Active Directory.

Sujet parent Déploiement avec la ligne de commande
Préparer les clients pour l'installation en utilisant la ligne de commande à partir d'une image administrative
Installer depuis l'image administrative en utilisant la ligne de commande
Propriétés de la ligne de commande


Administration d'installations multiples

Dans le cas des installations multiples, les tâches administratives comprennent la mise à niveau des images administratives vers de nouvelles versions, l'application de services packs et la suppression d'installations.

Table des matières

  • Mettre à niveau des images administratives vers une nouvelle version

    Pour mettre à jour des clients installés à partir d'une image administrative, commencez par mettre à jour cette dernière puis configurez les clients pour qu'ils référencent la nouvelle copie de l'image.

  • Administration des mises à jour de produits au moyen des service packs

    Les mises à jour de produits au moyen des service packs visent à améliorer la fiabilité du système, la compatibilité des programmes, la sécurité, etc.

  • Supprimer une installation

    Vous pouvez supprimer une installation sur un ordinateur individuel ou dans un environnement client/serveur.

Sujet parent Installations multiples
Déployer vers des clients multiples
Utilisation des images administratives
Déploiement avec la ligne de commande


Mettre à niveau des images administratives vers une nouvelle version

Pour mettre à jour des clients installés à partir d'une image administrative, commencez par mettre à jour cette dernière puis configurez les clients pour qu'ils référencent la nouvelle copie de l'image.

Exécutez le Gestionnaire d'installation SOLIDWORKS à partir de la Page de téléchargements SOLIDWORKS afin que les bons fichiers soient référencés.

Une fois l'image administrative mise à jour, ce qui a pour effet de créer une nouvelle copie de l'image, vous pouvez mettre à jour les clients en les faisant référencer la nouvelle copie de l'image administrative.

Si les clients référençaient la version précédente de l'image administrative via un répertoire partagé, il est possible de redéfinir ce répertoire en utilisant l'emplacement de l'image administrative mise à jour.

Table des matières

  • Télécharger des fichiers d'installation mis à jour pour les images administratives

    Le Gestionnaire d'installation SOLIDWORKS peut détecter quand vous avez besoin de fichiers d'installation mis à jour lors de la mise à niveau d'une image administrative.

  • Mise à niveau d’une image administrative

    Pour mettre à niveau une image administrative, le Gestionnaire d'installation SOLIDWORKS crée un nouveau répertoire d'image. Vous dirigez ensuite les clients vers ce nouveau répertoire d'image administrative pour mettre à niveau vers cette version du produit.

  • Mise à niveau de clients à partir d'images administratives

    Le Gestionnaire d'installation SOLIDWORKS peut automatiquement mettre à jour des ordinateurs clients installés à partir d'une image administrative.

Sujet parent Administration d'installations multiples
Administration des mises à jour de produits au moyen des service packs
Supprimer une installation


Télécharger des fichiers d'installation mis à jour pour les images administratives

Le Gestionnaire d'installation SOLIDWORKS peut détecter quand vous avez besoin de fichiers d'installation mis à jour lors de la mise à niveau d'une image administrative.

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Dans l'écran Bienvenue, sélectionnez Image administrative.
  3. Sur l'écran Numéro de série, entrez le numéro de série de SOLIDWORKS.
    Le Gestionnaire d'installation SOLIDWORKS recherche les produits pour lesquels vous avez une licence et les service packs disponibles sur le site Web de SOLIDWORKS.
  4. Si l'écran Version plus récente disponible s'affiche, sélectionnez Oui, télécharger et installer une version plus récente : version.
    Le Gestionnaire d'installation SOLIDWORKS lance une nouvelle session pour installer la version la plus récente.
  5. Dans le cas d'un problème du répertoire de téléchargement, l'écran Options de téléchargement peut apparaître; acceptez le répertoire par défaut pour les nouveaux fichiers d'installation ou entrez un nouveau nom de répertoire.
    Si un message vous informe que le répertoire n'existe pas, cliquez sur Oui pour le créer.
  6. Sur l'écran Téléchargement terminé, cliquez sur Fermer pour fermer le programme d'installation actuel et démarrer celui de la nouvelle version.
Sujet parent Mettre à niveau des images administratives vers une nouvelle version
Mise à niveau d’une image administrative
Mise à niveau de clients à partir d'images administratives


Mise à niveau d’une image administrative

Pour mettre à niveau une image administrative, le Gestionnaire d'installation SOLIDWORKS crée un nouveau répertoire d'image. Vous dirigez ensuite les clients vers ce nouveau répertoire d'image administrative pour mettre à niveau vers cette version du produit.

Ce processus suppose que vous avez téléchargé les fichiers d'installation mis à jour pour l'image administrative. Pour plus de détails, reportez-vous à Télécharger des fichiers d'installation mis à jour pour les images administratives.

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Dans l'écran Bienvenue, sélectionnez Image administrative.
    Les options de création d'images administratives s'affichent.
    Option | Description
    Créer une nouvelle image en utilisant les paramètres par défaut. | Créer l'image à l'aide des paramètres de configuration par défaut (sans se baser sur les paramètres définis pour une image administrative existante sur votre site).
    Créer une nouvelle image en utilisant les paramètres et les fichiers d'une image existante. | Créer l'image à l'aide des paramètres de configuration indiqués pour une image administrative existante sur votre site. Cliquez sur Parcourir pour indiquer le répertoire d'installation de l'image administrative existante.
  3. Sur l'écran Numéro de série cochez le numéro de série.
  4. Dans l'écran Résumé (Prêt à créer l'image), vérifiez que les options d'image administrative sont correctes.
    Pour des détails sur les options d'images administratives individuelles et d'installation, cliquez sur MODIFIER pour aller à la page d'options puis cliquez sur ?.
  5. Pour créer la nouvelle version de l'image administrative, cliquez sur Créer maintenant.

Vous pouvez maintenant mettre à niveau les clients vers cette nouvelle version de l'image administrative. Pour plus de détails, voir Mise à niveau de clients à partir d'images administratives.

Sujet parent Mettre à niveau des images administratives vers une nouvelle version
Télécharger des fichiers d'installation mis à jour pour les images administratives
Mise à niveau de clients à partir d'images administratives


Mise à niveau de clients à partir d'images administratives

Le Gestionnaire d'installation SOLIDWORKS peut automatiquement mettre à jour des ordinateurs clients installés à partir d'une image administrative.

En général, les images administratives sont organisées par dossiers sur un serveur. Pour ce faire, l'image administrative doit être située dans un dossier partagé.

Après la mise à niveau de l'image administrative, l'installation d'origine sera dans un dossier et l'installation mise à niveau sera dans un autre. Afin d'utiliser l'installation mise à niveau, supprimez l'option de partage du dossier de l'image administrative d'origine, puis ajoutez-la à celui de l'image administrative mise à niveau.

Au démarrage de SOLIDWORKS sur un ordinateur client installé à partir de l'image administrative d'origine, la nouvelle version est reconnue et le client est mis à niveau.
Lorsque SOLIDWORKS déclenche une mise à jour, d'autres produits installés à partir d'une image administrative se mettent à jour automatiquement.
Sujet parent Mettre à niveau des images administratives vers une nouvelle version
Télécharger des fichiers d'installation mis à jour pour les images administratives
Mise à niveau d’une image administrative

Supprimer l'option de partage du dossier de l'image administrative d'origine

Lorsque vous mettez à niveau une image administrative accessible depuis un dossier partagé, vous devez annuler l'option du partage du dossier d'origine.

  1. Parcourez jusqu'au dossier où se trouvent les fichiers de l'image administrative d'origine.
  2. Cliquez à l'aide du bouton droit de la souris sur le dossier et sélectionnez Propriétés.
  3. Sélectionnez Ne pas partager ce dossier dans l'onglet Partage et cliquez sur OK.

Ajoutez maintenant l'option de partage au dossier d'image administrative mise à niveau comme décrit dans Ajouter l'option de partage à un dossier d'image administrative mise à niveau.

Ajouter l'option de partage à un dossier d'image administrative mise à niveau

Après avoir créé un dossier d'image administrative mise à niveau et désactivé le partage pour le dossier d'image administrative d'origine, vous devez ajouter l'option de partage au nouveau dossier pour réactiver l'image administrative.

  1. Parcourez jusqu'au dossier où se trouvent les fichiers de l'image administrative mise à niveau.
  2. Cliquez à l'aide du bouton droit de la souris sur le dossier et sélectionnez Propriétés.
  3. Dans l'onglet Partage, spécifiez les propriétés de partage appropriées dans votre cas et modifiez le nom du partage au profit de celui utilisé par le dossier de l'image administrative d'origine.
Les ordinateurs installés depuis l'emplacement de partage de l'image administrative d'origine sont automatiquement mis à niveau vers la nouvelle version au démarrage de SOLIDWORKS.


Administration des mises à jour de produits au moyen des service packs

Les mises à jour de produits au moyen des service packs visent à améliorer la fiabilité du système, la compatibilité des programmes, la sécurité, etc.

Vous pouvez les acquérir de deux façons :
  • En utilisant le Gestionnaire d'installation SOLIDWORKS pour rechercher, télécharger et installer des mises à jour.

    Vous pouvez lancer le Gestionnaire d'installation SOLIDWORKS manuellement ou bien planifier une vérification périodique des mises à jour disponibles.

  • En téléchargeant les service packs manuellement depuis le site Web du support SOLIDWORKS.

    Les service packs sont des correctifs appliqués à une version existante du logiciel. Par exemple, SOLIDWORKS 2025 SP1.0 est un service pack de la version SOLIDWORKS 2025 SP0.0. Vous installez ces service packs à l'aide du Gestionnaire d'installation de SOLIDWORKS 2025 ; vous ne pouvez pas les installer avec le Gestionnaire d'installation SOLIDWORKS de la version SOLIDWORKS 2024.

    Pour obtenir de l'aide sur le téléchargement et l'installation de service packs, consultez la documentation relative à l'installation de la version SOLIDWORKS que vous mettez à jour.

Table des matières

  • Restaurer des service packs antérieurs dans une image administrative

    Vous pouvez faire revenir une image administrative à un service pack antérieur. Si vous avez installé le logiciel SOLIDWORKS à partir de disques, vous avez besoin des disques d'origine pour installer un service pack. Une copie de l'image administrative antérieure doit être disponible.

Sujet parent Administration d'installations multiples
Mettre à niveau des images administratives vers une nouvelle version
Supprimer une installation


Restaurer des service packs antérieurs dans une image administrative

Vous pouvez faire revenir une image administrative à un service pack antérieur. Si vous avez installé le logiciel SOLIDWORKS à partir de disques, vous avez besoin des disques d'origine pour installer un service pack. Une copie de l'image administrative antérieure doit être disponible.

Il n'est pas possible de restaurer un service pack antérieur pour les images administratives qui ont été mises à niveau. Les images administratives créées avec une méthode différente de celle du Gestionnaire d'installation SOLIDWORKS ne peuvent pas être restaurées à une version antérieure. Les clients installés à partir de ces images administratives doivent être désinstallés puis réinstallés en utilisant une image administrative créée depuis la version précédente.
  1. Supprimez le dossier contenant l'image administrative actuelle. Pour ce faire, ouvrez l'Invite de commandes et entrez:
    rmdir /s/q chemin_d'accès_à_l'image_administrative_actuelle
  2. Déplacez la copie de sauvegarde de l'image administrative vers l'emplacement où vous avez supprimé l'image administrative actuelle. Pour ce faire, ouvrez l'Invite de commandes et entrez:
    move chemin_d'accès_à_l'image_administrative_de_sauvegarde chemin_d'accès_à_l'image_administrative_actuelle
    Après avoir restauré une image administrative, les ordinateurs clients sont automatiquement restaurés à la prochaine exécution du logiciel SOLIDWORKS.
Sujet parent Administration des mises à jour de produits au moyen des service packs


SOLIDWORKS PDM et SOLIDWORKS Manage

SOLIDWORKS PDM est un produit de gestion de documents basé sur l'architecture client/serveur précédemment appelée SOLIDWORKS Enterprise PDM. SOLIDWORKS PDM est disponible dans deux types :
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM utilise une base de données Microsoft SQL Server pour gérer les coffres-forts de fichiers.

Ce tableau répertorie les systèmes de base de données, les composants de serveur et les options de client disponibles pour chaque type de produit.
 | PDM Standard | PDM Professional
Conçu pour | Réseaux de bureau petits et moyens, avec généralement moins de 20 utilisateurs simultanés. | Grand réseaux de bureau, avec un grand nombre d'utilisateurs simultanés
Limites | Moins de 1 socket ou 4 cœurs, 1 Go de RAM et une base de données de 10 Go | Limites de SQL Standard : Moins de 4 sockets ou 16 cœurs, 128 Mo de RAM et une base de données de 524 Po
Système de gestion de base de données | Microsoft SQL Server Express 2019 ou versions ultérieures jusqu'à 2022. | Microsoft SQL Server 2019 ou versions ultérieures jusqu'à 2022.
Requiert SolidNetWork License Manager ? | Oui | Oui
Inclut un serveur d'archives et un serveur de base de données ? | Oui | Oui
Inclut le serveur SOLIDWORKS PDM Web2 et le serveur WebAPI ? | Non | Oui
Types de clients | Natif | Natif, basé sur navigateur
Compléments client pour CAD Editor | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Intégration de Microsoft Office
Compléments client pour Contributor | DraftSight | DraftSight, Intégration avec Microsoft Office
Compléments client pour Viewer |  | Intégration de Microsoft Office

SOLIDWORKS Manage Professional offre des outils avancés de gestion des données à SOLIDWORKS PDM Professional. Il permet un contrôle avancé des versions ainsi qu'une gestion des projets, des processus et des éléments. Des tableaux de bord et des rapports interactifs vous aident à suivre les éléments, les activités et la progression des projets.

L'architecture de SOLIDWORKS Manage Professional est similaire à celle de SOLIDWORKS PDM Professional. Il utilise une architecture client/serveur et une base de données Microsoft SQL Server afin de gérer les données de projet et d'élément. Il existe trois services pour les fonctions de base de données, de serveur de fichiers et de serveur Web, qui prennent en charge les clients lourds et les clients de navigateur Web. Ces trois services peuvent être hébergés sur le même serveur ou sur des serveurs différents. Les utilisateurs qui disposent d'une licence SOLIDWORKS Manage Professional Editor peuvent utiliser un complément SOLIDWORKS Manage pour accéder aux données de Manage directement à partir de SOLIDWORKS.

Vous pouvez utiliser le gestionnaire d'installation SOLIDWORKS pour installer le serveur et le client SOLIDWORKS Manage Professional.

Pour obtenir des instructions sur l'installation de SOLIDWORKS Manage Professional, consultez le Guide d'installation de SOLIDWORKS PDM / SOLIDWORKS Manage.

Table des matières

  • Liste des composants serveur de PDM

  • Clarification des différences entre les clients PDM

    Avant d'installer le logiciel client, vous devez déterminer les clients nécessaires en fonction de votre environnement PDM.

  • Avant l'installation de PDM Server

    Retenez les exigences suivantes avant d'installer les composants serveur de PDM :

  • Installer un serveur PDM à l'aide du Gestionnaire d'installation SOLIDWORKS

    Lorsque vous installez le serveur PDM pour PDM Standard, vous pouvez installer le serveur d'archives, le serveur de base de données et le client PDM CAD Editor sur le même ordinateur. Vous n'avez pas besoin d'exécuter l'installation du client séparément.

  • Installation d'un client PDM à l'aide du Gestionnaire d'installation SOLIDWORKS


Liste des composants serveur de PDM

Ce tableau résume les composants serveur de SOLIDWORKS PDM Server.

Serveur | Function | Installation
Microsoft SQL Server Express pour PDM Standard | Gère les données dans les coffres-forts de données SOLIDWORKS PDM. | Peut être installé avec PDM Standard, ou utiliser une version sous licence et installée précédemment.
Microsoft SQL Server pour PDM Professional | Gère les données dans les coffres-forts de données SOLIDWORKS PDM. | C'est nécessaire Vous pouvez également utiliser une version sous licence et installée antérieurement.
Client SolidNetWork License Manager | Gère les licences SOLIDWORKS PDM. | Doit être installé pour permettre la création de nouveaux coffres-forts. Peut être installé avec les composants du serveur SOLIDWORKS PDM lors de l'utilisation du SOLIDWORKS Installation Manager.
Serveur d'archives | Gère les transferts de fichiers entre les clients et les archives du coffre-fort de fichiers et gère les utilisateurs et leurs informations d'identification. | C'est nécessaire Installer avec PDM Standard ou Professional.
Serveur de base de données | Interroge les bases de données PDM pour vérifier la présence de mises à jour, gère les règles d'importation et d'exportation de données, gère le système de messagerie, et planifie la réplication et le stockage en mémoire froide. | C'est nécessaire Installer avec PDM Standard ou Professional.
Serveur Web2 | Permet d'accéder aux coffres-forts de fichiers sur Internet à partir de clients utilisant un navigateur. | C'est facultatif Installer avec PDM Professional uniquement.
Web API Server | Les utilisateurs d'EXALEAD OnePart peuvent faire appel à un serveur Web API pour indexer et récupérer des données SOLIDWORKS PDM. | Facultatif. Installer avec PDM Professional uniquement.

Les serveurs d'archives sont exécutés en tant que services sur le compte système des ordinateurs où ils sont installés. Un serveur d'archives peut héberger plusieurs coffres-forts de fichiers sur le même ordinateur.

Dans une installation autonome, il est possible d'installer sur le même ordinateur le serveur d'archives, le serveur de base de données, le serveur de licences et le serveur Web API, ainsi que la base de données SQL Server ou SQL Express.

Dans un environnement distribué, les composants serveur peuvent résider sur des ordinateurs différents. SOLIDWORKS PDM Professional prend également en charge la réplication des archives de coffre-fort de fichiers et la base de données SQL Server pour améliorer les performances sur les sites distants. Pour plus d'informations, voir le Guide de réplication de SOLIDWORKS PDM Professional.

Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


Clarification des différences entre les clients PDM

Avant d'installer le logiciel client, vous devez déterminer les clients nécessaires en fonction de votre environnement PDM.

Ce tableau résume les clients pour SOLIDWORKS PDM Standard :
Type de client Standard | Description
CAD Editor | Compatible avec les fichiers SOLIDWORKS, DWG/DXF, Microsoft Word et Microsoft Excel. Tous les formats de fichiers pris en charge par le plug-in Office se comportent de la même manière dans SOLIDWORKS PDM Standard, à l'exception d'Aperçu.
Contributeur | Compatible avec les fichiers SOLIDWORKS, DWG/DXF, Microsoft Word et Microsoft Excel.
Visionneuse | Donne l'accès en lecture seule aux coffres-forts de fichiers. L'utilisateur peut effectuer la transition des fichiers via un flux de travail, mais il ne peut ni ajouter ni modifier (extraire, archiver, mettre à jour des valeurs) les fichiers.
Ce tableau résume les clients pour SOLIDWORKS PDM Professional :
Type de client Professional | Description
CAD Editor & Web | Prend en charge le fonctionnement avec tous les types de fichiers, y compris la gestion améliorée et la prévisualisation de formats CAO tels que SOLIDWORKS. Des compléments de CAO permettent aux utilisateurs d'accéder à SOLIDWORKS PDM Professional à partir de l'application de CAO. Les utilisateurs à distance peuvent rechercher dans les coffres-forts et effectuer des fonctions de base sur l'Internet à l'aide de clients Web2.
Contributor & Web | Prend en charge le fonctionnement avec tous les types de fichiers, y compris des fichiers CAO. Cependant, les compléments CAO ne sont pas pris en charge par ce type de clients. Les utilisateurs à distance peuvent rechercher dans les coffres-forts et effectuer des fonctions de base sur l'Internet à l'aide de clients Web2.
Visionneuse | Donne l'accès en lecture seule aux coffres-forts de fichiers. L'utilisateur peut effectuer la transition des fichiers via un flux de travail, mais ne peut ni ajouter, ni modifier des fichiers (extraire, archiver, mettre à jour des valeurs), ni utiliser des compléments CAO.
Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


Avant l'installation de PDM Server

Retenez les exigences suivantes avant d'installer les composants serveur de PDM :

  • Obtenez des droits administratifs complets sur les ordinateurs où vous allez installer les serveurs et les clients.
  • Assurez-vous que le serveur de bases de données a accès au serveur d'archives par le port TCP 3030 et au serveur SQL par le port TCP 1433.
  • Si vous allez utiliser une base de données SQL Server Express ou SQL Server existante, procurez-vous le nom de la base de données SQL Server, ainsi que l'ID de compte et le mot de passe d'un administrateur SQL Server ou du propriétaire de la base de données avec l'accès en lecture/écriture à la base de données. Vous ne pouvez pas utiliser l'utilisateur tew.
  • Si un client PDM est déjà installé sur le système, désinstallez-le. Si vous voulez le serveur PDM et le client PDM sur le même système, vous devez installer les deux à partir de la page Produits serveur dans le Gestionnaire d'installation de SOLIDWORKS.
Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


Installer un serveur PDM à l'aide du Gestionnaire d'installation SOLIDWORKS

Lorsque vous installez le serveur PDM pour PDM Standard, vous pouvez installer le serveur d'archives, le serveur de base de données et le client PDM CAD Editor sur le même ordinateur. Vous n'avez pas besoin d'exécuter l'installation du client séparément.

Lors de l'installation du serveur PDM pour PDM Professional, vous pouvez inclure ces composants, ainsi que les serveurs Web2 et Web API.

Pour installer un serveur PDM et ses composants :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Installer des composants de serveur et cliquez sur les options suivantes :
    • Installer les composants SOLIDWORKS PDM Server sur cet ordinateur.
    • Installer SolidNetWork License Manager sur cet ordinateur.

      Si SolidNetWork License Manager est installé sur cet ordinateur ou sur un autre, cette option ne s'affiche pas.

  3. Si la page Options de SolidNetwork License Manager s'affiche, saisissez un numéro de série et spécifiez un emplacement pour le répertoire, puis cliquez sur Suivant.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, pour SOLIDWORKS PDM Server, cliquez sur Modifier.
  6. Sur la page Options de SOLIDWORKS PDM Server :
    1. Pour Sélectionner un produit Serveur, cliquez sur SOLIDWORKS PDM Standard ou Professional.
    2. Pour Emplacement d'installation, cliquez sur Parcourir afin de spécifier un chemin de fichier.
    3. Dans Sélectionner les fonctions :
      1. Cliquez sur Serveur d'archives, Serveur de base de données et Client pour installer ces composants sur le même ordinateur. Si vous êtes dans un environnement distribué, vous pouvez installer le serveur d'archives et le serveur de base de données en exécutant le Gestionnaire d'installation sur un autre ordinateur.
        • Si un client PDM est déjà installé sur l'ordinateur, vous devez annuler l'installation et désinstaller le client. Vous pouvez ensuite exécuter le Gestionnaire d'installation SOLIDWORKS pour installer le serveur PDM en même temps que le client.
        • Le composant SOLIDWORKS PDM Client inclus dans l'installation du serveur SOLIDWORKS PDM comprend l'Explorateur d'articles qui ne peut être exclu.
      2. Si vous installez PDM Professional, vous pouvez également cliquer sur Serveur Web2 et Serveur Web API.
        Si vous installez le serveur Web API, vous pouvez spécifier une valeur dans le champ Numéro de port HTTP comprise entre 0 et 65535. La valeur par défaut est 65453.
    4. Dans SQL Server, vous pouvez installer une nouvelle instance des outils de base de données qui sont fournis avec PDM Server (SQL Server Express pour PDM Standard), ou vous pouvez spécifier le nom de la base de données, le nom d'utilisateur et le mot de passe d'une instance existante.
      SOLIDWORKS PDM Professional nécessite l'installation d'une version complète de SQL Server.
    5. Cliquez sur Retour au résumé.
  7. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.

    Lorsque l'installation de SOLIDWORKS Installation Manager est terminée, l'outil Configuration du serveur d'archives démarre. Suivez les instructions de l'assistant pour configurer le serveur d'archives.

Pour installer, configurer et dépanner le serveur d'archives, le serveur de base de données, le serveur Web2, ainsi que les bases de données SQL Server, consultez les rubriques associées dans le Guide d'installation de SOLIDWORKS PDM.

Table des matières

  • Modification d'une installation SOLIDWORKS PDM Server

Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


Modification d'une installation SOLIDWORKS PDM Server

Pour modifier une installation de SOLIDWORKS PDM Server et ses composants, utilisez Programmes et fonctionnalités à partir du Panneau de configuration de Windows. Vous ne pouvez pas modifier l'installation avec le Gestionnaire d'installation de SOLIDWORKS (SLDIM), même s'il s'agit de l'outil que vous avez utilisé pour installer SOLIDWORKS PDM Server.

Sujet parent Installer un serveur PDM à l'aide du Gestionnaire d'installation SOLIDWORKS


Installation d'un client PDM à l'aide du Gestionnaire d'installation SOLIDWORKS

La version principale de SOLIDWORKS PDM Client doit correspondre à la version majeure de SOLIDWORKS PDM Server. Lorsque vous installez ou mettez à jour SOLIDWORKS PDM Client, assurez-vous que les versions correspondent.

Pour installer un client PDM :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Installer sur cet ordinateur.
  3. Sur la page Numéro de série, cliquez sur Suivant.
    Les clients SOLIDWORKS PDM n'ont pas besoin d'un numéro de série séparé.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, sous Produits, cliquez sur Modifier.
  6. Sur la page Sélection de produit, cliquez sur Sélectionnez différents packages ou produits.
  7. Dans la boîte de dialogue Sélectionnez le package à afficher, sélectionnez une édition de SOLIDWORKS. Puis cliquer OK.
  8. Sur la page Sélection de produit, sélectionnez Client SOLIDWORKS PDM. Sélectionnez ensuite eDrawings pour activer la fonctionnalité d'aperçu de PDM. Si vous utilisez PDM SOLIDWORKS Professional, vous pouvez également sélectionner Explorateur d'articles.
  9. Sur la page Résumé, développez Options SOLIDWORKS PDM et cliquez sur Modifier.
  10. Sur la page Options de client SOLIDWORKS PDM, sélectionnez les éléments suivants, puis cliquez sur Retour au résumé:
    • Type de produit PDM
    • Type de client PDM
    • Compléments
  11. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.
Les administrateurs peuvent également utiliser l'Editeur d'options du Gestionnaire d'images administratives pour créer et déployer des images des clients PDM. Pour plus de détails, voir Utilisation des images administratives.
Sujet parent SOLIDWORKS PDM et SOLIDWORKS Manage


SOLIDWORKS Electrical

Le Gestionnaire d'installation SOLIDWORKS vous permet d'installer tous les composants de SOLIDWORKS Electrical, en mode autonome ou en mode client/serveur.

SOLIDWORKS Electrical utilise plusieurs composants. Lors de l'installation, vous devez sélectionner ces composants selon le type d'installation souhaité.
  • SOLIDWORKS Electrical Schematic - Application 2D pour créer et gérer les schémas électriques.
  • SOLIDWORKS Electrical 3D - Complément SOLIDWORKS pour intégrer des schémas 2D aux modèles 3D. SOLIDWORKS Electrical 3D vous permet de gérer l'implantation des appareils électriques ainsi que le routage des fils, des câbles et des faisceaux.
  • Data - Data regroupe toutes les données requises par le logiciel. Ces données sont graphiques (comme les fichiers représentant les symboles et les cartouches) ou techniques (comme les catalogues des constructeurs et les données associées aux symboles). Vous pouvez partager les données afin de les rendre accessibles à tous les utilisateurs.
  • Collaborative Server - Utilitaire pour la gestion de l'ouverture et de la mise à jour de schémas électriques.
  • SQL Server - SOLIDWORKS Electrical nécessite une base de données Microsoft SQL Server. Vous pouvez choisir de créer une nouvelle base de données ou d'utiliser une base de données existante lors de l'installation.

Type d'installation

Il est possible d'installer tous les composants SOLIDWORKS Electrical sur le même ordinateur. Il s'agit d'une installation autonome. Toutes les données de programme, comme les mises en plan de projet et les rapports, sont enregistrées sur le poste de travail.

Il est également possible d'installer les composants de SOLIDWORKS Electrical en tant qu'application client/serveur. Utilisez ce type d'installation si vous voulez stocker les données sur un serveur réseau. L'installation Client/Serveur permet à plusieurs utilisateurs de travailler sur le même projet. Les systèmes clients doivent avoir accès au réseau sur le serveur et disposer d'autorisations de lecture/écriture pour créer des projets, des bibliothèques et des symboles.

Information

Quel que soit le type d'installation (autonome ou client/serveur), vous devez démarrer votre session Windows en mode Droits complets pour installer SOLIDWORKS Electrical.

Vous ne pouvez installer qu'une seule version de SOLIDWORKS Electrical sur une machine. Si vous installez SOLIDWORKS et si vous sélectionnez SOLIDWORKS Electrical comme l'un des produits à installer, le programme d'installation supprime l'ancienne version de SOLIDWORKS Electrical.

Lorsque vous démarrez le Gestionnaire d'installation SOLIDWORKS, ce dernier détecte automatiquement les versions existantes de SOLIDWORKS Electrical installées sur le poste de travail ou sur le serveur.

Effectuez toujours une sauvegarde de l'environnement SOLIDWORKS Electrical existant avant d'installer une nouvelle version. Dans SOLIDWORKS Electrical Schematic, sélectionnez Fichier > Archiver l'environnement, ou dans SOLIDWORKS Electrical 3D, sélectionnez SOLIDWORKS Electrical > Outils > Archiver l'environnement.

Table des matières

  • Conditions requises pour l'installation de SOLIDWORKS Electrical

  • Installation autonome ou client/serveur

    Il existe deux modes d'installation de SOLIDWORKS Electrical. En mode autonome, vous installez le logiciel sur le poste de travail. En mode client/serveur, les utilisateurs partagent les données.

  • Configurer Collaborative Server

  • Configurer Microsoft SQL Server

  • Spécifier l'emplacement des données


Conditions requises pour l'installation de SOLIDWORKS Electrical

Pour accéder aux conditions requises actuelles, reportez-vous à Configuration système requise.

Sujet parent SOLIDWORKS Electrical
Installation autonome ou client/serveur
Configurer Collaborative Server
Configurer Microsoft SQL Server
Spécifier l'emplacement des données


Installation autonome ou client/serveur

Il existe deux modes d'installation de SOLIDWORKS Electrical. En mode autonome, vous installez le logiciel sur le poste de travail. En mode client/serveur, les utilisateurs partagent les données.

SOLIDWORKS Electrical doit toujours être connecté à une instance de SQL Server.

Sujet parent SOLIDWORKS Electrical
Conditions requises pour l'installation de SOLIDWORKS Electrical
Configurer Collaborative Server
Configurer Microsoft SQL Server
Spécifier l'emplacement des données

Installation autonome

Pour une première installation, vous DEVEZ installer tous les composants sur le poste de travail.

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • Données d'application
  1. Dans l'onglet Résumé, cliquez sur Modifier dans la section Sélection des produits et sélectionnez tous les composants SOLIDWORKS Electrical.
  2. Si vous souhaitez modifier les options d'installation, dans l'onglet Résumé, cliquez sur Modifier dans la section Options d'Electrical. Il est possible de créer une nouvelle instance de SQL Server ou d'utiliser une instance existante. Consultez les chapitres spécifiques sur les Données et Microsoft SQL Server dans la présente documentation pour en savoir plus. Sinon, conservez les options par défaut.
  3. Cliquez sur Installer maintenant pour continuer.
Si SOLIDWORKS Electrical est déjà installé sur le poste de travail, le Gestionnaire d'installation SOLIDWORKS le trouve automatiquement et il vous invite à le mettre à jour. Installez tous les composants sans modifier les Options d'Electrical.

Installation Client/Serveur

L'installation Client/Serveur vous permet de partager les données entre plusieurs utilisateurs.

Sur le serveur, vous devez installer les composants suivants :
  • Collaborative Server
  • Données d'application
  • SQL Server
Sur les clients, vous devez installer les composants suivants :
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. Sur le serveur, installez les composants du serveur.
  2. Dans l'onglet Bienvenue dans le Gestionnaire d'installation de SOLIDWORKS, cliquez sur Installer des composants de serveur.
  3. Sélectionnez l'option SOLIDWORKS Electrical.
  4. Dans l'onglet Résumé, vous pouvez modifier les options d'installation. Consultez les chapitres spécifiques sur les Données et Microsoft SQL Server dans la présente documentation pour en savoir plus. Sinon, conservez les options par défaut.
  5. Cliquez sur Installer maintenant pour continuer.
  6. Sur les clients, installez les applications.
  7. Dans l'onglet Bienvenue dans le Gestionnaire d'installation de SOLIDWORKS, cliquez sur Installer sur cet ordinateur.
  8. Dans l'onglet Résumé, cliquez sur Modifier dans la section Sélection des produits et désélectionnez l'option Electrical Server.
  9. Dans l'onglet Résumé, cliquez sur Modifier dans la section Options d'Electrical et modifiez les paramètres pour vous connecter au serveur.
  10. Cliquez sur Installer maintenant pour continuer.
Si SOLIDWORKS Electrical est déjà installé sur le poste de travail ou sur le serveur, le Gestionnaire d'installation SOLIDWORKS le trouve automatiquement et il vous invite à le mettre à jour. Pour mettre à jour le logiciel, procédez comme lors de la première installation.


Configurer Collaborative Server

Le Collaborative Server est un service Windows qui doit être exécuté en permanence et avoir une communication constante, ininterrompue et bidirectionnelle avec les clients au travers des pare-feu et des antivirus.

Pour configurer le Collaborative Server en mode individuel ou serveur, spécifiez les paramètres suivants :
  • Le nom de l'ordinateur (par exemple LOCALHOST ou MyMachine) ou son adresse IP (par exemple 127.0.0.1 ou 192.168.999.999).
  • Le numéro de port (par défaut 26666).

Vous pouvez configurer le Collaborative Server lors de l'installation ou ultérieurement dans la commande Outils > Paramètres d'application.

Pour fournir la communication bidirectionnelle ininterrompue, assurez-vous que les ports numéro 26666 à 26676 (lorsque 10 utilisateurs sont connectés simultanément) sont disponibles sur le système sur lequel Collaborative Server est installé. Sinon, demandez à l'administrateur système de trouver un autre port pour SOLIDWORKS Electrical.

Sujet parent SOLIDWORKS Electrical
Conditions requises pour l'installation de SOLIDWORKS Electrical
Installation autonome ou client/serveur
Configurer Microsoft SQL Server
Spécifier l'emplacement des données


Configurer Microsoft SQL Server

Assurez-vous qu'une instance de la base de données SQL Server est disponible pour n'importe quel type d'installation SOLIDWORKS Electrical. Vous pouvez utiliser une base de données SQL Server existante si elle est déjà installée sur le système, ou installer une nouvelle instance dans le cadre de l'installation de SOLIDWORKS Electrical.

Lorsque vous installez une nouvelle instance de SQL Server, l'installation de SOLIDWORKS fournit une version gratuite de Microsoft SQL Express 2022. Cette version est limitée à 1 processeur, 1 Go de mémoire et 10 Go de données. Les limitations de mémoire et processeur sont suffisantes pour prendre en charge 10 utilisateurs simultanés.

Si vous installez SQL Express 2022, veillez à ce que le logiciel et le matériel de serveur répondent aux exigences répertoriées dans Configuration système requise.

Si le même serveur compte plus de 10 utilisateurs simultanés, il est recommandé d'acheter et d'installer une version complète de SQL Server. Utilisez le flux de travail décrit pour installer SOLIDWORKS Electrical avec une instance existante de SQL Server.

Pour des informations sur SQL Express 2022, consultez la documentation de Microsoft SQL Server.

Sujet parent SOLIDWORKS Electrical
Conditions requises pour l'installation de SOLIDWORKS Electrical
Installation autonome ou client/serveur
Configurer Collaborative Server
Spécifier l'emplacement des données

Gestion des données dans SOLIDWORKS Electrical

De nombreux programmes utilisent une base de données unique qui contient toutes les données du programme. Tel n'est pas le cas de SOLIDWORKS Electrical. Chaque projet de SOLIDWORKS Electrical est affecté d'un numéro d'identification unique, et à chaque projet est associée une base de données identifiable par son numéro d'identification unique. Par exemple, dans le Project Manager SOLIDWORKS Electrical, un projet avec l'identificateur n° 112 sera associée à une base de données nommée « tew_project_data_112 ».

La raison de l'utilisation d'une base de données unique pour chaque projet est que ceci réduit de manière significative le temps de traitement. En outre, en cas de défaillance critique d'une base de données, un seul projet est affecté, et l'intégrité de la majorité des informations de programme est maintenue.

Toutefois, certaines entreprises possèdent des règles limitant la création de nouvelles bases de données. Pour exécuter SOLIDWORKS Electrical, il ne peut exister de restriction à la création de nouvelles bases de données par les utilisateurs. Consultez l'administrateur système ou de base de données pour vous assurer qu'aucun paramètre de configuration n'empêche les utilisateurs de créer de nouvelles bases de données.

Nouvelles instance de SQL Server

Si vous installez une nouvelle instance de SQL Server, vous devez posséder des droits administratifs complets sur le serveur, ainsi que tous les systèmes clients. Vous devez également veiller à ce que les clients aient les droits de lecture/écriture pour la base de données, afin qu'ils puissent créer et modifier les projets, les bibliothèques, les symboles et les autres données de projet.

Lorsque vous installez une nouvelle instance de SQL Server, sélectionnez un nom différent du nom par défaut.

Instances existantes de SQL Server

Pour installer de nouvelles bases de données SOLIDWORKS Electrical ou vous connecter à une installation de SOLIDWORKS Electrical sur une instance existante de SQL Server, vous devez être muni d'un compte utilisateur possédant des droits administratifs complets sur la base de données SQL Server.

Pour que SOLIDWORKS Electrical fonctionne correctement, vous devez activer SQL Server pour une authentification en mode mixte. L'authentification en mode mixte permet l'utilisation d'informations d'identification de Windows ainsi que SQL Server.

Pour vous connecter à une base de données SQL Server existante, vous pouvez utiliser l'authentification Windows ou SQL Server. Entrez un nom d'utilisateur et un mot de passe pour un compte de connexion Windows ou SQL Server possédant les droits complets d'administrateur de SQL Server.

Vous ne pouvez pas utiliser l'utilisateur tew pour vous connecter à SQL Server pour l'installation. Contactez votre administrateur de SQL Server ou l'administrateur système pour obtenir un compte de connexion avec les informations d'identification correctes pour SQL Server.

Bases de données SOLIDWORKS Electrical

Après avoir installé SOLIDWORKS Electrical, le programme d'installation crée les bases de données suivantes dans l'instance SQL Server.

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


Spécifier l'emplacement des données

Pour l'emplacement des données, sélectionnez un répertoire pour l'enregistrement des données de programme comme les pièces, les modèles et les symboles 2D et 3D. Cet emplacement doit être un répertoire dédié. Il ne peut pas s'agir d'un répertoire racine ou du répertoire utilisé pour enregistrer les données de SOLIDWORKS.

Le répertoire par défaut est C:\ProgramData\SOLIDWORKS Electrical.

En cas d'installation Client/Serveur, vous devez partager le Répertoire de données.

Le programme d'installation crée un nouveau dossier appelé Mise à jour dans le répertoire par défaut afin de stocker toutes les nouvelles données.

Lorsque vous démarrez SOLIDWORKS Electrical pour la première fois, le programme fait automatiquement fusionner les données stockées dans le dossier Mise à jour avec les données existantes. Dans l'assistant Mise à jour des données, vous pouvez sélectionner les données à ajouter dans l'application et la base de données SQL Server.

Sujet parent SOLIDWORKS Electrical
Conditions requises pour l'installation de SOLIDWORKS Electrical
Installation autonome ou client/serveur
Configurer Collaborative Server
Configurer Microsoft SQL Server


SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize fournit une suite d'outils autonomes qui combinent des techniques avancées de rendu avec des flux de travail et des fonctionnalités axés sur la conception visuelle, afin que vous puissiez créer des images hautement réalistes de modèles CAO 3D.

Les produits SOLIDWORKS Visualize sont disponibles dans deux packages :
  • Standard
  • Professionnel

Une version de SOLIDWORKS Visualize Standard est offerte avec chaque licence SOLIDWORKS Professional et Premium pour un abonnement actif. Les clients SOLIDWORKS à activation autonome ont besoin d'un numéro de série supplémentaire. Si vous ne connaissez pas votre numéro de série SOLIDWORKS Visualize, contactez votre administrateur ou votre revendeur SOLIDWORKS.

SOLIDWORKS Visualize prend également en charge les types de licence SolidNetWork Licensing (SNL) comme les licences flottantes, ainsi que l'activation hors ligne.

A l'aide du Gestionnaire d'installation SOLIDWORKS (SLDIM), vous installez SOLIDWORKS Visualize dans le cadre de l'installation individuelle (Installer sur cet ordinateur). Vous pouvez l'installer comme une application autonome, ce qui représente un avantage si vous voulez utiliser des ordinateurs distincts pour la modélisation et le rendu. Il ne consomme aucune licence SOLIDWORKS.

SOLIDWORKS Visualize Boost est un service qui vous permet de distribuer le rendu depuis un ordinateur exécutant SOLIDWORKS Visualize Professional vers un ou plusieurs ordinateurs sur un réseau. Vous pouvez effectuer d'autres tâches sur votre ordinateur pendant la génération de l'image rendue et les images finales rendues sont disponibles plus tôt. Vous pouvez également installer Visualize Boost dans le cadre de l'installation individuelle (Installer sur cet ordinateur) dans le gestionnaire d'installation SOLIDWORKS.

Une version de SOLIDWORKS Visualize Boost est offerte avec chaque version de SOLIDWORKS Visualize Professional pour un abonnement actif.
Visualize Boost est un complément conçu exclusivement pour Visualize Professional. Visualize Boost n'est pas compatible avec Visualize Standard.

Table des matières

  • Configuration système requise pour SOLIDWORKS Visualize

  • Installation de SOLIDWORKS Visualize à l'aide du Gestionnaire d'installation SOLIDWORKS

  • Installation de Visualize Boost à l'aide du Gestionnaire d'installation SOLIDWORKS


Configuration système requise pour SOLIDWORKS Visualize

Pour des performances et une configuration optimales de SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost, suivez ces instructions avant l'installation :
  • Assurez-vous de disposer d'un numéro de série distinct pour chaque produit avant d'installer SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost.
  • Assurez-vous que chaque ordinateur exécutant SOLIDWORKS Visualize ou SOLIDWORKS Visualize Boost répond aux exigences répertoriées dans Configuration système requise.
  • Installez l'application SOLIDWORKS Visualize Boost sur des ordinateurs de rendu dédiés au sein du même réseau. Ces ordinateurs doivent être différents de ceux qui exécutent SOLIDWORKS Visualize Professional pour décharger les tâches de rendu.
  • Si aucun processeur graphique applicable n'est trouvé, SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost sont définis par défaut sur l'unité centrale de traitement (CPU). Voir Certification matérielle SOLIDWORKS pour en savoir plus sur les cartes graphiques et les pilotes spécifiques.

Pour la prise en charge du processeur graphique à l'aide de 3DS Stellar Physically Correct

Mode de rendu précis Stellar :
  • Processeur graphique NVIDIA basé au moins sur la microarchitecture Maxwell
  • Version recommandée du pilote 538.78 avec prise en charge de CUDA 12.2.
  • Au moins 4 Go de mémoire vidéo
Mode de rendu rapide Stellar :
  • Processeur graphique NVIDIA basé au minimum sur la microarchitecture Turing (avec les cœurs RT Core)
  • Utilise la même version de pilote et la même quantité de mémoire que le mode Précis

Pour la prise en charge du processeur graphique à l'aide d'AMD ProRender

Modes de rendu AMD ProRender Rapide et Précis :
  • Une carte graphique et un pilote prenant en charge la norme Vulkan
Sujet parent SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost


Installation de SOLIDWORKS Visualize à l'aide du Gestionnaire d'installation SOLIDWORKS

Pour installer SOLIDWORKS Visualize :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Installer sur cet ordinateur.
  3. Procédez comme suit :
    1. Sur la page Numéro de série, développez Visualization.
    2. Sélectionnez SOLIDWORKS Visualize et saisissez le numéro de série.
    3. Cliquez sur Suivant.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.
Suivez les instructions de l'assistant d'activation du produit pour activer votre produit.

Après l'activation, cliquez deux fois sur l'icône de raccourci SOLIDWORKS Visualize sur le bureau pour démarrer l'application ou, à partir du menu Démarrer de Windows, cliquez sur SOLIDWORKS version > SOLIDWORKS Visualize version.

Table des matières

  • Tâches de post-installation

Sujet parent SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost


Tâches de post-installation

Après l'installation, vous devrez effectuer quelques tâches pour configurer SOLIDWORKS Visualize.

Pour plus d'informations, se reporter à Débuter avec SOLIDWORKS Visualize dans l'aide SOLIDWORKS Visualize.

Table des matières

  • Création du dossier de contenu

  • Accès à l'aide, aux tutoriels, aux informations système et aux licences

Sujet parent Installation de SOLIDWORKS Visualize à l'aide du Gestionnaire d'installation SOLIDWORKS


Création du dossier de contenu

Lorsque vous exécutez le logiciel pour la première fois, SOLIDWORKS Visualize vous demande un emplacement où créer un dossier de contenu.

Le dossier de contenu contient les sous-dossiers suivants, dans lesquels vous pouvez stocker les actifs de vos projets :
Sous-dossiers | Stockages
Caméras | Caméras et caméras par défaut que vous avez enregistrées
Environnements | Images High Dynamic Range (HDR)
Palettes | Images de fond
Images | Rendus et clichés
Apparences | Matériaux dans votre Bibliothèque d'apparences Les contenus se mettent à jour lorsque vous ajoutez une apparence à la bibliothèque.
Modèles | Fichiers de modèle Par défaut, SOLIDWORKS Visualize effectue d'abord une recherche dans ce dossier lorsque vous utilisez Fichier > Importer un modèle.
Fonds | Images 2D standard à utiliser dans les images de fond
Projets | Fichiers de projet natifs au format .SVPJ
Textures | Textures 2D à utiliser dans les apparences
Sujet parent Tâches de post-installation


Accès à l'aide, aux tutoriels, aux informations système et aux licences

Le menu Aide offre de la documentation et des options pour mettre à jour le logiciel et dépanner votre système.

Aide de Visualize | Ouvre l'aide en ligne de SOLIDWORKS Visualize.
Tutoriels de Visualize | Ouvre MySolidWorks et vous permet d'accéder aux tutoriels de SOLIDWORKS Visualize.
Notes de version | Affiche les notes de version en ligne pour la version actuelle.
Nouveautés | Affiche les nouvelles fonctionnalités des produits SOLIDWORKS.
Info système | Effectue une vérification du système du logiciel SOLIDWORKS Visualize avec votre matériel de PC, et suggère des mises à niveau, si nécessaire.
Vérifier la disponibilité de mises à jour | Recherche la dernière mise à jour de SOLIDWORKS Visualize sur le serveur.
Activer la licence | (licences fixes) Utilise l'assistant d'activation de produit SOLIDWORKS pour activer votre produit.
Désactiver la licence | (licences fixes) Utilise l'assistant d'activation de produit SOLIDWORKS pour désactiver votre produit.
SolidNetWork License Manager | Utilise l'assistant d'activation de produit SOLIDWORKS pour désactiver votre produit.
A propos de Visualize | Affiche le numéro de version et les informations de licence de votre copie de SOLIDWORKS Visualize.
Sujet parent Tâches de post-installation


Installation de Visualize Boost à l'aide du Gestionnaire d'installation SOLIDWORKS

Vous installez Visualize Boost à l'aide du Gestionnaire d'installation SOLIDWORKS. Il requiert un numéro de série distinct.

Vous devez installer Visualize Boost sur des ordinateurs différents de ceux sur lesquels SOLIDWORKS Visualize Professional est exécuté. Vous pouvez optimiser les performances de rendu en installant Visualize Boost sur des ordinateurs équipés de plusieurs processeurs graphiques (GPU).

Pour installer SOLIDWORKS Visualize Boost :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS.
  2. Sur la page Bienvenue, sélectionnez Installer sur cet ordinateur.
  3. Procédez comme suit :
    1. Sur la page Numéro de série, développez Visualization.
    2. Sélectionnez SOLIDWORKS Visualize Boost et saisissez le numéro de série.
    3. Cliquez sur Suivant.
  4. Suivez les instructions pour les avertissements du système et cliquez sur Suivant.
  5. Sur la page Résumé, acceptez les termes du Contrat de licence de SOLIDWORKS et cliquez sur Installer maintenant.
Suivez les instructions de l'assistant d'activation du produit pour activer votre produit.

Une fois activée, ouvrez l'app en double-cliquant sur le raccourci de bureau SOLIDWORKS Visualize Boost [image].

Table des matières

  • Configuration de Visualize Boost

    Vous pouvez configurer l'ordinateur Visualize Boost principal en tant que coordinateur et les autres ordinateurs du groupe de rendu en tant que nœuds.

Sujet parent SOLIDWORKS Visualize et SOLIDWORKS Visualize Boost


Configuration de Visualize Boost

Vous pouvez configurer l'ordinateur Visualize Boost principal en tant que coordinateur et les autres ordinateurs du groupe de rendu en tant que nœuds.

Visualize Boost vous permet de générer le rendu des images sur un ou plusieurs ordinateurs. La configuration est simple et intuitive. Un ordinateur principal, le coordinateur, gère le groupe et distribue les tâches de rendu à partir de SOLIDWORKS Visualize. Des machines supplémentaires, appelées nœuds, se connectent au coordinateur pour faciliter ces tâches sur un réseau. Dans une batterie de rendus, chaque machine incluse dans le groupe exécute une instance de Visualize Boost en continu.

Pour configurer Visualize Boost :

  1. Ouvrez Visualize Boost :
    • Double-cliquez sur le raccourci de bureau de Visualize Boost [image].
    • Dans le menu Démarrer de Windows, cliquez sur SOLIDWORKS <version> > SOLIDWORKS Visualize Boost <version>.
    Une fois le programme activé, la fenêtre Visualize Boost identifie et affiche le nom et l'adresse IP de l'ordinateur sous licence.
  2. Dans Visualize Boost, cliquez sur Fichier > Paramètres.
  3. Dans la boîte de dialogue Paramètres :
    1. Sélectionnez l'ordinateur qui fera office de coordinateur. N'indiquez pas de coordinateur lorsque vous configurez tous les autres nœuds.
    2. Acceptez les valeurs par défaut : 8001 pour le port Boost et 8002 pour le port DStellar.
      Vous pouvez mettre à jour ces ports pour répondre à la configuration requise du réseau. Veillez à ajouter des exceptions de pare-feu pour autoriser les communications avec les nœuds. Si vous avez des questions, renseignez-vous auprès de votre administrateur réseau.
  4. Facultatif : D'autres paramètres sont disponibles :
    Option | Description
    Langue | L'ordinateur utilise automatiquement la langue du système d'exploitation.
    Thème | Choisissez un arrière-plan Clair ou Sombre comme Thème. Ce paramètre affecte SOLIDWORKS Visualize s'il est installé sur le même ordinateur que Visualize Boost.
    Notifications activées | Affiche les messages générés par DStellar.Boost dans la zone de notification de Windows.
    Exporter | Enregistre les paramètres de configuration de Visualize Boost dans un fichier .json.
    Importer | Charge les paramètres existants dans une instance de Visualize Boost, dans un fichier .json.
  5. Cliquez sur Appliquer.
Pour finaliser la configuration, consultez les instructions de la rubrique Utilisation de Visualize Boost.
Sujet parent Installation de Visualize Boost à l'aide du Gestionnaire d'installation SOLIDWORKS


Administration des licences

Après l'installation, vous pouvez activer les licences SOLIDWORKS de deux manières : soit en activant les ordinateurs individuels (activation d’ordinateur), soit en installant et activant des licences réseau flottantes sur un serveur (Gestion des licences SolidNetWork).

En général, l'activation de licence est utilisée pour les installations sur des ordinateurs individuels; vous pouvez cependant installer le logiciel individuellement, puis contrôler les licences avec SolidNetWork License Manager. A l'inverse, même si les sites plus grands utilisent généralement des licences réseau flottantes, vous pouvez déployer des installations à partir d'une image administrative, puis activer les numéros de série à partir d'ordinateurs individuels.

Table des matières

  • Administrer les licences individuelles

    Vous pouvez définir une licence individuelle pour utiliser l'activation de l'ordinateur.

  • Administrer des licences avec SolidNetWork License Manager

    SolidNetWork License Manager prend en charge les clients de licence multiples en distribuant les licences aux clients du réseau. Le nombre d'utilisateurs peut ainsi dépasser le nombre de licences en utilisant des licences flottantes.


Administrer les licences individuelles

Vous pouvez définir une licence individuelle pour utiliser l'activation de l'ordinateur.

En règle générale, l'administration des licences individuelles consiste à activer et désactiver des licences directement depuis le logiciel SOLIDWORKS.

L'activation est une procédure d'enregistrement et de validation des licences SOLIDWORKS autonomes (autres que la licence SolidNetWork). En général, si votre licence de produit n'est pas activée, SOLIDWORKS tente de l'activer lorsque vous démarrez le produit.

A partir de SOLIDWORKS 2022 et versions ultérieures, si vous avez acheté une licence perpétuelle de SOLIDWORKS, vous devez également réactiver la licence une fois par an. Une licence perpétuelle n'expire jamais mais doit être réactivée. SOLIDWORKS vous invite à réactiver la licence perpétuelle avant la date de réactivation requise.

Vous pouvez aussi désactiver des licences individuelles en cliquant sur [image] > Licences > Désactiver dans SOLIDWORKS.

Sujet parent Administration des licences
Administrer des licences avec SolidNetWork License Manager

Activer une licence

Avant de pouvoir exécuter les produits SOLIDWORKS sur un ordinateur individuel, vous devez activer la licence pour cet ordinateur.

Pour procéder à l'activation, vous devez avoir accès à Internet ou à la messagerie électronique. Après l'activation, vous n'avez pas besoin d'être en ligne pour utiliser les produits. Si vous n'avez pas accès à la messagerie électronique sur l'ordinateur sur lequel vous utilisez ce produit, vous pouvez enregistrer le fichier d'activation et l'envoyer à partir d'un autre ordinateur.

Cette procédure:
  • Active toutes les licences de la gamme de produits SOLIDWORKS.
  • Vous permet de transférer les droits de licence d'un ordinateur à l'autre.
  • Peut être réalisée immédiatement (action recommandée) ou dans les 30 jours suivant l'installation.
  • Permet de se passer de dongles. Cependant, si vous exécutez des versions précédentes des produits SOLIDWORKS qui n'ont pas recours à l'activation, vous devez utiliser un dongle.

Pour les administrateurs système qui ont plusieurs numéros de série à gérer, il est possible d'utiliser l'Editeur d'options du Gestionnaire d'images administratives. Pour plus de détails, voir Editeur d'options du Gestionnaire d'images administratives.

Pour activer une licence:

  1. Démarrez SOLIDWORKS.
  2. Démarrez l'Activation de produit SOLIDWORKS à l'aide d'une des méthodes suivantes :
    • Si vous n'avez pas encore activé la licence pour cet ordinateur, la fenêtre Activation de produit SOLIDWORKS s'affiche automatiquement quand vous démarrez le logiciel SOLIDWORKS.
    • Si la fenêtre Activation de produit SOLIDWORKS ne s'affiche pas automatiquement, lancez l'activation en cliquant sur [image] > Licences > Activer.
  3. Sélectionnez la liste Produit pour spécifier le produit dont vous souhaitez activer la licence.
  4. Spécifiez l'activation automatique par Internet ou l'activation manuelle par la messagerie électronique.
  5. Fournissez les informations de contact par courrier électronique.
  6. Cliquez sur Suivant.
    • Par Internet: L'activation a lieu automatiquement.
    • Courriel : Cliquez sur Enregistrer pour créer un fichier de requête, puis envoyez ce fichier à activation@solidworks.com. Quand vous recevez l'e-mail contenant le fichier de réponse, extrayez ce dernier de l'e-mail puis cliquez sur Ouvrir pour le charger.
      Si nécessaire, quittez la procédure d'activation et exécutez-la de nouveau pour ouvrir le fichier de réponse.
  7. Cliquez sur Terminer.
Editeur d'options du Gestionnaire d'images administratives

Réactivation d'une licence

Si vous disposez de licences perpétuelles commerciales ou d'éducation des produits SOLIDWORKS 2022 et ultérieurs, vous devez réactiver ces licences une fois par an. L'activation de produit SOLIDWORKS vous invite à le réactiver avant la date de réactivation requise.

Pour réactiver une licence :

  1. Démarrez SOLIDWORKS.
    L'activation de produit SOLIDWORKS vous invite à réactiver. Pour chaque licence de produit SOLIDWORKS, les éléments suivants s'affichent :
    • La date d'expiration de l'activation actuelle
    • L'action requise pour continuer à utiliser le produit, par exemple en réactivant une licence perpétuelle ou en renouvelant et en réactivant une licence temporaire ou d'évaluation.
  2. Cliquez sur Réactiver pour démarrer l'assistant Activation de produit.

    Si vous ne souhaitez pas réactiver la licence immédiatement, cliquez sur Me le rappeler ultérieurement. Par exemple, dans SOLIDWORKS, cliquez sur [image] > Licences > Activer pour démarrer l'assistant Activation de produit. Voir Activer une licence.

Transférer une licence

Pour transférer une licence SolidNetWork sur un nouvel ordinateur ou sur un ordinateur mis à niveau, désactivez-la d'abord sur le serveur de clés de licence de Dassault Systèmes SOLIDWORKS Corporation, puis réactivez-le sur l'autre ordinateur.

Si vous ne pouvez pas désactiver la licence de Dassault Systèmes SOLIDWORKS Corporation (en raison d'une défaillance du disque dur, par exemple), la réactivation peut tout de même avoir lieu dans la plupart des cas. Si ce n'est pas le cas, contactez votre revendeur à valeur ajoutée pour obtenir de l'aide.

Pour transférer une licence :

  1. Dans SOLIDWORKS, cliquez sur [image] > Licences > Désactiver et suivez les instructions.
  2. Pour réactiver la licence, allez sur le nouvel ordinateur ou l'ordinateur mis à niveau et activez la licence en suivant la procédure d'activation initiale. Pour plus de détails, reportez-vous à Activer une licence.


Administrer des licences avec SolidNetWork License Manager

SolidNetWork License Manager prend en charge les clients de licence multiples en distribuant les licences aux clients du réseau. Le nombre d'utilisateurs peut ainsi dépasser le nombre de licences en utilisant des licences flottantes.

Cette image illustre une installation de licence SolidNetWork typique:

Cette image montre:
  • Le logiciel SolidNetWork License Manager est uniquement installé et activé sur l'ordinateur du gestionnaire de licences.
  • Aucun logiciel additionnel spécifique à SolidNetWork n'est installé sur les ordinateurs clients de la licence.

    Si vous spécifiez un numéro de série pour la licence SolidNetWork lors de l'installation, le Gestionnaire d'installation SOLIDWORKS identifie cet ordinateur comme étant un client de licence SolidNetWork. Le Gestionnaire d'installation SOLIDWORKS vous demande le nom et le numéro de port de l'ordinateur sur lequel réside SolidNetWork License Manager afin de connecter le client au gestionnaire de licences.

  • Le Gestionnaire de licences et tous les clients de licence doivent pouvoir être connectés au protocole TCP/IP (Transmission Control Protocol/Internet Protocol).

Table des matières

  • Présentation de l'installation des licences SolidNetWork

    Vous utilisez le Gestionnaire d'installation SOLIDWORKS pour installer SolidNetWork License Manager Server sur au moins un ordinateur avant d'installer le logiciel client SOLIDWORKS sur d'autres ordinateurs. Vous pouvez ensuite utiliser l'assistant Activation de produit afin d'ajouter et d'activer des numéros de série pour les licences perpétuelles et à durée limitée.

  • Démarrer SolidNetWork License Manager

    Vous pouvez démarrer SolidNetWork License Manager depuis le menu Démarrer de Windows.

  • Mettre à niveau SolidNetwork License Manager

    Dans le cas des versions majeures de SOLIDWORKS, la mise à niveau du gestionnaire de licences consiste à désinstaller l'ancien gestionnaire de licences, à en installer un nouveau et à réactiver la licence SolidNetWork.

  • Transférer une licence SolidNetWork

    Pour transférer une licence SolidNetWork sur un nouvel ordinateur ou sur un ordinateur mis à niveau, désactivez-la d'abord sur le serveur de clés de licence de Dassault Systèmes SOLIDWORKS Corporation, puis réactivez-la sur l'autre ordinateur.

  • Suppression des fichiers de licence SolidNetWork

    Vous pouvez supprimer les fichiers de licence SolidNetWork qui ont expiré avant de mettre à niveau votre version vers les nouvelles licences.

  • Emprunter et rendre des licences SolidNetWork

    Vous pouvez emprunter une licence SolidNetWork pour utiliser le logiciel à distance. Puisque la licence est retirée du groupe de licences disponibles, une licence empruntée doit être rendue pour être de nouveau disponible.

  • Gestion de l'accès aux versions de SOLIDWORKS

    Vous pouvez empêcher les utilisateurs d'utiliser des versions spécifiques de SOLIDWORKS dans un environnement SolidNetWork. Cette fonctionnalité vous permet de gérer les versions de SOLIDWORKS utilisées par différent(e)s personnes, projets et unités commerciales.

  • Surveillance du temps d'inactivité d'une licence

    SOLIDWORKS a la possibilité d'enregistrer le temps d'inactivité avec SolidNetWork License Manager de façon à ce que les licences qui n'ont pas été utilisées pendant un certain temps soient remises à disposition.

  • Utilisation d'une licence temporaire

    Vous pouvez utiliser une licence temporaire « any » lorsque la licence SolidNetWork n'est pas disponible.

  • Utiliser les licences SolidNetWork avec des compléments

    Vous pouvez utiliser SolidNetWork License Manager pour distribuer les licences des compléments SOLIDWORKS.

  • Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License

    Les utilisateurs de licences SolidNetWork peuvent choisir les licences SOLIDWORKS® Simulation de leur groupe de licences à utiliser lorsqu'ils ajoutent SOLIDWORKS Simulation. Ils peuvent également réaliser une mise à niveau de la licence SOLIDWORKS Simulation sans décharger le complément, au cas où ils auraient besoin d'un type de licence plus élevée pour des études plus avancées.

  • Chargement des modules Flow Simulation

    En tant que client disposant d'une licence SolidNetWork, deux méthodes vous permettent de contrôler le chargement des modules complémentaires HVAC et Electronics Cooling pour Flow Simulation.

  • Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics

    Lorsque vous exécutez des études dans SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation ou SOLIDWORKS Plastics, les licences réseau restent actives et n'ont pas de délai d'expiration. SOLIDWORKS conserve les licences pendant le processus de calcul, qui est considéré comme une activité.

  • Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative

    Vous pouvez configurer un ordinateur de réseau pour servir à la fois de gestionnaire de licences distribuant les licences SolidNetWork et d'emplacement de l'image administrative à partir de laquelle les utilisateurs peuvent installer le logiciel SOLIDWORKS.

  • Désinstaller SolidNetwork License Manager

    Lorsque vous mettez à niveau SolidNetwork License Manager, vous devez désinstaller l'anciene version avant d'installer la nouvelle.

  • Gestion des licences FlexNet Publisher

    La gestion des licences SolidNetWork est basée sur FlexNet Publisher®.

Sujet parent Administration des licences
Administrer les licences individuelles


Présentation de l'installation des licences SolidNetWork

Vous utilisez le Gestionnaire d'installation SOLIDWORKS pour installer SolidNetWork License Manager Server sur au moins un ordinateur avant d'installer le logiciel client SOLIDWORKS sur d'autres ordinateurs. Vous pouvez ensuite utiliser l'assistant Activation de produit afin d'ajouter et d'activer des numéros de série pour les licences perpétuelles et à durée limitée.

Lorsque vous installez le logiciel client SOLIDWORKS sur un ordinateur, spécifiez un numéro de série de licence SolidNetWork. Le Gestionnaire d'installation SOLIDWORKS identifie cet ordinateur comme client de licence SolidNetWork et vous invite à saisir le nom d'ordinateur et le numéro de port associés à SolidNetWork License Manager Server. Il affiche une erreur si SolidNetWork License Manager Server n'est pas installé ou si le nom ou le numéro de port est incorrect.

Processus d'activation

Avant que les utilisateurs puissent exécuter les produits SOLIDWORKS sur leur ordinateur personnel, vous devez activer une licence SolidNetWork sur l'ordinateur sur lequel se trouve le logiciel SolidNetWork License Manager Server.

Pour procéder à l'activation, vous devez avoir accès à une connexion Internet active ou à la messagerie électronique. Après l'activation, vous n'avez pas besoin d'être en ligne pour utiliser les produits. Si vous n'avez pas accès à la messagerie électronique sur l'ordinateur sur lequel vous utilisez ce produit, vous pouvez enregistrer le fichier d'activation et l'envoyer à partir d'un autre ordinateur.

Cette procédure:
  • Active les licences SolidNetWork au sein de SOLIDWORKS SolidNetWork License Manager pour tous les produits SOLIDWORKS.
  • Permet de transférer les droits de licence SolidNetWork d'un ordinateur SolidNetWork License Manager à l'autre.
  • Permet d'installer et d'activer les droits de licence SolidNetWork sur un ordinateur SolidNetWork License Manager.
  • Cette opération doit être effectuée pour que vous puissiez utiliser les licences SolidNetWork.
  • Permet de se passer de dongles. Si vous activez une licence SolidNetWork pour cette version de SOLIDWORKS, les licences SolidNetWork des versions précédentes de SOLIDWORKS sont activées. Il n'est plus nécessaire de conserver le dongle.

Table des matières

  • Installation de SolidNetWork License Manager Server

    SolidNetWork License Manager Server prend en charge plusieurs clients de licences. Il distribue les licences aux clients sur le réseau.

  • Activation de licences SolidNetWork

    Avant que les clients puissent exécuter les produits SOLIDWORKS sur leurs ordinateurs individuels, vous devez activer une licence SolidNetWork sur l'ordinateur de SolidNetwork License Manager.

  • Activation manuelle à l'aide de SolidNetWork License Manager Server

    Lorsque vous installez ou mettez à niveau SolidNetWork License Manager Server, vous devez activer ou réactiver la licence. Vous pouvez activer ou réactiver la licence via Internet ou choisir de procéder manuellement.

  • Installation des clients de licence SolidNetWork

  • Utiliser les licences SolidNetWork avec des pare-feux

    Si votre ordinateur utilise un pare-feu, vous devez configurer les ports de façon à ce qu'ils prennent en charge la gestion des licences SolidNetWork.

  • Réactiver une licence SolidNetWork

    La réactivation s'applique aux produits sous licence SolidNetWork après la mise à niveau de SolidNetwork License Manager Server vers la version 2022 par une entreprise. Même si les produits installés sont issus d'une version antérieure, les licences à partir de la version 2022 sur le serveur doivent être réactivées une fois par an.

  • Installation des gestionnaires de licences triade

    Les gestionnaires de licences triade utilisent trois ordinateurs pour une stabilité accrue. Si l'ordinateur qui gère le fichier de licence n'est pas disponible, un des deux autres ordinateurs prend le relais.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Installation de SolidNetWork License Manager Server

SolidNetWork License Manager Server prend en charge plusieurs clients de licences. Il distribue les licences aux clients sur le réseau.

Si vous mettez à niveau une version antérieure de SolidNetWork License Manager Server qui utilisait un dongle matériel pour l'activation des licences, retirez le dongle avant d'installer la nouvelle version de SolidNetWork License Manager Server.

  1. Lancez le Gestionnaire d'installation SOLIDWORKS comme décrit dans Télécharger le média d'installation.
  2. Pour choisir un type d'installation, sélectionnez Installer des composants de serveur, puis cliquez sur Installer SolidNetWork License Manager (licences distribuées) sur cet ordinateur.
  3. Sur la page Résumé, vérifiez l'emplacement d'installation et le téléchargement en arrière-plan, acceptez les conditions de licence, puis cliquez sur Installer maintenant.
  4. Dans l'assistant Activation de produit SOLIDWORKS, à partir de SolidNetWork License Manager Server, ajoutez un numéro de série et activez au moins une licence. Reportez-vous à la section Ajout de numéros de série et activation des licences SolidNetWork.
Sujet parent Présentation de l'installation des licences SolidNetWork
Activation de licences SolidNetWork
Activation manuelle à l'aide de SolidNetWork License Manager Server
Installation des clients de licence SolidNetWork
Utiliser les licences SolidNetWork avec des pare-feux
Réactiver une licence SolidNetWork
Installation des gestionnaires de licences triade


Activation de licences SolidNetWork

Avant que les clients puissent exécuter les produits SOLIDWORKS sur leurs ordinateurs individuels, vous devez activer une licence SolidNetWork sur l'ordinateur de SolidNetwork License Manager.

Pour activer une licence SolidNetWork:

  1. Démarrez SolidNetWork License Manager en cliquant sur Démarrer > Outils SOLIDWORKS version > SolidNetWork License Manager Server version.
  2. Facultatif : Si vous n'avez pas encore activé la licence SolidNetWork, le programme vous demande si vous souhaitez l'activer maintenant. Cliquez Oui.
    L'assistant Activation de produit SOLIDWORKS démarre.
  3. Facultatif : Si un pare-feu est activé, sélectionnez l'option Un pare-feu est utilisé sur ce serveur.
  4. Saisissez les numéros de port dans la page Informations du serveur de licences SolidNetWork, puis cliquez sur Suivant.
  5. Dans le numéro de série : sélectionnez les numéros de série désirés ou cliquez sur Sélectionner tout pour activer tous vos numéros de série SOLIDWORKS.
    1. Activez l'option Automatiquement sur Internet (recommandé).
    2. Sous Coordonnées, saisissez une adresse électronique.
    La boîte de dialogue Activation/réactivation réussie indique les produits qui ont été activés.
  6. Cliquez sur Terminer.
Sujet parent Présentation de l'installation des licences SolidNetWork
Installation de SolidNetWork License Manager Server
Activation manuelle à l'aide de SolidNetWork License Manager Server
Installation des clients de licence SolidNetWork
Utiliser les licences SolidNetWork avec des pare-feux
Réactiver une licence SolidNetWork
Installation des gestionnaires de licences triade


Activation manuelle à l'aide de SolidNetWork License Manager Server

Lorsque vous installez ou mettez à niveau SolidNetWork License Manager Server, vous devez activer ou réactiver la licence. Vous pouvez activer ou réactiver la licence via Internet ou choisir de procéder manuellement.

Si vous effectuez une activation manuelle :
  • Dans le cas d'une nouvelle installation de SolidNetWork License Manager Server, vous devez activer la licence deux fois pour configurer correctement le serveur. La première fois que vous activez la licence, vous initialisez le système de licence sur le serveur. La deuxième fois que vous effectuez la procédure, vous activez la licence proprement dite.
  • Dans le cas d'une mise à niveau de SolidNetWork License Manager Server, vous devez réactiver la licence existante. Si le serveur ne dispose pas de licences activées, lancez l'activation en utilisant l'option Modifier disponible sous l'onglet Administration du serveur.
Sujet parent Présentation de l'installation des licences SolidNetWork
Installation de SolidNetWork License Manager Server
Activation de licences SolidNetWork
Installation des clients de licence SolidNetWork
Utiliser les licences SolidNetWork avec des pare-feux
Réactiver une licence SolidNetWork
Installation des gestionnaires de licences triade


Installation des clients de licence SolidNetWork

Lorsque vous installez le logiciel de CAO SOLIDWORKS sur un ordinateur, vous devez spécifier un numéro de série de licence SolidNetWork. Le Gestionnaire d'installation SOLIDWORKS identifie cet ordinateur comme étant un client de licence SolidNetWork et vous invite à saisir le nom et le numéro de l'ordinateur SolidNetWork License Manager. Il affiche une erreur si SolidNetWork License Manager Server n'est pas installé ou si le nom ou le numéro de port est incorrect.

Pour installer SOLIDWORKS avec une licence SolidNetWork :

  1. Lancez le Gestionnaire d'installation SOLIDWORKS comme décrit dans Télécharger le média d'installation.
  2. Sur la page de bienvenue, cliquez sur Installer sur cet ordinateur s'il s'agit de la première installation de SOLIDWORKS sur cet ordinateur pour cette version majeure.
    Si vous mettez à niveau depuis une version existante et passez des licences individuelles à la gestion des licences SolidNetWork, cliquez sur Modifier l'installation individuelle (sur cet ordinateur). Pour plus de détails, voir Mettre à niveau de la gestion des licences individuelles vers la gestion SolidNetWork .
  3. Dans la boîte de dialogue Ajouter un serveur, saisissez l'adresse de SolidNetWork License Manager sous la forme :

    port@NomOrdinateur

    Le numéro de port doit être le même que celui utilisé pour l'ordinateur du Gestionnaire de licences. La valeur par défaut est 25734.

    Le Gestionnaire d'installation SOLIDWORKS essaie de confirmer que ce SolidNetWork License Manager est accessible. Si vous n'avez pas encore installé un gestionnaire de licences, cette confirmation échouera, mais vous pouvez cependant continuer l'installation du client de licence.
  4. Terminez l'installation de SOLIDWORKS en suivant les instructions du Gestionnaire d'installation SOLIDWORKS.
Sujet parent Présentation de l'installation des licences SolidNetWork
Installation de SolidNetWork License Manager Server
Activation de licences SolidNetWork
Activation manuelle à l'aide de SolidNetWork License Manager Server
Utiliser les licences SolidNetWork avec des pare-feux
Réactiver une licence SolidNetWork
Installation des gestionnaires de licences triade


Utiliser les licences SolidNetWork avec des pare-feux

Si votre ordinateur utilise un pare-feu, vous devez configurer les ports de façon à ce qu'ils prennent en charge la gestion des licences SolidNetWork.

Dans le logiciel pare-feu, vous devez ajouter deux ports de licence SolidNetWork (par exemple, SNL-in-port et SNL-out-port) à la liste des exceptions de pare-feu. Pour obtenir des détails sur la configuration de ces ports, consultez votre administrateur système.

Si vous utilisez le pare-feu Windows sur un système d'exploitation Windows pris en charge, vous devez modifier des ports sur l'ordinateur SolidNetWork License Manager et modifier le fichier de licence SolidNetWork pour distribuer les licences aux ordinateurs clients de licence.

Modifier les ports de l'ordinateur du Gestionnaire de licences pour le Pare-feu Windows

  1. Cliquez sur Démarrer et ouvrez Sécurité Windows.
  2. Sélectionnez Pare-feu et protection réseau > Paramètres avancés , puis cliquez sur Oui pour confirmer les modifications.
  3. Dans la boîte de dialogue Pare-feu Windows Defender avec fonctions avancées de sécurité, sélectionnez Règles de trafic entrant > Nouvelle règle.
  4. Dans l'Assistant Nouvelle règle entrante, sélectionnez le type de règle Port, puis cliquez sur Suivant.
  5. Saisissez le numéro de port dans le champ Ports locaux spécifiques : (par exemple, 80, 25734, 443), puis cliquez sur Suivant.
  6. Sélectionnez l'option Nom. Saisissez un nom (par exemple, SNL-in-port).
  7. Cliquez sur Terminer.

Modifier les paramètres du SolidNetWork License Manager pour le Pare-feu Windows

  1. Démarrez SolidNetWork License Manager en cliquant sur Démarrer > Outils SOLIDWORKS version > SolidNetWork License Manager Server version.
  2. Dans l'onglet Administration du serveur, sous Serveur de licences, cliquez sur Arrêter. Cliquez sur Oui pour confirmer et sur OK pour arrêter le serveur de licences.
  3. Sous Informations sur la licence, cliquez sur Modifier.
  4. Sous Type de serveur, sélectionnez la configuration de serveur pour votre réseau (Unique ou Triade) puis cliquez sur Suivant.
  5. Sous Informations sur le serveur:
    1. Sélectionnez Un pare-feu est utilisé sur ce serveur.
    2. Le numéro de port et le numéro de port du démon doivent contenir les numéros de port spécifiés pour le pare-feu Windows (pour des détails, voir la procédure ci-dessus).
    3. Sélectionnez Fichier d'options et cliquez sur Parcourir pour localiser le fichier. Cliquez sur Editer pour modifier ses paramètres.
    Le fichier d'options permet à l'administrateur de licences de contrôler les différents paramètres de fonctionnement des licences FlexNet.

    Recommandation : Localisez le fichier d'options dans le répertoire d'installation de SolidNetWork License Manager (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt). Ce fichier doit se situer dans le même répertoire que le fichier sw_d.lic.

    Pour obtenir des informations supplémentaires sur le fichier d'options, voir le License Administration Guide (Guide d'administration des licences) de FlexNet Publisher dans le répertoire d'installation de SolidNetWork License Manager ( ).

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

Sujet parent Présentation de l'installation des licences SolidNetWork
Installation de SolidNetWork License Manager Server
Activation de licences SolidNetWork
Activation manuelle à l'aide de SolidNetWork License Manager Server
Installation des clients de licence SolidNetWork
Réactiver une licence SolidNetWork
Installation des gestionnaires de licences triade


Réactiver une licence SolidNetWork

La réactivation s'applique aux produits sous licence SolidNetWork après la mise à niveau de SolidNetwork License Manager Server vers la version 2022 par une entreprise. Même si les produits installés sont issus d'une version antérieure, les licences à partir de la version 2022 sur le serveur doivent être réactivées une fois par an.

Dans les 30 jours suivant la date de réactivation, les produits SOLIDWORKS sur le réseau informent les utilisateurs que les licences vont expirer. Les administrateurs doivent avoir connaissance de l'expiration pour réactiver les licences à temps.

Pour réactiver une licence SolidNetWork :

  1. Démarrez le serveur SolidNetWork License Manager en cliquant sur Démarrer > Outils SOLIDWORKS version > Serveur du SolidNetWork License Manager version.
  2. Dans l'onglet Administration du serveur, sous Informations sur la licence, cliquez sur Réactiver.

  3. Dans Série, sélectionnez Tous pour toutes les licences ou saisissez un numéro de licence pour rechercher une licence spécifique.

    La boîte de dialogue Réactiver les licences indique en rouge toutes les licences dont la date d'expiration et de réactivation est comprise dans un délai de 30 jours. Les astérisques indiquent les licences qui doivent être renouvelées.

  4. Cliquez sur Réactiver.
Sujet parent Présentation de l'installation des licences SolidNetWork
Installation de SolidNetWork License Manager Server
Activation de licences SolidNetWork
Activation manuelle à l'aide de SolidNetWork License Manager Server
Installation des clients de licence SolidNetWork
Utiliser les licences SolidNetWork avec des pare-feux
Installation des gestionnaires de licences triade


Installation des gestionnaires de licences triade

Les gestionnaires de licences triade utilisent trois ordinateurs pour une stabilité accrue. Si l'ordinateur qui gère le fichier de licence n'est pas disponible, un des deux autres ordinateurs prend le relais.

Les composants suivants sont nécessaire pour utiliser des gestionnaires de licence triade:
  • Installez les gestionnaires de licences triade uniquement sur des ordinateurs stables qui ne sont pas fréquemment arrêtés.
  • Les trois ordinateurs gestionnaires de licences doivent être sur le même sous-réseau. Ne configurez jamais des gestionnaires de licences triade avec des communications ou des liaisons d'accès à distance lentes.
  • L'administrateur système doit détecter lorsqu'un gestionnaire de licences est hors service et le redémarrer le plus vite possible.
    Si seuls deux gestionnaires de licences fonctionnent, la situation est pire qu'avec un gestionnaire de licences unique, parce qu'il y a alors deux points d'échec.

Table des matières

  • Installer le Gestionnaire de licences triade initial

    Ce processus montre comment installer SolidNetWork License Manager sur le premier ordinateur de la triade.

  • Installer le gestionnaire de licences triade sur les ordinateurs suivants

    Suivez ces instructions pour installer le logiciel SolidNetWork License Manager sur le deuxième et le troisième ordinateur de la triade. Cette procédure est presque identique à l'installation du logiciel sur l'ordinateur initial, à l'exception des étapes 2(f) et 2(i).

Sujet parent Présentation de l'installation des licences SolidNetWork
Installation de SolidNetWork License Manager Server
Activation de licences SolidNetWork
Activation manuelle à l'aide de SolidNetWork License Manager Server
Installation des clients de licence SolidNetWork
Utiliser les licences SolidNetWork avec des pare-feux
Réactiver une licence SolidNetWork


Installer le Gestionnaire de licences triade initial

Ce processus montre comment installer SolidNetWork License Manager sur le premier ordinateur de la triade.

  1. Sur le premier ordinateur du gestionnaire de licences triade, installez le SolidNetWork License Manager à l'aide du Gestionnaire d'installation SOLIDWORKS.
    1. Lancez le Gestionnaire d'installation SOLIDWORKS comme décrit dans Télécharger le média d'installation.
    2. Pour choisir un type d'installation, sélectionnez Installer des composants de serveur, puis cliquez sur Installer SolidNetWork License Manager (licences distribuées) sur cet ordinateur.
    3. Sur la page Résumé, examinez l'emplacement d'installation du SolidNetWork License Manager, Options de téléchargement et cliquez sur Installer maintenant pour terminer le processus du Gestionnaire d'installation SOLIDWORKS.
  2. A l'aide de SolidNetWork License Manager, configurez l'ordinateur du gestionnaire de licences triade initial:
    1. Démarrer le SolidNetWork License Manager. Cliquez sur Démarrer > Outils SOLIDWORKSversion > SolidNetWork License Manager Server version.

      Puisque c'est la première fois que vous exécutez SolidNetWork License Manager sur cet ordinateur, le programme vous demande si vous souhaitez l'activer maintenant.

    2. Cliquez sur Non.

      L'onglet Administration du serveur du SolidNetWork License Manager de SOLIDWORKS apparaît.

    3. Sous l'onglet Administration du serveur, sous Options avancées, cliquez sur Options.
    4. Sous Mode de licence du serveur SolidNetWork, cliquez sur Fichier de licence, puis sur OK.
    5. Sous Informations sur la licence, cliquez sur Modifier.
      La boîte de dialogue Assistance du fichier de licence SolidNetWork apparaît.
    6. Sous Type de serveur, sélectionnez Triade et cliquez sur Suivant.
    7. Dans le volet Informations sur le serveur, vérifiez que le nom de l'ordinateur et le numéro de port de l'ordinateur gestionnaire de licences triade initial sont corrects et cliquez sur Suivant.

      Vérifiez que l'adresse de carte d'interface réseau (NIC) correspond aux informations contenues dans le fichier de licence SOLIDWORKS et que le numéro de port de l'ordinateur du gestionnaire de licences triade est correct. L'adresse NIC est également connue sous le nom d'adresse MAC (contrôle d'accès au support). Cliquez ensuite sur Suivant.

      Pour rechercher les adresses NIC, ouvrez une fenêtre d'invite de commandes et saisissez :

      ipconfig /all

      De plus, si votre ordinateur utilise un pare-feu, il se peut que vous ayez à ajouter des spécifications sur cet écran. Pour obtenir de plus amples informations, voir Utiliser les licences SolidNetWork avec des pare-feux.

    8. Sur l'écran Informations sur le serveur triade partenaire, saisissez le nom et l'ID d'hôte des deux autres ordinateurs gestionnaires de licences triade, puis cliquez sur Suivant.
      Ceci garantit qu'en cas d'indisponibilité d'un gestionnaire de licences triade, les ordinateurs clients peuvent obtenir une licence d'un des deux autres serveurs.
    9. Dans l'écran Licences, cliquez sur Lire pour rechercher et ouvrir le fichier de licence SolidNetWork.
      Les licences s'affichent dans l'assistant Fichier de licence SolidNetWork. Pour cet ordinateur, vous pouvez utiliser un fichier de licence que vous avez reçu d'un revendeur ou du service client SOLIDWORKS de Dassault Systèmes.
    10. Cliquez sur Terminer.
    11. Cliquez sur OK pour quitter et sur Terminer pour fermer SolidNetWork License Manager.
Sujet parent Installation des gestionnaires de licences triade
Installer le gestionnaire de licences triade sur les ordinateurs suivants
Utiliser les licences SolidNetWork avec des pare-feux


Installer le gestionnaire de licences triade sur les ordinateurs suivants

Suivez ces instructions pour installer le logiciel SolidNetWork License Manager sur le deuxième et le troisième ordinateur de la triade. Cette procédure est presque identique à l'installation du logiciel sur l'ordinateur initial, à l'exception des étapes 2(f) et 2(i).

On suppose que vous avez déjà installé au moins un gestionnaire de licences triade sur un autre ordinateur.

  1. Sur l'ordinateur du gestionnaire de licences triade, installez le SolidNetWork License Manager à l'aide du Gestionnaire d'installation SOLIDWORKS :
    1. Lancez le Gestionnaire d'installation SOLIDWORKS comme décrit dans Télécharger le média d'installation.
    2. Pour choisir un type d'installation, sélectionnez Installer des composants de serveur, puis cliquez sur Installer SolidNetWork License Manager (licences distribuées) sur cet ordinateur.
    3. Sur la page Résumé, vérifiez l'emplacement d'installation du SolidNetWork License Manager, Options de téléchargement et cliquez sur Installer maintenant pour terminer le processus du Gestionnaire d'installation SOLIDWORKS.
  2. A l'aide de SolidNetWork License Manager, configurez l'ordinateur du gestionnaire de licences triade:
    1. Démarrer le SolidNetWork License Manager. Cliquez sur Démarrer > Outils SOLIDWORKSversion > SolidNetWork License Manager Server version.
      Puisque c'est la première fois que vous exécutez SolidNetWork License Manager sur cet ordinateur, le programme vous demande si vous souhaitez l'activer maintenant.
    2. Cliquez sur Non.
      L'onglet Administration du serveur de SOLIDWORKS SolidNetwork License Manager apparaît.
    3. Sous Options avancées, cliquez sur Options.
      La boîte de dialogue Options avancées apparaît.
    4. Sous Mode de licence du serveur SolidNetWork, cliquez sur Fichier de licence, puis sur OK.
      La boîte de dialogue Options avancées se ferme.
    5. Sous Informations sur la licence, cliquez sur Modifier.
      La boîte de dialogue Assistance du fichier de licence SolidNetWork apparaît.
    6. Sous Type de serveur, sélectionnez Triade et Synchroniser les informations serveur/licence puis cliquez sur Suivant.
    7. Sur l'écran Information sur le serveur triade, saisissez le nom de l'ordinateur et l'identificateur de l'hôte. Cliquez ensuite sur Suivant.
      Ceci garantit qu'en cas d'indisponibilité d'un gestionnaire de licences, les ordinateurs client peuvent obtenir une licence des deux autres serveurs.
    8. Dans l'écran Licences, cliquez sur Lire pour rechercher et ouvrir le fichier de licence SolidNetWork.
      Les licences apparaissent dans l'assistant Fichier de licence SolidNetWork.
    Ce fichier de licences est généré par le premier ordinateur gestionnaire de licences triade que vous avez configuré. Généralement, le fichier de licence se trouve sous \licenses\sw_d.lic. Par exemple : C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. Cliquez sur Terminer.
      Une boîte de dialogue Assistance du fichier de licence SolidNetWork apparaît.
    2. Cliquez sur OK pour quitter l'Assistance du fichier de licence SolidNetWork puis sur Terminer pour quitter le SolidNetWork License Manager.

Répétez ce processus pour le troisième ordinateur gestionnaire de licences triade.

Sujet parent Installation des gestionnaires de licences triade
Installer le Gestionnaire de licences triade initial


Démarrer SolidNetWork License Manager

Vous pouvez démarrer SolidNetWork License Manager depuis le menu Démarrer de Windows.

Dans Windows, cliquez sur Démarrer > Outils SOLIDWORKS version > Serveur du SolidNetWork License Manager version.

Vous pouvez utiliser le même chemin depuis le menu Démarrer de Windows pour ouvrir SolidNetWork License Manager Client version.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Mettre à niveau SolidNetwork License Manager

Dans le cas des versions majeures de SOLIDWORKS, la mise à niveau du gestionnaire de licences consiste à désinstaller l'ancien gestionnaire de licences, à en installer un nouveau et à réactiver la licence SolidNetWork.

Le gestionnaire de licences pour une version plus récente peut distribuer des licences aux ordinateurs clients continuant d'utiliser la version antérieure.

  1. Démarrez SolidNetWork License Manager en cliquant sur Démarrer > Outils SOLIDWORKS version > SolidNetWork License Manager Server version.
  2. Sur l'onglet Utilisation de la licence, vérifiez qu'aucun ordinateur client du réseau n'exécute SOLIDWORKS.
  3. Désinstaller le Gestionnaire de licences SolidNetWork. Pour plus de détails, voir Désinstaller SolidNetwork License Manager.
  4. Installez le nouveau gestionnaire de licences et réactivez la licence SolidNetWork sur l'ordinateur. Pour plus de détails, voir Installation de SolidNetWork License Manager Server.

Si vous mettez à niveau SolidNetWork License Manager sur un ordinateur exécutant aussi l'application SOLIDWORKS, mettez à niveau les gestionnaires SolidNetWork License Manager et les clients avant d'installer tout nouveau service pack de l'application SOLIDWORKS sur cet ordinateur.

Si vous mettez à niveau le gestionnaire de licences sur un ordinateur hébergeant des images administratives, mettez à niveau le gestionnaire de licences avant les images administratives. Pour plus de détails, voir Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Transférer une licence SolidNetWork

Pour transférer une licence SolidNetWork sur un nouvel ordinateur ou sur un ordinateur mis à niveau, désactivez-la d'abord sur le serveur de clés de licence de Dassault Systèmes SOLIDWORKS Corporation, puis réactivez-la sur l'autre ordinateur.

Si vous êtes dans l'impossibilité de désactiver la licence de Dassault Systèmes SOLIDWORKS Corporation (en raison d'une défaillance du disque dur, par exemple), la réactivation peut tout de même avoir lieu dans la plupart des cas. Si ce n'est pas le cas, contactez votre revendeur à valeur ajoutée pour obtenir de l'aide.

Pour transférer une licence SolidNetWork :

  1. Démarrez le serveur SolidNetWork License Manager en cliquant sur Démarrer > Outils SOLIDWORKS version > Serveur du SolidNetWork License Manager version.
  2. Dans l'onglet Administration du serveur, sous Informations de la Licence, cliquez sur Modifier. L'assistant Activation de produit SOLIDWORKS démarre.
  3. Sous Que voulez-vous faire ?, sélectionnez Déplacer vos licences produit vers un ordinateur nouveau/mis à niveau, puis cliquez sur Suivant.
  4. Dans la liste N° de série :, sélectionnez les numéros de série ou cliquez sur Sélectionner tout pour activer tous vos numéros de série SOLIDWORKS.
    1. Sélectionnez l'option Automatiquement sur Internet (recommandé).
    2. Sous Coordonnées (requis) :, spécifiez une adresse électronique.
  5. La boîte de dialogue Désactivation réussie s'affiche.
    La désactivation de la licence produit se termine.
  6. Cliquez sur Terminer.
Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Suppression des fichiers de licence SolidNetWork

Vous pouvez supprimer les fichiers de licence SolidNetWork qui ont expiré avant de mettre à niveau votre version vers les nouvelles licences.

  1. Démarrez SolidNetWork License Manager en cliquant sur Démarrer > Outils SOLIDWORKS version > SolidNetWork License Manager Server.
  2. Sous l'onglet Administration du serveur, sous Informations sur la licence, cliquez sur Modifier, puis sur Suivant.
  3. Sur la page Activer/Désactiver votre produit SOLIDWORKS, sélectionnez les fichiers de licence SolidNetWork ayant expiré, puis cliquez sur Supprimer.
  4. Cliquez sur Terminer, puis sur OK pour quitter.
Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Emprunter et rendre des licences SolidNetWork

Vous pouvez emprunter une licence SolidNetWork pour utiliser le logiciel à distance. Puisque la licence est retirée du groupe de licences disponibles, une licence empruntée doit être rendue pour être de nouveau disponible.

Les licences empruntées ne sont valides que pour l'utilisateur actuel et la machine sur laquelle elles ont été empruntées. Elles ne peuvent pas être transférées.

La licence peut être empruntée pendant une période définie (jusqu'à 30 jours ou comme défini par l'administrateur système) et elle est supprimée du groupe de licences disponibles.

L'emprunt et le retour de licences ne fonctionnent pas si la licence SOLIDWORKS est en cours d'utilisation.

Les administrateurs système peuvent personnaliser les options d'emprunt pour:
  • Définir des utilisateurs ou des groupes autorisés à emprunter des licences.
  • Définir le nombre de licences ne pouvant pas être empruntées.

Pour plus de détails, voir rép_install_SolidNetWork_License_Manager\Docs\flexuser\licensingenduserguide.pdf.

Table des matières

  • Emprunter des licences SolidNetWork

  • Rendre une licence SolidNetWork empruntée

    Puisqu'une licence SolidNetWork empruntée est retirée du groupe de licences disponibles, cette licence empruntée doit être rendue pour pouvoir devenir de nouveau disponible.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Emprunter des licences SolidNetWork

Démarrez toujours SolidNetWork License Manager depuis le menu Démarrer. Vous devez être connecté à SolidNetWork License Manager pour emprunter la licence.

Ces étapes peuvent varier selon la configuration de votre système. Consultez la documentation de Microsoft Windows pour des instructions et des options supplémentaires.
  1. Démarrez SolidNetWork License Manager sur l'ordinateur client en cliquant sur Démarrer > Outils SOLIDWORKS version > Client SolidNetWork License Manager version.
  2. Dans l'onglet Emprunt de licence:
    1. Sélectionnez une date dans le champ Emprunter jusqu'au.
    2. Sous Licences de produits disponibles, sélectionnez les produits à emprunter et cliquez sur Emprunter.
    3. Dans la liste Sélectionnez le produit de la boîte de dialogue, sélectionnez un produit, puis cliquez sur OK pour confirmer.
    4. Au bas de la boîte de dialogue, cliquez sur Actualiser.
      La colonne Empruntée jusqu'au indique quand les licences doivent être rendues.
  3. Cliquez sur OK.

Dans l'onglet Utilisation des licences, vous pouvez également consulter le nombre total de licences, les licences gratuites et les licences utilisées par l'utilisateur, ainsi que les dates de fin d'emprunt.

Sélectionnez Uniquement des licences empruntées (démarrage plus rapide) si vous travaillez à distance et que vos applications SOLIDWORKS sont lentes à s'ouvrir.

Cette option bloque les requêtes vers vos serveurs de licences, ce qui peut être lent dans certains environnements. Les applications peuvent démarrer plus rapidement si l'on omet les requêtes, mais n'utiliseront que les licences que vous avez empruntées.

Redémarrez vos applications pour que cette option prenne effet.

Sujet parent Emprunter et rendre des licences SolidNetWork
Rendre une licence SolidNetWork empruntée


Rendre une licence SolidNetWork empruntée

Puisqu'une licence SolidNetWork empruntée est retirée du groupe de licences disponibles, cette licence empruntée doit être rendue pour pouvoir devenir de nouveau disponible.

  1. Démarrez SolidNetWork License Manager sur l'ordinateur client en cliquant sur Démarrer > Outils SOLIDWORKS version > Client SolidNetWork License Manager version.
  2. Dans l'onglet Emprunt de licence:
    1. Sous Licences de produits disponibles, sélectionnez les produits à rendre et cliquez sur Rendre.
    2. Cliquez sur Actualiser. La colonne Empruntée jusqu'au devient vide, indiquant que les licences ont été rendues.
  3. Cliquez sur OK.

Dans l'onglet Utilisation des licences, vous pouvez également afficher le nombre total de licences.

Il n'est pas nécessaire de rendre les licences après leur date d'expiration. A minuit le jour de la date d'expiration, la licence retourne dans SolidNetWork License Manager et les applications ne peuvent plus être exécutées sur le système à distance.
Sujet parent Emprunter et rendre des licences SolidNetWork
Emprunter des licences SolidNetWork


Gestion de l'accès aux versions de SOLIDWORKS

Vous pouvez empêcher les utilisateurs d'utiliser des versions spécifiques de SOLIDWORKS dans un environnement SolidNetWork. Cette fonctionnalité vous permet de gérer les versions de SOLIDWORKS utilisées par différent(e)s personnes, projets et unités commerciales.

Pour gérer l'accès aux versions de SOLIDWORKS à l'aide d'un fichier d'options FlexNet :

  1. Dans le répertoire d'installation de SolidNetWork License Manager, créez un fichier texte :
    Dossier_installation_SolidNetWork_License_Manager\Licenses\sw_d.opt
  2. Pour gérer l'accès à une version spécifique de SOLIDWORKS dans le fichier de licence, ajoutez la syntaxe suivante en face de SOLIDWORKS :
    :SWVERSION=xx Où xx est la version du produit SOLIDWORKS que vous souhaitez gérer
  3. Pour gérer plusieurs versions de SOLIDWORKS, ajoutez une ligne pour chaque version que vous désirez gérer.

    Les options FlexNet ne sont pas toutes prises en charge. Les options prises en charge pour les filtres de version sont les suivantes :

    INCLUDE | Autoriser uniquement l'utilisateur ou le groupe à démarrer la version spécifique. Tous les autres utilisateurs ne sont pas autorisés à démarrer cette version.
    INCLUDE_BORROW | Autoriser uniquement l'utilisateur ou le groupe à emprunter la version spécifique. Tous les autres utilisateurs ne sont pas autorisés à emprunter cette version.
    EXCLUDE | Empêcher l'utilisateur ou le groupe indiqué de démarrer la version spécifique de SOLIDWORKS. EXCLUDE supplante INCLUDE.
    EXCLUDE_BORROW | Empêcher l'utilisateur ou le groupe indiqué d'emprunter la version spécifique de SOLIDWORKS. EXCLUDE supplante INCLUDE.
    Exemples :
    1 | SWVERSION=32.0 désigne SOLIDWORKS 2025
    SWVERSION=31.0 désigne SOLIDWORKS 2024
    2 | INCLUDE solidworks:SWVERSION=32.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=32.0 USER jane
    Ces lignes du fichier d'options autorisent uniquement jane à exécuter SOLIDWORKS 2025. Tous les autres utilisateurs ne peuvent ni exécuter ni emprunter SOLIDWORKS 2025 mais peuvent exécuter et emprunter d'autres versions de SOLIDWORKS. jane peut également exécuter et emprunter d'autres versions de SOLIDWORKS.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=32.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=31.0 GROUP chicago
    EXCLUDE solidworks USER don
    Ces lignes définissent un GROUP d'utilisateurs nommé chicago et lui interdisent l'accès à la fois à SOLIDWORKS 2025 et à SOLIDWORKS 2024 mais ces utilisateurs peuvent exécuter n'importe quelle autre version de SOLIDWORKS. L'utilisateur don ne peut exécuter aucune version de SOLIDWORKS.
    4 | EXCLUDE swinspection_std:SWVERSION=32.0 HOST machine1
    Cette ligne interdit à quiconque utilisant la machine1 de lancer SOLIDWORKS Inspection 2025.

    Pour des informations supplémentaires sur FlexNet, voir le License Administration Guide (Guide d'administration des licences) de FlexNet Publisher dans le répertoire d'installation de SolidNetWork License Manager : \Docs\flexuser\fnp_LicAdmin.pdf.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Surveillance du temps d'inactivité d'une licence

SOLIDWORKS a la possibilité d'enregistrer le temps d'inactivité avec SolidNetWork License Manager de façon à ce que les licences qui n'ont pas été utilisées pendant un certain temps soient remises à disposition.

  1. Dans le répertoire d'installation de SolidNetWork License Manager, créez un fichier texte :
    Dossier_installation_Gestionnaire_licences_SolidNetWork\Licenses\sw_d.opt
  2. Ajoutez la ligne suivante au fichier:
    TIMEOUTALL secondes

    où secondes est un nombre supérieur ou égal à 900 (15 minutes), temps minimum autorisé.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Utilisation d'une licence temporaire

Vous pouvez utiliser une licence temporaire « any » lorsque la licence SolidNetWork n'est pas disponible.

Par défaut, SolidNetWork License Manager ne peut activer qu'un seul serveur à la fois. Pour travailler dans un environnement de test, vous pouvez obtenir un fichier de licence temporaire auprès de l'assistance technique et charger une licence « any » dans le logiciel SolidNetWork License Manager installé sur un autre serveur. Si vous utilisez un serveur hors ligne, vous pouvez appliquer les mêmes instructions pour charger une licence d'exemption d'activation.

En utilisant un fichier de licence « any », vous acceptez d'installer la licence SolidNetWork délivrée par Dassault Systèmes SOLIDWORKS Corporation dès que vous la recevrez. Vous devez respecter les restrictions relatives à la licence à tout moment.

Pour utiliser une licence « any » :

  1. Démarrez SolidNetWork License Manager en cliquant sur Démarrer > Outils SOLIDWORKS version > SolidNetWork License Manager Server version.
  2. Si le logiciel vous demande d'activer, cliquez sur Non.
  3. Dans l'onglet Administration du serveur, cliquez sur Options avancées > Options.
  4. Sous Mode de licence du serveur SolidNetWork, cliquez sur Fichier de licence, puis sur OK.
  5. Dans l'onglet Administration du serveur, sous Informations de la Licence, cliquez sur Modifier.
    La boîte de dialogue Assistance du fichier de licence SolidNetWork apparaît.
  6. Sous Type de serveur, sélectionnez Unique et cliquez sur Suivant.
  7. Sélectionnez l'identification du dongle et saisissez Any ou l'adresse NIC pour les informations du serveur. Cliquez ensuite sur Suivant.

    Cliquez sur Annuler lorsque le message suivant s'affiche : N'a pas pu lire le numéro d'identification du dongle.

    Si votre ordinateur utilise un pare-feu, il se peut que vous ayez à spécifier d'autres informations sur cet écran. Pour plus d'informations, voir Utiliser les licences SolidNetWork avec des pare-feux.
  8. Sous licences, cliquez sur Lire pour lire le fichier de licence.
  9. Dans la boîte de dialogue Lire, parcourez le texte jusqu'au fichier SNL_ANY.txt ou SNL_(NIC Card Number).txt fourni par l'assistance technique, puis cliquez sur Ouvrir. Puis cliquer OK.
    L'assistant de licence de fichier SolidNetWork répertorie les licences du fichier texte.
    Cliquez sur Enlever pour supprimer les entrées de licence temporaires qui ont expiré dans la liste.
  10. Cliquez sur Finir pour fermer l'assistant du fichier de licence SolidNetwork.
  11. Activez une licence « any » :
    1. Sous l'onglet Administration du serveur, cliquez sur Options avancées > Options.
    2. Sous Mode de licence du serveur SolidNetWork, cliquez sur Fichier de licence, puis sur OK.
    3. Sous l'onglet Administration du serveur, cliquez sur Modifier > Activer/Désactiver vos licences de produit.
    4. Sélectionnez le numéro de série, saisissez les coordonnées, puis choisissez la méthode d'activation. Si vous choisissez l'activation manuelle, suivez les instructions associées.
    5. Cliquez sur Terminer pour confirmer l'activation.
Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Utiliser les licences SolidNetWork avec des compléments

Vous pouvez utiliser SolidNetWork License Manager pour distribuer les licences des compléments SOLIDWORKS.

  • Il n'est pas nécessaire d'avoir le même nombre de licences pour le logiciel SOLIDWORKS et pour les compléments.
  • Pour obtenir une licence pour un complément, vous devez d'abord obtenir une licence pour SOLIDWORKS.
  • Pour emprunter une licence pour un complément, vous devez emprunter la licence du logiciel SOLIDWORKS et la licence du produit SOLIDWORKS qui inclut le complément. Une licence SOLIDWORKS Standard est empruntée par défaut. Cependant, pour activer un complément, vous devez emprunter une licence de produit SOLIDWORKS Professional, SOLIDWORKS Premium ou SOLIDWORKS Ultimate.
  • Pour libérer la licence d'un complément:
    • Dans SOLIDWORKS, cliquez sur Outils > Compléments, puis désactivez le complément voulu.
    • Quittez SOLIDWORKS.
Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License

Les utilisateurs de licences SolidNetWork peuvent choisir les licences SOLIDWORKS® Simulation de leur groupe de licences à utiliser lorsqu'ils ajoutent SOLIDWORKS Simulation. Ils peuvent également réaliser une mise à niveau de la licence SOLIDWORKS Simulation sans décharger le complément, au cas où ils auraient besoin d'un type de licence plus élevée pour des études plus avancées.

  1. Pour utiliser une licence SOLIDWORKS Simulation spécifique :
    1. Dans SOLIDWORKS, cliquez sur Outils > Compléments et, dans la boîte de dialogue Complément, sélectionnez SOLIDWORKS Simulation.
    2. Dans SOLIDWORKS Simulation (CommandManager), cliquez sur la flèche Bas [image] pour afficher une liste des licences sur votre serveur pouvant prendre en charge Simulation.

    3. Sélectionnez la licence SOLIDWORKS Simulation appropriée.
  2. Pour vérifier ou modifier votre licence SOLIDWORKS Simulation actuelle, cliquez sur la flèche Bas [image] dans SOLIDWORKS Simulation (CommandManager).

    La licence en cours d'utilisation porte une coche. Si des types de licences plus avancées sont disponibles, vous pouvez faire une mise à niveau.
    Vous ne pouvez pas rétrograder une licence SOLIDWORKS Simulation. Désactivez le complément SOLIDWORKS Simulation et ajoutez à nouveau la licence à un niveau inférieur.
  3. Facultatif : Pour désactiver le complément, cliquez sur SOLIDWORKS Simulation (CommandManager) ou supprimez-le dans Outils > Compléments.
Les cas suivants utilisent toujours l'ordre des licences :
  • Lors du lancement de SOLIDWORKS Simulation.
  • Si SOLIDWORKS Simulation est ajouté dans Outils > Compléments.
  • Si vous cliquez sur SOLIDWORKS Simulation sans préciser de licence dans la liste déroulante.
Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Chargement des modules Flow Simulation

En tant que client disposant d'une licence SolidNetWork, deux méthodes vous permettent de contrôler le chargement des modules complémentaires HVAC et Electronics Cooling pour Flow Simulation.

La première vous permet de spécifier le comportement par défaut des compléments lorsque vous chargez Flow Simulation. L'option Chargement automatique des modules complémentaires Flow Simulation, s'ils sont disponibles se trouve dans l'onglet Client SolidNetWork License Manager > Ordre des licences. Désactivez cette option si vous n'avez pas besoin des compléments Flow Simulation. Les modules complémentaires HVAC et Electronics Cooling ne se chargent pas lorsque Flow Simulation est ajouté avec les méthodes existantes.

La deuxième vous permet de remplacer le comportement par défaut et d'inclure les modules complémentaires HVAC et Electronics Cooling lorsque vous chargez Flow Simulation. Cliquez sur la flèche vers le bas [image] sur SOLIDWORKS Flow Simulation (barre d'outils du complément SOLIDWORKS®) ou SOLIDWORKS Flow Simulation avec un deux modules complémentaires à charger.

Sans ces méthodes, les licences des modules complémentaires sont consommées, que vous en ayez besoin ou non, et peuvent être refusées aux autres utilisateurs de votre réseau.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics

Lorsque vous exécutez des études dans SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation ou SOLIDWORKS Plastics, les licences réseau restent actives et n'ont pas de délai d'expiration. SOLIDWORKS conserve les licences pendant le processus de calcul, qui est considéré comme une activité.

Les périodes d'inactivité, définies par une option d'expiration, ne prennent effet qu'une fois le calcul des études terminé.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative

Vous pouvez configurer un ordinateur de réseau pour servir à la fois de gestionnaire de licences distribuant les licences SolidNetWork et d'emplacement de l'image administrative à partir de laquelle les utilisateurs peuvent installer le logiciel SOLIDWORKS.

Les ordinateurs clients peuvent se procurer des licences auprès du gestionnaire de licences puis installer SOLIDWORKS depuis le même ordinateur.

Cette configuration nécessite l'installation du gestionnaire de licences et de l'image administrative sur le même ordinateur. Commencez par installer le gestionnaire de licences puis créez et déployez l'image administrative.
Pour plus de détails, voir:
  • Installation de SolidNetWork License Manager Server
  • Déployer vers des clients multiples
Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Désinstaller SolidNetwork License Manager
Gestion des licences FlexNet Publisher


Désinstaller SolidNetwork License Manager

Lorsque vous mettez à niveau SolidNetwork License Manager, vous devez désinstaller l'anciene version avant d'installer la nouvelle.

  1. Démarrez SolidNetWork License Manager en cliquant sur Démarrer > Outils SOLIDWORKS version > SolidNetWork License Manager Server version.
  2. Vérifiez qu'aucun ordinateur client du réseau n'exécute SOLIDWORKS.
    L'onglet Utilisation de la licence indique les clients exécutant SOLIDWORKS.
  3. Si vous souhaitez transférer la licence SolidNetWork sur un autre ordinateur, désactivez-la sur cet ordinateur avant de supprimer SolidNetWork License Manager.
    Pour des informations sur le transfert de licences SolidNetWork, voir Transférer une licence SolidNetWork.
  4. Dans l'onglet Administration du serveur, sous Serveur de licences, cliquez sur Arrêter.
  5. Cliquez sur OK pour quitter le gestionnaire de licences.
  6. Dans Windows, ouvrez Panneau de configuration > Programmes et fonctionnalités.
  7. Sélectionnez SOLIDWORKS SolidNetWork License Manager, cliquez sur Désinstaller et confirmez la désinstallation.
  8. Dans l'Explorateur de fichiers, supprimez le dossier SOLIDWORKS SolidNetWork License Manager.
    (En général, vous trouverez ce dossier sous Program Files (x86) dans le répertoire d'installation de SOLIDWORKS.)

Vous êtes maintenant prêt à installer une nouvelle version du gestionnaire de licences. Pour plus de détails, reportez-vous à la section Installation de SolidNetWork License Manager Server.

Si l'ordinateur de SolidNetwork License Manager est équipé d'un dongle matériel, enlevez-le avant d'installer la nouvelle version de SolidNetwork License Manager.
Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Gestion des licences FlexNet Publisher
Installation de SolidNetWork License Manager Server


Gestion des licences FlexNet Publisher

La gestion des licences SolidNetWork est basée sur FlexNet Publisher®.

Pour des informations supplémentaires sur la gestion des licences FlexNet Publisher, voir le License Administration Guide (Guide d'administration des licences) de FlexNet Publisher dans le répertoire d'installation de SolidNetWork License Manager (C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf).

Pour obtenir les informations les plus récentes sur la gestion des licences FlexNet Publisher, contactez Flexera® Software.

Vous pouvez vérifier la version de FlexNet en examinant le journal sur le serveur de licences. Ouvrez le serveur SolidNetwork License Manager et cliquez sur Administration du serveur > Afficher le fichier journal. Le journal répertorie la version des licences FlexNet au début entre parenthèses.

Sujet parent Administrer des licences avec SolidNetWork License Manager
Présentation de l'installation des licences SolidNetWork
Démarrer SolidNetWork License Manager
Mettre à niveau SolidNetwork License Manager
Transférer une licence SolidNetWork
Suppression des fichiers de licence SolidNetWork
Emprunter et rendre des licences SolidNetWork
Gestion de l'accès aux versions de SOLIDWORKS
Surveillance du temps d'inactivité d'une licence
Utilisation d'une licence temporaire
Utiliser les licences SolidNetWork avec des compléments
Sélection d'une licence SOLIDWORKS Simulation avec une licence SolidNetWork License
Chargement des modules Flow Simulation
Délai d'inactivité pour SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation et SOLIDWORKS Plastics
Utiliser le même ordinateur pour les installations du Gestionnaire de licences et de l'image administrative
Désinstaller SolidNetwork License Manager


Dépannage

Reportez-vous à ces rubriques pour vous aider à résoudre les problèmes d'installation.

Table des matières

  • Utilisation de la licence de réseau

  • Fichiers journaux du Gestionnaire d'installation SOLIDWORKS

    Les fichiers journaux du Gestionnaire d'installation SOLIDWORKS sont disponibles pour vous aider à résoudre les problèmes d'installation.

  • Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS

    Le Gestionnaire d'installation SOLIDWORKS télécharge les fichiers d'installation dont il a besoin vers le dossier que vous spécifiez. Cette rubrique fournit des réponses aux questions fréquemment posées concernant le dossier de téléchargement.

  • Dépannage des licences SolidNetWork

    Si l'installation du logiciel SolidNetWork License Manager échoue, consultez les explications possibles suivantes.

  • Dépannage relatif aux mises à niveau

    Si vous rencontrez des problèmes lorsque vous mettez à niveau vers une nouvelle version SOLIDWORKS, consultez les explications possibles suivantes.

  • Validation des cartes graphiques lors de l'installation ou de la mise à niveau

    Lorsque vous terminez l'installation ou la mise à niveau de SOLIDWORKS sur votre ordinateur, exécutez SOLIDWORKS Rx pour vous assurer que votre ordinateur utilise une carte graphique et un pilote de carte graphique pris en charge.


Utilisation de la licence de réseau

Cette boîte de dialogue s'ouvre lorsque le serveur n'a plus assez de licences pour un produit.

Cliquez sur la flèche dans la case Produit pour afficher tous les choix de produits. Le choix inclut SOLIDWORKS et tous les compléments que vous pouvez acheter.

Nombre total de licences est le nombre total de licences que vous avez acheté.

Licences disponibles est le nombre de licences qui ne sont pas utilisées actuellement.

La case Licences utilisées par vous donne des informations sur chaque personne utilisant une licence actuellement.

Sujet parent Dépannage
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Dépannage relatif aux mises à niveau
Validation des cartes graphiques lors de l'installation ou de la mise à niveau


Fichiers journaux du Gestionnaire d'installation SOLIDWORKS

Les fichiers journaux du Gestionnaire d'installation SOLIDWORKS sont disponibles pour vous aider à résoudre les problèmes d'installation.

Ces fichiers journaux se trouvent avec les autres fichiers journaux de l'application SOLIDWORKS.

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

Si vous exécutez le Gestionnaire d'installation à partir d'un compte système, les journaux se trouvent dans ce dossier :
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
Pour afficher les répertoires des fichiers journaux, vous devrez peut-être définir les options des dossiers Windows sur Afficher les fichiers et dossiers cachés.

Si les données d'application sont situées sur un lecteur autre que C:, modifiez le chemin d'accès du répertoire en conséquence.

Ce répertoire contient le fichier SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, qui est un journal général de la progression du Gestionnaire d'installation SOLIDWORKS.

Le sous-répertoire Other Logs (Autres journaux) renferme des informations de journal d'installation plus détaillées.

Sujet parent Dépannage
Utilisation de la licence de réseau
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Dépannage relatif aux mises à niveau
Validation des cartes graphiques lors de l'installation ou de la mise à niveau


Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS

Le Gestionnaire d'installation SOLIDWORKS télécharge les fichiers d'installation dont il a besoin vers le dossier que vous spécifiez. Cette rubrique fournit des réponses aux questions fréquemment posées concernant le dossier de téléchargement.

Question Réponse
Comment installer les fichiers dans ce dossier?

Exécutez setup.exe. Vous devrez peut-être télécharger certains fichiers si vous choisissez d'installer des éléments qui n'ont pas été téléchargés antérieurement.

N'installez les fichiers pas en utilisant msiexec (voir ci-dessous).
Puis-je installer des fichiers MSI manuellement à partir de ce dossier en utilisant msiexec ou une autre application?

Non. Le Gestionnaire d'installation ne télécharge pas certains fichiers requis lors de l'exécution de msiexec.
Puis-je sélectionner le même dossier de téléchargement pour chaque version que j'installe?

Les dossiers de téléchargement sont spécifiques à la version. Le Gestionnaire d'installation de SOLIDWORKS crée automatiquement un sous-dossier spécifique à la version dans le dossier spécifié.

J'ai téléchargé certains produits manuellement sur le site Web de Dassault Systèmes SOLIDWORKS Corporation. Est-ce que le Gestionnaire d'installation peut les installer?
Les fichiers téléchargés manuellement peuvent être utilisés par le Gestionnaire d'installation SOLIDWORKS. Cependant, il est préférable d'exécuter le Gestionnaire d'installation SOLIDWORKS, et de sélectionner l'option de téléchargement des fichiers. Le Gestionnaire d'installation SOLIDWORKS indique les fichiers dont vous avez besoin selon ce que vous installez, et vous fournit des liens pour télécharger chaque fichier. Vous pouvez utiliser cette option lorsque la page de téléchargement ne fonctionne pas (probablement à cause de restrictions de téléchargement imposées par le serveur proxy).
Si une boîte de dialogue vous demande si vous souhaitez enregistrer ou exécuter les fichiers pendant un téléchargement ou une installation, spécifiez toujours d'enregistrer.
Est-ce que les fichiers téléchargés peuvent être partagés avec d'autres utilisateurs?

Oui. Le téléchargement doit alors se faire sur un partage réseau. Chaque client peut ensuite exécuter le Gestionnaire d'installation SOLIDWORKS à partir du partage pour procéder à l'installation.

Aucun téléchargement supplémentaire n'est requis, à moins qu'un utilisateur ne choisisse d'installer des produits qui n'ont pas été sélectionnés au cours du téléchargement initial ou qu'un ordinateur utilisant ce téléchargement pour l'installation n'ait une configuration requise différente de celle de l'ordinateur sur lequel vous avez téléchargé les fichiers.

Si vous téléchargez pour le compte d'autres utilisateurs, mais que vous n'installez pas, sélectionnez l'option Télécharger uniquement lorsque vous installez. Cette option vous permet de sélectionner des produits indépendamment de ce qui est installé sur votre système. Cependant, elle ne peut pas être utilisée pour télécharger des correctifs ou pour créer des images administratives.
Comment savoir quand une nouvelle version des produits SOLIDWORKS est disponible?
Vous êtes informé de la disponibilité d'une nouvelle version dans les cas suivants :
  • Si vous exécutez la fonction Vérifier la disponibilité de mises à jour (Démarrer > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour)
  • Si vous avez activé Téléchargement en arrière-plan de SOLIDWORKS
  • Si vous sélectionnez une version installée de SOLIDWORKS dans Ajout/Suppression de programmes et que vous cliquez sur Modifier
  • Si vous exécutez une version antérieure du Gestionnaire d'installation (sldIM.exe) à partir d'un dossier de téléchargement
Dans ces cas, vous pouvez choisir de télécharger la version plus récente. Le Gestionnaire d'installation SOLIDWORKS téléchargera et exécutera la nouvelle version de lui-même, sans aucun fichier d'installation. Après l'exécution de la nouvelle version du Gestionnaire d'installation SOLIDWORKS, vous pouvez sélectionner un ensemble d'actions d'installation. Le Gestionnaire d'installation SOLIDWORKS détermine quels fichiers d'installation sont requis (et n'ont pas encore été téléchargés) et vous propose de les télécharger.
Pourquoi le Gestionnaire d'installation SOLIDWORKS ne me laisse-t-il pas sélectionner un autre service pack de produit à installer ?

Les versions du Gestionnaire d'installation SOLIDWORKS n'installent qu'une version spécifique des produits SOLIDWORKS. Si vous voulez installer un autre service pack, vous devez exécuter la version correspondante du Gestionnaire d'installation SOLIDWORKS. Pour trouver la dernière version disponible, voir la rubrique précédente.
Pourquoi le Gestionnaire d'installation SOLIDWORKS ne parvient-il pas à télécharger des fichiers ?

Si des restrictions de serveur proxy empêchent les applications de télécharger des fichiers, le Gestionnaire d'installation SOLIDWORKS ne peut pas télécharger les fichiers automatiquement.

Vous pouvez télécharger les fichiers manuellement, puis les installer à l'aide du Gestionnaire d'installation SOLIDWORKS. Sélectionnez l'option souhaitée dans le Gestionnaire d'installation SOLIDWORKS pour télécharger des fichiers individuels (par exemple, Méthode de téléchargement manuelle sur la page Options de téléchargement). Selon votre sélection de produits et votre configuration minimale requise, une page Web apparaît dans une fenêtre séparée contenant des liens pour télécharger tous les fichiers requis manuellement.
Tous mes produits SOLIDWORKS ne sont pas mis à jour vers le Service Pack le plus récent. Pourquoi la fonction Vérifier la disponibilité m'indique-t-elle que je dispose de la version la plus récente ?

La fonction Vérifier la disponibilité de mises à jour ne vous indique que si vous avez installé (ou que vous exécutez) la dernière version du Gestionnaire d'installation SOLIDWORKS.

Si vous voulez mettre à jour tous les produits à la dernière version installée dans Panneau de commande > Programmes > Programmes et fonctions, sélectionnez la dernière version de SOLIDWORKS installée et cliquez sur Modifier.
Puis-je copier un DVD vers un dossier de téléchargement?

Oui, mais les installations risquent d'échouer à moins de copier l'intégralité du contenu de chaque DVD pour cette plate-forme. Le Gestionnaire d'installation SOLIDWORKS recherche les fichiers swdata*.id pour déterminer la version. Si ces fichiers ne sont pas présents, il ne peut pas reconnaître les fichiers d'installation copiés et vous demande de les télécharger.
Sujet parent Dépannage
Utilisation de la licence de réseau
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Dépannage relatif aux mises à niveau
Validation des cartes graphiques lors de l'installation ou de la mise à niveau


Dépannage des licences SolidNetWork

Si l'installation du logiciel SolidNetWork License Manager échoue, consultez les explications possibles suivantes.

Sujet parent Dépannage
Utilisation de la licence de réseau
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage relatif aux mises à niveau
Validation des cartes graphiques lors de l'installation ou de la mise à niveau

Accéder aux fichiers journaux des licences SolidNetWork

En cas d'erreur avec la licence, la réponse apparaît souvent dans le fichier dossier_installation_Gestionnaire_SNL\lmgrd.log.

Impossible d'obtenir une licence pour SOLIDWORKS. Impossible d'établir la connexion au serveur de licence.

De manière générale, ce problème est créé par les paramètres de port.

  • Les paramètres de port ne correspondent pas entre le Gestionnaire de licences SolidNetWork et le client de la licence.
  • Des paramètres de port supplémentaires n'ont pas été spécifiés pour des versions multiples de SolidNetWork License Manager.
  • Vérifiez que l'ordinateur client peut résoudre et router vers le serveur, compte tenu du nom du serveur.
Pour des détails sur les paramètres de port pour les Gestionnaires de licences SolidNetWork et les clients, voir Utiliser les licences SolidNetWork avec des pare-feux.
Utiliser les licences SolidNetWork avec des pare-feux


Dépannage relatif aux mises à niveau

Si vous rencontrez des problèmes lorsque vous mettez à niveau vers une nouvelle version SOLIDWORKS, consultez les explications possibles suivantes.

Sujet parent Dépannage
Utilisation de la licence de réseau
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Validation des cartes graphiques lors de l'installation ou de la mise à niveau

Modification ou réparation de la source qui a été déplacée

Lorsque SOLIDWORKS est installé, le Gestionnaire d'installation SOLIDWORKS se souvient de l'emplacement des sources d'installation (disque média, image du disque sur un réseau, etc.). Les sources doivent être disponibles au même endroit lors d'une modification ou d'une réparation.

Si ce n'est pas le cas ou bien si la source a été supprimée ou si le média source change, le Gestionnaire d'installation SOLIDWORKS produit un message d'erreur. Vous pouvez néanmoins modifier ou réparer les sources d'installation en naviguant vers un autre emplacement à condition qu'il contienne la même structure de fichiers et de dossiers.


Validation des cartes graphiques lors de l'installation ou de la mise à niveau

Lorsque vous terminez l'installation ou la mise à niveau de SOLIDWORKS sur votre ordinateur, exécutez SOLIDWORKS Rx pour vous assurer que votre ordinateur utilise une carte graphique et un pilote de carte graphique pris en charge.

Pour valider des cartes graphiques lors de l'installation ou de la mise à niveau :

  1. Lorsque le gestionnaire d'installation termine l'installation et affiche la page Terminer, sous Vérifier votre système, cliquez sur Exécuter le diagnostic du système.

    SOLIDWORKS Rx démarre et exécute le diagnostic.

  2. SOLIDWORKS Rx confirme si la carte graphique et le pilote de carte graphique sont pris en charge.
    Si la carte graphique est prise en charge, mais pas le pilote, un message de statut peut fournir une indication pour la mise à jour d'un pilote.

Tous les dix démarrages de SOLIDWORKS, un message Vérifier votre système s'affiche et recommande une nouvelle exécution du diagnostic du système. Pour supprimer ces notifications, cliquez à l'aide du bouton droit de la souris sur SOLIDWORKS Resource Monitor [image] dans la zone de notification Windows, puis cliquez sur Ignorer les notifications graphiques.

Vous pouvez valider une carte graphique et un pilote n'importe quand en cliquant à l'aide du bouton droit de la souris sur SOLIDWORKS Resource Monitor dans la zone de notification Windows. Le menu vous permet également d'effectuer les opérations suivantes :
  • Accéder à l'aide de SOLIDWORKS Resource Monitor
  • Exécuter le diagnostic du système
  • Ignorer les notifications graphiques
  • Ignorer les notifications de maintenance
  • Afficher les pilotes de carte graphique certifiés
Sujet parent Dépannage
Utilisation de la licence de réseau
Fichiers journaux du Gestionnaire d'installation SOLIDWORKS
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS
Dépannage des licences SolidNetWork
Dépannage relatif aux mises à niveau


Aide pour l'application Gestionnaire d'installation SOLIDWORKS

Le Gestionnaire d'installation SOLIDWORKS est une application autonome qui installe et met à jour vos produits SOLIDWORKS.

Le Gestionnaire d'installation SOLIDWORKS est l'outil principal pour le téléchargement, l'installation, la modification, la mise à jour, la réparation et la suppression du logiciel SOLIDWORKS.

Vous pouvez exécuter le Gestionnaire d'installation SOLIDWORKS :
  • A partir d'un DVD SOLIDWORKS, d'un dossier source partagé ou d'un dossier de téléchargement (lorsque vous installez une nouvelle version)
  • A partir du Panneau de configuration, à la page Ajout/Suppression de programmes (lorsque vous modifiez ou supprimez une version existante)
  • Par l'intermédiaire d'une vérification de mises à jour planifiée ou manuelle (lorsque vous recherchez, téléchargez et installez de nouvelles versions)

Les versions de SOLIDWORKS sont dotées du Gestionnaire d'installation SOLIDWORKS spécifique à la version de SOLIDWORKS en question.

Table des matières

  • Téléchargement en arrière-plan de SOLIDWORKS

    L'option de téléchargement en arrière-plan de SOLIDWORKS effectue des téléchargements automatiques des fichiers (par exemple, lorsqu'une nouvelle version de Service Pack est localisée) via des traitements en arrière-plan, vous permettant ainsi de continuer de travailler pendant le téléchargement. Une fois le téléchargement terminé, vous pouvez choisir d'installer maintenant, remettre le téléchargement à plus tard ou le supprimer.

  • Spécifier des options pour le gestionnaire d'installation

    Ces options comprennent les paramètres de journalisation, l'accès à Internet et la langue utilisés dans le Gestionnaire d'installation.

  • Résultats de la vérification de la disponibilité de mises à jour

    La fonction Vérifier la disponibilité de mises à jour recherche les versions plus récentes de SOLIDWORKS.

  • Emplacement de l'image administrative

    Indiquez l'emplacement de l'installation de l'image administrative.

  • Options de téléchargement

    Spécifiez les détails de la fin de l'opération de téléchargement tels que l'emplacement des fichiers téléchargés, comment télécharger les fichiers et s'il faut installer ceux-ci.

  • Options de téléchargement pour les fichiers du Gestionnaire d'installation SOLIDWORKS

    Vous avez choisi de télécharger une version ultérieure du Gestionnaire d'installation SOLIDWORKS. Utilisez cet écran pour spécifier où et comment elle est téléchargée.

  • Télécharger les fichiers d'installation du produit

    Spécifiez où et comment télécharger les fichiers manquants pour le produit spécifié.

  • Progression du téléchargement

    Le Gestionnaire d'installation SOLIDWORKS télécharge, vérifie et extrait tous les fichiers en parallèle pendant ce processus.

  • Download Results

    Indique si le téléchargement s'est bien terminé, a échoué pendant l'opération ou a été annulé.

  • Erreurs d'installation / Installation annulée

    L'installation a rencontré une erreur ou a été annulée.

  • L'installation est terminée

    Le Gestionnaire d'installation SOLIDWORKS a terminé son traitement.

  • Emplacement d'installation

  • Options de mise à niveau

    Une ou plusieurs versions majeures antérieures de SOLIDWORKS sont installées sur cet ordinateur. Vous pouvez créer une nouvelle installation, qui coexistera avec la version antérieure, ou faire une mise à niveau, ce qui supprimera la version antérieure.

  • Progression de l'installation

    Cette écran montre la progression de l'installation.

  • Type d'installation

    Vous pouvez spécifier l'opération d'installation que vous souhaitez exécuter. Par exemple, créer une nouvelle installation, modifier ou réparer une installation existante, créer une image administrative, installer des produits Serveur administratif ou télécharger des fichiers de façon à pouvoir les partager et les installer sur d'autres ordinateurs.

  • Installer et gérer plusieurs ordinateurs

    Le Gestionnaire d'installation SOLIDWORKS propose les outils suivants pour l'installation et la gestion de SOLIDWORKS sur plusieurs ordinateurs.

  • Téléchargement manuel

    Vous avez choisi de télécharger les fichiers manuellement (ou vous avez peut-être choisi de télécharger manuellement la dernière fois que vous avez exécuté le Gestionnaire d'installation SOLIDWORKS).

  • Version plus récente disponible

    Le Gestionnaire d'installation a détecté une version plus récente des produits SOLIDWORKS. Vous pouvez choisir d'installer la version contenue dans le DVD d'installation d'origine ou de télécharger et d'installer la nouvelle version.

  • Aucune nouvelle version disponible

    Aucune version plus récente ne peut être téléchargée. Continuer à installer la version indiquée.

  • Processus détectés

    Le Gestionnaire d'installation SOLIDWORKS a détecté sur cet ordinateur des processus qui pourraient empêcher la réussite de l'installation.

  • Sélection des produits

    Vous pouvez spécifier les produits à installer, modifier, télécharger ou supprimer.

  • Produits à télécharger

    Sélectionnez les produits SOLIDWORKS à télécharger à l'emplacement spécifié.

  • Produits à réparer

    Lorsque vous spécifiez Réparer cette installation, cet écran affiche les produits SOLIDWORKS, avec les numéros de version, qui peuvent être réparés par cette version du Gestionnaire d'installation SOLIDWORKS.

  • Numéros de série

    Les numéros de série associent votre ordinateur aux produits SOLIDWORKS que vous avez achetés.

  • Installation du serveur

    Les produits Serveur que vous tentez d'installer sont listés, ainsi que les résultats des installations.

  • Résumé

    Le Gestionnaire d'installation SOLIDWORKS dispose de toutes les informations nécessaires pour terminer l'opération d'installation.

  • Avertissements de la vérification du système

    L'option de vérification du système a signalé des problèmes qui pourraient avoir un impact sur la façon dont vous continuez l'installation. Dans la plupart des cas, vous devriez pouvoir continuer l'exécution du Gestionnaire d'installation SOLIDWORKS.

  • Options de l'Assistance pour le perçage/Toolbox

    Si vous installez SOLIDWORKS Toolbox, SOLIDWORKS comprend une bibliothèque de types de perçages standard et de composants.

  • Désinstaller des produits

    Lorsque vous sélectionnez Supprimer ou Désinstaller des programmes dans le Panneau de configuration, cet écran affiche les produits SOLIDWORKS (avec les numéros de version), qui peuvent être désinstallés par cette version du Gestionnaire d'installation SOLIDWORKS. Choisissez une désinstallation standard, personnalisée ou complète.


Téléchargement en arrière-plan de SOLIDWORKS

L'option de téléchargement en arrière-plan de SOLIDWORKS effectue des téléchargements automatiques des fichiers (par exemple, lorsqu'une nouvelle version de Service Pack est localisée) via des traitements en arrière-plan, vous permettant ainsi de continuer de travailler pendant le téléchargement. Une fois le téléchargement terminé, vous pouvez choisir d'installer maintenant, remettre le téléchargement à plus tard ou le supprimer.

L'option de téléchargement en arrière-plan est activée par défaut lorsque vous installez SOLIDWORKS.

Lorsque le Gestionnaire d'installation est exécuté, que ce soit pour une installation ou pour un téléchargement, le processus de téléchargement en arrière-plan est interrompu. A titre d'exemple, il interrompt tous les téléchargements en cours, il interdit le lancement d'autres téléchargements et ne permet pas de changer la spécification du fichier de téléchargement.

Vous pouvez désactiver le téléchargement en arrière-plan durant l'installation. Sur la page Résumé, sous Options de téléchargement, désactivez l'option Utiliser le téléchargement en arrière-plan pour les service packs à venir.

Lorsque cette option est activée, l'icône s'affiche dans la barre d'état système de Windows de la barre d'outils :

Cliquez sur cette icône pour activer les fonctions suivantes :
  • Aide sur le téléchargement en arrière-plan
  • Suspendre le téléchargement
  • Reprendre le téléchargement
  • Annuler le téléchargement
  • Options d'installation
  • Modifier les paramètres de téléchargement
  • Vérifier la disponibilité de mises à jour
  • Rechercher automatiquement des mises à jour
  • Télécharger automatiquement des mises à jour
  • Désactiver le téléchargement en arrière-plan

Aide sur le téléchargement en arrière-plan

Ouvrez cette rubrique d'aide pour le téléchargement en arrière-plan dans le Guide d'installation de SOLIDWORKS.

Suspendre/reprendre le téléchargement

Si un téléchargement s'effectue en arrière-plan, cliquez sur Suspendre le téléchargement pour interrompre l'opération, sachant que vous pouvez continuer le téléchargement plus tard en cliquant sur Reprendre le téléchargement.

Annuler le téléchargement

Si un téléchargement est en cours, interrompez-le et supprimez tous les fichiers téléchargés par l'option Téléchargement en arrière-plan.
Vous ne pouvez pas reprendre un téléchargement annulé.

Options d'installation

Lorsque le téléchargement est terminé, vous pouvez choisir parmi les options suivantes :
  • Installer maintenant : Installez les fichiers téléchargés.
  • Me le rappeler ultérieurement : N'installez pas les fichiers téléchargés, mais créez un message pour vous rappeler de reprendre l'opération plus tard.
  • Supprimer ce téléchargement : N'installez pas les fichiers téléchargés et supprimez-les. (Cette option est pratique lorsque vous avez finalement décidé de ne pas installer les fichiers téléchargés).

Modifier les paramètres de téléchargement

Changez l'emplacement du dossier de téléchargement des fichiers en arrière-plan.

Cette option n'est pas disponible lorsqu'un téléchargement est soit en cours soit suspendu.
Vous pouvez également spécifier le Nombre de jour entre les vérifications de mise à jour.

Vérifier la disponibilité de mises à jour

Exécutez la fonction Vérifier la disponibilité de mises à jour du Gestionnaire d'installation SOLIDWORKS.

Recherche automatique des mises à jour

Exécutez régulièrement la fonction Vérifier la disponibilité de mises à jour, vous avertissant des mises à jour disponibles au téléchargement.

Téléchargement automatique des mises à jour

Exécutez régulièrement la fonction Vérifier la disponibilité de mises à jour, téléchargeant les mises à jour à mesure de leur disponibilité.

Désactivation et réactivation du téléchargement en arrière-plan SOLIDWORKS

Vous pouvez désactiver les Téléchargements en arrière-plan en cliquant sur l'icône dans la barre d'état système de Windows et en sélectionnant Désactiver le téléchargement en arrière-plan.

Pour réactiver le téléchargement en arrière-plan, cliquez sur Démarrer > Gestionnaire d'installation SOLIDWORKS > Téléchargement en arrière-plan SOLIDWORKS.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Spécifier des options pour le gestionnaire d'installation

Ces options comprennent les paramètres de journalisation, l'accès à Internet et la langue utilisés dans le Gestionnaire d'installation.

Pour spécifier les options du Gestionnaire d'installation avant d'installer le logiciel :

  1. Dans le gestionnaire d'installation, cliquez à l'aide du bouton droit de la souris sur l'icône SOLIDWORKS de la barre de titre et sélectionnez :
    Option | Description
    Niveaux de journalisation de l'installation Spécifie le niveau de journalisation sur Elevé, Moyen ou Faible. Les niveaux plus élevés permettent de collecter plus de données pour le dépannage, mais peuvent ralentir l'installation. Faible (le plus rapide) est le niveau par défaut et offre une performance et une stabilité optimales.

    Créer des journaux Windows Installer (lent) permet d'enregistrer les journaux dans le même dossier que les autres journaux d'installation.
    Options relatives à l'image administrative | Sélectionnez Utiliser des noms de fichier courts (format 8.3) ou Utiliser des noms de dossier et de fichier complets.
    Collecter les journaux d'installation | Spécifie l'emplacement de stockage des journaux d'installation. Le gestionnaire d'installation enregistre ces fichiers dans IM_Logs.zip.
    Désactiver l'accès à Internet
    Langue | Spécifie la langue utilisée dans le Gestionnaire d'installation. La langue par défaut est l'anglais.
  2. Cliquez sur Fermer.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Résultats de la vérification de la disponibilité de mises à jour

La fonction Vérifier la disponibilité de mises à jour recherche les versions plus récentes de SOLIDWORKS.

Si vous disposez de privilèges d'administrateur sur l'ordinateur, vous pouvez exécuter Vérifier la disponibilité de mises à jour manuellement :
  • Dans Windows, cliquez sur Démarrer > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour
  • Dans SOLIDWORKS, cliquez sur [image] > Vérifier la disponibilité de mises à jour
L'option Vérifier la disponibilité de mises à jour n'est pas disponible pour les clients installés depuis des images administratives.

Nouvelle version disponible

Le Gestionnaire d'installation SOLIDWORKS a détecté une version plus récente des produits SOLIDWORKS. Vous pouvez mettre à jour en sélectionnant le Gestionnaire d'installation SOLIDWORKS pour cette version.

La version plus récente peut télécharger les fichiers d'installation en fonction des produits que vous spécifiez dans l'installation. Vous pouvez partager les fichiers téléchargés avec d'autres utilisateurs qui effectuent des installations par l'intermédiaire du Gestionnaire d'installation SOLIDWORKS.

Ces téléchargements sont uniquement destinés au Gestionnaire d'installation SOLIDWORKS.
Les options suivantes sont disponibles:
  • Si plusieurs versions sont disponibles, vous pouvez en sélectionner une dans la liste.
  • Pour des détails sur cette version, cliquez sur Voir ce que comprend cette mise à niveau.
Cliquez sur Suivant pour extraire et exécuter la version sélectionnée du Gestionnaire d'installation SOLIDWORKS.

Aucun nouveau téléchargement disponible/Impossible de vérifier la disponibilité de nouvelles versions

Le gestionnaire d'installation SOLIDWORKS n'a pas trouvé de version plus récente des produits SOLIDWORKS, soit parce que vous installez la dernière version disponible, soit parce qu'il n'a pas pu se connecter au site SOLIDWORKS pour vérifier.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Emplacement de l'image administrative

Indiquez l'emplacement de l'installation de l'image administrative.

Quand vous créez une image administrative, les options suivantes s'appliquent:
Emplacement de la nouvelle image | C'est l'emplacement du répertoire dans lequel le Gestionnaire d'installation SOLIDWORKS créera la nouvelle image. | Cet emplacement ne peut pas contenir une image administrative existante. L'image administrative doit se trouver dans un dossier pouvant être partagé pour le déploiement client.
Estimation de l'espace requis pour la création de l'image | Il s'agit de l'espace supplémentaire requis pour l'image administrative. | Vérifiez que le disque sur lequel vous installez a suffisamment d'espace libre pour prendre en charge les composants de l'image requis.
Créer une image à partir de | C'est l'emplacement du répertoire depuis lequel vous installez les produits SOLIDWORKS. Cette option s'affiche uniquement si l'option Installer uniquement est spécifiée. Pour plus de détails, voir Options de téléchargement.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Options de téléchargement

Spécifiez les détails de la fin de l'opération de téléchargement tels que l'emplacement des fichiers téléchargés, comment télécharger les fichiers et s'il faut installer ceux-ci.

Le Gestionnaire d'installation SOLIDWORKS permet la distribution électronique du logiciel (DEL). Si vous n'installez pas à partir d'un DVD SOLIDWORKS, vous êtes invité à spécifier la source des produits SOLIDWORKS que vous installez.

Pour obtenir des réponses à vos questions sur le dossier de téléchargement, voir Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS.

Que voulez-vous faire ?

Sélectionnez l'une des options suivantes :

Télécharger et installer/Télécharger et créer une image

Une fois le téléchargement terminé, le Gestionnaire d'installation SOLIDWORKS exécute une installation en utilisant les fichiers téléchargés.

Télécharger uniquement. Vous pouvez télécharger une fois puis partager les fichiers téléchargés avec plusieurs ordinateurs.

Le Gestionnaire d'installation SOLIDWORKS n'exécute pas d'installation après son téléchargement.

De manière générale, vous spécifiez cette option si vous téléchargez les fichiers pour configurer un ensemble de fichiers d'installation à partager entre plusieurs ordinateurs.

Si vous spécifiez cette option, il vous est alors demandé de choisir entre deux ensembles de fichiers à télécharger :
  • Fichiers pour CET ordinateur : Le téléchargement comprendra uniquement les fichiers manquants dans l'ensemble de fichiers d'installation qui se trouve actuellement sur l'ordinateur.
    Ce téléchargement devrait être plus petit car il contient :
    • Seulement les fichiers que vous avez sélectionnés dans la page Sélection des produits.
    • Seulement les fichiers prérequis nécessaires à l'ordinateur mais pas encore installés.

    Cependant, si vous essayez d'utiliser cet ensemble de fichiers téléchargés sur un autre ordinateur pour exécuter une installation, certains fichiers pourraient manquer (parce que l'ensemble de fichiers d'installation de l'autre ordinateur pourrait être différent de celui-ci). Vous pouvez utiliser ces fichiers de téléchargement pour réaliser une installation sur un autre ordinateur, mais lors de l'exécution de l'installation, il se peut que vous deviez télécharger d'autres fichiers pour compléter l'ensemble de fichiers d'installation sur cet ordinateur.

  • Fichiers à partager avec N'IMPORTE QUEL ordinateur : Le téléchargement contiendra l'ensemble complet de fichiers d'installation pouvant servir à installer cette version sur tout ordinateur.

    Ce téléchargement sera plus volumineux car il contient l'ensemble complet des fichiers que vous pouvez utiliser pour installer cette version d'un produit sur n'importe quel ordinateur.

    Si vous avez spécifié un ensemble limité de produits à télécharger, cette option ignore cette sélection et télécharge tous les produits contenus dans la version du produit.

    Le téléchargement contiendra tous les produits requis pour créer une image administrative, et pas seulement les fichiers requis pour une installation individuelle.

Installation uniquement/Création d'une image uniquement. J'ai déjà tous les fichiers d'installation nécessaires.

Le Gestionnaire d'installation SOLIDWORKS ne télécharge aucun fichier mais utilise les fichiers qui se trouvent dans le répertoire sélectionné.

Cliquez sur Parcourir pour accéder à un autre emplacement. Par exemple, vous pouvez naviguer jusqu'à un DVD d'installation ou un dossier de téléchargement, à condition que cet emplacement contienne tous les fichiers requis.

Si un message d'erreur vous informe que le dossier est incomplet et que vous vous attendiez à ce que tous les fichiers d'installation soient présents à cet emplacement, les explications possibles sont les suivantes :
  • Vous avez choisi d'installer un composant qui n'a pas encore été téléchargé ou a été sélectionné par défaut.
  • Les fichiers ont été téléchargés sur un autre ordinateur avec une configuration minimale différente.
  • Vous aviez précédemment effectué une installation client et vous créez à présent une image administrative qui requiert un plus grand nombre de fichiers.

Vous pouvez soit naviguer jusqu'à un dossier contenant tous les fichiers (par exemple, un DVD), soit sélectionner une des options de téléchargement.

Où souhaitez-vous télécharger les fichiers nécessaires ?

Il s'agit de l'emplacement du dossier de téléchargement.

Dans certains cas, il se peut que cette option soit visible, mais désactivée. Par exemple, si vous avez spécifié Installation uniquement, le Gestionnaire d'installation SOLIDWORKS installera tous les fichiers téléchargés contenus dans le répertoire spécifié pour cette option, plutôt que d'utiliser un dossier de téléchargement distinct.

Que vous téléchargiez ces fichiers ou que vous y accédiez depuis votre propre emplacement, tous les fichiers doivent être téléchargés dans le même dossier de téléchargement.

Taille estimée du téléchargement

L'espace disque requis estimé pour le téléchargement dépend de la liste complète des composants choisis, qu'il s'agisse d'un nouveau téléchargement ou que vous repreniez un téléchargement interrompu.

Ainsi, si vous reprenez un téléchargement antérieur, le Gestionnaire d'installation SOLIDWORKS ne télécharge que les fichiers qui ne l'ont pas encore été. La durée de téléchargement peut alors être inférieure à la durée estimée.

Si le téléchargement d'un fichier a été complété dans le téléchargement précédent, sa taille n'est pas comprise dans cette estimation. Par conséquent, l'estimation peut être plus importante que la taille réelle du téléchargement.

Quelle méthode de téléchargement souhaitez-vous utiliser ?

Téléchargement manuel

Dans certains cas, un serveur proxy peut empêcher les chargements automatiques depuis le Gestionnaire d'installation SOLIDWORKS.

En sélectionnant cette option, vous pouvez télécharger manuellement tous les fichiers par l'intermédiaire d'une page Web puis continuer l'exécution du Gestionnaire d'installation SOLIDWORKS pour terminer les opérations d'installation. Cette page Web est personnalisée par le gestionnaire d'installation pour télécharger uniquement les fichiers nécessaires pour terminer l'installation SOLIDWORKS.

Utilisation de Téléchargement en arrière-plan de SOLIDWORKS

Vous pouvez utiliser l'option Téléchargement en arrière-plan SOLIDWORKS pour exécuter le téléchargement ou pour télécharger les futures versions de SOLIDWORKS Service Pack dès qu'elles sont disponibles.

L'option Téléchargement en arrière-plan de SOLIDWORKS peut détecter et télécharger automatiquement de nouvelles mises à jour de Service Pack en arrière-plan et vous avertir lorsque le téléchargement est terminé et que les fichiers sont prêts pour l'installation. Pour plus de détails, voir Téléchargement en arrière-plan de SOLIDWORKS.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Options de téléchargement pour les fichiers du Gestionnaire d'installation SOLIDWORKS

Vous avez choisi de télécharger une version ultérieure du Gestionnaire d'installation SOLIDWORKS. Utilisez cet écran pour spécifier où et comment elle est téléchargée.

Pour obtenir des réponses à vos questions sur le dossier de téléchargement, voir Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS.

Cet écran apparaît uniquement si le dossier de téléchargement par défaut présente un problème (par exemple, s'il n'y a pas d'accès en écriture ou d'accès au réseau). De manière générale, il vous suffit d'indiquer un répertoire de téléchargement de rechange pour continuer.

Répertoire de téléchargement

Parcourez jusqu'à la destination des fichiers du Gestionnaire d'installation SOLIDWORKS.

La taille du téléchargement et l'espace requis sont affichés. L'espace requis tient compte de l'espace supplémentaire nécessaire au dézippage de certains téléchargements et est supérieur à la taille réelle du téléchargement.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Télécharger les fichiers d'installation du produit

Spécifiez où et comment télécharger les fichiers manquants pour le produit spécifié.

Le Gestionnaire d'installation SOLIDWORKS télécharge, vérifie et extrait tous les fichiers en parallèle pendant le processus de téléchargement.

Si vous quittez cet écran, le reste de l'installation est annulé.

Pour savoir quelles sont les conséquences d'une annulation et pour des instructions sur la façon de terminer des installations interrompues, consultez Erreurs d'installation / Installation annulée.

Répertoire de téléchargement

Parcourez jusqu'à la destination des fichiers téléchargés.

La taille du téléchargement et l'espace requis sont affichés. L'espace requis tient compte de l'espace supplémentaire nécessaire pour décompresser certains téléchargements et est supérieur à la taille réelle du téléchargement.

Pour obtenir des réponses à vos questions sur le dossier de téléchargement, consultez Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Erreurs d'installation / Installation annulée
Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS


Progression du téléchargement

Le Gestionnaire d'installation SOLIDWORKS télécharge, vérifie et extrait tous les fichiers en parallèle pendant ce processus.

Pour annuler le téléchargement une fois qu'il a commencé, cliquez sur Annuler.

Si vous annulez le téléchargement ou si celui-ci échoue, l'écran Téléchargement annulé ou Problème de téléchargement indique les téléchargements incomplets et vous permet de les reprendre ou de fermer l'application.

Pour obtenir des réponses à vos questions sur le dossier de téléchargement, voir Dossier de téléchargement du Gestionnaire d'installation SOLIDWORKS.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Download Results

Indique si le téléchargement s'est bien terminé, a échoué pendant l'opération ou a été annulé.

Problème de téléchargement/Téléchargement annulé

Si vous voyez le message Problème de téléchargement, le Gestionnaire d'installation SOLIDWORKS a rencontré des problèmes qui ont empêché le succès du téléchargement.

Si vous voyez Téléchargement annulé, vous avez annulé le téléchargement avant qu'il ne soit terminé.

Pour continuer:

Réessayer/Reprendre les téléchargements automatiques | Pour reprendre le chargement automatique à partir du point où vous l'avez annulé, sélectionnez cette option et cliquez sur Réessayer ou Reprendre le téléchargement.
Télécharger les fichiers individuellement dans un navigateur Web | Dans certains cas, un serveur proxy peut empêcher les chargements automatiques depuis le Gestionnaire d'installation SOLIDWORKS. | En sélectionnant cette option, vous pouvez télécharger manuellement tous les fichiers par l'intermédiaire d'une page Web puis continuer l'exécution du Gestionnaire d'installation SOLIDWORKS pour terminer les opérations d'installation. Cette page Web est personnalisée par le gestionnaire d'installation pour télécharger uniquement les fichiers nécessaires pour terminer l'installation SOLIDWORKS.

Téléchargement terminé

L'écran Téléchargement terminé s'affiche quand le téléchargement est terminé si vous avez spécifié l'option Télécharger uniquement.

Cliquez sur Terminer pour quitter le Gestionnaire d'installation SOLIDWORKS.

N'essayez d'installer aucun de ces produits manuellement. Servez-vous toujours du Gestionnaire d'installation SOLIDWORKS pour installer les fichiers téléchargés.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Erreurs d'installation / Installation annulée

L'installation a rencontré une erreur ou a été annulée.

Si une erreur ou une annulation se produit:
  • Les produits qui ont été installés avant l'erreur ou l'annulation demeurent sur l'ordinateur.
  • Le produit en cours d'installation au moment de l'annulation est supprimé, si possible, de sorte qu'il n'y ait pas d'installations partielles.
  • Les produits restants ne sont pas installés ou désinstallés. Une liste est affichée sous Pas encore de tentative.

    Pour reprendre l'installation ou la désinstallation de ces produits, cliquez sur le lien fourni.

Le Gestionnaire d'installation SOLIDWORKS installe d'abord les composants nécessaires qui manquent, tel que .NET Framework.

Table des matières

  • Récupération d'une installation qui a échoué ou qui a été annulée

    Si une erreur ou une annulation survient pendant l'installation, vous pouvez récupérer à partir de ce point en réexécutant l'installation.

  • Réparer une installation

    Si vous rencontrez des problèmes avec un produit SOLIDWORKS installé, vous pouvez utiliser le Gestionnaire d'installation SOLIDWORKS pour réparer l'installation.

  • Contacter le revendeur SOLIDWORKS

    Si vous n'avez pas réussi à modifier ou à réparer l'installation, contactez votre revendeur SOLIDWORKS local avec les informations réunies sur cet écran. Vous devrez peut-être fournir un fichier zip contenant les fichiers journaux du Gestionnaire d'installation SOLIDWORKS.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Récupération d'une installation qui a échoué ou qui a été annulée

Si une erreur ou une annulation survient pendant l'installation, vous pouvez récupérer à partir de ce point en réexécutant l'installation.

  1. Enregistrez le message d'erreur et le code produit pour l'installation qui a échoué, comme indiqué sur l'écran Erreurs d'installation ou Installation annulée.
    Si le logiciel vous demande un fichier source et que vous n'êtes pas en train de modifier une installation SOLIDWORKS existante, il se peut que l'installation ou l'ordinateur soit corrompu. Contactez votre revendeur SOLIDWORKS.
  2. Redémarrez l'ordinateur.
  3. Pour vous assurer qu'aucun produit SOLIDWORKS n'est en cours d'exécution, appuyez sur Ctr+Alt+Del pour ouvrir le Gestionnaire des tâches de Windows.
  4. Dans l'onglet Processus, si un ou plusieurs des processus suivants apparaît sous Nom de l'image, sélectionnez-les et cliquez sur Terminer le processus.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Si l'application est déjà installée et que vous étiez en train de la modifier ou de la supprimer, essayez de réparer l'installation. Pour plus de détails, cliquez sur Réparer une installation.
  6. Dans Windows, cliquez sur Démarrer > Panneau de configuration > Programmes et fonctionnalités.
  7. Sélectionnez la version de SOLIDWORKS qui a échoué.
    S'il n'y a pas d'entrée pour la version de SOLIDWORKS que vous vouliez installer, recommencez le processus d'installation.
  8. Effectuez l'une des actions suivantes:
    • Pour réessayer, cliquez sur Modifier et sélectionnez tous les produits qui n'ont pas été installés ou ont été ignorés pendant l'installation.

    • Pour ignorer l'installation qui a échoué, cliquez sur Modifier et sélectionnez tous les produits qui ont été ignorés pendant l'installation. Désactivez le produit dont l'installation a échoué.

    • Pour abandonner l'installation, cliquez sur Supprimer et sélectionnez les produits qui ont été installés.
    Ceci ne restaure pas la version antérieure des produits que vous mettez à niveau.
Sujet parent Erreurs d'installation / Installation annulée
Réparer une installation
Contacter le revendeur SOLIDWORKS


Contacter le revendeur SOLIDWORKS

Si vous n'avez pas réussi à modifier ou à réparer l'installation, contactez votre revendeur SOLIDWORKS local avec les informations réunies sur cet écran. Vous devrez peut-être fournir un fichier zip contenant les fichiers journaux du Gestionnaire d'installation SOLIDWORKS.

  1. Localisez les fichiers journaux. Pour Windows :
    C:\Users\nomu_tilisateur\AppData\Roaming\SOLIDWORKS\Installation Logs\version_installée\.
    Si le dossier est introuvable, il se pourrait qu'il soit caché. Dans l'Explorateur de fichiers, cliquez sur Outils > Options des dossiers. Dans l'onglet Affichage, sous Paramètres avancés, sélectionnez Afficher les fichiers, dossiers et disques cachés pour Fichiers et dossiers cachés.
  2. Zippez la totalité du contenu de ce dossier, y compris les sous-dossiers.
Sujet parent Erreurs d'installation / Installation annulée
Récupération d'une installation qui a échoué ou qui a été annulée
Réparer une installation


L'installation est terminée

Le Gestionnaire d'installation SOLIDWORKS a terminé son traitement.

Une ou plusieurs des options suivantes peuvent être affichées.

Nouveautés

Dans le cas d'installations individuelles, un document décrivant les nouvelles fonctionnalités dans SOLIDWORKS et ses compléments apparaît à la fin de l'installation.

Dans le cas d'installations d'images administratives, le document apparaît sur les ordinateurs individuels une fois leur installation terminée.

Participer au Programme d'amélioration de l'expérience utilisateur de SOLIDWORKS

Des informations au sujet des performances sont envoyées à SOLIDWORKS Corporation dans le but d'améliorer le produit. Le processus est transparent et confidentiel. Sélectionnez l'une des options suivantes:
  • Oui, je souhaite participer
  • Non, merci
  • Me le rappeler ultérieurement
Pour en savoir plus, visitez le site Web du Programme d'amélioration de l'expérience utilisateur.

La création de l'image administrative est terminée

Lorsque vous terminez la création de l'image administrative, vous pouvez cliquer sur Personnaliser une image et exécuter l'Editeur d'options d'image administrative pour personnaliser l'image.

Cliquez sur Montrez-moi comment installer cette image sur un client. pour afficher des instructions sur l'utilisation de l'Editeur d'options.

Pour plus de détails sur la configuration d'une image administrative à l'aide de l'Editeur d'options, voir Editeur d'options du Gestionnaire d'images administratives.

Cliquez sur Personnaliser l'image pour démarrer l'Editeur d'options du Gestionnaire d'images administratives afin de personnaliser les paramètres d'option de cette image administrative.
Vous pouvez démarrer l'Editeur d'options en double cliquant sur sldAdminOptionEditor.exe dans le dossier SOLIDWORKS Admin.

Table des matières

  • Vérifier la disponibilité de mises à jour de SOLIDWORKS

    Si vous disposez de droits d'administrateur sur l'ordinateur, le Gestionnaire d'installation SOLIDWORKS vous permet de vérifier la disponibilité de mises à jour soit la densité et les dimensions du modèle, soit en configurant des vérifications automatiques régulières.

  • Programme d'amélioration de l'expérience utilisateur de SOLIDWORKS

    Lorsque vous installez SOLIDWORKS, vous pouvez indiquer que les informations sur la performance soient envoyées à SOLIDWORKS Corporation pour améliorer le produit.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Editeur d'options du Gestionnaire d'images administratives


Vérifier la disponibilité de mises à jour de SOLIDWORKS

Si vous disposez de droits d'administrateur sur l'ordinateur, le Gestionnaire d'installation SOLIDWORKS vous permet de vérifier la disponibilité de mises à jour soit la densité et les dimensions du modèle, soit en configurant des vérifications automatiques régulières.

  1. Démarrez le Gestionnaire d'installation SOLIDWORKS en effectuant l'une des actions suivantes :

    • Dans SOLIDWORKS, cliquez sur Aide > Vérifier la disponibilité de mises à jour.

    • Sous Windows, cliquez sur Démarrer > Programmes > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour.

    Vous pouvez également cliquer sur Démarrer > Gestionnaire d'installation SOLIDWORKS > Téléchargement en arrière-plan SOLIDWORKS. Dans la zone de notification Windows, cliquez avec le bouton droit de la souris sur Téléchargements en arrière-plan SOLIDWORKS, puis cliquez sur Vérifier la disponibilité de mises à jour.
    Le Gestionnaire d'installation SOLIDWORKS vous informe s'il y a des mises à jour disponibles.
  2. Si c'est le cas, choisissez si vous voulez les télécharger et les installer.
  3. Pour activer les vérifications automatiques, lorsque le Gestionnaire d'installation SOLIDWORKS a terminé son traitement, sélectionnez Vérifier la disponibilité de mises à jour tous les __ jours et spécifiez la fréquence.
Sujet parent L'installation est terminée
Programme d'amélioration de l'expérience utilisateur de SOLIDWORKS


Programme d'amélioration de l'expérience utilisateur de SOLIDWORKS

Lorsque vous installez SOLIDWORKS, vous pouvez indiquer que les informations sur la performance soient envoyées à SOLIDWORKS Corporation pour améliorer le produit.

SOLIDWORKS utilise ces informations pour déterminer les tendances relatives à l'utilisation et à la qualité des produits. Notre but est de fournir des produits de la plus haute qualité et les journaux de performance nous aident à atteindre ce but.

Le processus est transparent. Toutes les informations contenues dans les fichiers journaux sont traitées de façon confidentielle. Elles ne sont utilisées à aucune autre fin et personne ne vous contactera.

Pour en savoir plus, visitez le site Web du Programme d'amélioration de l'expérience utilisateur.

Sujet parent L'installation est terminée
Vérifier la disponibilité de mises à jour de SOLIDWORKS


Emplacement d'installation

Les options suivantes s'appliquent aux installations, à l'exception de la création d'images administratives :
Installer les produits sélectionnés dans | C'est l'emplacement du répertoire dans lequel vous installez SOLIDWORKS. Si vous mettez à niveau ou modifiez une installation, tous les fichiers doivent être installés vers l'emplacement existant pour cette installation. Dans ce cas, il ne vous est pas possible de changer l'emplacement de l'installation SOLIDWORKS existante.
Estimation de l'espace requis pour l'installation | Il s'agit de l'espace supplémentaire requis pour les produits à installer ou modifier. | Vérifiez que le disque sur lequel vous effectuez l'installation a suffisamment d'espace libre pour prendre en charge les composants requis.
Installer à partir de | C'est l'emplacement du répertoire depuis lequel vous installez SOLIDWORKS. Cette option s'affiche uniquement si l'option Installer uniquement est spécifiée. Pour plus de détails, voir Options de téléchargement.
Consultez votre administrateur système avant de changer un des emplacements d'installation de SOLIDWORKS.

Emplacements de l'image administrative

Quand vous créez une image administrative, les options suivantes s'appliquent :
Emplacement de la nouvelle image | C'est l'emplacement du répertoire dans lequel le Gestionnaire d'installation SOLIDWORKS créera la nouvelle image. | Cet emplacement ne peut pas contenir une image administrative existante.
Estimation de l'espace requis pour la création de l'image | Il s'agit de l'espace supplémentaire requis pour l'image administrative. | Vérifiez que le disque sur lequel vous effectuez l'installation a suffisamment d'espace libre pour prendre en charge les composants de l'image requis.
Créer une image à partir de | C'est l'emplacement du répertoire depuis lequel vous installez les produits SOLIDWORKS. Cette option s'affiche uniquement si l'option Installer uniquement est spécifiée. Pour plus de détails, voir Options de téléchargement.
Emplacement de l'image existante | Quand vous mettez à niveau une image administrative, le Gestionnaire d'installation SOLIDWORKS crée une nouvelle image sur la base des paramètres de cette image existante. L'image existante n'est pas modifiée. C'est l'emplacement de l'image d'origine que vous avez spécifié dans l'écran Bienvenue qui est affiché.

Eviter d'utiliser des chemins de répertoire spécifiques à une version

Si vous spécifiez un numéro de version à l'emplacement du répertoire d'installation (par exemple, C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2023\) et que vous mettez ensuite à niveau cette version vers SOLIDWORKS 2024 le répertoire d'installation de SOLIDWORKS 2024 sera nommé SOLIDWORKS 2023.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Options de téléchargement


Options de mise à niveau

Une ou plusieurs versions majeures antérieures de SOLIDWORKS sont installées sur cet ordinateur. Vous pouvez créer une nouvelle installation, qui coexistera avec la version antérieure, ou faire une mise à niveau, ce qui supprimera la version antérieure.

Créez une nouvelle installation de version SOLIDWORKS.

Si vous choisissez de créer une nouvelle installation, vous pouvez sélectionner les produits SOLIDWORKS à installer.

Pour chacun des produits sélectionnés, une nouvelle installation de la version majeure est créée. Les versions majeures antérieures restent sur l'ordinateur, sauf SOLIDWORKS Electrical et SOLIDWORKS PDM Client.

Si vous désélectionnez un produit, sa nouvelle version n'est pas installée.

La création d'une nouvelle installation peut être utile si vous souhaitez accéder à la version antérieure de SOLIDWORKS même après l'installation de la version plus récente. Par exemple, si vous partagez des fichiers avec d'autres utilisateurs qui utilisent toujours la version plus ancienne, vous pouvez éviter les incompatibilités de versions pour les fichiers enregistrés dans la version plus récente.

Mettre à niveau SOLIDWORKS version_majeure_antérieure vers SOLIDWORKS version_majeure_actuelle.

Si vous choisissez la mise à niveau, vous pouvez sélectionner les produits SOLIDWORKS à mettre à niveau. Pour chacun des produits sélectionnés, une nouvelle installation est créée et les anciennes versions sont supprimées.

Si vous désélectionnez un produit, sa nouvelle version n'est pas installée et la version antérieure est conservée sur l'ordinateur.

Eléments à prendre en compte concernant SOLIDWORKS Electrical et SOLIDWORKS PDM Client

Vous ne pouvez installer qu'une seule version de SOLIDWORKS Electrical sur une machine. Si vous créez une nouvelle installation de SOLIDWORKS et que vous sélectionnez SOLIDWORKS Electrical comme l'un des produits à installer, l'ancienne version de SOLIDWORKS Electrical est supprimée.

Effectuez une sauvegarde de l'environnement SOLIDWORKS Electrical existant avant d'installer une nouvelle version. Dans SOLIDWORKS Electrical Schematic, sélectionnez Fichier Archiver l'environnement. Dans SOLIDWORKS Electrical 3D, sélectionnez SOLIDWORKS Electrical > Outils > Archiver l'environnement.

La version majeure de SOLIDWORKS PDM Client doit correspondre à la version majeure de SOLIDWORKS PDM Server. Si vous ne souhaitez pas mettre à niveau SOLIDWORKS PDM Server, ne sélectionnez pas SOLIDWORKS PDM Client pour la mise à jour.

Pour supprimer un produit sous Windows, utilisez Ajout/Suppression de programmes. Pour plus de détails, voir Supprimer une installation.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Supprimer une installation


Progression de l'installation

Cette écran montre la progression de l'installation.

Pour annuler l'installation une fois qu'elle a commencé, cliquez sur Annuler.

Pour savoir quelles sont les conséquences d'une annulation et pour des instructions sur la façon de terminer des installations interrompues, consultez Erreurs d'installation.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Type d'installation

Vous pouvez spécifier l'opération d'installation que vous souhaitez exécuter. Par exemple, créer une nouvelle installation, modifier ou réparer une installation existante, créer une image administrative, installer des produits Serveur administratif ou télécharger des fichiers de façon à pouvoir les partager et les installer sur d'autres ordinateurs.

Si la version la plus récente du logiciel SOLIDWORKS est déjà installée sur votre ordinateur, les options de modification ou de réparation vous seront proposées.

Individuel

Installez les produits SOLIDWORKS sur cet ordinateur.

Cette option apparaît uniquement si cette version n'est pas installée sur cet ordinateur.

Modifier l'installation individuelle

Modifiez l'installation SOLIDWORKS individuelle existante sur cet ordinateur.

Cette option apparaît uniquement si cette version est installée sur cet ordinateur.
Les modifications comprennent:
  • Ajout ou suppression de composants de SOLIDWORKS
  • Changement de package SOLIDWORKS (par exemple, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS Ultimate et ainsi de suite)
  • Changement de paramètre de numéro de série SOLIDWORKS
    Si vous avez déjà indiqué un numéro de série au cours d'une installation précédente, le Gestionnaire d'installation SOLIDWORKS peut ne pas afficher une invite de nouveau. Pour modifier le numéro de série, vous devez sélectionner cette option.

Réparer l'installation individuelle

Réparez l'installation SOLIDWORKS existante sur cet ordinateur.

Cette option apparaît uniquement si cette version est installée sur cet ordinateur.
Réparer vérifie que tous les fichiers sont présents et correctement enregistrés et corrige les problèmes rencontrés. Les données que vous avez créées ne sont pas affectées.
  • Pour réparer un produit, assurez-vous qu'il est sélectionné.
  • Désactivez les cases à cocher des produits que vous ne voulez pas réparer.
Vous pouvez réparer une installation individuelle. Vous ne pouvez pas réparer l'installation d'une image administrative; vous devez réinstaller en utilisant l'image administrative.

Image administrative

Créez ou mettez à jour une image administrative à déployer sur plusieurs ordinateurs.

Pour des détails sur l'installation de SOLIDWORKS sur plusieurs clients en utilisant l'image administrative, voir Utilisation des images administratives.

Lorsque vous créez ou mettez à jour des images administratives:
  • Vous pouvez utiliser les paramètres d'installation d'une image existante pour configurer une nouvelle image ou une image mise à jour, ou vous pouvez utiliser les paramètres d'installation SOLIDWORKS par défaut.
  • Si vous mettez à jour une image existante:
    • Le Gestionnaire d'installation SOLIDWORKS crée une nouvelle copie de l'image, même si vous mettez à jour. L'image d'origine n'est pas modifiée.
    • Vous pouvez créer l'image mise à jour en utilisant les fichiers de l'image existante que vous mettez à jour. Il en résulte un téléchargement moins volumineux.
    Si vous ne spécifiez pas une image pour laquelle un nouveau Service Pack est disponible pour mettre à jour l'image précédente, vous ne pouvez pas profiter du chargement de taille résulte.

Produits Serveur

Les produits Serveur SOLIDWORKS comprennent SOLIDWORKS Electrical, SOLIDWORKS PDM et SolidNetWork License Manager.

Pour SOLIDWORKS Electrical et SOLIDWORKS PDM, vous pouvez choisir d'installer les outils de client et serveur sur le même ordinateur ou sur des ordinateurs différents.

Pour plus de détails sur l'installation de ces serveurs, consultez les rubriques correspondantes dans l'aide.

Télécharger et partager tous les fichiers

Téléchargez les fichiers d'installation pour les produits SOLIDWORKS sélectionnés sans les installer.

Cette option ne s'affiche pas lorsque vous effectuez l'installation à partir de DVD.
Le contenu des fichiers téléchargés est le même que celui des fichiers disponibles sur les DVD d'installation de SOLIDWORKS. La sélection de cette option télécharge la totalité des fichiers d'installation, quels que soient les fichiers déjà installés sur votre ordinateur. Vous pouvez ensuite copier les fichiers vers un périphérique portable ou un répertoire de réseau et les utiliser pour installer le logiciel SOLIDWORKS sur d'autres ordinateurs. Vous pouvez également utiliser cette méthode pour configurer un serveur à partir duquel les utilisateurs peuvent effectuer les installations.
Cette méthode diffère de la création d'une image administrative.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Utilisation des images administratives
Administrer des licences avec SolidNetWork License Manager
SOLIDWORKS Electrical


Installer et gérer plusieurs ordinateurs

Le Gestionnaire d'installation SOLIDWORKS propose les outils suivants pour l'installation et la gestion de SOLIDWORKS sur plusieurs ordinateurs.

Images administratives de SOLIDWORKS

Si vous installez SOLIDWORKS sur plusieurs ordinateurs, vous pouvez créer une image administrative, puis déployer l'application sur d'autres ordinateurs.

SOLIDWORKS PDM

SOLIDWORKS PDM est un produit de gestion de documents basé sur la même architecture client/serveur que SOLIDWORKS Enterprise PDM. Il est disponible en deux versions : Standard et Professional. SOLIDWORKS PDM utilise une base de données Microsoft SQL Server pour gérer les coffres-forts de fichiers.

SolidNetWork License Manager

Avec SolidNetwork License Manager, le nombre d'utilisateurs peut dépasser le nombre de licences en faisant "flotter" l'utilisation des licences. Lorsqu'une licence client n'est pas utilisée, elle est disponible pour un autre utilisateur SOLIDWORKS.

Vous pouvez également utiliser SolidNetWork License Manager pour distribuer les licences pour les compléments SOLIDWORKS (par exemple, FeatureWorks).

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Téléchargement manuel

Vous avez choisi de télécharger les fichiers manuellement (ou vous avez peut-être choisi de télécharger manuellement la dernière fois que vous avez exécuté le Gestionnaire d'installation SOLIDWORKS).

Cliquez sur le lien pour ouvrir une page Web générée automatiquement qui contient une liste complète des fichiers dont vous avez besoin pour terminer le téléchargement.

Vous devez télécharger dans le dossier spécifié dans la page Résumé. L'installation ne pourra commencer que lorsque tous les fichiers seront téléchargés dans ce dossier.

Après avoir terminé les téléchargements manuels, cliquez sur Suivant pour continuer.

Si vous souhaitez télécharger automatiquement, vous pouvez changer l'option en retournant à la page Résumé et en changeant les réglages Options de téléchargement.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Version plus récente disponible

Le Gestionnaire d'installation a détecté une version plus récente des produits SOLIDWORKS. Vous pouvez choisir d'installer la version contenue dans le DVD d'installation d'origine ou de télécharger et d'installer la nouvelle version.

Si vous installez à partir d'un téléchargement

Sélectionnez l'une des options suivantes :
  • Continuer l'installation de la version.

    Sélectionnez cette option pour poursuivre l'installation de la version contenue dans le téléchargement initial.

  • Télécharger et installer une nouvelle version : version.

    Sélectionnez cette option pour télécharger et installer la nouvelle version. Si plusieurs nouvelles versions sont disponibles, vous pouvez sélectionner la version à télécharger et à installer.

Si vous installez à partir d'un DVD

Sous Voulez-vous utiliser la version plus récente ?, choisissez l'une des options suivantes :
  • Non, continuer l'installation de version à partir de ce DVD. Vous pouvez ensuite procéder à la mise à jour.

    Sélectionnez cette option pour continuer l'installation avec le Gestionnaire d'installation en cours.

    Une fois l'installation terminée, vous pouvez rechercher et installer des mises à jour avec le Gestionnaire d'installation. Pour vérifier la disponibilité de mises à jour, exécutez Démarrer > Gestionnaire d'installation SOLIDWORKS > Vérifier la disponibilité de mises à jour.
    Vérifier la disponibilité de mises à jour est disponible uniquement si vous disposez de privilèges d'administration sur l'ordinateur.

    L'avantage de cette méthode est que le téléchargement est moins volumineux. Les inconvénients sont qu'il s'agit d'un processus en deux étapes et que les fichiers téléchargés sont spécifiques à la version (et ne peuvent pas être partagés par d'autres utilisateurs utilisant des versions différentes).

  • Oui, installer avec ce DVD, puis télécharger et effectuer la mise à jour en utilisant version.

    Sélectionnez cette option pour télécharger et exécuter une version ultérieure du Gestionnaire d'installation afin d'installer les produits SOLIDWORKS pour cette version.

    Si un nouveau Service Pack peu volumineux est disponible pour mettre à jour la version DVD, le Gestionnaire d'installation installe la version d'origine depuis le DVD, puis applique la mise à jour du Service Pack. Il en résulte un téléchargement moins volumineux.

    Vous pouvez parvenir au même résultat en sectionnant l'option permettant de continuer l'installation depuis le DVD et en appliquant la mise à jour plus tard.

    L'avantage de cette option est qu'il s'agit d'un processus en une seule étape.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Aucune nouvelle version disponible

Aucune version plus récente ne peut être téléchargée. Continuer à installer la version indiquée.

Pour poursuivre l'installation, cliquez sur Suivant.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Processus détectés

Le Gestionnaire d'installation SOLIDWORKS a détecté sur cet ordinateur des processus qui pourraient empêcher la réussite de l'installation.

  • Pour continuer l'installation, effectuez une des opérations suivantes:
    • Fermez ces processus (par exemple en utilisant le Gestionnaire de tâches de Microsoft Windows) puis appuyez sur Réessayer.
    • Cliquez sur Ignorer pour continuer sans fermer les processus.
  • Pour arrêter l'installation, appuyez sur la touche Annuler.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Sélection des produits

Vous pouvez spécifier les produits à installer, modifier, télécharger ou supprimer.

Dans la liste des produits :
  • La liste des produits est la liste complète des produits disponibles dans la suite spécifiée au-dessus de la liste des produits.
  • Pour visualiser l'action que vous projetez pour un composant particulier, cliquez sur le nom du composant (mais pas dans la case à cocher). L'installation projetée s'affiche dans le champ d'information situé sous l'entrée de produit dans la liste.
  • Vous pouvez cocher la case adjacente au composant du produit pour changer l'action d'installation de ce composant. (A titre d'exemple, si vous installez ou supprimez des composants, la sélection de la case à cocher indique que le composant doit être installé ou supprimé et la suppression de la sélection de la case à cocher indique que le composant ne doit ni être installé ni supprimé).
  • Si vous effectuez une modification d'installation, un astérisque (*) apparaît à gauche des composants quand vous modifiez la sélection de produits.
  • Si un composant dispose de sous-composants d'installation optionnels, une icône + est visible à côté de son nom. Pour afficher les sous-composants disponibles pour un composant, cliquez sur l'icône +.
  • Si un composant est développé de façon à afficher des sous-composants optionnels, une icône - s'affiche à côté de son nom. Pour réduire la liste des sous-composants, cliquez sur l'icône -.

Si vous appliquez un Service Pack, vous ne pouvez pas sélectionner les fonctionnalités de SOLIDWORKS (FeatureWorks, par exemple) apparaissant sous SOLIDWORKS. La raison en est que vous ne pouvez pas ajouter ou supprimer de composant avec ce type de mise à niveau.

Les actions réalisées par le Gestionnaire d'installation SOLIDWORKS sont régies par un ensemble de règles de coexistence des produits Pour plus de détails, voir Règles de coexistence des produits.

Le Gestionnaire d'installation SOLIDWORKS sélectionne ces composants de produits par défaut :
  • Si vous effectuez une mise à niveau ou une mise à niveau d'un Service Pack, le Gestionnaire d'installation SOLIDWORKS sélectionne les produits installés couramment.
  • Dans le cas contraire, le Gestionnaire d'installation SOLIDWORKS sélectionne tous les produits auxquels vous avez droit.
Pour réduire la durée de l'installation et du téléchargement, ainsi que l'espace disque requis, développez les composants de produits et désactivez la case à cocher pour les composants dont vous n'avez pas besoin.

Si le Gestionnaire d'installation SOLIDWORKS n'a pas pu vérifier les produits auxquels vous avez droit, vous pouvez cliquer sur Sélectionnez différents packages ou produits pour modifier le package de produits (par exemple, SOLIDWORKS Professional, SOLIDWORKS Premium ou SOLIDWORKS Ultimate) à installer ou à modifier. Le Gestionnaire d'installation SOLIDWORKS liste tous les produits SOLIDWORKS sur votre média d'installation qui sont compatibles avec la suite sélectionnée. Vous pouvez sélectionner tous les produits que vous avez achetés ou que vous avez le droit d'évaluer.

Recherche SOLIDWORKS

La fonction Recherche SOLIDWORKS est un puissant outil de recherche sur le texte complet de documents SOLIDWORKS. La recherche affiche un aperçu, ainsi que l'emplacement et le nom du fichier.

Après l'installation, la Recherche SOLIDWORKS indexe les documents SOLIDWORKS pour permettre des recherches plus rapides. Seuls les fichiers SOLIDWORKS sont indexés par défaut.

Langues prises en charge

Développez le produit SOLIDWORKS et le composant Langues pour voir quelles langues vous pouvez installer.

La spécification des Langues limite le nombre de langues installées pour le produit SOLIDWORKS uniquement. Les installations d'autres produits ne sont pas affectées par cette spécification. A titre d'exemple, toutes les langues sont installées pour eDrawings® et SOLIDWORKS PDM.

Espace requis

Le Gestionnaire d'installation SOLIDWORKS indique la taille totale de l'installation ou la taille totale du téléchargement au bas de la page.

  • Si vous avez sélectionné l'option Télécharger uniquement, la taille du téléchargement apparaît. La taille du téléchargement est l'espace total requis pour tous les fichiers téléchargés (sans compter l'espace additionnel requis pour décompresser les fichiers une fois le téléchargement terminé). Le chiffre indiqué est une estimation.
    Tous les fichiers nécessaires à l'installation sont inclus dans la taille totale du téléchargement. Si certains fichiers ont déjà été téléchargés dans le dossier de téléchargement actuel, ils ne seront pas à nouveau téléchargés. C'est pourquoi la taille de téléchargement réelle peut être inférieure à la taille totale indiquée. Il se peut aussi que vous n'ayez pas besoin de télécharger de fichiers.
  • Sinon, Taille de l'installation s'affiche. La taille de l'installation correspond à la différence d'utilisation de l'espace disque une fois l'installation terminée. En raison de la compression des fichiers, les chiffres indiqués ne sont que des estimations.

    Si vous procédez à une mise à niveau ou que vous supprimez une installation existante, la taille de l'installation peut être nulle.

    Le chiffre indiqué n'inclut pas l'espace requis pour télécharger ou extraire des fichiers si cela est requis pour l'installation.

    Si des téléchargements sont requis et que vous les téléchargez sur le même lecteur, il se peut que l'espace requis soit significativement supérieur à la taille de l'installation.

    Afin de réduire la durée de téléchargement ou d'installation pour les futures modifications, ne supprimez pas les fichiers téléchargés après l'installation. Les mises à jour ou correctifs suivants nécessitent généralement d'avoir accès à la totalité des derniers fichiers d'installation.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Règles de coexistence des produits


Produits à télécharger

Sélectionnez les produits SOLIDWORKS à télécharger à l'emplacement spécifié.

Les produits disponibles pour téléchargement sont déterminés par le numéro de série fourni:

  • L'action à réaliser s'affiche à droite de chaque composant.
  • Si un composant dispose de sous-composants d'installation optionnels, une icône + s'affiche adjacente au composant. Pour afficher les sous-composants disponibles pour un composant, cliquez sur l'icône +.
  • Si un composant a été développé pour afficher des sous-composants optionnels, une icône - s'affiche adjacente au composant. Pour réduire la liste des sous-composants, cliquez sur l'icône -.
  • Cochez la case à gauche de chaque composant pour sélectionner la façon dont il est géré par le Gestionnaire d'installation SOLIDWORKS.
Le Gestionnaire d'installation SOLIDWORKS télécharge tous les produits auxquels vous avez droit, à moins que vous n'en décidiez autrement. Pour réduire la durée de téléchargement et l'espace disque requis, développez la liste des produits et sélectionnez les composants dont vous n'avez pas besoin.

Si le Gestionnaire d'installation SOLIDWORKS n'a pas pu vérifier les produits auxquels vous avez droit, vous pouvez sélectionner la suite SOLIDWORKS à télécharger. Le Gestionnaire d'installation SOLIDWORKS liste tous les produits SOLIDWORKS qui sont compatibles avec la suite sélectionnée.

Si le Gestionnaire d'installation SOLIDWORKS n'a pas pu vérifier les produits auxquels vous avez droit, vous pouvez cliquer sur Sélectionnez différents packages ou produits pour modifier le package de produits (par exemple, SOLIDWORKS Professional, SOLIDWORKS Premium ou SOLIDWORKS Ultimate) à installer ou à modifier. Le Gestionnaire d'installation SOLIDWORKS liste tous les produits SOLIDWORKS sur votre média d'installation qui sont compatibles avec la suite sélectionnée. Vous pouvez sélectionner tous les produits que vous avez achetés ou que vous avez le droit d'évaluer.

Langues prises en charge

La spécification des Langues limite le nombre de langues installées pour le produit SOLIDWORKS uniquement. Les installations d'autres produits ne sont pas affectées par cette spécification. Par exemple, eDrawings® installe toutes les langues.

Espace requis

L'espace requis pour le téléchargement est indiqué en fonction des produits sélectionnés. La taille du téléchargement est l'espace total requis pour tous les fichiers téléchargés (sans compter l'espace additionnel requis pour dézipper les fichiers une fois le téléchargement terminé). Le chiffre indiqué est une estimation.

Afin de réduire la durée de téléchargement ou d'installation pour les futurs mises à jour ou correctifs, ne supprimez pas les fichiers téléchargés après l'installation. Les mises à jour ou correctifs suivants nécessitent généralement d'avoir accès à la totalité des derniers fichiers d'installation.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Produits à réparer

Lorsque vous spécifiez Réparer cette installation, cet écran affiche les produits SOLIDWORKS, avec les numéros de version, qui peuvent être réparés par cette version du Gestionnaire d'installation SOLIDWORKS.

Réparer vérifie que tous les fichiers sont présents et correctement enregistrés et corrige les problèmes rencontrés. Les données que vous avez créées ne sont pas affectées.
  • Pour réparer un produit, assurez-vous qu'il est sélectionné.
  • Désactivez les cases à cocher des produits que vous ne voulez pas réparer.

Cliquez sur Réparer pour commencer la réparation des produits sélectionnés.

Vous pouvez réparer une installation individuelle. Vous ne pouvez pas réparer l'installation d'une image administrative; vous devez la réinstaller.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Numéros de série

Les numéros de série associent votre ordinateur aux produits SOLIDWORKS que vous avez achetés.

Si des produits SOLIDWORKS sont déjà installés sur votre ordinateur, leur numéro de série s'affiche par défaut :
  • S'il ne s'affiche pas, saisissez votre numéro de série SOLIDWORKS.
  • Si vous disposez de numéros de série correspondant à des produits qui ne sont pas inclus dans votre licence SOLIDWORKS, saisissez-les dans les champs appropriés.

Si vous disposez d'une connexion Internet, les numéros de série que vous indiquez permettent de déterminer les produits auxquels vous avez droit en poursuivant l'installation.

Comme il existe différentes façons d'acheter les produits SOLIDWORKS, certains numéros de série couvrent deux produits ou plus. Ainsi, un numéro de série SOLIDWORKS peut vous permettre d'installer SOLIDWORKS Simulation sans entrer de numéro de série SOLIDWORKS Simulation séparé. De plus, certains produits ne requièrent pas de numéro de série. Si vous avez des questions au sujet de vos numéros de série, contactez votre revendeur agréé.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Installation du serveur

Les produits Serveur que vous tentez d'installer sont listés, ainsi que les résultats des installations.

Etat de l'installation du serveur

Les installations des produits Serveur sont effectuées par une application d'installation externe. Si vous n'êtes pas dans cette application, vous devez y passer pour terminer l'installation.

Cliquez sur Annuler pour arrêter les installations de produits Serveur.

Installation du serveur terminée

L'application d'installation externe a terminé ses opérations.

Cliquez sur Terminer ou Suivant.
  • Si vous installez d'autres produits administratifs (par exemple une image administrative SOLIDWORKS), cette installation se poursuit.
  • Si les installations de produits Serveur étaient les seules effectuées, le Gestionnaire d'installation SOLIDWORKS se ferme.

Installation de serveur annulée ou échouée

Si une installation de produit Serveur a échoué ou a été annulée après avoir commencé, les serveurs non installés sont listés.

Cliquez sur Fermer ou Suivant.
  • Si vous avez spécifié d'autres installations de produits administratifs, le Gestionnaire d'installation SOLIDWORKS reprendra ses opérations.
  • Si les installations de produits Serveur étaient les seules effectuées, le Gestionnaire d'installation SOLIDWORKS se ferme.

Pour plus d'informations

Pour de plus amples informations sur l'installation, la configuration et l'utilisation de SolidNetWork License Manager, voir Administrer des licences avec SolidNetWork License Manager.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Résumé

Le Gestionnaire d'installation SOLIDWORKS dispose de toutes les informations nécessaires pour terminer l'opération d'installation.

Pour continuer: | Cliquez sur le bouton Action maintenant pour lancer l'opération d'installation (par exemple, Installer maintenant, Créer maintenant, Télécharger maintenant, Modifier maintenant).
Pour changer les réglages de votre installation: | Cliquez sur MODIFIER [image] pour la section que vous souhaitez modifier (par exemple, Produits, Emplacement d'installation, Options Toolbox).
Pour annuler: | Cliquez sur Annuler pour quitter le Gestionnaire d'installation SOLIDWORKS sans modifier les composants de l'installation.
Pour retourner à une page précédente: | Cliquez sur Précédent pour retourner à une page précédente du Gestionnaire d'installation SOLIDWORKS.
Pour des informations sur un ensemble donné d'options d'installation, (par exemple, Produits, Emplacement d'installation, Options Toolbox, etc.) :
  1. Cliquez sur MODIFIER [image] en regard de la section sur laquelle vous voulez des informations.
  2. Dans la page de détails qui s'affiche, cliquez sur Aide pour obtenir des informations sur ces paramètres d'options d'installation.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Avertissements de la vérification du système

L'option de vérification du système a signalé des problèmes qui pourraient avoir un impact sur la façon dont vous continuez l'installation. Dans la plupart des cas, vous devriez pouvoir continuer l'exécution du Gestionnaire d'installation SOLIDWORKS.

Les avertissements qui peuvent survenir à ce niveau sont listés ci-dessous avec des suggestions sur la manière de procéder.

Problèmes de validation du numéro de série

Le Gestionnaire d'installation n'a pas pu vérifier la disponibilité de nouvelles versions car il n'a pas pu valider votre numéro de série. Si vous êtes connecté et que vous avez entré un numéro de série valide, il s'agit peut-être d'un problème temporaire sur notre serveur. Réessayez ultérieurement.

Validation du numéro de série: Le Gestionnaire d'installation n'a pas pu valider votre numéro de série afin de déterminer quels produits vous pouvez installer. Vous pourrez néanmoins choisir les produits à installer, mais vous ne pourrez pas télécharger de fichiers d'installation. Vous devrez fournir l'ensemble des fichiers source téléchargés ou un DVD à partir desquels réaliser l'installation.

Résolution:
  • Vérifiez la connexion Internet. La vérification du numéro de série requiert une connexion Internet valide.
  • Vérifiez que le numéro de série que vous avez saisi, est valide pour les produits que vous essayez d'installer.
  • Certaines installations requièrent un contrat de maintenance valide lors du lancement commercial de la version. Pour de plus amples informations, contactez votre revendeur SOLIDWORKS.
  • Dans la plupart des cas, vous pouvez poursuivre l'installation, sous condition que vous installiez à partir d'un DVD ou d'un ensemble de fichiers téléchargés précédemment.

Version plus récente disponible

Version plus récente disponible

Nouvelles versions disponibles

Une version plus récente de ce produit peut être téléchargée.

Résolution: Lorsque vous exécutez une vérification de disponibilité de mises à jour, il peut vous être demandé d'installer une version ultérieure disponible au téléchargement auprès de SOLIDWORKS. Vous pouvez poursuivre cette opération à l'aide de la version que vous avez indiquée initialement ou vous pouvez télécharger cette version plus récente et l'installer.

Dernière version disponible

Ceci est la dernière version disponible. Cliquez sur Suivant pour continuer.

Aucun nouveau téléchargement disponible

Résolution: Ce message peut s'afficher lorsque vous êtes en train de vérifier la disponibilité de mises à jour pendant une installation ou une modification. Il indique que vous êtes en train d'installer (ou avez installé) la dernière version disponible.

Problèmes de connexion avec Internet

Connexion Internet: Le Gestionnaire d'installation n'a pas pu se connecter au serveur SOLIDWORKS afin de déterminer quels produits vous pouvez installer. Vous pourrez néanmoins choisir les produits à installer, mais vous ne pourrez pas télécharger de fichiers d'installation. Vous devrez fournir les fichiers source sur un DVD ou les fichiers préalablement téléchargés.

Impossible de vérifier la disponibilité de nouvelles versions

Le Gestionnaire d'installation n'a pas pu vérifier la disponibilité de nouvelles versions car il n'a pas pu établir de connexion avec le serveur.

Résolution:
  • Vérifiez la connexion Internet.
  • Vous pouvez poursuivre l'installation, sous condition que vous installiez à partir d'un DVD ou d'un ensemble de fichiers téléchargés précédemment.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Options de l'Assistance pour le perçage/Toolbox

Si vous installez SOLIDWORKS Toolbox, SOLIDWORKS comprend une bibliothèque de types de perçages standard et de composants.

Pour obtenir des informations sur la configuration, l'extension et l'utilisation de SOLIDWORKS Toolbox, cliquez sur Aide dans SOLIDWORKS et reportez-vous à la section Toolbox.

Avant d'utiliser le composant SOLIDWORKS Toolbox, assurez-vous de le configurer correctement en accord avec la politique de votre société ou de votre groupe. Dans de nombreux cas, un groupe configure et assure la maintenance d'un composant Toolbox central. Contactez l'administrateur SOLIDWORKS pour qu'il vous aide à spécifier Toolbox pendant l'installation de SOLIDWORKS.

Vous pouvez modifier la configuration sélectionnée de SOLIDWORKS Toolbox après l'installation. Dans SOLIDWORKS, cliquez sur Outils > Options. Dans l'onglet Options du système, cliquez sur Assistance pour le perçage/Toolbox.

Les sections suivantes décrivent toutes les options que vous pouvez rencontrer sur cet écran pour toutes les configurations. Les options Toolbox que vous voyez dépendent des configurations préexistantes de SOLIDWORKS et de Toolbox sur cet ordinateur, ainsi que des choix que vous avez opérés dans le Gestionnaire d'installation SOLIDWORKS.

Créer une nouvelle version de Toolbox nouvelle_version

Créer une nouvelle version de SOLIDWORKS Toolbox sur cet ordinateur.

Lorsque vous créez une nouvelle version, dans l'écran de Sélection des produits, développez SOLIDWORKS > SOLIDWORKS Toolbox, et sélectionnez les normes à appliquer pour Toolbox. Toutes les normes sont sélectionnées par défaut.

Les versions de Toolbox qui existent sur cet ordinateur ne sont pas modifiées.

Référencer ou mettre à niveau une installation de Toolbox existante

Utilisez une installation Toolbox existante Cliquez sur Parcourir pour spécifier l'emplacement du Toolbox que vous voulez utiliser avec cette installation.

  • Si le composant Toolbox est configuré pour une version majeure antérieure de SOLIDWORKS, il est mis à niveau vers cette version. Toute personnalisation apportée à ce Toolbox est conservée dans l'installation de Toolbox mise à niveau.
    Si le composant Toolbox est mis à niveau vers une nouvelle version majeure de SOLIDWORKS, il devient alors incompatible avec les ordinateurs exécutant des versions majeures antérieures de SOLIDWORKS.
  • Si le composant Toolbox est configuré pour cette version de SOLIDWORKS (ce qui peut être le cas si vous spécifiez une installation réseau partagée de Toolbox qui a déjà été mise à niveau), il n'est alors pas soumis à une mise à niveau.
  • Si vous mettez à niveau Toolbox dans un environnement SOLIDWORKS PDM, des procédures additionnelles sont requises. Pour plus de détails, voir Remarques sur la configuration de SOLIDWORKS Toolbox.

Cette option apparaît dans tous les scénarios d'installation, à l'exception de la création d'une image administrative.

Mettre à niveau la version Toolbox version-antérieure

Copiez une installation de Toolbox configurée pour une version majeure antérieure vers un nouvel emplacement et mettez cette copie à niveau vers cette version.

Cette option apparaît si une version majeure antérieure de SOLIDWORKS est installée sur cet ordinateur, mais que vous avez choisi de ne pas mettre à niveau cette installation vers cette version.
L'objet de cette option est de mettre à niveau Toolbox pour une version majeure antérieure de SOLIDWORKS installée, sans perturber les utilisateurs utilisant l'ancienne version de Toolbox.

Si vous mettez à niveau Toolbox dans un environnement SOLIDWORKS PDM, des procédures additionnelles sont requises. Pour plus de détails, voir Remarques sur la configuration de SOLIDWORKS Toolbox.

Mettre à niveau la version de Toolbox version_antérieure qui est installée

Mettez à niveau cette installation de Toolbox à une version plus récente.
Si le composant Toolbox est mis à niveau vers une nouvelle version majeure de SOLIDWORKS, il devient alors incompatible avec les ordinateurs exécutant des versions majeures antérieures de SOLIDWORKS.

Cette option s'affiche si vous mettez à niveau une version majeure antérieure de SOLIDWORKS vers cette version, et qu'une installation de Toolbox configurée pour cette version antérieure est rencontrée sur l'ordinateur.

Si vous mettez à niveau Toolbox dans un environnement SOLIDWORKS PDM, des procédures additionnelles sont requises. Pour plus de détails, voir Remarques sur la configuration de SOLIDWORKS Toolbox.

Utiliser la version Toolbox version_actuelle qui est installée

Le Gestionnaire d'installation SOLIDWORKS a détecté sur cet ordinateur une installation de Toolbox configurée pour cette version majeure de SOLIDWORKS.

Si vous sélectionnez cette option, SOLIDWORKS utilisera cette version de Toolbox. Aucune mise à niveau n'est effectuée.

Cette option apparaît si une version majeure antérieure de SOLIDWORKS est installée sur cet ordinateur, mais qu'un composant Toolbox est configuré pour cette version. Cela peut se produire si une installation partagée de Toolbox est créée sur un ordinateur qui exécute toujours une version plus ancienne de SOLIDWORKS.

Spécifiez l'emplacement de Toolbox pour l'ordinateur client.

Spécifiez un emplacement de réseau ou de répertoire comme emplacement Toolbox par défaut pour les installations client effectuées à partir d'une image administrative.
Si, lorsque l'installation du client se produit, cet emplacement contient une installation de Toolbox configurée pour une version majeure antérieure de SOLIDWORKS, le Gestionnaire d'installation SOLIDWORKS met ce composant Toolbox à niveau.

Cette option apparaît lorsque vous créez une nouvelle image administrative.

Mettre à niveau ou utiliser la version de Toolbox référencée dans l'image existante pour l'ordinateur client

Utilisez l'emplacement de Toolbox spécifié dans une image administrative que vous mettez à jour.
Si, lorsque l'installation du client se produit, cet emplacement contient une installation de Toolbox configurée pour une version majeure antérieure de SOLIDWORKS, le Gestionnaire d'installation SOLIDWORKS met ce composant Toolbox à niveau.

Sélectionner un autre emplacement Toolbox pour l'ordinateur client

Spécifiez pour Toolbox un autre emplacement que celui qui est spécifié dans une image administrative existante que vous mettez à jour.
Si, lorsque l'installation du client se produit, cet emplacement contient une installation de Toolbox configurée pour une version majeure antérieure de SOLIDWORKS, le Gestionnaire d'installation SOLIDWORKS met ce composant Toolbox à niveau.

Table des matières

  • Remarques sur la configuration de SOLIDWORKS Toolbox

    SOLIDWORKS Toolbox est une fonction puissante et complexe. Cette rubrique résume certains des concepts à prendre en compte lorsque vous configurez Toolbox à l'aide du Gestionnaire d'installation SOLIDWORKS.

  • Format UNC

    Le format UNC (Convention uniforme [ou universelle] d'affectation des noms) spécifie un format de syntaxe des noms de fichiers pour décrire un emplacement de fichiers partagés.

Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS
Remarques sur la configuration de SOLIDWORKS Toolbox


Remarques sur la configuration de SOLIDWORKS Toolbox

SOLIDWORKS Toolbox est une fonction puissante et complexe. Cette rubrique résume certains des concepts à prendre en compte lorsque vous configurez Toolbox à l'aide du Gestionnaire d'installation SOLIDWORKS.

Où trouver davantage d'informations à propos de SOLIDWORKS Toolbox

Pour obtenir des informations sur la configuration, l'extension et l'utilisation de SOLIDWORKS Toolbox, cliquez sur [image] Aide dans SOLIDWORKS et reportez-vous à la section Toolbox.

Partager Toolbox

Lorsque vous installez Toolbox, vous pouvez placer les données Toolbox sur l'ordinateur local ou dans un emplacement réseau partagé. Il est recommandé de stocker les données Toolbox dans un emplacement réseau. En utilisant un emplacement commun, tous les utilisateurs de SOLIDWORKS partagent un ensemble d'informations parfaitement cohérent.

Si c'est votre première installation, parcourez jusqu'à l'emplacement partagé où vous souhaitez installer Toolbox.

Mise à niveau d'une version existante de Toolbox

Si Toolbox est mise à niveau vers une nouvelle version majeure de SOLIDWORKS, elle devient alors incompatible avec les ordinateurs exécutant des versions majeures antérieures de SOLIDWORKS.

Si d'autres ordinateurs en restent à cette version majeure antérieure et continuent à requérir que Toolbox soit configuré pour cette version, faites une copie de cette version de Toolbox et mettez-la à niveau. La nouvelle installation de SOLIDWORKS met à niveau la copie de Toolbox, tandis que les installations antérieures de SOLIDWORKS continuent d'utiliser l'ancienne version de Toolbox.

Configuration de l'accès à Toolbox

Après l'installation, lorsque vous accédez aux composants Toolbox, SOLIDWORKS la configuration de Toolbox et émet des suggestions pour en améliorer l'accès et les performances.

Pour accéder à Toolbox quand il est partagé en réseau (utilisation recommandée), servez-vous d'un chemin UNC au serveur sur lequel la version partagée de Toolbox est installée. Pour plus de détails, voir Format UNC.

Un administrateur peut créer un mot de passe pour Toolbox et définir les permissions et préférences pour le groupe de travail. La restriction de l'accès à la configuration et la définition des préférences communes garantit la cohérence des données Toolbox.

Mise à niveau de Toolbox dans un environnement SOLIDWORKS PDM

Quand vous mettez à niveau le logiciel SOLIDWORKS, Toolbox est mis à niveau si des pièces ont été ajoutées. Si le dossier racine de Toolbox est dans un coffre-fort SOLIDWORKS PDM, vous devez préparer le dossier Toolbox avant de lancer la mise à niveau de SOLIDWORKS.

Sur le premier système sur lequel vous allez effectuer la mise à niveau, vous devez utiliser Obtenir la dernière version pour télécharger les fichiers Toolbox vers le cache local et extraire le fichier de base de données Toolbox. Sur les autres systèmes mis à jour, il suffit de télécharger les fichiers Toolbox.

Avant de mettre à niveau :
  • Assurez-vous qu'une sauvegarde complète de la base de données et des archives du coffre-fort a été effectuée.
  • Assurez-vous que les pièces Toolbox ne sont pas extraites ou en cours d'utilisation par tout assemblage actuellement extrait.

Pour mettre Toolbox à niveau:

  1. Dans l'Explorateur de fichiers, connectez-vous au coffre-fort en tant qu'utilisateur avec toutes les autorisations (extraction, archivage, ajout, suppression).
  2. Cliquez à l'aide du bouton droit de la souris sur le dossier Toolbox et cliquez sur Obtenir la dernière version pour copier tous les fichiers Toolbox et la base de données Toolbox dans votre cache local.
    Si votre serveur d'archives est distant, ceci peut prendre plusieurs minutes.
  3. Extrayez le fichier de base de données Toolbox (SWBrowser.mdb) ou (swbrowser.sldedb) de \Toolbox_folder_name\lang\your_lang.
  4. Exécutez le Gestionnaire d'installation SOLIDWORKS pour effectuer la mise à niveau.
  5. Sur l'écran Résumé, assurez-vous que l'emplacement d'installation sous Options Toolbox est celui du coffre-fort.

    Si ce n'est pas le cas, cliquez sur Modifier, sélectionnez Référencer ou mettre à niveau une installation de Toolbox existante et naviguez jusqu'à l'emplacement de Toolbox dans le coffre-fort.

  6. Une fois la mise à niveau terminée, dans l'Explorateur de fichiers, archivez le dossier Toolbox pour ajouter les nouveaux fichiers ou ceux qui ont été mis à jour dans le coffre-fort afin que d'autres utilisateurs puissent travailler avec Toolbox.
  7. Pour les mises à niveau, accédez à votre dossier Toolbox dans le coffre-fort et assurez-vous que les éléments suivants sont présents :
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      Si ce n'est pas le cas, contactez votre revendeur.

  8. Mettez à jour le reste des ordinateurs qui utilisent l'intégration de SOLIDWORKS PDM avec Toolbox :
    1. Dans l'Explorateur de fichiers, connectez-vous au coffre-fort en tant qu'utilisateur avec au moins les autorisations de lecture pour le dossier Toolbox.
    2. Cliquez à l'aide du bouton droit de la souris sur le dossier Toolbox et cliquez sur Obtenir la dernière version pour copier les fichiers Toolbox dans votre cache local.
    3. Exécutez le Gestionnaire d'installation SOLIDWORKS pour effectuer la mise à niveau.

      Le programme d'installation détecte que Toolbox a déjà été mis à niveau.

Pour plus de détails sur la configuration de Toolbox dans SOLIDWORKS PDM, voir Configuration de Toolbox dans l'aide de l'Outil d'administration SOLIDWORKS PDM.

Sujet parent Options de l'Assistance pour le perçage/Toolbox
Format UNC


Format UNC

Le format UNC (Convention uniforme [ou universelle] d'affectation des noms) spécifie un format de syntaxe des noms de fichiers pour décrire un emplacement de fichiers partagés.

\\serveur\<volume\<chemin

Par exemple:

\\Disk_Server\SOLIDWORKS\AdminImage

Sujet parent Options de l'Assistance pour le perçage/Toolbox
Remarques sur la configuration de SOLIDWORKS Toolbox


Désinstaller des produits

Lorsque vous sélectionnez Supprimer ou Désinstaller des programmes dans le Panneau de configuration, cet écran affiche les produits SOLIDWORKS (avec les numéros de version), qui peuvent être désinstallés par cette version du Gestionnaire d'installation SOLIDWORKS. Choisissez une désinstallation standard, personnalisée ou complète.

La désinstallation standard supprime les fichiers et dossiers du programme d'un produit SOLIDWORKS. Par défaut, tous les produits SOLIDWORKS de la version sélectionnée sont spécifiés pour une désinstallation standard.

Une désinstallation personnalisée supprime un ou plusieurs éléments parmi les suivants: Fichiers et dossiers du programme, clés de registre et dossiers de données, tels que SOLIDWORKS Toolbox et les fichiers et dossiers de l'emplacement de téléchargement d'origine.

Une désinstallation complète supprime les répertoires d'installation, les clés de registre et les dossiers de données.

Pour désinstaller un produit:
  1. Sur l'écran Désinstaller, assurez-vous que le produit est sélectionné.

    Si vous désinstallez tous les produits, le Gestionnaire d'installation SolidWorks est désinstallé aussi.

  2. Désélectionnez les produits que vous ne voulez pas supprimer.

    Si vous gardez un produit, le Gestionnaire d'installation SOLIDWORKS n'est pas supprimé.

  3. Choisissez une désinstallation complète ou personnalisée.
    1. Cliquez sur Modifier dans Options avancées.

      L'écran Options avancées apparaît. L'option Fichiers et dossiers programme est cochée.

    2. Sélectionnez une option ou plus pour une désinstallation personnalisée ou toutes les options pour une désinstallation complète.
    3. Cliquez sur Retour au résumé.
    4. Sur l'écran Résumé, développez Options avancées pour afficher la méthode de désinstallation et les entrées.
  4. Cliquez sur Supprimer des éléments.
Lorsque vous cliquez sur Supprimer des éléments, le Gestionnaire d'installation SOLIDWORKS commence à supprimer les produits immédiatement.
Sujet parent Aide pour l'application Gestionnaire d'installation SOLIDWORKS


Installation

SOLIDWORKS Connected fournit un accès à l'ensemble des services et applications 3DEXPERIENCE que vous êtes autorisé à utiliser en fonction de votre rôle.

Licensing

3DEXPERIENCE Platform utilise des licences d'utilisateurs nommés. Une licence est attribuée lorsqu'un administrateur vous octroie un rôle. Un rôle détermine les services et applications 3DEXPERIENCE que vous êtes autorisé à utiliser. Vous pouvez utiliser votre licence sur n'importe quel appareil. La licence n'est associée à aucun ordinateur spécifique.

Pour plus d'informations, voir Fonctions de base des licences DS.

Programme d'installation 3DEXPERIENCE

Lorsque vous installez SOLIDWORKS Connected pour la première fois, 3DEXPERIENCE Platform vous invite à télécharger et installer le programme d'installation 3DEXPERIENCE. Ce programme d'installation est un service en arrière-plan qui aide les applications natives (comme SOLIDWORKS Connected) à accéder à la plate-forme. L'icône du programme d'installation [image] apparaît dans la barre d'état système de Windows.

Pour plus d'informations, voir 3DEXPERIENCE Launcher. Vous avez besoin des informations d'identification 3DEXPERIENCE pour pouvoir accéder à l'Assistance utilisateur Dassault Systèmes.


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost est une app qui vous permet de distribuer le rendu depuis un ordinateur exécutant SOLIDWORKS Visualize Professional vers un ou plusieurs ordinateurs en réseau.

Vous pouvez effectuer d'autres tâches sur votre ordinateur pendant l'exécution du rendu en arrière-plan, et les images finales rendues sont disponibles plus tôt. Les images peuvent être rendues sur un seul ordinateur ou sur un groupe de plusieurs ordinateurs exécutant Visualize Boost.

Chaque abonnement actif à SOLIDWORKS Visualize Professional inclut une licence gratuite de SOLIDWORKS Visualize Boost.

Le gain de performances, tel qu'un rendu plus rapide, dépend de la puissance des ordinateurs exécutant Visualize Boost. Les ordinateurs équipés de processeurs graphiques performants offrent de meilleures améliorations.


Mettre à niveau de la gestion des licences individuelles vers la gestion SolidNetWork

Vous pouvez mettre un ordinateur à niveau de la gestion des licences individuelles SOLIDWORKS vers la gestion SolidNetWork en spécifiant le numéro de série de la licence SolidNetWork dans le Gestionnaire d'installation SOLIDWORKS.

Si SOLIDWORKS n'est pas installé sur un ordinateur, vous pouvez spécifier la gestion des licences SolidNetWork en entrant le numéro de série SolidNetWork lorsque vous faites l'installation avec le Gestionnaire d'installation SOLIDWORKS.

Si SOLIDWORKS est déjà installé sur un ordinateur et que vous passez de la gestion des licences individuelles à la gestion des licences SolidNetWork, vous pouvez modifier l'installation pour l'ordinateur client et spécifier le numéro de série de la licence SolidNetWork à la place du numéro de série individuel lorsque vous exécutez le Gestionnaire d'installation SOLIDWORKS. Pour plus de détails, voir Modifier une installation.
Si vous avez installé SOLIDWORKS à partir d'une image administrative, l'option Modifier n'est pas disponible. Modifiez l'image administrative à l'aide de l'Editeur d'options du Gestionnaire d'images administratives, désinstallez le client et réexécutez l'installation.


Utilisation de Visualize Boost

Pour activer le rendu distribué, vous devez connecter SOLIDWORKS Visualize à Visualize Boost après l'avoir configuré.

Pour établir une connexion avec Boost, vous devez spécifier les valeurs Adresse IP du coordinateur et Port Boost dans SOLIDWORKS Visualize.

Maintenez Visualize Boost et SOLIDWORKS Visualize ouverts pour effectuer les étapes suivantes.

Pour connecter SOLIDWORKS Visualize à Visualize Boost :

  1. Ouvrez Visualize Boost en double-cliquant sur le raccourci du bureau [image].
  2. Dans Visualize Boost, double-cliquez sur l'adresse IP du coordinateur pour la copier dans le Presse-papiers.
  3. Dans SOLIDWORKS Visualize, cliquez sur Outils > Options > Boost, puis appuyez sur CTRL+V pour coller l'adresse IP du coordinateur.
  4. Répétez les étapes 2 et 3 pour copier le numéro de port Boost de Visualize Boost dans SOLIDWORKS Visualize.
    Le numéro de port Boost spécifié dans Visualize Boost doit correspondre à celui indiqué dans SOLIDWORKS Visualize Boost.
    La commande Etat de Boost s'affiche dans SOLIDWORKS Visualize.
  5. Cliquez sur OK pour fermer la boîte de dialogue Options.
  6. Pour vous connecter à Boost, cliquez sur la commande Etat de Boost [image] ou déconnectez [image] dans les interfaces suivantes :
    • Affichage de type visée haute
    • Page Qualité de l'Assistant de rendu
    • Outils Options onglet Boost

Pour plus d'informations sur la configuration de Boost, voir SOLIDWORKS Visualize Boost.


Initialisation d'un nouveau serveur de licences SolidNetWork

Pour initialiser un nouveau serveur de licences SolidNetWork :

  1. Après avoir installé et ouvert SolidNetWork License Manager Server, cliquez sur Oui lorsqu'un message vous invite à l'activer.
  2. Dans la boîte de dialogue Informations du Serveur de licences SolidNetWork, vérifiez le pare-feu et les ports, puis cliquez sur Suivant.
  3. Dans l'assistant Activation de produit, sélectionnez les numéros de série à activer, puis l'option Manuellement par courrier électronique comme méthode d'activation et saisissez les informations de contact par courrier électronique.

    Avec la méthode manuelle, vous devez créer un fichier de demande que vous envoyez ensuite par e-mail à l'adresse activation@solidworks.com. Lorsque vous recevez l'e-mail contenant le fichier de réponse qui inclut la licence, extrayez le fichier et cliquez sur Ouvrir afin de le charger sur le serveur.

    Vous pouvez fermer et réexécuter l'assistant Activation de produit pour ouvrir et charger le fichier de réponse.

  4. Lorsqu'un message vous informe du bon déroulement de l'initialisation, cliquez sur OK, puis, dans l'assistant Activation de produit, cliquez sur Terminer.


Activation manuelle d'une nouvelle installation SolidNetWork License Manager Server

Après avoir initialisé SolidNetWork License Manager Server, ouvrez le serveur et créez une deuxième demande pour terminer l'activation.

Pour activer manuellement une nouvelle installation SolidNetWork License Manager Server :

  1. Effectuez l'une des opérations suivantes:
    • Si vous êtes invité à activer la licence, cliquez sur Oui.
    • Si aucune invite ne s'affiche, cliquez sur Modifier sous l'onglet Administration du serveur.
    Par défaut, les options avancées sont définies sur le mode Activation.
  2. Vérifiez le pare-feu et les ports dans la boîte de dialogue Informations du Serveur de licences SolidNetWork, puis cliquez sur Suivant.
  3. Dans l'assistant Activation de produit, sélectionnez les numéros de série à activer, saisissez l'adresse e-mail dans la zone Courriel sous Coordonnées, puis sélectionnez Manuellement par courrier électronique comme méthode d'activation.
  4. Créez un fichier de demande en suivant les étapes, puis envoyez-le à activation@solidworks.com. Lorsque vous recevez le fichier de réponse de licence, cliquez sur Ouvrir pour charger le fichier.
  5. Cliquez sur Terminer une fois l'activation terminée.


Activation manuelle d'une mise à niveau de SolidNetWork License Manager Server

Après avoir mis à niveau votre installation SolidNetWork License Manager Server à l'aide du Gestionnaire d'installation SOLIDWORKS, ouvrez le logiciel serveur.

Pour activer manuellement une mise à niveau de SolidNetWork License Manager Server :

  1. Sous l'onglet Administration du serveur, sous Informations sur la licence, cliquez sur Réactiver.
    Si vous avez désactivé les licences avant de désinstaller et de mettre à niveau SolidNetWork License Manager Server, cliquez plutôt sur Modifier sous l'onglet Administration du serveur. L'option Réactiver n'est disponible que si des licences sont activées sur le serveur.

    Passez à l'étape 3.

  2. Dans la boîte de dialogue Réactiver, sélectionnez les numéros de série installés pour afficher les licences associées, puis cliquez sur Réactiver.
  3. Vérifiez le pare-feu et les ports dans la boîte de dialogue Informations du Serveur de licences SolidNetWork, puis cliquez sur Suivant.
  4. Dans l'assistant Activation de produit, sélectionnez les numéros de série à activer, saisissez l'adresse e-mail dans la zone Courriel sous Coordonnées, puis sélectionnez Manuellement par courrier électronique comme méthode d'activation.
    L'activation manuelle est un processus simple. Les instructions de l'assistant d'activation du produit vous guideront tout au long de la procédure.
  5. Cliquez sur Terminer une fois l'activation terminée.