SOLIDWORKS 安裝及系統管理

本指南說明 SOLIDWORKS 產品的單機安裝與多個安裝的安裝、使用許可、升級與管理。

單機安裝 | 部署多個安裝
安裝 在一台或多台電腦上的安裝。 | 安裝 產生可部署至數台客戶端電腦的管理安裝點。
使用許可 機器的啟動或網路授權使用許可。 | 使用許可 機器的啟動或網路授權使用許可。
升級 將單機的電腦移動到新的版本。 | 升級 更新用於安裝在電腦上的管理安裝點，將多個電腦移動到新的版本。
管理 修改、修復及移除安裝，升級至新版本。 | 管理 升級管理安裝點與客戶端，以及網路使用許可管理。

SOLIDWORKS 安裝管理員可以讓您進行 SOLIDWORKS 產品元件的設定，包括 SOLIDWORKS、SOLIDWORKS Toolbox、SOLIDWORKS Electrical、SOLIDWORKS Manage、SOLIDWORKS PDM、SOLIDWORKS Visualize，以及 SOLIDWORKS SolidNetWork License Manager。

SolidNetWork License Manager 可透過在網路上散佈使用許可給客戶端，以支援多個使用許可客戶端。 透過浮動使用許可，可允許使用者的數目超過使用許可的數目。

目錄

  • 單機安裝或管理安裝點

    您應該在每部電腦上個別安裝 SOLIDWORKS 產品，還是應該產生一個管理安裝點，然後透過一個命令在所有客戶端上部署安裝呢？

  • 檢查系統及軟體需求

    安裝前，確認您的系統符合硬體、作業系統及 Microsoft 產品需求。 SOLIDWORKS Electrical、SOLIDWORKS Visualize 及 eDrawings 等附加程式有額外的需求。

  • 下載安裝媒體

    「SOLIDWORKS 下載」頁面提供所有安裝媒體。

  • 安裝 3DEXPERIENCE 應用程式

    如果您使用 3DEXPERIENCE Platform 管理資料，可以選購適用於 SOLIDWORKS 的 Collaborative Designer 角色，將您的桌面環境連接至此平台。


單機安裝或管理安裝點

您應該在每部電腦上個別安裝 SOLIDWORKS 產品，還是應該產生一個管理安裝點，然後透過一個命令在所有客戶端上部署安裝呢？

如果您僅安裝一台電腦，或如果您管理的是數十台或數百台電腦，應做何種選擇是相當明顯的。對介於兩者之間的情況，請考慮下列的比較。

單機安裝 | 管理安裝點
使用者可以自行管理自己的 SOLIDWORKS。 | 系統管理員可以使用選項編輯器來自訂多機安裝，指定如產生新安裝或升級現有安裝、以管理員使用者的身分執行安裝、在安裝之前或之後執行外部命令、或指定不同的產品群組等安裝選項。
執行安裝的個人必須實際上可存取電腦。 | 客戶端電腦可處在遠方，只要可從相同的網路存取它們。
您可以在不同的電腦上以獨立的設定安裝不同的版本、service pack 或產品。 | 使用選項編輯器，管理安裝點可以在多機安裝間維持在版本、service pack、產品及設定間的一致性。
電腦必須有網路或電子郵件的存取權。 需要網路或電子郵件連線來啟動 SOLIDWORKS 以及下載檔案。 在收集來自網路使用許可伺服器的使用許可時，也需要存取網路。 | 需要有本機的網路連線來部署應用程式；在客戶端電腦上不需要媒體磁碟機。 客戶端可自動更新。 所有從相同管理安裝點部署的客戶端是在相同的 service pack 上。 要維持多個版本，您可以產生多個管理安裝點。 使用許可的啟動可以是自動的。 管理安裝點在伺服器上需要有額外的磁碟空間；客戶端需要有與單機安裝相同的空間。
上層主題 SOLIDWORKS 安裝及系統管理
檢查系統及軟體需求
下載安裝媒體
安裝 3DEXPERIENCE 應用程式


檢查系統及軟體需求

安裝前，確認您的系統符合硬體、作業系統及 Microsoft 產品需求。 SOLIDWORKS Electrical、SOLIDWORKS Visualize 及 eDrawings 等附加程式有額外的需求。

要確保安裝的成功及獲得最佳的效能，請參考系統需求。

上層主題 SOLIDWORKS 安裝及系統管理
單機安裝或管理安裝點
下載安裝媒體
安裝 3DEXPERIENCE 應用程式


下載安裝媒體

「SOLIDWORKS 下載」頁面提供所有安裝媒體。

若您無法存取「SOLIDWORKS 下載」頁面，請聯絡您的 Value Added Reseller 來取得 DVD。

要下載安裝媒體：

  1. 使用您的電子郵件及密碼，或您的 SOLIDWORKS 序號，以訂閱服務客戶身分登入 SOLIDWORKS 下載頁面。
  2. 於「下載」頁面的選擇版本中，選擇年。
  3. 選擇 SOLIDWORKS 標籤，找到 SOLIDWORKS 產品。
  4. 在「產品」區域，選擇一個 Service Pack。
    最新主要版本請選擇「SOLIDWORKS 產品版本 0.0」。
  5. 按一下接受合約並繼續以接受使用許可協議書的條款。
  6. 按一下 Download。
    您的 Web 瀏覽器會將 SolidworksSetup.exe 下載至預設位置 C:\Users\Username\Downloads。
  7. 將 SolidworksSetup.exe 解壓縮至 Downloads 資料夾。
    您也可以將 SolidworksSetup.exe 解壓縮至偏好位置。
  8. 以管理權限執行 setup.exe。
  9. 按一下安裝管理員中的下載並共用所有檔案。
    只需下載一次，即可在多部機器上建立單機安裝或管理安裝點，然後依照提示完成程序。

    安裝管理員為您下載安裝媒體。

    此選項在下列清況中相當有用：
    • 在少數機器上安裝軟體
    • 使用可攜式磁碟機或網路磁碟機下載
    • 安裝 Service Pack
    要選擇下載特定的安裝檔案，請按照提示選擇手動下載方法。
上層主題 SOLIDWORKS 安裝及系統管理
單機安裝或管理安裝點
檢查系統及軟體需求
安裝 3DEXPERIENCE 應用程式


安裝 3DEXPERIENCE 應用程式

如果您使用 3DEXPERIENCE Platform 管理資料，可以選購適用於 SOLIDWORKS 的 Collaborative Designer 角色，將您的桌面環境連接至此平台。

此角色提供對 3DEXPERIENCE 應用程式的存取權，這些應用程式可讓 SOLIDWORKS 桌上型電腦產品儲存、搜尋及管理儲存在平台上的資料。您也可以使用 Web 式 SOLIDWORKS Connected 應用程式。如需詳細資訊，請參閱安裝。

您必須從 3DEXPERIENCE Platform，而非 SOLIDWORKS 安裝管理員來執行安裝和授權這些應用程式。如需安裝說明，請參閱 SOLIDWORKS 說明中的使用 3DEXPERIENCE Platform 和 3DEXPERIENCE 應用程式 > 安裝 3DEXPERIENCE 應用程式。

上層主題 SOLIDWORKS 安裝及系統管理
單機安裝或管理安裝點
檢查系統及軟體需求
下載安裝媒體
https://help.solidworks.com


單機安裝

目錄

  • 在個別電腦上安裝

    若要將 SOLIDWORKS 安裝在個別電腦上，您有幾種安裝方法可以使用。

  • 單機安裝的管理

    一般而言，單機安裝的管理包括修改、修復、移除與升級安裝。


在個別電腦上安裝

若要將 SOLIDWORKS 安裝在個別電腦上，您有幾種安裝方法可以使用。

SOLIDWORKS 安裝管理員會執行安裝，並根據您購買的產品執行適當的安裝。 在您開始安裝前：

  • 如果您要安裝獨立式 SOLIDWORKS，請準備好您的 SOLIDWORKS 序號。
  • 請確認您的 Internet 可正常的連線。 檢查權益中需要使用連線。
  • 產生 3DEXPERIENCE ID。如需有關產生 3DEXPERIENCE ID 的詳細資料，請參閱 https://www.3ds.com/support。
  • 確認您是帳戶的指定管理員，或者您的管理員已將您列為聯絡人。

SOLIDWORKS 安裝管理員安裝不同的 Microsoft 元件，包括 Microsoft Visual Studio Tools for Applications、Visual Basic 和 .NET Framework。如果電腦中並未安裝所有 Windows 必要元件的正確版本，SOLIDWORKS 安裝管理員會在安裝 SOLIDWORKS 產品前自動安裝這些元件。

SOLIDWORKS Chromium Embedded Framework (CEF) 為 SOLIDWORKS 安裝管理員所安裝的另一個元件。其目的在於顯示 SOLIDWORKS 應用程式和 3DEXPERIENCE Platform 的內容。

SOLIDWORKS Login Manager 也由 SOLIDWORKS 安裝管理員安裝。它允許登入 3DEXPERIENCE Marketplace 和 3DEXPERIENCE 應用程式。

安裝方法 程序摘要
從「SOLIDWORKS 下載」頁面下載

「SOLIDWORKS 下載」頁面提供所有安裝媒體。

  1. 瀏覽 SOLIDWORKS 下載 頁面。
  2. 使用您的 3DEXPERIENCE ID 登入。
  3. 於「下載」頁面的選擇版本中，選擇年。
  4. 按一下 SOLIDWORKS 產品的 SOLIDWORKS 標籤，並在產品下選擇 Service Pack。
  5. 按一下接受合約並繼續以接受使用許可協議書的條款。
  6. 按一下 Download。
您必須有正常運作的網際網路連線，並且能夠登入存取下載頁面。

若您無法存取下載頁面，請聯絡您的 Value Added Reseller 來取得安裝媒體。
使用伺服器上的下載目錄 在下載目錄中，連按兩下 setup.exe。

安裝 SOLIDWORKS 產品的電腦必須能夠存取下載目錄，而下載目錄必須包含所有 SOLIDWORKS 安裝檔案，如此安裝才能開始。如果您可以存取網際網路，並且對下載目錄擁有寫入權限，SOLIDWORKS 安裝管理員可以幫助您尋找遺失的檔案。
使用檢查更新更新現有的 SOLIDWORKS 安裝 執行下列之一：
  • 在 SOLIDWORKS 中，按一下 [image] > 檢查更新。
  • 在 Windows 中，按一下開始 > SOLIDWORKS 安裝管理員 > 檢查更新。
您也可以按一下開始 > SOLIDWORKS 安裝管理員 > SOLIDWORKS 背景下載程式。在 Windows 通知區域中，以滑鼠右鍵按一下 SOLIDWORKS 背景下載程式，然後按一下檢查更新。
您必須有正常運作的網際網路連線，並在機器上擁有管理員權限。

在 SOLIDWORKS 安裝管理員中，您也可以選擇下載並共用所有檔案的選項，包括必要的軟體。 當您在數個機器上安裝軟體，而且想要使用可攜式磁碟機或網路磁碟機來複製和下載時，這個選項很實用。 對於安裝 Service Pack 也很有幫助，因為完整版本和 Service pack 包含在一次安裝當中。

安裝完成時，啟動 SOLIDWORKS 應用程式並啟動使用許可。

若要顯示安裝在機器上的產品清單，請從 SOLIDWORKS 主功能表 -
  • 按一下 [image] > 我的產品
  • 按一下工作窗格的首頁，SOLIDWORKS 資源 > 我的產品
  • 按一下開始 > SOLIDWORKS 工具 版本 > 我的產品。

對話方塊中的核取記號表示您或您的組織擁有的產品 (根據您的啟動及網路使用許可)。您也可以按一下各個產品類別最上方的連結來進一步瞭解 SOLIDWORKS 產品。

如果您有 SOLIDWORKS 使用許可，若要查看哪些使用許可為使用中，請在 Windows 中按一下開始 > SOLIDWORKS 工具 <版本> > SolidNetWork License Manager Client > 使用許可的使用標籤。

上層主題 單機安裝
單機安裝的管理


單機安裝的管理

一般而言，單機安裝的管理包括修改、修復、移除與升級安裝。

目錄

  • 修改安裝

    在之前的安裝是以完整的安裝檔案集完成安裝的前提下，您可以修改安裝來安裝尚未安裝的產品或移除產品。 如果您使用 Service Pack 將之前的安裝升級，這個選項將無法使用。

  • 修復安裝

    如果您安裝的 SOLIDWORKS 產品有問題，您可以使用 SOLIDWORKS 安裝管理員來修復安裝。

  • 將單機安裝回溯至之前的 Service Pack

  • 移除安裝

    您可以移除在個別電腦或是在客戶端/伺服端環境中的安裝。

  • 升級至新版本

    有幾種方法可以將單機安裝升級為新的 SOLIDWORKS 版本。

  • 產品共存規則

    這些產品共存規則決定新產品的安裝方式以及現有產品的升級方式。

上層主題 單機安裝
在個別電腦上安裝


修改安裝

在之前的安裝是以完整的安裝檔案集完成安裝的前提下，您可以修改安裝來安裝尚未安裝的產品或移除產品。 如果您使用 Service Pack 將之前的安裝升級，這個選項將無法使用。

如果您安裝 SOLIDWORKS 並在之後購買附加程式，您可以修改安裝以包括新的附加程式。 您必須在個別的機器上安裝附加程式。

  1. 請確定沒有使用中的 SOLIDWORKS 工作階段。
  2. 在 Windows 中，選擇設定 > 應用程式 > 已安裝的應用程式。
  3. 選擇要修改的 SOLIDWORKS 安裝，然後按一下變更。
  4. 在歡迎使用 SOLIDWORKS 安裝管理員畫面上，按一下修改安裝。
  5. 在序號螢幕中，確認已指定正確的序號。
  6. 在產品選擇螢幕中，選擇要安裝或移除的產品。
    修改安裝時：
    • 根據預設，即使您指定了新的序號，仍然不會安裝或移除任何產品。您必須變更每個產品或功能元件的安裝動作。
    • 若要檢視對特定元件的動作，請按一下元件名稱（但不是核取方塊）。預定安裝動作會出現在產品清單下方的資訊欄位中。
    • 您可以按一下產品元件旁邊的核取方塊以變更該元件的安裝目錄。（例如，如果您要安裝或移除元件，選擇核取方塊則指定安裝或移除元件，清除核取方塊則指定不安裝或移除元件。）
    • 當您從初始規格變更元件安裝動作時，在清單中該元件的旁邊會出現一個星號 (*)。
    • 如果零組件具有可選用的安裝子零組件，零組件旁會顯示 [image] 圖示。若要查看零組件有哪些子零組件可用，請按一下 [image] 圖示。
    • 如果零組件已經展開，顯示可選用的子零組件，則零組件旁會出現 [image] 圖示。若要摺疊子零組件清單，請按一下 [image] 圖示。
  7. 在摘要螢幕中，按一下現在修改。
  8. 在安裝完成螢幕中，按一下完成。
上層主題 單機安裝的管理
修復安裝
將單機安裝回溯至之前的 Service Pack
移除安裝
升級至新版本
產品共存規則


修復安裝

如果您安裝的 SOLIDWORKS 產品有問題，您可以使用 SOLIDWORKS 安裝管理員來修復安裝。

若要修復安裝，您的電腦必須備有之前安裝的所有來源檔案及任何已套用的 Service Pack。這些必須位於您最初安裝的位置。

您可以修復一個單機安裝。您無法修復一個管理安裝點；您必須解除管理安裝點的安裝然後再次安裝。
  1. 開啟 Windows 控制台，然後按一下程式 > 程式和功能。
  2. 用右鍵按一下您想要修復的 SOLIDWORKS 版本，然後按一下變更。
  3. 在歡迎使用 SOLIDWORKS 安裝管理員畫面上，按一下修復您的安裝，然後按一下下一步。
  4. 在要修復的產品 螢幕中，選擇要修復的產品。
  5. 清除在螢幕上的其餘產品。
  6. 按一下修復。
上層主題 單機安裝的管理
上層主題 安裝錯誤/安裝取消
修改安裝
將單機安裝回溯至之前的 Service Pack
移除安裝
升級至新版本
產品共存規則
復原失敗或取消的安裝
聯絡 SOLIDWORKS 經銷商


將單機安裝回溯至之前的 Service Pack

若要將單機安裝回溯至目前主要版本系統中的前一個 service pack 版本，請解除安裝目前安裝在電腦中的 service pack 版本，然後重新安裝先前的版本。
上層主題 單機安裝的管理
修改安裝
修復安裝
移除安裝
升級至新版本
產品共存規則


移除安裝

您可以移除在個別電腦或是在客戶端/伺服端環境中的安裝。

  1. 請確定沒有使用中的 SOLIDWORKS 工作階段。
  2. 如果您要將 SOLIDWORKS 的使用許可移動到另一台電腦上，在移除此電腦所安裝的 SOLIDWORKS 之前，請先停用使用許可。
    詳細資訊請參閱移動使用許可。
  3. 開啟 Windows 控制台，再按一下程式和功能。
  4. 選擇要移除的產品零組件，然後按一下解除安裝。
    在某些情況下，您可能會在某個的主要發行版本中發現有多個 SOLIDWORKS Service Pack 元件。 要移除 SOLIDWORKS 的主要版本，請移除該主要版本的所有 Service Pack 元件。
  5. 在解除安裝的螢幕中：
    1. 選擇要移除的產品。
      根據預設，將會選取所有產品元件。
    2. 清除您不要移除的產品。
    3. 按一下 進階選項 中的 變更。
      進階選項畫面即會出現，並已選擇程式檔案和資料夾選項。
    4. 選擇一或多個選項來執行自訂的解除安裝，或選擇所有選項來執行完整的解除安裝。
      根據預設，SOLIDWORKS 安裝管理員會執行完整的解除安裝，並移除安裝時新增的所有檔案和資料夾。
    5. 按一下回到摘要。
    6. 在摘要畫面上，展開進階選項以顯示解除安裝的方法與項目。
    7. 按一下移除項目。
上層主題 單機安裝的管理
上層主題 多個安裝的管理
修改安裝
修復安裝
將單機安裝回溯至之前的 Service Pack
升級至新版本
產品共存規則
升級管理安裝點至新版本
Service Pack 產品更新管理
移動使用許可


升級至新版本

有幾種方法可以將單機安裝升級為新的 SOLIDWORKS 版本。

您可以在下列情況升級至一個新的版本：
  • 獲得新的安裝媒體
  • 啟動 SOLIDWORKS 時獲得升級的通知
  • 手動檢查更新
  • 啟動 SOLIDWORKS 安裝管理員的新執行個體時

安裝新的主要版本時，您可以升級先前安裝的主要版本或是安裝類似的新版本。如果您在先前已安裝的主要版本中安裝 Service Pack 版本，該版本會自動更新。

上層主題 單機安裝的管理
修改安裝
修復安裝
將單機安裝回溯至之前的 Service Pack
移除安裝
產品共存規則

手動檢查更新

如果您在機器上有管理員權限，您可以使用以下其中一個方法檢查已安裝的 SOLIDWORKS 版本是否有更新。

  • 在 SOLIDWORKS 中，按一下 [image] > 檢查更新。
  • 在 Windows 中，按一下開始 > SOLIDWORKS 安裝管理員 > 檢查更新。
您也可以按一下開始 > SolidWorks 安裝管理員 > SOLIDWORKS 背景下載程式。在 Windows 通知區域中，以滑鼠右鍵按一下 SOLIDWORKS 背景下載程式，然後按一下檢查更新。

升級警告

可以安裝多個不同主要版本的產品並不永遠支援主要的升級，或不支援以單一操作在主要版本之間升級的能力。

在此狀況下，SOLIDWORKS 安裝管理員會先安裝新版本，然後移除舊版本，以模擬升級。 此時，核心 SOLIDWORKS 產品支援主要升級，而其他產品則不支援。

此種情形的結果會是：
  • 在主要版本之間升級核心 SOLIDWORKS 產品時：
    • 您現有的安裝位置不會改變。
    • 如果發生了錯誤或您在升級過程中取消安裝，升級可被回溯。
  • 當其他產品在主要版本之間升級時：
    • 每個產品會先以新產品被安裝至新位置中，然後原始的安裝會移除。
    • 一但開始之後，如果發生了錯誤或您於升級的過程中取消安裝，升級無法回溯。


產品共存規則

這些產品共存規則決定新產品的安裝方式以及現有產品的升級方式。

規則 | 範例
您可以使用多種主要發行版本的核心 SOLIDWORKS 產品，但以下產品除外。 | SOLIDWORKS 2024 SP3.0 和 SOLIDWORKS 2025 SP0.0 可以共同存在於同一部電腦上。
但同一主要發行版本中有多個 Service Pack 不得使用。 | SOLIDWORKS 2025 SP0.0 和 2025 SP1.0 無法共同存在於同一部電腦上。如果在已經安裝 SOLIDWORKS 2025 SP0.0 的電腦上安裝 SOLIDWORKS 2025 SP1.0，則 SOLIDWORKS 安裝管理員會以 SP1.0 取代 SP0.0。
只允許在一部電腦中有下列產品的其中一個版本：
  • SolidNetWork License Manager
 如果已安裝 SolidNetWork License Manager 2024 SP3.0，即使電腦中仍然有較早的 SOLIDWORKS 主要版本，SolidNetWork License Manager 仍然會升級為 2025 SP0.0。
下列產品在電腦上只能有一個版本：
  • SOLIDWORKS Electrical
 如果您產生新的 SOLIDWORKS Electrical 2025 SP1.0 安裝項目，則 SOLIDWORKS 安裝管理員會自動從機器中移除較舊版本的 SOLIDWORKS Electrical。升級前，請先備份您的 SOLIDWORKS Electrical 環境。
只允許在一部電腦中有下列產品的其中一個版本：
  • SOLIDWORKS PDM 客戶端
  • SOLIDWORKS PDM 伺服器

如果您安裝 SOLIDWORKS 2025 SP0.0 或 SP1.0，那麼也應升級為 SOLIDWORKS 2025 PDM 伺服器和 PDM 客戶端。

如果您安裝 SOLIDWORKS 2025 PDM 伺服器，則應使用 PDM 伺服器的安裝程序來安裝 SOLIDWORKS PDM Client。不要以客戶端安裝程序另外安裝 SOLIDWORKS PDM Client。

SOLIDWORKS PDM 客戶端必須與 SOLIDWORKS PDM 伺服器位於同一部機器上，且為同一發行版本，擁有相同的 Service Pack。

詳細資訊請參閱SOLIDWORKS PDM 和 SOLIDWORKS Manage。

任何主要發行版本的 SOLIDWORKS，都只能安裝一個版本的隨附產品。 但是，不同主要發行版本的 SOLIDWORKS，其隨附產品則可以有多種版本共存。 | 如果 SOLIDWORKS 2025 SP0.0 升級為 2025 SP1.0，則 SOLIDWORKS Composer 2025 SP0.0 也會自動升級為 2025 SP1.0。然而，SOLIDWORKS Composer 2024 SP4.0. 可與 SOLIDWORKS Composer 2025 SP0.0 或與 SOLIDWORKS Composer 2025 SP1.0 共存。
上層主題 單機安裝的管理
修改安裝
修復安裝
將單機安裝回溯至之前的 Service Pack
移除安裝
升級至新版本


多個安裝

目錄

  • 部署至多個客戶端

    您可以產生一個管理安裝點來在多個客戶端上安裝 SOLIDWORKS 產品，然後部署安裝至客戶端。

  • 使用管理安裝點

    管理安裝點可讓您從單一網路位置進行可設定的 SOLIDWORKS 產品安裝。

  • 命令列部署

    您可以使用命令列提示或批次檔案（無訊息安裝）來自動部署管理安裝點。

  • 多個安裝的管理

    在多個安裝中，管理工作包括將管理安裝點升級至新的版本，套用 service pack 更新以及移除安裝。


部署至多個客戶端

您可以產生一個管理安裝點來在多個客戶端上安裝 SOLIDWORKS 產品，然後部署安裝至客戶端。

部署至多個客戶端的程序為：
  1. 產生管理安裝點。
    • 產生來自 SOLIDWORKS 安裝管理員的管理安裝點
  2. 部署管理安裝點至客戶端。
    • 透過 (電子郵件) 手動/提取方法將管理安裝點部署至客戶端
    • 透過自動/推送方法將管理安裝點部署至客戶端
    • 使用指令列從管理安裝點安裝
  3. 執行使用許可。
    • 管理個別的使用許可
    • 使用 SolidNetWork License Manager 來管理使用許可
上層主題 多個安裝
使用管理安裝點
命令列部署
多個安裝的管理


使用管理安裝點

管理安裝點可讓您從單一網路位置進行可設定的 SOLIDWORKS 產品安裝。

您可以從網路上的任何電腦 (包括客戶端電腦) 安裝管理安裝點。
  • 管理安裝點必須在一共用的資料夾中。
  • 如果您包括所有產品，管理安裝點磁碟空間需求可能是 17GB 或更多。
  • 如果當您升級管理安裝點時更新共用的名稱，則下一次客戶端應用程式啟動時會自動升級。詳細資訊請參閱 升級管理安裝點。
  • 部署管理安裝點時，安裝點路徑必須少於 58 個字元。
  • 客戶端必須在其電腦上有管理的權限。如果客戶端的權限不足，客戶端可以不同使用者的身分執行安裝。如果個別使用者對機器沒有本機系統管理權限 (安裝 SOLIDWORKS 產品需要此權限)，此選項就很有用。

    請參閱 從選項編輯器部署安裝。其中也會說明在客戶端權限不足時，安裝安裝點的替代方法。

  • 若已啟用 Windows 記錄，或如果您會使用管理安裝點選項編輯器中的狀態功能，則必須具備以下資料夾的讀取/寫入權限：{Administrative image directory}\x64\Logs。

在產生管理安裝點之後，管理安裝點選項編輯器可以管理安裝選項設定，以便使用者與群組從該安裝點安裝。 詳細資訊請參閱 管理安裝點選項編輯器。

目錄

  • 管理安裝點類型

    您可以使用「管理安裝點選項編輯器」，為遠端使用者和網路上的使用者產生數種安裝點類型。

  • 產生來自 SOLIDWORKS 安裝管理員的管理安裝點

    如果您在多台電腦上安裝 SOLIDWORKS，您可以產生一個管理安裝點，然後將應用程式部署到其他電腦上。

  • 管理安裝點選項編輯器

    管理安裝點選項編輯器讓您為個別的機器或一組機器自訂在管理安裝點中的安裝參數。

  • 設定管理員工具

上層主題 多個安裝
部署至多個客戶端
命令列部署
多個安裝的管理
從管理安裝點升級客戶端


管理安裝點類型

您可以使用「管理安裝點選項編輯器」，為遠端使用者和網路上的使用者產生數種安裝點類型。

管理安裝點類型 | 說明
標準 | 這是所有新的管理安裝點的預設安裝點。 這是標準的 Windows Installer 管理安裝點，適合能可靠存取公司網路的使用者。 它會將安裝所選 SOLIDWORKS 產品所需的所有檔案儲存在共用安裝點資料夾。 當使用者升級至新的 Service Pack 時，他們需要下載和套用修補程式檔案，而不需要下載整個安裝點。
遠端用戶端 | 此安裝點是針對無法可靠存取公司網路的遠端使用者所設計。 安裝此類型的安裝點時，遠端使用者會繼承您指定的所有安裝選項，例如序號和要安裝的產品等。 使用者可透過網際網路，從 SOLIDWORKS 下載頁面下載所需檔案。從網際網路存取和安裝這些檔案比從公司網路下載更為可靠，而且可減少網路的負載。 遠端使用者可使用標準管理安裝點所支援的相同技術來安裝此安裝點。 您仍然可以使用 sldim.exe 和 startwinstall.exe 檔案來執行指令碼安裝。 在安裝前，安裝檔案會下載至「管理安裝點選項編輯器」中指定的路徑。 使用者必須存取管理安裝點資料夾才能開始安裝，並執行託管於該處的批次或設定檔案。 遠端使用者必須有可儲存安裝點中所有檔案的足夠磁碟空間，不過使用者可以在安裝完成後刪除安裝點。
已壓縮 | 壓縮的管理安裝點是供需要將管理安裝點複製到多個網站或客戶端機器的組織使用，並希望將對網路的影響降至最低。 此安裝點比標準管理安裝點小 60%，但安裝時間相同。 它支援所有安裝作業，例如修改和修復。 壓縮的管理安裝點也有較短的檔案路徑。 這可避免安裝點儲存在深層資料夾結構時發生問題。 當使用者升級至新的 Service Pack 時，他們必須下載整個安裝點，而非僅下載修補程式。
上層主題 使用管理安裝點


產生來自 SOLIDWORKS 安裝管理員的管理安裝點

如果您在多台電腦上安裝 SOLIDWORKS，您可以產生一個管理安裝點，然後將應用程式部署到其他電腦上。

  1. 啟動 SOLIDWORKS 安裝管理員。

    請參閱下載安裝媒體。

  2. 在歡迎畫面上，選取產生一個管理安裝點以部署至多台電腦上，並選取下列其中一個選項：
    選項 | 敘述
    使用預設的設定產生一個新的安裝點。 | 使用預設的組態設定產生安裝點 (即不根據您的站點之現有管理安裝點所建立的設定。)
    使用來自現有安裝點的設定及檔案來產生一個新的安裝點。 | 使用為您所在站點之現有管理安裝點指定的組態設定產生安裝點。 按一下瀏覽為現有的管理安裝點指定安裝目錄。
  3. 輸入 SOLIDWORKS 序號。
  4. 按一下變更來修改產品或預設選項，包括：
    • 管理安裝點位置
    • 管理安裝點類型
  5. 接受使用許可協議書，然後按一下馬上產生。
  6. 按一下自訂安裝點，以在「管理安裝點選項編輯器」中開啟並顯示設定。
  7. 選擇性的: 按一下產生桌面捷徑以存取桌面上的安裝點。
上層主題 使用管理安裝點


管理安裝點選項編輯器

管理安裝點選項編輯器讓您為個別的機器或一組機器自訂在管理安裝點中的安裝參數。

在產生管理安裝點之後，SOLIDWORKS 安裝管理員會詢問您是否要啟動選項編輯器。 您也可以連按兩下在管理安裝點資料夾中的 sldAdminOptionEditor.exe 來開啟選項編輯器。

若要為機器群組或個別機器指定不同的安裝模型組態，請在「選項編輯器」選擇機器。然後再為那些機器指定安裝選項。

所有檔案或資料夾路徑提示的對話方塊，包括將所選資料夾對應至環境變數的選項。例如，如果您選擇 C:\Program Files\SOLIDWORKS Corp，檔案路徑會對應至 %ProgramFiles%\SOLIDWORKS Corp。最常見的變數是 %ProgramFiles% 和 %SystemDrive%。

您無法將所有路徑對應至環境變數。例如，您無法將 Z:\SOLIDWORKS Data 對應至環境變數。

目錄

  • 新增及刪除小組和機器

    管理安裝點選項編輯器讓您為一群機器或個別的機器指定不同的安裝組態。

  • 檢視及編輯選項設定

    SOLIDWORKS 管理安裝點選項編輯器可讓您檢視及變更用於群組的選項設定以及為安裝點指定的機器。

  • 從選項編輯器部署安裝

    您可以使用手動或推送方法，直接從選項編輯器部署安裝。

  • 結束選項編輯器

    您可以按一下「確定」或「關閉」以套用變更並結束「選項編輯器」。

  • 產生至選項編輯器的桌面捷徑

    您可以從應用程式內為特定管理安裝點產生選項編輯器的 Windows 桌面捷徑。

  • 透過電子郵件部署管理安裝點至客戶端

    一旦您產生了共用管理安裝點目錄，便可透過電子郵件通知客戶端。

上層主題 使用管理安裝點


新增及刪除小組和機器

管理安裝點選項編輯器讓您為一群機器或個別的機器指定不同的安裝組態。

舉例來說，您可以設定數台機器使用安裝點中的產品零組件子集，而另一組機器則可能使用不同的零組件子集。 即使您只有使用一個管理安裝點，選項編輯器小組設定仍然能夠讓您將不同的產品子集安裝至不同的機器小組。 您也可以在群組之間移動設定，並編輯機器群組。

您也可以將機器群組分成子群組。 子群組繼承自父群組的設定，但您可以變更每個子群組的個別設定。

加入一個小組：
  1. 用滑鼠右鍵按一下整體設定，然後按新增小組。
  2. 輸入小組的名稱。

新增機器：
  1. 用滑鼠右鍵按一下現有小組或整體設定，然後按新增機器。
    如果您用滑鼠右鍵按一下現有小組，則會將機器加入該小組。 否則，其被加入至最上層。
  2. 執行下列之一：
    • 選擇依機器名稱，並輸入一個機器名稱。
      機器名稱不能包括網域識別符號。例如，pluto.solidworks.com 是無效的。
    • 選擇依 IP 位址，並輸入機器的 IP 位址。
    • 選擇依 IP 位址範圍，並輸入範圍的起始 IP 位址和結束 IP 位址。
    • 按一下新增多台機器以輸入機器名稱。您可以透過分行符號、空格、標籤、逗號、句號、冒號或分號來分隔機器名稱。您也可以將分隔檔中的機器名稱清單 (例如 *.xls 或 *.cvs 檔案) 複製及貼上至對話方塊中。

    如果您依「名稱」、「IP 位址」和「IP 位址範圍」新增機器，安裝機器會依此順序尋找相符項目：機器名稱、IP 位址，然後是 IP 位址範圍。安裝選項將根據找到的第一個相符項目套用至安裝機器。

將現有機器移至群組或子群組：

將機器拖曳至群組或子群組。

將機器移出群組或子群組：

拖曳機器到整體設定或不同的群組或子群組。

若要刪除群組、子群組或機器︰

用滑鼠右鍵按一下群組、子群組或機器，然後按一下刪除群組或刪除機器。

如果您刪除了一個小組，則該小組中的所有機器都將被刪除。

刪除所有小組和機器：

用滑鼠右鍵按一下整體設定，然後按全部刪除。

上層主題 管理安裝點選項編輯器
檢視及編輯選項設定
從選項編輯器部署安裝
結束選項編輯器
產生至選項編輯器的桌面捷徑
透過電子郵件部署管理安裝點至客戶端


檢視及編輯選項設定

SOLIDWORKS 管理安裝點選項編輯器可讓您檢視及變更用於群組的選項設定以及為安裝點指定的機器。

  • 第一次啟動選項編輯器時，選項設定以唯讀模式顯示。 「變更」圖示 [image] 無陰影。

    按一下整體設定、群組或機器將顯示該品項之選項設定的摘要：

    範圍 | 顯示的選項設定
    整體設定 | 所有為管理安裝點指定的選項設定
    群組 | 變更與整體設定相關的群組設定
    機器 | 變更與群組相關的機器設定
  • 若要變更選項設定，請按一下變更 [image] 。 圖示將變為帶陰影，且顯示更詳細的選項設定清單。

    按一下整體設定、群組或機器可讓您變更該品項的選項設定。 當您所變更的選項設定，與所繼承的「整體設定」或群組設定不同時，該選項設定會強調顯示。

    如果再按一下變更 [image] 圖示，顯示將回復至唯讀模式。

    如果進行變更，選項編輯器在您結束時會提示您儲存或捨棄變更。

目錄

  • 為小組及機器指定選項設定

    您可以為所有機器（整體設定）、群組的機器及個別的機器指定選項設定。

  • 管理安裝點選項設定

    選項編輯器可讓您指定個別客戶端或群組的選項設定，包括序號、客戶端安裝選項、要安裝哪個軟體元件，以及 Toolbox 的位置。

  • 整體及群組選項設定的繼承

    整體設定或群組的選項設定由其底下的品項繼承。

  • 每台機器的自訂設定

    您也可以用右鍵按一下機器名稱，修改您已套用至特定機器的設定。

上層主題 管理安裝點選項編輯器
新增及刪除小組和機器
從選項編輯器部署安裝
結束選項編輯器
產生至選項編輯器的桌面捷徑
透過電子郵件部署管理安裝點至客戶端


為小組及機器指定選項設定

您可以為所有機器（整體設定）、群組的機器及個別的機器指定選項設定。

  1. 在選項編輯器中，按一下要修改的物件 (整體設定、一個群組或一台機器)。
  2. 在右側，按一下變更 [image] 。
    圖示將變為帶陰影，且顯示更詳細的選項設定清單。
  3. 按一下左側所選品項右邊的選項設定以進行變更。
    取代整體設定或群組設定的選項設定之變更將會強調顯示。
  4. 按一下確定或關閉來儲存您的變更。
    選項 | 敘述
    確定 | 選項編輯器將會儲存您的變更並結束。
    關閉 | 選項編輯器會詢問您是否要儲存變更，然後結束。
上層主題 檢視及編輯選項設定
管理安裝點選項設定
整體及群組選項設定的繼承
每台機器的自訂設定


管理安裝點選項設定

選項編輯器可讓您指定個別客戶端或群組的選項設定，包括序號、客戶端安裝選項、要安裝哪個軟體元件，以及 Toolbox 的位置。

序號

輸入要安裝於客戶端機器之產品的序號。
因為有許多種方式可以購買 SOLIDWORKS 產品，某些序號可能適用於兩種或多種產品。例如，SOLIDWORKS 序號可讓您安裝 SOLIDWORKS Simulation 而不需輸入個別的 SOLIDWORKS Simulation 序號。此外，有些產品並不需要序號。如果您對於序號有任何疑問，請聯絡您的 Value Added Reseller (VAR)。
如果您使用 SolidNetWork Licensing 管理使用許可：
  • 在第一個序號欄位中，輸入 SolidNetWork 的序號。
  • 在 SNL Server port@server 欄位中，以 nnnnn@servername 的形式輸入 SolidNetWork License Manager 伺服器的名稱與連接埠。 使用分號來將多行的輸入分開。

如需有關 SolidNetWork 使用許可的詳細資訊，請參閱 安裝 SolidNetWork 使用許可概觀。

客戶端安裝選項

您要如何在客戶端上執行主要版本的安裝？ 您可以指定客戶端安裝如何處理現有的較舊主要版本安裝：
  • 升級一個現有的主要版本（如果有的話）。

    指定此選項以將較舊主要版本安裝取代為較新版本安裝。

  • 產生一個新的主要版本。

    指定此選項以保留較舊的主要版本，並為較新的主要版本產生一個新的安裝。 要為較新版本的安裝指定位置，請按一下瀏覽。
在安裝新的主要版本之前，您是否要解除之前最新版本的安裝？ 您可以指定是否要解除現有之前主要版本的安裝：
  • 不要解除安裝。

    指定此選項來保留之前主要版本的安裝。

  • 解除安裝最新版本。
  • 解除安裝所有版本。
請問您要如何套用 SOLIDWORKS 的設定？ 在啟動軟體時可以指定一個設定檔案。客戶端安裝會參考一個設定檔。將設定 (*.sldsettings) 檔案儲存在所有安裝均可看見的共用 UNC 路徑。在安裝 SOLIDWORKS 之前，先指定 *.sldsettings 路徑。客戶端安裝會在安裝作業期間偵測 *.sldsettings 檔案路徑。
將 Windows 檔案權限指定為僅允許指定使用者的寫入權限，即可保護 *.sldsettings 檔案。

若要產生或編輯 *.sldsettings，請按一下啟動設定管理員。SOLIDWORKS 設定管理員工具可讓您定義要為終端使用者套用和選擇性鎖住的 SOLIDWORKS 系統選項。您也可以定義將設定套用至單機安裝的方式與時機，而且可藉由執行「設定管理員」工具和覆寫現有檔案，隨時修改 *.sldsettings 檔案。

您可以針對不同的機器或群組使用不同的 *.sldsettings 檔案。

安裝時即已設定 *.sldsettings 的路徑。一旦部署完成，請勿將 *.sldsettings 檔案重新命名或移動。

您必須具有現有的 SOLIDWORKS [目前的主要版本] 安裝才能執行「設定管理員」工具。
您要如何啟動客戶端的安裝？ 您可以指定是否在執行安裝後自動完成產品的啟動，或要求在安裝後由使用者手動執行產品啟動。
  • 當每個客戶端安裝完成時自動啟動。

    選擇此選項設定可自動執行產品啟動。輸入在客戶端電腦上執行啟動時所提供的電子郵件地址。

  • 不要自動啟動。

    選擇此選項設定來指定不要有自動的產品啟動。客戶端使用者在安裝後執行產品啟動。

系統管理選項

在每個安裝的過程中產生一個診斷記錄檔。 | 客戶端安裝項目可產生一個診斷記錄檔，以用於疑難排解安裝問題。 產生此記錄檔可能會使客戶端安裝項目速度變慢。 記錄檔儲存在管理安裝點目錄}\x64\Logs\<machine_name>。
以不同的使用者執行安裝。 | 您可以指定另一位具有管理權限的使用者來執行安裝，而非登入的使用者。如果個別使用者不具備自己機器的本機管理權限 (安裝 SOLIDWORKS 產品必須具備此權限)，此選項就很實用。 當客戶端沒有管理權限時，可使用替代的部署和安裝方法。 請參閱從選項編輯器部署安裝。
在安裝之前或之後執行一個程式。 | 您可以指定自訂程式在客戶端安裝之前或之後執行。
您是否要讓客戶參與 SOLIDWORKS 客戶經驗改進計劃？ | 您可以指定客戶端機器參與 SOLIDWORKS 客戶經驗改進計劃。 系統會將效能資訊送至 SOLIDWORKS Corporation 以幫助改進產品。 此過程是透明和保密的。 詳細資訊請參考客戶經驗改進計劃網站。

「在安裝之前執行一個程式」或「在安裝之後執行一個程式」選項的限制

這些選項可讓您於部署 SOLIDWORKS 前後，在客戶端機器上執行其他安裝程式或指令碼，例如安裝 Microsoft Office 的指令碼。

這些選項的使用有所限制。如果您使用任一選項來部署安裝程式或顯示使用者介面的指令碼 (例如顯示對話方塊的指令碼)，就會發生失敗。執行自動部署 SOLIDWORKS 時，無法在目標機器上安裝 SOLIDWORKS。

若要使用在安裝之前執行一個程式和在安裝之後執行一個程式選項，僅能選擇能以無訊息模式安裝的程式。

要安裝的軟體

您可以指定要安裝哪些 SOLIDWORKS 產品元件。
  • 所選擇的產品元件旁其核取方塊可指定在客戶端安裝期間安裝該元件。
  • 清除核取方塊則表示不安裝該元件。
  • 如果元件具有可選用的安裝子元件，元件旁會顯示 + 圖示。 若要查看元件有哪些子元件可用，請按一下 + 圖示。
  • 如果元件已經展開，顯示可選用的子元件，則元件旁會出現 - 圖示。 若要摺疊子元件清單，請按一下 - 圖示。
語言的指定僅會限制為 SOLIDWORKS 產品安裝的語言。 其他的產品不受此指定的影響。 例如，eDrawings® 會安裝所有語言。

Toolbox 選項

您可以指定客戶端安裝支援的標準以及預設的 Toolbox 位置。

通常有多個使用者存取一個共用的 Toolbox，一般是透過網路位置 (例如指定的 UNC 路徑、共用資料夾或公用網路磁碟機) 存取。

如果該位置包含 Toolbox 的較舊主要版本，則客戶端安裝會將該 Toolbox 升級至較新的主要版本。 這些檔案不再與 SOLIDWORKS 的較舊主要版本相容。
若有部分客戶端繼續使用較舊版本的 SOLIDWORKS，對於正在升級為較新版本的客戶端，您必須指定不同的 Toolbox 網路位置。

如需 SOLIDWORKS Toolbox 管理的詳細資訊，請參閱 SOLIDWORKS 說明中的 Toolbox 資訊。

安裝 Toolbox 軟體而不安裝 Toolbox 資料

如果環境具有 PDM 或共用 Toolbox/異形孔精靈位置，您可以將用戶端安裝指定為不在該位置安裝或升級 Toolbox 資料。

在下列情況下，執行此設定：
  • 您尚未在安裝 SOLIDWORKS 之前，指定 SOLIDWORKS PDM 本機視圖。
  • 此位置中的檔案正在使用中，會防止完成 SOLIDWORKS 安裝。
  • 此位置無法使用，會防止完成 SOLIDWORKS 安裝。

將用戶端安裝指定為不安裝 Toolbox 資料時，SOLIDWORKS 軟體和設定會指向 Toolbox/異形孔精靈位置，但稍後必須在中央位置安裝資料。

要安裝 SOLIDWORKS 軟體但不包含 Toolbox/異型孔精靈資料：
  • 當系統詢問您是否希望此用戶端安裝/升級 Toolbox 檔案時，選擇否，安裝 Toolbox 軟體而不納入資料檔案。

至少需有一人 (通常是 CAD 管理員) 於中央位置安裝或升級 Toolbox/異型孔精靈資料，否則軟體將無法正常運作。組織中的任何人均可處理此工作，只要執行一次手動安裝 SOLIDWORKS 軟體即可。如果您在 SOLIDWORKS PDM 內部管理 Toolbox，請遵循 SOLIDWORKS PDM 管理指南中 Toolbox 一節的說明步驟，以安裝或升級 Toolbox 資料。

SOLIDWORKS PDM 客戶端選項

您可以選擇以下選項來部署 SOLIDWORKS PDM 客戶端與附加程式：

  • PDM 產品類型
  • PDM 客戶端類型
  • 特徵
  • 資料保險箱視圖

    若要開啟視圖設定精靈，您必須在已安裝 SOLIDWORKS PDM 客戶端的機器上執行「管理安裝點選項編輯器」。

    若要在客戶端機器上產生保險箱視圖，您需要 Conisio 視圖設定 (.cvs) 檔案，該檔案定義在客戶端機器上設定保險箱視圖的參數。您可以參考現有的 .cvs 檔案，或是從「管理安裝點選項編輯器」產生此檔案。

如需這些客戶端與附加程式的詳細資訊，請參閱 SOLIDWORKS 說明中的 SOLIDWORKS PDM 一節。

Electrical 選項

您可以為 SOLIDWORKS Electrical 管理零組件指定下列參數：
  • 資料路徑
  • Collaborative Server 的機器名稱與連接埠號碼
  • SQL Server 機器名稱和密碼

如需有關這些零組件的詳細資訊，請參閱 SOLIDWORKS Electrical 。

上層主題 檢視及編輯選項設定
為小組及機器指定選項設定
整體及群組選項設定的繼承
每台機器的自訂設定
安裝 SolidNetWork 使用許可概觀
從選項編輯器部署安裝
SOLIDWORKS Electrical


整體及群組選項設定的繼承

整體設定或群組的選項設定由其底下的品項繼承。

例如：
  • 為整體設定所定義的設定會被所有群組及機器繼承。
  • 為群組所定義的設定會被該群組內的所有子群組和機器繼承。

您可以變更機器、子群組或機器的選項設定，來覆寫預設或繼承的設定。 當您變更來自預設或繼承值的選項設定時，該選項會被強調顯示。

若要將選項設定回復為原始繼承值，在群組、子群組或機器上按一下右鍵，然後按一下下列其中一項：
  • 回復到整體設定 (針對群組、子群組或非群組成員的機器)
  • 回復到群組設定 (針對屬於群組成員的機器)
  • 將所有成員回復到群組設定 (一次針對該群組所有成員)
上層主題 檢視及編輯選項設定
為小組及機器指定選項設定
管理安裝點選項設定
每台機器的自訂設定


每台機器的自訂設定

您也可以用右鍵按一下機器名稱，修改您已套用至特定機器的設定。

從快顯功能表中，您可以為每台機器執行下列工作：
  • 重新命名
  • 刪除機器
  • 回復到整體設定
  • 編輯註解
  • 編輯選項

「編輯選項」可讓您修改機器的所有選項，例如「客戶端安裝選項」及「系統管理選項」。

上層主題 檢視及編輯選項設定
為小組及機器指定選項設定
管理安裝點選項設定
整體及群組選項設定的繼承


從選項編輯器部署安裝

您可以使用手動或推送方法，直接從選項編輯器部署安裝。

  • 使用選項編輯器的「Deploy Manually」(手動部署) 頁面，將有關如何開始安裝的指示以電子郵件傳送給使用者。 當使用者擁有其客戶端機器的管理權限時可使用此方法。
    在系統管理選項之下，您可以選擇以不同的使用者執行安裝，將管理權限指派給使用者。
  • 使用選項編輯器的「Deploy Automatically」(自動部署) 頁面，將安裝自動推送至目標機器。 當使用者沒有在其系統上安裝軟體的管理權限時，使用此方法。 您也可以使用此方法來執行自訂安裝。

若要手動或自動部署，您必須將管理安裝點安裝目錄儲存為 Windows 共用目錄，以使其可透過網路位置使用，例如：\\machine\shared_directory。您也可以將安裝點複製到每台機器上的本機目錄，例如：C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0，讓安裝點可供使用。

目錄

  • 使用 UNC 路徑部署管理安裝點

    指定管理安裝點安裝目錄的網路位置時，使用 UNC 路徑 (\\machine_name\share_name)，而非對應網路磁碟機位置。

  • 使用 StartSWInstall.exe 部署管理安裝點

  • 手動部署

    如果使用者擁有在其系統上安裝所需的權限，您就可以使用此方法。

  • 自動部署的必要條件

    自動部署對於沒有管理權限的使用者而言是有效的，因為它可確保軟體安裝順利進行。

  • 自動部署

  • 測試推擠部署的設定

    「管理安裝點選項編輯器」中的自動部署標籤包含測試特徵。

上層主題 管理安裝點選項編輯器
新增及刪除小組和機器
檢視及編輯選項設定
結束選項編輯器
產生至選項編輯器的桌面捷徑
透過電子郵件部署管理安裝點至客戶端


使用 UNC 路徑部署管理安裝點

指定管理安裝點安裝目錄的網路位置時，使用 UNC 路徑 (\\machine_name\share_name)，而非對應網路磁碟機位置。

對應的網路磁碟機與推送和自動安裝方法不相容，也與提取和手動方法中的「以不同的使用者身分執行」不相容。

上層主題 從選項編輯器部署安裝


使用 StartSWInstall.exe 部署管理安裝點

您可以藉由執行指令 admin_image_install_dir\ StartSWInstall.exe 來安裝或解除安裝客戶端上的管理安裝點。 此方法會使用管理安裝點選項編輯器中所定義的選項、機器和群組來安裝 SOLIDWORKS。

您可以附加下列參數到 StartSWInstall.exe 指令：
參數 | 說明
/install | 在客戶端機器上安裝管理安裝點。
/uninstall 從客戶端機器解除安裝軟體，有兩種選用的參數：

/removedata

僅適用於解除安裝。 在解除安裝期間移除 SOLIDWORKS 資料檔案及資料夾。

/removeregistry

僅適用於解除安裝。 解除安裝期間移除 SOLIDWORKS 登錄項目。
/showui | 顯示 SOLIDWORKS 安裝管理員的進度視窗。 否則使用者將看不見 SOLIDWORKS 安裝管理員。
/now | 立即開始安裝或解除安裝。 不會出現 5 分鐘的警告對話方塊。

若您希望進行不需與使用者互動的安裝，但又不想要使用管理安裝點選項編輯器的自動部署時，使用 StartSWInstall.exe 是較理想的選擇，而非 StartSWInstall.hta。

上層主題 從選項編輯器部署安裝


手動部署

如果使用者擁有在其系統上安裝所需的權限，您就可以使用此方法。

要使用電子郵件手動部署安裝：

  1. 在選項編輯器中，按一下部署。
    安裝可用性及每台機器的狀態將會出現。
  2. 按一下傳送電子郵件。
  3. 指定管理安裝點安裝目錄的網路路徑。
    通常，管理安裝點安裝目錄的目錄路徑最初顯示為 Windows 檔案路徑 (例如：C:\SOLIDWORKS Admin\SOLIDWORKS 2025 SP0)。對話方塊指示此路徑並非一網路路徑。
    1. 按一下瀏覽為此管理安裝點安裝目錄指定網路位置。
    2. 導覽至其中安裝有管理安裝點的電腦，並選擇為管理安裝點安裝目錄指定的 Windows 共用目錄。
      不要在管理安裝點共用目錄內導覽 (例如導覽至 64bit 子目錄)。
    3. 按一下確定。
      對話方塊指示此路徑是一網路路徑。
    將會產生一封電子郵件，指示機器所有者如何使用管理安裝點中的 StartSWInstall.hta 檔案之網路位置從管理安裝點安裝。
  4. 將此電子郵件傳送至負責安裝 SOLIDWORKS 的使用者。

使用者可以連按兩下電子郵件中 StartSWInstall.hta 之網路位置的連結，以從管理安裝點安裝 SOLIDWORKS。

在選項編輯器中，安裝狀態會顯示：
擱置中 | 使用者尚未在此機器上執行安裝。
成功 | 使用者已在此機器上成功完成安裝。
失敗 | 使用者在此機器上執行了安裝，但失敗了。
其他可能顯示的狀態訊息包括：「安裝成功」、「解除安裝成功」、「正在安裝」、「正在解除安裝」、「需要重新開機」、「安裝失敗」以及「解除安裝失敗」。
在狀態欄的頂端，按一下綠色箭頭以重新整理並顯示更新的資訊。
上層主題 從選項編輯器部署安裝


自動部署的必要條件

自動部署對於沒有管理權限的使用者而言是有效的，因為它可確保軟體安裝順利進行。

若要使用自動部署，客戶端和伺服器都必須屬於相同的 Active Directory 網域。此組態允許將安裝工作推送至目標機器，並由 Microsoft 工作排程器執行，無需任何使用者動作。

使用推播安裝，工作排程器會使用選項編輯器中管理員指定的認證，在客戶端機器上執行工作，以啟動 SOLIDWORKS 安裝管理員。 工作排程器會以電腦的 LocalSystem 帳戶執行。 此帳戶會在網路上顯示為符合電腦安全性原則。 電腦安全性原則必須具備下列存取權限：
  • 管理安裝點資料夾的讀取存取權限。
  • 管理安裝點 folder\x64\logs 資料夾的讀取和寫入存取權限。

在 Active Directory 中，當您將電腦新增至共用資料夾的群組時，請選擇物件類型及電腦。

此外，服務管理安裝點與目標客戶端機器的電腦必須是相同 Microsoft Active Directory 網域的成員。

上層主題 從選項編輯器部署安裝


自動部署

要透過將安裝推送至使用者系統來自動部署：

  1. 在選項編輯器中，按一下 Deploy Automatically (自動部署) 標籤。
    安裝可用性及每台機器的狀態將會出現。
  2. 在部署欄底下，選擇目標客戶端機器，以及在部署欄中的群組。
    先選擇部署欄位下的一或多個機器或群組，才能開始部署程序。
  3. 在 Install Time (安裝時間) 下，選擇現在來立即部署，或選擇稍候再進行，為部署排定特定日期與時間。
  4. 在客戶端選項之下，選擇下列選項：
    • 安裝或升級 SOLIDWORKS 2025
    • 解除安裝 SOLIDWORKS 2025
      如果您選擇解除安裝，可指定是否將登錄項目隨資料檔案、資料夾和程式檔案及資料夾一起解除安裝。
  5. 若您在部署過程中或部署後需要一台或多台目標機器重新開機，請選擇電腦自動重新開機。
  6. 輸入一個或多個目標機器的客戶端憑證。
  7. 按一下部署，開始部署過程。
在選項編輯器中，安裝狀態顯示：
擱置中 | 尚未在此機器上執行安裝。
成功 | 已在此機器上成功完成安裝。
失敗 | 此機器上的安裝失敗。

其他可能顯示的狀態訊息包括： 「安裝成功」、「解除安裝成功」、「正在排程」、「正在連線」、「安裝中」、「解除安裝中」、「需要重新開機」、「安裝已排定」、「解除安裝已排定」、「安裝失敗」、「解除安裝失敗」、「連接失敗」以及「排程失敗」。

上層主題 從選項編輯器部署安裝


測試推擠部署的設定

「管理安裝點選項編輯器」中的自動部署標籤包含測試特徵。

您可以執行模擬安裝，練習部署作業所使用的系統，例如：
  • 連線至目標電腦。
  • 在該電腦上產生安裝工作。
  • 在該電腦上完成安裝工作。
  • 更新管理安裝點的狀態和記錄。
  • 偵測要在安裝前後執行的程序。

測試會驗證檔案路徑、驗證權限並報告安裝成功結束。測試不會在目標系統上安裝任何軟體或修改登錄。如果任何目標電腦上的系統失敗，測試會指出失敗的系統。

工具提示會提供有關失敗的更多詳細資訊。您可以將結果輸出至 .xml 試算表或 .csv，有助於檢閱多個失敗結果或與其他支援人員分享結果。

若要測試推擠部署的設定：

  1. 使用「安裝管理員」，產生管理安裝點。
  2. 啟動「管理安裝點選項編輯器」。

    您可以在安裝管理員完成產生管理安裝點後啟動此選項，或在管理安裝點資料夾中連按兩下 sldAdminOptionEditor.exe。

  3. 在設定標籤中，加入一或多台電腦。
  4. 按一下自動部署：
    1. 提供網域管理員的使用者名稱和密碼。
    2. 選擇一或多台要測試的電腦。
    3. 按一下測試。
  5. 在出現「設定測試」時，按一下執行測試。
  6. 等待數分鐘，讓測試完成，或隨時按一下取消測試。
  7. 檢閱並更正任何設定問題。
上層主題 從選項編輯器部署安裝


結束選項編輯器

您可以按一下「確定」或「關閉」以套用變更並結束「選項編輯器」。

  • 按一下確定以套用選項設定變更並結束「選項編輯器」。
  • 按一下 Windows 應用程式的關閉按鈕以結束「選項編輯器」。如果軟體偵測到有未儲存的變更，就會提示您儲存。
上層主題 管理安裝點選項編輯器
新增及刪除小組和機器
檢視及編輯選項設定
從選項編輯器部署安裝
產生至選項編輯器的桌面捷徑
透過電子郵件部署管理安裝點至客戶端


產生至選項編輯器的桌面捷徑

您可以從應用程式內為特定管理安裝點產生選項編輯器的 Windows 桌面捷徑。

  1. 啟動選項編輯器。
    例如，在檔案 Explorer 中，導覽至管理安裝點安裝目錄，並連按兩下 sldAdminOptionEditor.exe。
  2. 按一下產生至此選項編輯器的桌面捷徑。
    管理安裝點的選項編輯器之捷徑出現在 Windows 桌面上。
上層主題 管理安裝點選項編輯器
新增及刪除小組和機器
檢視及編輯選項設定
從選項編輯器部署安裝
結束選項編輯器
透過電子郵件部署管理安裝點至客戶端


透過電子郵件部署管理安裝點至客戶端

一旦您產生了共用管理安裝點目錄，便可透過電子郵件通知客戶端。

將管理安裝點目錄組態為在其他電腦可存取的電腦上共用（例如透過 UNC 路徑）。

您可以將包含 管理安裝點安裝目錄\StartSWInstall.hta 連結的電子郵件，傳送到所有的客戶端。 客戶端可以按一下此連結，然後按一下馬上安裝 SOLIDWORKS 產品，從管理安裝點開始安裝。

如果您將管理安裝點升級到新的 SOLIDWORKS 版本，就可以設定管理安裝點位置及共用屬性，讓之前使用該安裝點安裝的任何客戶端自動升級。詳細資訊請參閱從管理安裝點升級客戶端。
上層主題 管理安裝點選項編輯器
新增及刪除小組和機器
檢視及編輯選項設定
從選項編輯器部署安裝
結束選項編輯器
產生至選項編輯器的桌面捷徑


設定管理員工具

您可以使用設定管理員工具來指定部署或升級 SOLIDWORKS 軟體時套用的系統選項，並且防止使用者變更這些選項。在部署設定方面，此工具會取代 SOLIDWORKS 設定精靈，不過精靈仍可用於複製設定。

搭配管理安裝點選項編輯器使用設定管理員工具有三個步驟：
  1. 產生管理安裝點以存取工具。
  2. 使用設定管理員工具來產生包含您所選 SOLIDWORKS 選項的 *.sldsettings 檔案。
  3. 在 SOLIDWORKS 安裝中包含 *.sldsettings 檔案。
如果您使用的是 3DEXPERIENCE 附加程式，您也可以在管理安裝點之外部署 *.sldsettings 檔案。使用此方法的優點是會在登入時自動部署設定。
  1. 若要存取「設定管理員工具」，請依照 存取設定管理員工具 中的步驟操作。
  2. 請依照指示套用並鎖定設定。
  3. 從 3DEXPERIENCE Compass 中，展開我的角色，然後按一下平台管理員應用程式。前往內容 > 協同作業空間組態中心 > CAD 協同作業 > SOLIDWORKS > 設定 > 資源 > CAD 設定。
  4. 在 CAD 設定中，瀏覽、上載和下載 *.sldsettings 檔案。

目錄

  • 存取設定管理員工具

    若要存取「設定管理員工具」，則您必須先產生管理安裝點。

  • 使用設定管理員工具

  • 套用及鎖住選項

  • 完成設定選項

  • 在 SOLIDWORKS 安裝中包含 sldsettings 檔案

上層主題 使用管理安裝點


存取設定管理員工具

若要存取「設定管理員工具」，則您必須先產生管理安裝點。

您可以從管理安裝點內啟動「設定管理員工具」。

若要存取設定管理員工具：

  1. 執行管理安裝點資料夾中的 sldAdminOptionEditor.exe。
  2. 在管理安裝點選項編輯器中，按一下變更 [image] 。
  3. 在客戶端安裝選項區段中，執行下列操作：
    1. 按一下使用由 SOLIDWORKS 設定管理員輸出的設定檔案。
    2. 按一下啟動設定管理員。
      若要存取啟動設定管理員，SOLIDWORKS <版本> 必須安裝在執行 sldAdminOptionEditor.exe 的電腦上。
上層主題 設定管理員工具


使用設定管理員工具

若要使用設定管理員工具：

  1. 在歡迎標籤上，選擇下列選項：
    • 啟動此 SOLIDWORKS 版本的預設選項組。
    • 從這部電腦輸入 SOLIDWORKS 2025 選項。
    • 瀏覽至現有的 sldreg 檔案。
    • 瀏覽至現有的 sldsettings 檔案。
    *.sldreg 檔案由 SOLIDWORKS 設定精靈產生，而 *.sldsettings 檔案則由設定管理員工具產生。
  2. 按一下下一步。
上層主題 設定管理員工具


套用及鎖住選項

在系統選項標籤中，有兩欄核取方塊可讓您選擇要套用哪些選項，以及要鎖住哪些套用的選項，讓使用者無法變更這些選項。

使用者在 SOLIDWORKS 軟體中存取系統選項話方塊時，鎖住的選項會顯示為無法使用，而且該選項上會有一個鎖圖示 [image] 。 但您可以產生密碼，讓使用者能夠解除鎖住選項。 當使用者將游標停在鎖住的選項上時，會有一個工具提示顯示您的名稱及電子郵件，好讓使用者能聯絡您並要求密碼。

若要套用及鎖住選項：

  1. 在系統選項標籤中執行下列操作：
    1. 若要套用系統選項，請選擇選項並核取套用欄中對應的方塊。
    2. 若要鎖住系統選項，請選擇選項並同時核取套用與鎖住欄中對應的方塊。
      當使用者存取系統選項標籤時，這些選項會顯示，並加上一個鎖 [image] 。
  2. 依選項而定，您可能必須為選項指定其他參數。
  3. 您也可以套用訊息/錯誤/警告控制項，來阻止使用者解除訊息。
    1. 按一下訊息/錯誤/警告。
    2. 選擇套用，並針對您想要管理的訊息視需要選擇鎖住。
    3. 將訊息設定為顯示或不要顯示。

      如果您選擇顯示，訊息會從使用者的已解除訊息清單上移除，並且在適當時機向使用者顯示。 如果您選擇不要顯示，訊息會自動加入至使用者的已解除訊息清單，並且不會在使用者操作模型時顯示。

      此表格分別說明軟體中的行為：
      套用 | 鎖住 | 顯示 | 不要顯示 | 行為
      X | X | 強制顯示訊息。
      X | X | 解除訊息並將訊息加入至已解除訊息清單。
      X | X | X | 強制顯示訊息並停用訊息方塊中的不要再次顯示選項。
      X | X | X | 解除訊息並阻止使用者在工具 > 選項 > 訊息/錯誤/警告中加以啟用。
  4. 在系統選項標籤中，按一下下一步。
上層主題 設定管理員工具


完成設定選項

若要完成設定選項：

  1. 在完成標籤上，選擇系統選項的套用時機：
    • 使用者第一次啟動軟體時。
    • 每次啟動軟體時。
    • 以及是否要同時套用自訂。
  2. 您可以選擇在使用者不在網路上時套用鎖住的選項與允許 API 取代鎖住的選項。
  3. 若系統選項是鎖住的，您必須提供名稱與電子郵件地址。 當使用者將游標停在鎖住的選項上時，SOLIDWORKS 軟體會在工具提示中顯示此資訊。
  4. 您也可以允許使用者取代鎖住的選項。 接著您必須指定密碼，並將密碼提供給使用者。
  5. 按一下儲存以產生 *.sldsettings 檔案供部署使用。
上層主題 設定管理員工具


在 SOLIDWORKS 安裝中包含 sldsettings 檔案

若要在安裝中包含 *.sldsettings 檔案：

  1. 連按兩下管理安裝點資料夾中的 sldAdminOptionEditor.exe。
  2. 在管理安裝點選項編輯器中，按一下變更。
  3. 在客戶端安裝選項區段中，執行下列操作：
    1. 按一下使用由 SOLIDWORKS 設定管理員輸出的設定檔案。
    2. 按一下編輯路徑並瀏覽至 *.sldsettings 檔案。
    您可以為不同的群組或機器產生及套用不同的 *.sldsettings 檔案。
  4. 部署及安裝 SOLIDWORKS 軟體。

部署之後，您可以隨時重複步驟 2 來修改現有的 *.sldsettings。 SOLIDWORKS 軟體會於下次啟動時讀取已修改的 *.sldsettings。

上層主題 設定管理員工具


命令列部署

您可以使用命令列提示或批次檔案（無訊息安裝）來自動部署管理安裝點。

若要使用 SOLIDWORKS PDM 客戶端的命令列來部署管理安裝點，請參閱 SOLIDWORKS PDM 安裝指南。

目錄

  • 準備客戶端以便從管理安裝點進行指令列安裝

    在產生管理安裝點並且通知客戶端之前，必須安裝 Microsoft Windows 元件，使用指令列或 Microsoft Active Directory 產生的管理安裝點無法安裝這些元件。

  • 使用指令列從管理安裝點安裝

    您可以部署使用指令列從管理安裝點安裝。

  • 命令列屬性

    此處描述的命令列屬性包括特徵屬性、整體屬性、產品指定屬性和 Windows 位置慣例。

  • 使用 Microsoft Active Directory 部署管理安裝點

    Microsoft Active Directory Deployment 支援 SOLIDWORKS 核心產品對客戶端的部署。

上層主題 多個安裝
部署至多個客戶端
使用管理安裝點
多個安裝的管理


準備客戶端以便從管理安裝點進行指令列安裝

在產生管理安裝點並且通知客戶端之前，必須安裝 Microsoft Windows 元件，使用指令列或 Microsoft Active Directory 產生的管理安裝點無法安裝這些元件。

只有當您是從使用指令列或透過 Microsoft Active Directory 的管理安裝點安裝時，才需要手動安裝這些 Windows 元件。 如果您使用 SOLIDWORKS 安裝管理員來產生與安裝管理安裝點，這些 Windows 元件會自動安裝。
以下是 Windows 元件中之 SOLIDWORKS 所需的檔案摘要：
Windows Performance Toolkit | 可在 SOLIDWORKS Rx 中啟用延伸記錄。
Visual C++ 2022 Redistributable Package | 包含 Microsoft Visual C++ 的執行階段元件。 必須安裝 2022 版本。
Visual Basic for Applications 7.1 | 提供 Visual Basic 巨集支援。
Visual Studio Tools for Application 2022 | 選擇使用。包含支援 Visual Studio 2022 應用程式 (VSTA17) 的工具組。
.NET Framework 4.8 | 包含執行 .NET Framework 4.8 應用程式所需的 common language runtime 及 .NET Framework 元件。
SWCEF | Chromium Embedded Framework (CEF) 用來顯示 3DEXPERIENCE platform 內容。
Microsoft Edge WebView2 | 必須有此項目才能顯示網頁內容。
SOLIDWORKS Login Manager | 允許登入 3DEXPERIENCE Marketplace 和其他 3DEXPERIENCE 應用程式。
所有 SOLIDWORKS 產品 (不僅是核心 SOLIDWORKS 產品) 都需要 Visual C++ Redistributable Package 和 .NET Framework 4.8。

這些元件必須包括在管理安裝點目錄的子目錄中。

下列表格說明每個支援的作業系統所需的特定檔案。
作業系統：Windows Server 2019 64 位元和 Windows Server 2022 64 位元
SOLIDWORKS PDM Server 和 SOLIDWORKS SolidNetWork License Manager 都支援在 Windows Server 2019 及 2022 上進行安裝。
Windows Performance Toolkit： | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package： | vc_redist.x86.exe vc_redist.x64.exe 兩者皆需安裝。
Visual Basic 7.1： | vba71.msi 和 vba71_1033.msi 加上選擇性語言套件。
.NET Framework 4.8： | ndp48-x86-x64-allos-enu.exe
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe
作業系統：Windows 10 和 Windows 11 (64 位元)
Windows Performance Toolkit： | WPTx64-x86_en-us.msi
Visual C++ 2022 Redistributable Package： | vc_redist.x86.exe vc_redist.x64.exe 兩者皆需安裝。
Visual Basic 7.1： | vba71.msi 和 vba71_1033.msi 加上選擇性語言套件。
.NET Framework 4.8： | .NET 4.8 是作業系統的一部分，並滿足此需求。
SWCEF | CEF for SOLIDWORKS Applications.msi
Microsoft Edge Web View2 | MicrosoftEdgeWebView2RuntimeInstallerX64.exe

目錄

  • 64 位元作業系統中從指令列安裝 Windows 必要元件

    您可遵照此程序，使用 Windows 64 位元版本的指令列安裝管理安裝點安裝的 Windows 必要元件。

上層主題 命令列部署
使用指令列從管理安裝點安裝
命令列屬性
使用 Microsoft Active Directory 部署管理安裝點


64 位元作業系統中從指令列安裝 Windows 必要元件

您可遵照此程序，使用 Windows 64 位元版本的指令列安裝管理安裝點安裝的 Windows 必要元件。

如果要在一個安裝作業中安裝多個元件，請使用下列程序中提供的指令建立一個批次檔，然後用它將元件推至客戶端電腦。

  1. 請確定目標電腦至少有 620 MB 的可用空間及有效的 TEMP 目錄。
  2. 安裝 Visual C++ 版本 Redistributable Package。您必須安裝各套件中的 32 位元及 64 位元版本。
    安裝版本 = 2022 的套件。

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vc_redist.x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vc_redist.x86.exe /Q

  3. 安裝 Microsoft .NET Framework 4.8：
    administrative_image_directory\.Net_Framework_4.8\ndp48-x86-x64-allos-enu.exe
  4. 安裝 Visual Studio Tools for Applications 2022：
    administrative_image_directory\Microsoft_VSTA17\vsta_setup.exe
  5. 安裝 Visual Basic 7.1：
    administrative_image_directory\Microsoft_VBA\vba71.msi 與 administrative_image_directory\Microsoft_VBA\vba71_1033.msi 為所有語言所必要。
    僅需安裝此套件的 64 位元版本。

    另外，請針對所需的語言安裝下列套件：

    vba71_1028.msi | 繁體中文
    vba71_1031.msi | 德文
    vba71_1036.msi | 法文
    vba71_1040.msi | 義大利文
    vba71_1041.msi | 日文
    vba71_1042.msi | 韓文
    vba71_1046.msi | 巴西葡萄牙文
    vba71_2052.msi | 簡體中文
    vba71_3082.msi | 西班牙文
    英文、捷克文、波蘭文、俄文及土耳其文不需要額外的語言套件。
  6. 安裝 SOLIDWORKS Chromium Embedded Framework (SWCEF)：
    administrative_image_directory\swcef\CEF for SOLIDWORKS Applications.msi.
  7. 安裝 SOLIDWORKS Login Manager：
    administrative_image_directory\swloginmgr\SOLIDWORKS Login Manager.msi.
上層主題 準備客戶端以便從管理安裝點進行指令列安裝


使用指令列從管理安裝點安裝

您可以部署使用指令列從管理安裝點安裝。

無訊息安裝：

  1. 開啟「命令提示字元」視窗 (在 Windows 中，按一下開始 > 執行)。
  2. 輸入 msiexec.exe 指令以及 /i 和 /qb 選項，然後指定非如下所示之預設值的任何選項屬性。

    msiexec /i "administrative_image_directory\64bit\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\your_folder /qb

個別安裝零組件指令列屬性包括：
  • 命令列功能屬性
  • 指令列整體屬性
  • eDrawings 指令列屬性
  • SOLIDWORKS Flow Simulation 指令列屬性

使用下列的範例做為無訊息安裝的範本。

SOLIDWORKS 客戶端

  • SOLIDWORKS 核心 (英文)
  • Toolbox 附加程式
  • 參予回饋計畫
  • 法文

SOLIDWORKS：

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=4 ADDLOCAL=SolidWorks, SolidWorksToolbox TOOLBOXFOLDER="toolbox path for example C:\SolidWorks Data\" /qb

SOLIDWORKS 法文安裝元件必須單獨安裝：

msiexec /i "administrative_image_directory\64bit\SOLIDWORKS French\french.msi" /qb

在指定 SOLIDWORKS 語言元件安裝指令時，不要指定指令列引數。

eDrawings 客戶端

  • 所有特徵

msiexec /i
            "administrative_image_directory\64bit\eDrawings\eDrawings.msi"
          INSTALLDIR="C:\Program Files\your_folder"
            SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst
          ADDLOCAL=All /qb

SOLIDWORKS Electrical

由於同時安裝 SOLIDWORKS Electrical 與 Microsoft SQL Server 在技術上較為複雜，因此會從文件中排除 SOLIDWORKS Electrical 的指令列範例。

SOLIDWORKS Visualize 和 Visualize Boost

針對 SOLIDWORKS Visualize：

msiexec. /i “administrative_image_directory\64bit\SOLIDWORKS Visualize.msi” ACTIVSERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize” /qb

針對 SOLIDWORKS Visualize Boost：

msiexec /i “administrative_image_directory\64bit\SOLIDWORKS Visualize Boost.msi” ACTVISERIALNUMBER=”1234123412341234ABCDEFGH” INSTALLDIR=”C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost” /qb

上層主題 命令列部署
準備客戶端以便從管理安裝點進行指令列安裝
命令列屬性
使用 Microsoft Active Directory 部署管理安裝點


命令列屬性

此處描述的命令列屬性包括特徵屬性、整體屬性、產品指定屬性和 Windows 位置慣例。

目錄

  • 命令列功能屬性

    SOLIDWORKS 安裝支援指令列部署的這些 ADDLOCAL 屬性。

  • 指令列整體屬性

    除非另有說明，每個屬性是為系統管理安裝或單機安裝而定義。使用整體屬性，序號可以同時傳至系統管理安裝及單機安裝。

  • eDrawings 指令列屬性

    這些命令列屬性是 eDrawings ® 所特有的。

  • SOLIDWORKS Composer/Composer Player 指令列屬性

    這些指令列屬性是 SOLIDWORKS Composer 和 SOLIDWORKS Composer Player 所特有的。

  • SOLIDWORKS Flow Simulation 指令列屬性

    這些指令列屬性是 SOLIDWORKS Flow Simulation 所特有的。

  • SOLIDWORKS Inspection 命令列屬性

    這些命令列屬性是 SOLIDWORKS Inspection 所特有的。

  • SOLIDWORKS Visualize 命令列屬性

    這些命令列屬性是 SOLIDWORKS Visualize 所特有的。

  • 管理安裝點的 MSI 檔案位置

    為了從命令列產生管理安裝點，產品元件 .msi 檔案儲存在 SOLIDWORKS 媒體中的這些位置。

上層主題 命令列部署
準備客戶端以便從管理安裝點進行指令列安裝
使用指令列從管理安裝點安裝
使用 Microsoft Active Directory 部署管理安裝點


命令列功能屬性

SOLIDWORKS 安裝支援指令列部署的這些 ADDLOCAL 屬性。

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • ScanTo3D
  • Simulation
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
為命令列安裝指定屬性時：
  • SOLIDWORKS 未支援使用 ADDSOURCE 選項安裝產品。
  • 屬性需注意大小寫，不能包含空格或破折號，且必須用逗點分開。
上層主題 命令列屬性
指令列整體屬性
eDrawings 指令列屬性
SOLIDWORKS Composer/Composer Player 指令列屬性
SOLIDWORKS Flow Simulation 指令列屬性
SOLIDWORKS Inspection 命令列屬性
SOLIDWORKS Visualize 命令列屬性
管理安裝點的 MSI 檔案位置


指令列整體屬性

除非另有說明，每個屬性是為系統管理安裝或單機安裝而定義。使用整體屬性，序號可以同時傳至系統管理安裝及單機安裝。

屬性 | 說明
ENABLEPERFORMANCE 應用程式是否應自動傳送效能資料至 SOLIDWORKS Corporation。

1

傳送效能資料。

0

不要傳送效能資料。
INSTALLDIR | SOLIDWORKS 的安裝資料夾。
MBDSERIALNUMBER | SOLIDWORKS 模型定義產品的序號。
MOTIONSERIALNUMBER | SOLIDWORKS Motion 產品的序號。
OFFICEOPTION 指定要安裝的產品套件：
0 | SOLIDWORKS Standard
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
4 | SOLIDWORKS Ultimate
REINSTALL 指定 所有 (ALL) 以更新目前安裝的所有功能。
只有在更新為現有主要版本中的 Service Pack 版本時，才指定此屬性 (例如，將現有的 SOLIDWORKS 2025 SP01 安裝更新為 SOLIDWORKS 2025 SP02)。
REINSTALLMODE Microsoft Installer 重新安裝選項。

例如，將安裝從一個 Service Pack 版本升級至相同主要版本中的另一個版本時，應指定 REINSTALLMODE=vomus。

如需 REINSTALLMODE 設定的詳細資訊，請參閱 www.microsoft.com 上的 Windows Installer 文件。

只有在更新為現有主要版本中的 Service Pack 版本時，才指定此屬性 (例如，將現有的 SOLIDWORKS 2025 SP01 安裝更新為 SOLIDWORKS 2025 SP02)。第一次安裝新的 SOLIDWORKS 主要版本時，不要指定此屬性。
SERVERLIST SolidNetWork 伺服器清單。
SolidNetWork 伺服器清單是一個以分隔符號分隔字串的清單，每個字串都代表伺服器上的一個連接埠號碼，其格式為：
  • 三合一 (以逗號分隔) =xxxxx@server_name1,yyyyy@server_name2,zzzzz@server_name3
  • 非三合一 (以分號分隔) = xxxxx@server_name1;yyyyy@server_name2;zzzzz@server_name3
X 和 Y 為一個數字。 請勿在清單中的最後一個伺服器之後輸入分隔符號。
SIMULATIONSERIALNUMBER | SOLIDWORKS Simulation 產品的序號。
SOLIDWORKSSERIALNUMBER | 包括所有附加程式在內的 SOLIDWORKS 產品的序號。
SWMIGRATE 要升級的 SOLIDWORKS 版本，顯示方式與在SOLIDWORKS 安裝選擇對話方塊內的清單上相同。例如：

SWMIGRATE="SOLIDWORKS 2025 x64 Edition SP01"

僅當目前已安裝有舊主要版本而又要安裝新主要版本時，才指定此屬性。將一個 Service Pack 版本升級至同一主要版本中的另一個版本時，不要指定此屬性。
TOOLBOXFOLDER SOLIDWORKS Toolbox 檔案的安裝資料夾。

例如： TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

如果環境具有 PDM 或共用 Toolbox/異形孔精靈位置，您可以使用 NOTTOOLBOXSETUP 屬性指定客戶端安裝，以不在該位置安裝或升級 Toolbox 資料。指定：

0 | 安裝 Toolbox 檔案。
1 | 不安裝 Toolbox 檔案。
TRANSFORMS 包含語言特定的形式項目：
TRANSFORMS number.mst
  • 中文 (1028)
  • 簡體中文 (2052)
  • 捷克文 (1029)
  • 英文 (1033)
  • 法文 (1036)
  • 德文 (1031)
  • 義大利文 (1040)
  • 日文 (1041)
  • 韓文 (1042)
  • 波蘭文 (1045)
  • 巴西葡萄牙文 (1046)
  • 俄文 (1049)
  • 西班牙文 (1034)
  • 土耳其文 (1055)
UPGRADESWINSTALL
指定是否將現有的 SOLIDWORKS 版本升級為目前的版本。
0 | 新的安裝，不更新。
1 | 更新
僅當目前已安裝有舊主要版本而又要安裝新主要版本時，才指定此屬性。 當您將一個 Service Pack 版本升級至同一主要版本中的另一個版本時，不要指定此屬性。
上層主題 命令列屬性
命令列功能屬性
eDrawings 指令列屬性
SOLIDWORKS Composer/Composer Player 指令列屬性
SOLIDWORKS Flow Simulation 指令列屬性
SOLIDWORKS Inspection 命令列屬性
SOLIDWORKS Visualize 命令列屬性
管理安裝點的 MSI 檔案位置


eDrawings 指令列屬性

這些命令列屬性是 eDrawings ® 所特有的。

屬性 | 描述
ADDLOCAL 指定要安裝哪些部分的 eDrawings 應用程式。
All 是建議的選項。
指令列語法 | 特徵
All | 安裝所有的功能。eDrawings 應用程式會搜尋已安裝的 SOLIDWORKS 及 AutoCAD Publisher 應用程式來查驗安裝的有效性。
CALS | 以 eDrawings Viewer 檢視 CAL 檔案
Inventor | 從 Autodesk Inventor 應用程式產生 eDrawings 檔案。
eDrawingsViewer | 檢視 eDrawings 及其他檔案。
ProE | 使用 eDrawings Viewer 檢視 ProE 檔案
DXFDWGTranslator | 以 eDrawings Viewer 檢視 DXF/DWG 檔案。
Shortcuts | 安裝桌面捷徑。
XML3D | 以 eDrawings Viewer 檢視 3DXML 檔案。
INSTALLDIR | 指定下列項目的安裝資料夾 eDrawings
SNLSERVER 輸入 SolidNetWork License 伺服器的 連接埠@伺服器名稱 。使用分號來分隔多個 連接埠@伺服器名稱 組合。

只有 SOLIDWORKS SNL 伺服器模型組態才需要 SNLSERVER 和 SERVERLIST 的連接埠伺服器名稱。

SolidNetWork 伺服器清單是一個以分隔符號分隔字串的清單，每個字串都代表伺服器上的一個連接埠號碼，其格式為：
  • 三度空間參考 (頓號分隔)

    = xxxx@server_name1、yyyy@server_name2、zzzz@server_name3

  • 非三度空間參考 (分號分隔)

    = xxxx@server_name1；yyyy@server_name2；zzzz@server_name3

X 和 Y 為一個數字。在清單中的最後一個伺服器之後，不要輸入分號 (;)。
上層主題 命令列屬性
命令列功能屬性
指令列整體屬性
SOLIDWORKS Composer/Composer Player 指令列屬性
SOLIDWORKS Flow Simulation 指令列屬性
SOLIDWORKS Inspection 命令列屬性
SOLIDWORKS Visualize 命令列屬性
管理安裝點的 MSI 檔案位置


SOLIDWORKS Composer/Composer Player 指令列屬性

這些指令列屬性是 SOLIDWORKS Composer 和 SOLIDWORKS Composer Player 所特有的。

若是 SOLIDWORKS Composer：

屬性 | 描述
ACTIVSERIALNUMBER | SOLIDWORKS Composer 序號。
ACTIVSERIALNUMBERPLAYERPRO | 選擇使用。 SOLIDWORKS Composer Player Pro 序號。
ADDLOCAL 選擇使用。如果您安裝完整的應用程式，您便不需要指定 ADDLOCAL 屬性。
如需自訂安裝，請使用含下列必要項目的 ADDLOCAL：
  • Licensing
  • CLOSA
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
您也可以使用含 Sync3Dvia 的 ADDLOCAL，但並非必要。
INSTALLDIR | 指定 SOLIDWORKS Composer 軟體的安裝資料夾。

若是 SOLIDWORKS Composer Player：

屬性 | 描述
ACTIVSERIALNUMBERPLAYERPRO | 選擇使用。 SOLIDWORKS Composer Player Pro 序號。
INSTALLDIR | 指定 SOLIDWORKS Composer Player 軟體的安裝資料夾。
在沒有安裝 SOLIDWORKS 的機器上，您必須使用 SOLIDWORKS Translator 來將 SOLIDWORKS 檔案輸入至 SOLIDWORKS Composer 中。 您必須使用 SOLIDWORKS 安裝管理員來部署 SOLIDWORKS Translator，您不能使用命令列。
上層主題 命令列屬性
命令列功能屬性
指令列整體屬性
eDrawings 指令列屬性
SOLIDWORKS Flow Simulation 指令列屬性
SOLIDWORKS Inspection 命令列屬性
SOLIDWORKS Visualize 命令列屬性
管理安裝點的 MSI 檔案位置


SOLIDWORKS Flow Simulation 指令列屬性

這些指令列屬性是 SOLIDWORKS Flow Simulation 所特有的。

屬性 | 描述
ACTIVSERIALNUMBER SOLIDWORKS Flow Simulation 單機序號。

（來自管理安裝點的單機安裝及客戶端安裝）
CWUPGRADEINSTALL 升級 SOLIDWORKS Flow Simulation 應用程式軟體的現有版本。
1 | 更新
2 | 新安裝；安裝在新目錄中

（來自管理安裝點的單機安裝及客戶端安裝）
INSTALLDIR 指定特定 SOLIDWORKS Flow Simulation 應用程式軟體的安裝。

(僅單機安裝)
SERVERLIST | 是以分號分隔的字串清單，每個字串代表的是伺服器上的連接埠號碼，其格式為： xxxxx@server_name1; yyyyy@server_name2;& 其中 x 和 y 是單一位數。 在清單中的最後一個伺服器之後，不要輸入分號 (;)。
SOLIDWORKSPATH 指定安裝 SOLIDWORKS 軟體的資料夾。

（來自管理安裝點的單機安裝及客戶端安裝）
上層主題 命令列屬性
命令列功能屬性
指令列整體屬性
eDrawings 指令列屬性
SOLIDWORKS Composer/Composer Player 指令列屬性
SOLIDWORKS Inspection 命令列屬性
SOLIDWORKS Visualize 命令列屬性
管理安裝點的 MSI 檔案位置


SOLIDWORKS Inspection 命令列屬性

這些命令列屬性是 SOLIDWORKS Inspection 所特有的。

屬性 | 說明
ACTIVSERIALNUMBER | SOLIDWORKS Inspection 序號。 （來自管理安裝點的單機安裝及客戶端安裝）
INSTALLDIR | 指定安裝 SOLIDWORKS Inspection 應用程式軟體。 (僅單機安裝)
SERVERLIST | 是以分號分隔的字串清單，每個字串代表的是伺服器上的連接埠號碼，其格式為： xxxxx@server_name1; yyyyy@server_name2;& 其中 x 和 y 是單一位數。 在清單中的最後一個伺服器之後，不要輸入分號 (;)。
上層主題 命令列屬性
命令列功能屬性
指令列整體屬性
eDrawings 指令列屬性
SOLIDWORKS Composer/Composer Player 指令列屬性
SOLIDWORKS Flow Simulation 指令列屬性
SOLIDWORKS Visualize 命令列屬性
管理安裝點的 MSI 檔案位置


SOLIDWORKS Visualize 命令列屬性

這些命令列屬性是 SOLIDWORKS Visualize 所特有的。

屬性 | 描述
ACTIVSERIALNUMBER | SOLIDWORKS Visualize 序號。 (來自管理安裝點的單機安裝及客戶端安裝)
INSTALLDIR | 指定 SOLIDWORKS Visualize 應用程式軟體的安裝。 (僅單機安裝)
SERVERLIST | 是以分號分隔的字串清單，每個字串代表的是伺服器上的連接埠號碼，其格式為： xxxxx@server_name1; yyyyy@server_name2;& 其中 x 和 y 是單一位數。 在清單中的最後一個伺服器之後，不要輸入分號 (;)。
上層主題 命令列屬性
命令列功能屬性
指令列整體屬性
eDrawings 指令列屬性
SOLIDWORKS Composer/Composer Player 指令列屬性
SOLIDWORKS Flow Simulation 指令列屬性
SOLIDWORKS Inspection 命令列屬性
管理安裝點的 MSI 檔案位置


管理安裝點的 MSI 檔案位置

為了從命令列產生管理安裝點，產品元件 .msi 檔案儲存在 SOLIDWORKS 媒體中的這些位置。

SOLIDWORKS (核心產品，英文)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (非英文元件)

繁體中文 | swwi\lang\chinese\chinese.msi
簡體中文 | swwi\lang\chinese-simplified\chinese-simplified.msi
捷克文 | swwi\lang\czech\czech.msi
法文 | swwi\lang\french\french.msi
德文 | swwi\lang\german\german.msi
義大利文 | swwi\lang\italian\italian.msi
日文 | swwi\lang\japanese\japanese.msi
韓文 | swwi\lang\korean\korean.msi
波蘭文 | swwi\lang\polish\polish.msi
巴西葡萄牙文 | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
俄文 | swwi\lang\russian\russian.msi
西班牙文 | swwi\lang\spanish\spanish.msi
土耳其文 | swwi\lang\turkish\turkish.msi

DocManager API

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

3DExperience Marketplace for SOLIDWORKS

marketplace\3dexperience marketplace.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS Composer

swComposer\SOLIDWORKS Composer.msi

SOLIDWORKS Composer Player

swComposerPlayerSOLIDWORKS Composer Player.msi

SOLIDWORKS Electrical

swelectric\SOLIDWORKS Electrical.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS Manage 客戶端

SWManageClient\SOLIDWORKS Manage Client.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional 雖然提供 API ，但僅適用於客戶端，無法在 .msi 檔案中的使用。 如需相關資訊，請參閱 SOLIDWORKS PDM 客戶端 install\API 目錄中的 API 指南。

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Visualize

visualize\SOLIDWORKS Visualize.msi

SOLIDWORKS Visualize Boost

visualizeboost\SOLIDWORKS Visualize Boost.msi
上層主題 命令列屬性
命令列功能屬性
指令列整體屬性
eDrawings 指令列屬性
SOLIDWORKS Composer/Composer Player 指令列屬性
SOLIDWORKS Flow Simulation 指令列屬性
SOLIDWORKS Inspection 命令列屬性
SOLIDWORKS Visualize 命令列屬性


使用 Microsoft Active Directory 部署管理安裝點

Microsoft Active Directory Deployment 支援 SOLIDWORKS 核心產品對客戶端的部署。

Microsoft Active Directory 是一個用來管理網路環境中的客戶端及伺服端的目錄服務。它可以簡化管理、移轉及部署。

如需透過 Microsoft Active Directory 安裝 SOLIDWORKS 的相關資訊，請聯絡您的經銷商。

上層主題 命令列部署
準備客戶端以便從管理安裝點進行指令列安裝
使用指令列從管理安裝點安裝
命令列屬性


多個安裝的管理

在多個安裝中，管理工作包括將管理安裝點升級至新的版本，套用 service pack 更新以及移除安裝。

目錄

  • 升級管理安裝點至新版本

    若要更新從管理安裝點安裝的客戶端，請先更新管理安裝點，然後組態客戶端以參考安裝點的新副本。

  • Service Pack 產品更新管理

    Service Pack 產品更新可以包含對系統穩定性、程式相容性、安全性等的更新。

  • 移除安裝

    您可以移除在個別電腦或是在客戶端/伺服端環境中的安裝。

上層主題 多個安裝
部署至多個客戶端
使用管理安裝點
命令列部署


升級管理安裝點至新版本

若要更新從管理安裝點安裝的客戶端，請先更新管理安裝點，然後組態客戶端以參考安裝點的新副本。

從 SOLIDWORKS 下載頁面執行 SOLIDWORKS 安裝管理員，以便參考正確的檔案。

一旦您更新管理安裝點 (會產生安裝點的新副本)，您可以讓客戶端參考管理安裝點的新副本來更新客戶端。

如果客戶端使用共用的目錄來參考之前版本的管理安裝點，您可以使用更新的管理安裝點位置來重新定義共用目錄。

目錄

  • 為管理安裝點下載更新的安裝檔

    在升級管理安裝點時，SOLIDWORKS 安裝管理員可以幫您偵測您是否需要更新的安裝檔。

  • 升級管理安裝點

    若要升級管理安裝點，SOLIDWORKS 安裝管理員會產生一個新的安裝點目錄。 接著您可以指定客戶端使用新的管理安裝點目錄以升級至該產品版本。

  • 從管理安裝點升級客戶端

    SOLIDWORKS 安裝管理員可以自動從管理安裝點升級客戶端電腦。

上層主題 多個安裝的管理
Service Pack 產品更新管理
移除安裝


為管理安裝點下載更新的安裝檔

在升級管理安裝點時，SOLIDWORKS 安裝管理員可以幫您偵測您是否需要更新的安裝檔。

  1. 啟動 SOLIDWORKS 安裝管理員。
  2. 在歡迎畫面中，選擇管理安裝點。
  3. 在序號畫面中輸入 SOLIDWORKS 序號。
    SOLIDWORKS 安裝管理員會檢查 SOLIDWORKS 網站是否有您獲授權可使用的產品及可用的 service pack。
  4. 如果出現有較新版本可用畫面，請選擇是，下載及安裝較新的版本：版本。
    SOLIDWORKS 安裝管理員會啟動一個新的工作階段來安裝較新的版本。
  5. 如果下載資料夾發生問題，可能會顯示下載選項。如果下載選項顯示，請接受新安裝檔案的預設目錄或是輸入新的目錄名稱。
    如果出現目錄不存在的訊息，請按一下是來產生目錄。
  6. 在下載完成畫面上，按一下關閉以關閉目前的安裝程式，並啟動新版本的安裝程式。
上層主題 升級管理安裝點至新版本
升級管理安裝點
從管理安裝點升級客戶端


升級管理安裝點

若要升級管理安裝點，SOLIDWORKS 安裝管理員會產生一個新的安裝點目錄。 接著您可以指定客戶端使用新的管理安裝點目錄以升級至該產品版本。

此程序會假設您已經為管理安裝點下載更新的安裝檔。詳細資訊請參閱為管理安裝點下載更新的安裝檔。

  1. 啟動 SOLIDWORKS 安裝管理員。
  2. 在歡迎畫面中，選擇管理安裝點。
    管理安裝點的產生選項出現。
    選項 | 敘述
    使用預設的設定產生一個新的安裝點。 | 使用預設的組態設定產生安裝點 (即不根據您的站點之現有管理安裝點所建立的設定。)
    使用來自現有安裝點的設定及檔案來產生一個新的安裝點。 | 使用為您所在站點之現有管理安裝點指定的組態設定產生安裝點。 按一下瀏覽為現有的管理安裝點指定安裝目錄。
  3. 在序號畫面中檢查序號。
  4. 在摘要 (已準備好產生安裝點) 畫面中，檢查管理安裝點選項是否正確。
    如需有關個別管理安裝點與安裝選項的詳細資訊，請按一下變更進入選項頁，然後按一下說明。
  5. 若要產生管理安裝點的新版本，請按一下現在產生。

您現在可以升級客戶端為管理安裝點的新版本。詳細資訊請參閱從管理安裝點升級客戶端。

上層主題 升級管理安裝點至新版本
為管理安裝點下載更新的安裝檔
從管理安裝點升級客戶端


從管理安裝點升級客戶端

SOLIDWORKS 安裝管理員可以自動從管理安裝點升級客戶端電腦。

管理安裝點通常安排在一個伺服器的資料夾中。要支援客戶端的自動升級，管理安裝點必須位於共用的資料夾中。

在升級管理安裝點之後，原始的安裝會在一個資料夾中，而升級的安裝在另一個資料夾中。要使用升級的安裝，您必須先從原始的管理安裝點資料夾中移除共用的選項，然後將共用的選項加入至升級的管理安裝點資料夾中。

從原始管理安裝點安裝的 SOLIDWORKS 在客戶端機器上啟動時，其會發現新的版本並升級客戶端。
此外，當 SOLIDWORKS 觸發更新時，從管理安裝點安裝的其他產品將會自動更新。
上層主題 升級管理安裝點至新版本
為管理安裝點下載更新的安裝檔
升級管理安裝點

從原始的管理安裝點資料夾中移除共用的選項

在升級從共用資料夾存取的管理安裝點時，您必須從原始資料夾中移除共用的選項。

  1. 瀏覽至原始管理安裝點檔案所在的資料夾。
  2. 用右鍵按一下資料夾並選擇內容。
  3. 在共用標籤中選擇不共用此資料夾，然後按一下確定。

現在將共用的選項加入至升級的管理安裝點資料夾中，如將共用選項新增至升級的管理安裝點資料夾中所述。

將共用選項新增至升級的管理安裝點資料夾

一旦您產生了更新的管理安裝點資料夾並且停用原始管理安裝點資料夾的共用，您必須將共用選項新增至新資料夾以便重新啟用管理安裝點。

  1. 瀏覽至升級的管理安裝點檔案所在的資料夾。
  2. 用右鍵按一下資料夾並選擇內容。
  3. 在共用的標籤中，指定您組織或群組的共用屬性，並變更共用的名稱為原始管理安裝點資料夾使用的名稱。
啟動 SOLIDWORKS 時，從原始管理安裝點共用位置安裝項目的電腦將會自動升級為新的版本。


Service Pack 產品更新管理

Service Pack 產品更新可以包含對系統穩定性、程式相容性、安全性等的更新。

您可以以兩種方式獲得產品更新：
  • 透過使用 SOLIDWORKS 安裝管理員檢查、下載與安裝更新。

    您可以手動啟動 SOLIDWORKS 安裝管理員，或將其排定為定期檢查更新。

  • 從 SOLIDWORKS 支援網站手動下載 Service Pack。

    Service packs 是以修補（patches）的方式套用至現有的軟體版本上。例如，SOLIDWORKS 2025 SP1.0 是 SOLIDWORKS 2025 SP0.0 的 Service Pack。您可以使用 SOLIDWORKS 2025 安裝管理員安裝這些 Service Pack，但無法在 SOLIDWORKS 2024 中使用 SOLIDWORKS 安裝管理員進行安裝。

    關於下載及安裝 Service Pack 的說明，請參閱您要更新 SOLIDWORKS 版本的安裝文件。

目錄

  • 以管理安裝點回溯 Service Pack

    您可以將管理安裝點回溯至之前安裝的 service pack。 如果您使用磁碟片來安裝 SOLIDWORKS 軟體，您需要原始的磁碟才能復原 service pack。 您必須已儲存了較早管理安裝點影像的複製。

上層主題 多個安裝的管理
升級管理安裝點至新版本
移除安裝


以管理安裝點回溯 Service Pack

您可以將管理安裝點回溯至之前安裝的 service pack。 如果您使用磁碟片來安裝 SOLIDWORKS 軟體，您需要原始的磁碟才能復原 service pack。 您必須已儲存了較早管理安裝點影像的複製。

已被升級的管理安裝點不能回溯至前一個 service pack。 以 SOLIDWORKS 安裝管理員以外的任何方法產生的管理安裝點無法被回溯至之前的版本。 必須先解除安裝從這些管理安裝點安裝的客戶端，然後再使用從先前版本產生的管理安裝點重新安裝。
  1. 刪除包含目前管理安裝點的資料夾。要執行此操作，請開啟命令提示字元視窗並輸入：
    rmdir /s/q 至目前管理安裝點的路徑
  2. 將管理安裝點的備份副本移至您剛才刪除的目前管理安裝點的所在位置。要執行此操作，請開啟命令提示字元視窗並輸入：
    move 至備份管理安裝點的路徑 至目前管理安裝點的路徑
    在您回溯管理安裝點之後，下一次客戶端電腦執行 SOLIDWORKS 軟體時，就會自動回溯。
上層主題 Service Pack 產品更新管理


SOLIDWORKS PDM 和 SOLIDWORKS Manage

SOLIDWORKS PDM 是基於客戶端/伺服器架構 (前稱為 SOLIDWORKS Enterprise PDM) 的文件管理產品。 SOLIDWORKS PDM 有兩種類型：
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM 會使用 Microsoft SQL Server 資料庫來管理檔案資料保險箱。

此表格列出每種產品類型可用的資料庫系統、伺服器零組件及客戶端選項。
 | PDM Standard | PDM Professional
專門針對以下配置而設計： | 中小型辦公室網路，一般有少於 20 位的同時使用者。 | 大型辦公室網路，大量同時使用的使用者
限制 | 1 插槽或 4 核心中較少者，1 GB 的 RAM，而且資料庫大小為 10 GB | SQL 標準限制：4 插槽或 16 核心中較少者，128 GB 的 RAM，而且資料庫大小為 524 PB
資料庫管理系統 | Microsoft SQL Server Express 2019 或以上版本，最高至 2022。 | Microsoft SQL Server 2019 或以上版本，最高至 2022。
是否需要啟動 SolidNetWork License Manager？ | 有 | 有
是否包括保存檔伺服器與資料庫伺服器？ | 有 | 有
是否包括 SOLIDWORKS PDM Web2 伺服器和 WebAPI 伺服器？ | 無 | 有
客戶端類型 | 原始 | 原始、以瀏覽器為基礎
CAD Editor 的客戶端附加程式 | SOLIDWORKS、DraftSight | SOLIDWORKS、DraftSight、Microsoft Office 整合
Contributor 的客戶端附加程式 | DraftSight | DraftSight、Microsoft Office 整合
Viewer 的客戶端附加程式 |  | Microsoft Office 整合

SOLIDWORKS Manage Professional 會為 SOLIDWORKS PDM Professional 提供進階的資料管理工具。 其提供進階版本控制、專案、程序及品項管理等功能。 互動式儀表板和報告可協助您追蹤品項、活動以及完成專案的進度。

SOLIDWORKS Manage Professional 的架構與 SOLIDWORKS PDM Professional 類似。其使用客戶端-伺服端架構，搭配 Microsoft SQL Server 資料庫來管理項目與專案資料。針對資料庫、檔案伺服器與 Web 伺服器功能提供三種服務，可支援厚實型客戶端與 Web 瀏覽器客戶端。您可在相同伺服器或不同伺服器上主控這三種服務。如果使用者具備 SOLIDWORKS Manage Professional Editor 使用許可，便可使用 SOLIDWORKS Manage 附加程式直接存取 SOLIDWORKS 中的 Manage 資料。

您可以使用 SOLIDWORKS 安裝管理員來安裝 SOLIDWORKS Manage Professional 伺服器與客戶端。

如需安裝 SOLIDWORKS Manage Professional 的指示，請參閱 SOLIDWORKS PDM/SOLIDWORKS Manage 安裝指南。

目錄

  • PDM 伺服器元件的清單

  • 瞭解 PDM 客戶端之間的差異

    安裝客戶端軟體之前，您必須根據您的 PDM 環境決定所需的客戶端。

  • 安裝 PDM Server 之前

    安裝 PDM 伺服器元件之前，請先記住這些需求條件：

  • 使用 SOLIDWORKS 安裝管理員安裝 PDM 伺服器

    當您安裝 PDM Standard 的 PDM 伺服器時，您可以在相同的機器上安裝保存檔伺服器、資料庫伺服器及 PDM CAD Editor 客戶端。 您不需要個別執行客戶端安裝。

  • 使用 SOLIDWORKS 安裝管理員安裝 PDM 客戶端


PDM 伺服器元件的清單

下表摘要描述 SOLIDWORKS PDM Server 的伺服器零組件。

伺服器 | 函數 | 安裝
適用於 PDM Standard 的 Microsoft SQL Server Express | 管理 SOLIDWORKS PDM 資料之資料保險箱中的資料。 | 可與 PDM Standard 一併安裝，或使用先前授權和安裝的版本。
適用於 PDM Professional 的 Microsoft SQL Server | 管理 SOLIDWORKS PDM 資料之資料保險箱中的資料。 | 必須使用。 您也可以使用先前授權和安裝的版本。
SolidNetWork License Manager 客戶端 | 管理 SOLIDWORKS PDM 的使用許可。 | 必須先安裝才能產生新的資料保險箱。 使用 SOLIDWORKS 安裝管理員時，能與 SOLIDWORKS PDM 伺服器零組件一同安裝。
保存檔伺服器 | 管理客戶端與檔案資料保險箱保存檔之間的檔案轉移，並管理使用者及其認證。 | 必須使用。 與 PDM Standard 或 Professional 一併安裝。
資料庫伺服器 | 輪詢 PDM 資料庫是否有更新、管理資料輸入與輸出規則、管理訊息系統，以及排程複製和冷藏。 | 必須使用。 與 PDM Standard 或 Professional 一併安裝。
Web2 伺服器 | 可讓您透過網際網路從以瀏覽器為基礎的客戶端存取檔案資料保險箱。 | 選擇使用。 僅與 PDM Professional 一併安裝。
Web API 伺服器 | EXALEAD OnePart 使用者可使用 Web API 伺服器來建立索引和復取 SOLIDWORKS PDM 資料。 | 選擇使用。 僅與 PDM Professional 一併安裝。

保存檔伺服器會在安裝所在的電腦系統帳戶上以服務的方式執行。 一部保存檔伺服器可以在同一台電腦上主控多個檔案資料保險箱。

在獨立的安裝中，保存檔伺服器、資料庫伺服器、使用許可伺服器及 Web API 伺服器，以及 SQL Express 或 SQL Server 資料庫，都可以在同一台機器上進行安裝。

在分散式環境中，伺服器的零組件可以位在不同的機器上。 SOLIDWORKS PDM Professional 也支援複製檔案資料保險箱保存檔及 SQL 伺服器資料庫，以改善在遠端位置的效能。 如需詳細資訊，請參閱 SOLIDWORKS PDM Professional 複製指南。

上層主題 SOLIDWORKS PDM 和 SOLIDWORKS Manage


瞭解 PDM 客戶端之間的差異

安裝客戶端軟體之前，您必須根據您的 PDM 環境決定所需的客戶端。

此表格摘要描述 SOLIDWORKS PDM Standard 的客戶端：
Standard 客戶端類型 | 說明
CAD Editor | 支援處理 SOLIDWORKS、DWG/DXF 格式、Microsoft Word 和 Microsoft Excel 檔案。Office 外掛程式處理的所有檔案格式，其運作方式與在 SOLIDWORKS PDM Standard 中相同，但預覽功能除外。
貢獻者 | 支援處理 SOLIDWORKS、DWG/DXF 格式、Microsoft Word 和 Microsoft Excel 檔案。
Viewer | 允許以唯讀方式存取檔案資料保險箱。使用者可以透過工作流程轉換檔案，但無法新增或修改 (取出、存回、更新值) 檔案。
此表格摘要描述 SOLIDWORKS PDM Professional 的客戶端：
Professional 客戶端類型 | 說明
CAD Editor & Web | 支援處理所有檔案類型，包括增強管理與預覽 CAD 格式，如 SOLIDWORKS。CAD 附加程式可讓使用者從 CAD 應用程式中存取 SOLIDWORKS PDM Professional。遠端使用者可使用 Web2 客戶端，透過網際網路搜尋資料保險箱並執行基本功能。
Contributor & Web | 支援處理所有檔案類型，包括 CAD 檔案。然而，此客戶端類型不支援 CAD 附加程式。遠端使用者可使用 Web2 客戶端，透過網際網路搜尋資料保險箱並執行基本功能。
Viewer | 允許以唯讀方式存取檔案資料保險箱。 使用者可以透過工作流程轉換檔案，但無法新增或修改 (取出、存回、更新值) 檔案或使用 CAD 附加程式。
上層主題 SOLIDWORKS PDM 和 SOLIDWORKS Manage


安裝 PDM Server 之前

安裝 PDM 伺服器元件之前，請先記住這些需求條件：

  • 取得您要安裝伺服器和客戶端之機器的完整管理權限。
  • 確定資料庫伺服器可透過 TCP 連接埠 3030 存取保存檔伺服器，並可透過 TCP 連接埠 1433 存取 SQL Server</Z1>。</Z2>
  • 如果您要使用現有的 QL Server Express 或 SQL Server 資料庫，請取得 SQL Server 資料庫的名稱及 SQL Server 系統管理員或具有資料庫讀取/寫入存取權限之資料庫擁有者的帳戶 ID 和密碼。 您無法使用 tew 使用者。
  • 如果 PDM 客戶端已經安裝在系統上，請解除安裝。 如果您要 PDM 伺服器與 PDM 客戶端均位在相同的系統上，您可以從 SOLIDWORKS 安裝管理員的伺服器產品頁面安裝這兩個項目。
上層主題 SOLIDWORKS PDM 和 SOLIDWORKS Manage


使用 SOLIDWORKS 安裝管理員安裝 PDM 伺服器

當您安裝 PDM Standard 的 PDM 伺服器時，您可以在相同的機器上安裝保存檔伺服器、資料庫伺服器及 PDM CAD Editor 客戶端。 您不需要個別執行客戶端安裝。

安裝 PDM Professional 的 PDM 伺服器時，您可以包括這些零組件，並同時包括 Web2 伺服器和 Web API 伺服器。

若要安裝 PDM 伺服器及其零組件：

  1. 啟動 SOLIDWORKS 安裝管理員。
  2. 在歡迎頁面中，選擇伺服器產品，然後按一下下列項目：
    • 在此電腦上安裝SOLIDWORKS PDM Server 元件。
    • 在此電腦上安裝 SolidNetWork License Manager。

      如果這台電腦或其他電腦上已安裝 SolidNetWork License Manager，則不會顯示此選項。

  3. 如果顯示 SolidNetwork License Manager 選項頁面，請輸入序號並指定目錄的位置，然後按下一步。
  4. 依照系統警告的指示操作，然後按一下下一步。
  5. 在摘要頁面中，針對 SOLIDWORKS PDM Server 按一下變更。
  6. 在 SOLIDWORKS PDM Server 選項頁面中：
    1. 針對選擇伺服器產品，按一下 SOLIDWORKS PDM Standard 或 Professional。
    2. 針對安裝位置，按一下瀏覽來指定檔案路徑。
    3. 在選擇特徵中：
      1. 按一下保存檔伺服器、資料庫伺服器及客戶端，在同一台機器上安裝這些零組件。如果您是在分散式環境，您可以在另一部機器上執行安裝管理員來安裝保存檔伺服器與資料庫伺服器。
        • 如果已經在機器上安裝 PDM 客戶端，您必須取消此安裝並解除安裝用戶端。接著您可以執行 SOLIDWORKS 安裝管理員來一起安裝 PDM 伺服器與客戶端。
        • SOLIDWORKS PDM 客戶端零組件包含在 SOLIDWORKS PDM 伺服器安裝中，其中包括無法排除的品項 Explorer。
      2. 如果您安裝的是 PDM Professional，您也可以按一下 Web2 伺服器和 Web API 伺服器。
        如果您安裝的是 Web API 伺服器，您可為介於 0 和 65535 間的 HTTP 連接埠號碼指定一個值。預設值為 65453。
    4. 在 SQL Server 中，您可以安裝隨附於 PDM 伺服器 (適用於 PDM Standard 的 SQL Server Express) 之資料庫工具的新副本，也可以指定現有副本的資料庫名稱、使用者名稱及密碼。
      必須為 SOLIDWORKS PDM Professional 安裝 SQL Server 的完整版本。
    5. 按一下回到摘要。
  7. 在「摘要」頁面中，接受 SOLIDWORKS 使用許可協議書的條款，然後按一下馬上安裝。

    當 SOLIDWORKS 安裝管理員完成安裝時，保存檔伺服器組態工具就會啟動。 請遵循精靈的提示來設定保存檔伺服器。

若要設定、組態和疑難排解保存檔伺服器、資料庫伺服器、Web2 伺服器及 SQL Server 資料庫，請參閱 SOLIDWORKS PDM 安裝指南中的相關主題。

目錄

  • 修改 SOLIDWORKS PDM Server 安裝項目

上層主題 SOLIDWORKS PDM 和 SOLIDWORKS Manage


修改 SOLIDWORKS PDM Server 安裝項目

若要修改 SOLIDWORKS PDM Server 及其零組件等安裝項目，請使用 Windows「控制台」中的程式和功能。 您無法透過 SOLIDWORKS 安裝管理員 (SLDIM) 修改安裝的項目，即使這是您安裝 SOLIDWORKS PDM Server 的方式也沒辦法。

上層主題 使用 SOLIDWORKS 安裝管理員安裝 PDM 伺服器


使用 SOLIDWORKS 安裝管理員安裝 PDM 客戶端

SOLIDWORKS PDM Client 的主要版本必須與 SOLIDWORKS PDM Server 的主要版本相符。 安裝或升級 SOLIDWORKS PDM Client 時，請確定版本相符。

若要安裝 PDM 客戶端：

  1. 啟動 SOLIDWORKS 安裝管理員。
  2. 請在歡迎頁面上選擇安裝在此電腦上。
  3. 在「序號」頁面中，按一下下一步。
    SOLIDWORKS PDM 客戶端不需要個別序號。
  4. 依照系統警告的指示操作，然後按一下下一步。
  5. 在「摘要」頁面中，於產品之下，按一下變更。
  6. 在「產品選擇」頁面中，按一下選擇不同的套件或產品。
  7. 在「選擇您要顯示的套件」對話方塊中，選擇 SOLIDWORKS 的版本。然後按一下確定。
  8. 在「產品選擇」頁面中，選擇 SOLIDWORKS PDM 客戶端。 然後選擇 eDrawings 來啟用 PDM 預覽功能。 如果您使用的是 SOLIDWORKS PDM Professional，您也可以選擇品項 Explorer。
  9. 在摘要頁面中，展開 SOLIDWORKS PDM 選項並按一下變更。
  10. 在「SOLIDWORKS PDM 客戶端選項」頁面中，選擇下列項目，並按一下回到摘要：
    • PDM 產品類型
    • PDM 客戶端類型
    • 附加程式
  11. 在「摘要」頁面中，接受 SOLIDWORKS 使用許可協議書的條款，然後按一下馬上安裝。
系統管理員也可以使用管理安裝點選項編輯器來產生和部署 PDM 客戶端的影像。詳細資訊請參閱 使用管理安裝點。
上層主題 SOLIDWORKS PDM 和 SOLIDWORKS Manage


SOLIDWORKS Electrical

SOLIDWORKS 安裝管理員可讓您以獨立或客戶端/伺服器模式來安裝 SOLIDWORKS Electrical 的所有零組件。

SOLIDWORKS Electrical 可使用數種元件。在安裝期間，您必須依據您需要的安裝類型來選擇這些元件。
  • SOLIDWORKS Electrical Schematic - 2D 應用程式，可產生和管理電路圖。
  • SOLIDWORKS Electrical 3D - SOLIDWORKS 附加程式，可整合 2D 圖示與 3D 模型。SOLIDWORKS Electrical 3D 可讓您管理電氣裝置的配置，並設計配線、纜線和線束的線路。
  • 資料 -「資料」會為軟體所需的所有資料建立群組。此資料為圖形資料 (例如代表符號及標題圖塊的檔案) 或技術資料 (例如製造商目錄和符號相關資料)。您可共用資料，讓所有使用者都能加以存取。
  • Collaborative Server - 管理電路工程圖開啟和更新的公用程式。
  • SQL Server - SOLIDWORKS Electrical 需要 Microsoft SQL Server 資料庫。您可在安裝期間選擇要產生新資料庫或使用現有資料庫。

安裝類型

您可以在同一台機器上安裝所有 SOLIDWORKS Electrical 元件。此為獨立安裝。所有程式資料 (例如專案工程圖和報告) 會儲存在工作站上。

您也可以將 SOLIDWORKS Electrical 作為客戶端/伺服器應用程式來安裝。 如果您要在網路伺服器上儲存資料，請使用此類型的安裝。 客戶端/伺服器安裝可讓數位使用者使用相同的專案。 客戶端系統必須擁有連至伺服器的網路存取權，以及產生專案、資料庫及符號的讀取/寫入權限。

資訊

不論使用哪一個安裝類型 (獨立或客戶端/伺服器)，您都必須以完整權限模式來啟動 Windows 工作階段，才能安裝 SOLIDWORKS Electrical。

您只能在一台機器上安裝一個版本的 SOLIDWORKS Electrical。 如果您要安裝 SOLIDWORKS 並選擇 SOLIDWORKS Electrical 作為其中一個要安裝的產品，則安裝程式會移除舊版的 SOLIDWORKS Electrical。

啟動 SOLIDWORKS 安裝管理員時，它會自動偵測已安裝在工作站或伺服器上的現有 SOLIDWORKS Electrical 版本。

安裝新版本前，請務必先備份現有的 SOLIDWORKS Electrical 環境。 在 SOLIDWORKS Electrical Schematic 中選擇檔案 > 建立環境記錄檔，或在 SOLIDWORKS Electrical 3D 中選擇SOLIDWORKS Electrical > 工具 > 建立環境記錄檔。

目錄

  • 安裝 SOLIDWORKS Electrical 的需求

  • 獨立或客戶端/伺服器安裝

    SOLIDWORKS Electrical 有兩種安裝模式。在獨立模式中，是將軟體安裝在工作站。在客戶端/伺服器模式中，使用者共用資料。

  • 設定 Collaborative Server

  • 組態 Microsoft SQL Server

  • 指定資料位置


安裝 SOLIDWORKS Electrical 的需求

若要存取目前的系統需求，請參閱系統需求。

上層主題 SOLIDWORKS Electrical
獨立或客戶端/伺服器安裝
設定 Collaborative Server
組態 Microsoft SQL Server
指定資料位置


獨立或客戶端/伺服器安裝

SOLIDWORKS Electrical 有兩種安裝模式。在獨立模式中，是將軟體安裝在工作站。在客戶端/伺服器模式中，使用者共用資料。

SOLIDWORKS Electrical 必須一直連接 SQL Server 的副本。

上層主題 SOLIDWORKS Electrical
安裝 SOLIDWORKS Electrical 的需求
設定 Collaborative Server
組態 Microsoft SQL Server
指定資料位置

獨立安裝

若是第一次安裝，您必須在工作站上安裝所有零組件。

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • 應用程式資料
  1. 在摘要標籤中，按一下產品選擇區段的變更，然後選擇所有 SOLIDWORKS Electrical 零組件。
  2. 如果要修改安裝選項，請在摘要標籤中，按一下 Electrical 選項區段的變更。 可以產生新的 SQL Server 執行個體或使用現有的執行個體。 如需詳細資訊，請參閱本文件中有關資料與 Microsoft SQL Server 的特定章節。 如果不需變更，請保留預設選項。
  3. 按一下馬上安裝以繼續。
如果工作站已安裝 SOLIDWORKS Electrical，則 SOLIDWORKS 安裝管理員 會自動找出該程式並提示您進行更新。 安裝所有零組件而不變更 Electrical 選項。

客戶端/伺服器安裝

客戶端/伺服器安裝可以讓多位使用者共用資料。

在伺服器上，您必須安裝以下零組件：
  • Collaborative Server
  • 應用程式資料
  • SQL Server
在客戶端上，您必須安裝以下零組件：
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. 在伺服器上，安裝伺服器零組件。
  2. 在歡迎使用 SOLIDWORKS 安裝管理員標籤，按一下安裝伺服器零組件。
  3. 選擇 SOLIDWORKS Electrical 選項。
  4. 在摘要標籤中，您可以修改安裝選項。 請參閱本文件說明資料與 Microsoft SQL Server 的特定章節以瞭解更多詳細資料。 若不是，請保留預設選項。
  5. 按一下馬上安裝來繼續。
  6. 在客戶端上，安裝應用程式。
  7. 在歡迎使用 SOLIDWORKS 安裝管理員標籤，按一下安裝在此電腦上。
  8. 在摘要標籤中，按一下產品選擇區段的變更，然後清除 Electrical Server 選項。
  9. 在摘要標籤中，按一下 Electrical 選項區段的變更，然後修改設定以便連接到伺服器。
  10. 按一下馬上安裝來繼續。
如果 SOLIDWORKS Electrical 已經安裝在工作站或伺服器上，SOLIDWORKS 安裝管理員會自動找到它並提示您進行更新。 使用與第一次安裝相同的程序來更新軟體。


設定 Collaborative Server

Collaborative Server 是必須不斷持續執行的 Windows 服務，且透過防火牆與病毒掃描程式與用戶端進行連續、不中斷的雙向通訊。

若要將 Collaborative Server 設定為單機模式或伺服器模式，則必須指定下列的參數：
  • 機器名稱 (例如 LOCALHOST 或 MyMachine)，或其 IP 位址 (例如 127.0.0.1 或 192.168.999.999)。
  • 連接埠號碼 (預設 26666)。

您可以在安裝過程中設定 Collaborative Server 或是稍後使用工具 > 應用程式設定指令來設定。

若要提供不中斷的雙向通訊，請確定在要安裝協作伺服器的系統上可使用連接埠號碼 26666 至 26676 (當有 10 位使用者同時連線時)。 若不是，請要求系統管理員提供另一個連接埠供 SOLIDWORKS Electrical 使用。

上層主題 SOLIDWORKS Electrical
安裝 SOLIDWORKS Electrical 的需求
獨立或客戶端/伺服器安裝
組態 Microsoft SQL Server
指定資料位置


組態 Microsoft SQL Server

請確定 SQL Server 資料庫的執行個體可用於 SOLIDWORKS Electrical 安裝的任何類型。您可以使用現有的 SQL Server 資料庫 (如果您已經安裝在系統上)，或在 SOLIDWORKS Electrical 安裝期間安裝新執行個體。

當您安裝新的 SQL Server 執行個體時，SOLIDWORKS 安裝會提供免費版本的 Microsoft SQL Express 2022。此版本限於 1 CPU、1 GB 的記憶體及 10 GB 的資料。記憶體和 CPU 限制足以支援 10 個同時的使用者。

如果您安裝 SQL Express 2022，請確定伺服器軟體與硬體符合系統需求中所列需求。

最佳做法是，如果在相同伺服器上有 10 位以上同時的使用者，您應該購買並安裝完整版本的 SQL Server。使用所述工作流程安裝 SOLIDWORKS Electrical 與 SQL Server 的現有執行個體。

如需 SQL Express 2022 的相關資訊，請參閱 Microsoft SQL Server 說明文件。

上層主題 SOLIDWORKS Electrical
安裝 SOLIDWORKS Electrical 的需求
獨立或客戶端/伺服器安裝
設定 Collaborative Server
指定資料位置

管理 SOLIDWORKS Electrical 中的資料

許多程式使用包含所有程式資料的單一資料庫。 這與 SOLIDWORKS Electrical 的情況不同。SOLIDWORKS Electrical 中的每個專案中會被指派獨特的 ID 號碼，且每個專案都有可根據其獨特 ID 號碼識別的相關資料庫。 例如，在 SOLIDWORKS Electrical 專案管理員中，如果您找到 ID#112 的專案，相關資料庫名稱則為「tew_project_data_112」。

每個專案擁有獨特資料庫的原因是這麼做會大幅減少處理時間。 同時，在發生重大資料庫故障的情況下，只有一個專案會受影響，保留了多數程式資訊的完整性。

不過，有些公司會有限制新資料庫產生的原則。 執行 SOLIDWORKS Electrical，針對使用者產生新資料庫可能會沒有限制。 請檢查系統或資料庫管理員，以確保沒有任何組態設定讓使用者無法產生新資料庫。

SQL Server 的新執行個體

如果您安裝 SQL Server 的新執行個體，您需要伺服器以及任何客戶端系統的完整系統管理權限。 您還必須確定客戶端有讀取/寫入資料庫的權限，因此客戶端可以產生及修改專案、資料庫、符號及其他專案資料。

當您安裝 SQL Server 的新執行個體時，請選擇預設以外的名稱。

SQL Server 的現有執行個體

您需要有擁有 SQL Server 資料庫完整系統管理權限的使用者帳戶來安裝新 SOLIDWORKS Electrical 資料庫，或連線至 SQL Server 現有執行個體上的 SOLIDWORKS Electrical 安裝。

如要 SOLIDWORKS Electrical 正常運作，您必須啟用 SQL Server 以進行混合模式驗證。 混合模式驗證可使用任一 Windows 或 SQL Server 認證。

若要連線至現有的 SQL Server 資料庫，您可以使用 Windows 或 SQL Server 驗證。 輸入擁有完整 SQL Server 系統管理權限的 Windows 或 SQL Server 登入使用者名稱與密碼。

您無法使用「tew」使用者連線至 SQL Server 以進行安裝。 聯絡您的 SQL Server 管理員或系統管理員尋求協助，取得 SQL Server 的正確認證以登入。

SOLIDWORKS Electrical 資料庫

在您安裝 SOLIDWORKS Electrical 之後，安裝程式會在 SQL Server 副本中建立以下資料庫。

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


指定資料位置

選擇要儲存程式資料 (例如零件、範本及 2D 和 3D 符號) 的目錄，以指定資料位置。 此位置必須是專用目錄。 不得為用來儲存 SOLIDWORKS 資料的根目錄或相同目錄。

預設目錄是 C:\ProgramData\SOLIDWORKS Electrical。

若是採用客戶端/伺服器安裝模式，您必須共用資料目錄。

安裝程式在預設目錄中產生一個新資料夾稱為 Update 來儲存所有新資料。

當您首次啟動 SOLIDWORKS Electrical，程式自動把儲存在 Update 資料夾的資料與現有資料合併。 在更新資料精靈中，您可以選擇要加入應用程式及 SQL Server 資料庫中的資料。

上層主題 SOLIDWORKS Electrical
安裝 SOLIDWORKS Electrical 的需求
獨立或客戶端/伺服器安裝
設定 Collaborative Server
組態 Microsoft SQL Server


SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize 提供一套單機工具，這套工具結合進階影像計算功能與視覺設計導向的功能和工作流程，可讓您產生 3D CAD 模型的高度逼真影像。

SOLIDWORKS Visualize 產品提供兩種套件：
  • 標準
  • Professional

在有效訂閱中，每個 SOLIDWORKS Professional 和 Premium 使用許可都包含一套免費的 SOLIDWORKS Visualize Standard。針對獨立啟動 SOLIDWORKS 客戶，您需要額外的序號。如果您不知道 SOLIDWORKS Visualize 序號，請洽詢您的 SOLIDWORKS 管理員或經銷商。

SOLIDWORKS Visualize 也支援 SolidNetWork Licensing (SNL) 使用許可類型 (如浮動使用許可)，以及離線啟動。

使用 SOLIDWORKS 安裝管理員 (SLDIM)，安裝 SOLIDWORKS Visualize 作為單機 (安裝在此電腦上) 安裝的一部分。您可以將其作為獨立應用程式安裝，如果您想要針對模型建立和影像計算使用不同的電腦，這是很便利的方法。該軟體無需使用 SOLIDWORKS 使用許可。

SOLIDWORKS Visualize Boost 是一個服務，可讓您將影像計算從執行 SOLIDWORKS Visualize Professional 的電腦分配至網路上的一或多部電腦。您可在產生所計算的影像時，在電腦上執行其他工作，而且最終計算出的影像會更快提供給您。您可以在 SOLIDWORKS 安裝管理員中，把 Visualize Boost 當作單機 (安裝在此電腦上) 安裝的一部分來安裝。

在有效訂閱中，每套 SOLIDWORKS Visualize Professional 都包含一套免費的 SOLIDWORKS Visualize Boost。
Visualize Boost 是僅適用於 Visualize Professional 的一項產品附加元件。Visualize Boost 無法與 Visualize Standard 搭配運作。

目錄

  • SOLIDWORKS Visualize 的系統需求

  • 使用 SOLIDWORKS 安裝管理員安裝 SOLIDWORKS Visualize

  • 使用 SOLIDWORKS 安裝管理員安裝 Visualize Boost


SOLIDWORKS Visualize 的系統需求

為達到 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost 的最佳效能和設定，請在安裝之前遵循以下準則：
  • 在安裝 SOLIDWORKS Visualize 與 SOLIDWORKS Visualize Boost 之前，請確保每個產品都有單獨的序號。
  • 請確定執行 SOLIDWORKS Visualize 或 SOLIDWORKS Visualize Boost 的每台電腦都符合系統需求中所列需求。
  • 在相同網路中專門進行影像計算的電腦中安裝 SOLIDWORKS Visualize Boost 應用程式。這些電腦應該與執行 SOLIDWORKS Visualize Professional 以卸載影像計算任務的電腦不同。
  • 如果找不到適當的 GPU，SOLIDWORKS Visualize 及 SOLIDWORKS Visualize Boost 會依預設使用中央處理器 (CPU)。如需特定圖形卡和驅動程式的相關資訊，請參閱 SOLIDWORKS 硬體認證。

使用 3DS Stellar Physically Correct 的 GPU 支援：

Stellar 準確影像計算模式：
  • 至少基於 Maxwell 微架構的 NVIDIA 顯示卡
  • 建議的驅動程式版本為 538.78，支援 CUDA 12.2。
  • 至少 4 GB 影像記憶體
Stellar 快速影像計算模式：
  • 至少基於 Turing 微架構的 NVIDIA 顯示卡 (含 RT Core)
  • 使用與準確模式相同的驅動程式版本和記憶體需求

使用 AMD ProRender 的 GPU 支援：

AMD ProRender快速與準確影像計算模式：
  • 支援 Vulkan 標準的 GPU 和驅動程式
上層主題 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost


使用 SOLIDWORKS 安裝管理員安裝 SOLIDWORKS Visualize

安裝 SOLIDWORKS Visualize：

  1. 啟動 SOLIDWORKS 安裝管理員。
  2. 請在歡迎頁面上選擇安裝在此電腦上。
  3. 執行下列的操作：
    1. 在序號頁面中，展開 Visualization。
    2. 選擇 SOLIDWORKS Visualize 並輸入序號。
    3. 按一下下一步。
  4. 依照系統警告的指示操作，然後按一下下一步。
  5. 在「摘要」頁面中，接受 SOLIDWORKS 使用許可協議書的條款，然後按一下馬上安裝。
請依照「產品啟動」精靈中的指示來啟動產品。

啟動之後，連按兩下桌面上的 SOLIDWORKS Visualize 捷徑圖示以啟動應用程式，或從 Windows 的開始功能表中，按一下SOLIDWORKS 版本 > SOLIDWORKS Visualize 版本。

目錄

  • 安裝後的工作

上層主題 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost


安裝後的工作

在安裝之後，有幾件您可執行的工作以設定 SOLIDWORKS Visualize。

如需更多資訊，請參閱 SOLIDWORKS Visualize 說明中的開始使用 SOLIDWORKS Visualize。

目錄

  • 產生內容資料夾

  • 存取說明、學習單元、系統資訊及使用許可

上層主題 使用 SOLIDWORKS 安裝管理員安裝 SOLIDWORKS Visualize


產生內容資料夾

當您第一次執行軟體時，SOLIDWORKS Visualize 會提示您需要一個位置以產生內容資料夾。

內容資料夾包含下列子資料夾，可用於儲存專案的資產：
子資料夾 | 儲存
攝影機 | 預設攝影機及您已儲存的攝影機
環境 | 高動態範圍 (HDR) 影像
調色盤 | 背景圖影像
影像 | 影像計算和快照
外觀 | 外觀資料庫中的材質 當您將外觀加到資料庫時內容會更新。
模型 | 模型檔案 根據預設，您使用檔案 > 輸入模型時，SOLIDWORKS Visualize 會先搜尋這個資料夾。
板 | 在背景圖中使用的標準 2D 影像
專案 | 採用 .SVPJ 格式的原始專案檔案
紋路 | 在外觀中使用的 2D 紋路
上層主題 安裝後的工作


存取說明、學習單元、系統資訊及使用許可

「說明」功能表提供說明文件和選項，以更新軟體並疑難排解您的系統。

Visualize 說明 | 開啟 SOLIDWORKS Visualize 線上說明。
Visualize 學習單元 | 開啟 MySolidWorks 並讓您存取 SOLIDWORKS Visualize 學習單元。
新版本說明 | 顯示目前版本的線上版本說明。
新增功能 | 顯示 SOLIDWORKS 產品的新功能。
系統資訊 | 執行 SOLIDWORKS Visualize 軟體及 PC 硬體的系統檢查，需要時建議更新。
檢查更新 | 檢查伺服器是否有最新 SOLIDWORKS Visualize 更新。
啟動使用許可 | (節點鎖住的使用許可) 使用 SOLIDWORKS 產品啟動精靈以啟動您的產品。
停用使用許可 | (節點鎖住的使用許可) 使用 SOLIDWORKS 產品啟動精靈以停用您的產品。
SolidNetWork License Manager | 使用 SOLIDWORKS 產品啟動精靈來停用您的產品。
關於 Visualize | 顯示 SOLIDWORKS Visualize 複本的版本號碼及使用許可資訊。
上層主題 安裝後的工作


使用 SOLIDWORKS 安裝管理員安裝 Visualize Boost

您可以使用 SOLIDWORKS 安裝管理員來安裝 Visualize Boost。 此產品需要個別序號。

您應將 Visualize Boost 安裝在與執行 SOLIDWORKS Visualize Professional 時所在的不同的機器上。您可在具有多個圖形處理單元 (GPU) 的電腦上安裝 Visualize Boost，使影像計算效能達到最高。

若要安裝 SOLIDWORKS Visualize Boost：

  1. 啟動 SOLIDWORKS 安裝管理員。
  2. 請在歡迎頁面上選擇安裝在此電腦上。
  3. 執行下列的操作：
    1. 在序號頁面中，展開 Visualization。
    2. 選擇 SOLIDWORKS Visualize Boost 並輸入序號。
    3. 按一下下一步。
  4. 依照系統警告的指示操作，然後按一下下一步。
  5. 在「摘要」頁面中，接受 SOLIDWORKS 使用許可協議書的條款，然後按一下馬上安裝。
請依照「產品啟動」精靈中的指示來啟動產品。

啟動後，連按兩下 SOLIDWORKS Visualize Boost 桌面捷徑 [image] 以開啟應用程式。

目錄

  • 設定 Visualize Boost

    您可以將主要 Visualize Boost 機器設定為「協調器」，並將影像計算叢集中的其他機器設定為「節點」。

上層主題 SOLIDWORKS Visualize 和 SOLIDWORKS Visualize Boost


設定 Visualize Boost

您可以將主要 Visualize Boost 機器設定為「協調器」，並將影像計算叢集中的其他機器設定為「節點」。

Visualize Boost 可讓您在單一機器或機器叢集上計算影像。設定既簡單又直覺。主要電腦，即協調器，可管理叢集並從 SOLIDWORKS Visualize 分配影像計算工作。其他機器稱為節點，會連線至「協調器」以協助在網路上進行這些工作。在影像計算伺服器陣列中，叢集中的每部機器都會持續執行 Visualize Boost 的副本。

設定 Visualize Boost：

  1. 開啟 Visualize Boost：
    • 連按兩下 Visualize Boost 桌面捷徑 [image] 。
    • 從 Windows 開始功能表，按一下SOLIDWORKS <版本> > SOLIDWORKS Visualize Boost <版本>。
    啟動後，Visualize Boost 視窗會識別並顯示授權機器的名稱和 IP 位址。
  2. 在 Visualize Boost 中，按一下檔案 > 設定。
  3. 在設定對話方塊中：
    1. 選擇一部機器作為協調器。設定其他所有節點時，保持協調器清除。
    2. 接受 Boost 連接埠的預設值 8001，DStellar 連接埠的預設值 8002。
      您可以更新這些連接埠以符合網路需求。請務必為節點通訊加入防火牆例外。如有問題，請洽詢您的網路管理員。
  4. 選擇性的: 其他參數包括：
    選項 | 敘述
    語言 | 機器會自動使用作業系統的語言。
    主題 | 針對佈景主題選擇亮或暗。如果 SOLIDWORKS Visualize 安裝在與 Visualize Boost 相同的機器上，則此設定會對 SOLIDWORKS Visualize 造成影響。
    已啟用通知 | 在 Windows 通知區域中顯示來自 DStellar.Boost 的訊息。
    輸出 | 將 Visualize Boost 組態設定儲存至 .json 檔案。
    輸入 | 將現有設定載入至 Visualize Boost 副本的 .json 檔案中。
  5. 按一下套用。
若要完成設定，請參閱使用 Visualize Boost 的指示。
上層主題 使用 SOLIDWORKS 安裝管理員安裝 Visualize Boost


使用許可管理

在安裝之後，您可以透過以下兩種方式啟動 SOLIDWORKS 使用許可：啟動單機電腦 (使用機器啟動)，或是在伺服器上安裝並啟動浮動網路使用許可 (SolidNetWork 使用許可)。

一般而言，在單機電腦上的安裝通常使用使用許可啟動；不過，您可以個別的安裝軟體，然後用 SolidNetWork License Manager 來控制使用許可。 反之，雖然大型的場所通常使用浮動的網路使用許可，但您可以從管理安裝點部署安裝，然後從個別的電腦上啟動序號。

目錄

  • 管理個別的使用許可

    您可以指定個別使用許可，作為使用機器啟動的授權。

  • 使用 SolidNetWork License Manager 來管理使用許可

    SolidNetWork License Manager 可透過在網路上散佈使用許可給客戶端，以支援多個使用許可客戶端。 透過浮動使用許可，可允許使用者的數目超過使用許可的數目。


管理個別的使用許可

您可以指定個別使用許可，作為使用機器啟動的授權。

一般而言，個別使用許可的管理即是直接從 SOLIDWORKS 軟體啟動和停用使用許可。

啟動是 SOLIDWORKS 單套 (非 SolidNetWork 使用許可) 使用許可的產品授權及註冊過程。 通常如果您的產品使用許可尚未啟動，則當您啟動產品時，SOLIDWORKS 會嘗試將它啟動。

從 SOLIDWORKS 2022 和更新版本開始，如果您購買 SOLIDWORKS 的永久使用許可，仍要一年重新啟動一次使用許可。永久使用許可永遠不會過期，但必須重新啟動。SOLIDWORKS 會在規定的重新啟動日期之前，提示您重新啟動永久使用許可。

您可以按一下 SOLIDWORKS 中的 [image] > 使用許可 > 停用，來停用個別的使用許可。

上層主題 使用許可管理
使用 SolidNetWork License Manager 來管理使用許可

啟動使用許可

在您能夠在個別電腦上執行 SOLIDWORKS 產品之前，您必須啟動該電腦的使用許可。

啟動要求您要能夠存取網際網路或電子郵件。 在啟動之後，您不需連線至網路來使用產品。 如果您在使用此產品的電腦上沒有辦法使用電子郵件，您可以儲存啟動的檔案並從另一台電腦來傳送。

此過程：
  • 啟動整個 SOLIDWORKS 產品線的所有軟體使用許可。
  • 可讓您將使用許可的權利從一台電腦移動至另一台電腦上。
  • 能夠立刻執行安裝（建議）或是在 30 天內安裝。
  • 不需要使用硬體鎖。 不過，如果您執行未使用啟動的先前 SOLIDWORKS 產品版本，您則需要使用硬體鎖。

如果系統管理員有多個序號需要管理，您可以使用管理安裝點選項編輯器。詳細資訊請參閱 管理安裝點選項編輯器。

啟動使用許可：

  1. 啟動 SOLIDWORKS。
  2. 使用以下方法之一來啟動 SOLIDWORKS 產品啟動：
    • 如果您尚未啟動此電腦的使用許可，當您啟動 SOLIDWORKS 軟體時，SOLIDWORKS 產品啟動視窗會自動出現。
    • 如果 SOLIDWORKS 產品啟動視窗並未自動出現，請按一下 [image] > 使用許可 > 啟動以開始啟動。
  3. 選擇產品清單以指定您要啟動其使用許可的產品。
  4. 指定在網際網路上自動啟動或使用電子郵件手動啟動。
  5. 提供電子郵件聯絡資訊。
  6. 按一下下一步。
    • 網際網路：啟動會自動進行。
    • 電子郵件: 按一下儲存產生一個要求檔，然後將檔案透過電子郵件傳送至 activation@solidworks.com。當您收到包含回覆檔的電子郵件時，請從電子郵件取得檔案，然後按一下開啟將檔案載入。
      必要時，您可以退出然後重新執行啟動程序以開啟回覆檔。
  7. 按一下完成。
管理安裝點選項編輯器

重新啟動使用許可

如果您擁有 SOLIDWORKS 2022 產品及更新產品的永久商業或教育使用許可，必須每年重新啟動一次這些使用許可。SOLIDWORKS 產品啟動會提示您在規定的重新啟動日期之前重新啟動。

重新啟動使用許可：

  1. 啟動 SOLIDWORKS。
    SOLIDWORKS 產品啟動會提示您重新啟動。每個 SOLIDWORKS 產品使用許可都會顯示下列資訊：
    • 目前啟動過期的日期
    • 繼續使用產品需要採取的動作，例如重新啟動永久使用許可或續約，以及重新啟動條款或評估使用許可。
  2. 按一下立即重新啟動以啟動產品啟動精靈。

    如果您不想立即重新啟動使用許可，請按一下稍後再提醒我。 例如，在 SOLIDWORKS 中，按一下 [image] > 使用許可 > 啟動，以啟動產品啟動精靈。 請參閱啟動使用許可。

移動使用許可

要將 SolidNetwork 使用許可移動至新的或已升級的電腦，請先在 Dassault Systèmes SOLIDWORKS Corporation 的使用許可授權碼伺服器上停用使用許可。然後在其他電腦上重新啟動。

如果您無法在 Dassault Systèmes SOLIDWORKS Corporation 停用使用許可 (例如由於硬碟機故障)，在大部分的情況中仍可成功重新啟動。如果不是，請聯絡您的 Value Added Reseller 取得協助。

若要移動使用許可：

  1. 在 SOLIDWORKS 中，按一下 [image] > 使用許可 > 停用，然後遵照指示操作。
  2. 要重新啟動，請於新的或升級的電腦上根據初始啟動的程序啟動使用許可。 詳細資訊請參閱啟動使用許可。


使用 SolidNetWork License Manager 來管理使用許可

SolidNetWork License Manager 可透過在網路上散佈使用許可給客戶端，以支援多個使用許可客戶端。 透過浮動使用許可，可允許使用者的數目超過使用許可的數目。

本圖描述典型的 SolidNetWork 使用許可安裝：

該圖片說明：
  • SolidNetWork License Manager 軟體只在使用許可管理員電腦上安裝及啟動。
  • 使用許可客戶端電腦沒有安裝任何其他特定的 SolidNetWork 軟體。

    如果您在安裝時指定 SolidNetWork license 序號，SOLIDWORKS 安裝管理員會將該電腦識別為 SolidNetWork license 客戶端。SOLIDWORKS 安裝管理員會提示您輸入 SolidNetWork License Manager 電腦名稱，以及將客戶端與使用許可管理員連接的連接埠號碼。

  • 使用許可管理員以及所有使用許可客戶端必須擁有 TCP/IP（傳輸控制協定/網際網路協定）連線能力。

目錄

  • 安裝 SolidNetWork 使用許可概觀

    您可以使用 SOLIDWORKS 安裝管理員，於在任何電腦上安裝 SOLIDWORKS 客戶端軟體之前，在至少一部電腦上安裝 SolidNetWork License Manager 伺服器。然後，您可以使用「產品啟動精靈」，為永久與期限使用許可加入及啟動序號。

  • 啟動 SolidNetWork License Manager

    您可以從 Windows 開始功能表啟動 SolidNetWork License Manager。

  • 升級 SolidNetWork 使用許可管理員

    在 SOLIDWORKS 的主要版本中，升級使用許可管理員包括解除安裝舊的使用許可管理員、安裝新的使用許可管理員，以及重新啟動 SolidNetWork license。

  • 移動 SolidNetWork License

    若要將 SolidNetWork License 移動至新的或是已升級的電腦上，請先在 Dassault Systèmes SOLIDWORKS Corporation 的使用許可授權碼伺服器上停用使用許可，然後在另一台電腦上重新啟動。

  • 刪除 SolidNetWork 使用許可檔案

    您可以在升級至新使用許可之前，先刪除已過期的 SolidNetWork license 檔案。

  • 借用與歸還 SolidNetWork 使用許可

    您可以借用一個 SolidNetWork 使用許可以便從遠端位置使用軟體。由於使用許可會從可用的使用許可池中移除，因此必須歸還借用的使用許可以便使它再次成為可用狀態。

  • 管理各 SOLIDWORKS 版本的存取權限

    您可以在 SolidNetWork 的環境中限制使用者使用特定的 SOLIDWORKS 版本。 此功能可讓您管理不同人員、專案及業務單位使用的 SOLIDWORKS 版本。

  • 監控使用許可閒置時間

    SOLIDWORKS 能讓您在 SolidNetWork License Manager 上登記許可閒置的時間，讓一段特定時間未被使用的使用許可可以重新回到自由許可的控制池內。

  • 使用暫時使用許可

    如果 SolidNetWork license 無法使用，您可以使用暫時性的「any」使用許可。

  • 使用有附加產品的 SolidNetWork 使用許可

    您可以使用 SolidNetWork License Manager 來分配 SOLIDWORKS 核心附加產品的使用許可。

  • 選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可

    SolidNetWork 使用許可使用者可以在加入 SOLIDWORKS Simulation 時，控制要使用其使用許可集區中的哪些 SOLIDWORKS® Simulation 使用許可。 在需要更高的使用許可類型來執行更多進階研究時，這些使用者也可以升級 SOLIDWORKS Simulation 使用許可，而無需上傳附加程式。

  • 載入 Flow Simulation 模組

    作為 SolidNetWork License 客戶，您可使用兩種方法控制載入 HVAC 及電子冷卻附加程式模組，以執行 Flow Simulation。

  • SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時

    當您執行 SOLIDWORKS Simulation、Plastics 或 Flow Simulation 研究時，網路使用許可會保持啟用且不會逾時。SOLIDWORKS 在計算過程中持有使用許可，被認定為一項活動。

  • 在使用許可管理員和管理安裝點安裝時使用同一部電腦

    您可以在網路上將一台電腦設定為散佈 SolidNetWork 使用許可的使用許可管理員，以及作為管理安裝點的位置 (使用者可以透過它安裝 SOLIDWORKS 軟體)。

  • 解除安裝 SolidNetWork License Manager

    在升級 SolidNetWork License Manager，您必須解除安裝舊的使用許可管理員，然後才能安裝新的管理員。

  • FlexNet Publisher 使用許可管理

    SolidNetWork 使用許可是以 FlexNet Publisher® 使用許可管理為基礎。

上層主題 使用許可管理
管理個別的使用許可


安裝 SolidNetWork 使用許可概觀

您可以使用 SOLIDWORKS 安裝管理員，於在任何電腦上安裝 SOLIDWORKS 客戶端軟體之前，在至少一部電腦上安裝 SolidNetWork License Manager 伺服器。然後，您可以使用「產品啟動精靈」，為永久與期限使用許可加入及啟動序號。

當您在電腦上安裝 SOLIDWORKS 客戶端軟體時，請指定 SolidNetWork license 序號。SOLIDWORKS 安裝管理員會將該電腦識別為 SolidNetWork license 客戶端，並提示您輸入 SolidNetWork License Manager 伺服器的電腦名稱與連接埠號碼。如果 SolidNetWork License Manager 伺服器未安裝，或名稱或連接埠號碼不正確，則會顯示錯誤。

啟動程序

在使用者能夠在單機電腦上執行 SOLIDWORKS 產品之前，您必須在 SolidNetWork License Manager 伺服器電腦上啟動 SolidNetWork license。

啟動要求您要能夠存取使用中網際網路連線或電子郵件。在啟動之後，您不需連線至網路來使用產品。如果您在使用此產品的電腦上沒有辦法使用電子郵件，您可以儲存啟動的檔案並從另一台電腦來傳送。

此過程：
  • 在 SOLIDWORKS 產品中啟動 SOLIDWORKS SolidNetWork License Manager 與 SolidNetWork 使用許可。
  • 可讓您將 SolidNetWork 使用許可權利從一台 SolidNetWork License Manager 電腦移至另一台電腦。
  • 讓您在 SolidNetWork License Manager 電腦上安裝與啟動 SolidNetWork 使用許可。
  • 必須先執行這個動作，您才能使用 SolidNetWork 使用許可。
  • 不需要使用硬體鎖。如果您為此 SOLIDWORKS 版本啟動了 SolidNetWork 使用許可，則先前 SOLIDWORKS 版本的 SolidNetWork 使用許可也會啟動。您不再需要保留硬體鎖。

目錄

  • 安裝 SolidNetWork License Manager 伺服器

    SolidNetWork License Manager 伺服器支援多個使用許可客戶端。它可以將使用許可分配到網路中的客戶端上。

  • 啟動 SolidNetWork License

    在使用者能夠在單機電腦上執行 SOLIDWORKS 產品之前，您必須在 SolidNetWork License Manager 電腦上啟動 SolidNetWork 使用許可。

  • 使用 SolidNetWork License Manager 伺服器進行手動啟動

    當您安裝或升級 SolidNetWork License Manager 伺服器時，您需要啟動或重新啟動使用許可。您可以透過網際網路啟動或重新啟用使用許可，或選擇以手動方式執行。

  • 安裝 SolidNetWork License 客戶端

  • 使用 SolidNetWork 使用許可與防火牆

    如果您的電腦有使用防火牆，您必須設定連接埠以支援 SolidNetWork 使用許可。

  • 重新啟動 SolidNetWork License

    在組織將 SolidNetwork License Manager 伺服器升級至 2022 版本或更新版本後，重新啟動會套用至 SolidNetWork License 產品。即使已安裝的產品來自較早版本，伺服器上 2022 版本之後的使用許可每年都需要重新啟動一次。

  • 三合一 (Triad ) 使用許可管理員安裝

    三合一使用許可管理員使用三台電腦以獲得額外的穩定。如果無法使用管理使用許可檔案的電腦，另外的兩台電腦可以取代。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


安裝 SolidNetWork License Manager 伺服器

SolidNetWork License Manager 伺服器支援多個使用許可客戶端。它可以將使用許可分配到網路中的客戶端上。

如果您是從因啟動使用許可而使用硬體鎖的 SolidNetWork License Manager 伺服器先前版本來升級，請在安裝新版本的 SolidNetWork License Manager 伺服器之前先移除硬體鎖。

  1. 如下載安裝媒體中所述，啟動 SOLIDWORKS 安裝管理員。
  2. 針對安裝類型，請選擇安裝伺服器元件，然後按一下在此電腦上安裝 SolidNetWork License Manager (分配的使用許可)。
  3. 在摘要頁面上，檢閱安裝位置與背景下載程式，同意使用許可條款，然後按一下立即安裝。
  4. 在 SolidNetWork License Manager 伺服器的 SOLIDWORKS 產品啟動精靈中，加入序號並啟動至少一個使用許可。請參閱新增序號及啟動 SolidNetWork License。
上層主題 安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License
使用 SolidNetWork License Manager 伺服器進行手動啟動
安裝 SolidNetWork License 客戶端
使用 SolidNetWork 使用許可與防火牆
重新啟動 SolidNetWork License
三合一 (Triad ) 使用許可管理員安裝


啟動 SolidNetWork License

在使用者能夠在單機電腦上執行 SOLIDWORKS 產品之前，您必須在 SolidNetWork License Manager 電腦上啟動 SolidNetWork 使用許可。

啟動 SolidNetWork 使用許可：

  1. 啟動 SolidNetWork License Manager，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。
  2. 選擇性的: 如果您尚未啟動 SolidNetWork 使用許可，系統要求您將其啟動。按一下是。
    此操作會啟動 SOLIDWORKS 產品啟動精靈。
  3. 選擇性的: 如果使用防火牆，請選擇在此伺服器上有正在使用的防火牆。
  4. 在 SolidNetWork License 伺服器資訊頁面中輸入連接埠號碼，然後按一下下一步。
  5. 在序號：中選擇特定序號，或按一下全選以強調顯示，並啟動所有 SOLIDWORKS 序號。
    1. 選擇選項來啟動自動在 Internet 上 (建議使用)。
    2. 在聯絡資訊之下，指定一個電子郵件地址。
    啟動/重新啟動成功對話方塊會顯示已經啟動的產品。
  6. 按一下完成。
上層主題 安裝 SolidNetWork 使用許可概觀
安裝 SolidNetWork License Manager 伺服器
使用 SolidNetWork License Manager 伺服器進行手動啟動
安裝 SolidNetWork License 客戶端
使用 SolidNetWork 使用許可與防火牆
重新啟動 SolidNetWork License
三合一 (Triad ) 使用許可管理員安裝


使用 SolidNetWork License Manager 伺服器進行手動啟動

當您安裝或升級 SolidNetWork License Manager 伺服器時，您需要啟動或重新啟動使用許可。您可以透過網際網路啟動或重新啟用使用許可，或選擇以手動方式執行。

當您手動啟動時：
  • 對於新的 SolidNetWork License Manager 伺服器，您必須啟動兩次才能正確設定伺服器。您正在伺服器上初始化您第一次啟動的使用許可系統。第二次重複此程序時，即可啟動使用許可。
  • 針對已升級的 SolidNetWork License Manager 伺服器，您必須重新啟動現有使用許可。如果伺服器沒有已啟動的使用許可，請改用「伺服器系統管理」標籤上的修改來執行啟動。
上層主題 安裝 SolidNetWork 使用許可概觀
安裝 SolidNetWork License Manager 伺服器
啟動 SolidNetWork License
安裝 SolidNetWork License 客戶端
使用 SolidNetWork 使用許可與防火牆
重新啟動 SolidNetWork License
三合一 (Triad ) 使用許可管理員安裝


安裝 SolidNetWork License 客戶端

當您在電腦上安裝 SOLIDWORKS CAD 軟體時，您會指定 SolidNetWork License 序號。SOLIDWORKS 安裝管理員會將該電腦識別為 SolidNetWork License 客戶端，並提示您輸入 SolidNetWork License Manager 電腦名稱與號碼。如果 SolidNetWork License Manager 伺服器未安裝，或名稱或連接埠號碼不正確，則會顯示錯誤。

若要以 SolidNetWork license 安裝 SOLIDWORKS：

  1. 如下載安裝媒體中所述，啟動 SOLIDWORKS 安裝管理員。
  2. 如果這是這台電腦第一次安裝 SOLIDWORKS 的主要版本，請在「歡迎」畫面上按一下安裝在此電腦上。
    如果您正在從現有的版本升級，同時要從單機使用許可變更為 SolidNetWork 使用許可，請按一下修改單機安裝 (在此電腦上)。 如需詳細資訊，請參閱從單機使用許可升級為 SolidNetWork 使用許可 。
  3. 在新增伺服器對話方塊中，以下列形式輸入 SolidNetWork License Manager 的位址：

    連接埠號碼@電腦名稱

    連接埠號碼必須與使用許可管理員電腦所使用的相同。預設是25734。

    SOLIDWORKS 安裝管理員會嘗試驗證此 SolidNetWork License Manager 是否可存取。如果您尚未安裝使用許可管理員，則此項驗證將會失敗；但您仍然可以繼續使用許可客戶端安裝。
  4. 遵照 SOLIDWORKS 安裝管理員指示完成 SOLIDWORKS 安裝。
上層主題 安裝 SolidNetWork 使用許可概觀
安裝 SolidNetWork License Manager 伺服器
啟動 SolidNetWork License
使用 SolidNetWork License Manager 伺服器進行手動啟動
使用 SolidNetWork 使用許可與防火牆
重新啟動 SolidNetWork License
三合一 (Triad ) 使用許可管理員安裝


使用 SolidNetWork 使用許可與防火牆

如果您的電腦有使用防火牆，您必須設定連接埠以支援 SolidNetWork 使用許可。

在防火牆軟體中，您必須將兩個 SolidNetWork License 連接埠 (例如 SNL-in-port 和 SNL-out-port) 新增至防火牆例外清單。如需有關設定這些連接埠的詳細資訊，請向系統管理員詢問。

如果您是在支援的 Windows 作業系統中使用 Windows 防火牆，您必須在 SolidNetWork License Manager 電腦上修改連接埠，然後修改 SolidNetWork License 檔案，將使用許可傳送至使用許可客戶端電腦。

修改 Windows 防火牆的使用許可管理員電腦連接埠

  1. 按一下開始並開啟 Windows 安全性。
  2. 選擇防火牆與網路保護 > 進階設定，然後按一下是以確認變更。
  3. 在具有進階安全性的 Windows Defender 防火牆對話方塊中，選擇輸入規則 > 新規則。
  4. 在新增輸入規則精靈中，選擇規則類型連接埠，然後按一下下一步。
  5. 在特定本機連接埠中輸入連接埠號碼：(例如 80, 25734, 443)，然後按一下下一步。
  6. 選擇名稱。輸入名稱 (例如 SNL-in-port)。
  7. 按一下完成。

修改 Windows 防火牆中的 SolidNetWork License Manager 設定

  1. 啟動 SolidNetWork License Manager，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。
  2. 在伺服器管理標籤的使用許可伺服器之下，按一下停止。按一下是以確認，並按一下確定以停止使用許可伺服器。
  3. 在使用許可資訊之下，按一下修改。
  4. 在伺服器類型之下，選擇您網路的伺服器安排 (單機或三合一)，然後按下一步。
  5. 在伺服器資訊之下：
    1. 選擇在此伺服器上有正在使用的防火牆。
    2. 連接埠號碼和 Vendor Daemon 連接埠號碼應該包含為 Windows 防火牆指定的連接埠號碼 (詳細資訊請參閱上述步驟)。
    3. 選擇選項檔案，然後按一下瀏覽以找出檔案。按一下編輯以變更檔案的任一參數。
    該選項檔案可讓使用許可管理員控制 FlexNet 使用許可的各種作業參數。

    建議事項：將選項檔案存放在 SolidNetWork License Manager 安裝目錄中 (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt)。此檔案必須與 sw_d.lic 檔位於同一目錄中。

    如需更多有關選項檔案的資訊，請參閱 SolidNetWork License Manager 安裝目錄中的 FlexNet Publisher 使用許可管理指南：

    C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf

上層主題 安裝 SolidNetWork 使用許可概觀
安裝 SolidNetWork License Manager 伺服器
啟動 SolidNetWork License
使用 SolidNetWork License Manager 伺服器進行手動啟動
安裝 SolidNetWork License 客戶端
重新啟動 SolidNetWork License
三合一 (Triad ) 使用許可管理員安裝


重新啟動 SolidNetWork License

在組織將 SolidNetwork License Manager 伺服器升級至 2022 版本或更新版本後，重新啟動會套用至 SolidNetWork License 產品。即使已安裝的產品來自較早版本，伺服器上 2022 版本之後的使用許可每年都需要重新啟動一次。

在重新啟動日期的 30 天內，網路上的 SOLIDWORKS 產品會通知使用者使用許可即將到期。 管理員必須知道到期日，才能及時重新啟動使用許可。

若要重新啟動 SolidNetWork 使用許可：

  1. 啟動 SolidNetWork License Manager 伺服器，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。
  2. 在「伺服器管理」標籤的使用許可資訊下，按一下重新啟動。

  3. 在序號中，選擇全部選擇所有使用許可，或輸入使用許可號碼搜尋特定使用許可。

    重新啟動使用許可對話方塊會將 30 天內所有使用許可到期和重新啟動日期以紅色強調顯示。需要更新的標星號使用許可。

  4. 按一下重新啟動。
上層主題 安裝 SolidNetWork 使用許可概觀
安裝 SolidNetWork License Manager 伺服器
啟動 SolidNetWork License
使用 SolidNetWork License Manager 伺服器進行手動啟動
安裝 SolidNetWork License 客戶端
使用 SolidNetWork 使用許可與防火牆
三合一 (Triad ) 使用許可管理員安裝


三合一 (Triad ) 使用許可管理員安裝

三合一使用許可管理員使用三台電腦以獲得額外的穩定。如果無法使用管理使用許可檔案的電腦，另外的兩台電腦可以取代。

使用三合一使用許可管理員的要求條件：
  • 只能在穩定而不會常被關機的電腦上安裝三合一使用許可管理員。
  • 三台使用許可管理員電腦應該是在同一個子網路上，絕對不要使用慢速傳輸或是電話撥接組態三合一使用許可管理員。
  • 當使用許可管理員電腦當機時，系統管理者應該偵測出來並且儘快地重新啟動。
    如果只有兩台使用許可管理員電腦在執行，這個狀況比使用單一使用許可管理員電腦更糟，因為存在了兩個失敗點。

目錄

  • 安裝初始三合一使用許可管理員

    此程序會顯示如何將 SolidNetWork License Manager 安裝在三合一電腦中的第一台電腦上。

  • 在後續的電腦上安裝三合一使用許可管理員

    請遵循以下指示將 SolidNetWork License Manager 軟體安裝在三合一電腦中的第二台與第三台電腦上。 除了步驟 2(f) 與 2(i) 外，此程序與在第一台電腦上安裝軟體時幾乎完全相同。

上層主題 安裝 SolidNetWork 使用許可概觀
安裝 SolidNetWork License Manager 伺服器
啟動 SolidNetWork License
使用 SolidNetWork License Manager 伺服器進行手動啟動
安裝 SolidNetWork License 客戶端
使用 SolidNetWork 使用許可與防火牆
重新啟動 SolidNetWork License


安裝初始三合一使用許可管理員

此程序會顯示如何將 SolidNetWork License Manager 安裝在三合一電腦中的第一台電腦上。

  1. 在第一台三合一使用許可管理員電腦中，使用 SOLIDWORKS 安裝管理員來安裝 SolidNetWork License Manager：
    1. 如下載安裝媒體中所述，啟動 SOLIDWORKS 安裝管理員。
    2. 針對安裝類型，選擇安裝伺服器元件，然後按一下在此電腦上安裝 SolidNetWork License Manager (分配的使用許可)。
    3. 在摘要頁面中，檢閱 SolidNetWork License Manager 安裝位置、下載選項，然後按一下馬上安裝，以完成 SOLIDWORKS 安裝管理員程序。
  2. 使用 SolidNetWork License Manager，組態初始三合一使用許可管理員電腦：
    1. 啟動 SolidNetWork License Manager。按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。

      由於這是您第一次在此電腦上執行 SolidNetWork License Manager，系統會詢問您是否要現在啟動。

    2. 按一下否。

      SOLIDWORKS SolidNetWork License Manager 的伺服器管理標籤會出現。

    3. 在「伺服器系統管理」標籤的進階選項下，按一下選項。
    4. 在 SolidNetWork Server License 模式之下，按一下使用使用許可檔案，然後按確定。
    5. 在使用許可資訊之下，按一下修改。
      SolidNetWork License 檔案精靈出現。
    6. 在伺服器類型之下，選擇三合一，然後按下一步。
    7. 在「伺服器資訊」窗格中，確認初始三合一使用許可管理員電腦的電腦名稱與連接埠號碼是正確的，然後按一下下一步。

      檢查網路介面卡 (NIC) 位址是否與自 SOLIDWORKS 接收之使用許可檔案中的資訊相符，以及該三合一使用許可管理員電腦的連接埠號碼是否正確。 NIC 位址也稱為 MAC (媒體存取控制位址) 位址。 然後按一下下一步。

      若要尋找網路介面卡位址，請開啟命令提示字元視窗並輸入：

      ipconfig /all

      此外，如果您的電腦使用防火牆，可能需要在此畫面上新增規格。詳細資訊請參閱使用 SolidNetWork 使用許可與防火牆。

    8. 在三合一搭配伺服器資訊畫面中，為其他兩台三合一使用許可管理員電腦輸入電腦名稱以及主機 ID 值，再按一下下一步。
      如此可確保如果有一個三合一使用許可管理員無法使用，客戶端電腦仍然能夠從其他兩台伺服器取得使用許可。
    9. 在使用許可畫面中，按一下讀取以瀏覽及開啟 SolidNetWork 使用許可檔案。
      使用許可出現在 SolidNetWork 使用許可檔案精靈中。針對此電腦，您使用從 Value Added Reseller 或 Dassault Systèmes' SOLIDWORKS 客戶支援處收到的使用許可檔案。
    10. 按一下完成。
    11. 按一下確定以結束，並按一下完成以關閉 SolidNetWork License Manager。
上層主題 三合一 (Triad ) 使用許可管理員安裝
在後續的電腦上安裝三合一使用許可管理員
使用 SolidNetWork 使用許可與防火牆


在後續的電腦上安裝三合一使用許可管理員

請遵循以下指示將 SolidNetWork License Manager 軟體安裝在三合一電腦中的第二台與第三台電腦上。 除了步驟 2(f) 與 2(i) 外，此程序與在第一台電腦上安裝軟體時幾乎完全相同。

在此假設您已經在其他電腦中安裝了至少一個三合一使用許可管理員。

  1. 在三合一使用許可管理員電腦中，使用 SOLIDWORKS 安裝管理員來安裝 SolidNetWork License Manager：
    1. 如下載安裝媒體中所述，啟動 SOLIDWORKS 安裝管理員。
    2. 針對安裝類型，請選擇安裝伺服器元件，然後按一下在此電腦上安裝 SolidNetWork License Manager (分配的使用許可)。
    3. 在摘要頁面中，確認 SolidNetWork License Manager 安裝位置、下載選項，然後按一下馬上安裝，以完成 SOLIDWORKS 安裝管理員程序。
  2. 使用 SolidNetWork License Manager，組態三合一使用許可管理員電腦：
    1. 啟動 SolidNetWork License Manager。按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。
      由於這是您第一次在此電腦上執行 SolidNetWork License Manager，系統會詢問您是否要現在啟動。
    2. 按一下否。
      SOLIDWORKS SolidNetwork License Manager 的伺服器管理標籤會出現。
    3. 在進階選項之下，按一下選項。
      進階選項對話方塊出現。
    4. 在 SolidNetWork Server License 模式之下，按一下使用使用許可檔案，然後按確定。
      進階選項對話方塊關閉。
    5. 在使用許可資訊之下，按一下修改。
      SolidNetWork License 檔案精靈出現。
    6. 在伺服器類型之下，選擇三合一和同步化伺服器/使用許可資訊，然後按下一步。
    7. 請在三合一伺服器資訊畫面中，輸入電腦名稱及主機 ID 值。然後按一下下一步。
      如此可確保如果有一個使用許可管理員無法使用，客戶端電腦仍然能夠從其他兩台伺服器取得使用許可。
    8. 在使用許可畫面中，按一下讀取以瀏覽及開啟 SolidNetWork 使用許可檔案。
      使用許可出現在 SolidNetWork 使用許可檔案精靈中。
    此使用許可檔案是由您設定的第一台三合一使用許可管理員電腦產生。通常，使用許可檔案位於 \licenses\sw_d.lic。例如：C:\Program Files\SOLIDWORKS SolidNetWork License Manager\licenses\sw_d.lic
    1. 按一下完成。
      SolidNetWork 使用許可檔案精靈警告出現。
    2. 按一下確定以結束 SolidNetWork 使用許可檔案精靈，然後按完成以結束 SolidNetWork License Manager。

針對第三台三合一使用許可管理員電腦重複此程序。

上層主題 三合一 (Triad ) 使用許可管理員安裝
安裝初始三合一使用許可管理員


啟動 SolidNetWork License Manager

您可以從 Windows 開始功能表啟動 SolidNetWork License Manager。

在 Windows 中，按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。

您可以使用與 Windows 開始功能表中相同的路徑開啟 SolidNetWork License Manager 客戶端版本。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


升級 SolidNetWork 使用許可管理員

在 SOLIDWORKS 的主要版本中，升級使用許可管理員包括解除安裝舊的使用許可管理員、安裝新的使用許可管理員，以及重新啟動 SolidNetWork license。

較新版本的使用許可管理員也可以為仍然使用先前版本的客戶端電腦散佈使用許可。

  1. 啟動 SolidNetWork License Manager，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。
  2. 在使用許可使用標籤中，確認網路上沒有客戶端電腦正在執行 SOLIDWORKS。
  3. 解除安裝舊的使用許可管理員。詳細資訊請參閱 解除安裝 SolidNetWork License Manager。
  4. 安裝新的使用許可管理員以及在使用許可管理員電腦上重新啟動 SolidNetWork license。詳細資訊請參閱 安裝 SolidNetWork License Manager 伺服器。

如果您在升級電腦上的 SolidNetWork License Manager 而該電腦也執行 SOLIDWORKS 應用程式，請先升級 SolidNetWork License Manager 和客戶端，然後才可以在該電腦上安裝任何新的 SOLIDWORKS 應用程式 Service Pack。

如果您在代管管理安裝點的電腦上升級使用許可管理員，請先升級使用許可管理員然後再升級管理安裝點。 詳細資訊請參閱 在使用許可管理員和管理安裝點安裝時使用同一部電腦。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


移動 SolidNetWork License

若要將 SolidNetWork License 移動至新的或是已升級的電腦上，請先在 Dassault Systèmes SOLIDWORKS Corporation 的使用許可授權碼伺服器上停用使用許可，然後在另一台電腦上重新啟動。

如果您無法將 Dassault Systèmes SOLIDWORKS Corporation 的使用許可停用 (例如硬碟機故障)，在大部分的情況中仍可成功重新啟動。如果不是，請聯絡您的 Value Added Reseller 取得協助。

若要移動 SolidNetWork 使用許可：

  1. 啟動 SolidNetWork License Manager 伺服器，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。
  2. 在伺服器管理標籤的使用許可資訊下，按一下修改。SOLIDWORKS 產品啟動精靈將會啟動。
  3. 在您想執行的工作？下，選擇將產品使用許可移至新的/升級的電腦，然後按一下下一步。
  4. 在序號：清單之下，選擇序號或按一下全選以啟動所有 SOLIDWORKS 序號。
    1. 選擇自動在 Internet 上 (建議使用) 選項。
    2. 在聯絡資訊 (必填的)：之下，指定電子郵件地址。
  5. 隨即會顯示停用成功訊息方塊。
    停用產品使用許可的作業即完成。
  6. 按一下完成。
上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


刪除 SolidNetWork 使用許可檔案

您可以在升級至新使用許可之前，先刪除已過期的 SolidNetWork license 檔案。

  1. 啟動 SolidNetWork License Manager，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器。
  2. 在伺服器系統管理標籤的使用許可資訊下，按一下修改，然後按一下下一步。
  3. 在啟動/停用您的 SOLIDWORKS 產品頁面上，選擇已過期的 SolidNetWork license 檔案，然後按一下移除。
  4. 按一下完成與確定以結束。
上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


借用與歸還 SolidNetWork 使用許可

您可以借用一個 SolidNetWork 使用許可以便從遠端位置使用軟體。由於使用許可會從可用的使用許可池中移除，因此必須歸還借用的使用許可以便使它再次成為可用狀態。

借出的使用許可只在目前借用的系統中，由目前借用的使用者使用時有效。您無法移動借出的使用許可。

使用許可可被借出一段特定的時間，最多 30 天（或由您的系統管理員來定義），使用許可會從可用的使用許可控制池中被移除。

如果 SOLIDWORKS 使用許可正在使用中，便無法借用及歸還該使用許可。

系統管理員可以自訂借用來：
  • 定義可借用使用許可的使用者或小組。
  • 設定無法被借出的使用許可數量

詳細資訊請參閱 SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf。

目錄

  • 借用 SolidNetWork 使用許可

  • 歸還借用的 SolidNetWork 使用許可

    由於借用的 SolidNetWork 使用許可會從可用的使用許可池中移除，因此必須歸還借用的使用許可以便使它再次成為可用狀態。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


借用 SolidNetWork 使用許可

請一律從開始功能表啟動 SolidNetWork License Manager。您必須連線至 SolidNetWork License Manager 才能借用使用許可。

根據您的系統設定，這些步驟可能有所不同。 請參閱 Microsoft Windows 說明文件以取得額外指示和選項。
  1. 在客戶端機器上啟動 SolidNetWork License Manager，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 客戶端版本。
  2. 在使用許可的借用標籤中：
    1. 在借用直至中選擇一個日期。
    2. 在可用的產品使用許可下，選擇要借用的產品，然後按一下借用。
    3. 在對話方塊提示中選擇產品，從清單中選擇產品，然後按一下確定以確認。
    4. 在對話方塊的底部，按一下重新整理。
      借用直至欄會顯示使用許可何時到期歸還。
  3. 按一下確定。

在「使用許可的使用」標籤中，您也可以檢視全部的使用許可、可使用的使用許可和使用使用許可的使用者，以及借用直至日期。

如果您於遠端工作，且 SOLIDWORKS 應用程式開啟速度緩慢，請選擇僅使用借用的使用許可 (更快啟動)。

此選項會封鎖對您使用許可伺服器的查詢，在某些環境中伺服器可能會變慢。省略查詢即可更快啟動應用程式，但僅可使用您借用的使用許可。

請重新啟動您的應用程式，讓此選項生效。

上層主題 借用與歸還 SolidNetWork 使用許可
歸還借用的 SolidNetWork 使用許可


歸還借用的 SolidNetWork 使用許可

由於借用的 SolidNetWork 使用許可會從可用的使用許可池中移除，因此必須歸還借用的使用許可以便使它再次成為可用狀態。

  1. 在客戶端機器上啟動 SolidNetWork License Manager，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 客戶端版本。
  2. 在使用許可的借用標籤中：
    1. 在借用的產品使用許可下，選擇要歸還的產品，然後按一下歸還。
    2. 按一下重新整理。借用直至欄變成空白，表示已歸還使用許可。
  3. 按一下確定。

在「使用許可的使用」標籤中，您也可以檢視全部的使用許可。

到期日後，您便不需要歸還使用許可。使用許可會在失效日期的午夜歸還至 SolidNetWork License Manager 使用許可池中，而遠端系統中的應用程式將不再執行。
上層主題 借用與歸還 SolidNetWork 使用許可
借用 SolidNetWork 使用許可


管理各 SOLIDWORKS 版本的存取權限

您可以在 SolidNetWork 的環境中限制使用者使用特定的 SOLIDWORKS 版本。 此功能可讓您管理不同人員、專案及業務單位使用的 SOLIDWORKS 版本。

若要使用 FlexNet 檔案選項來管理 SOLIDWORKS 版本的存取：

  1. 在 SolidNetWork 使用許可管理員安裝目錄中，產生一個文字檔：
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. 若要在使用許可檔案中管理特定 SOLIDWORKS 版本的存取，請將下列語法新增至 SOLIDWORKS 旁：
    :SWVERSION=xx 其中 xx 是您要管理的 SOLIDWORKS 產品版本
  3. 若要管理多個 SOLIDWORKS 版本，請針對您要管理的每個版本新增一行。

    並非所有的 FlexNet 選項均受支援。 篩選器版本的支援選項為：

    INCLUDE | 只允許使用者或群組啟動特定版本。 不允許所有其他的使用者啟動該版本。
    INCLUDE_BORROW | 只允許使用者或群組借用特定版本。 不允許所有其他的使用者借用該版本。
    EXCLUDE | 禁止列出的使用者或群組啟動特定的 SOLIDWORKS 版本。 EXCLUDE 優先於 INCLUDE。
    EXCLUDE_BORROW | 禁止列出的使用者或群組借用特定的 SOLIDWORKS 版本。 EXCLUDE 優先於 INCLUDE。
    範例：
    1 | SWVERSION=32.0 請參考 SOLIDWORKS 2025
    SWVERSION=31.0 請參考 SOLIDWORKS 2024
    2 | INCLUDE solidworks:SWVERSION=32.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=32.0 USER jane
    選項檔案中的這些行僅允許 jane 執行 SOLIDWORKS 2025。其他所有使用者都無法執行或借用 SOLIDWORKS 2025，但可以執行和借用其他版本的 SOLIDWORKS。jane 也可以執行和借用其他版本的 SOLIDWORKS。
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=32.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=31.0 GROUP chicago
    EXCLUDE solidworks USER don
    這些行可定義名為 chicago 的使用者 GROUP，並禁止他們存取 SOLIDWORKS 2025 及 SOLIDWORKS 2024，但他們可以執行其他任何版本的 SOLIDWORKS。使用者 don 無法執行任何版本的 SOLIDWORKS。
    4 | EXCLUDE swinspection_std:SWVERSION=32.0 HOST machine1
    此行禁止 machine1 上的任何人啟動 SOLIDWORKS Inspection 2025。

    如需有關 FlexNet 的資訊，請參閱 SolidNetWork License Manager 安裝目錄 (\Docs\flexuser\fnp_LicAdmin.pdf) 中的 FlexNet Publisher 使用許可管理指南。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


監控使用許可閒置時間

SOLIDWORKS 能讓您在 SolidNetWork License Manager 上登記許可閒置的時間，讓一段特定時間未被使用的使用許可可以重新回到自由許可的控制池內。

  1. 在 SolidNetwork License Manager 安裝目錄中，產生一個文字檔：
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. 加入下列的各行至檔案中：
    TIMEOUTALL seconds

    其中 seconds 是大於或等於 900 (即 15 分鐘) 的數字，此為所允許的最小時間。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


使用暫時使用許可

如果 SolidNetWork license 無法使用，您可以使用暫時性的「any」使用許可。

根據預設，SolidNetWork License Manager 一次只能啟動一個伺服器。若要在測試環境中工作，您可以透過技術支援取得暫時使用許可檔案，並將「any」使用許可載入另一部伺服器上的 SolidNetWork License Manager。如果使用離線伺服器，您可以使用相同的指示來載入免啟動使用許可。

安裝「any」使用許可檔案，即表示您同意從 Dassault Systèmes SOLIDWORKS Corporation 收到 SolidNetWork license 後，便實行使用許可。仍然需要遵守使用許可的限制。

使用「any」使用許可：

  1. 啟動 SolidNetWork License Manager，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。
  2. 如果軟體提示您啟動，請按一下否。
  3. 在「伺服器管理」標籤中，按一下進階選項 > 選項。
  4. 在 SolidNetWork Server License 模式之下，按一下使用使用許可檔案，然後按確定。
  5. 在「伺服器管理」標籤的使用許可資訊下，按一下修改。
    SolidNetWork License 檔案精靈出現。
  6. 在伺服器類型之下，選擇單機，然後按下一步。
  7. 選擇硬體鎖 ID，輸入任何或 NIC 位址，以取得伺服器資訊。然後按一下下一步。

    當您看到此訊息時，請按一下取消：無法讀取硬體鎖 ID 號碼。

    如果您的電腦有使用防火牆，您可能需要在螢幕上訂出其他規格。詳細資訊請參閱使用 SolidNetWork 使用許可與防火牆。
  8. 在「使用許可」下，按一下讀取以讀取使用許可檔案。
  9. 在讀取對話方塊中，瀏覽至技術支援提供的 SNL_ANY.txt 或 SNL_(NIC Card Number).txt 檔案，並按一下開啟。然後按一下確定。
    SolidNetWork 檔案使用許可精靈會列出文字檔的使用許可。
    按一下移除刪除清單中已過期的臨時授權項目。
  10. 按一下完成以關閉 SolidNetWork License 檔案精靈。
  11. 啟動「any」使用許可：
    1. 在「伺服器管理」標籤中，按一下進階選項 > 選項。
    2. 在 SolidNetWork Server License 模式之下，按一下使用使用許可檔案，然後按一下確定。
    3. 在「伺服器系統管理」標籤中，按一下修改 > 啟動/停用您的產品使用許可。
    4. 選擇序號，輸入聯絡資訊，然後選擇啟動方法。如果您選擇手動啟動，請依照指示操作。
    5. 按一下完成以確認啟動。
上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


使用有附加產品的 SolidNetWork 使用許可

您可以使用 SolidNetWork License Manager 來分配 SOLIDWORKS 核心附加產品的使用許可。

  • 不需要有相同數量的 SOLIDWORKS 軟體使用許可與 SOLIDWORKS 附加程式使用許可。
  • 若要取出附加產品的使用許可，您必須先取出 SOLIDWORKS 的使用許可。
  • 要借用一個附加的產品的使用許可，您必須同時借用 SOLIDWORKS 軟體使用許可以及包括附加程式的 SOLIDWORKS 產品使用許可。依預設會借用 SOLIDWORKS Standard 使用許可，但若要啟用附加程式，您則必須借用 SOLIDWORKS Professional、SOLIDWORKS Premium 或 SOLIDWORKS Ultimate 產品的使用許可。
  • 釋放一個附加的產品的使用許可：
    • 在 SOLIDWORKS 中，按一下工具 > 附加程式然後清除附加程式。
    • 離開 SOLIDWORKS。
上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可

SolidNetWork 使用許可使用者可以在加入 SOLIDWORKS Simulation 時，控制要使用其使用許可集區中的哪些 SOLIDWORKS® Simulation 使用許可。 在需要更高的使用許可類型來執行更多進階研究時，這些使用者也可以升級 SOLIDWORKS Simulation 使用許可，而無需上傳附加程式。

  1. 若要使用特定 SOLIDWORKS Simulation 使用許可：
    1. 在 SOLIDWORKS 中，按一下工具 > 附加程式，然後在附加程式對話方塊中選擇 SOLIDWORKS Simulation。
    2. 在 SOLIDWORKS Simulation (CommandManager) 中，按一下向下箭頭 [image] 以顯示伺服器中支援 Simulation 的使用許可清單。

    3. 選擇適當的 SOLIDWORKS Simulation 使用許可。
  2. 若要檢查或變更目前的 SOLIDWORKS Simulation 使用許可，請在 SOLIDWORKS Simulation (CommandManager) 中按一下向下箭頭 [image] 。

    使用中的使用許可會顯示核取符號。 如果可使用更多的進階使用許可類型，則可以進行升級。
    您無法將 SOLIDWORKS Simulation 使用許可降級。 停用 SOLIDWORKS Simulation 附加程式，並將使用許可加回較低的層級。
  3. 選擇性的: 若要停用附加程式，請按一下 SOLIDWORKS Simulation (CommandManager)，或從工具 > 附加程式將其清除。
下列情況仍可使用的使用許可順序：
  • 當 SOLIDWORKS Simulation 開啟執行時。
  • 如果 SOLIDWORKS Simulation 已加入工具 > 附加程式。
  • 如果您在未從下拉清單指定使用許可的情況下，按一下 SOLIDWORKS Simulation。
上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


載入 Flow Simulation 模組

作為 SolidNetWork License 客戶，您可使用兩種方法控制載入 HVAC 及電子冷卻附加程式模組，以執行 Flow Simulation。

第一種方法可讓您在載入 Flow Simulation 時，指定附加程式的預設行為。選項自動載入 Flow Simulation 附加程式模組 (若有) 位於 SolidNetWork License Manager 客戶端 > 使用許可順序標籤中。如果不需要 Flow Simulation 附加程式，請清除此選項。在現有方法中加入 Flow Simulation 時，不會載入 HVAC 和電子冷卻附加程式模組。

第二種方法可讓您在載入 Flow Simulation 時覆寫預設行為，並納入 HVAC 和電子冷卻附加程式模組。按一下 SOLIDWORKS Flow Simulation (SOLIDWORKS® 附加程式工具列) 或具有一個或兩個要載入附加程式模組的 SOLIDWORKS Flow Simulation 上的向下箭頭 [image] 。

如果沒有這些方法，則不論您是否需要這些附加程式模組的使用許可，都會耗用使用許可，而且可能會遭您網路上的其他使用者拒絕。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時

當您執行 SOLIDWORKS Simulation、Plastics 或 Flow Simulation 研究時，網路使用許可會保持啟用且不會逾時。SOLIDWORKS 在計算過程中持有使用許可，被認定為一項活動。

無活動期由 TIMEOUT 選項所定義，只有在研究完成計算後才會生效。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


在使用許可管理員和管理安裝點安裝時使用同一部電腦

您可以在網路上將一台電腦設定為散佈 SolidNetWork 使用許可的使用許可管理員，以及作為管理安裝點的位置 (使用者可以透過它安裝 SOLIDWORKS 軟體)。

客戶端電腦可以從使用許可管理員取得使用許可，然後從同一部電腦安裝 SOLIDWORKS。

此種組態要求使用許可管理員及管理安裝點安裝在同一部電腦上。先安裝使用許可管理員，然後產生與部署管理安裝點。
詳細資訊請參閱：
  • 安裝 SolidNetWork License Manager 伺服器
  • 部署至多個客戶端
上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
解除安裝 SolidNetWork License Manager
FlexNet Publisher 使用許可管理


解除安裝 SolidNetWork License Manager

在升級 SolidNetWork License Manager，您必須解除安裝舊的使用許可管理員，然後才能安裝新的管理員。

  1. 啟動 SolidNetwork License Manager，請按一下開始 > SOLIDWORKS 工具版本 > SolidNetWork License Manager 伺服器版本。
  2. 請確認網路上沒有客戶端電腦正在執行 SOLIDWORKS。
    使用許可的使用標籤顯示正在執行 SOLIDWORKS 的客戶端。
  3. 如果您想要將 SolidNetWork 使用許可移動至其他電腦，請先停用該電腦的使用許可，然後再從此電腦上移除 SolidNetWork License Manager。
    如需移動 SolidNetWork License 的相關資訊，請參閱移動 SolidNetWork License。
  4. 在伺服器管理標籤的使用許可伺服器之下，按一下停止。
  5. 按一下確定來離開使用許可管理員。
  6. 在 Windows 中，開啟控制台 > 程式和功能。
  7. 選擇 SOLIDWORKS SolidNetWork License Manager，按一下解除安裝，然後確認解除安裝。
  8. 在檔案 Explorer 中，刪除 SOLIDWORKS SolidNetWork License Manager 資料夾。
    (此資料夾通常是位於 SOLIDWORKS 安裝目錄中的 Program Files (x86) 之下)。

您現在已經準備好安裝新的使用許可管理員版本。詳細資訊請參閱安裝 SolidNetWork License Manager 伺服器。

如果 SolidNetWork License Manager 電腦有一附加的硬體鎖，請在安裝新版本的 SolidNetWork License Manager 之前先移除硬體鎖。
上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
FlexNet Publisher 使用許可管理
安裝 SolidNetWork License Manager 伺服器


FlexNet Publisher 使用許可管理

SolidNetWork 使用許可是以 FlexNet Publisher® 使用許可管理為基礎。

如需更多有關 FlexNet Publisher 使用許可管理的資訊，請參閱 SolidNetWork License Manager 安裝目錄 (C:\Program Files\SOLIDWORKS SolidNetWork License Manager\Docs\flexuser\fnp_LicAdmin.pdf) 中的 FlexNet Publisher 使用許可管理指南

如需有關 FlexNet Publisher 使用許可管理的最新資訊，請聯絡 Flexera® Software。

您可以檢閱使用許可伺服器上的記錄檔以檢查 FlexNet 版本。開啟 SolidNetwork License Manager 伺服器，然後按一下伺服器管理 > 檢視記錄檔。記錄檔會在括號開始處列出 FlexNet 使用許可版本。

上層主題 使用 SolidNetWork License Manager 來管理使用許可
安裝 SolidNetWork 使用許可概觀
啟動 SolidNetWork License Manager
升級 SolidNetWork 使用許可管理員
移動 SolidNetWork License
刪除 SolidNetWork 使用許可檔案
借用與歸還 SolidNetWork 使用許可
管理各 SOLIDWORKS 版本的存取權限
監控使用許可閒置時間
使用暫時使用許可
使用有附加產品的 SolidNetWork 使用許可
選擇擁有 SolidNetWork License 的 SOLIDWORKS Simulation 使用許可
載入 Flow Simulation 模組
SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation 和 SOLIDWORKS Plastics 無活動逾時
在使用許可管理員和管理安裝點安裝時使用同一部電腦
解除安裝 SolidNetWork License Manager


疑難排解

請參閱這些主題以協助您解決安裝問題。

目錄

  • 網路使用許可的使用

  • SOLIDWORKS 安裝管理員記錄檔案

    SOLIDWORKS 安裝管理員記錄檔案能夠協助您對安裝上的問題進行疑難排解。

  • SOLIDWORKS 安裝管理員下載資料夾

    SOLIDWORKS 安裝管理員可下載其所需要的安裝檔案至您指定的資料夾中。 這些主題提供您關於下載資料夾常見問題的答案。

  • SolidNetWork 使用許可疑難排解

    如果 SolidNetWork 使用許可管理員安裝失敗，請檢查這些可能的說明。

  • 升級的疑難排解

    如果您在升級新的 SOLIDWORKS 版本時遇到問題，請查看這些可能有用的說明。

  • 安裝或升級時驗證圖形顯示卡

    當您在機器上完成 SOLIDWORKS 的安裝或升級後，請執行 SOLIDWORKS Rx 以確保機器正在執行支援的圖形顯示卡及圖形顯示卡驅動程式。


網路使用許可的使用

當伺服器對某產品沒有許可可供使用時，此對話方塊出現。

按一下產品方塊中的箭頭來顯示所有的產品選擇。 選擇包括 SOLIDWORKS 及所有購買的附加應用程式。

全部的使用許可是您購買的使用許可總數。

可使用的使用許可是未在使用中的使用許可數。

使用許可的使用者方塊提供使用使用許可之每個人的資訊。

上層主題 疑難排解
SOLIDWORKS 安裝管理員記錄檔案
SOLIDWORKS 安裝管理員下載資料夾
SolidNetWork 使用許可疑難排解
升級的疑難排解
安裝或升級時驗證圖形顯示卡


SOLIDWORKS 安裝管理員記錄檔案

SOLIDWORKS 安裝管理員記錄檔案能夠協助您對安裝上的問題進行疑難排解。

這些記錄檔案的位置與其他 SOLIDWORKS 應用程式記錄檔案的位置相同。

  • C:\Users\username\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

如果您是從系統帳號執行安裝管理員，則記錄檔位於此資料夾：
  • C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version
若要查看記錄檔案目錄，您需要將 Windows 資料夾選項設定為顯示隱藏的檔案及資料夾。

如果應用程式資料位於 C: 以外的磁碟機，請根據情況調整目錄路徑。

此目錄包含 SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt 檔案，該檔案是 SOLIDWORKS 安裝管理員進度的一般記錄。

Other Logs 子目錄中包含更多詳細的安裝記錄資訊。

上層主題 疑難排解
網路使用許可的使用
SOLIDWORKS 安裝管理員下載資料夾
SolidNetWork 使用許可疑難排解
升級的疑難排解
安裝或升級時驗證圖形顯示卡


SOLIDWORKS 安裝管理員下載資料夾

SOLIDWORKS 安裝管理員可下載其所需要的安裝檔案至您指定的資料夾中。 這些主題提供您關於下載資料夾常見問題的答案。

問題 答案
如何安裝在此資料夾中的檔案？

執行 setup.exe。如果選擇安裝過去沒有下載的項目，可能仍然需要下載某些檔案。

請勿使用 msiexec 進行安裝 (請參閱下方)。
可以使用 msiexec 或一些其他應用程式來手動安裝此資料夾中的 MSI 檔案嗎？

否。 安裝管理員並不會下載執行 msiexec 時需要的某些檔案。
可以為安裝的每個版本選擇相同的下載資料夾嗎？

下載資料夾為版本特定。 SOLIDWORKS 安裝管理員會自動在指定資料夾中產生版本特有的子資料夾。

我從 Dassault Systèmes SOLIDWORKS Corporation 網站手動下載了某些產品。 安裝管理員可以安裝這些產品嗎？
SOLIDWORKS 安裝管理員可使用手動下載的檔案。 不過，最好還是執行 SOLIDWORKS 安裝管理員，藉由選擇選項來下載檔案。 SOLIDWORKS 安裝管理員會根據您正安裝的項目來顯示您需要的檔案，並提供每個檔案的下載連結。 當內建的下載頁面無法作用時（主要有可能是代理伺服器強制的限制），可以使用此選項。
如果在下載或安裝時，對話方塊詢問您要儲存還是執行檔案，請一律指定儲存。
下載的檔案可與其他使用者共享嗎？

是。 要如此操作，請下載至網路共用處。 接下來，每個客戶端就可以從共用處執行 SOLIDWORKS 安裝管理員來進行安裝。

除非使用者選擇要安裝的部份項目在最初下載並未選取，或者如果使用此下載安裝的電腦的必要項目與下載檔案電腦的必要項目不同，否則不需要進一步的下載。

如果您是代替其他人下載而不是自己要安裝，請在安裝時選擇只要下載選項。 這個選項可讓您選擇產品，不論它是否能安裝在您的系統中。 不過，不能使用此選項下載修補程式。
如何知道是否有新的 SOLIDWORKS 產品版本？
在下列的情況下，會通知您有新的版本：
  • 如果您執行「檢查更新」(開始 > SOLIDWORKS 安裝管理員 > 檢查更新)
  • 如果您已啟用 SOLIDWORKS 背景下載程式
  • 如果您在 Windows 新增/移除程式選擇已安裝的 SOLIDWORKS 版本，然後按一下變更
  • 如果您是從下載資料夾執行舊版的安裝管理員 (sldIM.exe)
在這些狀況下，您可以選擇下載較新的版本。 SOLIDWORKS 安裝管理員將會下載與執行較新的安裝管理員版本，不會下載和執行任何安裝檔案。 新版的 SOLIDWORKS 安裝管理員版本執行之後，您可以選擇一組安裝動作。 SOLIDWORKS 安裝管理員會決定需要哪些安裝檔案 (先前沒有下載的) 並且可為您下載這些檔案。
為什麼 SOLIDWORKS 安裝管理員不讓我選擇要安裝之產品的不同 Service Pack？

SOLIDWORKS 安裝管理員的每個版本是專門用來只安裝特定版本的 SOLIDWORKS 產品。 如果您想要安裝不同的 service pack，則需要執行該版本的 SOLIDWORKS 安裝管理員。 要找出可用的最新版本，請參閱之前的品項。
為什麼 SOLIDWORKS 安裝管理員無法下載檔案？

如果代理伺服器限制會造成應用程式無法下載檔案，SOLIDWORKS 安裝管理員就無法自動下載檔案。

您可以手動下載檔案，然後使用 SOLIDWORKS 安裝管理員安裝檔案。在 SOLIDWORKS 安裝管理員中選擇下載個別檔案的選項 (例如下載選項頁面中的手動下載方法)。根據您產品的選擇及系統的需求，一網頁會出現在個別的視窗中，其中包含手動下載所需檔案的連結。
並非所有的 SOLIDWORKS 產品均有更新至最新的 Service Pack。 為什麼「檢查更新」顯示這已是最新的版本？

檢查更新 只能告知您是否安裝了 (或正執行) SOLIDWORKS 安裝管理員的最新版本。

如果您要將所有產品都更新至控制台 > 程式集 > 程式和功能中安裝的最新版本，請選擇最新安裝的 SOLIDWORKS 版本，然後按一下變更。
可以複製 DVD 到下載資料夾中嗎？

可以，但除非您複製為該作業平台所發行之 DVD 的整個內容，否則安裝有可能失敗。 SOLIDWORKS 安裝管理員會尋找 swdata*.id 檔案以判定版本。 如果這些檔案不是最新的，它將無法識別您複製的任何安裝檔案，因此需要下載它們。
上層主題 疑難排解
網路使用許可的使用
SOLIDWORKS 安裝管理員記錄檔案
SolidNetWork 使用許可疑難排解
升級的疑難排解
安裝或升級時驗證圖形顯示卡


SolidNetWork 使用許可疑難排解

如果 SolidNetWork 使用許可管理員安裝失敗，請檢查這些可能的說明。

上層主題 疑難排解
網路使用許可的使用
SOLIDWORKS 安裝管理員記錄檔案
SOLIDWORKS 安裝管理員下載資料夾
升級的疑難排解
安裝或升級時驗證圖形顯示卡

存取 SolidNetWork 使用許可記錄檔案

當使用許可發生錯誤時，答案經常出現在 SNL_Manager_安裝目錄\lmgrd.log 檔案中。

無法獲得 SOLIDWORKS 的使用許可。 無法連接至伺服器。

這個問題通常是由於連接埠設定所造成的。

  • 在 SolidNetWork 使用許可管理員與使用許可客戶端之間的連接埠設定可能不符。
  • 可能沒有為 SolidNetWork License Manager 的多個版本指定額外的連接埠設定。
  • 請檢查客戶端機器是否可以根據伺服器名稱精確地解出及產生路線至伺服器。
有關 SolidNetWork License Manager 與客戶端連接埠設定的詳細資訊，請參閱使用 SolidNetWork 使用許可與防火牆。
使用 SolidNetWork 使用許可與防火牆


升級的疑難排解

如果您在升級新的 SOLIDWORKS 版本時遇到問題，請查看這些可能有用的說明。

上層主題 疑難排解
網路使用許可的使用
SOLIDWORKS 安裝管理員記錄檔案
SOLIDWORKS 安裝管理員下載資料夾
SolidNetWork 使用許可疑難排解
安裝或升級時驗證圖形顯示卡

修改或修復已移動的來源

安裝 SOLIDWORKS 時，SOLIDWORKS 安裝管理員會記住安裝來源 (磁碟媒體、網路上的磁碟安裝點等等) 的位置。當修改或修復時，其預期來源是在相同的位置。

如果來源移動或被刪除，或來源媒體變更，SOLIDWORKS 安裝管理員會產生一個錯誤訊息。不過，您可以瀏覽至另一個位置來修改或修復安裝來源，只要該位置包含所有相同的檔案及資料夾結構。


安裝或升級時驗證圖形顯示卡

當您在機器上完成 SOLIDWORKS 的安裝或升級後，請執行 SOLIDWORKS Rx 以確保機器正在執行支援的圖形顯示卡及圖形顯示卡驅動程式。

若要在安裝或升級時驗證圖形顯示卡：

  1. 當安裝管理員完成安裝並顯示完成頁面時，請在檢查您的系統下按一下執行系統診斷。

    SOLIDWORKS Rx 隨即啟動並執行診斷。

  2. SOLIDWORKS Rx 會確認是否支援圖形顯示卡及圖形顯示卡驅動程式。
    如果支援圖形顯示卡但不支援驅動程式，則狀態訊息可能會提供驅動程式更新的指標。

每啟動 SOLIDWORKS 十次時，即會出現檢查您的系統訊息，並建議您再次執行系統診斷。若要抑制這些通知，請在 Windows 通知區域中用右鍵按一下 SOLIDWORKS Resource Monitor [image] ，然後按一下關閉圖形通知。

您可以隨時用右鍵按一下 Windows 通知區域中的 SOLIDWORKS Resource Monitor，以驗證圖形顯示卡與驅動程式。功能表也可讓您：
  • 存取 SOLIDWORKS Resource Monitor 的說明
  • 執行系統診斷
  • 解除圖形通知
  • 解除訂閱通知
  • 檢視經認證的圖形卡驅動程式
上層主題 疑難排解
網路使用許可的使用
SOLIDWORKS 安裝管理員記錄檔案
SOLIDWORKS 安裝管理員下載資料夾
SolidNetWork 使用許可疑難排解
升級的疑難排解


SOLIDWORKS 安裝管理員應用程式說明

SOLIDWORKS 安裝管理員是可安裝並更新 SOLIDWORKS 產品的獨立應用程式。

SOLIDWORKS 安裝管理員是下載、安裝、修改、更新、修復和刪除 SOLIDWORKS 軟體的主要工具。

您可以使用下列方式來執行 SOLIDWORKS 安裝管理員：
  • 從 SOLIDWORKS DVD、共用的來源或下載資料夾 (安裝新版本時)
  • 從控制台新增或移除程式頁（修改或移除現有版本時）
  • 透過排定或手動更新檢查（刪除、下載與安裝新的發行版本時）

SOLIDWORKS 的每個版本都有該 SOLIDWORKS 版本專屬的 SOLIDWORKS 安裝管理員版本。

目錄

  • SOLIDWORKS 背景下載程式

    SOLIDWORKS 背景下載程式使用背景程序來執行自動化檔案下載 (例如，在找到新的 Service Pack 版本時)，可讓您在下載時繼續進行其他工作。 下載完成時，您可以決定要立刻安裝，暫緩下載，或移除下載。

  • 指定安裝管理員選項

    這些選項包括記錄、網際網路存取以及安裝管理員所用語言的設定。

  • 檢查更新結果

    檢查更新會尋找 SOLIDWORKS 的更新版本。

  • 管理安裝點位置

    指定管理安裝點的安裝位置。

  • 下載選項

    指定完成下載作業的詳細資訊，例如下載的檔案位置、如何下載檔案，以及是否安裝下載的檔案。

  • SOLIDWORKS 安裝管理員檔案的下載選項

    您選擇要下載 SOLIDWORKS 安裝管理員較新的版本。 使用此螢幕來指定於何處及如何下載。

  • 下載產品安裝檔案

    為特定的產品指定於何處及如何下載遺失的檔案。

  • 下載進度

    SOLIDWORKS 安裝管理員在此過程中，會平行處理所有檔案的下載、確認及擷取。

  • 下載結果

    指出下載是否順利完成，在操作期間失敗或是已經取消。

  • 安裝錯誤/安裝取消

    安裝時發生錯誤或是已經取消。

  • 安裝完成

    SOLIDWORKS 安裝管理員已完成其處理。

  • 安裝位置

  • 升級選項

    此電腦上安裝了一個或多個較舊的 SOLIDWORKS 版本。 您可以產生新的安裝項目，其會與較舊版本共存，或者您可以升級，升級則會移除較舊的版本。

  • 安裝進度

    此螢幕顯示安裝的進度。

  • 安裝類型

    您可以指定想要執行的安裝作業。 例如產生新的安裝、修改或修復現有安裝、產生管理安裝點、安裝管理伺服器產品，或下載檔案，讓您可以在其他電腦上共用和安裝它們。

  • 安裝及管理多台電腦

    SOLIDWORKS 安裝管理員提供下列安裝與管理多個 SOLIDWORKS 電腦的工具。

  • 手動下載

    您已經選擇手動下載檔案 (或者可能是您上次執行 SOLIDWORKS 安裝管理員時已經選擇手動下載)。

  • 有較新的版本可用

    安裝管理員偵測到有較新版本的 SOLIDWORKS 產品。 您可以選擇安裝包含在原始安裝 DVD 中的版本或下載，或您可以選擇下載及安裝較新的版本。

  • 沒有新的版本可用

    沒有較新的版本可供下載。繼續安裝指定的版本。

  • 偵測到的程序

    SOLIDWORKS 安裝管理員在這台電腦上偵測到可能會使安裝失敗的程序。

  • 產品選擇

    指定要安裝、修改、下載或移除的產品元件。

  • 下載的產品

    選擇要下載至特定位置的 SOLIDWORKS 產品。

  • 要修復的產品

    指定修復此安裝時，此螢幕會顯示此版本的 SOLIDWORKS 安裝管理員能夠修復的 SOLIDWORKS 產品以及版本號碼。

  • 序號

    序號會將您的電腦與您所購買的 SOLIDWORKS 產品建立關聯。

  • 伺服器安裝

    會列出您嘗試安裝的伺服器產品，並有安裝的結果。

  • 摘要

    SOLIDWORKS 安裝管理員擁有完成安裝作業所需的所有資訊。

  • 系統檢查警告

    系統檢查所報告的問題會影響您繼續安裝的方式。 在多數的情況下，您應該能夠繼續使用 SOLIDWORKS 安裝管理員。

  • 異型孔精靈/Toolbox 選項

    如果您安裝 SOLIDWORKS Toolbox，SOLIDWORKS 會包括鑽孔類型與五金器具的標準資料庫。

  • 解除安裝產品

    當您從控制台中選擇移除或解除安裝程式時，螢幕會顯示可以由此版本 SOLIDWORKS 安裝管理員解除安裝的 SOLIDWORKS 產品 (包含版本編號)。 您可以選擇要執行標準、自訂或完整的解除安裝。


SOLIDWORKS 背景下載程式

SOLIDWORKS 背景下載程式使用背景程序來執行自動化檔案下載 (例如，在找到新的 Service Pack 版本時)，可讓您在下載時繼續進行其他工作。 下載完成時，您可以決定要立刻安裝，暫緩下載，或移除下載。

安裝 SOLIDWORKS 時，SOLIDWORKS 背景下載程式預設為啟用。

SOLIDWORKS 安裝管理程式正在執行時，無論 SOLIDWORKS 背景下載程式是在進行安裝或下載作業，背景下載程式都會暫停。 例如，它會暫停任何執行中的下載，不允許開始任何新的下載，而且不允許變更指定的下載資料夾。

在安裝過程中您可以停用背景下載程式。 在「摘要」頁，在「下載選項」下，清除為之後的 service packs 使用背景下載程式選項。

啟用後，此圖示出現在工具列中的 Windows 通知區域中：

按一下此圖示可啟用下列作業：
  • 背景下載程式的說明
  • 暫停下載
  • 繼續下載
  • 取消下載
  • 安裝選項
  • 變更下載設定
  • 檢查更新
  • 自動檢查更新
  • 自動下載更新
  • 停用背景下載程式

背景下載程式的說明

在 SOLIDWORKS 安裝指南中開啟背景下載程式的這一說明主題。

暫停/繼續下載

如果下載在背景中執行，按一下暫停下載以暫停該下載，稍後按一下繼續下載又可繼續。

取消下載

如果下載在執行中，停止該下載並刪除背景下載程式已經下載的任何檔案。
取消後的下載無法再繼續。

安裝選項

下載完成後，您可以選擇下列選項：
  • 馬上安裝： 安裝下載的檔案。
  • 稍後再提醒我： 不安裝下載的檔案，但設定稍後以訊息提醒您。
  • 刪除此下載： 不安裝下載的檔案，而將其刪除。 （如果您決定不再安裝下載的檔案，此選項很有用。）

變更下載設定

變更背景下載程式下載檔案的資料夾位置。

如果下載正在執行或已暫停，此選項不可用。
您也可以指定更新檢查之間的天數。

檢查更新

執行 SOLIDWORKS 安裝管理員的檢查更新功能。

自動檢查更新

定期執行檢查更新，在有更新可供下載時通知您。

自動下載更新

定期執行檢查更新，在有更新時進行下載。

停用及重新啟用 SOLIDWORKS 背景下載程式

您可以按一下 Windows 系統匣中的圖示來停用背景下載程式，然後選擇停用背景下載程式。

若要重新啟用背景下載程式，請按一下開始 > SOLIDWORKS 安裝管理員 > SOLIDWORKS 背景下載程式。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


指定安裝管理員選項

這些選項包括記錄、網際網路存取以及安裝管理員所用語言的設定。

要在安裝軟體之前，指定安裝管理員選項：

  1. 在安裝管理員中，用右鍵按一下標題列的 SOLIDWORKS 圖示，並選擇：
    選項 | 敘述
    安裝記錄層級 將記錄層級指定為高、中或低。較高層級會收集更多資料用於疑難排解，但可能因此拖慢安裝速度。預設設定為低 (最快)，提供最佳效能和穩定性。

    產生 Windows Installer 記錄 (較慢)會將記錄檔儲存在與其他安裝記錄檔相同的資料夾。
    管理安裝點選項 | 選擇使用短檔名 (8.3 格式) 或使用完整的資料夾和檔案名稱。
    收集安裝記錄檔 | 指定安裝記錄檔的儲存位置。 安裝管理員將這些檔案儲存在 IM_Logs.zip。
    停用 Internet 的存取
    語言 | 指定安裝管理員所使用的語言。 預設為英文。
  2. 按一下關閉。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


檢查更新結果

檢查更新會尋找 SOLIDWORKS 的更新版本。

如果您在機器上擁有管理員權限，您就可以手動執行 檢查更新：
  • 在 Windows 中，按一下開始 > SOLIDWORKS 安裝管理員 > 檢查更新
  • 在 SOLIDWORKS 中，按一下 [image] > 檢查更新
從管理安裝點安裝的客戶端上無法使用檢查更新。

有新的版本可用

SOLIDWORKS 安裝管理員偵測到較新的 SOLIDWORKS 產品版本。 您可以選擇較新版本的 SOLIDWORKS 安裝管理員來更新至該版本。

這個較新的版本可以根據您在安裝中指定的產品下載安裝檔案。 您可以與其他使用 SOLIDWORKS 安裝管理員來安裝的使用者共用下載的檔案。

這些下載僅供 SOLIDWORKS 安裝管理員使用。
可用的選項有︰
  • 如果有多個版本可用，您可以從清單中選擇一個版本。
  • 關於此版本的詳細資訊，按一下查看此升級包含的項目。
按一下下一步可取得並執行所選的 SOLIDWORKS 安裝管理員版本。

沒有可用的新下載/無法檢查是否有新的版本

SOLIDWORKS 安裝管理員沒有找到更新的 SOLIDWORKS 產品版本，可能是因為您安裝的是最新版本，或者 SOLIDWORKS 安裝管理員無法連線至 SOLIDWORKS 站台進行檢查。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


管理安裝點位置

指定管理安裝點的安裝位置。

在產生管理安裝點時，這些選項適用：
新的安裝點位置 | 此為 SOLIDWORKS 安裝管理員產生新安裝點的目錄位置。 | 這個位置不能夠包含現有的管理安裝點。 管理安裝點必須位於可供客戶端部署共用的資料夾中。
估計產生安裝點所需的磁碟空間 | 此為管理安裝點所需的額外空間。 | 請確認正在安裝產品的磁碟有足夠的可用空間可支援安裝點需求。
產生安裝點來源 | 此為您安裝 SOLIDWORKS 產品的目錄位置。 只有在已指定只要安裝選項時，這個選項才會出現。 詳細資訊請參閱下載選項。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


下載選項

指定完成下載作業的詳細資訊，例如下載的檔案位置、如何下載檔案，以及是否安裝下載的檔案。

SOLIDWORKS 安裝管理員支援電子軟體通路 (ESD)。 如果您不是使用 SOLIDWORKS DVD 來安裝，系統將提示您指定所要安裝之 SOLIDWORKS 產品的來源。

關於下載資料夾問題的答案，請參閱SOLIDWORKS 安裝管理員下載資料夾。

您要執行何種操作？

選擇下列其中一項：

下載及安裝/下載及產生安裝點

在下載完成之後，SOLIDWORKS 安裝管理員會使用下載的檔案執行安裝。

只要下載。 您可以下載一次然後將下載的檔案與多部電腦共用。

SOLIDWORKS 安裝管理員在下載完成後不會執行安裝。

一般而言，如果您要下載檔案並且組態為多部電腦共用安裝檔案集，您需要指定這個選項。

如果您指定這個選項，系統接著會要求您在兩組要下載的檔案中做選擇：
  • 「此」電腦適用的檔案： 此下載僅包含目前在此電腦中安裝檔案集內缺少的檔案。
    這應該會是較小的下載，因為它只包含：
    • 在產品選擇頁中所選取的產品檔案
    • 您的電腦需要但是尚未安裝的先決要件檔案

    但是，如果您嘗試在其他電腦上使用此下載的檔案集執行安裝，可能會缺少某些檔案 (因為其他電腦上的安裝檔案集可能與這部電腦的不同)。 您可以使用這些下載檔案在其他電腦上進行安裝，但是在安裝執行時，您可能需要下載其他檔案才能使該電腦上的安裝檔案集完整無缺。

  • 可與「任何」電腦共用的檔案： 下載會包含完整的安裝檔案集，可用來將此版本安裝在任何電腦上。

    這會是較大的下載，因為它包含了完整的檔案集，您可以用來在任何電腦上安裝此版本的任何產品。

    如果您指定下載有限的產品集，這個選項會忽略該規格並且下載包含在產品版本中的所有產品。

    下載將會包含產生管理安裝點所需的所有檔案，而不只是執行單機安裝所需要的檔案。

只要安裝/只要產生安裝點。 我已經有需要的所有安裝檔。

SOLIDWORKS 安裝管理員不會下載任何檔案，而是使用所選目錄中的檔案。

按一下瀏覽來瀏覽至不同的位置。 例如，您可以瀏覽至安裝 DVD 或下載資料夾，只要該位置包含所有必要的檔案即可。

如果您接收到資料夾是不完整的錯誤訊息，但您認為所有的安裝檔案都應該在該位置時，可能的原因包括：
  • 您選擇了一個之前未下載的元件來安裝，或預設選擇安裝該元件。
  • 檔案下載至有不同系統需求的另一電腦上。
  • 您之前執行的是客戶端的安裝，但現在要產生一個需要較大檔案集的管理安裝點。

您可以瀏覽至包含所有檔案的資料夾 (例如 DVD)，或是選擇其中一個下載選項。

您要將要求的檔案下載至何處？

這是下載資料夾位置。

在某些情況下，這個選項雖然看得見，但是為停用狀態。 舉例來說，如果指定只要安裝，SOLIDWORKS 安裝管理員將會從該選項指定的目錄安裝任何下載的檔案，而不是使用另外的下載資料夾。

不論您是下載這些檔案或從您自己的位置來存取這些檔案，所有的檔案必須被下載至相同的下載資料夾中。

估計下載大小

不論這是新的下載或您繼續之前工作階段的下載，所估計的下載磁碟空間需求是根據列出的完整所選元件而定。

例如，如果您繼續之前的下載，SOLIDWORKS 安裝管理員將僅處理尚未下載的檔案。 下載的時間會少於估計的時間。

如果檔案在先前的下載中已經完成下載，其大小不會包含在此次估計當中。因此，估計的大小可能會高於實際的下載大小。

您要如何下載？

執行手動下載

在某些情況下，代理伺服器可能會禁止從 SOLIDWORKS 安裝管理員自動下載。

透過選擇此選項，您可以透過網頁手動下載檔案，然後在 SOLIDWORKS 安裝管理員中繼續完成安裝作業。此網頁是由 SOLIDWORKS 安裝管理員自訂，僅會下載完成安裝所需的檔案。

使用 SOLIDWORKS 背景下載程式

您可以使用 SOLIDWORKS 背景下載程式來完成此下載的操作或在提供未來的 SOLIDWORKS Service Pack 版本時，將其下載。

Solidworks 背景下載程式可於背景中自動偵測及下載新的 Service Pack 更新，並於下載完成檔案準備好可供安裝時通知您。 詳細資訊請參閱 SOLIDWORKS 背景下載程式。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


SOLIDWORKS 安裝管理員檔案的下載選項

您選擇要下載 SOLIDWORKS 安裝管理員較新的版本。 使用此螢幕來指定於何處及如何下載。

關於下載資料夾問題的答案，請參閱SOLIDWORKS 安裝管理員下載資料夾。

這個畫面只有在預設下載資料夾發生問題時才會出現（例如如果沒有寫入權限或網路存取權限）。一般而言，您只需指定替代下載目錄即可繼續。

下載目錄

瀏覽至 SOLIDWORKS 安裝管理員檔案的目的地。

下載大小以及需要的空間數量將會顯示。所需空間的量包括解壓縮某些下載所需的額外空間，這是比實際的下載大小更大。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


下載產品安裝檔案

為特定的產品指定於何處及如何下載遺失的檔案。

SOLIDWORKS 安裝管理員在下載的過程中，會平行處理所有檔案的下載、確認及擷取。

取消此螢幕會取消其餘的安裝順序。

如需取消安裝的影響及如何完成被中斷之安裝程序的說明，請參閱 安裝錯誤/安裝取消。

下載目錄

瀏覽至下載檔案的目的地。

會顯示下載大小及所需的空間。所需空間的量包括解壓縮某些下載所需的額外空間，這比實際的下載大小更大。

關於下載資料夾問題的答案，請參閱 SOLIDWORKS 安裝管理員下載資料夾。

上層主題 SOLIDWORKS 安裝管理員應用程式說明
安裝錯誤/安裝取消
SOLIDWORKS 安裝管理員下載資料夾


下載進度

SOLIDWORKS 安裝管理員在此過程中，會平行處理所有檔案的下載、確認及擷取。

要在下載開始之後取消下載，請按一下取消。

如果您取消下載或是下載失敗，下載取消或下載問題螢幕會指出哪些下載尚未完成，讓您繼續下載或關閉應用程式。

關於下載資料夾問題的答案，請參閱SOLIDWORKS 安裝管理員下載資料夾。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


下載結果

指出下載是否順利完成，在操作期間失敗或是已經取消。

下載問題/下載取消

如果您看見下載問題，表示安裝管理員遇到問題，使得下載無法完成。

如果您看見下載取消，表示您在下載完成前已經取消下載。

繼續：

重試/繼續自動下載 | 若要從您取消下載的時間點繼續自動下載，請選擇此選項然後按一下重試下載或繼續下載。
在 Web 瀏覽器中分別下載檔案 | 在某些情況下，代理伺服器可能會禁止從 SOLIDWORKS 安裝管理員自動下載。 | 透過選擇此選項，您可以透過網頁手動下載檔案，然後在 SOLIDWORKS 安裝管理員中繼續完成安裝作業。 此網頁是由 SOLIDWORKS 安裝管理員自訂，僅會下載完成安裝所需的檔案。

下載完成

如果您指定只要下載選項，當下載完成時，會出現下載完成畫面。

按一下完成結束 SOLIDWORKS 安裝管理員。

請勿嘗試手動安裝任何這些產品。 請一律使用 SOLIDWORKS 安裝管理員來安裝下載的檔案。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


安裝錯誤/安裝取消

安裝時發生錯誤或是已經取消。

如果錯誤或取消發生：
  • 在錯誤或取消之前安裝的產品會保留在電腦上。
  • 如果可能，取消時正在安裝的產品會被回溯，因此不會有部分的安裝。
  • 其餘產品未安裝或取消安裝。在尚未嘗試之下會出現一個清單。

    若要繼續安裝或取消安裝這些產品，請按一下提供的連結。

SOLIDWORKS 安裝管理員會先安裝尚未安裝在此電腦上的任何先決要件，例如 .NET Framework。

目錄

  • 復原失敗或取消的安裝

    如果在安裝期間發生錯誤或取消安裝，您可以透過重新執行安裝的方式從該點復原。

  • 修復安裝

    如果您安裝的 SOLIDWORKS 產品有問題，您可以使用 SOLIDWORKS 安裝管理員來修復安裝。

  • 聯絡 SOLIDWORKS 經銷商

    如果修改或修復安裝失敗，請聯絡您當地的 SOLIDWORKS 經銷商，並提供從畫面收集到的資訊。 可能會需要您提供 SOLIDWORKS 安裝管理員記錄檔的 zip 檔案。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


復原失敗或取消的安裝

如果在安裝期間發生錯誤或取消安裝，您可以透過重新執行安裝的方式從該點復原。

  1. 為失敗的安裝記錄下錯誤訊息及產品碼，這些會出現在安裝錯誤或安裝取消畫面中。
    如果軟體提示您提供來源檔案，且您不是修改現有的 SOLIDWORKS 安裝，安裝或電腦可能有所損壞。 請聯絡您的 SOLIDWORKS 經銷商。
  2. 重新啟動電腦。
  3. 若要確定沒有 SOLIDWORKS 產品正在 Windows 中執行，請按下 Ctr+Alt+Del 來開啟「工作管理員」。
  4. 在處理程序標籤中，如果在影像名稱之下有任何下列的處理程序，請選擇它們並按下結束處理程序。
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. 如果應用程式已被安裝，且您嘗試修改或移除它，請嘗試使用修復安裝。詳細資訊請參考修復安裝。
  6. 在 Windows 中，按一下開始 > 控制台 > 程式和功能。
  7. 選擇失敗的 SOLIDWORKS 版本。
    如果沒有您嘗試安裝之 SOLIDWORKS 版本的項目，請重複安裝程序。
  8. 執行下列操作之一︰
    • 要重新嘗試，請按一下變更，然後選擇所有安裝失敗或於安裝過程中跳過的產品。

    • 要略過失敗的安裝，按一下變更並選擇在安裝過程中跳過的所有產品。 清除安裝失敗的產品。

    • 要放棄安裝，請按一下移除並選擇任何已安裝的產品。
    這並不會回復到您所升級產品之前的版本。
上層主題 安裝錯誤/安裝取消
修復安裝
聯絡 SOLIDWORKS 經銷商


聯絡 SOLIDWORKS 經銷商

如果修改或修復安裝失敗，請聯絡您當地的 SOLIDWORKS 經銷商，並提供從畫面收集到的資訊。 可能會需要您提供 SOLIDWORKS 安裝管理員記錄檔的 zip 檔案。

  1. 找出記錄檔案。 針對 Windows：
    C:\Users\使用者名稱\AppData\Roaming\SOLIDWORKS\Installation Logs\安裝的版本\。
    如果您找不到資料夾，它可能是隱藏起來了。在檔案 Explorer 中，按一下工具 > 資料夾選項。在檢視標籤的進階設定之下，針對隱藏的檔案和資料夾選擇顯示隱藏的檔案、資料夾與磁碟機。
  2. 將此資料夾的整個內容 (包括子資料夾) 壓縮成 Zip 檔案。
上層主題 安裝錯誤/安裝取消
復原失敗或取消的安裝
修復安裝


安裝完成

SOLIDWORKS 安裝管理員已完成其處理。

可能會顯示其中一個或多個選項。

新增功能

對於單機安裝，當您完成安裝的過程時，會有一個描述 SOLIDWORKS 及其附加產品中之新功能的文件出現。

對於管理安裝點的安裝，當客戶端完成安裝時，文件會出現在客戶端電腦上。

參加 SOLIDWORKS 客戶經驗改進計劃

系統會將效能資訊送至 SOLIDWORKS Corporation 以幫助改進產品。此過程是透明和保密的。選擇以下之一︰
  • 是，我願意參加
  • 否，謝謝
  • 稍後再提醒我
詳細資訊請參考客戶經驗改進計劃網站。

管理安裝點的產生已完成

當您完成管理安裝點的產生時可以按一下自訂安裝點，以執行管理安裝點選項編輯器來自訂安裝點。

按一下顯示如何在一客戶端上安裝此安裝點。來顯示如何使用選項編輯器的說明。

如需有關使用選項編輯器設定管理安裝點的詳細資訊，請參閱 管理安裝點選項編輯器。

按一下自訂安裝點啟動管理安裝點選項編輯器，以為此管理安裝點自訂選項設定。
您之後可連按兩下 SOLIDWORKS Admin 資料夾中的 sldAdminOptionEditor.exe 來開啟「選項編輯器」。

目錄

  • 檢查 SOLIDWORKS 更新

    如果您在機器上有管理員權限，您可以使用 SOLIDWORKS 安裝管理員手動檢查更新，或是設定定期自動檢查更新。

  • SOLIDWORKS Customer Experience Improvement Program

    在安裝 SOLIDWORKS 時，可以指定要傳送效能資訊至 SOLIDWORKS Corporation 以協助改善產品。

上層主題 SOLIDWORKS 安裝管理員應用程式說明
管理安裝點選項編輯器


檢查 SOLIDWORKS 更新

如果您在機器上有管理員權限，您可以使用 SOLIDWORKS 安裝管理員手動檢查更新，或是設定定期自動檢查更新。

  1. 執行下列其中一項操作來啟動 SOLIDWORKS 安裝管理員：

    • 在 SOLIDWORKS 應用程式中，按一下說明 > 檢查更新。

    • 在 Windows 中，按一下開始 > 程式集 > SOLIDWORKS 安裝管理員 > 檢查更新。

    您也可以按一下開始 > SOLIDWORKS 安裝管理員 > SOLIDWORKS 背景下載程式。在 Windows 通知區域中，以滑鼠右鍵按一下 SOLIDWORKS 背景下載程式，然後按一下檢查更新。
    SOLIDWORKS 安裝管理員會告訴您是否有任何可用更新。
  2. 如果有可用的更新，選擇是否要下載並安裝它們。
  3. 若要啟用自動定期檢查更新，請在 SOLIDWORKS 安裝管理員完成處理時選擇每 __ 天檢查更新然後指定檢查頻率。
上層主題 安裝完成
SOLIDWORKS Customer Experience Improvement Program


SOLIDWORKS Customer Experience Improvement Program

在安裝 SOLIDWORKS 時，可以指定要傳送效能資訊至 SOLIDWORKS Corporation 以協助改善產品。

SOLIDWORKS 會使用這些資訊來決定產品使用及品質的相關趨勢。 我們的目標是提供最高品質的產品，效能記錄檔是在此過程中相當有用的工具。

此過程是透明不可見的。包含在記錄檔中所有的資訊都是保密的。資訊不會用於其他的目的，且沒有人會與您聯絡。

詳細資訊請參閱客戶經驗改進計劃網站。

上層主題 安裝完成
檢查 SOLIDWORKS 更新


安裝位置

對於管理安裝點產生以外的安裝，以下選項將適用：
安裝所選產品至： | 此為您安裝 SOLIDWORKS 的目錄位置。 在升級或修改安裝時，必須將所有檔案安裝至該安裝的現有位置。在此狀況下，您無法變更現有 SOLIDWORKS 安裝的位置。
估計安裝所需的磁碟空間 | 此為安裝或修改所選產品所需的額外空間。 | 請確認正在安裝產品的磁碟有足夠的可用空間可支援安裝需求。
安裝來源 | 此為您安裝 SOLIDWORKS 的來源目錄位置。 只有在已指定只要安裝選項時，這個選項才會出現。如需詳細資訊，請參閱下載選項。
在變更 SOLIDWORKS 安裝位置之前，請向您的系統管理員詢問。

管理安裝點位置

在產生管理安裝點時，這些選項適用：
新的安裝點位置 | 此為 SOLIDWORKS 安裝管理員產生新安裝點的目錄位置。 | 這個位置不能夠包含現有的管理安裝點。
估計產生安裝點所需的磁碟空間 | 此為管理安裝點所需的額外空間。 | 請確認正在安裝產品的磁碟有足夠的可用空間可支援安裝點需求。
產生安裝點來源 | 此為您安裝 SOLIDWORKS 產品的目錄位置。 只有在已指定只要安裝選項時，這個選項才會出現。如需詳細資訊，請參閱下載選項。
現有安裝點的位置 | 在升級現有的管理安裝點時，SOLIDWORKS 安裝管理員會根據該現有安裝點的設定產生新的安裝點。此現有安裝點未修改。這樣會顯示您在歡迎畫面中指定的原始安裝點的位置。

避免使用版本特定的目錄路徑

如果您在安裝目錄位置 (例如 C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2023\) 中指定版本號碼，接著將該安裝升級至 SOLIDWORKS 2024，則您會有 SOLIDWORKS 2024 安裝目錄，標示為 SOLIDWORKS 2023。

上層主題 SOLIDWORKS 安裝管理員應用程式說明
下載選項


升級選項

此電腦上安裝了一個或多個較舊的 SOLIDWORKS 版本。 您可以產生新的安裝項目，其會與較舊版本共存，或者您可以升級，升級則會移除較舊的版本。

產生一個 SOLIDWORKS 版本的新安裝。

如果您選擇產生新的安裝項目，您可以選擇要安裝的 SOLIDWORKS 產品。

系統會為各個所選擇的產品，產生此主要版本的新安裝項目。 較舊的主要版本會留在機器上，但 SOLIDWORKS Electrical 和 SOLIDWORKS PDM 客戶端除外。

如果您清除某個產品，就不會安裝新版本。

如果您在安裝新版本之後仍然希望可以存取較舊版本的 SOLIDWORKS，產生新的安裝是比較適合的作法。 例如，如果您與仍然在執行舊版 SolidWorks 的其他使用者共用檔案，就可以避免使用較新的版本儲存檔案時的版本不相容性。

將 SOLIDWORKS previous_major_version 升級為 SOLIDWORKS current_major_version。

如果您選擇要升級，您可以選擇要升級的 SOLIDWORKS 產品。 系統會為各個所選擇的產品產生新安裝項目，並移除較舊的版本。

如果您清除某個產品，則不會安裝新版本，而且較舊的版本會留在機器上。

SOLIDWORKS Electrical 和 SOLIDWORKS PDM Client 考量事項

您只能在一台機器上安裝一個版本的 SOLIDWORKS Electrical。 如果您正在產生新 SOLIDWORKS 安裝項目，並且選擇 SOLIDWORKS Electrical 作為其中一個要安裝的產品，系統便會移除舊版的 SOLIDWORKS Electrical。

安裝新版本前，請先備份現有的 SOLIDWORKS Electrical 環境。 在 SOLIDWORKS Electrical Schematic 內選擇檔案建立環境記錄檔，或者在 SOLIDWORKS Electrical 3D 內選擇SOLIDWORKS Electrical > 工具 > 建立環境記錄檔。

SOLIDWORKS PDM Client 的主要版本必須與 SOLIDWORKS PDM Server 的主要版本相符。 如果您不打算升級 SOLIDWORKS PDM Server，請勿選擇 SOLIDWORKS PDM Client 進行升級。

若要在 Windows 中移除產品，請使用新增/移除程式。詳細資訊請參閱 移除安裝。
上層主題 SOLIDWORKS 安裝管理員應用程式說明
移除安裝


安裝進度

此螢幕顯示安裝的進度。

要在安裝開始之後取消安裝，請按一下取消。

如需取消安裝的影響及如何完成被中斷之安裝程序的說明，請參閱安裝錯誤。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


安裝類型

您可以指定想要執行的安裝作業。 例如產生新的安裝、修改或修復現有安裝、產生管理安裝點、安裝管理伺服器產品，或下載檔案，讓您可以在其他電腦上共用和安裝它們。

若最新版本的 SOLIDWORKS 軟體已經安裝在您的電腦上，您可以選擇要修改或修復它。

單機型

在此電腦上安裝 SOLIDWORKS 產品。

只有此電腦上未安裝這個版本時，這個選項才會出現。

修改單機安裝

修改此電腦上現有的 SOLIDWORKS 安裝

只有當這個版本已安裝在此電腦上時，這個選項才會出現。
修改包括：
  • 新增或移除 SOLIDWORKS 產品元件
  • 變更至不同的 SOLIDWORKS 套裝軟體 (例如 SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS Ultimate 等)
  • 變更 SOLIDWORKS 序號設定
    如果您在先前的安裝期間已經指定一個 SOLIDWORKS 序號，SOLIDWORKS 安裝管理員可能不會重新提示。若要變更序號，您必須選擇此選項。

修復單機安裝

修復此電腦上現有的 SOLIDWORKS 安裝。

只有當這個版本已安裝在此電腦上時，這個選項才會出現。
修復會確認所有的檔案都存在且被適當的登錄，並修復任何發現的問題。 您所產生的資料不會受影響。
  • 要修復一個產品，請確定有將其選取。
  • 清除您所不要修復產品的核取方塊。
您可以修復一個單機安裝。您無法修復一個管理安裝點的安裝；您必須使用管理安裝點再次安裝。

管理安裝點

產生或更新管理安裝點，以便部署至多台電腦。

如需關於在多個客戶端上使用管理安裝點安裝 SOLIDWORKS 的詳細資訊，請參閱使用管理安裝點。

產生或更新管理安裝點時：
  • 您可以使用現有安裝點中的安裝設定來設定新的或更新的安裝點，或者您可以使用預設的 SOLIDWORKS 安裝設定。
  • 如果您更新現有的安裝點：
    • 即使您正在更新，SOLIDWORKS 安裝管理員仍然會產生一個新的安裝點副本。 原始的安裝點不會修改。
    • 您可以使用正在更新的現有安裝點中的檔案產生更新的安裝點。這樣會產生較小的下載。
    如果您沒有指定 Service Pack 版本可以用來更新先前安裝點的安裝點，您無法利用較小下載的優點。

伺服器產品

SOLIDWORKS 伺服器產品包括 SOLIDWORKS Electrical、SOLIDWORKS PDM 和 SolidNetWork License Manager。

若是 SOLIDWORKS Electrical 和 SOLIDWORKS PDM，您可以選擇在同一台電腦上，或在不同的電腦上安裝客戶端和伺服器工具。

如需有關安裝這些伺服器的詳細資訊，請參閱說明中相對應的主題。

下載並共用所有檔案

下載所選的 SOLIDWORKS 產品的安裝檔案而不安裝產品。

如果您是從 DVD 安裝，這個選項將不會出現。
下載檔案的內容跟 SOLIDWORKS 安裝 DVD 可取得的檔案內容相同。 選擇此選項下載完整的安裝檔案集，不論您的電腦上已經安裝什麼檔案。 您接著可以複製到可攜式裝置或網路目錄，然後使用它們在其他電腦上安裝 SOLIDWORKS 軟體。 您也可以使用此方法來設定一個伺服器，讓您的使用者可以從伺服器執行安裝。
這與產生一個管理安裝點的方法不同。
上層主題 SOLIDWORKS 安裝管理員應用程式說明
使用管理安裝點
使用 SolidNetWork License Manager 來管理使用許可
SOLIDWORKS Electrical


安裝及管理多台電腦

SOLIDWORKS 安裝管理員提供下列安裝與管理多個 SOLIDWORKS 電腦的工具。

SOLIDWORKS 管理安裝點

如果您在多台電腦上安裝 SOLIDWORKS，您可以產生一個管理安裝點，然後將應用程式部署到其他電腦上。

SOLIDWORKS PDM

SOLIDWORKS PDM 是建立在與 SOLIDWORKS Enterprise PDM 相同架構的文件管理產品。 它提供兩種版本： Standard 及 Professional。 SOLIDWORKS PDM 會使用 Microsoft SQL Server 資料庫來管理檔案資料保險箱。

SolidNetWork License Manager

SolidNetWork License Manager 透過浮動使用許可，允許使用者的數目超過使用許可的數目。 當客戶端使用許可不在使用中時，其他的 SOLIDWORKS 使用者可使用此使用許可。

您也可以使用 SolidNetWork License Manager 來分配 SOLIDWORKS 核心附加產品 (例如 FeatureWorks) 的使用許可。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


手動下載

您已經選擇手動下載檔案 (或者可能是您上次執行 SOLIDWORKS 安裝管理員時已經選擇手動下載)。

按一下連結以開啟自動產生的網頁，其中包含完成下載所需的完整檔案清單。

您必須下載至摘要頁中指定的資料夾。安裝必須等到所有檔案下載至該資料夾之後才會開始。

一旦您完成手動下截，請按下一步繼續。

如果您想要自動下載，可以返回摘要頁並變更下載選項以變更選項。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


有較新的版本可用

安裝管理員偵測到有較新版本的 SOLIDWORKS 產品。 您可以選擇安裝包含在原始安裝 DVD 中的版本或下載，或您可以選擇下載及安裝較新的版本。

如果您從下載中安裝

選擇下列其中一項：
  • 繼續安裝 版本。

    選擇此選項來繼續安裝包含在初始下載中的版本。

  • 下載及安裝新的版本： 版本。

    選擇此選項來下載及安裝新的版本。 如果有多個新版本可用，您可以選擇要下載及安裝的版本。

如果您從 DVD 中安裝

在您是否要使用較新的版本？之下，選擇其中一個選項：
  • 否，繼續從此 DVD 安裝 版本。 您可以稍後更新。

    選擇此選項來使用目前的安裝管理員繼續安裝。

    在安裝完成之後，您可以使用安裝管理員來檢查及安裝更新。 若要檢查是否有更新，請執行開始 > SOLIDWORKS 安裝管理員 > 檢查更新。
    您必須擁有該機器的管理權限，才能使用檢查更新。

    此種方法的好處是會產生較小的下載。 缺點是這是一個兩步驟的程序，而且您下載的檔案為該版本專有 (無法與使用不同版本的其他使用者共用)。

  • 是，使用此 DVD 執行安裝，然後下載並更新至版本。

    選擇此選項來下載及執行較新版本的安裝管理員，以安裝該版本的 SOLIDWORKS 產品。

    如果有小的 Service Pack 版本可更新 DVD 版本，安裝管理員會從 DVD 安裝原始版本，然後套用 Service Pack 更新。 這樣會產生較小的下載。

    選擇從 DVD 繼續安裝的選項，然後在日後套用更新，同樣能達成相同結果。

    這個選項的優點是它只有一個步驟的過程。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


沒有新的版本可用

沒有較新的版本可供下載。繼續安裝指定的版本。

要繼續安裝，按一下下一步。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


偵測到的程序

SOLIDWORKS 安裝管理員在這台電腦上偵測到可能會使安裝失敗的程序。

  • 要繼續安裝，請執行下列操作之一：
    • 關閉這些程序（例如使用 Microsoft Windows 工作管理員），然後按重試。
    • 按一下忽略繼續而不關閉程序。
  • 若要停止安裝，請按取消。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


產品選擇

指定要安裝、修改、下載或移除的產品元件。

在產品清單中：
  • 產品清單是產品的完整清單，可在產品清單上方指定的套裝軟體中取得。
  • 若要檢視對特定元件的動作，請按一下元件名稱（但不是核取方塊）。 預定安裝動作會出現在產品清單下方的資訊欄位中。
  • 您可以按一下產品元件旁邊的核取方塊以變更該元件的安裝目錄。 （例如，如果您要安裝或移除元件，選擇核取方塊則指定安裝或移除元件，清除核取方塊則指定不安裝或移除元件。）
  • 如果您執行的是修改安裝，當您在產品選擇中進行任何變更時，在元件的左邊會出現一個星號 (*)。
  • 如果元件具有可選用的安裝子元件，元件旁會顯示 + 圖示。 若要查看元件有哪些子元件可用，請按一下 + 圖示。
  • 如果元件已經展開，顯示可選用的子元件，則元件旁會出現 - 圖示。 若要摺疊子元件清單，請按一下 - 圖示。

如果您正在套用 Service Pack，則無法選擇出現在 SOLIDWORKS 底下的 SOLIDWORKS 功能 (例如 FeatureWorks)。 這是因為執行此類型的升級時，您無法新增或移除功能。

SOLIDWORKS 安裝管理員所執行的動作是由一組產品共存規則所控制。詳細資訊請參閱 產品共存規則。

根據預設，SOLIDWORKS 安裝管理員會選擇這些產品元件：
  • 如果您執行的是升級或 Service Pack 更新，SOLIDWORKS 安裝管理員會選擇目前已安裝的產品。
  • 否則，SOLIDWORKS 安裝管理員會選擇您有資格安裝的所有產品。
要減少您安裝或下載的時間及所需的磁碟空間，請展開產品元件並清除不需要之元件的核取方塊。

如果 SOLIDWORKS 安裝管理員無法確認您有資格安裝的產品，您可以按一下選擇不同的套件或產品來變更要安裝或修改的產品套件 (例如 SOLIDWORKS Professional、SOLIDWORKS Premium 或 SOLIDWORKS Ultimate) 清單。SOLIDWORKS 安裝管理員列出您安裝媒體中與所選套件相容的所有 SOLIDWORKS 產品。您可以選擇已購買或是有資格評估的任何產品。

SOLIDWORKS 搜尋

SOLIDWORKS 搜尋提供對 SOLIDWORKS 文件強大的全文搜尋。搜尋顯示預覽及檔案位置與名稱。

在安裝之後，SOLIDWORKS 搜尋會編制 SOLIDWORKS 文件的索引以提供更快的搜尋。 預設僅編制 SOLIDWORKS 檔案的索引。

支援的語言

展開 SOLIDWORKS 產品及語言元件來查看您可以安裝的語言。

語言的指定僅會限制為 SOLIDWORKS 產品安裝的語言。其他的產品不受此指定的影響。例如，eDrawings® 與 SOLIDWORKS PDM 會安裝所有語言。

所需空間

SOLIDWORKS 安裝管理員會於頁面的下方報告總安裝大小或總下載的大小。

  • 如果您選擇只要下載選項，螢幕上會出現下載大小。下載大小是所有下載檔案所需磁碟空間的總量 (不包括在下載完成之後解壓縮檔案所需要的額外空間)。數字只是一個估計值。
    安裝所需要的所有檔案會被包括在總下載大小中。如果某些檔案已下載至目前的下載資料夾中，便不會再下載。因此，您實際的下載大小可能小於所示的整體下載大小，或您可能不需要下載讓何檔案。
  • 否則，安裝大小會出現。 安裝大小是當您完成此安裝時，會發生的磁碟空間使用量的變化。 由於檔案的壓縮，這些數字只是估計值。

    如果您升級或移除一現有的安裝，安裝的大小將會是零。

    所示的數字不包括任何下載或解壓縮所需要的空間（如果需要安裝的話）。

    如果需要下載，且您要下載至相同的磁碟中，實際的磁碟空間需求可以遠大於所示的安裝大小。

    要減少未來修改的下載或安裝時間，請於安裝之後不要刪除下載的檔案。 隨後的升級及修補程式通常需要存取最後完整的安裝檔案集。

上層主題 SOLIDWORKS 安裝管理員應用程式說明
產品共存規則


下載的產品

選擇要下載至特定位置的 SOLIDWORKS 產品。

可供下載的產品是根據您提供的序號而定：

  • 為每個元件執行的動作出現在每個項目的右側。
  • 如果元件已選擇安裝子元件，元件旁會出現 + 圖示。 要查看元件可用的子元件，請按一下 + 圖示。
  • 如果已展開元件來顯示選擇的子元件，元件旁會出現 - 圖示。 要摺疊子元件清單，請按一下 - 圖示。
  • 按一下每個元件左側的核取方塊來選擇 SOLIDWORKS 安裝管理員應處理該元件的方式。
除非您另有指定，否則 SOLIDWORKS 安裝管理員會下載所有您有資格使用的產品。要減少您下載的時間及需要的磁碟空間，請展開產品元件並選擇您不需要的元件。

如果 SOLIDWORKS 安裝管理員無法確定您是否有資格使用的產品為何，您可以選擇下載 SOLIDWORKS 套件。 SOLIDWORKS 安裝管理員會列出與您所選套件相容的所有 SOLIDWORKS 產品。

如果 SOLIDWORKS 安裝管理員無法確認您有資格安裝的產品，您可以按一下選擇不同的套件或產品來變更要安裝或修改的產品套件 (例如 SOLIDWORKS Professional、SOLIDWORKS Premium 或 SOLIDWORKS Ultimate) 清單。SOLIDWORKS 安裝管理員列出您安裝媒體中與所選套件相容的所有 SOLIDWORKS 產品。您可以選擇已購買或是有資格評估的任何產品。

支援的語言

語言的指定只會限制為 SOLIDWORKS 產品安裝的語言。 其他的產品不受此指定的影響。 例如，eDrawings® 會安裝所有語言。

所需空間

根據您選擇的產品，會顯示執行下載所需的空間。下載大小是所有下載檔案所需磁碟空間的總量（不包括在下載完成之後解壓縮所需要的額外空間）。數字只是一個估計值。

要減少未來升級及修補程式的下載或安裝時間，請於安裝之後不要刪除下載的檔案。隨後的升級及修補程式通常需要存取最後完整的安裝檔案集。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


要修復的產品

指定修復此安裝時，此螢幕會顯示此版本的 SOLIDWORKS 安裝管理員能夠修復的 SOLIDWORKS 產品以及版本號碼。

修復會確認所有的檔案都存在且被適當的登錄，並修復任何發現的問題。您所產生的資料不會受影響。
  • 要修復一個產品，請確定有將其選取。
  • 清除您所不要修復產品的核取方塊。

按一下修復開始修復所選的產品。

您可以修復一個單機安裝。您無法修復一個管理安裝點的安裝；您必須重新安裝管理安裝點。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


序號

序號會將您的電腦與您所購買的 SOLIDWORKS 產品建立關聯。

如果 SOLIDWORKS 產品已安裝在您的電腦上，預設會顯示其序號：
  • 如果序號沒有顯示，請輸入您的 SOLIDWORKS 序號。
  • 若您擁有 SOLIDWORKS 使用許可不包含的產品之序號，請在適當的欄位輸入這些序號。

如果您有網際網路連線，在您後續的安裝過程中，您提供的序號可決定您有資格安裝的產品。

因為有許多種方式可以購買 SOLIDWORKS 產品，某些序號可能適用於兩種或多種產品。 例如，SOLIDWORKS 序號可讓您安裝 SOLIDWORKS Simulation 而不需輸入個別的 SOLIDWORKS Simulation 序號。 此外，有些產品並不需要序號。 如果您對於序號有任何問題，請聯絡您的 VAR。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


伺服器安裝

會列出您嘗試安裝的伺服器產品，並有安裝的結果。

伺服器安裝狀態

伺服器產品安裝是由外部安裝應用程式所執行。如果您沒有在該應用程式中，您必須切換至該應用程式以完成安裝。

按一下取消以停止伺服器產品安裝。

伺服器安裝完成

外部安裝應用程式已經成功完成。

按一下 完成 或 下一步。
  • 如果您安裝的是其他的管理產品 (例如 SOLIDWORKS 管理安裝點)，則該安裝會繼續。
  • 如果伺服器產品安裝是唯一的安裝作業，SOLIDWORKS 安裝管理員將會關閉。

伺服器安裝已取消或失敗

如果伺服器產品安裝失敗或是在安裝開始後被取消，會列出未被安裝的伺服器。

按一下 關閉 或 下一步。
  • 如果您指定了其他管理產品安裝，SOLIDWORKS 安裝管理員將會繼續。
  • 如果伺服器產品安裝是唯一的安裝作業，SOLIDWORKS 安裝管理員將會關閉。

詳細資訊

如需安裝、設定和使用 SolidNetWork License Manager 的詳細資訊，請參閱 使用 SolidNetWork License Manager 來管理使用許可。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


摘要

SOLIDWORKS 安裝管理員擁有完成安裝作業所需的所有資訊。

要繼續： | 按一下現在動作以初始化安裝作業 (例如馬上安裝、現在產生、現在下載、現在修改)。
變更安裝的設定︰ | 在您要變更的部分按一下變更 [image] (例如產品、安裝位置、Toolbox 選項)。
要取消： | 按一下取消以結束 SOLIDWORKS 安裝管理員而不變更安裝元件。
回復上一頁： | 按一下上一步返回 SOLIDWORKS 安裝管理員的上一頁。
有關特別安裝選項集的資訊 (例如，產品、安裝位置、Toolbox 選項等)：
  1. 按一下所需資訊部分旁邊的變更 [image] 。
  2. 在出現的詳細資料頁面中，按一下說明以取得有關這些安裝選項設定的資訊。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


系統檢查警告

系統檢查所報告的問題會影響您繼續安裝的方式。 在多數的情況下，您應該能夠繼續使用 SOLIDWORKS 安裝管理員。

您在此階段可能遇到的警告列於下面，同時列出了如何繼續操作的建議。

序號驗證問題

安裝管理員無法檢查是否有新的版本，因為其無法驗證您的序號。 如果您已連接並輸入有效的序號，這可能表示我們的伺服器暫時有問題。 請稍後再試。

序號驗證：安裝管理員無法驗證您的序號來確定您有權安裝哪些產品。您仍然能夠選擇要安裝的產品，但無法下載任何安裝檔案。您需要下載一套完整的來源檔案或提供 DVD 以供安裝。

解析度(R):
  • 檢查 internet 連線。序號檢查需要有效的 internet 連線。
  • 檢查您輸入的序號是否對您要安裝的產品有效。
  • 有些安裝要求您在版本發行時具備有效的訂閱。 如需詳細資訊，請洽詢您的 SOLIDWORKS 經銷商。
  • 大多數情況下，如果從 DVD 或之前下載的檔案集安裝，您可以繼續安裝。

有較新的版本可用

有較新的版本可用

有新的版本可用

此產品有一個較新的版本可供下載。

解析度(R): 執行「檢查更新」作業時，安裝可能會提示您從 SOLIDWORKS 下載並安裝更新的版本。 您可以使用起始指定的版本繼續此作業，或者下載較新的版本，並使用該版本繼續作業。

有最新版本可用

這是可用的最新版本。按一下「下一步」來繼續。

沒有可用的新下載

解決辦法：此訊息在您於安裝或修改期間檢查更新時可能會出現。它表示您目前正在安裝（或已安裝）可用的最新版本。

Internet 連線問題

Internet 連線： 安裝管理員無法連接至 SOLIDWORKS 伺服器來判斷您有權安裝哪些產品。 您仍然能夠選擇要安裝的產品，但無法下載任何安裝檔案。 您必須以 DVD 提供來源檔案或之前下載的檔案集。

無法檢查是否有新的版本

安裝管理員無法檢查是否有新的版本因為其無法與伺服器連線。

解決辦法：
  • 檢查 internet 連線。
  • 如果從 DVD 或之前下載的檔案集安裝，您可以繼續安裝。

上層主題 SOLIDWORKS 安裝管理員應用程式說明


異型孔精靈/Toolbox 選項

如果您安裝 SOLIDWORKS Toolbox，SOLIDWORKS 會包括鑽孔類型與五金器具的標準資料庫。

如需有關設定、延伸與使用 SOLIDWORKS Toolbox 的詳細資訊，請在 SOLIDWORKS 中按一下說明，參閱 Toolbox 一節。

在使用 SOLIDWORKS Toolbox 之前，請確定已經根據貴公司政策或群組原則將其正確設定。在許多情況下，Toolbox 將由一個群組進行設定與維護。請向 SOLIDWORKS 管理員尋求協助，了解如何在 SOLIDWORKS 安裝期間指定 Toolbox。

您可以在安裝之後變更所選的 SOLIDWORKS Toolbox。 在 SOLIDWORKS 中，按一下工具 > 選項。在系統選項標籤上，按一下異形孔精靈/Toolbox。

以下幾節將說明您在此畫面的所有模型組態中，會遇到的所有選項。您能看見的實際 Toolbox 選項需視此電腦上預先存在的 SOLIDWORKS 和 Toolbox 模型組態，以及您指定至此點的 SOLIDWORKS 安全管理員選擇而定。

產生一個新的新版本 Toolbox

在此電腦上產生一個新的 SOLIDWORKS Toolbox 版本。

當您產生一個新版本時，請在「產品選擇」畫面中展開 SOLIDWORKS > SOLIDWORKS Toolbox 並選取要支援 Toolbox 的標準。 依預設會選取所有的標準。

此電腦中任何現有的 Toolboxe 都不會修改。

參考或升級現有的 Toolbox

使用現有的 Toolbox。 按一下瀏覽以指定想要和此安裝一起使用的 Toolbox 位置。

  • 如果已經為先前的 SOLIDWORKS 主要發行版本設定 Toolbox，則會升級至此版本。 對於該 Toolbox 所做的任何自訂會保留在升級的 Toolbox 中。
    升級 Toolbox 至新的 SOLIDWORKS 主要發行版本時，會使 Toolbox 與執行前一個主要發行 SOLIDWORKS 版本的電腦無法相容。
  • 如果已經為此 SOLIDWORKS 版本設定 Toolbox (如果您指定了已經升級的共用網路 Toolbox，就會出現此情況)，則不會升級至該 Toolbox。
  • 如果您升級在 SOLIDWORKS PDM 環境中的 Toolbox，需要額外的程序。詳細資訊請參閱 關於組態 SOLIDWORKS Toolbox 的注意事項。

這個選項會出現在所有安裝狀況中，但是產生管理安裝點時不會出現。

升級舊版本 Toolbox

將為先前主要發行版本所組態的 Toolbox 複製到新的位置，並且將該副本升級為此版本。

如果此電腦中已經安裝先前的 SOLIDWORKS 主要發行版本，但是您選擇不要將該安裝升級至此版本，這個選項就會出現。
這個選項的目的是為了將先前已經安裝的主要 SOLIDWORKS 版本升級 Toolbox，但是不要影響使用較舊 Toolbox 版本的使用者。

如果您升級在 SOLIDWORKS PDM 環境中的 Toolbox，需要額外的程序。詳細資訊請參閱 關於組態 SOLIDWORKS Toolbox 的注意事項。

升級此安裝的舊版本 Toolbox

升級此 Toolbox 至較新的版本。
升級 Toolbox 至新的 SOLIDWORKS 主要發行版本時，會使 Toolbox 與執行前一個主要發行 SOLIDWORKS 版本的電腦無法相容。

如果您將先前的 SOLIDWORKS 主要發行版本升級為此版本，而在此電腦上發現已為該版本設定的 Toolbox，這個選項就會出現。

如果您升級在 SOLIDWORKS PDM 環境中的 Toolbox，需要額外的程序。詳細資訊請參閱 關於組態 SOLIDWORKS Toolbox 的注意事項。

使用已安裝的目前版本 Toolbox

SOLIDWORKS 安裝管理員在此電腦上偵測到為此 SOLIDWORKS 主要發行版本設定的 Toolbox。

如果您選擇這個選項，SOLIDWORKS 將會使用此 Toolbox。 不會發生升級。

如果已經在此電腦上安裝先前的 SOLIDWORKS 主要發行版本，但是已經為此版本設定 Toolbox，這個選項就會出現。 如果在仍執行舊版 SOLIDWORKS 的電腦上產生共用 Toolbox，就可能會發生此情況。

為客戶端電腦指定 Toolbox 的位置

當客戶端從管理安裝點安裝時，將網路或目錄位置指定為預設的 Toolbox 位置。
如果在進行客戶端安裝時，位置包含了為先前的 SOLIDWORKS 主要發行版本設定的 Toolbox，SOLIDWORKS 安裝管理員便會將該 Toolbox 升級。

這個選項會在您產生新的管理安裝點時出現。

為客戶端電腦升級或使用於現有安裝點所參考的 Toolbox

使用您在更新現有管理安裝點時指定的 Toolbox 位置。
如果在進行客戶端安裝時，位置包含了為先前的 SOLIDWORKS 主要發行版本設定的 Toolbox，SOLIDWORKS 安裝管理員便會將該 Toolbox 升級。

為客戶端電腦所選擇的一個不同的 Toolbox 位置

指定一個與您在更新現有管理安裝點時指定的位置不同的 Toolbox 位置。
如果在進行客戶端安裝時，位置包含了為先前的 SOLIDWORKS 主要發行版本設定的 Toolbox，SOLIDWORKS 安裝管理員便會將該 Toolbox 升級。

目錄

  • 關於組態 SOLIDWORKS Toolbox 的注意事項

    SOLIDWORKS Toolbox 是一個強大又複雜的功能。本主題列舉了一些在使用 SOLIDWORKS 安裝管理員設定 Toolbox 之前，應該考量的概念。

  • UNC 格式

    標準 (或通用) 命名慣例格式可指定檔案名稱語法格式以描述共用檔案位置。

上層主題 SOLIDWORKS 安裝管理員應用程式說明
關於組態 SOLIDWORKS Toolbox 的注意事項


關於組態 SOLIDWORKS Toolbox 的注意事項

SOLIDWORKS Toolbox 是一個強大又複雜的功能。本主題列舉了一些在使用 SOLIDWORKS 安裝管理員設定 Toolbox 之前，應該考量的概念。

尋找更多有關 SOLIDWORKS Toolbox 的資訊

如需有關設定、延伸與使用 SOLIDWORKS Toolbox 的詳細資訊，請在 SOLIDWORKS 中按一下 [image] 說明，參閱 Toolbox 一節。

使用共用的 Toolbox

當您安裝 Toolbox 時，可以讓 Toolbox 資料存放於您的本機電腦或是共用的網路位置中。 建議將 Toolbox 資料儲存於網路位置。 透過使用共同位置的方式，所有 SOLIDWORKS 使用者都會共用一組一致的扣件資訊。

如果這是第一次安裝，請瀏覽至您要安裝 Toolbox 的共用位置。

升級現有的 Toolbox

升級 Toolbox 至新的 SOLIDWORKS 主要發行版本時，會使 Toolbox 與執行前一個主要發行 SOLIDWORKS 版本的電腦無法相容。

如果其他電腦仍然維持使用前一個主要版本，而且繼續需要為該版本設定的 Toolbox，請製作該 Toolbox 的一份複本，然後升級該複本。新的 SOLIDWORKS 安裝會升級 Toolbox 的複本，而先前的 SOLIDWORKS 安裝會繼續使用舊的 Toolbox。

組態 Toolbox 的存取

安裝之後，存取 Toolbox 零組件時，SOLIDWORKS 就會檢查 Toolbox 模型組態，並提出改善存取與效能的建議。

如需存取共用的網路 Toolbox (建議)，請使用安裝共用 Toolbox 之伺服器的 UNC 路徑。詳細資訊請參閱 UNC 格式。

管理員可以為 Toolbox 建立一個密碼，並且為工作群組設定權限與喜好設定。限制模型組態的存取權限以及設定共同喜好設定可確保一致性的 Toolbox 資料。

在 SOLIDWORKS PDM 環境中升級 Toolbox

升級 SOLIDWORKS 軟體時，如果已加入零件，則會升級 Toolbox。 如果 Toolbox 根資料夾是在 SOLIDWORKS PDM 資料保險箱中，則在進行 SOLIDWORKS 升級之前，必須先對 Toolbox 資料夾做準備。

在執行升級的第一個系統中，您必須使用取得最新的版本來將 Toolbox 檔案下載至本機快取，並取出 Toolbox 資料庫檔案。 在要升級的其他系統中，僅需下載 Toolbox 檔案。

升級之前：
  • 確保最近完整備份了資料保險箱資料庫與保存檔。
  • 確保 Toolbox 零件未取出，或正由任何取出的組合件使用。

升級 Toolbox：

  1. 在檔案 Explorer 中，以擁有完整權限 (取出、存回、加入、刪除) 的使用者身份登入資料保險箱。
  2. 用右鍵按一下 Toolbox 資料夾，然後按一下取得最新的版本，將所有 Toolbox 檔案與 toolbox 資料庫複製到本機快取。
    如果您的保存檔伺服器為遠端伺服器，這可能需要花費幾分鐘的時間。
  3. 從 \Toolbox_folder_name\lang\your_lang 取出 Toolbox 資料庫檔案 (SWBrowser.mdb) 或 (swbrowser.sldedb)。
  4. 執行 SOLIDWORKS 安裝管理員，以執行升級。
  5. 在摘要畫面上，確保 Toolbox 選項安裝位置為資料保險箱中的位置。

    如果不是，請按一下變更，選擇 Reference or upgrade an existing Toolbox (參考或升級現有 Toolbox)，然後瀏覽至資料保險箱中的 Toolbox 位置。

  6. 完成升級時，在檔案 Explorer 中，存回 Toolbox 資料夾以將任何新檔案或更新的檔案加入至資料保險箱，以便其他使用者能夠使用 Toolbox。
  7. 若要升級，請導覽至資料保險箱中的 Toolbox 資料夾，並確保下列項目存在：
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      如果不是，請聯絡您的 Value Added Reseller。

  8. 將 SOLIDWORKS PDM 整合與 Toolbox 搭配使用的其餘電腦升級。
    1. 在檔案 Explorer 中，以至少擁有對 Toolbox 資料夾的讀取權限的使用者身份登入資料保險箱。
    2. 用右鍵按一下 Toolbox 資料夾，然後按一下取得最新的版本，將 Toolbox 檔案複製到本機快取。
    3. 執行 SOLIDWORKS 安裝管理員，以執行升級。

      安裝程式會偵測 Toolbox 是否已升級。

如需關於 SOLIDWORKS PDM 中 Toolbox 模型組態的詳細資訊，請參閱 SOLIDWORKS PDM 管理工具說明中的組態 Toolbox。

上層主題 異型孔精靈/Toolbox 選項
UNC 格式


UNC 格式

標準 (或通用) 命名慣例格式可指定檔案名稱語法格式以描述共用檔案位置。

\\伺服器\磁碟區\路徑

例如：

\\Disk_Server\SOLIDWORKS\AdminImage

上層主題 異型孔精靈/Toolbox 選項
關於組態 SOLIDWORKS Toolbox 的注意事項


解除安裝產品

當您從控制台中選擇移除或解除安裝程式時，螢幕會顯示可以由此版本 SOLIDWORKS 安裝管理員解除安裝的 SOLIDWORKS 產品 (包含版本編號)。 您可以選擇要執行標準、自訂或完整的解除安裝。

標準的解除安裝會移除 SOLIDWORKS 產品的程式檔案與資料夾。 根據預設，所選版本的所有 SOLIDWORKS 產品皆指定為標準的解除安裝。

自訂解除安裝會移除一或多個下列項次： 程式檔案及資料夾、登錄碼以及資料資料夾，例如 SOLIDWORKS Toolbox ，與來自原始下載位置的檔案與資料夾。

完整的解除安裝會移除安裝目錄、登錄碼以及資料資料夾。

解除一個產品的安裝：
  1. 在解除安裝的螢幕中，請確定選擇了該產品。

    如果您要解除所有產品的安裝， Solidworks 安裝管理員同時也會被解除安裝。

  2. 清除您不要移除的產品</Z1>。</Z2>

    如果您要保留任何產品，SOLIDWORKS 安裝管理員就不會被移除。

  3. 選擇要執行自訂或完整的解除安裝。
    1. 按一下進階選項中按一下變更。

      進階選項的螢幕出現。程式檔案及資料夾的選項被核取。

    2. 選擇一或多個選項來執行自訂的解除安裝，或選擇所有的選項來執行一個完整的解除安裝。
    3. 按一下回到摘要。
    4. 在摘要的螢幕中，展開進階選項來顯示解除安裝的方法與項目。
  4. 按一下移除項目。
按一下移除項目時，SOLIDWORKS 安裝管理員會立即開始移除產品。
上層主題 SOLIDWORKS 安裝管理員應用程式說明


安裝

SOLIDWORKS Connected 可根據您的角色為您有權使用的所有 3DEXPERIENCE 服務和應用程式提供存取權。

Licensing

3DEXPERIENCE Platform 使用記名使用者使用許可。 系統管理員授予您角色時，將會指派使用許可。 角色會決定您有權使用的 3DEXPERIENCE 服務和應用程式。 您可以在任何裝置上使用您的使用許可。 使用許可並未繫結至特定機器。

詳細資訊請參閱 DS 使用許可要點。

3DEXPERIENCE Launcher

首次安裝 SOLIDWORKS Connected 時，3DEXPERIENCE Platform 會提示您下載並安裝 3DEXPERIENCE Launcher。 Launcher 是一種協助 SOLIDWORKS Connected 等原始應用程式存取平台的背景服務。 Launcher 圖示 [image] 會在安裝後顯示於 Windows 系統匣中。

詳細資訊請參閱 3DEXPERIENCE Launcher。 存取 Dassault Systèmes 使用者協助功能需要 3DEXPERIENCE 認證。


SOLIDWORKS Visualize Boost

SOLIDWORKS Visualize Boost 是一個應用程式，可讓您將影像計算從執行 SOLIDWORKS Visualize Professional 的電腦分配至網路上的一或多部電腦。

您可於在背景進行影像計算時，在機器上執行其他工作，而且最終計算的影像會更快準備好。您可在單一機器上計算影像，或在執行 Visualize Boost 的多電腦叢集上計算影像。

SOLIDWORKS Visualize Professional 的每個有效訂閲都包含一套免費的 SOLIDWORKS Visualize Boost 使用許可。

效能的提升 (例如更快的影像計算時間) 取決於 Visualize Boost 電腦的能力。擁有更好 GPU 的機器將能提供更好的改善效果。


從單機使用許可升級為 SolidNetWork 使用許可

在 SOLIDWORKS 安裝管理員中指定 SolidNetWork 使用許可序號，電腦就可以從單機 SOLIDWORKS 使用許可升級為 SolidNetWork 使用許可。

如果電腦中並未安裝 SOLIDWORKS，當您在使用 SOLIDWORKS 安裝管理員進行安裝時，可以輸入 SolidNetWork 序號以指定 SolidNetWork 使用許可。

如果電腦中已經安裝 SOLIDWORKS，而且您正要從單機使用許可轉換為 SolidNetWork 使用許可，您可以在執行 SOLIDWORKS 安裝管理員時為客戶端電腦修改安裝並且指定 SolidNetWork 使用許可序號，以取代單機使用許可序號。詳細資訊請參閱修改安裝。
若您從管理安裝點來安裝 SOLIDWORKS，則無法使用修改選項。使用管理選項編輯器對管理安裝點進行變更、解除安裝客戶端，然後再重新執行安裝。


使用 Visualize Boost

若要啟用分散式影像計算，您必須在設定後將 SOLIDWORKS Visualize 連線至 Visualize Boost。

Boost 連線需要 SOLIDWORKS Visualize 中的協調器 IP 位址和 Boost 連接埠值。

請針對以下步驟保持 Visualize Boost 與 SOLIDWORKS Visualize 開啟。

將 SOLIDWORKS Visualize 連線至 Visualize Boost：

  1. 連按兩下桌面捷徑 [image] ，開啟 Visualize Boost。
  2. 連按兩下 Visualize Boost 中的協調器 IP 位址以將其複製到剪貼簿。
  3. 在 SOLIDWORKS Visualize 中，按一下工具 > 選項 > Boost 並按 CTRL+V 以貼上協調器 IP 位址。
  4. 重複步驟 2 和 3，將 Boost 連接埠從 Visualize Boost 複製到 SOLIDWORKS Visualize。
    在 Visualize Boost 與 SOLIDWORKS Visualize Boost 中指定的 Boost 連接埠必須相同。
    Boost 狀態控制項會顯示在 SOLIDWORKS Visualize 中。
  5. 按一下確定以關閉選項對話方塊。
  6. 若要連線到 Boost，請按一下 Boost 狀態控制項 [image] ，或在這些介面中中斷連線 [image] ：
    • 立即顯示
    • 影像計算精靈品質頁面
    • 工具 選項 Boost 標籤

如需有關 Boost 組態的詳細資料，請參閱 SOLIDWORKS Visualize Boost。


初始化新 SolidNetWork License 伺服器

若要初始化新 SolidNetWork License 伺服器：

  1. 安裝並開啟 SolidNetWork License Manager 伺服器後，請於出現啟動提示時按一下是。
  2. 在 SolidNetWork License 伺服器資訊對話方塊中，確認防火牆與連接埠，然後按一下下一步。
  3. 在產品啟動精靈中，選擇要啟動的序號，選擇手動經電子郵件作為啟動方法，然後輸入電子郵件聯絡資訊。

    手動方法需要您產生要求檔案，並透過電子郵件將其傳送至 activation@solidworks.com。當您收到內含授權回應檔案的電子郵件時，請解壓縮檔案，然後按一下開啟將其載入伺服器。

    您可以關閉並重新執行產品啟動精靈以開啟並載入回應檔案。

  4. 當訊息方塊通知您初始化成功時，請按一下確定，然後在產品啟動精靈中按一下完成。


手動啟動新 SolidNetWork License Manager 伺服器

初始化 SolidNetWork License Manager 伺服器之後，請開啟 SolidNetWork License Manager 伺服器，並產生第二個要求以完成啟動。

若要手動啟動新 SolidNetWork License Manager 伺服器：

  1. 執行下列之一：
    • 如果系統提示要求您啟動，按一下是。
    • 如果系統提示未出現，請在伺服器系統管理標籤中按一下修改。
    依預設，進階選項設定為使用啟動模式。
  2. 確認「SolidNetWork License 伺服器資訊」對話方塊中的防火牆與連接埠，然後按一下下一步。
  3. 在「產品啟動精靈」中，選擇要啟動的序號，輸入電子郵件聯絡資訊，然後選擇手動經電子郵件作為啟用方法。
  4. 請依照步驟產生要求檔案，並將其傳送至 activation@solidworks.com。當您收到使用許可回應檔案時，按一下開啟以載入檔案。
  5. 啟動完成時，按一下完成。


手動啟動升級的 SolidNetWork License Manager 伺服器

使用 SOLIDWORKS 安裝管理員升級 SolidNetWork License Manager 伺服器之後，開啟 SolidNetWork License Manager 伺服器。

若要手動啟動升級的 SolidNetWork License Manager 伺服器：

  1. 在伺服器系統管理標籤的使用許可資訊下，按一下重新啟動。
    如果您在解除安裝及升級 SolidNetWork License Manager 伺服器前停用使用許可，請改為在伺服器系統管理標籤中按一下修改。只有在伺服器上有已啟動的使用許可時，才能重新啟動。

    繼續執行步驟 3。

  2. 在重新啟動對話方塊中，選擇已安裝的序號以檢視其相關聯使用許可，然後按一下重新啟動。
  3. 確認SolidNetWork License 伺服器資訊對話方塊中的防火牆與連接埠，然後按一下下一步。
  4. 在「產品啟動精靈」中，選擇要啟動的序號，輸入電子郵件聯絡資訊，然後選擇手動經電子郵件作為啟用方法。
    手動啟動程序很簡單。產品啟動精靈中的指示會引導您完成程序。
  5. 啟動完成時，按一下完成。